Internode Topology Discovery and Communication
Optical applications on the NCS 1010 nodes must discover the OLT-OLT link topology. Span level applications must discover the adjacent nodes. Link level applications must learn the complete OLT-OLT link topology. NCS 1010 uses OSPF to discover the link topology and communicate topology information.
The networking devices running OSPF detect topological changes in the network, flood link-state updates to neighbors, and quickly converge on a new view of the topology. Each OSPF router in the network soon has the same topological view again.
Optical applications on NCS 1010 must discover the link topology, the different nodes and the node types, and the optical spectral band the nodes work on. NCS 1010 uses an enhanced version of OSPF that supports a new link-state advertisement attribute that advertises the node type and band.
Configure OSPF
The following commands are the necessary configurations for OSPF on an NCS 1010 OLT node.
configure
router ospf process-name
router-id router-id
distribute link-state
nsf
network point-to-point
redistribute connected
area area-id
interface Loopback1
interface GigabitEthernet0/0/0/0
The following commands are the necessary configurations for OSPF on an NCS 1010 ILA node.
configure
router ospf process-name
router-id router-id
distribute link-state
nsf
network point-to-point
redistribute connected
area area-id
interface Loopback1
interface GigabitEthernet0/0/0/0
interface GigabitEthernet0/0/0/2
Important |
You must configure router ID during OSPF configuration on NCS 1010 nodes. |
See Implementing OSPF, for a description of the concepts and tasks necessary to implement OSPF on Cisco IOS XR.
Configure OSPF cost
Feature Name |
Release Information |
Description |
---|---|---|
Configure OSPF cost |
Cisco IOS XR Release 7.11.1 |
To identify the best route, OSPF path computation uses the link cost. The system calculates the cost based on the available interface bandwidth. From this release onwards, you can set a user-defined cost value using the cost variable in the router ospf command. As a result, this feature enables you to set a specific route when there are two equal-cost routes to the same destination. |
Cost is the metric, you can use the cost command to explicitly specify the interface (network) for OSPF path calculation.
configure
router ospf process-name
router-id router-id
area area-id
interface Loopback1
interface GigabitEthernet0/0/0/0
cost cost
See cost (OSPF) for different command modes and usage guidelines to implement cost OSPF on Cisco IOS XR.
Note |
The cost of the link is inversely proportional to the bandwidth of the link. |
The following example shows a sample cost configuration.
P/0/RP0/CPU0:ios(config)#router ospf 1
RP/0/RP0/CPU0:ios(config-ospf)#area 0
RP/0/RP0/CPU0:ios(config-ospf-ar)#interface Loopback0
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#interface GigabitEthernet0/0/0/0
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#cost 20
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#commit