D Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter D.

dead-interval (OSPF virtual link)

To set the interval during which at least one hello packet must be received from a neighbor on an Open Shortest Path First (OSPF) virtual link before the router declares that neighbor as down, use the dead interval command. To restore the default, use the no form of this command.

dead-interval seconds

no dead-interval

 
Syntax Description

seconds

Interval (in seconds) during which the router must receive at least one hello packet from a neighbor or that neighbor is removed from the peer list and does not participate in routing. The range is from 1 to 65535. The value must be the same for all nodes on the virtual link.

 
Defaults

The default value for seconds is our times the interval set by the hello-interval command.

 
Command Modes

Virtual link configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the dead interval command in virtual link configuration mode to configure the dead interval advertised in OSPF hello packets. This value must be the same for all networking devices on the virtual link.

You can configure a shorter dead interval ( seconds) to detect a down neighbor faster and improve convergence. A shorter dead interval may lead to virtual link instability by incorrectly declaring a slow neighbor as down.

Use the show ip ospf virtual-links command to verify the dead interval.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the OSPF dead interval to 20 seconds:

switch(config)# ospf 201
switch(config-router)# area 99 virtual-link 192.0.2.4
switch(config-router-vlink)# dead-interval 20
 

 
Related Commands

Command
Description

hello-interval (OSPF virtual link)

Configures the Interval between hello packets that Cisco NX-OS sends on the virtual link.

show ip ospf virtual-link

Displays OSPF-related information for a virtual link.

dead-interval (OSPFv3 virtual link)

To set the interval during which at least one hello packet must be received from a neighbor on an Open Shortest Path First version 3 (OSPFv3) virtual link before the router declares that neighbor as down, use the dead interva l command. To restore the default, use the no form of this command.

dead-interval seconds

no dead-interval

 
Syntax Description

seconds

Interval (in seconds) during which the router must receive at least one hello packet from a neighbor or that neighbor is removed from the peer list and does not participate in routing. The range is from 1 to 65535. The value must be the same for all nodes on the virtual link.

 
Defaults

The default value for seconds is our times the interval set by the hello-interval command.

 
Command Modes

Virtual link configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the dead interval command in virtual link configuration mode to configure the dead interval advertised in OSPFv3 hello packets. This value must be the same for all networking devices on the virtual link.

You can configure a shorter dead interval ( seconds) to detect a down neighbor faster and improve convergence. A shorter dead interval may lead to virtual link instability by incorrectly declaring a slow neighbor as down.

Use the show ospfv3 virtual-links command to verify the dead interval.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the OSPFv3 dead interval to 20 seconds:

switch(config)# ospfv3 201
switch(config-router)# area 99 virtual-link 192.0.2.4
switch(config-router-vlink)# dead-interval 20
 

 
Related Commands

Command
Description

hello-interval (OSPFv3 virtual link)

Configures the interval between hello packets that Cisco NX-OS sends on the virtual link.

show ospfv3 virtual-link

Displays OSPFv3-related information for a virtual link.

default-information originate (EIGRP)

To generate a default route into the Enhanced Interior Gateway Routing Protocol (EIGRP), use the default-information originate command in the appropriate configuration mode. To disable this feature, use the no form of this command.

default-information originate [ always ] [ route-map map-name ]

no default-information originate

 
Syntax Description

always

(Optional) Generates the default route if the route is not in the EIGRP routing information base.

route-map map-name

(Optional) Generates the default route only if the route is permitted by the route map. The map name is an alphanumeric string of up to 63 characters.

 
Defaults

Disabled

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to originate a default route (0.0.0.0/0) to all routes that pass the Condition route map.

switch(config)# router eigrp 201
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-information originate route-map Condition
 

 
Related Commands

Command
Description

address-family

Enters address-family configuration mode.

default-metric

Sets the metric for routes redistributed into EIGRP.

redistribute

Redistributes routes from other routing protocols into EIGRP.

default-information originate (IS-IS)

To control the origination of a default route, use the default-information originate command.

default-information originate [ always ] [ route-map name ]

 
Syntax Description

always

(Optional) Specifies always to advertise the default route.

route-map name

(Optional) Specifies the name of the routing rules route map to announce default routes. The name can be up to 63 characters.

 
Defaults

The default route is not redistributed into the IS-IS routing domain.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

You can force a default route into an IS-IS routing domain. Whenever you specifically configure redistribution of routes into an IS-IS routing domain, by default, the default route is not redistributed into the IS-IS routing domain. The default-information originate route-map command generates a default route into IS-IS, which can be controlled by a route map. You can use the route map to identify the level into which the default route is to be announced, and you can specify other filtering options configurable under a route map. You can use a route map to conditionally advertise the default route, depending on the existence of another route in the routing table of the router.

Examples

This example shows how to always advertise the default route:

switch(config)# router isis TEST1
switch(config-router)# default-information originate always
switch(config-router)#
 

This example shows how to specify a route map to conditionally advertise the default route:

switch(config)# router isis TEST1
switch(config-router)# default-information originate route-map CORE1
switch(config-router)#

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.

default-information originate (OSPF)

To generate a default external route into an Open Shortest Path First (OSPF) routing domain, use the default-information originate command. To disable this feature, use the no form of this command.

default-information originate [ always ] [ route-map map-name ]

no default-information originate [ always ] [ route-map map-name ]

 
Syntax Description

always

(Optional) Specifies to always advertise the default route regardless of whether the route table has a default route.

route-map map-name

(Optional) Specifies to advertise the default route if the route map is satisfied. The map-name argument can be any alphanumeric string up to 63 characters.

 
Defaults

Advertises the default route if the route is in the route table.

 
Command Modes

Router configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the default-information originate command to assign a default route for redistributed routes. Whenever you use the redistribute command to redistribute routes into an OSPF routing domain, Cisco NX-OS automatically becomes an Autonomous System Boundary Router (ASBR). However, an ASBR does not, by default, generate a default route into the OSPF routing domain.

Use the route-map keyword to filter redistributed routes so that Cisco NX-OS generates a default route only for routes that pass the route map. Use the always keyword to generate the default route regardless of whether the default route is in the route table.

note.gif

Noteblank.gif The default-information originate command ignores match statements in the optional route map.


This command requires the Enterprise Services license.

Examples

This example shows how to configure the default route redistributed into the OSPF routing domain for the Enhanced Interior Gateway Protocol (EIGRP):

switch(config)# router ospf 109
switch(config-router)# redistribute eigrp 108 route-map EigrpPolicy
switch(config-router)# default-information originate always

 
Related Commands

Command
Description

redistribute (OSPF)

Redistributes routes from one routing domain into OSPF.

route-map

Defines a filter policy for routes.

default-information originate (OSPFv3)

To generate a default external route into an Open Shortest Path First version 3 (OSPFv3) routing domain, use the default-information originate command. To disable this feature, use the no form of this command.

default-information originate [ always ] [ route-map map-name ]

no default-information originate [ always ] [ route-map map-name ]

 
Syntax Description

always

(Optional) Specifies to always advertise the default route regardless of whether the route table has a default route.

route-map map-name

(Optional) Specifies to advertise the default route if the route map is satisfied. The map-name argument can be any alphanumeric string up to 63 characters.

 
Defaults

Advertises the default route if the route is in the route table.

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the default-information originate command to assign a default route for redistributed routes. Whenever you use the redistribute command to redistribute routes into an OSPFv3 routing domain, Cisco NX-OS automatically becomes an Autonomous System Boundary Router (ASBR). However, an ASBR does not, by default, generate a default route into the OSPFv3 routing domain.

Use the route-map keyword to filter redistributed routes so that Cisco NX-OS generates a default route only for routes that pass the route map. Use the always keyword to generate the default route regardless of whether the default route is in the route table.

note.gif

Noteblank.gif The default-information originate command ignores match statements in the optional route map.


This command requires the Enterprise Services license.

Examples

This example shows how to configure the default route redistributed into the OSPFv3 routing domain for the Border Gateway Protocol (BGP):

switch(config)# router ospfv3 109
switch(config-router)# redistribute bgp 108 route-map bgpPolicy
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# default-information originate always

 
Related Commands

Command
Description

redistribute (OSPFv3)

Redistributes routes from one routing domain into OSPFv3.

route-map

Defines a filter policy for routes.

default-information originate (RIP)

To generate a default route into the Routing Information Protocol (RIP), use the default-information originate command in router address-family configuration mode. To disable this feature, use the no form of this command.

default-information originate [ always ] [ route-map map-name ]

no default-information originate

 
Syntax Description

always

(Optional) Generates the default route if the route is not in the RIP routing information base.

route-map map-name

(Optional) Generates the default route only if the route is permitted by the route map. The map name is any alphanumerical string up to 63 characters.

 
Defaults

This command is disabled by default.

 
Command Modes

Router address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to originate a default route (0.0.0.0/0) to all routes that pass the Condition route map:

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-information originate route-map Condition
 

 
Related Commands

Command
Description

address-family

Enters address-family configuration mode.

default-metric

Sets the metric for routes redistributed into RIP.

redistribute

Redistributes routes from other routing protocols into RIP.

default isis passive-interface

To allow all Intermediate System-to-Intermediate System (IS-IS) interfaces to be set as passive by default, use the default isis passive-interface command.

default isis passive-interface {level-1 | level-1-2 | level-2}

 
Syntax Description

level-1

(Optional) Suppresses level-1 PDU.

level-1-2

(Optional) Suppresses level-1 and level-2 PDU.

level-2

(Optional) Suppresses level-2 PDU.

 
Defaults

None

 
Command Modes

Interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to allow all IS-IS interfaces to be set as passive by default:

switch# configure terminal
switch(config)# router isis 1
switch(config-router)# passive-interface default level-1
switch(config-router)# exit
switch# configure terminal
switch(config)# interface GigabitEthernet 0/0/0/
switch(config-if# isis passive-interface level-1
switch(config-if)# no isis passive-interface level-1
switch(config-if)# default isis passive-interface level-1
switch(config-if#

 
Related Commands

Command
Description

isis passive-interface

Blocks sending of routing updates on an IS-IS interface.

no isis passive-interface

Re-enables sending of routing updates on an IS-IS interface and activates only those interfaces that need adjacencies.

default-metric (EIGRP)

To set metrics for an Enhanced Interior Gateway Routing Protocol (EIGRP), use the default-metric command. To remove the metric value and restore the default state, use the no form of this command.

default-metric bandwidth delay reliability loading mtu

no default-metric

 
Syntax Description

bandwidth

Minimum bandwidth of the route in kilobits per second. The range is from 1 to 16777215. The default value is 100000.

delay

Route delay in tens of microseconds. The range is from 1 to 16777215. The default value is 100 (tens of microseconds).

reliability

Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100-percent reliability; 0 means no reliability. The default value is 255.

loading

Effective bandwidth of the route expressed as a number from 1 to 255 (255 is 100-percent loading). The default value is 1.

mtu

Minimum maximum transmission unit (MTU) size of the route in bytes. The range is from 1 to 4294967295. The default value is 1492.

 
Defaults

bandwidth: 100000
delay: 100 (tens of microseconds)
reliability: 255
loading: 1
MTU: 1500

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Changed the default value for MTU to 1492.

 
Usage Guidelines

Use the default-metric command with the redistribute command to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever external metrics do not convert to EIGRP metrics, you can use a default metric to provide a reasonable substitute to the external metric and enable the redistribution to proceed.

This command requires the Enterprise Services license.

Examples

This example shows how to take redistributed Routing Information Protocol (RIP) metrics and translate them into EIGRP metrics with the following values: bandwidth = 1000, delay = 100, reliability = 250, loading = 100, and MTU = 1500.

switch(config)# router eigrp 1
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute rip 100 route-map FilterRIP
switch(config-router-af)# default-metric 1000 100 250 100 1500

 
Related Commands

Command
Description

redistribute

Redistributes routes from one routing domain into another routing domain.

default-metric (OSPF)

To set default metric values for the Open Shortest Path First (OSPF) routing protocol, use the default-metric command. To return to the default state, use the no form of this command.

default-metric metric-value

no default-metric metric-value

 
Syntax Description

metric-value

Default metric value appropriate for the specified routing protocol. The range is from 1 to 1677214.

 
Defaults

The metric for redistributed, connected, and static routes is set to 25.

 
Command Modes

Router configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the default-metric command with the redistribute command to configure the same metric value for all redistributed routes except static and directly connected routes. A default metric helps to redistribute routes with incompatible metrics. Whenever external route metrics do not convert to an OSPF metric, use a default metric to enable the redistribution to proceed.

note.gif

Noteblank.gif The default-metric command does not apply to the redistribution of directly connected routes into OSPF. Use a route map to change the default metric for directly connected routes.


This command requires the Enterprise Services license.

Examples

This example shows how to configure OSPF to redistribute RIP and BGP and set the default metric to 10:

switch(config)# router ospf 201
switch(config-router)# default-metric 10
switch(config-router)# redistribute rip 109 route-map FilterRip
switch(config-router)# redistribute bgp 4 route-map FilterBgp

 
Related Commands

Command
Description

redistribute (OSPF)

Redistributes routes from another routing domain into OSPF.

default-metric (OSPFv3)

To set default metric values for the Open Shortest Path First version 3 (OSPFv3) routing protocol, use the default-metric command. To return to the default state, use the no form of this command.

default-metric metric-value

no default-metric metric-value

 
Syntax Description

metric-value

Default metric value appropriate for the specified routing protocol. The range is from 1 to 1677214.

 
Defaults

The metric for redistributed, connected, and static routes is set to 25.

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the default-metric command with the redistribute command to configure the same metric value for all redistributed routes except directly connected routes. A default metric helps to redistribute routes with incompatible metrics. Whenever external route metrics do not convert to an OSPFv3 metric, use a default metric to enable the redistribution to proceed.

note.gif

Noteblank.gif The default-metric command does not apply to the redistribution of directly connected routes into OSPF. Use a route map to change the default metric for directly connected routes.


This command requires the Enterprise Services license.

Examples

This example shows how to configure OSPFv3 to redistribute RIP and BGP and set the default metric to 10:

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# default-metric 10
switch(config-router-af)# exit
switch(config-router)# redistribute rip 109 route-map FilterRip
switch(config-router)# redistribute bgp 4 route-map FilterBgp

 
Related Commands

Command
Description

redistribute (OSPFv3)

Redistributes routes from another routing domain into OSPFv3.

default-metric (RIP)

To set default metric values for the Routing Information Protocol (RIP), use the default-metric command in router address-family configuration mode. To return to the default state, use the no form of this command.

default-metric value

no default-metric [ value ]

 
Syntax Description

value

Default metric value. The range is from 1 to 15.

 
Defaults

value : 1

 
Command Modes

Router address-family configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the default-metric command with the redistribute command to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever external metrics do not convert to RIP metrics, you can use a default metric to provide a reasonable substitute to the external metric and enable the redistribution to proceed.

This command does not require a license.

Examples

This example shows how to advertise Open Shortest Path First (OSPF) routes using RIP and assign the OSPF-derived routes with a RIP metric of 10:

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-metric 10
switch(config-router-af)# redistribute ospf 109 route-map FilterOSPF

 
Related Commands

Command
Description

address-family

Enters address-family configuration mode.

default-information originate

Generates a default route for routes redistributed into RIP.

redistribute

Redistributes routes from one routing domain into another routing domain.

delay

To delay a state change for Object Tracking, use the delay command. To disable this function, use the no form of this command.

delay { up up-time [ down down-time] | down down-time [ up up-time ]}

no delay

 
Syntax Description

up up-time

Delays the object track state change for an up condition. The range is from 0 to 180 seconds.

down down-time

Delays the object track state change for a down condition. The range is from 0 to 180 seconds.

 
Defaults

None

 
Command Modes

Object track mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.2(4)

This command was introduced.

 
Usage Guidelines

Use the delay command to delay when object tracking detects an up or down state change for a tracked object or track list. This delay helps prevent state flapping.

This command does not require a license.

Examples

This example shows how to configure the delay timer for a tracked object:

switch(config)# configure terminal

switch(config)# track 1 interface ethernet 1/2 line-protocol

switch(config-track)# delay up 30 down 30
 

 
Related Commands

Command
Description

track

Configures a tracked object or track list.

delay minimum

To delay Hot Standby Router Protocol (HSRP) initialization after a reload or after an interface comes up, use the delay minimum command. To disable this function, use the no form of this command.

delay minimum [ min-delay ] reload [reload-delay ]

no delay minimum [ min-delay ] reload [reload-delay ]

 
Syntax Description

delay minimum min-delay

Specifies the minimum time (in seconds) to delay HSRP group initialization after an interface comes up. This period applies to all subsequent interface events. The default is 0 seconds.

reload reload-delay

Specifies the time period to delay HSRP group initialization after the router has reloaded. This period applies only to the first interface-up event after the router has reloaded. The default is 0 seconds.

 
Defaults

The HSRP delay default is 0 seconds.

 
Command Modes

Interface configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use delay minimum command to delay HSRP initialization either after a reload or after an interface comes up. This configuration allows the interface and router to stabilize after the interface comes up and helps prevent HSRP state flapping.

This command does not require a license.

Examples

This example shows how to configure a minimum delay of 3 seconds, and a group initialization delay of 10 seconds:

switch(config)# configure terminal
switch(config)# interface ethernet 0
switch(config)# ip address 172.16.6.5 255.255.255.0
switch(config)# hsrp 1
switch(config)# delay minimum 3 reload 10
switch(config)# ip 172.16.6.100

 
Related Commands

Command
Description

feature hsrp

Enables HSRP configuration.

disable-peer-as-check (BGP)

To disable checking the peer autonomous system number (ASN) during route advertisement, use the disable-peer-as-check command.

disable-peer-as-check

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Checking the ASN during route advertisement is enabled.

 
Command Modes

config-router-vrf-neighbor-af mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to disable checking the peer ASN during a route advertisement:

s witch# configure terminal

switch(config)# feature bgp

switch(config)# feature-set mpls

switch(config)# feature mpls l3vpn

switch(config)# feature bgp

switch(config)# router bgp 1.1

switch(config-router)# neighbor 33.0.1.63 remote-as 100

config-router-vrf-neighbor)# address-family ipv4 unicast

switch(config-router-neighbor-af)# neighbor 33.0.1.63 remote-as 100

switch(config-router-vrf-neighbor)# address-family ipv4 unicast

switch(config-router-vrf-neighbor-af)# disable-peer-as-check

switch(config-router-vrf-af)#
 

 
Related Commands

Command
Description

address-family ipv4 unicast

Enters address family configuration mode for configuring routing sessions that use standard IPv4 address prefixes.

allowas-in

Allows duplicate autonomous system number (ASN) in the AS path. Configure this parameter in the VPN address family configuration mode at the PE spokes and at the neighbor mode at the PE hub.

neighbor

Adds an entry to the BGP or multiprotocol BGP neighbor table for this VRF.

discard-route

For Cisco NX-OS to automatically configure a discard route for the summary address to prevent routing black holes and route loops, use the discard-route command. To prevent the discard routes from being created, use the no form of this command.

discard-route { internal | external }

no discard-route { internal | external }

 
Syntax Description

internal

(Optional) Specifies internal route.

external

(Optional) Specifies external route.

 
Defaults

Enabled

 
Command Modes

config-router mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to automatically configure a discard route for the summary address to prevent routing black holes and route loops:

switch# configure terminal
switch(config)# router ospf 201
switch(config-router)# area 0.0.0.10 range 10.3.0.0/16
switch(config-router)# summary-address 10.5.0.0/16 tag 2
switch(config-router)# no discard-route internal
switch(config-router)#
 

This example shows how to prevent the discard routes from being created:

switch(config-router)# no discard-route internal

 
Related Commands

Command
Description

router ospf

Configures an Open Shortest Path First (OSPF) routing instance.

distance (EIGRP)

To allow the use of two administrative distances—internal and external—for the Enhanced Interior Gateway Routing Protocol (EIGRP) that could provide a better route to a node, use the distance command. To reset to default, use the no form of this command.

distance internal-distance external-distance

no distance

 
Syntax Description

internal-distance

Administrative distance for EIGRP internal routes. Internal routes are routes that are learned from another entity within the same autonomous system (AS). The distance can be a value from 1 to 255. The default value is 90.

external-distance

Administrative distance for EIGRP external routes. External routes are routes for which the best path is learned from a source external to this autonomous system. The distance can be a value from 1 to 255. The default value is 170.

 
Defaults

internal-distance : 90
external-distance : 170

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual router or a group of routers. Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means that the routing information source cannot be trusted and should be ignored.

Use the distance command if another protocol is known to provide a better route to a node than was actually learned through the external EIGRP or some internal routes should be preferred by EIGRP.

This command requires the Enterprise Services license.

Examples

This example shows how to set the administrative distance of all EIGRP 1 internal routes to 80 and all EIGRP external routes to 130:

switch(config)# router eigrp 1
switch(config-router)# distance 80 130

 
Related Commands

Command
Description

show ip eigrp

Displays information about the Enhanced Interior Gateway Routing Protocol (EIGRP) running on the router.

distance (IS-IS)

To define an administrative distance for routes that are inserted into the routing table, use the distance configuration mode command. To return the administrative distance to its default distance definition, use the no form of this command.

distance value

no distance

 
Syntax Description

value

Administrative distance. Range: 1 to 255. Default: 115.

 
Defaults

The default route is not redistributed into the IS-IS routing domain.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual router or a group of routers. Numerically, an administrative distance is an integer from 0 to 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means the routing information source cannot be trusted at all and should be ignored.

This command requires the Enterprise Services license.

Examples

This example shows how to set the administrative distance to 90:

switch(config)# router isis TEST1
switch(config-router)# distance 90
 

 
Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

net

Specifies the Network Entity Title (NET) for an IS-IS process.

router isis

Enables IS-IS.

distance (OSPF)

To define the Open Shortest Path First (OSPF) route administrative distance, use the distance command. To restore the default, use the no form of this command.

distance distance

no distance

 
Syntax Description

distance

Administrative distance for all routes local to this OSPF process. The range is from 1 to 255.

 
Defaults

110

 
Command Modes

Router configuration

 
Supported User Roles

network-admin

vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the distance command to set a distance for an entire group of routes. Use the distance command when you configure multiple routing protocols, and you want to choose one set of routes over the other.

This command requires the Enterprise Services license.

Examples

This example shows how to set the distance to 200, making the route less reliable:

switch(config)# router ospf 1
switch(config-router)# distance 200
switch(config-router)# router ospf 2
switch(config-router)# distance 20

distance (OSPFv3)

To define the Open Shortest Path First version 3 (osPFv3) route administrative distance, use the distance command. To restore the default, use the no form of this command.

distance distance

no distance

 
Syntax Description

distance

Administrative distance for all routes local to this OSPFv3 process. The range is from 1 to 255.

 
Defaults

110

 
Command Modes

Address-family configuration

 
Supported User Roles

network-admin

vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the distance command to set a distance for an entire group of routes. Use the distance command when you configure multiple routing protocols, and you want to choose one set of routes over the other.

This command requires the Enterprise Services license.

Examples

This example shows how to set the distance to 200, making the route less reliable:

switch(config)# router ospfv3 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# distance 200

distance (RIP)

To define the administrative distance assigned to routes discovered by the Routing Information Protocol (RIP), use the distance command in the router address-family configuration mode. To remove the distance and restore the system to its default condition, use the no form of this command.

distance admin-distance

no distance admin-distance

 
Syntax Description

admin-distance

Administrative distance to be assigned to RIP routes. The range is from 0 to 255.

 
Defaults

admin-distance : 120

 
Command Modes

Router address-family configuration

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the distance command to change the preference of RIP routes over other protocol routes. Numerically, an administrative distance is an integer from 0 to 255. In general, a higher value indicates a lower trust rating. An administrative distance of 255 means that the routing information source cannot be trusted at all and should be ignored.

Table 4-1 lists default administrative distances.

 

Table 4-1 Default Administrative Distances of Routing Protocols

Routing Protocols
Administrative Distance Value

Connected interface

0

Static route out an interface

0

Static route to next hop

1

EIGRP Summary Route

5

External BGP

20

Internal EIGRP

90

OSPF

110

IS-IS

115

RIP

120

External EIGRP

170

Internal BGP

200

Unknown

255

This command does not require a license.

Examples

This example shows how to set the administrative distance for RIP:

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# distance 85

 
Related Commands

Command
Description

address-family

Enters address-family configuration mode.

redistribute

Redistributes routes from one routing domain into RIP.

distribute

To distribute routes between specific IS-IS levels, use the distribute command. To return to the default setting, use the no form of this command.

distribute { level-1 | level-2 } into { level-1 | level-2 } { all | route-map name }

 
Syntax Description

level-1

Distributes the interarea routes into level-1 of this IS-IS instance.

level-2

Distributes the interarea routes into level-2 of this IS-IS instance.

into

Specifies from one level to another level.

all

Distributes all route levels.

route-map name

Prevents distribution of a specific route-map. The name can be any alphanumeric string up to 63 characters.

 
Defaults

The default route is not distributed into the IS-S routing domain. If enabled, IS-IS allows distribution of route between level-1 and level-2 such that optimal inter-area routing could be obtained.

This command requires the Enterprise Services license.

 
Command Modes

Router configuration
VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

level-1 summarizes the IP address into the level-1 area. Only routes redistributed into Level 1 are summarized with the configured address and mask value.

level-2 summarizes the IP address into the level-2 area. Routes learned by level-1 routing are summarized into the level-2 backbone with the configured address and mask value. Redistributed routes into level-2 IS-IS will be summarized also.

In IS-IS, all areas are stub areas, which means that no routing information is leaked from the backbone (level-2) into areas (level-1). Level-1-only routers use default routing to the closest level-1-level-2 router in their area. This command enables you to redistribute level-2 IP routes into level-1 areas. This redistribution enables level-1-only routers to pick the best path for an IP prefix to get out of the area. This is an IP-only feature, CLNS routing is still stub routing.

For more control and scalability, a distribute list or a route map can control which level-2 IP routes can be redistributed into level-1. This command allows large IS-IS-IP networks to use areas for better scalability.

Examples

This example distributes level-1 routes into a level-2 network:

switch(config)# distribute level-1 into level-2
 

down-bit-ignore

To disable down bit (DN bit) checking on a provider edge (PE) router, use the down-bit-ignore command in OSPF VRF configuration mode. To return to the default setting, use the no form of this command.

down-bit-ignore

no down-bit-ignore

 
Syntax Description

This command has no keywords or arguments.

 
Defaults

By default, the down bit (DN bit) checking is enabled. The information from the link-state advertisement (LSA) for which the DN bit is set is ignored during Open Shortest Path First (OSPF) route calculation.

 
Command Modes

OSPF VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command is supported only in the OSPF VRF mode on a PE router. This command is not supported in OSPF VRF mode on a non-PE router.

When a PE receives a type 3, 5, or 7 LSA with the DN bit set from a customer edge (CE) router, the information from the LSA is not used during OSPF route calculation. The DN bit ignore feature enables a PE router to process type-3, type-5, and type-7 LSAs that are received from a CE router when the DN bit is set. When you configure the DN bit ignore feature, the PE router includes these LSAs in OSPF route computation.

The DN bit is used to prevent routing loops in Layer 3 virtual private network (VPN) configurations using OSPF in a PE-CE scenario. The DN bit ignore feature is applicable for only certain topologies, such as a hub and spoke topology of PE routers with multiple virtual routing and forwarding (VRF) CEs connected to the hub PE. You should be use this command with caution because it can cause routing loops.