E Commands

This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter E.

ebgp multihop

To configure the exterior Border Gateway Protocol (eBGP) time-to-live (TTL) value to support eBGP multihop, use the ebgp multihop command. To reset to default, use the no form of this command.

ebgp multihop ttl-value

no ebgp multihop ttl-value

 
Syntax Description

ttl-value

TTL value for eBGP multihop. The range is from 2 to 255. You must manually reset the BGP sessions after using this command.

 
Defaults

None

 
Command Modes

BGP neighbor configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

 
Usage Guidelines

Use the ebgp multihop command to configure the eBGP time-to-live (TTL) value to support eBGP multihop. In some situations, an eBGP peer is not directly connected to another eBGP peer and requires multiple hops to reach the remote eBGP peer. You can configure the eBGP TTL value for a neighbor session to allow these multihop sessions.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the eBGP multihop value:

switch(config)# router bgp 1.1
switch(config-router)# neighbor 192.0.2.1 remote-as 1.2
switch(config-route-neighbor) ebgp multihop 2

 
Related Commands

Command
Description

feature bgp

Enables the BGP feature.

eigrp graceful-restart

To enable graceful restart for the Enhanced Interior Gateway Routing Protocol (EIGRP), use the eigrp graceful-restart command. To reset to default, use the no form of this command.

eigrp graceful-restart

no eigrp graceful restart

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

Enabled

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Replaced by graceful-restart command.

 
Usage Guidelines

Use the eigrp graceful-restart command to allow EIGRP to remain in the data forwarding path through a process restart. This command is the same as the nsf command.

This command requires the Enterprise Services license.

Examples

This example shows how to enable graceful restart:

switch(config)# router eigrp 1
switch(config-router)# eigrp graceful-restart

 
Related Commands

Command
Description

graceful-restart

Enables graceful restart.

timers nsf

Configures timers for nonstop forwarding and graceful restart.

eigrp log-neighbor-changes

To enable the logging of changes in Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor adjacencies, use the eigrp log-neighbor-changes command. To disable the logging of changes in EIGRP neighbor adjacencies, use the no form of this command.

eigrp log-neighbor-changes

no eigrp log-neighbor-changes

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

Adjacency changes are logged.

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Replaced by log-neighbor-changes command.

 
Usage Guidelines

Use the eigrp log-neighbor-changes command to log neighbor adjacency changes to monitor the stability of the routing system and to detect problems. Logging is enabled by default. To disable the logging of neighbor adjacency changes, use the no form of this command.

This command requires the Enterprise Services license.

Examples

This example shows how to enable logging of neighbor changes for EIGRP process 209:

switch(config)# router eigrp 209
switch(config-router)# eigrp log-neighbor-changes

 
Related Commands

Command
Description

log-neighbor-changes

Enables logging of EIGRP neighbor changes.

log-neighbor-warnings

Enables logging of EIGRP neighbor warnings.

log-adjacency-changes

Enables logging of EIGRP adjacency state changes.

eigrp log-neighbor-warnings

To enable the logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor warning messages, use the eigrp log-neighbor-warnings command. To disable the logging of EIGRP neighbor warning messages, use the no form of this command.

eigrp log-neighbor-warnings [ seconds ]

no eigrp log-neighbor-warnings

 
Syntax Description

seconds

(Optional) Time interval (in seconds) between repeated neighbor warning messages. The range of seconds is from 1 to 65535.

 
Command Default

Neighbor warning messages are logged.

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Replaced by log-neighbor-warnings command.

 
Usage Guidelines

Use the eigrp log-neighbor-warnings command to enable neighbor warning messages and to configure the interval between repeated neighbor warning messages.

This command requires the Enterprise Services license.

Examples

This example shows how to log neighbor warning messages for EIGRP process 209 and to repeat the warning messages in 5-minute (300 seconds) intervals:

switch(config)# router eigrp 209
switch(config-router)# eigrp log-neighbor-warnings 30

 
Related Commands

Command
Description

log-neighbor-changes

Enables logging of EIGRP neighbor changes.

log-neighbor-warnings

Enables logging of EIGRP neighbor warnings.

log-adjacency-changes

Enables logging of EIGRP adjacency state changes.

eigrp router-id

To set the router ID used by the Enhanced Interior Gateway Routing Protocol (EIGRP) when communicating with its neighbors, use the eigrp router-id command. To remove the configured router ID, use the no form of this command.

eigrp router-id ip-address

no eigrp router-id ip-address

 
Syntax Description

ip-address

Router ID in dotted decimal notation.

 
Command Default

EIGRP automatically selects an IP address to use as the router ID when an EIGRP process is started. The highest local IP address is selected and loopback interfaces are preferred. The router ID is not changed unless the EIGRP process is removed with the no router eigrp command or if the router ID is manually configured with the eigrp router-id command.

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Replaced by router-id command.

 
Usage Guidelines

Use the eigrp router-id command to manually configure the router ID for EIGRP. The router ID is used to identify the originating router for external routes. If an external route is received with the local router ID, the route is discarded. The router ID can be configured with any IP address with two exceptions; 0.0.0.0 and 255.255.255.255 are not legal values and cannot be entered. You should configure unique value for each router.

This command requires the Enterprise Services license.

Examples

This example shows how to configure 172.16.1.3 as a fixed router ID:

switch(config)# router eigrp 209
switch(config-router)# eigrp router-id 172.16.1.3

 

eigrp stub

To configure a router as a stub using the Enhanced Interior Gateway Routing Protocol (EIGRP), use the eigrp stub command. To disable the EIGRP stub routing feature, use the no form of this command.

eigrp stub [ direct | leak-map map-name | receive-only | redistributed ]

no eigrp stub [ direct | leak-map map-name | receive-only | redistributed ]

 
Syntax Description

direct

(Optional) Advertises directly connected routes.

leak-map map-name

(Optional) Allows dynamic prefixes based on the leak map.

receive-only

(Optional) Sets the router as a receive-only neighbor.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.

 
Command Default

Disabled

 
Command Modes

Address-family configuration
Router configuration
Router VRF configuration

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

4.0(1)

This command was introduced.

4.0(3)

Replaced by stub command.

 
Usage Guidelines

Use the eigrp stub command to configure a router as a stub where the router directs all IP traffic to a distribution router.

The direct keyword permits EIGRP stub routing to advertise connected routes. This option is enabled by default.

The receive-only keyword restricts the router from sharing any of its routes with any other router in that EIGRP autonomous system, and the receive-only keyword does not permit any other option to be specified because it prevents any type of route from being sent.

The redistributed keyword permits the EIGRP Stub Routing feature to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP will not advertise redistributed routes.

If you use any of these four keywords ( direct, leak-map, receive-only, redistributed) with the eigrp stub command, only the route types specified by the particular keyword(s) are advertised.

This command requires the Enterprise Services license.

 
Usage Guidelines

This example shows how to configure the router as a receive-only neighbor:

switch(config)# router eigrp 1
switch(config-router)# eigrp stub receive-only

event fib resource tcam usage

To configure an event statement for the policy, use the event fib resource tcam usage command.

event fib resource tcam usage

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

None

 
Command Modes

config-applet mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

By using the event fib resource tcam usage command, you can configure a policy in the Embedded Event Manager (EEM) to monitor TCAM utilization on Cisco Nexus 7000 M1 Series modules.

The event fib resource tcam usage command triggers an event each time the TCAM utilization percentage becomes a multiple of 5, in either direction.

This command requires the Enterprise Services license.

Examples

This example shows how to configure an event statement for the policy:

switch# configure terminal
switch(config)# event manager applet Test1
switch(config-applet)# description “checks TCAM usage threshold on M1 card”
switch(config-applet)# event fib resource tcam usage
switch(config-applet#

 
Related Commands

Command
Description

show event manager policy-state

Displays information about the status of the specified event policy.

event fib route

To configure an event statement for the policy, use the event fib route command. To remove an event statement from an Embedded Event Manager (EEM) policy, use the no form of this command.

event fib route {inconsistent | missing | failure}

no event fib route {inconsistent | missing | failure}

 
Syntax Description

inconsistent

Triggers an event if the route or adjacency programming is changed in the hardware configuration.

missing

Triggers an event if the route is deleted in the unicast Forward Information Base (FIB).

failure

Triggers an event if a route fails to be inserted in the unicast FIB.

 
Defaults

None

 
Command Modes

config-applet mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2(2)

This command was introduced.

 
Usage Guidelines

This command requires the Enterprise Services license.

Examples

This example shows how to configure an event statement for the policy:

switch# configure terminal
switch(config)# event manager applet Route1
switch(config-applet)# description “checks for missing routes in FIB”
switch(config-applet)# event fib route missing
switch(config-applet)#

 
Related Commands

Command
Description

show event manager policy-state

Displays information about the status of the specified event policy.

 

export vrf

To export IP prefixes to the default VRF (global routing table) from any other VRF, use the export vrf command.

export vrf default [ prefix-limit] map route-map

 
Syntax Description

prefix-limit

Number of routes that can be exported in order to avoid the global table being over-loaded.

The default value is 1000.

map

Specifies the route map.

route-map

Name of the route map. It is case-sensitive, alphanumeric character string with a maximum length of 63 characters.

 
Command Modes

Address Family Configuration (config-vrf-af)

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

7.3(0)D1(1)

This command was introduced.

.

Examples

The following example shows how to export the route-map, BgpMap, to default VRF, and verify the configuration:

switch# configure terminal
switch(config)# feature bgp
switch(config)#vrf context vpn1
switch(config-vrf)# address-family ipv4 unicast
switch(config-vrf-af)# export vrf default 3 map BgpMap
switch(config-vrf-af)# exit
switch(config)# show gp process vrf vpn1

 
Related Commands

Command
Description

import vrf

Import IP prefixes from default VRF.