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Change History
This table lists changes made to this guide. Most recent changes appear at the top:

DateSeeChange
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DateSeeChange

July 2019Upgrade Windows ServerAdded new Section, Upgrade Windows
Server

Upgrade SQL ServerAdded new Section, Upgrade SQL Server

Install Microsoft SQL ServerUpdated Microsoft SQL Server to 2017

Removed prerequisite and modified note
in the Section, Before you begin

Modified features list

Common Ground Upgrade Task FlowAdded new rows for upgrading Windows
Server and SQL Server

Throughout the documentUpdated Microsoft Windows Server to
2016

Upgrade Windows ServerAdded a note on uninstalling antivirus and
NIS Tools not supported

System RequirementsAdded a note on Windows Defender
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About This Guide
This guide describes how to install the components and software for a newUnified CCE system, or to upgrade
an existing Unified CCE system.

Audience
This guide is intended for users who install and upgrade Unified CCE contact centers.

The procedures assume that the system has been thoroughly designed and staged in preparation for the
installation or upgrade.

Related Documents
LinkSubject

Design GuideDesign considerations and guidelines for deploying
a Unified CCE solution, including its various
components and subsystems.

Staging GuideSystem diagrams, staging steps and sample test cases
for supported models of Unified CCE.
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LinkSubject

Preinstallation and PlanningPre-installation requirements and issues to address
when you prepare for a Unified CCE installation.

Communications, Services, and Additional Information
• To receive timely, relevant information from Cisco, sign up at Cisco Profile Manager.

• To get the business impact you’re looking for with the technologies that matter, visit Cisco Services.

• To submit a service request, visit Cisco Support.

• To discover and browse secure, validated enterprise-class apps, products, solutions and services, visit
Cisco Marketplace.

• To obtain general networking, training, and certification titles, visit Cisco Press.

• To find warranty information for a specific product or product family, access Cisco Warranty Finder.

Cisco Bug Search Tool

Cisco Bug Search Tool (BST) is a web-based tool that acts as a gateway to the Cisco bug tracking system
that maintains a comprehensive list of defects and vulnerabilities in Cisco products and software. BST provides
you with detailed defect information about your products and software.

Field Notice
Cisco publishes Field Notices to notify customers and partners about significant issues in Cisco products that
typically require an upgrade, workaround, or other user action. For more information, see Product Field Notice
Summary at https://www.cisco.com/c/en/us/support/web/tsd-products-field-notice-summary.html.

You can create custom subscriptions for Cisco products, series, or software to receive email alerts or consume
RSS feeds when new announcements are released for the following notices:

• Cisco Security Advisories

• Field Notices

• End-of-Sale or Support Announcements

• Software Updates

• Updates to Known Bugs

For more information on creating custom subscriptions, see My Notifications at https://cway.cisco.com/
mynotifications.
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Documentation Feedback
To provide comments about this document, send an email message to the following address:
contactcenterproducts_docfeedback@cisco.com

We appreciate your comments.

Conventions
This document uses the following conventions:

DescriptionConvention

Boldface font is used to indicate commands, such as user entries, keys, buttons,
folder names, and submenu names.

For example:

• Choose Edit > Find.

• Click Finish.

boldface font

Italic font is used to indicate the following:

• To introduce a new term. Example: A skill group is a collection of agents
who share similar skills.

• A syntax value that the user must replace. Example: IF (condition, true-value,
false-value)

• A book title. Example: See the Cisco Unified Contact Center Enterprise
Installation and Upgrade Guide.

italic font

Window font, such as Courier, is used for the following:

• Text as it appears in code or that the window displays. Example:
<html><title>Cisco Systems, Inc. </title></html>

window font

Angle brackets are used to indicate the following:

• For arguments where the context does not allow italic, such as ASCII output.

• A character string that the user enters but that does not appear on the window
such as a password.

< >
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C H A P T E R 1
Preparation

• Scenarios, on page 1
• System Requirements, on page 2

Scenarios
Cisco Unified Contact Center Enterprise (Unified CCE) is supported only in a virtualized environment.

Installation Scenario
In a virtualized environment, you can run Unified CCE on a VMware ESXi platform. Run the virtual machines
(VMs) on Cisco Unified Computing System (UCS) C-series servers, or equivalent third-party servers.

Install the Unified CCE components after you configure the VMs.

You can use the OVA template to deploy the VMs before beginning with the installation of Unified CCE
components.

For more information about the complete procedure, see the Installation Task Flow, on page 29.

Upgrade Scenarios
This release contains an updated database schema. Use the Enhanced Database Migration Tool (EDMT) to
perform a schema upgrade during the upgrade process.

You can upgrade from Unified CCE 11.0(x), 11.5(x), and 11.6(x) to Unified CCE 12.0(1) by using one of the
two methods:

• Common Ground Upgrades: The Common Ground method is an in-place upgrade performed on your
existing virtual machine which involves upgrading the Cisco Unified Contact Center Enterprise and all
other associated software that is hosted on it. If your hardware meets the requirements for this release,
you can perform a Common Ground upgrade without acquiring extra hardware.

• Technology Refresh Upgrades: Use the Technology Refresh upgrade method to upgrade your hardware
at the same time as the Cisco Unified Contact Center Enterprise system. When using the Technology
Refresh method, you prepare a destination system on new hardware and then migrate data from your
existing deployment to the new one.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
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Follow the documented procedures to build a parallel network using new hardware and pre-stage it with
configuration data to support the existing production network. Use the Enhanced Database Migration
Tool (EDMT) to transfer data and perform a schema upgrade during the upgrade process. Do not use
backup and restore procedures to perform the pre-staged configuration on the parallel network.

Upgrade scenarios are considered at a component level; you can perform one type of upgrade on one component,
and another type of upgrade on another component. However, the A and B side of any given component must
be running on identical hardware.

Follow the task flow and tasks for the upgrade scenario that applies to each individual component involved
in the overall upgrade.

While upgrading from previous versions of Unified ICM / Unified CCE using the base installer for the current
release, make sure that there are no other Windows sessions that are active. These sessions may have
inadvertently left some Unified CCE tools like Configuration Manager open. This can prevent the tools from
getting upgraded appropriately and this can cause the tool to malfunction or assert. The installer logs indicate
that some files were locked, during the upgrade. To resolve the issue with these tools that were not upgraded,
you need to re-run the base installer and ensure that no other windows sessions are open.

Note

System Requirements
Before you start installation or upgrade activities, plan your Unified CCE contact center installation or upgrade.
For system requirements, see the Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html.

By default, Windows Defender is enabled on Windows Server. For more information on Windows Defender
antivirus compatibility, see https://docs.microsoft.com/en-us/windows/security/threat-protection/
windows-defender-antivirus/windows-defender-antivirus-compatibility.

Before proceeding with Unified ICM application installation, ensure that you follow the antivirus guidelines
specified in the Section, Antivirus Guidelines of the Security Guide for Cisco Unified ICM/Contact Center
Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Unified ICM installation can also take longer than expected due to scanning of files by Windows Defender.
Based on your IT policy, either:

• Disable Windows Defender. For more information, see Disable Microsoft Defender Antivirus procedure
in Microsoft documentation.

-OR-

• Add the Unified ICM product folder <ICM install directory:>\icm to the exclusion list of Windows
Defender. For more information, see https://docs.microsoft.com/en-us/windows/security/threat-protection/
windows-defender-antivirus/configure-extension-file-exclusions-windows-defender-antivirus.

On Logger, Rogger, AW, and HDS servers, the Unified CCE Installer adds BUILTIN\Administrators to SQL
security logins and assigns sysadmin role to it. This is required for Logger and Administration & Data
Server services to function appropriately.

Ensure that the system is ready, and meets all requirements for supported hardware and software.
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This section provides a summary of the requirements for Unified CCE. If you have not confirmed all the
information in this section, complete the planning phase before proceeding further.

For more information, see these documents:

• Solution Design Guide for Cisco Unified Contact Center Enterprise at http://www.cisco.com/en/US/
products/sw/custcosw/ps1844/products_implementation_design_guides_list.html

• Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/dam/en/us/td/docs/
voice_ip_comm/uc_system/virtualization/cisco-collaboration-virtualization.html

• Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html

Platform Requirements
Server selection for Unified CCE in a virtualized environment involves several factors, including:

• The server and all related hardware must be supported for use in a virtualized Unified CCE system

• Minimum specifications for processing, memory, and storage

• Whether you want a packaged and tested Cisco configuration (Tested Reference Configuration or TRC)
or a configuration that you base on Cisco-defined minimum requirements (Specs-based Configuration)

• Compatibility requirements for all hardware, and Cisco and third-party software including the VMware
required to run and manage a virtual environment

Confirm that your hardware selection is supported for Unified CCE and meets all minimum specifications:

For detailed requirements information,
see

VMware requiredServer

Virtualization for Unified Contact Center
Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_
system/virtualization/
cisco-collaboration-virtualization.html

• VMware vSphere ESXi

• VMware vCenter (Optional)

UCS C-series (TRC):

• VMware vCenter

• VMware vSphere ESXi

UCS C-series
(Specs-based):

• VMware vCenter

• VMware vSphere ESXi

Third-party
(Specs-based)

In addition to confirming that your servers meet minimum specifications, confirm that your server choice is
compatible with all Cisco and third-party software.

Network Requirements
Network requirements for virtualized Unified CCE systems vary widely, depending on the size and type of
Unified CCE solution deployment. Confirm that you have clearly established all network requirements before
you install or upgrade a Unified CCE contact center.
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For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/cisco-collaboration-virtualization.html.

Transport Layer Security Version 1.2 Required
Contact center enterprise solutions require the use of TLS 1.2 only connections in this release. Our services
accept incoming TLS connections only over TLS 1.2. All outgoing TLS connection use only TLS 1.2.

All clients that connect to either our web interfaces or databases must support TLS 1.2.

The older versions of the TLS/SSL are disabled by installer.Note

For more information see, Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/
us/support/customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html.

Software License Requirements

Third-Party Products

For detailed information about the software editions and versions supported for this release, see the Contact
Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-device-support-tables-list.html.

Note

Before you begin an installation or upgrade of any part of your contact center, confirm the following:

• That you have all the required software products.

• That all the software versions are compatible with each other.

• That all software versions are also compatible with all hardware and VMware.

Virtualization Requirements
You run the Unified Contact Center Enterprise solution on VMware ESXi platform.

The following requirements apply to VMware on virtual machines for Unified CCE:

• After you install the Unified CCE components on each VM, install the latest VMware Tools from your
VMware host using the VMware Tool default settings.

Update the VMware Tools whenever you patch or upgrade ESXi.Note

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/cisco-collaboration-virtualization.html.
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ESXi Supportability
For information on supported versions of ESXi for this release see Contact Center Enterprise Compatibility
Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

As part of the CommonGround upgrade process, if there are no available overlapping supported ESXi versions,
upgrade the Unified CCE software first if a back-out of the upgrade is required.

If the upgrade is successful and working, you can then proceed to upgrade ESXi to a supported version for
final testing and restoring production operation.

Compatibility Requirements
As part of the planning process, ensure that all hardware, Cisco software, third-party software, VMware, and
firmware are compatible. Confirm that you meet all the following compatibility requirements:

SeeFor this
compatibility
information

Virtualization Software Requirements at http://www.cisco.com/c/dam/en/us/td/docs/voice_
ip_comm/uc_system/virtualization/virtualization-software-requirements.html

VMware and
Cisco software
components

See the following:

VMware Compatibility Guide at
http://www.vmware.com/resources/compatibility/search.php.

For more information, see Virtualization for Unified Contact Center Enterprise at
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Cisco Installation and Upgrade Guides at http://www.cisco.com/c/en/us/support/
servers-unified-computing/ucs-c-series-rack-servers/products-installation-guides-list.html

Required
firmware

Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Review the compatibility between different versions of the Cisco components
to plan upgrades that occur across multiple maintenance windows.
Components that are upgraded in one maintenance window must continue
to operate with other components that are still at the previous version until
the full upgrade is completed.

Note

Cisco software
product
intercompatibility
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SeeFor this
compatibility
information

See the following:

SNMP Guide for Cisco Unified ICM/Contact Center Enterprise at http://www.cisco.com/
c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html

Serviceability Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html

Windows OS
and SNMP

• SNMP
Service

• SNMP MI
Provider

Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Third party
software
products
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C H A P T E R 2
Installation Overview

• Installation Tools, on page 7

Installation Tools
During installation, use one or all of the following tools, as required:

• ICM-CCE-Installer—The main Unified CCE Installer copies all files into relevant folders, creates the
base registries, and installs needed third-party software such as JRE and Apache Tomcat. It uses the
Microsoft .NET Framework which is an integral software of Windows Server.

Optionally, you can update the JRE installed by the Unified CCE Installer with
a later version of the JRE. See Update the Java Runtime Environment (Optional),
on page 55.

Note

Do not run the installer remotely. Download the installer to a local machine for installation.

• Cisco Unified Intelligent Contact Management Database Administration (ICMDBA) Tool—Used to
create new databases, modify or delete existing databases, and perform limited SQL Server configuration
tasks.

The SQL Server installation disables the Windows Computer Browser service.
The ICMDBA requires this service. If you need to run ICMDBA on this server,
enable the Computer Browser service.

Note

• Domain Manager—Used to provision Active Directory.

• Web Setup—Used to set up the Call Routers, Loggers, Network Gateways, Network Interface Controllers,
and Administration & Data Servers.

• Peripheral Gateway (PG) Setup—Used to set up PGs, the CTI server, and the Outbound Option dialer.

• AdminClientInstaller—Installs the Administration Client on a system that is not running other Unified
CCE components.

The AdminClientInstaller is delivered on the installation media with the ICM-CCE-Installer.
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• Administration Client Setup—Used to add, edit, or remove Administration Clients and Administration
Client Instances.
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C H A P T E R 3
Preinstallation

• Preinstallation Task Flow, on page 9
• Preinstallation Tasks, on page 9

Preinstallation Task Flow
Before you can install Unified CCE and the associated components, set up the network, create virtual machines,
and install and configure third-party software.

After you set the hostname of any Unified CCE server, you cannot change it.The length of the hostname must
not exceed 15 characters.

Important

SeeTask

Set up Active Directory, on page 9If you are integrating Unified CCE into an
existing corporate network, verify Domain
Controller health. If you are installing into
a new Active Directory domain, install and
configure Active Directory and DNS server.

Set Up Virtual Machines, on page 10Download Open Virtualization Format
(OVA) templates and create virtual
machines.

Set Up Third-Party Software, on page 15Install and configure third-party software.

Preinstallation Tasks

Set up Active Directory
Ensure that you have a completed plan for your domain structure and Active Directory implementation before
you set up your network.
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The Unified CCE servers should be in the same domain, and multiple domains are not supported.Warning

For more information, see the Staging Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.

Set Up Virtual Machines

Verify Datastores
Before you install the VMs, verify that the datastore is in place. The type of datastore depends on the type of
server on which you deploy the VMs. For example, UCS-B servers use a SAN datastore and UCS-C servers
use DAS datastores.

For more information, see the VMware documentation at https://www.vmware.com/support/pubs/.

For more information, see Virtualization for Unified Contact Center Enterprise at https://www.cisco.com/c/
dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Configure HyperFlex M5 Series
Cisco HyperFlex HX-Series System provides a unified view of the storage across all nodes of the HyperFlex
HX cluster via the HX Data Controller Platform. For optimal performance, it is recommended that all VMs
are mapped to the single unified datastore. This mapping enables the HX Data Platform to optimize storage
access based on the workload and other operating parameters.

For more information, see the documentation on Cisco HyperFlex HXData Platform at https://www.cisco.com/
c/en/us/support/hyperconverged-systems/hyperflex-hx-data-platform-software/
products-installation-guides-list.html.

For information on installing collaboration software, see the Cisco Collaboration on Virtual Servers at
https://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-callmanager/
products-installation-guides-list.html.

Configure RAID for Cisco UCS C240 M5SX
The disk array configuration for the Cisco UCS C240 M5SX is already set up to match the requirements.
Verify the settings as follows:

Procedure

Using Cisco Integrated Management Controller, check that the following settings are configured correctly:

• Virtual Drive Info: RAID 5 with 6 (Physical Disks) * 4 (Virtual Drives or Datastores)

• Stripe Size: 128KB

• Write Policy: Write Back with BBU

• Read Policy: Read Ahead Always
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For more information regarding RAID configuration for Cisco UCS C240 M5SX, see the Installation and
Configuration section of the Cisco Collaboration on Virtual Servers Guide at:

https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/virtual/chcs_b_
cisco-collaboration-on-virtual-servers.html

Download Unified CCE OVA Files
The Unified CCE Open Virtualization Format (OVA) files define the basic structure of the corresponding
VMs that are created. The structure definition includes the CPU, RAM, disk space, reservation for CPU, and
reservation for memory.

Before you begin

You must have a valid service contract associated with your Cisco.com profile.

Procedure

Step 1 Go to the Unified CCE Download Software page on Cisco.com.
Step 2 Click Download to download and save the appropriate OVA file to your local hard drive. When you create

VMs, you select the OVA required for the application.

Create a Virtual Machine from the OVA
To create virtual machines (VMs) from the OVA files, complete the following procedure.

ECE requires a second virtual hard drive on its VM. The OVA creates one virtual hard drive. Create a second
hard drive of an appropriate size for your solution requirements.

Note

Procedure

Step 1 Select the Host in the vSphere client.
Step 2 Choose File > Deploy OVF Template.
Step 3 Browse to the location on your local drive where you stored the OVA. Click Open to select the file. Click

Next.

Step 4 Click Next at the OVF Template Details page.
Step 5 Enter the virtual machine name. It cannot contain spaces or special characters. Enter a maximum of 32

characters. Click Next.
Step 6 On the Name and Location page, enter a name of your choice in the Name field. Click Next.

After the VM is created, you cannot rename it.Important
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Step 7 On the Deployment Configuration page, select the applicable configuration from the drop-down list. Click
Next.

Step 8 Choose a data store on which to deploy the new virtual machine. Click Next.

For each datastore, the following tables describe the RAID group, the ESXi Host, and the virtual machines
for the Cisco UCS C240 M4SX and Cisco UCS C240 M5SX servers.

RAID configuration for the Cisco UCS C240 M4SX and Cisco UCS C240 M5SX

Virtual MachinesESXi HostVM DatastoreRAID Group

ESXi operating system

Unified CCE Rogger, Side A

Unified Communications Manager
Publisher

Cisco Finesse Primary

Adatastore 1VD0

Unified CCE AW-HDS-DDS, Side AAdatastore 2VD1

Unified Communications Manager
Subscriber 1

Unified CVP OAMP Server

Unified CVP Server, Side A

Adatastore 3VD2

Unified Intelligence Center Server
Publisher

Unified CCE PG, Side A

Adatastore 4VD3

ESXi operating system

Unified CCE Rogger, Side B

Unified Communications Manager
Subscriber 2

Cisco Finesse Secondary

Bdatastore 1VD0

Unified CCE AW-HDS-DDS, Side BBdatastore 2VD1

Unified Customer Voice Portal
Reporting Server (optional)

Unified CVP Server, Side B

Bdatastore 3VD2

Unified Intelligence Center Server
Subscriber

Unified CCE PG, Side B

Enterprise Chat and Email Server
(optional)

Bdatastore 4VD3

Step 9 On the Disk Format page, choose Thick provisioned Eager Zeroed format for the virtual disk format.
Click Next.
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Thick provisioned Lazy Zero is also supported, but Thin provisioned is not supported.Note

Step 10 Confirm that the Network Mapping page is correct:
a) Public network adapter to Public network
b) Private network adapter to Private network

Certain VMs do not require a private network connection. The OVAs for those VMs do not create
a second network adapter.

Note

Step 11 Click Finish.

Step 12 At the Successfully Completed message, click Close.

For more information, see Virtualization for Unified Contact Center Enterprise at
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Note

Allocate a Second Virtual Hard Drive
After deploying the OVA files, the second hard drive is no longer automatically created. To create a second
hard drive:

Procedure

Step 1 Right-click the virtual machine and click Edit Settings.
Step 2 In the Hardware tab, click on Add.

The Add Hardware window appears.

Step 3 You can select the type of device you wish to add. Select Hard Disk, and then click Next.
Step 4 Select the Create a new virtual disk option, and then click Next.
Step 5 In the Capacity section, use the Disk Size box to assign the desired disk space, and then click Next.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
13

Preinstallation
Allocate a Second Virtual Hard Drive

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/virtualization-unified-contact-center-enterprise.html
http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/virtualization-unified-contact-center-enterprise.html


Virtual machine templates for Logger, Rogger, AW, and HDS servers do not have a SQL database
drive preprovisioned. The following reference table can be used to assign disk space to the virtual
machine based on the type:

Default Second Disk SizeVirtual Machine Template

500 GBLogger

150 GBRogger

500 GBAW-HDS-DDS

500 GBAW-HDS

500 GBHDS-DDS

You can custom size the SQL database disk space tomeet data retention requirements, as calculated
by the Database Estimator tool.

Note

Step 6 On the Disk Provisioning section choose Thick provision Lazy Zeroed format. Click Next.
Step 7 In the VM Options > Advanced Options section, retain the default options and then click Next.
Step 8 In the Ready to Complete section, click Finish to create the hard disk.
Step 9 Click OK to confirm the changes.

The Recent Tasks window at the bottom of the screen displays the progress.

Initialize and Format Secondary Disk
After the second hard disk is created, allocate memory to the hard disk.

Procedure

Step 1 Open the command prompt, and type diskmgmt.msc.
Step 2 Right-click Disk 1, and click Online.
Step 3 After the disk goes online, right-click the disk, and then click Initialize Disk.
Step 4 Select Master Boot Record (MBR) radio button.
Step 5 After the disk is initialized, right-click the disk, and then click Convert to Dynamic Disk.
Step 6 In the Convert to Dynamic Disk window, check the Disk 1 check box to select it, and then click OK.
Step 7 Right click on the unallocated disk space, and click New Simple Volume. The New Simple Volume Wizard

window appears.
Step 8 Click Next and follow the on-screen instructions to create a simple volume on the disk.
Step 9 Click Finish to complete the process of allocating memory to the hard drive.
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Mount ISO Files
Upload ISO image to data store:

1. Select the host in the vSphere client and click Configuration. Then click Storage in the left panel.

2. Select the datastore that will hold the ISO file.

3. Right click and select Browse datastore.

4. Click the Upload icon and select Upload file.

5. Browse to the location on your local drive where you saved the ISO file, and upload the ISO to the
datastore.

Mount the ISO image:

1. Right-click the VM in the vSphere client and select Edit virtual machine settings.

2. Click Hardware and select CD|DVD Drive 1.

3. Check Connect at power on (Device status panel upper right).

4. Click the Datastore ISO File radio button and then click Browse.

5. Navigate to the data store where you uploaded the file.

6. Select the ISO file and click OK.

Set Up Third-Party Software

Install Microsoft Windows Server
Complete the following procedure to install Microsoft Windows Server on the virtual machines deployed.

For information about supported editions, see the Contact Center Enterprise Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Note

Before installing 12.5(1) ICMon SQL Server , make sure to install ODBCDriver 13 for SQL Server®manually.Note

Procedure

Step 1 Mount the Microsoft Windows Server ISO image to the virtual machine.

Check the Connect at power on check box when mounting the ISO.

For more information, see Mount and Unmount ISO File.
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Step 2 Power on the VM.
Step 3 Enter the Language, Time and Currency Format, and Keyboard settings. Click Next.
Step 4 Click Install Now.
Step 5 If prompted, enter the product key for Windows Server and click Next.
Step 6 Select the Desktop Experience option for the Windows Server and click Next.
Step 7 Accept the license terms and click Next.
Step 8 Select Custom: Install Windows only (advanced), select Drive 0 to install Microsoft Windows Server, and

then click Next.

The installation begins. After the installation is complete, the system restarts without prompting.

Step 9 Enter and confirm the password for the administrator account, and then click Finish.
Step 10 Enable Remote Desktop connections as follows:

a) Navigate to Control Panel > System and Security > System.
b) Click Remote Settings.
c) Click the Remote tab.
d) Select the Allow remote connections to this computer radio button. The Remote Desktop Connection

dialog displays a notification that the Remote Desktop Firewall exception is enabled. Click OK.

Step 11 Install VMWare tools. See Install Vmware Tools, on page 17
Step 12 Open the Network and Sharing Center, and in the View your basic network info and set up connections

section, click Ethernet.
Step 13 In the Ethernet Status window, click Properties.
Step 14 In the Ethernet Properties dialog box, configure the network settings and the Domain Name System (DNS)

data:
a) Uncheck Internet Protocol Version 6 (TCP/IPv6).
b) Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.
c) Select Use the following IP Address.
d) Enter the IP address, subnet mask, and default gateway.
e) Select Use the following DNS Server Address.
f) Enter the preferred DNS server address, and click OK.

Step 15 Navigate to Control Panel > System and Security > System. Follow the instructions:
a) ClickChange Settings.
b) In Computer name tab, click Change.
c) Change the name of the computer from the name randomly generated during Microsoft Windows Server

installation. The name does not contain underscores or spaces.
d) Select Domain radio button to change the member from Workgroup to Domain.
e) Enter qualified domain name and click OK.
f) In the Windows security dialog, validate the domain credentials and click OK.
g) On successful authentication, click OK.
h) Reboot the server and sign in with domain credentials.
Restart your system for the change to take effect.

Step 16 Go to Settings > Update & Security and run Microsoft Windows Update.

Microsoft Windows Server is installed. In addition, Internet Explorer 11 is installed automatically.
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Edge Chromium (Microsoft Edge) is not installed by default on theWindows server. To install Edge Chromium
(Microsoft Edge), see Microsoft documentation.

If you want to install Unified CCE on a multilingual version of Windows Server, refer to Microsoft
documentation for details in installing Microsoft Windows Server Multilingual language packs.

If Unified CCE language pack is applied on Chinese Windows OS machine, set the screen resolution to 1600
x 1200.

Note

Set Windows Locale
If theWindows system locale differs from the display language (and therefore also the SQL collation setting),
some characters appear incorrectly in the user interface and are saved incorrectly to the database. For example,
if the system locale is English and an agent works in Spanish, characters such as the acute a do not appear
correctly.

If you use a multilingual version of Microsoft Windows Server, complete this procedure to set the Windows
locale.

Procedure

Step 1 Open Control Panel > Clock, Region and Language.
Step 2 In the Region section, click Change date, time, or number formats.
Step 3 Click the Administrative tab.
Step 4 In the Language for non-Unicode programs section, click Change system locale.
Step 5 In the Region Settings window, select the language that matches the display language.
Step 6 Restart the virtual machine.

Install Vmware Tools
VMware Tools is a suite of utilities that enhance the performance of the virtual machine guest operating
system. It also aids virtual machine management.

The AppInfo feature provided by the VMware tools has to be disabled. For instructions to disable the AppInfo
feature, see the VMware documentation.

Note

Install VMware Tools for Windows

Procedure

Step 1 From the vSphere Client, right-click the virtual machine, select Power, and click Power On.
Step 2 Click the Summary tab.
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In the General section, the VMware Tools field indicates whether VMware Tools are:

• installed and current

• installed and not current

• not installed

Step 3 Click the Console tab to make sure that the guest operating system starts successfully. Log in if prompted.
Step 4 Right-click the virtual machine, select Guest OS, and then click Install/Upgrade VMware Tools. The

Install/Upgrade VMware Tools window appears with the option - Interactive Tools Upgrade and Automatic
Tools Upgrade.
a) To install/upgrade the VMware tools manually, select the Interactive Tools Upgrade option, and click

OK. Follow the on-screen instructions to install/upgrade the VMware tools, and restart the virtual machine
when prompted.

b) To install/upgrade the VMware tools automatically, select the Automatic Tools Upgrade option, and
click OK. This process takes a few minutes to complete, and restart the virtual machine when prompted.

Install VMware Tools for VOS

To install or upgrade VMware Tools using VOS, perform the following steps:

Procedure

Step 1 Ensure that your virtual machine is powered on.
Step 2 Right-click the VM menu. Select Guest > Install / Upgrade VMware tools .
Step 3 Choose the interactive tools update and press OK.
Step 4 Open the console and log in at the command prompt.
Step 5 Enter the command utils vmtools refresh and confirm.

The server automatically reboots twice.
Step 6 After reboot, check the Summary tab for the VM to verify that the VMware Tools version is current. If it is

not current, reboot the VM and check the version again.

The process takes a few minutes. After the process completes, the tools are listed as Running (Current) on
the VM's Summary tab in vSphere.

Install Microsoft SQL Server
Install Microsoft SQL Server and store the SQL Server log and temporary files on the same vDisk as the
operating system when using default (two) vDisk design. If you choose to use more than two virtual disks,
then the tempDB cannot be on the same vDisk as the solution database.

For further information about the database placement and performance tuning the SQL installation, see the
Microsoft documentation.
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For information about supported editions, see the Contact Center Enterprise Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

Note

Before you begin

Microsoft SQL Server does not contain SQL Server Management Studio in the default toolkit. To rerun the
SQL Server setup to install Management Studio, navigate to: SQL Selection Center > Installation > Install
SQL Server Management Tools. If your computer has no internet connection, download and install SQL
Server Management Studio manually.

Note

Procedure

Step 1 Mount the Microsoft SQL Server ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 15.

Step 2 Select Installation in the left pane and then clickNew SQL Server stand-alone installation or add features
to an existing installation. Click OK.

Step 3 On the Product Key page, enter the product key and then click Next.
Step 4 Accept the License Terms and then click Next.
Step 5 Optional: On theMicrosoft Update page, check theUse Microsoft Update to check for updates check box,

and then click Next.

If you do not check the Use Microsoft Update to check for updates option, click Next on the
Product Updates page.

Note

Step 6 On the Install Rules page, click Next.

In this step, the installation program checks to see that your system meets the hardware and software
requirements. If there are any issues, warnings or errors appear in the Status column. Click the links for more
information about the issues.

Step 7 On the Feature Selection page, select only the following, and click Next:

• Database Engine Services

• Client Tools Connectivity

• Client Tools Backwards Compatibility

• Client Tools SDK

• SQL Client Connectivity SDK

If you intend to use Outbound Option High Availability two-way replication, be sure to select the Replication
feature on this page. For more information about replication, see the Outbound Option Guide for Unified
Contact Center Enterprise.
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Step 8 On the Instance Configuration page, select Default Instance and click Next.

Step 9 On the Server Configuration page, click the Services Account tab.
a) Associate the SQL services with the virtual account.

• For the SQL Server Agent service, in the Account Name field, select NT
Service\SQLSERVERAGENT. If you have enabled Outbound Option High Availability, this
account must have the system administrator privilege.

• For the SQL Server Database Engine, in the Account Name field, select NT
Service\MSSQLSERVER.

While you can use the Network or Local Services account instead of the Virtual account,
using the Virtual account provides security.

Note

b) For the remaining services, accept the default values.
c) In the Start Up Type column, for the SQL Server Agent service account, select Automatic from the

list.
d) EnableGrant Perform Volume Maintenance Task privilege to SQL Server Database Engine Service.

Unified ICM Installer automatically enables theGrant Perform Volume Maintenance Task
for the NT service account.If it is not enabled automatically then you must enable Grant
Perform Volume Maintenance Task privilege to SQL Server Database Engine Service
manually on the SQL server.

Note

Step 10 On the Server Configuration page, click the Collation tab.
a) In the Database Engine section, click Customize.
b) Select the Windows Collation designator and sort order radio button.
c) Select the appropriate collation. Typically, you choose the SQL Server collation that supports theWindows

system locale most commonly used by your organization; for example, "Latin1_General" for English.

See the Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/
support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html for details about collations used for other languages.

Note

The database entry is related to the collation that you select. For example, if you set the collation for
Latin1_General, but you select Chinese language at sign-in. When you enter field values in Chinese, the
application displays the unsupported character error, because the database does not support the
characters.

It is critical to select the correct collation setting for the language display on your system. If
you do not select the correct collation during installation, you must uninstall and reinstall
Microsoft SQL Server.

Important

d) Check the Binary check box.
e) Click OK, and then click Next.

Step 11 On the Database Engine Configuration page:
a) On the Server Configuration tab, click the Mixed Mode radio button.
b) Enter the password for the SQL Server system administrator account, and confirm by reentering it.
c) Click Add Current User to add the user who is installing the SQL Server as an administrator.
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d) On theTempDB tab, set the Initial size andAutogrowth for Rogger, Logger, AW-HDS-DDS, AW-HDS,
and HDS-DDS. For information about values for respective components Increase Database and Log File
Size for TempDB, on page 22.

For more information about the SQL Server TempDBDatabase and its use, see the Microsoft SQL Server
documentation.

e) Click Next.

Step 12 On the Ready to Install page, click Install.
Step 13 On the Complete page, click Close.
Step 14 Enable Named Pipes and set the sort order as follows:

a) Open the SQL Server Configuration Manager.
b) In the left pane, navigate to SQL Native Client 11.0 Configuration (32bit) > Client Protocols.
c) In the right pane, confirm that Named Pipes is Enabled.
d) Right-click Client Protocols and select Properties.
e) In the Enabled Protocols section of the Client Protocols Properties window, use the arrow buttons to

arrange the protocols in the following order:

1. Named Pipes

2. TCP/IP

f) Check the Enable Shared Memory Protocol and then click OK.
g) In the left pane, navigate to SQL Server Network Configuration > Protocols for MSSQLSERVER.
h) In the right pane, right-click Named Pipes and select Enable.

By default, Microsoft SQL Server dynamically resizes its memory. The SQL Server reserves the
memory based on process demand. The SQL Server frees its memory when other processes
request it, and it raises alerts about the memory monitoring tool.

Cisco supports the Microsoft validation to dynamically manage the SQL Server memory. If your
solution raises too many memory alerts, you can manually limit SQL Server’s memory usage.
Set the maximum and minimum limit of the SQL memory using the maximum memory usage
settings in the SQL Server Properties menu.

For more information about the SQL Server memory settings and its use, see the Microsoft SQL
Server documentation.

Note

Step 15 Set the SQL Server's default language to English as follows:
a) Launch SQL Server Management Studio.
b) In the left pane, right-click the server and select Properties.
c) Click Advanced.
d) In the Miscellaneous section, set the Default Language to English.
e) Click OK.

Set the SQL Server default language to English because Cisco Unified Contact Center Enterprise
requires a US date format (MDY). Many European languages use the European date format
(DMY) instead. This mismatch causes queries such as select * from table where date =

'2012-04-08 00:00:00' to return data for the wrong date. Handle localization in the client
application, such as Cisco Unified Intelligence Center.

Important

Step 16 Restart the SQL Server service as follows:
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a) Navigate to the Windows Services tool.
b) Right-click SQL Server (MSSQLSERVER) and click Stop.
c) Right-click SQL Server (MSSQLSERVER) and click Start.

Step 17 Ensure that the SQL Server Browser is started, as follows:
a) Navigate to the Windows Services tool.
b) Navigate to the SQL Server Browser.
c) Right-click to open the Properties window.
d) Enable the service, change the startup type to Automatic, and click Apply.
e) To start the service, click Start, and then click OK.

What to do next

Do not change the SQL port number. Retain the default port numbers as 1433 for TCP and 1434 for UDP
connections. In case you change the port numbers, the applications like CCEAdmin will not work.

Caution

Increase Database and Log File Size for TempDB

To get the benefits of TempDBmultiple data files support in CCE components, configure the following values
as suggested for respective components.

TempDB Transaction Log FileTempDB Data FilesvCPUCCE
Component

AutogrowthInitial SizeAutogrowthInitial
Size

Number of
Files

10MB600MB100MB800MB44Rogger

10MB600MB100MB800MB44Logger

10MB600MB100MB800MB44AW-HDS-DDS

10MB600MB100MB400MB88AW-HDS

10MB600MB100MB400MB88HDS-DDS

Set Users as System Administrators

Any users who are involved in installing or upgrading a Unified ICM/CCE solution must be added as part of
SQL Server Security login and associated with the System Administrator role. Complete the following steps
to set a user as a System Administrator:

Procedure

Step 1 Open the Microsoft SQL Server Management Studio using the System Administrator login credentials.
Step 2 In the Object Explorer pane, click the Security folder.

The Security folder expands.

Step 3 Right-click the Logins folder, and then click New Login.
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The Login-New view appears.

Step 4 In theLogin name field, enter the Domain login name of the user whom you want to associate with the System
Administrator role.

Use the following format:

<domain>\<username>

Step 5 In the Object Explorer pane, click the Server Roles folder.

The Server Roles view appears.

Step 6 Check the sysadmin check box.

This step is mandatory.Note

System administrator is a predefined fixed server-level role in the Microsoft SQL Server. The system
administrator performs operations on a site-level. System administrators manage jobs, role definitions, and
shared schedules that are used to run reports.

You must be a system administrator to create, modify, and delete individual records in the Configuration
Manager tool.

For details about the sysadmin role, see the Microsoft SQL documentation.

Step 7 Click OK.

The user is now a part of the SQL Security login and is also associated with the System Administrator role.

Install Antivirus Software
For details about supported anitvirus softwares, see Contact Center Enterprise Compatibility Matrix, see
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

Use your antivirus vendor's product documentation for installation instructions, and adhere to the following:

• Update antivirus software manually. Do not enable automatic updates.

• To allow required access to installation program files or folders, perform file-blocking exclusions in the
antivirus product file-and-folder protection rules. For example, to create the exclusions in McAfee
VirusScan:

1. Open the VirusScan console.

2. Right-click Access Protection and select Properties.

3. In the Anti-virus Standard Protection category, make sure that the rule Prevent IRC communication
is unchecked in the Block column.

• Be aware that in the firewall component of Symantec Endpoint Protection 12.1, the Network Threat
Protection feature must be disabled. The feature is enabled by default. When the feature is enabled, both
sides of a redundant router come up in stand-alone mode which blocks communication between each
side of the router pair. This blocking affects all deployment types.
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If you retain the default (enabled) and start serviceson side A and B of the router, the following Symantec
message appears in the system tray: “The client will block traffic from IP address [side A router address]
for the next 600 seconds.” The same message is also written to the security login client management.
The Symantec Network Threat Protection traffic log indicates that a default firewall rule called “Block_all”
was dynamically enabled. The router logs show that both sides of the router came up in stand-alone
mode.

If you are using a managed client, perform the following steps:

1. Launch Symantec Endpoint Protection Manager.

2. Click Policies.

3. Right-click the firewall policy that you want to disable, and then select Edit.

4. Uncheck the check mark next to the policy to disable it.

5. Click OK to confirm.

If you are using an unmanaged client, perform the following steps:

1. Double-click the Symantec icon in the system tray and select Change Settings.

2. Configure settings for Network Threat Protection and uncheck the Enable Firewall check box at
the top of the Firewall tab.

• The firewall component of Trend Micro Deep Security blocks the communication between each side of
the Router/PG. If you retain the default (enabled) setting and start the services on side A and side B, then
the system logs a new deny event in the location: Trend Micro Manager > Events > Firewall Events.

To resolve the issue, disable the Trend Micro firewall policy or add a new firewall exception for that
particular policy.

Installation of .NET Framework
The Unified CCE installation or upgrade runs faster if .NET Framework 4.7.2 or later version is pre-installed.

If the appropriate version of the .NET Framework is not installed, the Unified CCE installer installs it.

Set Up Virtual Machines for Installation

Validate Network Adapter Settings and Power On

Procedure

Step 1 Select the virtual machine (VM) in the vSphere client. Right-click the VM and choose Edit settings.
Step 2 On the Hardware tab, select each network adapter. Make sure that Connect at power on in the Device Status

group is checked.
Step 3 Under Network Connection, select the applicable network connection from the Network label drop-down

list:

• Network adapter 1 = Public (visible)
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• Network adapter 2 = Private

Certain VMs do not require a private network connection. The OVAs for those VMs do not create
a second network adapter.

Note

Step 4 Close the dialog box.
Step 5 If you are powering up the VM for the first time, power on the VM and wait for the VM to restart and to apply

customization. The restart can take 5–10 minutes.

Do not press Ctrl-Alt-Delete. If you press Ctrl-Alt-Delete after powering on, the customization
does not take effect, which requires completing the customization manually.

Important

Configure Network Cards

Procedure

Step 1 In the virtual machine, open Network and Sharing Center.
Step 2 Click Change adapter settings.
Step 3 Rename Ethernet 0 to public for the Public network card.
Step 4 Rename Ethernet 1 to private for the Private network card.
Step 5 Assign an interface metric value for the network adapter:

a) Select the network adapter and right-click Properties.
b) In the Networking tab, select the appropriate Internet Protocol version and click Properties.
c) In the Internet Protocol Version Properties dialog box, click Advanced.
d) In the IP Settings tab, uncheck the Automatic metric checkbox and type a low value in the Interface

metric text box.

A low value indicates a higher priority. Make sure that the Public Network card should have
a lower value compared to the Private Network card.

By default, the value of the Interface Metric property for a network adapter is automatically
assigned and is based on the link speed.

Note

e) Click OK to save the settings.

Repeat the steps to assign an interface metric value for the internal/private cluster communication network
adapter.

Set Persistent Static Routes
For geographically distributed Central Controller sites, redundant CallRouter, Logger, and Peripheral Gateway
components typically have a Private IP WAN connection between Side A and Side B. Windows only allows
one default gateway for each VM (which sends the Private Network traffic to the Public Network). So, you
add a Static Route to all the VMs running the CallRouter, Logger, and PG applications.
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To create a persistent static route with the route add command, you need the destination subnet, the subnet
mask, the local gateway IP, and the interface number of the local Private Network interface:

route add <destination subnet> mask <subnet mask> <gateway IP> IF <interface number> -p

You must launch the DOS prompt as an administrator to run the commands in this procedure.

Procedure

Step 1 On each CallRouter, Logger, or PG VM, run ipconfig /all.
Record the IPv4 Address, Subnet Mask, and Physical Address (MAC address) for the Private
Network interface.

Step 2 On each of these VMs, run route print –4.
Record the Interface for the Private Network. You can identify the correct interface by looking for its
Physical Address (MAC address).

Step 3 On each of these VMs, run route add <destination subnet> mask <subnet mask> <gateway IP> IF

<interface number> -p to add a persistent static route for the remote Private Network.

Configure Private Ethernet Card

Procedure

Step 1 Right-click private and select Properties.
Step 2 Uncheck Client for Microsoft Networks.
Step 3 Uncheck File and Printer Sharing for Microsoft Networks.
Step 4 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 5 Check Internet Protocol Version 4 (TCP/IPV4) and click Properties.

a) Remove the IP Address for the Default Gateway.
b) Remove the IP Address for the Preferred DNS server.
c) Remove the IP Address for the Alternate DNS server.

Step 6 Click the Advanced button. Open the DNS tab. Uncheck Register this connection's addresses in DNS.
Step 7 Add an entry for the private IP address.

This IP address should have an entry in the DNS server. This would be required while adding
the Router or a Peripheral Gateway throughWebsetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "p" to easily identify it as the private interface.

For example: If the host name is RoggerA, make an entry in the DNS as "RoggerAp" for the
private IP address.

Note

Step 8 Optional: Add another entry for the private high IP address.
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This IP address should have an entry in the DNS server. This would be required while adding
the Router or a Peripheral Gateway throughWebsetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "ph" to easily identify it as the private interface.

For example: If the host name is RoggerA, make an entry in the DNS as "RoggerAph" for the
private high IP address.

Note

Step 9 Click OK twice. Then, click Close.

Configure Public Ethernet Card

Procedure

Step 1 Right-click Visible and select Properties.
Step 2 Check Client for Microsoft Networks.
Step 3 Check File and Printer Sharing for Microsoft Networks.
Step 4 Uncheck Internet Protocol Version 6 (TCP/IPV6).
Step 5 Check Internet Protocol Version 4 (TCP/IPV4) and click Properties.
Step 6 Confirm the Public IP address, Subnet mask, Default gateway and Preferred DNs server, and click

Advanced.
Step 7 On the Advanced tab, enter the public IP addresses.
Step 8 On the DNS tab, in the DNS suffix for this connection field, enter the name of the local DNS zone for the

server and check Register this connection's addresses in DNS.
Step 9 Optional: Add another entry for the public IP address.

This IP address should have an entry in the DNS server. This would be required while adding
the Router or a Peripheral Gateway throughWebsetup and PeripheralGatewaySetup respectively.

A host (A) resource record must be created in the DNS' Forward Lookup Zones, and can be of
the form hostname followed by a suffix "PuH" to easily identify it as the public interface.

For example: If the host name is RoggerA, make an entry in the DNS as "RoggerAPuH" for the
public IP address.

Note

Step 10 If the server requires access to resources in a different trusting or trusted domain or DNS zone, selectAppend
these DNS suffixes (in order) and enter the local DNS zone for the server first, and then add the other
secondary zones that represent the trusting or trusted domain.

Step 11 Click OK twice. Then, click Close.
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C H A P T E R 4
Installation

• Installation Task Flow, on page 29
• Installation Tasks, on page 31

Installation Task Flow
This section lists the installation tasks for a Unified CCE contact center solution.

Installation procedures for Unified CCE components appear later in this chapter. For the non-Unified CCE
components in your solution, follow the links in the table to access the installation guides for those components.

For the Unified CCE components, the sequence you follow can vary according to the distribution of Unified
CCE components on virtual machines.

SeeTask

Set Up Virtual Machines for Installation, on page 24Ensure that virtual machines are ready for
installation

Installing Cisco Unified Communications ManagerInstall Unified CommunicationsManager

Install Unified CCE Software, on page 31Install Unified CCE components (Router,
Logger, Administration & Data Servers,
peripherals)

Create Outbound Option Database, on page 35

and then see

Outbound Option Guide for Unified Contact Center Enterprise
at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-user-guide-list.html

Install Outbound Option

Cisco Finesse Server Installation, on page 60Install Finesse

Enterprise Chat and Email Installation Guide (for Unified Contact
Center Enterprise) at https://www.cisco.com/c/en/us/support/
customer-collaboration/cisco-enterprise-chat-email/
products-installation-guides-list.html

Install Enterprise Chat and Email
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SeeTask

Install Cisco Identity Service Standalone Deployment, on page
71

or

Install Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS), on page 81

Install Single Sign-On Identity Service
Standalone (4000, 8000, 12000 Agent
Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Installation and Upgrade Guide for Cisco Unified Intelligence
Center at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

or

Install Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS), on page 81

Install Cisco Unified Intelligence Center
Standalone (4000, 8000, 12000 Agent
Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Live Data Standalone Installation, on page 75

or

Install Coresident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS), on page 81

Install Live Data Standalone (4000, 8000,
12000 Agent Deployment)

or

Install Coresident Deployment (2000
Agent Deployment)

Installation and Upgrade Guide for Cisco Unified Customer Voice
Portal at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-customer-voice-portal/
products-installation-guides-list.html

Install Cisco Unified Customer Voice
Portal (Unified CVP) 1

Installation and Configuration Guide for Cisco Unified Contact
Center Management Portal at https://www.cisco.com/c/en/us/
support/customer-collaboration/
unified-contact-center-management-portal/
products-installation-guides-list.html

Install Unified Contact Center
Management Portal (Unified CCMP)

Cisco SocialMiner User Guide at https://www.cisco.com/c/en/us/
support/customer-collaboration/socialminer/
products-user-guide-list.html

Install Cisco SocialMiner

Installation and Administration Guide for Cisco MediaSense at
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cust_
contact/contact_center/mediasense/115/User_Guide/CUMS_BK_
M5B01864_00_ms-user-guide-115/CUMS_BK_M5B01864_00_
ms-user-guide-105_chapter_010.html

Install Cisco MediaSense 2

1 If you are using IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP IVR.
2 UCCE 12.0 supports only Cisco MediaSense 11.5.
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Installation Tasks
The following section provides instructions about installing Unified CCE components. For instructions about
installing non-Unified CCE components in a Unified CCE solution, see the links to component-specific
documents in the Installation Task Flow.

Take a backup of the VM snapshot before installing the Unified CCE software, because uninstallation support
is not provided .

Note

Install Unified CCE Software

Procedure

Step 1 Mount the Unified CCE Installer ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 15.

Step 2 Open the ICM-CCE-Installer, click Next.
Step 3 Select Fresh Install and click Next.

The installer program proceeds through a series of screens on which you specify information.

Step 4 To apply Unified ICM anyMaintenance/Minor Release, clickBrowse and navigate to theMaintenance/Minor
Release software.

Step 5 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade
planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

Set up Organizational Units

Add a Domain
Use the Domain Manager tool to add a domain.

Procedure

Step 1 Log in with a Domain Administrator privilege.
Step 2 Open the Domain Manager Tool from Unified CCE Tools shortcut on your desktop.
Step 3 Click Select. under Domains.
Step 4 You can add domains through the Select Domains dialog box, or you can add a domain manually if the target

domain cannot be detected automatically.
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To add domains by using the controls in the Select Domains dialog box:

a) In the left pane under Choose domains, select one or more domains.
b) Click Add to add the selected domains, or click Add All to add all the domains.

To add a domain manually:

a) In the field under Enter domain name, enter the fully qualified domain name to add.
b) Click Add.
c) Click OK.

Add Organizational Units
Use the DomainManager tool to create the Cisco root Organizational Unit (OU) for a domain, and then create
the facility and instance OUs.

The system software always uses the root OU named Cisco_ICM. You can place the Cisco_ICM OU at any
level within the domain where the Unified ICMCentral Controller is installed. The system software components
locate the root OU by searching for this name.

The user who creates the Cisco Root OU automatically becomes a member of the Setup Security Group for
the Cisco Root OU. In effect, this user is granted privileges to all Unified CCE tasks in the domain.

Procedure

Step 1 Log in with a domain administrator privilege and open the Domain Manager Tool from Unified CCE Tools
shortcut on the desktop.

Step 2 Choose the domain.
Step 3 If this OU is the first instance, then perform the following steps to add the Cisco_ICM root:

a) Under Cisco root, click Add.
b) Select the OU under which you want to create the Cisco root OU, then click OK.

When you return to the Domain Manager dialog box, the Cisco root OU appears either at the domain root
or under the OU you selected. You can now add the facility.

Step 4 Add the facility OU:
a) Select the Cisco Root OU under which you want to create the facility OU.
b) In the right pane, under Facility, click Add.
c) Enter the name for the Facility, and click OK.

Step 5 Add the instance OU:
a) Navigate to and select the facility OU under which you want to create the instance OU.
b) In the right pane, under Instance, click Add.
c) Enter the instance name and click OK.

Step 6 Click Close.
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Add Users to Security Groups
To add a domain user to a security group, use this procedure. The user is then granted the user privileges to
the functions that are controlled by that security group.

Procedure

Step 1 Open the Domain Manager tool and select the Security Group you want to add a user to.
Step 2 Under Security group, click Members.
Step 3 Under Users, click Add.
Step 4 Select the domain of the user you want to add.
Step 5 (Optional) In the Optional Filter field, choose to further filter by the Name or User Logon Name, apply the

search condition, and enter the search value.
Step 6 Click Search.
Step 7 Select the member you want to add to the Security Group from the search results.
Step 8 Click OK.

Add Unified CCE Instance

Procedure

Step 1 Open the Unified CCE Web Setup tool from shortcut on your desktop.
Step 2 Sign in as a domain user with local administrator rights.
Step 3 Click Instance Management, and then click Add.
Step 4 On the Add Instance page, from the drop-down list, choose the customer Facility and Instance.
Step 5 Enter an instance number.

The same instance name can occur more than once in a domain, so the instance number provides the uniqueness.
The instance number must be between 0 and 24. The instance number must match for the same instance across
your entire deployment. For an Enterprise (single instance) deployment, select 0 unless there are reasons to
select another value.

Step 6 Click Save.

These steps of adding instance must be repeated on each Windows Server VM that hosts the
Unified ICM component(s).

Note
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Set Up Unified CCE Central Controller and Administration and Data Server
Components

Create Component Databases
To improve database performance, Unified ICM uses a reduced fill factor from previous releases for the index
pages in every table of the Logger, AW, and HDS databases.

Create Logger Database

Perform this procedure on the Side A and Side B Rogger VM.

Procedure

Step 1 From Unified CCE Tools, open the ICMDBA tool, and click Yes at any warnings that display.
Step 2 Navigate to Server > Instances.
Step 3 Right-click the instance name and choose Create to create the logger database.
Step 4 In the Select Component dialog box, choose the logger you are working on (Logger A or Logger B). Click

OK.
Step 5 At the prompt, “SQL Server is not configured properly. Do you want to configure it now?”, click Yes.
Step 6 On the Configure page, in the SQL Server Configurations pane checkMemory (MB) and Recovery Interval.

Click OK.
Step 7 On the Stop Server page, click Yes to stop the services.
Step 8 In the Select Logger Type dialog box, choose Enterprise. Click OK to open the Create Database dialog box.
Step 9 Create the Logger database and log as follows:

a) In the DB Type field, choose the Side (A or B).
b) In the region field, choose your region.
c) In the Create Database dialog box, click Add to open the Add Device dialog box.
d) Click Data.
e) Choose the drive on which you want to create the database, for example, the E drive.
f) For the Size field, consider whether to choose the default (which is 1.4GB, a fairly minimal size) or

calculate a value appropriate for your deployment by using the Database Size Estimator Tool. If you
calculate the value, enter it here.

a) Click OK to return to the Create Database dialog box.
b) Click Add again.
c) In the Add Device dialog box, click Log.
d) Choose the drive where you created the database.
e) In the Size field, choose the default setting or, if you have calculated an appropriate size for your

deployment, enter that value.
f) Click OK to return to the Create Database dialog box.

Step 10 In the Create Database dialog box, click Create, then click Start.
Step 11 When you see the successful creation message, click OK and then Close.
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Create HDS Database

Perform this procedure on the Administration & Data Server on which you want to create the HDS database.

Procedure

Step 1 Open the ICMDBA tool, and click Yes at any warnings that display.
Step 2 Navigate to Servers > Instances.
Step 3 Right-click the instance name and choose Create.
Step 4 In the Select Component dialog box, choose Administration & Data Server. Click OK.
Step 5 At the prompt “SQL Server is not configured properly. Do you want to configure it now?”, click Yes.
Step 6 On the Configure dialog box, click OK.
Step 7 On the Select AW Type dialog box, choose Enterprise. Click OK to open the Create Database dialog box.
Step 8 Create the HDS database as follows:

a) From the DB Type drop-down list, choose HDS.
b) Click Add.
c) On the Add Device dialog box, select Data.
d) From the Available Drives list, choose the drive on which you want to install the database.
e) In the Size field, you can leave the default value or enter an appropriate size for your deployment.

You can use the Database Size Estimator Tool to calculate the appropriate size for your
deployment.

Note

f) Click OK to return to the Create Database dialog box.
g) Click Add.
h) On the Add Device dialog box, select Log.
i) From the Available Drives list, choose the drive on which you created the database.
j) In the Size field, you can leave the default value or enter an appropriate size for your deployment.
k) Click OK to return to the Create Database dialog box.

Step 9 On the Create Database dialog box, click Create and then click Start.
Step 10 When you see the successful creation message, click OK and then click Close.

Create Outbound Option Database

Outbound Option uses its own SQL database on the Logger. Perform the following procedure on the Side A
Logger or the Side B Logger.

After you complete this procedure, see the Outbound Option Guide for Unified Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-user-guide-list.html .

Procedure

Step 1 Open the ICMDBA tool and click Yes to any warnings.
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Step 2 Navigate to Servers > <Logger Server> > Instances > <Unified CCE instance> > LoggerA or LoggerB.
Right-click the instance name and select Database > Create.

Step 3 On the Stop Server message, click Yes to stop the services.
Step 4 In the Create Database dialog box, click Add to open the Add Device dialog box.
Step 5 Click Data, and choose the drive on which you want to create the database, for example, the E drive. In the

database size field, you can choose to retain the default value or enter a required value.
Step 6 Click OK to return to the Create Database dialog box.
Step 7 In the Add Device dialog box, click Log. Choose the desired drive. Retain the default value in the log size

field and click OK to return to the Create Database dialog box.
Step 8 In the Create Database dialog box, click Create, and then click Start. When you see the successful creation

message, click OK and then click Close.

For more information see the Outbound Option Guide for Unified Contact Center Enterprise guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-user-guide-list.html

Configure SQL User Account for Outbound Options High Availability

Complete these steps on both sides of the Logger to configure the Microsoft SQL User for Outbound Options
High Availability database operations:

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Logger.
Step 2 Navigate to Security > Logins, right-click Logins and select New Logins.
Step 3 On the General Screen:

a) Enter the login name.
b) Select SQL Server authentication.
c) Enter and confirm the password.

Step 4 On the Server Roles page, select the sysadmin check box.
Step 5 Navigate to Security>Logins>NT AUTHORITY\SYSTEM, right-click Properties.
Step 6 On the server roles page, check the sysadmin check box.
Step 7 Click OK.

Add Components to Unified CCE Instance

Add Logger Component to Instance

Perform this procedure on the Side A and Side B Loggers; both logger machines must be up and operational.

Before you begin

If you choose to enable Outbound Option, you can also enable Outbound Option High Availability. Outbound
Option High Availability facilitates two-way replication between the Outbound Option database on Logger
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Side A and the Outbound Option database on Logger Side B. Use the ICMDBA tool to create an outbound
database on Side A and Side B; then set up the replication by using theWeb Setup tool, as described in several
of the following steps.

Procedure

Step 1 Open the Web Setup tool.
Step 2 Choose Component Management > Loggers. Click Add, and then choose the instance.
Step 3 On the Deployment page, select the Logger (A or B). Click Duplexed, and then click Next.
Step 4 On the Central Controller Connectivity page, enter the host names for Sides A and B for these interfaces:

Router Private and Logger Private. Then, click Next.
Step 5 If an external AW-HDS-DDS exists in the deployment, check Enable Historical/Detail Data Replication.

If no external AW-HDS-DDS exists in the deployment, leave Enable Historical/Detail Data Replication
unchecked.

Step 6 On the Additional Options page, click Display Database Purge Configuration Steps.
Step 7 Click the Enable Outbound Option check box if you are installing a Unified CCE Logger and choose to

deploy Outbound Option.

If this Logger is being added for a Rogger server, where there are two IP addresses that are
configured on the public Network Interface Card (for IP-based prioritization), uncheck "Register
this connection's addresses in DNS" for the public ethernet card. In addition, ensure that there is
only one A-record entry in the DNS server corresponding to the host name of the server, which
maps to the normal priority IP address. This is necessary for processes like the campaignmanager
and replication running as part of the Logger service, to listen on the right interface IP address
for client connections.

Note

Step 8 Click the Enable High Availability check box to enable Outbound Option High Availability on the Logger.
(An Outbound Option database must exist on Logger Side A and Logger Side B.) Checking this check box
enables Outbound Option High Availability two-way replication between the Outbound Option database on
Logger Side A and the Outbound Option database on Logger Side B. Two-way replication requires that you
check this check box on both the Logger Side A and Side B Additional Options page. If you disable two-way
replication on one side, you must also disable it on the other side.

You must enable Outbound Option in order to enable Outbound Option High Availability. Similarly, if you
want to disable Outbound Option and you have enabled Outbound Option High Availability, you must disable
High Availability (uncheck theEnable High Availability check box) before you can disable Outbound Option
(uncheck the Enable Outbound Option check box).

Disabling HAwill not disable outbound option, customer has to explicitly disable outbound when
HA is disabled.

Note

Step 9 If you enable High Availability, enter a valid public server hostname address for Logger Side A and Logger
Side B. Entering a server IP address instead of a server name is not allowed.

The SQL server name must be the same as the server host name since this value used to resolve
the server IP address and locate the SQL DB on that server.

Note

Step 10 If you enable High Availability, enter the SQL Server Admin Credentials (Username and Password),
which are required to establish two-way replication. The username and password must be the same on Logger
Side A and Logger Side B, and the user must have the SQL Server System Admin privilege.
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SQL replication requires that the correct SQL system admin username and password be in place when setting
up Outbound Option High Availability. Changing the password for the SQL user used to set up SQL replication
in Outbound Option High Availability causes replication to fail until you disable High Availability and
re-enable it with the new username and password. Because of this requirement, be careful about how and
when you change the password for this user.

Step 11 If you enable High Availability, enter the Active Directory Account Name that the opposite side logger runs
under or a security group that includes that account. For example, if you are running Websetup on the logger
on Side A, enter the name of the Active Directory account (or security group) that is run on Side B logger.

Step 12 Select the Syslog box to enable the Syslog event feed process (cw2kfeed.exe).

The event feed is processed and sent to the Syslog collector only if the Syslog collector is
configured. For more information about the Syslog event feed process, see the Serviceability
Guide for Cisco Unified ICM/Contact Center Enterprise at http://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Note

Step 13 Click Next.
Step 14 On the Data Retention page, modify the Database Retention Configuration table:

a) For these tables, set the retention period to 40 days:

• Application_Event

• Event

• Network_Event

• Route_Call_Detail

• Route_Call_Variable

• Termination_Call_Detail

• Termination_Call_Variable

b) Accept the default settings for all other tables. If your contact center requires access to any of that data
for a longer period, enter an appropriate value.

Step 15 Click Next.
Step 16 On the Data Purge page, configure purges for a day of the week and a time when there is low demand on the

system.
Step 17 Accept the default Automatic Purge at Percent Full.
Step 18 Click Next.
Step 19 In the Summary window select the Create Service Account option, complete the following steps:

a) Enter the domain user.

Verify that the user is created in the specified domain.

b) Enter the valid password.
c) Review the Summary and click Finish.
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Use the same domain user account for all the distributor and logger services. If you want to use
different domain accounts for the logger and the distributor, ensure that the distributor service
user account is added to the local logger UcceService groups on Side A and Side B.

Caution

Add Router Component to Instance

Perform this procedure for Side A and Side B Routers.

Procedure

Step 1 In the Web Setup tool, select Component Management > Routers.
Step 2 Click Add to set up the Call Router.
Step 3 On the Deployment page, choose the current instance.
Step 4 In the Deployment dialog, select the appropriate side.
Step 5 Click Duplexed, and then click Next.
Step 6 In the Router Connectivity dialog, configure the Private Interface and Public Interfaces. Click Next.

For the address input fields, use Fully Qualified Domain Names instead of IP addresses.

When there are two IP addresses configured on the public Network Interface Card (for IP-based
prioritization), manually add two A-records on the DNS server. One A-record is for the high
priority IP address and the other one is for the normal priority IP address. The host part of the
two DNS entires should be different from the hostname of Windows server. Use the new DNS
entries to configure the interfaces. This note applies to the Router and to all PG machines.

Note

Step 7 In the Enable Peripheral Gateways field, enter the number assigned to the PGs to enable it. Click Next.

Use a hyphen to indicate a range and commas to separate values. For example, "2-4, 6, 79-80" enables PG2,
PG3, PG4, PG6, PG79, and PG80. Spaces are ignored.

Step 8 In the Router Options dialog, the Enable Quality of Service (QoS) is enabled by default. Click Next.
On the Router Quality of Service page, you see preconfigured values for the Router QoS for the Private
Network. These values only appear if you selected a Side A Router. You can change the values in the DSCP
fields if necessary.
Keep QoS enabled for all Unified CCE Private network traffic. For most deployments, disable QoS for the
public network traffic. For more details, refer to the appropriate section in the Solution Design Guide for Cisco
Unified Contact Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.html.

Step 9 In the Router Quality of Service dialog, click Next.
Step 10 In the Summary dialog, make sure that the Router summary is correct, then click Finish.

Add Administration & Data Server Component to Instance

Follow this procedure for all types of Administration & Data Servers:
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• Configuration-Only Administration Server—Supports configuration changes only. Does not support
reporting.

• Administration Server and Realtime Data Server (AW)—Supports configuration changes and real-time
reporting. Does not support historical reporting.

• Administration Server, Realtime and Historical Data Server, and Detail Data Server
(AW-HDS-DDS)—Supports configuration and real-time and historical reporting, including call detail
and call variable data.

Not all fields apply to all server types.

AW Database is created when you add Administration & Data Server Component. Data from the
Config_Message_Log table is replicated from the Logger database to the AW database; you can use the AW
database for auditing purposes. When you add the Administration & Data Server component, the retention
period for the Config_Message_Log table in the AW database defaults of 90 days. To change the retention
period, modify the following registry key: Cisco Systems, Inc.\ICM\<instancename>\Distributor

\RealTimeDistributor\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog.

Note

Procedure

Step 1 Open the Web Setup tool.
Step 2 Select Component Management > Administration & Data Servers. Click Add.
Step 3 On the Deployment page, choose the current instance.
Step 4 On the Add Administration & Data Servers page, configure as follows:

a) Click Enterprise.
b) Select the deployment size:
c) Click Next.

Step 5 Select the radio button for your deployment size (either Small to Medium or Large).

For deployment size definitions and guidelines, see the Solution Design Guide for Cisco Unified
Contact Center Enterprise.

Note

Step 6 Click Next.
Step 7 In a Small to Medium Deployment page, select the radio button for your preferred option.

The three options from which to select are:

• Administration Server, Real-time and Historical Data Server and Detail Data Server (AW-HDS-DDS)

• Administration Server and Real-time Data Server (AW)

• Configuration-Only Administration Server

If you select AW-HDS-DDS, you must also specify Enable Historical Detail Data Replication
during Logger setup.

Note

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
40

Installation
Add Administration & Data Server Component to Instance



Before you select a role that includes Historical Database Server (HDS), you must deploy an
HDS database on this instance by running the Cisco Unified Intelligent Contact Management
Database Administration Tool (ICMDBA) on the local machine.

Note

Step 8 Click Next.
Step 9 On the Server Role in a Large Deployment page, select the radio button for your preferred option.

The four options from which to select are:

• Administration Server and Real-time and Historical Data Server (AW-HDS)

• Historical Data Server and Detail Data Server (HDS-DDS)

• Administration Server and Real-time Data Server (AW)

• Configuration-Only Administration Server

If you select AW-HDS or HDS-DDS, you must also specify Enable Historical Detail Data
Replication during Logger setup.

Note

Before you select a role that includes Historical Database Server (HDS), you must deploy an
HDS database on this instance by running ICMDBA on the local machine.

Note

Step 10 Click Next.
Step 11 On the next page of the wizard, enter connectivity information between Primary and Secondary Administration

and Data servers.

Each site has at least one and usually two Administration & Data Servers that serve as real-time
data Administration & Data Servers for the site. The primary Administration & Data Server
maintains an active connection to the real-time server through which it receives real-time data.
If the site has two Administration & Data Servers, Administration Clients are configured to
automatically switch to a secondary Administration & Data Server if the first Administration &
Data Server becomes non-functional for any reason. The secondary Administration&Data Server
also maintains connections to the real-time server; however, these connections remain idle until
needed. The secondary Administration & Data Server uses the primary Administration & Data
Server, as their source for the real-time feed.

Note

Indicate whether the server being setup is the Primary or Secondary Administration & Data Server at the site,
by clicking on the radio button.

Next enter the host name or IP address of the Primary and Secondary Administration and Data Server at the
site. The Secondary Administration and Data Server field is mandatory. If there is no secondary Administration
and Data Server being deployed at the site, then the same host name as that of the primary needs to be provided
in this field.

Each primary and secondary pair must have its own Site Name, and the Site Name must be exactly the same
on both Administration & Data Servers for them to be logically viewed as one.

Step 12 On the Database and Options page, configure as follows:
a) In the Create Database(s) on Drive field, choose C.
b) Uncheck the Configuration Management Service (CMS) Node check box.
c) Check the Internet Script Editor (ISE) Server check box.
d) Click Next.

Step 13 On the Central Controller Connectivity page, configure as follows:
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a) For Router Side A, enter the Router Side A IP address.
b) For Router Side B, enter the Router Side B IP address.
c) For Logger Side A, enter the Logger Side A IP address.
d) For Logger Side B, enter the Logger Side B IP address.
e) Enter the Central Controller Domain Name.
f) Based on the Reference Design of your deployment type, distribute your AW-HDS and HDS-DDS VMs

on Side A or Side B by selecting Central Controller Side A Preferred or Central Controller Side B
Preferred. For details on the Reference Designs, see the Solution Design Guide for Cisco Packaged
Contact Center Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/
packaged-contact-center-enterprise/products-technical-reference-list.html.

g) Click Next.

The Administration & Data Server can connect to the router with a hostname of maximum 15
characters.

Note

Step 14 In the Summary window select the Create Service Account option, and complete the following steps:
a) Enter the domain user.

Verify that the user is created in the specified domain.

b) Enter the valid password.
c) Review the Summary and click Finish.

Use the same domain user account for all the distributor and logger services. If you want to use
different domain accounts for the logger and the distributor, ensure that the distributor service
user account is added to the local logger UcceService groups on Side A and Side B.

Caution

Set up Peripheral Gateways
To set up all the following types of Peripheral Gateways (PG), complete the procedures in this section:

• Cisco Unified Communications Manager PG (CUCM PG)

• Voice Response Unit PG (VRU PG)

• Media Routing PG (MR PG)

• Unified CCE Gateway PG (UCC Enterprise Gateway PG)

Configure Peripheral Gateways in PG Explorer
Follow this procedure to complete the first portion of PG configuration. After this procedure, you add a
peripheral to the PG; you cannot save the configuration unless there is at least one peripheral in the
configuration.

Not all fields apply to all PG types.

Before you begin

Ensure that the Logger, Router, and Distributor services are running.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
42

Installation
Set up Peripheral Gateways

https://www.cisco.com/c/en/us/support/customer-collaboration/packaged-contact-center-enterprise/products-technical-reference-list.html
https://www.cisco.com/c/en/us/support/customer-collaboration/packaged-contact-center-enterprise/products-technical-reference-list.html


Procedure

Step 1 From your desktop, double-click the Unified CCE Tools icon, and open Administration Tools folder from
Unified CCE Tools icon on the desktop.

Step 2 Double-click the Configuration Manager icon.
Step 3 Select Tools > Explorer Tools > PG Explorer Tool.
Step 4 Click Retrieve, then click Add PG.
Step 5 Complete the Logical Controller section as follows:

a) Logical Controller ID—Leave blank. This value is generated automatically when the record is saved.
b) Physical Controller ID—Leave blank. This value is generated automatically when the record is saved.
c) Name—Enter a unique enterprise name for the PG.
d) List Tools —Select Agent Settings.
e) Client Type—Select as follows from the drop-down list:

• For a CUCM PG: CUCM

• For a VRU PG: VRU

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

f) Configuration Parameters—Leave blank.
g) Description—Enter any other information about the PG. Configuration Manager copies this value to the

description fields of the logical interface controller, physical interface controller, peripheral, and (if
applicable) the routing client records.

h) Physical Controller Description—Enter a description for the physical controller.
i) Primary CTI Address—Enter the address for the primary CTI server. Make this entry in the form of

<IP address or server name where the CTI server is installed>: <Client Connection Port Number>.
j) Secondary CTI Address—Enter an address for a secondary CTI server (for duplexed systems).
k) Reporting Interval—Select the 15 or 30 Minute reporting interval option (default is 30 Minute). Unified

CCE software stores historical information in either half-hour or 15-minute summaries (but not both),
based on the reporting interval value that you set. The Router sends these records to the Logger, which
in turn writes them to the Central Database.

Step 6 Do not exit the PG Explorer tool. You add a peripheral to the PG and save the configuration in the next
procedure.

Add Peripherals to Peripheral Gateways
Fields can vary according to PG type.

Procedure

Step 1 With the PG record open in the PG Explorer tool, highlight the PG icon in the tree hierarchy in the lower-left
corner of the window.

Step 2 On the Peripheral tab, enter the following:
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a) Name—Enter a unique enterprise name for this peripheral.
b) Peripheral Name—Enter the name of the peripheral as it is known at the site. Unlike the Enterprise Name

field, the value of this field does not have to be unique. For example, at each site you can label the
peripherals Switch1, Switch2, and so forth.

c) Client Type—Select as follows:

• For a CUCM PG: CUCM

• Configure Agent Desk settings before adding CUCM PG. See Assign Agent Desk Settings

• For a VRU PG: VRU

• Configure Network VRU before adding VRU PG. See Configure Network VRUs, on page 110

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

d) Location—Enter the peripheral's location, for example, the name of a city, building, or department.
e) Abandoned Call Wait Time—Enter the minimum time (in seconds) an incoming call must be queued

before being considered an abandoned call if the caller hangs up.
f) Configuration Parameters—As desired, enter a string containing any parameters that must be sent to

the device to initialize it. In most cases, you leave this field blank.
g) Peripheral Service Level Type—The default type of service level calculation that the peripheral performs

for its associated services. Select Calculated by Call Center.
h) Call Control Variable Map—As desired, enter a string that describes the mappings of the peripheral

call control variables to Unified CCE call control variables.
i) Agent Phone Line Control—Specify one of the following agent phone line control options:

• Single Line: Enables single-line monitoring and reporting (default).

• All Lines: Enables multiline monitoring and reporting.

j) NonACD Line Impact—Specify one of the following nonACD line impact options:

• Available Agent Goes Not Ready: Agent state is set to Not Ready with a system reason code when
the agent answers or calls out on a secondary line while in the Available or Not Ready state.

• Available Agent Stays Available: Agent state is unchanged when agent is on a call on a secondary
line.

k) Description—As desired, enter any additional information about the peripheral.
l) Default Desk Settings—Select as follows:

• For a CUCM PG: Select the Agent Desk Settings that you created earlier

• For a VRU PG: None

• For an MR PG: None

• For a UCC Enterprise Gateway PG: None

m) Enable Post Routing—Check this check box to enable the Unified CommunicationsManager peripheral
to send route requests to the Router. When you check this check box, the Routing Client tab is enabled.
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Step 3 On the Advanced tab, enter the following:
a) Available Holdoff Delay—Set this field to zero.
b) Answered Short Calls Threshold—Maximum duration, in seconds, for a short call. Any calls with a

duration below the threshold are considered short. You can choose to exclude short calls from handle
times you calculate.

c) Network VRU—The type of network VRU. Select as follows:

• For a CUCM PG: None

• For a VRU PG: Select the corresponding Network VRU that you created earlier.

• For an MR PG: Select the Type 2 Network VRU that you created earlier.

• For a UCC Enterprise Gateway PG: None

d) Agent Auto-Configuration—Not supported for Unified CCE. Leave this option disabled.
e) Internal IPTA Only—Be sure that you check this check box for the Unified CCE System PG.
f) Agent Targeting Mode—Determines how the Router builds the labels. Select Rule Preferred.

When this check box is checked, only the local PG can target agents on the PG. The Router uses the skill
group IPTA configuration to select agents. When this check box is unchecked, for calls routed between
different PGs, the Router picks the agent (which minimizes the benefit of the Unified CCE System PG).
Unchecking the check box also requires the creation of more device targets.

Step 4 On the Agent Distribution tab, enter the following:
a) Enable Agent Reporting—Check to allow Unified CCE reporting on agents.
b) Agent Event Detail—Enables label text (as opposed to numeric) Not Ready Reason Code reporting.
c) The Agent Distribution Entries section of this tab contains entries for agent Administration &Data Servers

available for distributing agent report data for the selected peripheral. Click New, then define the values
in the Currently Selected site section of this tab as follows:

• Administration & Data Server site name: The name of the currently selected site in the agent
distribution entries list. For MR PGs, do not specify a name for this field.

• Agent real time data: Check to enable the flow of agent real-time data from the peripheral to the
Administration & Data Server. Uncheck to disable the flow of agent real-time data.

• Agent historical data: Check to enable the flow of agent historical data from the peripheral to the
Administration & Data Server. Uncheck to disable the flow of agent historical data.

Step 5 On the Routing Client tab, enter the following:
a) Name—An enterprise name for this routing client. The name must be unique among all routing clients

in the enterprise.
b) Timeout threshold—The maximum time, in milliseconds, the routing client can wait for a response to

a routing request.
c) Late threshold—The threshold value, in milliseconds, for classifying responses as late. Any response

that exceeds this threshold is considered late even if it does not exceed the Timeout threshold.
d) Timeout limit—The maximum time, in seconds, for which the routing client waits for a response. If the

routing client receives no responses from the Unified CCE system within this limit, it terminates routing
operation.

e) Default media routing domain—Retain the default value, which is None.
f) Default call type—Use this call type for any route request that does not match a defined call type mapping.
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The drop-down list contains all configured call types. The Unified CCE uses the default call type for any
routing request from the routing client that does not otherwise map to a call type. If you do not define a
default call type for the routing client, the Unified CCE uses a general default call type if you define one
through the System Information command.

g) Configuration parameters—Leave blank.
h) Dialed Number/Label map—Indicates whether only specific labels are valid for each dialed number

associated with this routing client (when selected) or whether all labels associated with the routing client
are valid for any dialed number (when not selected). Leave unchecked.

i) Client Type—Select as follows from the drop-down list:

• For a CUCM PG: IPCC/Enterprise Agent

• For a VRU PG: VRU

• For an MR PG: MediaRouting

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

j) Description—More information about the routing client.
k) Network routing client—A name used to associate routing clients across instances.
l) Network transfer preferred—If this check box is checked, indicates that network transfer is preferred.

When the target of a call is reachable by both a label defined for the requesting routing client and by
another label defined for the network routing client that prerouted the call, this option indicates which
choice is preferred.

Step 6 Click Save.
Step 7 Record the Logical Controller ID and Peripheral ID for subsequent use in setting up the PG.

Configure Peripheral Gateway Setup

To ensure that PGs work synchronously, configure the PGs that are collocated on the same physical server
in the same order on both the sides. This must be based on the order in which they are installed and not on
peripheral identifiers. For information on port utilization, refer to the Port Utilization Guide for Cisco Unified
Contact Center Solutions at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html.

Before you enable secured connection between the components, ensure to complete the security certificate
management process.

For more information, see the Security Guide for Cisco Unified ICM/Contact Center Enterprise at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Caution

Procedure

Step 1 Open the Peripheral Gateway Setup tool from Unified CCE Tools on the desktop.
Step 2 Click Add in the Instance Components section.
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Step 3 Click Peripheral Gateway.
Step 4 Complete the following steps in the Peripheral Gateway Properties dialog box.

a) Choose Production Mode. Do not set the Auto Start feature until after the installation is complete.
b) Specify whether the PG is part of a duplexed pair.
c) In the ID field, select from the drop-down list the PG device number as enabled in the Router.
d) If the PG is duplexed, specify whether you are installing Side A or Side B. If the PG is simplex, select

Side A.
e) In the Client Type Selection section of the window, select the client type:

• For a CUCM PG: CUCM

• For a MediaRouting PG: MediaRouting

• For a VRU PG: VRU

• For a UCC Enterprise Gateway PG: UCC Enterprise Gateway

Step 5 Click Add, and then click Next.
Step 6 Enter the Logical Controller ID generated while configuring the PG in the PG Explorer tool. Click Add and

select PIM 1 from the list. Click OK.
Step 7 Configure the PG properties:

a) To put the PIM into service, check the Enabled option. Enabling the PIM allows it to communicate with
the peripheral when the Peripheral Gateway is running.

b) Enter the peripheral name in the Peripheral name field. Usually, the enterprise name from the associated
Peripheral record is themost appropriate name to use.When creating peripheral names, use short descriptive
names and keep the length to a minimum.

c) Enter the Peripheral ID in the Peripheral ID field. This is the ID that you created when you configured
the PG in the PG Explorer tool.

d) For CUCM PG:

1. Enter the Agent extension length.

2. In the CUCM Parameters section, in the Service field, provide the IP address of the CUCM.

3. Enter the credentials of Application User that you created in CUCM.

For more information about Application User, see Set Up Application User , on page 159.

4. Select the appropriate Mobile Agent Codec, and click OK.

e) For MR PG:

• To add MR PG for ECE:

1. In theApplication Hostname (1) field, enter the hostname or the IP address of the ECE services
server. If you have installed two services servers for high availability, provide the information
for the primary service server on Side A.

2. In the Application Connection Port (1) field, enter the port number on the ECE services server
that the PIM will use to communicate with the application. The default port is 38001.

3. In theApplication Hostname (2) andApplication Connection Port (2) fields, enter the hostname
or the IP address of the secondary ECE services server VM and port number on Side B.

Set these values only if you have installed two services servers for high availability.Note
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• To add MR PG for Customer Collaboration Platform:

1. In the Application Hostname (1) field, enter the hostname or the IP address of the Customer
Collaboration Platform.

2. By default, Customer Collaboration Platform accepts the MR connection on Application
Connection Port 38001. The Application Connection Port setting on Customer Collaboration
Platformmust match the setting on the MR PG as specified in theApplication Connection Port
(1) field.

3. Leave the Application Hostname (2) and Application Connection Port (2) fields blank.

• To add MR PG for Outbound Option:

1. In theApplication Hostname (1) field, enter the hostname or the IP address of the BA_IP Dialer.

2. In the Application Connection Port (1) field, enter the connection port for the BA_IP Dialer.
Otherwise, accept the default port number (38001) on the application server machine that the
PIM uses to communicate with the application.

• To add MR PG for any third-party application:

1. In theApplication Hostname (1) field, enter the hostname or the IP address of the multichannel
application server machine.

2. In the Application Connection Port (1) field, enter the port number on the application server
that the PIM will use to communicate with the application. The default port is 38001.

3. If two applications interact with the Unified CCE, in the Application Hostname (2) field, enter
the hostname or the IP address of the second application server machine. If you are using the
hostname, the name must be in the hosts file.

4. For two applications that interact with the Unified CCE, in the Application Connection Port
(2) field, enter the port number on the second application server machine that is used by the PIM.

The below steps are common for any application server:

1. For Heartbeat Interval (seconds), specify how often the PG checks its connection to the call server.
Use the default value.

2. ForReconnect Interval (seconds), specify how often the PG should try to reestablish a lost connection
to the call server. Use the default value.

3. Check the Enable Secured Connection checkbox to enable secured connection.

Enable Secured Connection establishes a secured connection between MR PIM and Application
Server.

Ensure that you provide the correct information in the Application Hostname(1) and Application
Connection Port(1) fields.

f) For VRU PG:

1. In the VRU host name field, enter the name by which the VRU is known to the network.

2. In the VRU connect port field, enter the number of the VRU connection port that the PG connects
to.
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3. In theReconnect interval (sec) field, specify how often, in seconds, the PG tries to re-establish a lost
connection to the VRU. The default value is usually appropriate.

4. In the Heartbeat interval (sec) field, specify how often, in seconds, the PG checks its connection to
the VRU. The default value is usually appropriate.

5. In the DSCP field, use the drop-down box to override the default value and set it to the desired DSCP
value. The list of DSCP values in the drop-down box are the same as what are used during setup for
connection between the Peripheral Gateway (PG) and the CallRouter. On an existing VRU PG system,
this registry key does not exist. In that scenario, the PIM code uses CS3 as the default value when the
VRU PIM process is activated.

6. Check the Enable Secured Connection checkbox to enable secured connection.

This establishes a secured connection between VRU PIM and CVP.

Step 8 Click OK.
Step 9 From the Peripheral Gateway Component Properties window, click Next. The Device Management

Protocol Properties window appears.
a) Enter the appropriate settings and click Next. The Peripheral Gateway Network Interfaces window

appears.
b) Configure the Private Interface and Public interfaces and click Next.

Note:

For the address input fields, use Fully Qualified Domain Names instead of IP addresses.

When there are two IP addresses configured on the public Network Interface Card (for IP-based
prioritization), manually add two A-records on the DNS server. One A-record is for the high priority IP
address and the other one is for the normal priority IP address. The host part of the two DNS entires should
be different from the hostname of Windows server. Use the new DNS entries to configure the public
interfaces. This note applies to the Router and to all PG machines.

Step 10 In the Check Setup Information window, verify the setup information and click Next.
Step 11 When the Setup Complete window appears, click Finish .

When you add new PG, ensure that the PG ID is provided in the Router configuration. Provide
the number that is assigned to the PG in the Enable Peripheral Gateway field in Web Setup

Note

Install Cisco JTAPI Client on PG
After setting up the Cisco Unified Communications Manager (CUCM) PG, you must install the Cisco JTAPI
client. PG uses Cisco JTAPI to communicate with CUCM. Install the Cisco JTAPI client from CUCM
Administration.

Continue with the steps provided in this section if you are installing the JTAPI client for CUCM version earlier
than Release 12.5.

To install the JTAPI client for CUCM, Release 12.5 and above, see Install Cisco JTAPI Client on PG, on
page 50.

Note
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Before you begin

Before you install the JTAPI client, ensure that the previous version is uninstalled.

Procedure

Step 1 Open a browser window on the PG machine.
Step 2 Enter the URL for the Unified Communications Manager Administration utility: http://<Unified

Communications Manager machine name>/ccmadmin.
Step 3 Enter the username and password that you created while installing and configuring the Unified Communications

Manager.
Step 4 Choose Application > Plugins. Click Find.
Step 5 Click the link next to Download Cisco JTAPI for Windows.We recommend you to download the 64 bit

version. However, if you have already downloaded the 32 bit version, you can proceed to step 7.

Download the JTAPI plugin file.

Step 6 Choose Save and save the plugin file to a location of your choice.
Step 7 Open the installer.
Step 8 In the Security Warning box, click Yes to install.
Step 9 Choose Next or Continue through the remaining Setup screens. Accept the default installation path.
Step 10 When prompted for the TFTP Server IP address, enter the CUCM IP address.
Step 11 Click Finish.
Step 12 Reboot the machine.

Install Cisco JTAPI Client on PG

Complete the following procedure only if you are installing JTAPI client to connect to Cisco Unified
Communications Manager, Release 12.5 and above.

Before you begin

Before you install the JTAPI client, ensure that the previous version is uninstalled.

Procedure

Step 1 Open a browser window on the PG machine.
Step 2 Enter the URL for the Unified Communications Manager Administration utility: http://<Unified

Communications Manager machine name>/ccmadmin.
Step 3 Enter the username and password that you created while installing and configuring the Unified Communications

Manager.
Step 4 Choose Application > Plugins. Click Find.
Step 5 Click the link next toDownload Cisco JTAPI Client for Windows 64 bit orDownload Cisco JTAPI Client

for Windows 32 bit.

Download the JTAPI plugin file.
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Step 6 Choose Save and save the plugin file to a location of your choice.
Step 7 Unzip the JTAPI plugin zip file to the default location or a location of your choice.

There are two folders in the unzipped folder CiscoJTAPIx64 and CiscoJTAPIx32.

Step 8 Run the install64.bat file in the CiscoJTAPIx64 folder or run the install32.bat file in the
CiscoJTAPIx32 folder.

The default install path for JTAPI client is C:\Program Files\JTAPITools.

Step 9 To accept the default installation path, click Enter and proceed.

Follow the instructions. Click Enter whenever necessary as per the instructions.

The JTAPI client installation completes at the default location. The following message is displayed:

Installation Complete.

Step 10 Reboot the machine.

What to do next

The default location, where the JTAPI client is installed, also contains the uninstall64.bat and
uninstall32.bat file. Use this file to uninstall this version of the client, if necessary.

Note

Set up CTI Server
Use the PG Setup tool to set up a CTI Server.

Add CTI Server Component

Procedure

Step 1 Open Peripheral Gateway Setup tool from Unified CCE Tools on the desktop.
Step 2 Click Add in the Instance Components section.

The ICM Component Selection dialog box opens.

Step 3 Click CTI Server, and click OK.

The CTI Server Properties dialog box opens.
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Set CTI Server Properties

Procedure

Step 1 In the CTI Server Properties dialog box, check Production mode and Auto start at system startup unless
your Unified CCE support provider tells you otherwise. These settings set the CTI Server Service startup type
to Automatic, so the CTI Server starts automatically when the machine starts up.

Step 2 Check the Duplexed CTI Server option if you are configuring redundant CTI Server machines.
Step 3 In the CG Node Properties section, the numeric portion of the CG node ID must match the PG node ID (for

example, CG 1 and PG 1).
Step 4 The ICM system ID is the Device Management Protocol (DMP) number of the PG associated with the CTI

Gateway. Generally this number is the number associated with the CG ID in step 3.
Step 5 If the CTI Server you add is duplexed, specify which Side you are setting up: Side A or Side B. If the CTI

Server is simplex, choose Side A.
Step 6 Click Next.

The CTI Server Component Properties dialog box opens.

Set CTI Server Component Properties
The CTI Server Component Properties dialog box supports the following modes of connections:

• Secured and Non-Secured Connection (Mixed-mode): Allows secured and non-secured connection
between the CTI Server and the CTI clients.

• Secured-Only Connection: Allows secured connection between the CTI Server and the CTI clients.

Non-Secured only mode is not supported.Important

To enable secured connection between the components, ensure to complete the security certificate management
process.

For more information, see the chapter Certificate Management for Secured Connections in Security Guide
for Cisco Unified ICM/Contact Center Enterprise at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

Note

In the CTI Server Component Properties dialog box, setup automatically displays the default Secured
Connection Port and the Non-Secured Connection Port values. Use these values or change them to the
required port numbers. CTI clients use these ports to connect to the CTI Server.

If you have multiple CTI servers running on a single machine, each CTI server must use a different port
number set for Secured connection and Mixed-mode connection.
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Procedure

Step 1 Select the appropriate connection type.
a) For Secured Connection, check the Enable Secure-Only Mode check box.

This option disables the Non-Secured Connection Port field.

b) For Mixed-mode connection, ensure that the Enable Secure-Only Mode check box is unchecked.

This is the default connection mode.

Step 2 To ensure that an agent is logged in to the client before the client receives events from the CTI Server, check
the Agent Login Required for Client Events check box. This ensures that the clients are prevented from
accessing data for other agents.

Step 3 Click Next.

The CTI Server Network Interface Properties dialog box opens.

Set CTI Server Network Interface Properties

Procedure

Step 1 In the CTI Server Network Interface Properties dialog box, in the PG public interfaces section, enter the
public network addresses for the PGs associated with the CTI Server.

Step 2 In the CG private interfaces section, enter the private network addresses of the CTI Server.
Step 3 In the CG visible interfaces section, enter the public network addresses of the CTI Server.
Step 4 Click Next.

The Check Setup Information window opens.

Complete CTI Server Setup

Procedure

Step 1 In the Check Setup Information window, ensure that the settings displayed are as you intended. If you want
to modify any settings before proceeding, use the Back button.

Step 2 When the settings are correct, click Next.
Step 3 The final screen displays and asks whether you want to start the Node Manager now.
Step 4 Click Finish to exit setup (and optionally start the Node Manager).

If you choose to start it, the Node Manager automatically starts the other Unified CCE processes on the CTI
Server.
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Install Unified CCE Administration Client

Install Administration Client
Don’t install the Administration Client on a system that already has other Unified CCE software installed;
the Administration Client must reside on a standalone machine. AdminClientInstaller is available in the
Unified CCE Installer ISO image .

For information on supported operating systems, see the Contact Center Enterprise Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html

If Microsoft .Net Framework 4.7.2 is not installed before installing the administration client, then run the
following command to avoid delay in launching the administration client for the first time:

• For 32-bit: %SYSTEMDRIVE%\Windows\Microsoft.NET\Framework\v4.0.30319>ngen.exe
executequeueditems

• For 64-bit: %SYSTEMDRIVE%\Windows\Microsoft.NET\Framework64\v4.0.30319>ngen.exe
executequeueditems

Note

Procedure

Step 1 Mount the Unified CCE Installer ISO image to the virtual machine. For more information, see Mount ISO
Files, on page 15.

Step 2 Launch AdminclientInstaller from AdminClientInstaller folder.

The Administration Client Installer program proceeds through a series of screens on which you specify
information.

Step 3 When the installation is complete, reboot the server.

Set up Administration Client
You cannot run the Administration Client Setup tool remotely through a browser. Run the tool on the local
machine.

Before you begin

Any user who is a local administrator on the machine and a domain user can log in. However, to view the
lists and to perform tasks with the Administration Client Setup tool, you must have the following permissions:

• Administrator on the local machine

• Either a domain administrator or a member of at least one Setup security group in the machine domain.
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Procedure

Step 1 Open the Administration Client Setup tool from Unified CCE Tools shortcut on the desktop.
Step 2 Sign in as a domain user with local Administrator rights.
Step 3 Click Instance Management, and then click Add.
Step 4 On the Add Instance page, from the drop-down list, choose the customer facility and instance.
Step 5 Enter an instance number.

The same instance name can occur more than once in a domain, so the instance number provides the uniqueness.
The instance number must be between 0 and 24. The instance number must match for the same instance across
your entire deployment. For an Enterprise (single instance) deployment, select 0 unless there is a reason to
choose another value.

Step 6 Click Save.
Step 7 Select Component Management > Administration Clients.
Step 8 Click Add.
Step 9 Select an instance for the Administration Client from the drop-down list.
Step 10 Click the radio button for your Administration Client type.
Step 11 Enter the hostname or IP address of the Primary and Secondary Administration & Data Servers. If you have

only one Administration & Data Server, specify it for both Primary and Secondary Administration & Data
Servers; both fields are required

Step 12 Click Save.

Install Unified CCE Language Pack
The Unified CCE Language pack is used to install the localized version of the help files of the Unified CCE
Web Administration tool.

The Unified CCE Language pack also contains the customized version of Configuration Manager tools for
east Asian locales like Chinese, Japanese and Korean. The language pack enables localized input to be entered
in those Configuration Manager tool sets.

These tool sets include some of the following tools:

• Explorer Tools

• List Tools

• System Information

• Outbound Option related tools

Update the Java Runtime Environment (Optional)
Before updating the Java Runtime Environment (JRE),

• Export the certificates of all the components imported into the truststore.

The command to export the certificates is
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• Enter the truststore password when prompted.

Themain Unified CCE Installer installs the Java Runtime Environment (JRE) to a default location (for example,
C:\Program Files (x86)\Java\jre<version>) and creates a JAVA_HOME environment variable set to that
location. In most circumstances, you do not need to modify or configure the JRE after the Unified CCE
installation. For information on the version installed, see the Java requirements in theContact Center Enterprise
Compatibility Matrix at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-device-support-tables-list.html.

If required, you can update the JRE installed by the Unified CCE installation to a later version.

To update the Unified CCE JRE to a later version:

1. Review and see the Java requirements in the Contact Center Enterprise Compatibility Matrix to confirm
that Unified CCE supports the JRE version you want to install.

2. Follow the JRE installer procedure to install the JRE to the VM on which your Unified CCE components
are installed.

3. Set the JAVA_HOME environment variable to the location of the new JRE.

4. Restart the virtual machine.

The ICM-CCE-Installer installs the version of Java that is listed in theContact Center Enterprise Compatibility
Matrix. If an older version of JRE is currently installed on the deployment machine, the installer does not
uninstall it, you must manually uninstall it.

Note

After updating the Java Runtime Environment (JRE),

• Import the certificates for all the components that you previously exported from the truststore before you
updated the JRE.

The command to import certificates is keytool -import -keystore <JRE path>\lib\security\cacerts -file
<filepath>.cer -alias <alias>.

• Enter the truststore password when prompted.

• Enter 'yes' when prompted to trust the certificate.

Upgrade Tomcat Utility
Use the optional Cisco Upgrade Tomcat Utility to:

• Upgrade Tomcat to version 7.0 build releases. (That is, only version 7.0 build releases work with this
tool.) Youmay choose to upgrade to newer builds of Tomcat release 7.0 to keep up with the latest security
fixes.

Tomcat uses the following release numbering scheme: Major.minor.build. For example, you can upgrade
from 7.0.62 to 7.0.65 . You cannot use this tool for major or minor version upgrades.

Revert a Tomcat upgrade.
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If you use the utility to upgrade Tomcat multiple times, you can revert to only
one version back of Tomcat. For example, if you upgrade Tomcat from 7.0.62
to 7.0.63, and then to 7.0.75, the utility reverts Tomcat to 7.0.63.

Note

Before using the tool:

• Download the Tomcat installer (apache-tomcat-version.exe) from the Tomcat website:
http://archive.apache.org/dist/tomcat/tomcat-7/ . Copy the installer onto the Unified CCE component
VMs. For Example C:\UpgradeTomcatTool.

• Download the utility zip file, extract it, and run the file to upgrade Tomcat.

Download link:

• Delete or back up large log files in these directories to reduce upgrade time:

<ICM install directory>:\icm\tomcat\logs
<ICM install directory>:\icm\debug.txt

Upgrade Tomcat
For detailed information on the results from each step, see the ../UpgradeTomcatResults/UpgradeTomcat.log
file.

Stop Unified CCE services on the VM before using the Tomcat Utility.Note

Procedure

Step 1 From the command line, navigate to the directory where you copied the Upgrade Tomcat Utility.
Step 2 Enter this command to run the tool: java -jar UpgradeTomcatTool-<version>.jar -upgrade

Step 3 When prompted, enter the full pathname of the new Tomcat installer.

For example:
c:\tomcatInstaller\apache-tomcat-<version>.exe

Step 4 When prompted, enter yes to continue with the upgrade.
Step 5 Repeat these steps for all unified CCE component VMs.

Revert Tomcat
For detailed information on the results from each step, see the ../UpgradeTomcatResults/UpgradeTomcat.log
file.
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Stop Unified CCE services on the VM before using the Tomcat Utility.Note

Procedure

Step 1 From the command line, navigate to the directory where you copied the Upgrade Tomcat Utility.
Step 2 Enter this command to run the tool: java -jar UpgradeTomcatTool-<version>.jar -revert

Step 3 When prompted, enter yes to continue with the reversion.
Step 4 Repeat these steps for all unified CCE component VMs.

Silent Installation
In certain situations, such as when a system administrator wants to install or upgrade software silently on
multiple systems simultaneously, a silent installation is performed to run an installation wizard.

Silent Installation Prerequisites for Unified CCE Release 12.5(1)
Before running a silent installation, complete the following tasks:

• Stop all applications that are running on the system.

• By default, silent installation assumes the following parameter: Install on Drive C.

To override this default, edit the ICMCCSilentsetup.ini file in the ICM-CCE-Installer directory.

• Mount the ISO image to the target machine, and make the following edits on the target machine:

• If you are performing a Technology Refresh upgrade, change the szInstallType from 0 to 1. The
default value of 0 is for a Fresh Install.

• If you are performing a Technology Refresh upgrade, provide a path for the szExportedRegistryPath
parameter where the exported registry from source machine is placed.

• To change the drive on which you are installing the application, change the szDrive parameter.
Replace C with the drive where you want to install.

• If you do not want to apply SQL Security Hardening, change the line that reads szSQLSecurity=1
to szSQLSecurity=0.

You can apply SQL Security Hardening during the installation, or you can use the Security Wizard to apply
it after the install.

Note
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Perform a Silent Installation for Unified CCE Release 12.5(1)

Procedure

Step 1 Mount the Installation ISO image to the target machine. For more information, see Mount ISO Files, on page
15.

Step 2 From a command prompt window, navigate to the ICM-CCE-Installer directory.
Step 3 Enter the command setup.exe /s.

Installation starts. Upon successful installation, the server reboots.

Step 4 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade
planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

If the installation is not successful, no error message appears in the command prompt window. You must
check the installation log file <SystemDrive>:\temp\ICMInstall.log to determine the reason why
the installation failed.

Note

Set Deployment Type in Unified CCE Administration Configuration
Perform the following steps to set the deployment type.

For more information on deployment types, see the following document:

Solution Design Guide for Cisco Unified Contact Center Enterprise at http://www.cisco.com/en/US/products/
sw/custcosw/ps1844/products_implementation_design_guides_list.html

Procedure

Step 1 On Administration & Data Server, from the desktop open the Unified CCE Tools folder and navigate to:
Administration Tools > CCE Web Administration .

Step 2 Log in as a Config security group member in the format user@domain.
Step 3 Double-click Unified CCE Administration.
Step 4 Click Infrastructure Settings > Deployment Settings.
Step 5 On the Deployment Type page, select your deployment from the drop-down menu and click Next.
Step 6 Click Done.
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Cisco Finesse Server Installation
Cisco Finesse server is installed on a virtual machine (VM). The installation runs from an ISO image and uses
an OVA template. For more information, see Cisco Finesse Installation and Upgrade Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/finesse/products-installation-guides-list.html.

Configure a DataStore ISO file on the virtual CD/DVD drive of the target VM to install Finesse.Note

The installation takes about an hour. For most of that time, it can run unattended. Much of the installation
requires no action on the part of the person who runs it. When user input is required, use the following keyboard
navigation and selection actions. The installation wizard screens do not recognize a mouse or a touchpad.

Press this keyTo do this

TabMove to the next field.

Alt-TabMove to the previous field.

SpacebarSelect an option.

Up or Down Arrow keysScroll up or down a list.

Tab to Back and press the SpacebarGo to the previous screen.

Tab to Help and press the SpacebarGet information about a screen.

Installation Task Flow
The following table provides an overview of the tasks you perform to install Cisco Finesse. Tasks must be
performed in the order they are listed.

See Install Finesse on Primary Node, on page 61.Install Finesse on the primary node.1

See Configure Contact Center Enterprise Administration
& Data Server Settings, on page 64.

Configure the database settings.2

See Configure Contact Center Enterprise CTI Server
Settings, on page 168

Configure the CTI server settings.3

See Restart Cisco Finesse Tomcat, on page 67.Restart Cisco Finesse Tomcat on the
primary node.

4

See Validate Configuration, on page 68Validate configuration5

See Configure Cluster Settings, on page 68.Configure the cluster settings for the
secondary node.

6

See Install Finesse on Secondary Node, on page 68.Install Finesse on the secondary node.7

See Check Replication Status, on page 71.Ensure replication is functioning between
the two nodes.

8
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See Install language pack.Install language packs (optional).8

See Install VMware Tools for VOS, on page 18Install VMware Tools9

Install Finesse on Primary Node

Procedure

Step 1 Follow the instructions in the OVA README.txt file to import and deploy the OVA, to edit VM settings,
and to power on the VM and edit the BIOS settings in the console. For more information, see the section on
Installation Files.

Do not use Thin Provisioning or a VM snapshot when creating a VM to host Cisco Finesse. The
use of Thin Provisioning or snapshots can negatively impact the performance of Cisco Finesse
operation.

Note

Messages appear while the preinstallation script runs. When the preinstallation script ends, the DVD Found
screen opens.

Step 2 Select OK on the Disk Found screen to begin the verification of the media integrity and a brief hardware
check.

If the media check passes, select OK to open the Product Deployment Selection screen. Continue to Step 3.

If the media check fails, the installation terminates.

Step 3 The Product Deployment Selection screen states that the Cisco Finesse product suite will be installed. This
screen has only one choice: OK.

Select OK to open the Proceed with Install screen.

Step 4 The Proceed with Install screen shows the version of the product that is currently installed (if any) and the
version of the product for this ISO. For the initial installation, the version currently installed shows NONE.

Select Yes on the Proceed with Install screen to open the Platform Installation Wizard screen.

Step 5 On the Platform Installation Wizard screen, select Proceed to open the Basic Install screen.
Step 6 Select Continue on the Basic Install screen to open the Basic Install wizard.

The Basic Install wizard presents a series of screens that present questions and options pertinent to the platform
and the setup configuration. Help is available for each wizard screen.

The first Basic Install wizard screen is Timezone Configuration.

Step 7 On the Timezone Configuration screen:
a) Use the up and down arrows to locate the local time zone that most closely matches your server location.

You can also type the initial character of the time zone to move to that item in the list. The Timezone field
is based on country and city and is mandatory. Setting it incorrectly can affect system operation.

b) Select OK to open the Auto Negotiation Configuration screen.

Step 8 On the Auto Negotiation Configuration screen, select Continue to use automatic negotiation for the settings
of the Ethernet network interface card (NIC).

The MTU Configuration screen appears.
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Step 9 In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units
(1500).

Finesse supports the default setting of 1500 for MTU only. No other value is supported.Note

Your selection of No opens the Static Network Configuration screen.

Step 10 On the Static Network Configuration screen, enter static network configuration values as follows, referring
to the Configuration Worksheet if necessary:
a) Enter the Host Name.
b) Enter the IP Address.
c) Enter the IP Mask.
d) Enter the GW Address.
e) Select OK to open the Domain Name System (DNS) Client Configuration screen.

Step 11 On the DNS Client Configuration screen, select Yes to specify the DNS client information.

DNS client configuration is mandatory for Cisco Finesse. Select Yes on this screen. If you select
No, after the installation is complete, agents cannot sign in to the desktop and you have to reinstall
Finesse.

Important

Step 12 Specify your DNS client information as follows, referring to the Configuration Worksheet if necessary:
a) Enter the Primary DNS (mandatory).
b) Enter the Secondary DNS (optional).
c) Enter the Domain (mandatory).
d) Select OK to open the Administrator Login Configuration screen.

Step 13 On the Administrator Login Configuration screen:
a) Enter the credentials for the administrator.
b) Select OK to open the Certificate Information screen.

Step 14 On the Certificate Information screen:
a) Enter the following data to create your Certificate Signing Request: Organization, Unit, Location, State,

and Country.
b) Select OK to open the First Node Configuration screen.

Step 15 On the First Node Configuration screen, select Yes to indicate that you are configuring the first node.

Your selection of Yes opens the Network Time Protocol Client Configuration screen.

Step 16 On the Network Time Protocol Client Configuration screen, enter the IP address, NTP server name, or NTP
Server Pool name for at least one external NTP server.

Step 17 After you complete the NTP configuration, select OK. This action opens the Security Configuration screen.
Step 18 On the Security Configuration screen, enter the Database Access Security password, and then select OK.
Step 19 On the Application User Configuration screen, enter the credentials for the application user.

Select OK to open the Platform Configuration Confirmation screen. This screen states that the platform
configuration is complete.

Step 20 On the Platform Configuration Confirmation screen, select OK.

The installation begins.

The installation can take up to an hour to complete and can run unattended for most of that time.
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During the installation, the monitor shows a series of processes, as follows:

• Formatting progress bars

• Copying File progress bar

• Package Installation progress bars

• Post Install progress bar

• Populate RPM Archive progress bar

• Application Installation progress bars (multiple Component Install screens, security checks)

• An informational screen saying the system will reboot momentarily to continue the installation

If you see the following virtual machine question, select Yes, and then click OK:

Figure 1: Virtual Machine Message

• A system reboot

Messages stream down your monitor during the reboot. Some of them prompt you to press a key. Do
not respond to these prompts to press a key.

• Application Pre Install progress bars

• Configure and Setup Network progress bars

If a Network Connectivity Failure screen appears during the Configure and Setup Network
process, clickReview, and then clickOK at the Errors screen. Follow the prompts to reenter
the information that caused the failure. The installation continues when the connection
information is complete.

Note

• Security configuration

A message appears that states the installation of Cisco Finesse has completed successfully.
The installation of Cisco Finesse has completed successfully.

Cisco Finesse <version number>
<hostname> login: _
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What to do next

Sign in to the Finesse administration console on the primary Finesse server (https://FQDN of Finesse
server:8445/cfadmin) to configure CTI server, Administration & Database server, and cluster settings.

After you configure these settings, install Finesse on the secondary node.

Configure Contact Center Enterprise Administration & Data Server Settings
Configure the Contact Center Enterprise Administration & Data Server settings to enable authentication for
Cisco Finesse agents and supervisors.

If you are using HTTPS, the first time you access the administration console, you see a browser security
warning. To eliminate browser security warnings each time you sign in, you can trust the self-signed certificate
provided with Finesse or obtain and upload a CA certificate.

Note

Procedure

Step 1 Sign in to the administration console.
Step 2 In the Contact Center Enterprise Administration &Data Server Settings area, enter the Administration &Data

Server settings as described in the following table. Refer to your configuration worksheet if necessary.

DescriptionField

The hostname or IP address of the Unified CCE Administration &
Data Server. For example, abcd12-5-aw-a.

Primary Host/IP Address

The hostname or IP address of the backup Unified CCE
Administration & Data Server. For example, abcd12-5-aw-b.

Backup Host/IP Address

The port of the Unified CCE Administration & Data Server.

The default value is 1433.

Cisco Finesse expects the primary and backup
Administration & Data Server ports to be the same,
hence the Finesse administration console exposes one
port field. You must ensure that the port is the same for
the primary and backup Administration&Data Servers.

Note

Database Port

The name of the AW Database (AWDB). For example,
ucceinstance_awdb.

AW Database Name

The domain name of the AWDB. For example, cisco.com.Domain
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DescriptionField

The username required to sign in to the AWDB.

If you specify a domain, this user refers to the
Administrator Domain user that the AWDB uses to
synchronize with the logger. In which case, the AWDB
server must use Windows authentication and the
configured username must be a domain user.

If you do not specify a domain, this user must be an
SQL user.

Note

Username

The password required to sign in to the AWDB.Password

Step 3 Click Save.

Contact Center Enterprise CTI Server Settings
Use the Contact Center Enterprise CTI Server Settings gadget to configure the A and B Side CTI servers.

All fields on this tab are populated with default system values or with values an administrator has previously
entered. Change values to reflect your environment and preferences.

For configuring secure connection select the Enable SSL encryption check box.

Test the CTI connection for given configuration using the Test Connection button.

After you make any changes to the values on the Contact Center Enterprise CTI Server Settings gadget, you
must restart all the nodes of Cisco Finesse Tomcat. To make changes to other settings (such as Contact Center
Enterprise Administration&Data Server settings), you canmake those changes and then restart Cisco Finesse
Tomcat.

If you restart Cisco Finesse Tomcat, agents must sign out and sign in again. As a best practice, make changes
to CTI server settings and restart the Cisco Finesse Tomcat Service during hours when agents are not signed
in to the Finesse desktop.

The secure encryption and Test Connection functionality is supported only from Unified CCE 12.0.

Note

Although the B Side Host/IP Address and B Side Port fields are not shown as required, A and B Side CTI
servers are mandatory for a production deployment of Unified CCE and Cisco Finesse.

Note

The following table describes the fields on the Contact Center Enterprise CTI Server Settings gadget:
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ExplanationField

The hostname or IP address of the A Side CTI server.
This field is required.

This value is typically the IP address of the Peripheral
Gateway (PG). The CTI server runs on the PG.

A Side Host/IP Address

The value of this field must match the port configured
during the setup of the A Side CTI server.

This field is required and accepts values between 1
and 65535.

You can find this value using the Unified CCE
Diagnostic Framework Portico tool on the PG box.
For more information about Diagnostic Framework
Portico, see the Serviceability Guide for Cisco Unified
ICM/Contact Center Enterprise.

The default value is 42027.

A Side Port

The ID of the Agent PG Routing Client (PIM).

The Agent PG Peripheral ID should be configured to
the same value for the A and B Side CTI server.

This field is required and accepts values between 1
and 32767.

The default value is 5000.

Peripheral ID

The hostname or IP address of the B Side CTI server.B Side Host/IP Address

The value of this field must match the port configured
during the setup of the B Side CTI server.

This field accepts values between 1 and 65535.

B Side Port

Check this box to enable secure encryption.Enable SSL encryption

Actions on the Contact Center Enterprise CTI Server Settings gadget:

• Save: Saves your configuration changes.

• Revert: Retrieves the most recently saved server settings.

• Test Connection: Tests the CTI connection.

CTI Test Connection

When you click Test Connection:

1. Input validation is done on the request attributes.

Host/IP Address must not be empty. Port and Peripheral IDs must be within the valid range.

2. Validation is done to check if the provided Host/IP is resolved by Finesse box.
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3. Validation is done to check if AW Database is reachable and if a valid path ID is configured for the
provided Peripheral ID.

4. Socket connection is established to the provided Host/IP and port. The connection might fail if there is
no route to the provided IP. If SSL encryption box is checked, this step also checks for successful TLS
handshake. For TLS handshake to be successful, mutual trust has to be established between Finesse and
CTI server.

For information on how to establish trust between Finesse and CTI server, see Security Guide for Cisco
Unified ICM/Contact Center Enterprise at https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html

5. After successful socket connection, a CTI initialization request is sent to check if the provided host is a
CTI host.

If the CTI response is a success for the CTI initialization request and peripheral provided is configured
with Unified CCE, it is confirmed to be a CTI host.

6. CTI connection is closed by sending a CTI session close request.

If Test Connection is successful for Side A or B of the CTI cluster and the other side fails, it is a valid
configuration as CTI server works in active-passive mode and connects to the active node. Inactive CTI node
will refuse connection on the CTI port. However, Administrator has to ensure that the failed side also has a
valid entry for CTI host and port field. System cannot verify this due to server restrictions.

If Test Connection is successful on Side A and B of the CTI cluster, then there is an error in the system
configuration. Verify that the Side A and B of the CTI node have valid entries for port and host.

Test connection API success result does not guarantee peripheral to be online. It only validates if the peripheral
provided is configured with Unified CCE.

Test connection API with insecure connection parameter will function as intended for earlier versions of
Unified CCE deployments.

Note

Restart Cisco Finesse Tomcat
After youmake changes to the Contact Center Enterprise CTI Server, Contact Center Enterprise Administration
& Data Server, or cluster settings, restart Cisco Finesse Tomcat for the changes to take effect.

After you restart Finesse, it can take approximately 6minutes for all server-related services to restart. Therefore,
you wait 6 minutes before you attempt to access the Finesse administration console.

Note

Procedure

Step 1 Access the CLI and run the following command:

utils service restart Cisco Finesse Tomcat
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Step 2 You can enter the command utils service list to monitor the Cisco Finesse Tomcat Service. After Cisco Finesse
Tomcat changes to STARTED, the configured agents can sign in to the desktop.

Validate Configuration
After starting the Tomcat service, you must test the configuration for the changes you have made.

Procedure

Step 1 Log in to the GUI
Step 2 Click Test to test the configuration changes.

Validation errors, if any, in the configuration are displayed.

If there are any errors, you must restart the Tomcat service after you resolve the errors.

Configure Cluster Settings
Configure the cluster settings for the secondary Finesse node. The secondary Finesse node handles agent
requests if the primary server goes down.

Procedure

Step 1 If you are not already signed in the primary node, sign in to the administration console of the primary node
with the Application User credentials.

Step 2 In the Cluster Settings area, in the Hostname field, enter the hostname of the secondary Finesse server.
Step 3 Click Save.

Install Finesse on Secondary Node
Install the same version of Finesse on both the primary and secondary Finesse nodes.

Configure a Datastore ISO file on the virtual CD/DVD drive of the target VM to install Finesse.Note

Finesse administration tasks can only be performed on the primary Finesse server. After you install the
secondary server, sign in to the administration console on the primary server to perform administration tasks
(such as configuring reason codes or call variable layout).

Note
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Before you begin

• Install Finesse on the primary server. See Install Finesse on Primary Node.

• Use the Finesse administration console on the primary Finesse server to configure CTI server,
Administration & Database server, and cluster settings.

• Ensure that the DNS server has forward and reverse DNS set up for both the primary and secondary
node.

Procedure

Step 1 Follow the instructions in the OVA README.txt file to import and deploy the OVA, to edit VM settings,
and to power on the VM and edit the BIOS settings in the Console.

Messages appear while the preinstallation script runs. When the preinstallation script ends, the DVD Found
screen opens.

Step 2 Select Yes on the DVD Found screen to begin the verification of the media integrity and a brief hardware
check.

If the media check passes, select OK to open the Product Deployment Selection screen. Continue to Step 3.

If the media check fails, the installation terminates.

Step 3 The Product Deployment Selection screen states that the Cisco Finesse product suite will be installed. This
screen has only one option: OK.

Select OK to open the Proceed with Install screen.

Step 4 The Proceed with Install screen shows the version of the product that is currently installed (if any) and the
version of the product for this ISO. For the initial installation, the version currently installed shows NONE.

Select Yes on the Proceed with Install screen to open the Platform Installation Wizard screen.

Step 5 On the Platform Installation Wizard screen, select Proceed to open the Basic Install screen.
Step 6 Select Continue on the Basic Install screen to open the Basic Install wizard.

The Basic Install wizard presents a series of screens that present questions and options pertinent to the platform
and the setup configuration. Help is available for each wizard screen.

The first Basic Install wizard screen is Timezone Configuration.

Step 7 In the Timezone Configuration screen:
a) Use the up and down arrows to locate the local time zone that most closely matches your server location.

You can also type the initial character of the time zone to move to that item in the list. The Timezone field
is based on country and city and is mandatory. Setting it incorrectly can affect system operation.

b) Select OK to open the Auto Negotiation Configuration screen.

Step 8 On the Auto Negotiation Configuration screen, select Continue to use automatic negotiation for the settings
of the Ethernet network interface card (NIC).

The MTU Configuration screen appears.

Step 9 On the MTU Configuration screen, select No to keep the default setting for Maximum Transmission Units
(1500).
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Finesse supports the default setting of 1500 for MTU only. No other value is supported.Note

Your selection of No opens the Static Network Configuration screen.

Step 10 On the Static Network Configuration screen, enter the static network configuration values as follows, referring
to the Configuration Worksheet if necessary:
a) Enter the Host Name.
b) Enter the IP Address.
c) Enter the IP Mask.
d) Enter the GW Address.
e) Select OK to open the Domain Name System (DNS) Client Configuration screen.

Step 11 On the DNS Client Configuration screen, select Yes to specify the DNS client information.

IMPORTANT: DNS client configuration is mandatory for Cisco Finesse. Select Yes on this screen. If you
select No, after the installation is complete, agents can't sign in to the desktop and you have to reinstall
Finesse.

Step 12 Specify your DNS client information as follows, referring to the Configuration Worksheet if necessary:
a) Enter the Primary DNS (mandatory).
b) Enter the Secondary DNS (optional).
c) Enter the Domain (mandatory).
d) Select OK to open the Administrator Login Configuration screen.

Step 13 On the Administrator Login Configuration screen:
a) Enter the credentials for the administrator.
b) Select OK to open the Certificate Information screen.

Step 14 On the Certificate Information screen:
a) Enter the following data to create your Certificate Signing Request: Organization, Unit, Location, State,

and Country.
b) Select OK to open the First Node Configuration screen.

Step 15 On the First Node Configuration screen, select No to indicate that you’re configuring the second node.

A warning message appears that indicates you must first configure the server on the first node before you can
proceed. If you already configured the first node, select OK.

Step 16 On the Network Connectivity Test Configuration screen, select No to proceed with the installation after
connectivity is verified.

Step 17 On the First Node Configuration screen, specify the information about the first node as follows:
a) Enter the Host Name of the primary Finesse server.
b) Enter the IP Address of the primary Finesse server.
c) Enter the Security Password of the primary Finesse server.
d) Confirm the Security Password.

Step 18 Select OK to open the Platform Configuration Confirmation screen.
Step 19 On the Platform Configuration Confirmation screen, select OK.

The installation begins.

The installation can take up to an hour to complete and can run unattended for most of that time.

A message appears that states the installation of Cisco Finesse has completed successfully.
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The installation of Cisco Finesse has completed successfully.

Cisco Finesse <version number>
<hostname> login: _

What to do next

Check the replication status. If all nodes in the cluster show a replication status of 2, replication is functioning
correctly.

After installation, by default the configuration that controls the reverse-proxy authentication is enabled.When
the reverse-proxy authentication is enabled and multiple client-side certificates are configured on the system,
it impacts the certificate acceptance pop-ups from clients that are connected directly to the Finesse server
without using a reverse-proxy. To prevent these pop-ups from appearing, use the utils systems reverse-proxy
client-auth command on both the Finesse nodes to disable the reverse-proxy authentication that don’t need
VPN-less access to Finesse.

It can take 10–20 minutes to establish replication fully between the two nodes.

To access platform-specific applications like Disaster Recovery System, Cisco Unified Serviceability, and
Cisco Unified Operating SystemAdministration, use the following URL, https://FQDN of Finesse server:8443.

Note

Check Replication Status

Procedure

Step 1 Access the CLI on the primary Finesse server.
Step 2 Sign in with the Administrator User credentials that are defined during installation.
Step 3 Run the following command:

utils dbreplication runtimestate

This command returns the replication status on both the primary and secondary Finesse servers.

Install Cisco Identity Service Standalone Deployment
Follow this sequence of tasks to install the Cisco Identity Service (Cisco IdS) standalone deployment.

TaskSequence

Verify that you created a separate virtual machine for the IdS publisher node and the IdS
subscriber node. See Set Up Virtual Machines, on page 10.

1

Install IdS publisher node. See

Install Publisher/Primary Node of Cisco Identity Service , on page 72

2
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TaskSequence

Set IdS subscriber node. See Set IdS Subscriber Node, on page 733

Install IdS subscriber node. See

Install Subscriber/Secondary Node of Cisco Identity Service , on page 74

4

Upgrade VMware Tools. See Install VMware Tools for VOS, on page 185

Install Publisher/Primary Node of Cisco Identity Service

Before you begin

DNS Configuration is mandatory for installation of Cisco Identity Service. To configure DNS, add the VMs
to the forward and reverse lookups of the DNS.

If the deployment uses host files in addition to DNS, use FQDNs in the host file.Note

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, select Cisco Identity Service and click OK.
d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
n) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
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o) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,
Unit, Location, State, and Country. Select OK.

p) In the First Node Configuration screen, select Yes.
q) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
r) In the Security Configuration screen, enter the security password and select OK.
s) In the SMTP Host Configuration screen, select No.
t) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
u) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.

Set IdS Subscriber Node
Youmust provide the publisher node the address of the subscriber node. You do this with the set ids subscriber
command.

Procedure

Step 1 Log in to your publisher IdS node.
Step 2 Run the following command to set the subscriber node:

set ids subscriber name
name

Specifies the hostname or ip address of the IdS subscriber node address.

What to do next

You can use these Cisco IdS CLI commands only in an IdS standalone deployment. You run these commands
on the IdS publisher node.

Required Minimum Privilege Level: Ordinary

Use this command to show IdS subscriber node information.

show ids subscriber

There are no required parameters.

Required Minimum Privilege Level: Advanced

Use this command to unset IdS subscriber node configuration.
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unset ids subscriber

There are no required parameters.

Install Subscriber/Secondary Node of Cisco Identity Service

Before you begin

DNS Configuration is mandatory for installation of Cisco Identity Service. To configure DNS, add the VMs
to the forward and reverse lookups of the DNS.

If the deployment uses host files in addition to DNS, use FQDNs in the host file.Note

Before you install the subscriber/secondary nodes, youmust install the publisher/primary nodes and configure
the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, select Cisco Identity Service and click OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same time zone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
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n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.

Live Data Standalone Installation
Follow this sequence of tasks to install Live Data Standalone.

TaskSequence

For all deployments except the 2000 agent reference design, verify that you created a separate
virtual machine for the IdS publisher node and the IdS subscriber node. See Set Up Virtual
Machines, on page 10.

1

Install Live Data Primary Node.

See Install Publisher/Primary Node of Live Data , on page 75

2

Set Live Data Secondary Node, on page 773

Install Live Data Secondary Node.

See Install Subscriber/Secondary node of Live Data , on page 77

4

Upgrade VMware Tools. See Install Vmware Tools, on page 17.5

Configure Live Data with AW, on page 786

Configure Live Data Machine Services, on page 797

Configure Live Data for Unified Intelligence Center Data Sources, on page 808

Restart Live Data, on page 819

Set Up Certificates for Live Data, on page 8110

Install Publisher/Primary Node of Live Data

Before you begin

DNSConfiguration is mandatory for installation of Live Data. To configure DNS, add the VMs to the forward
and reverse lookups of the DNS.
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If the deployment uses host files in addition to DNS, use FQDNs in the host file. Live Data and single sign-on
(SSO) require FQDNs to work properly.

Note

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, select Live Data and click OK.
d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
n) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
o) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
p) In the First Node Configuration screen, select Yes.
q) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
r) In the Security Configuration screen, enter the security password and select OK.
s) In the SMTP Host Configuration screen, select No.
t) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
u) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.
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Step 5 Unmount the ISO image.

Set Live Data Secondary Node
Use the set live-data secondary command to provide the primary node the address of the secondary node.

Procedure

Step 1 Log in to your primary Live Data node.
Step 2 Run the following command to set the secondary node:

set live-data secondary name
name

Specifies the hostname or IP address of the Live Data secondary node.

Install Subscriber/Secondary node of Live Data
This task is required for installation of the DNS Configuration is mandatory for installation of Live Data. To
configure DNS, add the VMs to the forward and reverse lookups of the DNS.

Before you begin

If the deployment uses host files in addition to DNS, use FQDNs in the host file. Live Data and single sign-on
(SSO) require FQDNs to work properly.

Note

Before you install the subscriber or secondary nodes, you must install the publisher or primary nodes and
configure the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, select Live Data and click OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
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d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.

Configure Live Data with AW
Configure Live Data with AW to access the primary AW DB and the secondary AW DB. The command also
automatically tests the connection from Live Data to the primary or secondary AW, checks to see if you (as
the configured user) have appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want to perform the test. When you include the
skip-test parameter, the command does not check if you (as the configured user) have appropriate AW DB
access and does not report results.

You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and Subscriber.

Note
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Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 132.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries on the master system database for the SQL user who is configured to work with Live Data:
USE master
GO
GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

set live-data aw-access primary addr port db user [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

set live-data aw-access secondary addr port db user [skip-test]
You can also optionally run the following command at any time to show and test the AW configuration that
you set from Live Data to the primary and secondary AW DBs.

The skip-test parameter is optional. Include it only if you do not want to perform the test.

show live-data aw-access [skip-test]

For more information, see set live-data aw-access, on page 270 .

Configure Live Data Machine Services
This command tells the AW where your Live Data machine services are located.

• Whenever you run set live-data machine-services, be sure to also run set live-data cuic-datasource to
reconfigure the Live Data data sources for the Unified Intelligence Center. See Configure Live Data for
Unified Intelligence Center Data Sources, on page 80.

Note

Procedure

Step 1 Log in to your Live Data server.
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Step 2 Run the following command to configure the Live Data machine services:

set live-data machine-services awdb-user

Use the user@domain format to specify the AW database domain user with write-access permission. The
domain is a fully qualified domain name (FQDN), and the username is a user principal name. You must be
authorized to change Unified CCE configuration.

• The Router and Peripheral Gateway (PG) TIP and TOS connection information is
automatically populated for Unified CCE deployments that support Live Data. To set the
deployment type, see Set Deployment Type in Unified CCE Administration Configuration,
on page 59. The Live Data server uses this information to establish a connection, and receive
reporting data as well as agent and call events as they occur.

• Cisco Unified CommunicationsManager (CUCM) PG, generic PGswith CUCMperipherals,
and Unified CCE Gateway PGs are supported for Live Data.

Note

Once you have updated the host name of Live Data Server, you need to re-run the below set of
commands, otherwise new host name will not be accepted.

set live-data machine-services awdb-user

set live-data cuic-datasource cuic-addr cuic-port cuic-user

Verify that the show machine-services display changed hostname.

It is necessary for you to re-run the set of commands, otherwise Live data machine services will
not be updated with the new host name.

Note

Configure Live Data for Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.

If you are using any certificates that are unapproved by Cisco, ensure to import the CUIC certificate into the
Live Data server before you run set live-data machine-services.

Note

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-user
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Restart Live Data
After you complete the configuration procedures for the AW, the Live DataMachine Services, and the Unified
Intelligence Center data source, restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart

Whenever a new peripheral gateway that supports Live Data gets deployed and started, its feed
will not be available to Live Data server automatically. Restart the Live Data server to start the
feed from the newly deployed Peripheral Gateway.

Note

Set Up Certificates for Live Data
For secure Cisco Finesse, Cisco Unified Intelligence Center, and Live Data server-to-server communication,
perform any of the following:

• Use the self-signed certificates provided with Live Data.

When using self-signed certificates, agents must accept the Live Data certificates
in the Finesse desktop when they sign in before they can use the Live Data gadget.

Note

• Produce a Certification Authority (CA) certificate internally.

• Obtain and install a Certification Authority (CA) certificate from a third-party vendor.

Install Coresident Deployment (Cisco Unified Intelligence Center with Live
Data and IdS)

Follow this sequence of tasks to install the coresident deployment (Cisco Unified Intelligence Center with
Live Data and IdS).

TaskSequence

Set Deployment Type in Unified CCE Administration Configuration:

Set Deployment Type in Unified CCE Administration Configuration, on page 59

1

Install Coresident Deployment Primary Node.

See Install Publisher/Primary Node of Co-resident Deployment (Cisco Unified Intelligence
Center with Live Data and IdS), on page 82

2
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TaskSequence

Install Coresident Deployment Secondary Node.

See Install Subscriber/Secondary Node of Co-resident Deployment (Cisco Unified
Intelligence Center with Live Data and IdS), on page 83

3

Add Coresident (Cisco Unified Intelligence Center with Live Data and IdS) Machine Type
to the System Inventory, on page 85

4

Upgrade VMware Tools. See Install Vmware Tools, on page 17.5

Configure Live Data with AW, on page 856

Configure Live Data Unified Intelligence Center Data Sources, on page 867

Restart Live Data, on page 878

Set up certificates for Live Data. See9

Unified CCE 2000 agent reference design use the UCCE: 4000 Agents Rogger deployment type. But, you
can use the 2000 agent reference design OVA and server layout.

Note

Install Publisher/Primary Node of Co-resident Deployment (Cisco Unified Intelligence Center with
Live Data and IdS)

Before you begin

DNSConfiguration is mandatory for installation of Coresident deployment (Cisco Unified Intelligence Center
with Live Data and IdS). To configure DNS, add the VMs to the forward and reverse lookups of the DNS.

If the deployment uses host files in addition to DNS, use FQDNs in the host file. Live Data and single sign-on
(SSO) require FQDNs to work properly.

Note

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, for the Progger (Lab only) or 2000 agent reference design,

choose Cisco Unified Intelligence Center with Live Data and IdS, and then select OK. The Cisco
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Unified Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center
with Live Data and Cisco Identity Service (IdS) on the same server.

d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
n) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
o) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
p) In the First Node Configuration screen, select Yes.
q) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
r) In the Security Configuration screen, enter the security password and select OK.
s) In the SMTP Host Configuration screen, select No.
t) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
u) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.

Install Subscriber/Secondary Node of Co-resident Deployment (Cisco Unified Intelligence Center
with Live Data and IdS)

Before you begin

DNSConfiguration is mandatory for installation of Coresident deployment (Cisco Unified Intelligence Center
with Live Data and IdS). To configure DNS, add the VMs to the forward and reverse lookups of the DNS.
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If the deployment uses host files in addition to DNS, use FQDNs in the host file. Live Data and single sign-on
(SSO) require FQDNs to work properly.

Note

Before you install the subscriber or secondary nodes, you must install the publisher or primary nodes and
configure the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen, for the Progger (Lab only) or 2000 agent reference design,

choose Cisco Unified Intelligence Center with Live Data and IdS, and then select OK. The Cisco
Unified Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center
with Live Data and Cisco Identity Service (IdS) on the same server.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, enter your DNS client configuration. Select OK.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
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r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs
unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.

Add Coresident (Cisco Unified Intelligence Center with Live Data and IdS) Machine Type to the
System Inventory

Procedure

Step 1 In Unified CCE Administration, navigate to System > Deployment.
Step 2 Add the new machine to the System Inventory:

a) Click Add.

The Add Machine popup window opens.

b) From the Type drop-down menu, select the following machine type:

CUIC_LD_IdS Publisher, for the coresident Unified Intelligence Center, Live Data, and Identity Service
machine available in the 2000 agent reference design.

c) In the Hostname field, enter the FQDN, hostname, or IP address of the machine.

The system attempts to convert the value you enter to FQDN.

d) Enter the machine's Administration credentials.
e) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.

What to do next

If you remove a component from your deployment, delete it from your System Inventory. If you add the
component again, or add more components, add those components to the System Inventory.

Configure Live Data with AW
This command tells Live Data how to access the primary AW DB and the secondary AW DB. The command
also automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want the test that is performed. When you include
the skip-test parameter, no checking is done to see if you (as the configured user) have appropriate AW DB
access, and no results are reported.
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You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and the Subscriber.

Note

Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 132.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries for the SQL user who is configured to work with Live Data.
USE master
GO
GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

set live-data aw-access primary addr port db user [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

set live-data aw-access secondary addr port db user [skip-test]
You can also optionally run the following command at any time to show and test the AW configuration that
you set from Live Data to the primary and secondary AW DBs.

(The skip-test parameter is optional; include it only if you do not want the test performed.)

show live-data aw-access [skip-test]

For more information, see set live-data aw-access, on page 270 .

Configure Live Data Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.

Before you begin

• Ensure that AW distributor and Cisco Unified Intelligence Center Publisher are in service.
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• Ensure that AW DB connection information is updated on the same node, where you want to configure
Live Data CUIC data source.

• Configure Live Data endpoints in the Machine Service table.

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-user

Restart Live Data
After you complete the configuration procedures for the AW and the Unified Intelligence Center data source,
restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart
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C H A P T E R 5
Initial Configuration

• Initial Configuration Overview, on page 89
• Initial Configuration Task Flow, on page 89
• Initial Configuration Tasks, on page 90

Initial Configuration Overview
This initial configuration brings the contact center to the point where a complete call flow is possible. The
configured systemwill process information about incoming calls, perform call routing, and enable call handling.

Initial Configuration Task Flow
SeeTask

Set Deployment Type in Unified CCEAdministration
Configuration, on page 59

Set Deployment Type in Unified CCEAdministration
Configuration

Configure Cisco Unified Contact Center Enterprise,
on page 91

Configure Cisco Unified Contact Center Enterprise

Configure Cisco Unified Intelligence Center, on page
131

Configure Cisco Unified Intelligence Center

Configure Cisco Unified Customer Voice Portal, on
page 139

Configure Cisco Unified Customer Voice Portal

Configure Cisco Unified Communications Manager,
on page 157

Configure Cisco Unified Communications Manager

Configure Cisco Finesse, on page 168Configure Cisco Finesse
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Initial Configuration Tasks

Configure Permissions in the Local Machine
In this release,Unified CCE defaults to providing user privileges by memberships to local user groups on local
machines. This technique moves authorization out of Active Directory. However, it requires a one-time task
on each local machine to grant the required permissions.

You can use the ADSecurityGroupUpdate registry key to choose between the new default behavior and the
previous behavior. For more information, see the chapter on solution security in the Solution Design Guide.

Note

Before using the Configuration Manager tool, configure the required registry and folder permissions for the
UcceConfig group.

Configure Registry Permissions
This procedure only applies to distributor machines. Grant the required registry permissions for the
UcceConfig group on the local machine.

In Unified CCEAdministration Client, the AdminClient installer does not create the local groupUcceConfig.
You must manually create local group UcceConfig.

Note

Procedure

Step 1 Run the regedit.exe utility.
Step 2 Select HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM.
Step 3 Right-click and select Permissions.
Step 4 If necessary, add UcceConfig in Group or user names.
Step 5 Select UcceConfig and check Allow for the Full Control option.
Step 6 Click OK to save the change.
Step 7 Repeat the previous steps to grant Full Control to the UcceConfig group for

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Cisco Systems, Inc.\ICM.
Step 8 Repeat the previous steps to grant Full Control to the UcceConfig group for

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2.

If you have configured the Unified CCE Administration Client, open Local security policy and
go to User Rights Assignment. Right click Create Global Object. Go to properties and add
the local Group UcceConfig.

Note
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Configure AW-HDS Database Permissions
Follow this procedure to grant access to the AWDB-HDS database to UcceConfig group members.

Procedure

In SQL Management Studio, do the following:
a) Go to Security > Logins.
b) Locate <Machine name>\UcceConfig. Right-click and select properties.
c) Go to User Mappings and select one AWDB database. Ensure that GeoTelAdmin, GeoTelGroup, and

public are selected.
d) Repeat step c for the HDS database.

Configure Folder Permissions
Grant the required folder permissions to the UcceConfig group on the local machine.

Procedure

Step 1 In Windows Explorer, select <ICM install directory>\icm.
Step 2 Right-click and select Properties.
Step 3 On the Security tab, select UcceConfig and check Allow for the Full Control option.
Step 4 Click OK to save the change.
Step 5 Repeat the previous steps to grant Full Control to the UcceConfig group for <SystemDrive>:\temp.

Configure Cisco Unified Contact Center Enterprise
You can configure individual records, or you can use the Bulk Configuration tool to configure multiple records
at one time. Bulk configuration is available for the following:

• Agents

• Call types

• Dialed number plans

• Dialed numbers

• Labels

• Network trunk groups

• Network VRU scripts

• Peripheral targets

• Persons
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• Regions

• Region prefixes

• Routes

• Trunks

• Trunk groups

• Scheduled targets

• Services

• Skill groups

• VRU port maps

Access Configuration Manager tool
You perform all Unified CCE configuration tasks using the Configuration Manager tool, which is installed
with the Unified CCE software.

1. From your desktop, double-click the Unified CCE Tools icon, and then select Administration Tools.

2. Double-click the Configuration Manager icon.

Configure Media Routing Domain
You must establish Media Routing Domains (MRD) for each media type that your Unified CCE System
supports. A Voice MRD is installed by default with Unified CCE. You need to create MRDs for other media
such as chat, email, and tasks. Additionally, if you are using Cisco Enterprise Chat and Email (ECE), you
need to create media classes for ECE chat and email.

If you are configuring Media Routing Domains for ECE, see the Configuration Guide for Cisco Unified
ICM/Contact Center Enterprise for complete instructions, at http://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/
products-installation-and-configuration-guides-list.html.

If you are configuring a Media Routing Domain for Task Routing with third-party multichannel applications,
do not use this procedure. See the Cisco Unified Contact Center Enterprise Features Guide for instructions,
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-feature-guides-list.html.

Important

Procedure

Step 1 Start the Configuration Manager and select Tools > List Tools > Media Routing Domain List.
Step 2 Click Retrieve and then click Add.

The Attributes tab appears.

Step 3 On the Attributes tab, provide values for the following fields:
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Name. Enter the enterprise name of the MRD.

Media Class. Use the drop-down list to select the media class for the integrated application.

Max Time in queue. The default maximum queue time for calls in queue is one hour. To override this default,
modify the value of the Max Time In queue field.

The MR domain ID is automatically generated when you save the MRD.

Step 4 After completing the required fields, click Save.

Repeat this procedure to add an MRD for each media class that your system supports.

Configure Trunk Groups
For the Unified CCE, the Network Trunk Group is the placeholder in the Unified CCE database for the trunk
group; it performs no other function.

For deployments that:

• Use the Unified CCE System PG, you must create one Network Trunk Group for each Unified CCE
System PG peripheral.

• Do not use the Unified CCE System PG, you must create two Network Trunk Groups—one for the
Unified Communications Manager and one for the Unified CVP or Unified IP IVR. If you are deploying
the Unified CVP, create one Network Trunk Group per CVP Server.

A Unified CCE Trunk Group is a collection of trunks associated with a single peripheral and usually used for
a common purpose. For the Unified CCE, the trunk groups for VRU peripherals are used primarily as a place
holder in the Unified CCE database.

Create a trunk group for each Unified CommunicationsManager peripheral and a trunk group for each Unified
IP IVR application. If you are deploying Unified CVP, you must create two trunk groups for each Unified
CVP Server that match the Group Numbers configured in Unified CVP Application Administration. For
Unified IP IVR, the trunk group peripheral number in the Unified CCE must match the CTI Port Group ID
on Unified IP IVR.

To configure a Network Trunk Group (and the trunk group under it):

Procedure

Step 1 From the ConfigurationManager, chooseConfigure ICM > Peripherals >Trunk Group >Network Trunk
Group Explorer. The ICM Network Trunk Group Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Click Add Network Trunk Group. The Network Trunk Group tab opens.
Step 4 Add a unique name for the Network Trunk Group and an appropriate description.
Step 5 Click Add Trunk Group to add a trunk group.
Step 6 Complete these fields:

Peripheral. Select the peripheral to which the trunk group is associated.

Peripheral Number. Enter the number of the trunk group as understood by the peripheral. This number must
be unique among all trunk groups associated with the peripheral. For Unified IP IVR, this number must:
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a. Match a CTI Port Group ID configured on the Unified IP IVR.

b. Be an odd number.

c. Be unique for all Unified IP IVRs handled by an Unified CCE System PG.

For example, if a Unified CCE System PG handles four Unified IP IVRs and each Unified IP IVR peripheral
has one CTI Port Group, then the CTI Port Group ID for the first Unified IP IVR should be 1, the port group
ID for the second Unified IP IVR should be 3, and so on. For the Unified CVP, this number must match a
CVP Server Group Number configured on the CVP Server.

Peripheral Name. Enter the name of the trunk group as understood by the peripheral. This name must be
unique among all trunk groups associated with the peripheral.

Name. Enter the enterprise name of the trunk group. The Unified CCE forms a default for this name using
the entries from the Peripheral and Peripheral Name fields.

Extension. Leave this field blank.

Trunk Count. Select Use Trunk Data. When you specify Use Trunk Data, the system software determines
the trunk count dynamically by counting the associated records in the Trunk table.

Configuration Parameters. Leave this field blank.

Description. Enter an optional description.

Step 7 To add trunks to the trunk group, click Add Trunk.
Step 8 Add trunks as desired.
Step 9 Click Save and then click Close.
Step 10 Repeat these steps to create all necessary trunk groups.

Configure Network VRU Bank
The Network VRU Bank allows load balancing across multiple VRUs to occur and eliminates the need for
complex translation-route configuration.

Configure a Network VRU Bank, only if your deployment uses the Unified CCE System PG.

Before you begin

Do this after you configure the following:

• Network VRU

• Network Trunk Group

• All other trunk groups

Procedure

Step 1 From the Configuration Manager, choose Explorer Tools > Network VRU Explorer. The Network VRU
Explorer dialog box opens.

Step 2 Click Retrieve and select your Network VRU.
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Step 3 Select the Network VRU Bank tab and click Add.

The Select Trunk Group dialog box opens, displaying the all trunk groups configured on all Unified CCE
System PG peripherals.

Step 4 Select the trunk group associated with the translation routing group on your Unified IP IVR. Make the
appropriate trunk group selection for each Unified IP IVR in your deployment.

Step 5 Click OK.
Step 6 Click Add Label to add a label for the Network VRU Bank. The label must be the CTI Route Point trigger

for the Translation-Routing application on the Unified IP IVR. By default, in the Label tab, the first field
shows the selected Network VRU, not the Network VRU Bank:
a) Click the drop-down list box to show the available Network VRU banks.
b) Select a Network VRU bank in the drop-down list.
c) Then configure the label for the Network VRU bank.
d) Repeat the steps to configure labels for all of the Network VRU Banks.

If Network VRUBank labels are available, the Router uses themwhen it balances the load between the Unified
IP IVRs. If the Router cannot find an eligible Network VRU Bank labels, it uses the Network VRU label.

Configure services
A service refers to a type of processing that a caller requires. For example, separate services might be defined
for Sales, Support, or Accounts Payable. Services are often associated with a peripheral, and are sometimes
referred to as peripheral services. An agent is assigned one or more skills that in turn is associated with services.
Routing to a Unified CCE service effectively targets an agent assigned to a Unified CCE skill group associated
with the Unified CCE service.

Services on the Unified CCE correspond to CTI Route Points on Unified Communications Manager.

On Unified CCE systems that interface with Unified CVP systems, you must configure two services with
Peripheral Numbers of 1 and 2. However, outside of these services the preferred method of defining Unified
CCE routable tasks is by defining call types.

For the two Unified CVP services, you do not need to configure ServiceMembers, Routes, Peripheral Targets,
or Labels.

Note

Procedure

Step 1 From the Configuration Manager menu, choose Tools > Explorer Tools > Service Explorer. The Service
Explorer dialog box opens.

Step 2 Select the peripheral for which you want to create a service and click Retrieve.
Step 3 Click Add Service.

The Service Configuration window opens.
Step 4 On the Service tab, enter the following:

The Media Routing Domain associated with the service.
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Peripheral Number. Enter the number for the service on the peripheral. This field must be unique for all
services for the peripheral, but not necessarily across all peripherals. If you are deploying the Unified CVP,
enter 1 for the first service and 2 for the second service.

Peripheral Name. Enter a name that describes the service.

Enterprise Name. Enter an enterprise name for the service. This name must be unique among all the services
in the enterprise. If you do not enter a value, this name is autogenerated.

Config Param. Not used for the Unified CCE.

Description. Enter any additional information about the service.

Service Level Type. Indicates how the Unified CCE calculates the service level for the service. You can
choose to omit abandoned calls from the calculation, treat them as having exceeded the threshold (negative
impact on service level), or treat them as answered calls (positive impact on service level). You can also
choose to use the default specified for the peripheral.

Service Level Threshold. Enter the time in seconds, for the service level. The Unified CCE tracks the
percentage of calls answered within this threshold. If this field is negative, the value of the default for the
peripheral is used.

Step 5 On the Advanced tab, enter the following:

Peripheral Service Level. Indicates the type of service level calculation that the peripheral performs for this
service. This setting has no effect because the PG does not report a peripheral service level.

Schedule name. Identifies an imported schedule associated with the service.

Extension. If you are deploying Outbound Option, enter the extension to associate with this service. This
corresponds to a CTI Route Point defined in Unified Communications Manager and is associated with the
PG User.

Step 6 On the Service Members tab, select skill groups to associate with this service.
Step 7 Click Apply.
Step 8 Repeat this procedure to add any other services.

Configure dialed numbers
The dialed number (DN) is the number that the caller dials to start the call and identifies the Unified CCE
routing script to run. Set dialed numbers for ring no answer, dialed number plan entries, and for
Supervisor/emergency calls.

For Unified Communications Manager to generate a route request to the Unified CCE, the cluster associates
the DN with a CTI Route Point for the Unified CCE JTAPI User. Configure the DN in the Unified CCE. After
the Unified CCE receives the route request with the DN, that DN is mapped to a Unified CCECall type, which
is then mapped to a Unified CCE routing script.

You cannot use the DN for a CTI Route Point on a different CTI Route Point in another partition. Ensure that
DNs are unique across all CTI Route Points on all partitions.

Note

Unified CCE generates a unique value for the Label Name list after you configure a dialed number.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
96

Initial Configuration
Configure dialed numbers



Procedure

Step 1 From the Configuration Manager, choose Tools > List Tools > Dialed Number/Script Selector List.

The Dialed Number/Script Selector List dialog box opens.

Step 2 Click Retrieve and then click Add.

The Attributes tab displays.

Step 3 In the Attributes tab, enter values in the following fields:

Routing client. Choose the enterprise name of the routing client associated with this dialed number. After
you select a routing client and save to the database, this field becomes read only.

Media Routing Domain. The media routing domain associated with the selected dialed number or script
selector.

Dialed number string. Enter the string value that the routing client passes to the Unified CCE for this dialed
number (for example: 8005551212).

Name. Enter the enterprise name for the dialed number. This name must be unique among all dialed numbers
in the system. If you do not enter a value, the name is autogenerated.

Customer. Use the drop-down list to select the customer (Unified CCE instance) associated with the dialed
number.

Default label. Choose the name of the default label for this dialed number. The label must have been previously
defined for it to be in the selection list. Use the Label List tool in the Configuration Manager to define labels.
If the Unified CCE fails to determine a target for the call within the routing client's time-out threshold, then
the default label for the dialed number is used.

Description. Enter a description for the dialed number.

Permit application routing. If you intend to route calls from a parent system to this dialed number, check
this dialog box.

Reserved by IVR. For VRU dialed numbers, check this box. This setting prevents the CallManager PIM
from trying to exert control on the calls arriving on these Route Points.

Step 4 On the DNMapping tab, as desired, clickAdd to specify a call type and other dialing information to associate
with this dialed number.

Step 5 Click Save to enter the dialed number information.
Step 6 Repeat this procedure for any additional dialed numbers.

Configure call types
A call type is a category of Unified CCE routable task. Each call type has a schedule that determines which
routing script or scripts are active for that call type at any time.

There are two classes of call types:

• Voice (phone calls). Voice call types are categorized by the dialed number (DN), caller-entered digits
(CED), and calling line ID (CLID). The CED and CLID can be optional, depending on the call.
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• Non-voice (email and text chat). Non-voice call types are categorized by the Script Type Selector,
Application String 1, and Application String 2. Application String 1 and Application String 2 can be
optional, depending on the application.

To facilitate Unified CCE reporting, it is good practice to create separate call types for VRU applications and
queuing applications.

Procedure

Step 1 From the Configuration Manager, select Tools > List Tools > Call Type List.

The Call Type List dialog box opens.

Step 2 Click Retrieve and then click Add.

The Attributes tab appears.

Step 3 In the Attributes tab, enter values for the following fields:

Name. Enter an enterprise name for the call type. This name must be unique among call types in the system.

Customer. Choose the customer (Unified CCE Instance) from the drop-down list.

Service level threshold. The service level threshold is the target maximum time that a caller spends in a queue
before being connected to an agent.When you set up a peripheral, you specify a default service level threshold
for all services associated with that peripheral. If you enter a negative number, the service level threshold
from the Peripheral table is used.

This field is prepopulated with the default service level threshold for this peripheral and grayed out. If you
wish to override this default, check the Override System Information Default check box to the right of this
field and enter a different value.

You can also set the Service Level in the Configuration Manager with the System Information tool. When
the service level is defined with the Call Type tool, this setting overrides a setting made with the System
Information tool. If service level is not defined with the Call Type tool, but is defined with the System
Information tool, the Unified CCE uses the System Information setting.

Service level type. Indicates how the system software calculates the service level for the service. The default
is the level specified for the associated peripheral. To set a different level type, check the Override System
Information Default check box and select the type you want from the selection box.

Bucket Intervals. Indicates the Bucket Intervals setting for the call type. Bucket intervals are defined with
the Bucket Intervals List tool. If you wish to override the defined default, check the Override System
Information Default check box and select a different Bucket Intervals setting.

Description. Enter an optional description of the call type.

Step 4 Click Save to enter the call type information.

Repeat this procedure to add additional call types.
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Configure Variables

Configure Expanded Call Context Variables

Expanded Call Context (ECC) variables are variables that you define and enable in the ConfigurationManager
to store values for a call. You can specify the variable name and data type. The name must begin with the
string "user." ECC variables are in addition to the variables the system software defines for each call
(PeripheralVariable1 through PeripheralVariable10, CallerEnteredDigits, CallingLineID, and so on).

An ECC variable name can be up to 33 bytes long (1–32 usable characters). Use the following naming
convention when creating an ECC variable:

user.<CompanyName>.<VariableDescription>

In this syntax:

• <CompanyName> is the name of your company.

• <VariableDescription> is a descriptive tag for the variable.

For example:

user.Cisco.AcctNum

Using this naming convention prevents naming conflicts with any third-party applications that interface with
the system software.

For a large corporation, you can break <VariableDescription> down to include the Business Unit, Division,
or other organizational entities.

Note

ECC variables follow these size rules:

• An ECC variable can be either a scalar variable or an array element, each with a maximum length of 210
bytes.

Array types are not supported for an agent request.Note

• The maximum number of elements in an array is 255.

• The maximum buffer size for each scalar variable = 5 + the maximum variable length. The 5 bytes
includes 4 bytes to tag the variable and 1 byte for the null terminator.

• The maximum buffer size for each array = 5 + (1 + the maximum length of an array element) * (the
maximum elements in the array). There is a null terminator for each element, and a null terminator for
the array as a whole.

• You pass ECC variables in an ECC payload which has a 2000-byte limit. The total sum of all the maximum
buffer sizes for each variable and each array in one ECC payload cannot exceed 2000 bytes.

For example, if you intended to use the following:

• A scalar ECC variable with a maximum length of 100 bytes

• A scalar ECC variable with a maximum length of 80 bytes
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• An ECC array with a maximum of 9 elements with each element having a maximum length of 200
bytes

Totaled the buffer size is: (5+100) + (5+80) + (5 + (1+200)*9) = 2004. Because this size is too large,
you must change the length of one of the scalar ECC variables or the length of the array ECC variables.

For Web Callback and Delayed Callback to work properly, an ECC variable (also known as a named variable)
must be defined. The Cisco CTI driver supports the use of ECC variables in addition to the standard call
variables associated with a call. Before an ECC variable can be used, it must be defined in the Unified CCE
ECC variable database table.

ECC Variables for Voice MRDs with Collaboration

ECC variables must be configured in Configuration Manager's Expanded Call Variable List tool (for each
integrated application) to route requests using the voice Media Routing Domain.

For Voice MRDs with Collaboration, the ECC variables are:

• user.ewm.activity.id

• user.ewm.customer.name

Validate ECC Variable Size for CTI Server

Before configuring ECC variables, validate the total size of the ECC variables against the following rules and
limits:

• Because the total size of the buffer used to store the variables in CTI Server internally is 2500 bytes, the
total sum of all the maximum buffer sizes for each scalar variable and arrays must be no greater than
2500.

• The maximum buffer size for each scalar variable = 4 + length of the ECC name + the maximum length
of the variable where the 4 bytes includes a 1 byte tag, 1 byte to define the length, and 2 terminating
NULL characters.

• The maximum buffer size for each array = (5 + length of the ECC name + the maximum length of array
element) * (the maximum number of elements in the array) where the 5 bytes includes a 1 byte tag, 1
byte to define the length, 1 byte for the array index, and 2 terminating NULL characters.

• For example, if you intend to use one scalar ECC variable with a maximum length of 100 bytes named
user.var, one scalar ECC variable with a maximum length of 80 bytes named user.vartwo, and an ECC
array named user.varthree with a maximum of 9 elements with each element having a maximum length
of 200 bytes, the buffer size would be:

(4+8+100) + (4+11+80) + ((5 + 13 + 200)*9)) = 2169

where 8 is the length of user.var, 11 is the length of user.vartwo and 13 is the length of user.varthree.

Enable ECC Variables

Procedure

Step 1 Within the Configuration Manager, double-click Tools > Miscellaneous Tools > System Information.

The System Information window appears.
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Step 2 Select the Expanded call context enabled check box.
For additional information, refer to the online Help.

Step 3 Click Save to apply your changes.

Define ECC Variables

Procedure

Step 1 Within the Configuration Manager, double-click Tools > List Tools > Expanded Call Variable List.

The Expanded Call Variable List window appears.

Step 2 Click Retrieve to enable adding ECC variables.
Step 3 Click Add.

The Attributes property tab appears.

Step 4 Complete the Attributes property tab. See the List Tools Online Help for details on the Attributes property
tab.

Step 5 Click Save to apply your changes.

What to do next

If you change the configuration of any ECC variable with the Expanded Call Variable List tool, restart the
Unified CVP Call Server or VRU PIM to force a renegotiation of the ECC variables.

Before you can use the new ECC variable, you must add it to an ECC payload.

If your solution only has a Default payload, the solution automatically adds any new ECC variables to the
Default payload until it reaches the 2000-byte limit.

Note

Define ECC Payloads

You can create and modify ECC payloads in the Expanded Call Variable Payload List tool.

The tool checks that the ECC payload does not exceed the 2000-byte limit only when you save your changes.
The counters on the Members tab only show what the current size is with all the selected members. They are
only informational and do not enforce the limit. The limit is enforced when you attempt to save the changes.

Note

To define an ECC payload, you create the ECC payload and then add its members.
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Procedure

Step 1 In the Configuration Manager, open Tools > List Tools > Expanded Call Variable Payload List.

The ECC Payload List window appears.

Step 2 Click Retrieve to enable adding ECC payloads.
Step 3 Click Add.

The Attributes property tab appears.

Step 4 Complete the Attributes property tab. See the List Tools Online Help for details on the Attributes property
tab.

Step 5 On the Members tab, click Add.

A dialog box listing all the existing ECC variables appears.

Step 6 Select the members for your ECC payload and click OK.

Watch that the ECC Variable Size counter does not exceed 2000 bytes. For ECC payloads that go to CTI
clients, watch that the CTI Message Size counter does not exceed 2500 bytes.

Step 7 Click Save to apply your changes.

Configure User Variables

You can also create global user variables; for example, you can create a user variable called usertemp to serve
as a temporary storage area for a string value used by an If node.

After you have defined a user variable, you can then use the Script Editor Formula Editor to access the variable
and reference it in expressions, just as you would with a “built-in” variable.

Each user variable must:

• Have a name that begins with user.

This name cannot contain the dot/period (.) character.Note

• Be associated with an object type, for example, Service. (This enables the system software to maintain
an instance of that variable for each object of that type in the system.)

• Be checked as persistent. A persistent variable maintians its value between script invocations. This allows
you to set the variable in one script and reference later in another script.

Because these variables may be persisted, do not use User Variables to store
sensitive information belonging to the customer or company. Using these variables
to store confidential information could lead to violation of security standards,
such as PCI, the Common Criteria, HIPAA, or FIPS 140-2.

Note
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A user variable can store a value up to 40 characters long.

Define User Variables

Procedure

Step 1 Within the Configuration Manager, select Tools > List Tools > User Variable List.

The User Variable List window appears.

Step 2 In the User Variable List window, click Retrieve to enable Add.
Step 3 Click Add.

The Attributes property tab appears.

Step 4 Complete the Attributes property tab.

TheVariable name,Object type, andData type fields are required. All other fields are optional.
For additional information refer to the online Help.

Note

Step 5 Click Save to apply your changes.

Configure Users

Create Person records

All Unified CCE agents must have a Person record. When you create an Agent record, you can associate the
record with an existing Person record. If you do not associate the Agent record with an existing Person record,
a new Person record is automatically created when you create the agent.

To configure a Person record before configuring an agent, complete the following steps:

Procedure

Step 1 From the Configuration Manager, choose Peripherals > Person > Person List.
The Person List dialog box opens.

Step 2 Click Retrieve and then click Add.
Step 3 in the Attributes tab, enter information in the following fields:

First Name. Enter the person's first name.

Last Name. Enter the person's last name.

Login Name. Enter the person's login name.

Password. Enter a password for the person.

Enable Logins. Check this check box.

Step 4 Click Save and then click Close.
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Step 5 Repeat this procedure to add additional Person records.

Associate agents with peripherals

Procedure

Step 1 Select Tools > Explorer Tools > Agent Explorer.
The Agent Explorer dialog box displays.

Step 2 Select the peripheral you want associated with the agent from the drop-down list and click Retrieve.
Step 3 Click Add Agent to display the Agent configuration tab.
Step 4 In the Agent tab, enter information in the following fields:

Last Name. Enter the agent's last name.

First Name. Enter the agent's first name.

Login Name. Enter the name the agent uses to login. This name must be unique in the enterprise.

Password. Enter the agent's password. This password is validated during the agent login process.

Login Enabled. Check this check box if you want the enable the agent to login.

Select Person. Click this button to select a person to associate with the agent record. You can select a person
for a new agent, an existing agent, or a temporary agent.

Enterprise Name. Enter an enterprise name for the agent that is unique within the enterprise. The default is
a combination of the peripheral name with the agent's first and last name.

Peripheral Name. Enter a name for the agent as known to the peripheral.

Peripheral Number. Enter the agent's login ID. This number identifies the agent to the peripheral. This
number needs to be unique among all agents for the peripheral, but does not need to be unique across all
peripherals. Agent IDs can be up to eleven digits long. The first digit in the ID must be 1 through 9. It cannot
be 0. Also, this number cannot be the same as the extensions on the Unified CommunicationsManager cluster
for this agent. Finally, the ID can not exceed the extension length specified in the Unified Communications
Manager Peripheral Gateway Setup

Step 5 Click the Advanced tab and enter information in the following fields:

Desk Setting. Use the drop-down list to select the desktop settings to be associated with the agent. If you do
not make a selection, the Unified CCE applies the default desk settings defined for the peripheral.

ConfigParam. Use this field to enter any specific configuration parameters that may be required. Make entries
in this field only if instructed to do so by your Cisco support representative.

Description. Enter any other information you want about the agent.

Agent State Trace. Select to enable the agent's state trace control. When enabled, the Unified CCE records
every state transition made by the agent.

Step 6 Click Save.
Step 7 Repeat this procedure to configure additional agents.
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Assign Agent Desk Settings

Agent Desk Settings associate a set of permissions or characteristics with specific agents. The settings are
comparable to Class of Service settings on a PBX or ACD. Desk settings are associated with an agent when
you configure the agent. The desk settings are global in scope and you can apply them to any configured agent
on any peripheral within a Unified CCE configuration.

Agent Desk Settings provide a profile that specifies parameters such as whether auto-answer is enabled, how
long to wait before rerouting a call for Ring No Answer, what DN to use in the rerouting, and whether reason
codes are needed for logging out and going not-ready. You must associate each agent with an agent desk
setting profile in the Unified CCE configuration. A single agent desk setting profile can be shared by many
agents. Changes made to an agent's desk setting profile while the agent is logged in are not activated until the
agent logs out and logs in again.

If Agent Desk Settings are not associated with an agent, the agent is assigned the peripheral default settings,
which depend on the peripheral to which the agent is assigned.

When you configure Agent Desk Settings, you specify the amount of non-active time after which an agent is
automatically logged out, whether wrap up is required following incoming and outbound calls, the amount
of time allocated for wrap up, and the method used for assist and emergency calls. You also specify settings
for the Ring No Answer feature.

Ring No Answer

The Ring No Answer feature, configured in Agent Desk Settings, ensures that when an agent does not answer
a call, the call is taken away from the agent after a specified number of seconds and re-assigned to another
agent or requeued.

When a call is routed to an agent but the agent fails to answer the call within a configurable amount of time,
the Unified Communications Manager PIM for the agent who did not answer changes that agent's state to not
ready (so that the agent does not get more calls) and launches a route request to find another agent. Any call
data is preserved and popped onto the next agent's desktop. If no agent is available, the call can be sent back
to the Unified IP IVR for queuing treatment again. Again, all call data is preserved. The routing script for this
RONA treatment should set the call priority to “high” so that the next available agent is selected for this caller.
In the agent desk settings, you can set the RONA timer and the DN used to specify a unique call type and
routing script for RONA treatment.

This feature behaves and is configured differently depending on whether you deploy the Unified CVP or
Unified IP IVR in the Unified CCE System.

The Dialed Number for Ring No Answer is peripheral-specific. Therefore, each Unified Communications
Manager PG in your deployment must have its own set of Agent Desk Settings configured for it; you cannot
use a particular desk setting across peripherals.

Note

About Ring No Answer with Unified IP IVR

For Unified CCE systems in which you deploy the Unified IP IVR, the Ring No Answer feature ensures that
when an agent does not answer a call the following applies:

• The call is taken away from that agent after ringing for a configurable number of seconds and is rerouted
to a different agent or placed in queue.

• The state of the agent who did not answer the call is changed to “Not Ready.”
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Reroute a call on Ring No Answer works as follows for Unified IP IVR:

1. A routing script connects the call to an agent.

2. If the agent does not answer the phone within the Ring No Answer time set in Agent Desk Settings, the
Unified Communications Manager changes the agent's state to “Not Ready” and post routes the call to
Unified CCE.

3. The Unified CCE Router runs a routing script using the dialed number specified in the agent desk setting
record. The routing script associated with the DN typically looks for another agent and routes the call to
that new agent.

4. If no agents are available, the call typically is translation routed or queued to the VRU, or sent to some
other queue point. Queuing treatment is restarted.

Give the call the highest priority in the queue so that the call is routed to the next available agent.Note

5. Any call data is preserved to be popped onto the agent screen. In addition, a flag is set in the database so
that Unified CCE can report on all of the occurrences of Ring No Answer.

About Ring No Answer with Unified CVP

For Unified CCE systems in which you deploy the Unified CVP, the Unified Communications Manager does
not control the Unified CVP and cannot send an unanswered call back to the Unified CVP for re-queuing.
You configure the Ring No Answer feature to only make the agent “Not Ready” when they do not answer a
call, and use the Unified CVP Router Requery feature to re-queue the call.

As of Release 9.0, the Unified CVP deployment no longer requires that you configure the RNA timer on both
sides (Unified CVP and Unified CCE); configure Ring No Answer (RNA) timeout only in Unified CVP. This
removes the requirement to manually align the relevant Unified CVP and Unified CCE timer configuration.
To configure RNA timeout in Unified CVP, see the Patterns for RNA timeout on outbound SIP calls
section in the Unified CVP OAMP console.

Reroute a call on Ring No Answer works as follows for Unified CVP:

1. A routing script connects the call to an agent by sending a connect message to the Unified CVP. The script
node should have Enable Target Requery enabled. To enable this, edit the node, select Change and check
the Enable Target Requery check box.

2. The agent's phone rings.

3. If the phone is not answered (either via the agent desktop or physically going off-hook) within the Ring
No Answer time set in Agent Desk Settings, Unified CCE makes the agent unavailable, but does not
actually change the agent state to Not Ready until the call is redirected.

4. When the Unified CVP Ring No Answer timeout expires, the Unified CVP sends an EventReport=No
Answer message to the Router instructing it to select another target according to the routing script and
send a Connect message to Unified CVP. The target might be another agent or a VRU label to requeue
the call.

Give the call the highest priority in the queue so that the call is routed to the next available agent.Note
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5. Any call data is preserved to be popped onto the second agent screen.

In addition, a flag is set in the database so that Unified CCE can report on all of the occurrences of Ring No
Answer.

Note

6. When the call is redirected from the original agent, the agent's state changes to “Not Ready.”

Configure Agent Desk Settings

Procedure

Step 1 From the AW server, open Configuration Manager, choose Configure ICM > Enterprise > Agent Desk
Settings > Agent Desk Settings List. The Agent Desk Settings List dialog box opens.

Step 2 Click Retrieve and then Click Add.
Step 3 Fill in the Attributes tab information:

Name. Enter a name for the agent desk settings that is unique within the enterprise.

Ring No Answer Time. Enter the number of seconds (between 1 and 120) that a call may ring at the agent's
station. If you are deploying the Unified CVP, make sure this number is less than the number set for the No
Answer Timeout for Router Requery that you set in the Unified CVP.

If you configure this timer, you do not need to configure the Unified Communications Manager Call Forward
on No Answer for agent extensions in the Unified Communications Manager, unless you want them to be
used when the agent is not logged in. If you set the Unified Communications Manager Call Forward No
Answer time, enter a value at least 3 seconds higher than the Ring No Answer Time on each Unified
Communications Manager node.

Ring no answer dialed number. Enter the Unified CCE DN associated with the routing script that you want
to use to reroute a call that an agent has not answered. If you are deploying the Unified CVP, leave this field
blank.

Logout non-activity Time. Enter the number of seconds (between 10 and 7200) in which the agent can remain
in Not Ready state before Unified CCE automatically logs out the agent.

Work Mode on Incoming. Select whether wrap-up is required following an incoming call. Select an option
from the drop-down list.

Work Mode on Outgoing. Select whether wrap-up is required following an outgoing call. Select an option
from the drop-down list.

Wrap Up Time. Enter the amount of time, in seconds, allocated to an agent to wrap up a call.

Assist Call Method. Select whether Unified CCE creates a consultative call or a blind conference call for a
supervisor assistance request.

Emergency Alert Method. Select whether the Unified CCE creates a consultative call or a blind conference
call for an emergency call request.

Blind conference is not supported if the call may queue on a VRU.

Description. Enter additional optional information about the agent desk settings.
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Step 4 Use the following boxes to select or de-select miscellaneous settings:

Auto-answer. Indicates whether calls to the agent are automatically answered. The agent is not required to
take any action to answer the call. If a second call comes in while a call is in progress, the call is not
automatically answered. This is the same behavior as with Unified Communications Manager.

If you enable auto-answer, you must also configure the agent phone in Unified Communications Manager to
turn the speakerphone or headset (or both) to ON. If you turn only the headset to ON, the agent must also turn
the phone headset button to ON.

In a multi-line enabled environment with auto-answer selected, if you are on a call on your non-ACD line,
the call will not auto-answer. However, if you turn on Unified Communications Manager Auto Answer, the
call will answer.

Idle Reason Required. Indicates whether an agent is required to enter a reason before entering the Idle state.

Logout Reason Required. Indicates whether an agent is required to enter a reason before logging out.

Auto Record on Emergency. Indicates in a record request is automatically sent when an emergency call
request starts.

Cisco Unified Mobile Agent (check box). Enables the Unified Mobile Agent feature so that the agent can
log in remotely and take calls from any phone. For more information about the Unified Mobile Agent, see
the Cisco Unified Contact Center Enterprise Features Guide at https://www.cisco.com/en/US/products/sw/
custcosw/ps1844/products_feature_guides_list.html.

Step 5 Click Save and then click Close.

Designate Agent Supervisor

You can identify an agent as a supervisor.

If you define an agent as a supervisor:

• If single sign-on is disabled either globally or for the agent you want to designate as a supervisor, the
supervisor must have an Active Directory account. If the supervisor does not have an Active Directory
account, the designation fails.

• If single sign-on is enabled either globally or for the agent you want to designate as a supervisor, you
must enter the individual's name in the format that your identity provider requires.

To create an agent who is a supervisor:

Procedure

Step 1 In the Configuration Manager menu, select Tools > Explorer Tools > Agent Explorer. The Agent Explorer
window appears.

Step 2 In the Select filter data box, select the peripheral with which the agent is to associated and click Retrieve.
This enables the Add Agent button.

Step 3 Click Add Agent.

You must add the agent supervisor, as both member and supervisor, to the Member tab on the
agent team list. To get the benefit from the Team layout in Finesse, the agent supervisor must be
a member of the team.

Note

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
108

Initial Configuration
Designate Agent Supervisor

https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_feature_guides_list.html
https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_feature_guides_list.html


Step 4 In the property tabs on the right side of the window, enter the appropriate property values. Use the Agent Tab
to define the agent and designate the agent as a supervisor. Use the Skill Group Membership Tab to map the
agent to any skill groups. (See the Configuration Manager online help for more information.)

An agent team can have only one primary supervisor. There is no upper limit to the number of
secondary supervisors for a team. Refer to the online help for instructions on how to assign a
primary supervisor.

Note

Step 5 When finished, click Save.

Create agent teams

You can group individual agents into agent teams that supervisors can manage. Agent teams are assigned to
specific peripherals, so you must assign all agents of a given team to the same peripheral. You assign agents
individually to agent teams.

When configuring agent teams, be aware of the following rules:

• An agent can be a member of only one agent team.

• An agent team can have only one Primary Supervisor.

• A supervisor can be a supervisor of any number of agent teams.

• A supervisor for an agent team can also be a member of that agent team.

• All agents belonging to an agent team and all supervisors for that agent team must be on the same
peripheral.

For more information on team limits, see the appendix on system requirements in the Solution Design Guide
for Cisco Unified Contact Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-implementation-design-guides-list.html.

Procedure

Step 1 From the Configuration Manager, select Configure ICM > Peripherals > Agent Team > Agent Team List.
Step 2 Click Retrieve and then Add to add a new agent team.
Step 3 Click the Attributes tab and enter values in the following fields:

Name. Enter an enterprise name for the agent team that is unique within the enterprise.

Peripheral: Enter the name of the agent team peripheral. You can select the name from the drop-down list.

Supervisor Script Dialed Number: Select a dialed number for the agent team from the drop-down list. If
you have not created a supervisor script, select the default, “none”. When you create the script, return to this
screen and enter the dialed number for the script.

Description: Enter additional information about the agent team.

Step 4 Click the Members tab and click Add.
Step 5 Choose the agents that you to assign to the team and click OK.
Step 6 Click the Supervisor tab and choose the supervisor from the Primary Supervisor drop-down list.
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Step 7 To add a secondary supervisor, click the Add button and select a secondary supervisor from the list. Click
OK.

Step 8 Click Save and then click Close.

Configure Network VRUs
Use the Configuration Manager tool to configure Network VRUs.

After you configure a Network VRU and VRU scripts, you can use the Script Editor to write a routing script
to send a call to the VRU and invoke a specific VRU script.

See Scripting and Media Routing Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html formore information.

Create Network VRU Target

Procedure

Step 1 Within the Configuration Manager, select Tools > Explorer Tools > Network VRU Explorer.

The Network VRU Explorer window appears.

Step 2 In the Network VRU Explorer window, click Retrieve to enable Add Network VRU .
Step 3 Click Add Network VRU.

The Network VRU property tab appears.

Step 4 Complete the Network VRU property tab.

The Name and Type fields are required. All other fields are optional.

The ECC Payload field provides the name of the ECC payload that has scope for interactions with this network
VRU. For additional information refer to the Online Help.

Step 5 Click Save to apply your changes.

Define Network VRU Label

You must associate all VRU Types (except Type 6) with a Network VRU label.

Procedure

Step 1 In the Network VRU Explorer window, clickRetrieve and select the Network VRU you want to add the label
to.

The Label property tab appears.

Step 2 Complete the Label property tab.
The Routing client, Label, and Label type fields are required. All other fields are optional. For additional
information refer to the online Help.
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Step 3 Click Save to apply your changes.

Set Default Network VRU and Range of Correlation Numbers

For Network VRUs, you must use the System Information dialog to define a range of correlation IDs so the
system software can communicate with the VRU about the call.

Procedure

Step 1 Within the Configuration Manager, select Tools > Miscellaneous Tools > System Information.

The System Information window appears.

Step 2 In the System Information window, select the Default Network VRU.
Step 3 Enter the Minimum Correlation Number.
Step 4 Enter the Maximum Correlation Number.

For additional information refer to the online help.

Step 5 Click Save to apply your changes.

Configure scripts

Network VRU scripts

VRU scripts differ from routing scripts. A configured VRU script runs only when the Unified CCE instructs
it to do so from a routing script. A VRU script on the Unified CCE is the configured record for the VRU script
that resides on the VRU system. A VRU script executes to collect digits, play hold music, or perform many
other common functions.

After you configure the VRU scripts, you can use the Script Editor to write a routing script to send a call to
the VRU and invoke a specific VRU script.

For deployments that include the Unified CVP, use the Translation Route to VRU node to send calls to the
Network VRU and invoke VRU scripts. Do not use Translation Route to VRU node for deployments that use
the Unified CCE System PG. Instead, use any one of Queue to Skill Group or Send to VRU nodes.

Routing and administrative scripts

A routing script processes call routing requests from a routing client. Typically it examines several targets
and applies selection rules to find an available qualified agent or a target with the shortest expected delay.
You can set up different routing scripts to execute for different types of tasks. You can define call types in
terms of the telephone number the caller dialed, the number the caller is calling from, and additional digits
entered by the caller. For each call type, you can schedule different routing scripts to execute on different
days or at different times of the day.

An administrative script runs periodically to perform a task, such as setting variables.
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Configure Network VRU scripts

Procedure

Step 1 From the Configuration Manager, select Tools > List Tools > Network VRU Script List.

The Network VRU Script List dialog box opens.

Step 2 Click Retrieve and then click Add.
Step 3 On the Attributes tab, enter the configuration information for the VRU script as follows:

Network VRU. Specify the Network VRU with which this script should be associated.

VRU Script Name. Enter script name; for example, BasicQ.

Name. Enter the script file name; for example, BasicQ.aef

Timeout [seconds]. Enter 180.

Configuration param. Leave blank.

Customer. Choose the same Unified CCE customer you chose for call type from the drop-down list.

Step 4 Check the Interruptible check box.
Step 5 Click Save and the click Close.

Troubleshoot Network VRU scripts

If a timeout occurs on a VRU script, it is possible that the Router does not notify the VRU PIM that a timeout
has occurred. Because the VRU PIM is not informed of the problem, it does not notify the VRU to cancel the
script.

At this point, the options for script flow include the following:

• The failure path in the Router script sends the call to a label, the VRU PIM gets a Connect and, if the
VRU supports it, generates a Cancel message. This is the most common result.

• Before the Router picks a label, the VRU script completes and the VRU sends a Script Result message
to the Router. The Router then sends a Dialogue Failure Event because it is not expecting a Script Result.
This is the next most common result.

• The failure path in the Router script tries to run another VRU script. This is not a common result.

Currently, the best resolution to this problem is to use longer time-outs or create shorter VRU scripts. Be
aware that the failure exit from the Run VRU Script node is a problem that you may need to resolve.

VRU error checking

A special call variable VruStatus, allows you to check the result of the last VRU node (Send To
VRU/Translation Route to VRU/Run VRU Script) that the Unified CCE processed. The following table lists
the values for this variable.

DescriptionMeaningValue

The last VRU node was successful.VRU_SUCCESS0
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DescriptionMeaningValue

The last VRU node failed because of a routing or
configuration error.

VRU_ERROR1

The last Send To VRU or Translation Route to VRU node
failed because the routing client did not respond within
20 seconds or the last RunVRUScript node failed because
the timeout limit defined for the script expired.

VRU_TIMEOUT2

The last VRU node did not complete because the caller
hung up or was otherwise lost. (Because this causes the
routing script to terminate immediately, this value is never
seen.)

VRU_ABORTED3

The last VRU node failed because communication with
the VRU ended unexpectedly.

VRU_DIALOG_FAILED4

The VRU failed because the referenced VRU script was
not found in the Unified CCE configuration.

VRU_SCRIPT_NOT_FOUND5

Configure routing and administrative scripts

After you complete your Unified CCE configuration, you can write routing scripts and administrative scripts.
You create, maintain, and monitor these scripts using the Script Editor.

SeeFor Information about

Configuration Guide for Cisco Unified ICM/Contact Center
Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_configuration_guides_list.html

Creating Unified CCE scripts

Scripting and Media Routing Guide for Cisco Unified
ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html

Designing scripts for Unified CCE using the
Script Editor

Cisco Unified Contact Center Enterprise Reporting User
Guide at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_user_guide_list.html

Planning scripts for your Unified CCE
reporting needs

Outbound Option Guide for Unified Contact Center
Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps524/prod_installation_guides_list.html

Creating scripts for Outbound Option

Configure Agent Targeting Rules
The Agent Targeting Rules (ATR) configures call routing by specifying the agent extension range, instead
of configuring Device Targets and Labels for every phone/Routing Client. This simplifies the call routing
configuration for the Agent PGs. Also, this feature reduces the amount of memory used by the Router because
a large number of Device Targets and Labels are replaced by a few rules. ATRs are therefore, the preferred
method for installation.
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Before you begin

You must configure the PGs and routing clients before you configure the Agent Targeting Rules.

Procedure

Step 1 From the Configuration Manager, choose one of the following:

• Configure ICM > Targets > Device Target > Agent Targeting Rule.
• Tools > List Tools > Agent Targeting Rule.

The ICM Agent Targeting Rules dialog box opens.

Step 2 Click Retrieve.
Step 3 Click Add.
Step 4 Enter a name for the rule.
Step 5 Select a peripheral where the rule will be associated.
Step 6 Select the rule type:

• Agent Extension

• Substitute Agent Extension: Enter the agent extension prefix and agent extension length.

• Translation Route: Select a Translation Route.

For the Translation Route option, you must also configure the Translation Route DAIS as dialed numbers
associated with the target agent's peripheral routing client in Unified CCE. You must map the dialed
numbers to the route points that are configured in Unified CommunicationsManager and associated with
the JTAPI user. This is necessary to complete the Translation Route Rule.

Step 7 Select one or more routing clients that can initiate the route request.
Step 8 Enter the agent's extension range.
Step 9 Click Save.
Step 10 Test the rule configuration by routing calls from each routing client to each agent extension you defined. If

you defined a range, simplify the test by testing the lower and the upper limits of the agent extension, and a
sampling of the extensions in between the range limits.

Configure translation routes
Use the Translation Route wizard to configure the translation routes for the Unified CommunicationsManager
and VRU peripherals. This wizard automates the correct associations with peripheral targets, labels, and
routes.

Run the Translation Route Wizard only if your Unified CCE solution uses Unified CVP.Note
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Procedure

Step 1 In the Configuration Manager, select Tools > Wizards > Translation Route Wizard.

The Translation Route Wizard introductory dialog box opens.

Step 2 Click Next.

The Acquire Lock and Select Configuration Task dialog box opens.

Step 3 Select Create New.
Step 4 Click Next.

The Define Translation Route dialog box opens. The graphic on the left of the dialog box shows the entities
you are defining while using the Translation Route Wizard.

Step 5 Enter a long and short name for the translation route and, optionally, a description (the short name is used in
forming target names).

Step 6 Click Next.

The Select Configuration dialog box opens.

Step 7 Choose the single peripheral, single routing client configuration from the drop-down list.

The graphic changes to show the configuration you select.

Step 8 Click Next.

The Select Peripheral Gateway, Peripherals, and Services dialog box opens.

Step 9 Enter values for the following fields:

Peripheral Gateway. Choose the gateway target for the translation route.

Peripheral. Choose the single peripheral or the peripheral to route calls to.

Service/Service Array. If the translation route is associated with a single peripheral, choose the service
associated with the translation route. If the translation route is associated with multiple VRUs, then select a
service array.

Step 10 Click Next.

The Select Routing Clients and Dialed Numbers dialog box opens. Use this dialog box to specify the Unified
Communications Manager peripheral (or VRU peripheral) as the routing client from which translation routed
calls originate. For the Unified CCE the dialed number string is not applicable.

Step 11 Click Next.

The Select Network Trunk Groups for Routing Clients dialog box opens. Choose at least one network trunk
group to be used in peripheral targets associated with the translation route.

Step 12 Choose a routing client, select a network trunk group value for it, and click Add.

The Network Trunk Group appears in the list at the bottom of the dialog box.

Step 13 Click Next.

The Configure DAIS dialog box opens.
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Step 14 Use this dialog box to specify the DAIS values that map to route points on the VRU. Do one of the following:

• To enter a specific DAIS value, click Add DAIS and enter the value.

• To add a range of DAIS values, typically required by a translation route, click Add DAIS Range.

A dialog box prompts you to enter a starting and ending DAIS value. The Translation Route Wizard
automatically generates the DAIS values in the range.

Step 15 Click Next.

The Configure Label dialog box appears.

Step 16 Use this dialog box to define a label that maps to the DAIS/CTI route points. A label consists of a prefix and
a suffix. Each DAIS value requires a unique label. Do one of the following:

• Enter prefixes and suffixes individually.

• Use the buttons in this dialog box to set a range of values or to base the prefix or suffix values on the
DAIS values.

Step 17 Click Next.

The Wizard Complete dialog box opens.

Step 18 Click Create Translation Route to create the translation route and its associated entities.

First, the Translation Route Wizard displays a success message and then the dialog box appears.

Step 19 Do one of the following:

• To see details about the translation route you just created, click Run Report.

• To return to the beginning of the Translation Route Wizard and perform a new task, select Start New
Task and click Finish.

• To exit the Translation Route Wizard, click Finish.

You can also use the Translation Route Explorer to create a translation route or to modify a translation route
that you created with the Translation Route Wizard. Select Configuration Manager > Tools > Explorer
Tools > Translation Route Explorer.

Note

Configure Skill Groups or Precision Routing
Skill groups are collections of agents that share a common set of skills. Skill groups are associated with a
peripheral and are members of Services. You can associate agents with one or more skill groups.

To configure skill groups, you create skill groups, add the skill groups to services as members, and assign
agents to one or more skill groups.

Precision routing offers an alternative to skill group routing. Using Unified CCE scripting, you can dynamically
map the precision queues to direct a call to the agent who best matches the precise needs of the caller.

To configure precision routing, you create attributes, assign attributes to agents, create precision queues, and
create routing scripts.
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Configure Skill Groups

Add skill groups

You configure skill groups to group agents with similar skills. You can associate agents with one or more
skill groups. Skill groups are associated with a specific Unified Communications Manager PIM. You can
group skill groups from multiple PIMs into Enterprise Skill Groups. You can direct calls to (routed to)
Enterprise Skill Groups to share the load across multiple call centers or Unified Communications Manager
installations. You can do reporting on Enterprise Skill Groups.

Agents are assigned one or more skills by associating the agent with the desired skill group.

After you create services and skill groups, you associate one or more skill groups with a service by making
them members of that service.

A default skill group is created automatically when you create system PGs. The default skill group acts as a
bucket to capture information about calls not routed by Unified CCE. (A call placed directly to an agent
extension is an example of such a scenario.) If you deploy multichannel applications in your Unified CCE
system, default skill groups are created for each Media Routing Domain that you configure.

An agent must be assigned to at least one skill group to log in.Note

Procedure

Step 1 From the Configuration Manager, select Configure ICM > Peripherals > Skill Group > Skill Group
Explorer.
The Skill Group Explorer dialog box opens.

Step 2 In the Select filter data section, select the peripheral from the drop-down list:
Step 3 Click Retrieve and then click Add Skill group to add a new skill group for the selected peripheral.
Step 4 Click the Skill Group tab and enter values for the following:

Media Routing Domain. Use Cisco_Voice for agents that do not use other media. For more information, see
the Enterprise Chat and Email Installation Guide (for Unified Contact Center Enterprise) at
https://www.cisco.com/c/en/us/support/customer-collaboration/cisco-enterprise-chat-email/
products-installation-guides-list.html.

Peripheral Number. Enter the skill group number as known by the peripheral. This value must be unique
among all skill groups for the peripheral, but does not need to be unique across peripherals.

Peripheral Name. Enter the local name for the skill group. This value must be unique among all skill groups
for the peripheral, but does not need to be unique across peripherals.

Name. The Configuration Manager generates the value for this field. This value is a unique name for the skill
group made up of a default value from the peripheral enterprise name and the skill group peripheral name.

Available Holdoff Delay. For the Unified CCE peripheral type, set this field to 0.

Priority. This field is read-only and defaults to 0.

Extension. Leave blank for the Unified CCE peripheral type.

ICM picks the agent. Check this check box.
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Step 5 Click Save and then click Close.
Step 6 Repeat this procedure for any additional skill groups.

Assign skill groups as service members

To make a skill group a member of a service, you establish mappings of skill groups to services. Each skill
group can be mapped to zero, one, or more services. Each service can have zero, one, or more skill group
members.

Procedure

Step 1 From the Configuration Manager, choose Configure ICM > Peripherals > Service > Service Explorer.
The Service Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Click the service that directs the skill group and then click the Service Members tab.
Step 4 On the Service Members tab, click Add to associate a skill group with the service.
Step 5 Click OK.
Step 6 Click Save and then click Close.
Step 7 Repeat this procedure for each skill group you want to associate with a service.

Assign agents to skill groups

Agents must be assigned to at least one skill group in order to log in. You can assign agents to the most
appropriate skill groups according to their talents and skills to ensure that the most appropriate agent for a
request responds to the customer.

Procedure

Step 1 From the Agent Explorer dialog box, choose the Skill Group Membership tab.
Step 2 From the Skill group name list, select the skill groups to which you want this agent assigned.
Step 3 Click Add.

The Add Skill Group Membership box opens, showing the skill groups to which the agent has been assigned.
Step 4 Click OK.
Step 5 Click Save and then click Close on the Agent Explorer dialog box.
Step 6 Repeat this procedure to assign additional agents to skill groups.

You can remove agents from the Skill Group tab if necessary by selecting the agent and clicking Remove,
then Save.

Note

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
118

Initial Configuration
Assign skill groups as service members



Configure Precision Routing
To configure precision routing, use the Unified CCE Web Administration application, which links to various
precision routing gadgets. To access the application, click the CCE Web Administration shortcut on your
desktop, or copy the following URL into your browser: https://distributor ip/cceadmin.

For more information on precision routing, see the Cisco Unified Contact Center Enterprise Features Guide
at https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_feature_guides_list.html

Add Attributes

Procedure

Step 1 Navigate to Unified CCE Administration > Organization > Skills > Attributes.
Step 2 In theList of Attributeswindow, clickNew. TheNew Attributeswindow has two tabs: General andMember.
Step 3 Complete the following fields on the General tab:

DescriptionRequiredField

Type a unique attribute name. For example, to create
an attribute for mortgage insurance, type mortgage.

yesName

Enter a maximum of 255 characters to describe the
attribute.

noDescription

Select the type: Boolean or Proficiency.noType

Select the default (True or False for Boolean, or a
number from 1 to 10 for Proficiency).

noDefault

Step 4 Click Save.

Search for Agents

The Search field in the Agents tool offers an advanced and flexible search.

Click the + icon at the far right of the Search field to open a popup window, where you can:

• Select to search for agents only, supervisors only, or both.

• Select to search for all agents or only ECE enabled agents.

• Enter a username, agent ID, first or last name, or description to search for that string.

• Enter one or more site names separated by spaces. (Site is an OR search.)

• Enter one or more peripheral set names separated by spaces (Peripheral Set is an OR search). The search
is case-insensitive and does not support partial matches.

Search by department is available only when departments are configured.Note

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
119

Initial Configuration
Configure Precision Routing

https://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_feature_guides_list.html


Assign Attributes to Agents

Procedure

Step 1 With the selected agent displayed, click the Attributes tab.
Step 2 Complete the Attributes tab:

This tab shows the attributes associated with this agent and their current values.

Click Add to open a popup list of all attributes, showing the name and current default value for each.

a) Click the attributes you want to add for this agent.
b) Set the attribute value as appropriate for this agent.

Add Precision Queue

Procedure

Step 1 Navigate to Unified CCE Administration > Organization > Skills > Precision Queues.

This opens a List of Precision Queues window showing all precision queues that are currently configured.

Step 2 Click New to open the New Precision Queue window. Complete the fields.

DescriptionRequiredName

Enter up to 255 characters to
describe the precision queue.

noDescription

MRDs organize how requests for
media are routed. The system routes
calls to skill groups or precision
queues that are associated with a
particular communicationmedium;
for example, voice or email. This
field defaults to Cisco_Voice.

noMedia Routing Domain
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DescriptionRequiredName

Select the service level type used
for reporting on your service level
agreement.

Service level type indicates how
calls that are abandoned before the
service level threshold affect the
service level calculation.

• Ignore Abandoned Calls (the
default): Select this option if
you want to exclude
abandoned calls from the
service level calculation.

• Abandoned Calls have
Negative Impact: Select this
option if you want only those
calls that are answered within
the service level threshold
time to be counted as treated
calls. The service level is
negatively affected by calls
that abandon within the
service level threshold time.

• Abandoned Calls have
Positive Impact: Select this
option if you consider a call
that is abandoned within the
service level threshold time as
a treated call. With this
configuration, abandoned calls
have a positive impact on the
service level.

yesService Level Type

Enter the time in seconds that calls
are to be answered based on your
service level agreement, from 0 to
2,147,483,647.

The time that you enter in this field
is used to report on service level
agreements and does not affect how
long a call remains in a precision
queue. The length of time a call
remains in a step is determined by
the wait time for each individual
step.

yesService Level Threshold
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DescriptionRequiredName

Select an option to determinewhich
agents receive calls from this
queue.

The ordering of agents does not
dictate the agents who are selected
into a Precision Queue step. Agents
are included or excluded based on
the conditions specified for the step.

• Longest Available Agent (the
default): The default method
of agent ordering for a
precision queue. The call is
delivered to the agent who has
been in the available (or
ready) state the longest.

• Most Skilled Agent: The call
is delivered to the agent who
has the highest competency
sum from all the attributes
pertinent to the Precision
Queue step. In an agent-rich
environment, this can mean
that more competent agents
would be utilized more than
less competent agents.

• Least Skilled Agent: The call
is delivered to the agent who
has the lowest competency
sum from all the attributes
pertinent to the Precision
Queue step.

yesAgent Order

Select the bucket interval whose
bounds are to be used to measure
the time slot in which calls are
answered.

The field defaults to the system
default.

To select a different bucket
interval:

noBucket Intervals

Step 3 Click the numbered Step Builder link (Step 1, Step 2, and so on) to build a precision queue step in the Step
Builder popup window.

Step 4 When you have finished adding, click Save.
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Consider If Formula for Precision Queue

If you are not on the last step of the precision queue, then you can enter a Consider If formula for that step.
A Consider If formula evaluates a call (within a step) against additional criteria. Each time a call reaches a
step with a Consider If expression, the expression is evaluated. If the value for the expression returns as true,
the call is considered for the step. If the value returns as false, the call moves to the next step. If no expression
is provided for a step, the step is always considered for calls.

To add a Consider If formula, type the formula into the Consider If box. Alternatively, you can use the Script
Editor to build the formula and then copy and paste it into the Consider If box. Objects used in Consider If
formulas are case-sensitive. All Consider If formulas that you add to a precision queue must be valid. If you
add an invalid formula, you cannot save the precision queue. To ensure that the formula is valid, use Script
Editor to build and validate the formula.

Only the following scripting objects are valid in a Consider If formula:

• Call

• PQ

• Skillgroup

• ECC

• PQ Step

• Call Type

• Custom Functions (You can create custom functions in Script Editor.)

It is possible that a valid Consider If formula can become invalid. For example, if you delete an object used
in the formula after you create or update the precision queue, the formula is no longer valid.

Consider If Formula Examples

• PQ.PQ1.LoggedOn > 1--Evaluates whether there is more than one agent logged in to this queue.

• CallType.CallType1.CallsRoutedToday > 100--Evaluates whether more than 100 calls of this call type
were routed today.

• PQStep.PQ1.1.RouterAgentsLoggedIn > 1--Evaluates whether there is more than one router agent
logged in to this queue for Step 1.

• CustomFunction(Call.PeripheralVariable1) > 10--Evaluates whether this formula using a custom
function returns a value greater than 10.

Build Precision Queue Steps

Every precision queue must have a step, and every step must have an Expression. An Expression is a collection
of attribute terms.

Procedure

Step 1 Click the numbered step link in the Steps panel (Step 1, Step 2, and so on).

The step number popup window opens.
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Step 2 Build the first step as follows.
a) Click the magnifying glass icon to the right of the Select Attribute field in the Expression 1 panel.
b) Select an attribute from the list.
c) Use the two Select fields to establish the terms of the attribute. Click the first Select field to choose an

operator.

• For Boolean attributes, choices are the operators for Equal and Not Equal.

• For Proficiency attributes, choices are the operators for True, False, Less Than, Less Than or Equal
To, Greater Than, and Greater Than or Equal To.

d) Click the second Select field to choose a value.

• For Boolean attributes, values are True and False.

• For Proficiency attributes, values are numbers from 1 to 10.

Your selection creates an attribute term for the Expression.

Step 3 To add a second attribute to the first Expression, click Add Attribute in the Expression 1 row.
a) Select AND or OR to establish the relationship between the first and second attributes.
b) Repeat steps 2b, 2c, and 2d.

Step 4 Continue to add attributes to Expression 1.

All attributes within an expression must be joined by the same logical operator. They must all be ANDs, or
they must all be ORs.

Step 5 To add a second Expression, click the Add Attribute drop-down in the Expression 1 row and select Add
Expression.

Step 6 Select AND or OR to establish the relationship between the first and second Expressions.
Step 7 Add attributes to Expression 2.
Step 8 Continue to add Expressions as needed.

In this example, a Spanish caller located in the Boston area needs an onsite visit from a technician to repair
his ServerXYZ. An ideal agent should be fluent in Spanish and have the highest proficiency in ServerXYZ.
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This can be seen in Expression 1. Expression 2 allows us to specify that the selected agent must also be from
either Boston or the New England area.

Step 9 When you have completed the step, click OK to add it to the precision queue.
Step 10 To build the next step, click Add Step.

Each successive step is prepopulated with the Expressions and attributes of its predecessor. Decrease the
attribute qualifications and competencies in successive steps to lower the bar such that the pool of acceptable
agents increases.

Step 11 When you have created all steps, you can open any step except the last and enter values in the Consider if
and Wait for fields.

• Consider if is a formula that evaluates a call within a step against additional criteria. (See Consider If
Formula for Precision Queue, on page 123 for more information about Consider If.)

• Wait for is a value in seconds to wait for an available agent. A call will queue at a particular step and
wait for an available agent matching that step criteria until the number of seconds specified. A blank
wait time indicates that the call will proceed immediately to the next step if no available agents match
the step criteria. Wait time defaults to 0 and can take a value up to 2147483647.

Configure routes
The route is a value returned by a routing script that maps to a target or a peripheral. Those targets include
services, skill groups, agents, translation routes, queue points, or CTI route points. The Unified CCE converts
a route to a device target to direct to the request destination.

When you create a route, you associate the route with a service.

Procedure

Step 1 From the Configuration manager, choose Tools > Explorer Tools > Skill Group Explorer.
The Skill Group Explorer dialog box opens.

Step 2 Click Retrieve.
Step 3 Choose the skill group for which you are creating the route.
Step 4 Click Add Route.

The Route tab opens.

Step 5 In the Route tab, enter information in the following fields:

Skill group priority. The value 0 indicates a base skill group. This is the default when there is only one skill
group and there are no priorities.

Name. The enterprise name of the route.

Description. Enter an optional description of the route.

Service Name: The name for the service.
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Step 6 Click Save.

When you break the association between a route and a peripheral, the Unified CCE removes the Route ID
value from all peripheral targets that reference that route.

Caution

Perform Bulk Configuration

Access Bulk Configuration Tools

Procedure

Step 1 Double-click Configuration Manager in the Administration Data Server group or the Administration Client
group.

Step 2 In the Menu selection box, select Tools > Bulk Configuration.
Step 3 From the submenu selection list, select Insert if you need to insert data or Edit if you need to edit.
Step 4 In the next menu selection list, select the type of table with which you need to work.

Add New Records

You can add records by inserting multiple blank rows (records) and filling in the data or by importing the
data.

You can also edit the data you insert when you insert it.

Insert New Records

To insert a new record:

Procedure

Step 1 In the Bulk Configuration > Insertmenu, select the name of the data table to which you want to add records.
The appropriate Insert window opens, automatically displaying one new row.

Step 2 To create additional rows, enter the number of additional rows in the Quantity field and click Insert. The
additional rows are added in the Insert window.

Step 3 Enter the data in the rows:
a) If you want to edit individual fields in the new rows, type the information you want in each of the fields

and skip to Step 8.
b) If you want to edit a column in multiple rows so that a range of values is entered, continue to Step 4.

For other ways of entering data into multiple rows, see Edit Range of Data, on page 129Note

Step 4 Select the rows in the column you want to modify.
Step 5 Click Edit Range. The Edit Range dialog appears.
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Step 6 Enter a prefix (optional), the start value for the range, and a suffix (optional). The generated values are listed
in the dialog.

Step 7 Click OK to close the Edit Range dialog and apply the values to the column you selected.
Step 8 When you have finished setting fields in the new rows, press Enter to apply your changes to the Unified CCE

database.

You can leave empty rows, the system ignores them. No changes are made to the database until
you press Enter.

Note

Import Data

You can import data from a specified text file into the opened database table. You can import whole records
or only columns of data if the data matches (see Step 3 of the following procedure). The process cancels if
any error occurs during the import process.

Procedure

Step 1 In the Insert or Edit window, click Import.
Step 2 In the Import dialog, click File.
Step 3 In the File Open dialog, select the file containing the data that you want to import and click Open.

The Import File Data area displays the first few lines of the opened file.

• When importing data in the Edit mode, the following rules apply:

• The Bulk Configuration tool reads only those records whose primary key values match those of
records in the Edit window.

If a record does not match the primary key value, the record is considered to be an error and a
message box with the primary key value pops up to ask you to correct the problem.

• If any field in the import record is null, the corresponding field value in the grid window become
blank for an edit cell or uses the default value for a drop-down list cell.

• If any field is missing in the import file, the corresponding field in the Edit window remains
unchanged.

• If there is a larger number of records in the file to be imported than the number of rows in the grid,
it is considered an error and a message box pops up asking you to correct it.

• If there is a duplicated primary key in the file to be imported, it is considered an error and a message
box with the duplicated primary key value pops up asking you to correct it.

• After importing, all records imported (including records marked for deletion in the grid) are marked
as “Changed” regardless of whether the value is changed or not.

• After importing, the records display in index order (ordered by logical keys). If you did not sort
before importing, the order appears the same after the import.

• When importing data in the Insert mode, the following rules apply:

• Only a single import is supported and any existing rows are removed from the grid. When you click
Import, the following message box pops up if there is any record in the grid:
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All the existing data will be replaced by the data to be imported.
If you want to retain the current data on the grid please click
the Cancel button then save or export the existing data. Click the
OK button to proceed with the importing.

• After importing, all rows are marked as “New” and the ordering is the same as that in the file
imported from.

• In the Import Insert mode, the tool reads only those records whose primary key values are not
presented. If the primary key field is selected for file to be imported, it is considered an error and a
message box with the primary key field name pops up asking you to correct the problem.

• If any field in the import record is null, the corresponding field value in the grid window becomes
blank for an edit cell or uses the default value for a drop-down list cell.

If headers are included in the imported file, the Add and Remove buttons are not
enabled and you can only import the records as a whole. In that case, skip to Step 6.

Note

Step 4 If the imported data does not contain headers, in the Available Fields list box, select the names of the fields
to import that match the data and click Add.

Step 5 To change the order of the columns, select a column and move it within the list by clicking Up or Down.
Step 6 Click OK. The data is imported into the data table.

Data File Format

The import and export files used by the Bulk Configuration tool can optionally include a header that identifies
the table and columns in the file. The header is followed by one line for each row of data.

The following rules apply to file headers:

• A line beginning with a number sign (#) is a comment and is ignored.

• Blank lines are also ignored.

• The header content is indicated by a line beginning with two underline characters and the word TABLE
or COLUMNS. The following line contains the name of the table or the name of the columns. For
example:

__TABLE

Call_Type __

COLUMNS

CallTypeID EnterpriseName Description Deleted CustomerDefinitionID

• All column names must be on a single line and are separated by Tab characters.

The following rules apply to the data in the files:

• One row of table data per line.

• Column values must be in the same order in all rows. If columns are specified in the header, the
columns in the data rows must be in the same order.

• Column values are separated by a single Tab character.
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• Fields intentionally left blank must be represented by two adjacent Tab characters or a Tab character
at the end of a line. On import, the default value is used for such a value.

• String values may include spaces.

• An error occurs on import if a line contains too few or too many values.

A simple way to create the import file with a valid format is to use Excel and
save the file as Text (Tab delimited) (*.TXT).

Note

Select Data

You can select whole records for importing, exporting, setting security, deleting, or undeleting. Or, you can
select the same field in multiple records for simultaneous editing.

Select Records

Click in the left-most numbered field in a row to select that row and highlight it. Click in any other field in a
row to select the row but not highlight it.

Select One Field in Multiple Records

You can select one edit-control field (when there is no section box in the field) in multiple records in any of
the following three ways:

• Click the field where you want to start and, keeping the left mouse button held down, move the cursor
to the last field.

• Click the field where you want to start. While holding down the Shift key, click the last field.

• Click the field where you want to start. While holding down the Shift key, click the down arrow to select.

• Press Ctrl, then click on each field you wish to select. This allows you to select a discontinuous group
of fields.

Edit Range of Data

You can edit a range of data in a table column in three ways:

Procedure

• Apply a single value to a range of edit-control fields
• Apply a single value to a range of selection-box fields
• Apply a range of values to a range of fields

Apply a Single Value to a Range of Edit-Control Fields

An edit-control field is one you can edit that does not contain a selection box.

To apply a single value to a range of edit-control fields:
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Procedure

Step 1 Make your selection: click the field where you want the range to start and, keeping the left mouse button held
down, move the cursor to the last field in the range.

Step 2 Type the new entry that you want to appear in all the fields.
Step 3 Click Enter or Tab. This applies the change to all the records in the range and moves the focus to the next

data field.

Apply a Single Value to a Range of Selection-Box Fields

To apply a single value to a range of selection-box fields:

Procedure

Step 1 Select the first field where you want the range to start.
Step 2 Press the Shift key and hold it down for steps 3, 4, and 5.
Step 3 Click the selection-box down arrow but keep the left mouse button held down and select the fields you want

in the range.
Step 4 Click the last field in the selection to display the selection list. You can also open the selection box by pressing

Alt + an arrow key.
Step 5 Click your selection.
Step 6 Click Enter or Tab (or any other field). This applies the change to all the records and moves the focus to the

next data field.

Apply a Range of Values to a Range of Fields in a Column

To apply a range of values to a range of fields in a column:

Procedure

Step 1 Select the range of fields in a database column. This enables the Edit Range button.

The Edit Range button does not work for selection-box fields.Note

Step 2 Click Edit Range. The Edit Range dialog displays.
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Figure 2: Edit Range Dialog Box

Step 3 In the Edit Range From field, enter the first number of the range.
Step 4 In the Prefix and Suffix fields, you can optionally enter substrings to appear before or after each value. The

Edit Range dialog lists the generated values.

When entering a numeric range, you may also enter leading zeros to ensure proper alignment
(that is, 001 to 999).

Note

Step 5 Click OK. This applies the changes to the fields you selected in the Insert or Edit window.

Configure Cisco Unified Intelligence Center

Acquire License

Procedure

Step 1 Go to the following URL:

https://software.cisco.com/download/home/282163829/type/282377062/release/11.5%25281%2529

Step 2 Download the CUIC_Premium.lic file.
Step 3 Save the license file in a location where the System Application User can access it.

Sign In to Administration Console
Who can sign in to the administration console: The System Application User who is the default Superuser.

To upload the license, you must sign in to the Unified Intelligence Center Administration Console. This is
the OAMP interface for Unified Intelligence Center. The first person who signs in to the Administration
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application must do so using the user ID and password that were defined for the System Application User
during the installation. This user is the initial Superuser for Unified Intelligence Center Administration.

Procedure

Step 1 Enter this URL: http://<HOST ADDRESS>/oamp, where HOST ADDRESS is the IP address or hostname of
your Controller node.

Step 2 Enter the System Application User ID and password that you defined during installation.

Upload License
After the license file is uploaded to the publisher node, within a minute, it is automatically replicated to all
nodes in the cluster.

Procedure

Step 1 In the Administration application, choose Cluster Configuration > License Management.
Step 2 Click Browse.
Step 3 Navigate to the location where the *.lic file was saved.
Step 4 Click Apply License to load the license.

A message appears indicating that the license file was uploaded successfully and will be distributed to other
nodes (if any) in the cluster in approximately one minute.

The databases are polled once a minute for changes. The license replication is not immediate but
occurs within a minute.

Note

Configure SQL User Account

Procedure

Step 1 Launch Microsoft SQL Server Management Studio on the Administration and Data Server.
Step 2 Navigate to Security > Logins, right-click Logins and select New Logins.

Use these steps to create login accounts for theCisco Unified Intelligence Center reporting data sources and
for Finesse connectivity to the AW Database on the Cisco Finesse Administration page.

Step 3 On the General Screen:
a) Enter the Login Name.
b) Select SQL Server authentication.
c) Enter and confirm the password.
d) Uncheck Enforce password policy.

Step 4 In the Server Roles page, check the following check boxes:

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
132

Initial Configuration
Upload License



• public

• securityadmin

• serveradmin

• setupadmin

• sysadmin

Step 5 On the User Mapping page, do the following:

a. Check the Real-time database and Historical database check boxes.

b. In Database role memberships pane, check the following check boxes:

• db_datareader

• db_datawriter

• db_ddladmin

• db_owner

• db_securityadmin

• public

For an SQL user configured to work with Live Data, check the master database check box
and the db_datareader and db_datawriter check boxes (in Database role memberships pane).

Note

Step 6 Click OK.

What to do next

Ensure that you configure SQL User Account on both the primary and secondary AW databases.Note

Configure Data Sources
To integrate Unified Intelligence Center with Unified CCE, youmust configure the following two data sources:

• Unified CCE Historical data source—This data source is added by default to support the Unified CCE
stock historical reports and Unified CCEUser Integration. Complete the Database Host, Database Name,
and the Database User ID and Password fields for this data source and ensure that it is online before
Unified CCE User Synchronization can occur.

• Unified CCE Realtime data source—This data source is added by default to support the Unified CCE
stock real time reports. Complete the Database Host, Database Name, and the Database User ID and
Password fields for this data source.

Depending on your environment, the Unified CCE Historical and Realtime data sources can point to the same
machine.
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You can execute a CLI command to point each node to a unique IP Address for the Unified CCE Historical
or Realtime data source. The command is set cuic properties host-to-ip. For more information about
the CLI, see the Administration Console User Guide for Cisco Unified Intelligence Center at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/products-maintenance-guides-list.html.

To integrate Unified Intelligence Center with Unified CVP, you must add a Unified CVP data source.

A Unified Intelligence Center data source is also installed by default. This data source represents the Unified
Intelligence Center database on the node that stores records for reports, dashboards, and users maintained on
that node. This data is replicated across all nodes in the cluster. You can edit the description for this data
source, but do not change other fields. The Unified Intelligence Center data source for each node is configured
by default to point to that member.

Configure Unified CCE Data Sources

Procedure

Step 1 From the Unified Intelligence Center Reporting application, click Data Sources drawer on the left panel to
open the Data Sources page.

Step 2 Select the Unified CCE Historical Data Source.
Step 3 Click Edit to open the Data Source Create/Edit page.
Step 4 Complete the fields for the selected data source. See online help for guidance.

The name of the database instance is a required field only for Informix databases.Note

Step 5 Test the data source connection. Troubleshoot, if required.
Step 6 Save the data source.
Step 7 Repeat steps 2 through 6 for the Unified CCE Realtime data source.

Create Data Source for Cisco Unified CVP Report Data

Procedure

Step 1 Log in to the Unified Intelligence Center at https://<hostname/ IP address of CUIC
Publisher>:8444/cuicui.

Step 2 Select the Data Sources drawer to open the Data Sources page.
Step 3 Click New to open New Data Source page.
Step 4 Complete fields on this page as follows:

ValueField

Enter the name of this data source.

Report Designers and Report Definition Designers do not
have access to the Data Sources page but can see the list of
Data Sources when they create custom reports. To benefit
those users, give a new Data Source a meaningful name.

Name
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ValueField

Enter a description for this data source.Description

Choose Informix.

Type is disabled in Edit mode.Note

Data Source Type

Host Settings

Enter the IP address or hostname for the Unified CVP
Reporting server.

Database Host

Enter the port number. Typically, the port is 1526.Port

Enter the name of the reporting database on the Unified CVP
reporting server. The database name can be cvp_data or
callback.

Database Name

Specify the instance name of the desired database. By default,
this is cvp.

Instance

Choose the correct time zone for the data stored in the
database. In locations that change from Standard Time to
Daylight Savings Time, this time zone is updated
automatically.

Set CVP datasource timezone configuration to
UTC on CUIC.

Note

Timezone

Authentication Settings

Enter the user ID of the Reporting User who is configured in
the Operations Console to access the Unified CVP reporting
database.

(The cvp_dbuser account is created automatically during
Unified CVP Reporting server installation.)

Database User ID

Enter and confirm the password for the database user.Password and Confirm Password

Choose UTF-8.Charset

View or edit the permissions for this datasource forMyGroup
and for the All Users group.

Default Permissions

Select the maximum pool size.

Value ranges from 5-200. The default Max Pool Size value
is 100 and is common for both the primary and secondary
data source tabs.

Max Pool Size

Step 5 Click Test Connection.

If the status is not Online, review the error message to determine the cause and edit the data source accordingly.
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Step 6 Click Save to close the Add Data Source window.

The new data source appears on the Data Sources list.

Cisco Unified Intelligence Center Reporting User Roles

There are seven User Roles, and a user can be assigned to one, any, or all of them. The roles are:

• Login User

• System Configuration Administrator

• Security Administrator

• Dashboard Designer

• Value List Collection Designer

• Report Designer

• Report Definition Designer

Depending on the size, staff, geographical distribution, and security practices of your call center, you might
want to assign multiple user roles to a few people or to distribute user roles to many people.

Login User

By default, everyone who can sign in to Unified Intelligence Center is a Login User. Login Users have that
role and only that role until the Security Administrator assigns additional roles or deactivates (removes) the
Login User role.

A Security Administrator or System Application user can remove the login role from any user.

An active login user can:

• Log in to Unified Intelligence Center

• Open the Security drawer, access the User List, and edit his own User Information page; for example,
to change his alias or phone number.

System Configuration Administrator

This user has all the rights of an active Login User and also:

• Has full access to the Data Sources drawer and its functions.

• Has full access to the Scheduler drawer and its functions.

Security Administrator

This user has all the rights of an active Login User and also has full access to the Security drawer and its
functions.

Dashboard Designer

This user has all the rights of an active Login User and also has full access to the Dashboard drawer.
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Value List Collection Designer

This user has all the rights of an active Login User and also:

• Has full access to the Value Lists drawer.

• Has View (Read) access to the Data Sources drawer.

Report Designer

This user has all the rights of an active Login User and also:

• Has full access to the Reports drawer.

• Has View (Read) access to the Data Sources and Value Lists drawers.

• Can access the Scheduler drawer to work with the user's own reports.

Report Definition Designer

This user has all the rights of an active Login User and also:

• Has full access to the Report Definition drawer.

• Has View (Read) access to the Data Sources and Value Lists drawers.

Download Report Bundles
The following Cisco Unified Intelligence Center report bundles are available as downloads from Cisco.com
https://software.cisco.com/download/type.html?mdfid=282163829&catid=null. Click the Intelligence Center
Reports link to view all available report bundles:

• Realtime and Historical Transitional templates - Introductory templates designed for new users. These
templates are simplified versions of the All Fields templates, and are similar to templates available in
other contact center solutions.

• Realtime and Historical All Fields templates - Templates that provide data from all fields in a database.
These templates are most useful as a basis for creating custom report templates.

• Live Data templates - Templates that provide up to the moment data for contact center activity.

• Realtime and Historical Outbound templates - Templates for reporting on Outbound Option activity.
Import these templates if your deployment includes Outbound Option.

• Realtime and Historical Cisco SocialMiner templates - Templates for reporting on SocialMiner activity.
Import these templates if your deployment includes SocialMiner.

• Cisco Unified Intelligence Center Admin Security templates - Templates to report on Cisco Unified
Intelligence Server audit trails, permissions, and template ownership.

Additionally, sample custom report templates are available from the Cisco Developer Network
(https://developer.cisco.com/web/ccr/documentation).
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Import Report Bundles

Procedure

Step 1 Sign in to Unified Intelligence Center at https://<hostname/ IP address of CUIC Publisher>:8444/cuicui, and
click Reports in the left pane.

Step 2 Click Import Report.
Step 3 In the File Name (XML or ZIP file) field, click Browse.
Step 4 Browse to and select the report bundle zip file, and click Open.

Select a report bundle for the version of software deployed in the contact center.

Step 5 Select the location where you want to save the file.
Step 6 Click Import.
Step 7 Choose one:

• If the report or reports do not yet exist, you must provide the data source. From the Data Source for
ValueList drop-down list, select the data source used. Then click Import.

You have to select a data source for the value list only if it does not use the same data source
as the report definition. For LiveData reports, the Data Source for ReportDefinition is
LiveData Streaming and the Data Source for ValueList is UCCE Realtime. For real time
reports, the Data Source is UCCE Realtime. For historical reports, the Data Source is UCCE
Historical.

Note

• If the report or reports do exist, a message appears asking you if you want to replace the existing report
(which overwrites any report definition changes associated to it). Click Yes, Yes to All, No, or No to
All.

Configure Unified Intelligence Center Administration
Complete the following procedure to configure Unified Intelligence Center Administration.

Procedure

Step 1 Sign in to the Cisco Unified Intelligence Center Administration Console
(https://<hostname>:8443/oamp).

Step 2 Configure the Active Directory tab under Cluster Configuration > Reporting Configuration.
a) For Host Address for the Primary Active Directory Server, enter the IP address of the domain controller.
b) For Port, enter the port number for the domain controller.
c) Complete the Manager Distinguished Name fields that are required for the customer.
d) Enter and confirm the password with which the Manager accesses the domain controller.
e) For User Search Base, specify users and the domain name and any sub-domain names .
f) For Attribute for User ID, select the required option.
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If the Windows domain name and the NETBIOS names are different, do the following: in
the Cisco Unified Intelligence Center Administration Console, under Active Directory
Settings, in the field Attribute for User ID, ensure to select sAMAccountName, and add the
NETBIOS value to set it as default value.

Note

g) Add at least one domain for the UserName Identifier. Do not type the @ sign before the domain name.
h) Set a domain as the default.
i) Click Test Connection.
j) Click Save.

For more details, see the online help.Note

Step 3 Configure syslog for all devices.
a) Choose Device Management > Logs and Traces Settings.
b) For each host address:

• Select the associated servers and click the arrow to expand.

• Select the server name.

• In the Edit Serviceability Settings screen Syslog Settings pane, configure the Primary and Backup
Host. Click Save.

Step 4 Configure SNMP for all devices, if used.
a) Select Network Management > SNMP.
b) Navigate to SNMP and for each server add the following:

• V1/V2c Community Strings.

• Notification Destination.

Configure Cisco Unified Customer Voice Portal

Configure Unified CVP Server

Set Up FTP Server

Procedure

Step 1 Install the FTP Service on the server.
a) Choose Start > Administrative Tools > Server Manager.
b) Expand Roles in the left panel of the Server Manager window.
c) Right-click Web Server (IIS) and click Add Role Services.
d) Check the FTP Server check box, click Next and then click Install, installation takes a few moments.
e) When the installation is complete, click Close.
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Step 2 Enable the FTP Service on the server.
a) Choose Start > Administrative Tools > Server Manager.
b) Expand Roles in the left panel of the Server Manager window.
c) Expand Web Server (IIS) and then click Internet Information Services (IIS) Manager.
d) Expand hostname.
e) Right-click Sites and click Add FTP Site.
f) Enter a FTP site name.
g) Enter c:\Inetpub\wwwroot in the Physical path of the FTP site name, and click Next.
h) Enter the IP address of the CVP Server.
i) Select No SSL in SSL Options and then click Next.
j) Check the Anonymous and Basic check boxes.
k) Select All Users from the Allow Access To drop-down list.
l) Check the Read and Write check boxes, and then click Finish.

Step 3 Set the Basic Setting for the FTP Server.
a) Click Sites and then click the FTP server that you have created.
b) Click Basic Settings in the Actions tab and click Connect as.
c) Select Application user (pass-through authentication) option and click OK twice.

Configure Unified CVP Reporting Server

Create Reporting Users

Who can create a user:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Superuser.

Unified CVP reporting users can sign in to Unified Intelligence Center only if they exist in the Administration
console as Superusers or if Active Directory (AD) is configured in the Unified Intelligence Center
Administration console for their domain:

• Superusers who are added are considered to be IP Multimedia Subsystem (IMS) users.

• Users who are authenticated through Active Directory are considered to be Lightweight Directory Access
Protocol (LDAP) users.

Both IMS users and LDAP users can log in to Unified Intelligence Center reporting and are restricted to the
limited Login User role until the Unified Intelligence Center reporting security administrator gives them
additional roles and flags them as active users.

Create Superusers

Procedure

Step 1 Log in to the Cisco Unified Intelligence Center Administration Console (https://<HOST ADDRESS>/oamp).
Step 2 Navigate to Admin User Management > Admin User Management to open the Users page.
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Step 3 Click Add New to add and configure a new user or click an existing username to edit the configuration for
that user.

This page has three tabs: General, Credentials, and Policy. For information about completing these tabs, see
Administration Console User Guide for Cisco Unified Intelligence Center at https://www.cisco.com/en/US/
products/ps9755/prod_maintenance_guides_list.html or the Administration console online help.

Step 4 Click Save.

Set Up Active Directory Server for LDAP Users

Configure the Active Directory tab in the Cisco Unified Intelligence Center Administration console so that
Unified CVP reporting users can log in to the Unified Intelligence Center reporting application with the user
name and password that is defined in their domain.

Procedure

Step 1 In the Cisco Unified Intelligence Center Administration application, navigate to Cluster Configuration >
Reporting Configuration and select the Active Directory tab.

Step 2 Complete all fields on this page, referring to the online help for guidance.
Step 3 Click Test Connection.
Step 4 When the connection is confirmed, click Save.

Sign In to Cisco Unified Intelligence Center Reporting Interface

Who can sign in to the Unified Intelligence Center reporting interface:

• Initially, the System Application User who is the default Superuser.

• Eventually, any Unified CVP user who was created in the Administration Console as an IMS superuser
or an LDAP user.

Perform the following procedure to sign in to the Unified Intelligence Center reporting interface.

Procedure

Step 1 Sign in to the Cisco Unified Intelligence Center Administration Console (https://<HOST ADDRESS>/oamp).
Step 2 Navigate to Control Center > Device Control.
Step 3 Click on the name of the Member node you want to access. This opens the Cisco Unified Intelligence Center

login page for that member.
Step 4 Enter your user ID and password. The Overview page appears.
Step 5
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Cisco Unified Customer Voice Protocol Reporting User Role Additions

Once Unified CVP users log in to Unified Intelligence Center, they are added to the Unified Intelligence
Center database and appear on the user list.

New users are initially defined as Login Users: the lowest level user role of Unified Intelligence Center. A
Unified Intelligence Center Security Admin user must access the User List page to check a User is Active
check box and to grant additional user roles to the user.

Figure 3: User List Page

Obtain and Import Report Templates

Obtain Cisco Unified CVP Report Templates

Who can obtain import Unified CVP report templates: any user in your organization.

The Unified CVP reporting template XML files are installed with Unified CVP. Locate them and copy them
to a Cisco Unified Intelligence Center client workstation.

Perform the following procedure to obtain import Unified CVP report templates.

Procedure

Step 1 In the Unified CVP server, locate the Unified CVP template files. These are XML files that reside on the
reporting server in %CVP_HOME%\CVP_Reporting_Templates. You can also find them in the Installation
directory \Downloads and Samples\Reporting Templates.

Step 2 Choose the files and copy them to the client computer from where you can launch the Unified Intelligence
Center Reporting web application.
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Import Unified CVP Report Templates

Procedure

Step 1 Launch the Unified Intelligence Center web application using the URL https://<CUCI ADDRESS:8444/cuicui/.
Step 2 Enter CUIC Username and Password.
Step 3 Create a folder to import the reports.

a) Click Reports.
b) From the toolbar, click New > Folder.
c) Enter the folder name and click Save.

Step 4 Import the report templates.
a) Click Reports > New > Import. You will be redirected to the CUIC legacy interface.
b) Click Reports > Import Report.
c) In the File Name (XML or ZIP File) field, click Browse and select the template file to import.
d) In the Save To field, expand the Reports tree and select the folder created to import the report template.
e) Click Import. CUIC validates the Report Definition ID in the template and successfully imports the

template.

When one or more underlying Report Definitions do not exist in CUIC, you will be prompted to
select a data source for the Report Definition and Value Lists. For information on creating Data
Sources and Value Lists, see Cisco Unified Intelligence Center Report Customization Guide at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-user-guide-list.html.

Note

Configure Unified CVP Operations Console

Enable Unified CVP Operations Console

Complete the following procedure on the Unified CVP OAMP server to enable the Unified CVP Operations
Console.

Procedure

Step 1 Go to Start > Run and type services.msc.
Step 2 Check that Cisco CVP OPSConsoleServer service is running. If it is not, right-click that service and click

Start.
Step 3 Go to Start > All Programs > Cisco Unified Customer Voice Portal > Operation Console to open the

Unified CVP OPSConsole page. If you are using Microsoft Internet Explorer, you will need to accept the
self-signed certificate.
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Configure Unified CVP Call Server Component

• There is one Unified CVP server on Side A and one Unified CVP server on side B for the 500 agent
deployment.

• There are two Unified CVP servers on Side A and two Unified CVP server on side B for the 1000 agent
deployment.

• There are eight Unified CVP servers on Side A and eight Unified CVP server on side B for the 4000
agent deployment.

Note

Procedure

Step 1 On the Unified CVP OAMP server, go to Start > All Programs > Cisco Unified Customer Voice Portal.
Step 2 Click Operations Console and log in.
Step 3 Navigate to Device Management > Unified CVP Call Server.
Step 4 Click Add New.
Step 5 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Server. Check ICM,

IVR, and SIP. Click Next.
Step 6 Click the ICM tab. For each of the Cisco Unified CVP Call Servers, retain the default port of 5000 for the

VRU Connection Port.
Step 7 Click the SIP tab:

a) In the Enable outbound proxy field, select No.
b) In the Use DNS SRV type query field, select Yes.
c) Check Resolve SRV records locally.

Step 8 Click the Device Pool tab. Make sure the default device pool is selected.
Step 9 (Optional) Click the Infrastructure tab. In the Configuration Syslog Settings pane, configure these fields as

follows:
a) Enter the IP address or the hostname of the syslog server.

Example:

Prime server
b) Enter 514 for the port number of the syslog server.
c) Enter the name of the backup server to which the reporting server writes log messages.
d) In the Backup server port number field, enter the port number of the backup syslog server.

Step 10 Click Save & Deploy.
Step 11 Repeat this procedure for the remaining Unified CVP Servers.
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Configure Unified CVP VXML Server Component

Procedure

Step 1 In the Unified CVP Operations console, navigate to Device Management > Unified CVP VXML Server.
Step 2 Click Add New.
Step 3 On the General tab, enter the IP address and the hostname of the Cisco Unified CVP Server.
Step 4 Configure the primary and backup CVP Call Servers.
Step 5 Click the Configuration tab. In the Enable reporting for this CVP VXML Server field, click Yes to

optionally enable reporting. If you do not want to enable reporting, click No.
Step 6 Click the Device Pool tab. Make sure the default device pool is selected. If prompted to restart the primary

and secondary call servers, click No. Do not restart at this time.
Step 7 Click Save & Deploy.
Step 8 Repeat this procedure for all CVP Servers.

Configure Unified CVP Media Server

Procedure

Step 1 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 2 Click Add New.
Step 3 On the General tab, configure the following.

a) Enter the IP address and the hostname of the Unified CVP server.
b) Check FTP Enabled.
c) Either Check Anonymous Access or enter the credentials.
d) Click Test SignIn to validate the FTP access.

Step 4 Click Save.
Step 5 Repeat Step 1 through 4 for all Media Servers.
Step 6 After you configure all Media Servers, click Deploy.
Step 7 Click Deployment Status to make sure that you applied the configuration.
Step 8 In the CVP Operations Console, navigate to Device Management > Media Server.
Step 9 Change Default Media Server from None to any one of the Unified CVP servers. Then click Set.
Step 10 Click Deploy.

Install Unified CVP licenses

Procedure

Step 1 Sign in to the CVP Operations Console.
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Step 2 Choose Bulk Administration > File Transfer > Licenses.
Step 3 In the Select device type field, choose All Unified CVP devices.
Step 4 Browse and select the license file.
Step 5 Click Transfer.
Step 6 Click File Transfer Status to monitor transfer progress.

Configure Gateways

Procedure

Step 1 In the Unified CVP Operations Console, navigate to Device Management > Gateway.
Step 2 Click Add New.
Step 3 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the hostname.
c) Choose the Device Type.
d) In the Username and Passwords pane, enter the username, password, and enable password.

Step 4 Click Test Sign-in to verify that a connection with the gateway can be established and that the credentials
are correct.

Step 5 Click Save.
Step 6 Repeat for every gateway.

Add Unified CCE Devices

Procedure

Step 1 Log in to the Unified CVP Operations Console.
Step 2 Choose Device Management > Unified ICM.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the Hostname.
c) Check Enable Serviceability.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.

Step 5 Click Save.
Step 6 Repeat Steps 1 to 5 for all Unified CCE machines.
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Add Unified Communications Manager Devices

Procedure

Step 1 Log in to the CVP Operations Console.
Step 2 Choose Device Management > Unified CM.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the Hostname.
c) Check Enable Synchronization.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.

For Small contact center deployment add the NAT IP address of the unified CM.Note

Step 5 Click Save.
Step 6 Repeat Steps 1 to 5 for all Unified Communications Manager Devices.

Add Unified Intelligence Center Devices

Procedure

Step 1 Log in to the CVP Operations Console.
Step 2 Navigate to the Cisco Unified Intelligence Center Device. Choose Device Management > Unified IC.
Step 3 Click Add New.
Step 4 On the General tab, configure as follows:

a) Enter the IP address.
b) Enter the Hostname.
c) Check Enable Serviceability.
d) Enter the Username.
e) Enter the Password.
f) Confirm Password.
g) Accept the default port.
h) Associate all the existing CVP Reporting Servers.

Step 5 Click Save.

Transfer Scripts and Media Files

Create the notification destination and deploy to all of the Unified CVP devices.
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Procedure

Step 1 In the Unified CVP Operations Console, navigate to Bulk Administration > File Transfer > Scripts &
Media.

Step 2 In the Select device type field, select the Gateway.
Step 3 Move all Gateways to Selected.
Step 4 Click Default Gateway files.
Step 5 Click Transfer and select OK at the popup window.
Step 6 Click File Transfer Status to monitor transfer progress.

Configure SNMP

Formore information about SNMP inUnified CCE, see the Serviceability Guide for Cisco Unified ICM/Contact
Center Enterprise at http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_
configuration_guides_list.html and SNMP Guide for Cisco Unified ICM/Contact Center Enterprise at
http://www.cisco.com/en/US/products/sw/custcosw/ps1844/products_installation_and_configuration_guides_
list.html.

Procedure

Step 1 In the Unified CVP Operations Console, navigate to SNMP > V1/V2c > Community String .
Step 2 Click Add New.

a) On the General tab, name the community string.
b) On the Devices tab, select the required device from the list of available devices.
c) Click Save and Deploy.

Step 3 Create the notification destination and deploy to all of the Unified CVP devices.
a) Navigate to SNMP > V1/V2c > Notification Destination.
b) Click Add New.
c) Complete the fields.
d) Select the Devices tab and assign the SNMP notification destination to a device.
e) Click Save and Deploy.

Configure SIP Server Group

SIP Server Groups are required for Cisco Unified Communications Manager and Gateways.

Procedure

Step 1 In the Unified CVP Operations Console, navigate to System > SIP Server Group .
Step 2 Create a server group for the Cisco Unified Communications Manager devices:

a) On the General tab, click Add New.
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b) Fill in the SRV Domain Name FQDN field with a value that will also be used in the Cluster FQDN
setting in Enterprise Parameters in Communications Manager. For example, cucm.cisco.com.

c) In the IP Address/Hostname field, enter an IP address or hostname for the Unified Communications
Manager node.

d) Click Add.
e) Repeat Steps c and d for each Unified Communications Manager subscriber. Click Save.

Do not put the Publisher node in the server group.Note

SIP server group for Communications Manager is not required for SCC deployment as there is no direct
SIP trunk created from Communications Manager to CVP in SCC model.

The FQDN should match the FQDN configured in the Enterprise Cluster FQDN setting on the Cisco Unified
Communications Manager. For example, cucm.cisco.com. Adding the cluster subscriber nodes will load
balance across all sub nodes.

Step 3 Create a server group for the gateway devices:
a) On the General tab, click Add New.
b) In the SRV Domain Name FQDN field, enter the SRV Domain Name FQDN. For example

vxmlgw.cisco.com.
c) In the IP Address/Hostname field, enter an IP address or hostname for each gateway.
d) Click Add.
e) Repeat Steps c and d for each gateway. Click Save.

Add all VXML gateways as appropriate for deployment and branches. Adding all VXML gateways to
the server group will load balance calls across all the member server group gateways.

Step 4 Associate these server groups to all Unified CVP Call Servers:
a) On the Call Server Deployment tab, move all Unified CVP Call Servers from the Available list to the

Selected list.
b) Click Save and Deploy.

In the small contact center agent deployment, CUBE(SP) does not support FQDN
configuration, therefore, you cannot create SIP server group pointing to CUBE(SP) for each
sub customer.

Note

• In the small contact center agent deployment, CUBE(SP) does not support FQDN
configuration, therefore, you cannot create SIP server group pointing to CUBE(SP) for
each sub customer.

• In 12000 and 24000 agent deployment model, each CUCM cluster should have one SIP
Server group with their subscriber nodes.

Note

Configure Dialed Number Patterns

Dialed number patterns are required for:

• Agent Device

• Network VRU
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• Ringtone

• Error

Procedure

Step 1 In the Unified CVP Operations Console, navigate to System > Dialed Number Pattern.
Step 2 For each dialed number pattern in the following table:

a) Click Add New.
b) In the Dialed Number Pattern field, enter the dialed number pattern.
c) In the Description field, enter a description for the dialed number pattern.
d) In the Dialed Number Pattern Types pane, check the specified dialed number pattern types.
e) Click Save.

Step 3 After you configure all dialed number patterns, click Deploy.
Step 4 Click Deployment Status to make sure that you applied the configuration.

Dialed number pattern typesDescriptionDialed number pattern

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example, vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Ringtone91*

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example, vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Error92*

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both the
Unified Communications Manager gateway.

Check Enable RNA Timeout for Outbound Calls. The
default timeout value is 60 seconds.

Agent Device.The agent extension
pattern. For example,
enter 500* where the
range of agent
extensions is 5001 to
500999.

Check Enable Local Static Route.

Route to SIP Server Group and IP
Address/Hostname/Server Group Name are both VXML
Gateway (for example vxmlgw.cisco.com).

Check Enable Send Calls to Originator.

Network VRU Label777*
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Dialed number pattern typesDescriptionDialed number pattern

Check Enable Local Static Route.

In IP Address/Hostname/Server Group field provide the
signaling IP address and port of the CVP adjacency in
CUBE(SP) in the format:< IP Address>:<Port number>

For each sub customer a unique port must be configured.

Check Enable RNA Timeout for Outbound Calls. The
timeout is 15 seconds.

Agent Device Label for
the sub customer in the
SCC model.

The agent extension
pattern for the sub
customer in SCC
model. For example,
enter 500* where the
range agent extensions
is 5001 to 500999.

In 12000 and 24000 agent deployment model, each CUCM cluster should have separate Dialed
number Pattern with their agent extension range.

Note

Configure Cisco IOS Enterprise Voice Gateway

Complete the following procedure to configure the Cisco IOS Voice Gateway. Instructions are applicable to
both TDM and Cisco UBE Voice gateways, unless otherwise noted.

Complete all configuration steps in enable > configuration terminal mode.Note

Procedure

Step 1 Configure the network interfaces:
interface GigabitEthernet0/0
ip route-cache same-interface
duplex auto
speed auto
no keepalive
no cdp enable

Step 2 Configure global settings:
voice service voip
no ip address trusted authenticate
allow-connections sip to sip
signaling forward unconditional
!If this gateway is being licensed as a Cisco UBE the following lines are also required
mode border-element
ip address trusted list
ipv4 0.0.0.0 0.0.0.0 # Or an explicit Source IP Address Trust List

sip
rel1xx disable
header-passing
options-ping 60
midcall-signaling passthru

Step 3 Configure voice codec preference:

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
151

Initial Configuration
Configure Cisco IOS Enterprise Voice Gateway



voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw

Step 4 Configure Unified CVP services and settings:
# Default CVP Services
application
service new-call flash:bootstrap.vxml
service survivability flash:survivability.tcl
service CVPSelfService flash:CVPSelfServiceBootstrap.vxml
service ringtone flash:ringtone.tcl
service cvperror flash:cvperror.tcl
service bootstrap flash:bootstrap.tcl
service handoff flash:handoff.tcl

# Default CVP http, ivr, rtsp, mrcp and vxml settings
http client cache memory pool 15000
http client cache memory file 1000
http client cache refresh 864000
no http client connection persistent
http client connection timeout 60
http client connection idle timeout 10
http client response timeout 30
ivr prompt memory 15000
ivr asr-server rtsp://asr-en-us/recognizer
ivr tts-server rtsp://tts-en-us/synthesizer
rtsp client timeout connect 10
rtsp client timeout message 10
mrcp client timeout connect 10
mrcp client timeout message 10
mrcp client rtpsetup enable
vxml tree memory 500
vxml audioerror
vxml version 2.0

Step 5 Configure primary and secondary media servers:
#Configure the media servers where
# the primary matches the default media server defined in OAMP.
# the secondary is located on the opposite side of the primary.
ip host mediaserver ###.###.###.### # IP Address for primary media server.
ip host mediaserver-backup ###.###.###.### # IP Address for secondary media server.

Step 6 Configure the dial-peers:
# Configure CVP survivability
dial-peer voice 1 pots
description CVP TDM dial-peer
service survivability
incoming called-number .T
direct-inward-dial

# Configure CVP Ringtone
dial-peer voice 919191 voip
description CVP SIP ringtone dial-peer
service ringtone
incoming called-number 9191T
voice-class sip rel1xx disable
dtmf-relay rtp-nte
codec g711ulaw
no vad
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# Configure CVP Error
dial-peer voice 929292 voip
description CVP SIP error dial-peer
service cvperror
incoming called-number 9292T
voice-class sip rel1xx disable
dtmf-relay rtp-nte
codec g711ulaw
no vad

#Configure VXML leg where the incoming called-number matches the Network VRU Label
dial-peer voice 7777 voip
description Used for VRU leg
service bootstrap
incoming called-number 777T
dtmf-relay rtp-nte
codec g711ulaw
no vad

#Configure the Switch leg where
# preference is used to distinguish between sides.
# max-conn is used prevent overloading of CVP
# options-keepalive is used to handle failover
# Note: the example below is for gateways located on the A-side of a geographically
distributed deployment
# Note: Ensure that you configure switch dial-peers for each CVP server.

dial-peer voice 70021 voip
description Used for Switch leg SIP Direct
preference 1
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP1, SideA
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
no vad

dial-peer voice 70022 voip
description Used for Switch leg SIP Direct
preference 1
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP2, SideA
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
no vad

dial-peer voice 70023 voip
description Used for Switch leg SIP Direct
preference 2
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
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session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP1, SideB
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
no vad

dial-peer voice 70024 voip
description Used for Switch leg SIP Direct
preference 2
max-conn 225
destination-pattern xxxx...... # Customer specific destination pattern
session protocol sipv2
session target ipv4:###.###.###.### # IP Address for CVP2, SideB
session transport tcp
voice-class codec 1
voice-class sip options-keepalive up-interval 12 down-interval 65 retry 2
dtmf-relay rtp-nte
no vad

Step 7 Configure the hardware resources (transcoder, conference bridge, and MTP):
# Note: This section is only for reference. You must configure Hardware resources using
Unified Communications Domain Manager.
# Configure the voice-cards share the DSP resources located in Slot0
voice-card 0
dspfarm
dsp services dspfarm
voice-card 1
dspfarm
dsp services dspfarm
voice-card 2
dspfarm
dsp services dspfarm
voice-card 3
dspfarm
dsp services dspfarm
voice-card 4
dspfarm
dsp services dspfarm

# Point to the contact center call manager
sccp local GigabitEthernet0/0
sccp ccm ###.###.###.### identifier 1 priority 1 version 7.0 # Cisco Unified CM sub 1
sccp ccm ###.###.###.### identifier 2 priority 1 version 7.0 # Cisco Unifed CM sub 2

# Add a SCCP group for each of the hardware resource types
sccp ccm group 1
associate ccm 1 priority 1
associate profile 2 register <gw70mtp>
associate profile 1 register <gw70conf>
associate profile 3 register <gw70xcode>

# Configure DSPFarms for Conference, MTP and Transcoder
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions 24
associate application SCCP
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dspfarm profile 2 mtp
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions software 500
associate application SCCP

dspfarm profile 3 transcode universal
codec g711ulaw
codec g711alaw
codec g729r8
maximum sessions 52
associate application SCCP

Universal transcoder is only needed for cases where you engage the G.729 caller to G.729 only
agent with IVR in middle and performs any supplementary services or use features like whisper
announcement or agent greeting. If both the agent and caller are using G.729, transcoding is not
required. .

Note

Step 8 (Optional) Configure the SIP Trunking:
# Configure the resources to be monitored
voice class resource-group 1
resource cpu 1-min-avg threshold high 80 low 60
resource ds0
resource dsp
resource mem total-mem
periodic-report interval 30

# Configure one rai target for each CVP Server
sip-ua
rai target ipv4:###.###.###.### resource-group1 # CVP1A
rai target ipv4:###.###.###.### resource-group1 # CVP2A
rai target ipv4:###.###.###.### resource-group1 # CVP1B
rai target ipv4:###.###.###.### resource-group1 # CVP2B
permit hostname dns:%Requires manual replacement - ServerGroup Name defined in CVP.System.SIP
Server Groups%

Step 9 Configure Incoming PSTN Sip Trunk Dial Peer
dial-peer voice 70000 voip
description Incoming Call From PSTN SIP Trunk
incoming called-number xxxx…… # Customer specific incoming called-number pattern
voice-class sip rel1xx disable
dtmf-relay rtp-nte h245-signal h245-alphanumeric
codec g711ulaw
no vad

Step 10 Configure ASR TTS:
#Configure primary server
ip host asr-en-us <ASR server ip>
ip host tts-en-us <TTS server hostname>

voice class uri TTS sip
pattern tts@<TTS server ip>

voice class uri ASR sip
pattern asr@<ASR server hostname>

ivr asr-server sip:asr@<ASR server hostname*>
ivr tts-server sip:tts@<TTS server hostname*>

dial-peer voice 5 voip
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description FOR ASR calls
preference1
session protocol sipv2
voice-class sip options-keepalive up-interval 12 down-interval 65 retry
2
session target ipv4:<ASR server IP>
destination uri ASR
dtmf-relay rtp-nte
codec g711ulaw
no vad

dial-peer voice 6 voip
description FOR TTS calls
preference1
session protocol sipv2
voice-class sip options-keepalive up-interval 12 down-interval 65 retry
2
session target ipv4:<TTS server IP>
destination uri TTS
dtmf-relay rtp-nte
codec g711ulaw
no vad

#Configure backup server
dial-peer voice 7 voip
destination uri ASR
session target ipv4:<ASR backup server IP>
session protocol sipv2
voice-class sip options-keepalive up-interval 12 down-interval 65 retry
2dtmf-relay rtp-nte
codec g711ulaw
preference 2
no vad

dial-peer voice 8 voip
destination uri TTS
session target ipv4:<TTS backup server IP>
session protocol sipv2
voice-class sip options-keepalive up-interval 12 down-interval 65 retry
2dtmf-relay rtp-nte
codec g711ulaw
preference 2
no vad

Step 11 Configure SNMP
snmp-server community <string name> ro

Step 12 Configure Back-office

Example here is for Internal number that is dialed is 82009999 and converting the Internal number
to the PSTN number : 2142009999

Note

Example:

voice translation-rule 2
rule 1 /^8200/ /214200

voice translation-profile Xform
translate called 2

Ensure that you configure dial-peers for each CVP serverNote
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dial-peer voice 2 voip
description out dial-peer CC pilot dial-peer
translation-profile outgoing Xform
destination-pattern 8200T
session protocol sipv2
session target ipv4:<IP address of CVP Server>
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte

Configure Cisco Unified Communications Manager

Set Up Device Pool
Complete the following procedure to configure a device pool.

Procedure

Step 1 Choose System > device pool.
Step 2 Click Add new.
Step 3 Provide an appropriate device pool name in Device Pool Name.
Step 4 Select a corresponding Call manager group in Cisco Unified Communications Manager group.
Step 5 Select appropriate Date/Time Group and Region.
Step 6 Select an appropriate Media resource group list in Media Resource Group List.

Step 7 Click Save.

Set Up Unified Communications Manager Groups
Complete the following procedure to add a Unified CommunicationsManager to the Unified Communications
Manager Group.

Before you configure a Unified Communications Manager Group, you must configure the Unified
Communications Managers that you want to assign as members to that group.

Procedure

Step 1 Login to the Cisco Unified Communication Manager Administration page, choose System > Server.
Step 2 Make sure that you configure both the Publisher and Subscriber.

a) Click Add New.
b) Select appropriate Server Type Eg: CUCM Voice/Video Select Next.
c) Enter the Host Name/IP Address.
d) Click Save.

Step 3 Choose System > Cisco Unified CM.
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Step 4 Click Find.
Step 5 Make sure that you configured both the Publisher and Subscriber.
Step 6 Choose System > Cisco Unified CM Group.
Step 7 Add both Cisco Unified CommunicationsManagers to the Default Unified CommunicationsManager Group.

Select Default and from the Available Cisco unified communication managers select both Publisher and
Subscriber to Selected Cisco Unified Communications Managers

Step 8 Click Save.

Set Up CTI Route Point
Complete the following procedure to add a computer telephony integration (CTI) route point for agents to
use for transfer and conference.

Procedure

Step 1 Choose Device > CTI Route Point.
Step 2 Click Add New.
Step 3 Use the wildcard string XXXXX to represent the digits of the dialed number configured on Unified CCE.

For example, the preconfigured dialed number in the Unified CCE for an agent phone is 10112.Note

Step 4 Select the appropriate device pool.
Step 5 Click Save.

Set Up Trunk
Complete the following procedure to configure a trunk for the Unified CVP Servers.

Procedure

Step 1 Choose Device > Trunk.
Step 2 Click Add New.
Step 3 From the Trunk Type drop-down list, choose SIP Trunk, and then click Next.
Step 4 In the Device Name field, enter a name for the SIP trunk.
Step 5 In the Description field, enter a description for the SIP trunk.

a) Enter the SIP Trunk name in the Device Name field.
b) Select the appropriate Device Pool.

Step 6 Click Next.
Step 7 In the Trunk Configuration window, enter the appropriate settings:

a) Uncheck the Media Termination Point Required check box.
b) Enter the Destination Address.
c) Select the appropriate SIP Trunk Security Profile
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d) From the SIP Profile drop-down list, choose Standard SIP Profile.
e) From the DTMF Signaling Method drop-down list, choose RFC 2833.

Step 8 Click Save.

Set Up Application User

Procedure

Step 1 Choose User Management > Application User.
Step 2 In the Application User Configuration window, click Add New.
Step 3 Enter the User ID that you entered in Set Up Enterprise Parameters , on page 162. Unified CCE defines the

user ID as pguser.
Step 4 Enter a cisco in the Password field of your choice.

If you change this user ID or password in Unified CCE, you must also change the Unified
Communications Manager application user configuration.

Note

To change the JTAPI password on the CUCM configuration page:

a. Open the peripheral Gateway Setup in PG Machine.

b. Edit the CUCM PG.

c. Set the same password for the user as previously set in Step 4.

Note

Step 5 Add the application user to the Standard CTI Enabled Group and Role:
a) Click Add to Access Control Group.
b) Select the Standard CTI Enabled group.
c) Select the Standard CTI Allow Control of Phones supporting Connected Xfer and conf group.
d) Select the Standard CTI Allow Control of Phones supporting Rollover Mode group.
e) Click Add Selected.
f) Click Save.

Step 6 Associate the CTI route points and the phones with the application user.
Step 7 Click Save.

Set Up SIP Options

Procedure

Step 1 Select Device > Device Settings > SIP Profile.
Step 2 Enter values for the mandatory fields.
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Step 3 Select the Enable OPTIONS Ping to monitor destination status for Trunks with Service Type "None
(Default)" check box.

Step 4 Associate this SIP profile on the trunk.

Set Up Route Pattern

Procedure

Step 1 Choose Call Routing > Route Hunt > Route Pattern.
Step 2 Add a route pattern for the Unified CVP routing clients as follows:

a) Click Add New.
b) In the Route Pattern field, enter 7777777777!
c) In the Gateway/Route List field, choose SIPTRK_to_CVP_1.
d) Click Save.

Step 3 Add a route pattern for the Cisco Unified Communications Manager routing client.
a) Click Add New.
b) In the Route Pattern field, enter 8881111!
c) In the Gateway/Route List field, choose SIPTRK_to_CVP_1.
d) Click Save.

These route patterns must match the network VRU label defined in Unified CCE.Note

Set Up Conference Bridge

Procedure

Step 1 Choose Media Resources > Conference bridge.
Step 2 Add a conference bridge for each ingress/VXML combination gateway in the deployment.
Step 3 In the Conference Bridge name field, enter a unique identifier for the conference bridge name that coincides

with the configuration on the gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Set Up Media Termination Point

Procedure

Step 1 Choose Media Resources > Media Termination Point.
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Step 2 Add a media termination point for each ingress/VXML combo gateway in the deployment.
Step 3 In the Media Termination Point Name field, enter a media termination point name for each ingress/VXML

combo gateway in the deployment.
Step 4 Click Save.
Step 5 Click Apply Config.

Set Up Transcoder

Procedure

Step 1 Choose Media Resources > Transcoder.
Step 2 Add a transcoder for each ingress/VXML combo gateway in the deployment.
Step 3 In the Device Name field, enter a unique identifier for the transcoder that coincides with the configuration on

the gateway.
Step 4 Click Save.
Step 5 Click Apply Config.

Set Up Media Resource Group
Complete the following procedure to configure amedia resource group for conference bridge, media termination
point, and transcoder.

Procedure

Step 1 Choose Media Resources > Media Resource Group.
Step 2 Add a Media Resource Group for Conference Bridges.
Step 3 Select all the hardware conference bridge resources configured for each ingress/VXML combination gateway

in the deployment and add them to the group.
Step 4 Click Save.
Step 5 Choose Media Resources > Media Resource Group.
Step 6 Add a Media Resource Group for Media Termination Point.
Step 7 Select all the hardware media termination points configured for each ingress/VXML combination gateway in

the deployment and add them to the group.
Step 8 Click Save.
Step 9 Choose Media Resources > Media Resource Group.
Step 10 Add a Media Resource Group for Transcoder.
Step 11 Select all the transcoders configured for each ingress/VXML combination gateway in the deployment and

add them to the group.
Step 12 Click Save.
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Set Up and Associate Media Resource Group List
Complete the following procedure to configure and associate a media resource group list. Add the media
resource group list to the following devices and device pool.

Procedure

Step 1 Choose Media Resources > Media Resource Group List.
Step 2 Add a Media Resource Group list and associate all of the media resource groups.
Step 3 Click Save.
Step 4 Choose System > Device Pool.
Step 5 Click Default.
Step 6 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2.
Step 7 Click Save.
Step 8 Click Reset.
Step 9 Choose Device > CTI Route Point.
Step 10 Click the configured CTI Route Point. For more information, see Set Up CTI Route Point , on page 158.
Step 11 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2
Step 12 Click Save.
Step 13 Click Reset.
Step 14 Choose Device > SIP Trunk.
Step 15 Click the configured SIP Trunk for. For more information, see Set Up Trunk , on page 158.
Step 16 From the Media Resource Group List drop-down list, choose the media resource group added in Step 2
Step 17 Click Save.
Step 18 Click Reset.

Set Up Enterprise Parameters

Procedure

Step 1 Choose System > Enterprise Parameter.
Step 2 Configure the Cluster Fully Qualified Domain Name.

Example:

ccm.hcscc.icm

The Cluster Fully Qualified Domain Name is the name of the Unified Communications Manager
Server Group defined in Unified CVP.

Note
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Configure Mobile Agent
Complete the following procedure to configure CTI ports for Unified Mobile Agent.

Procedure

Step 1 In Unified Communications Manager Administration, choose Device > Phone.
Step 2 Click Add a New Phone.
Step 3 Select CTI Port from the Phone Type drop-down list.
Step 4 Click Next.
Step 5 In Device Name, enter a unique name for the local CTI Port pool name; click OK when finished.

Using the example naming convention format LCPxxxxFyyyy:

a) LCP identifies the CTI Port as a local device.
b) xxxx is the peripheral ID for the Unified Communications Manager PIM.
c) yyyy is the local CTI Port.

The name LCP5000F0000 would represent CTI Port: 0 in a local CTI Port pool for the Unified
Communications Manager PIM with the peripheral ID 5000.

Step 6 In Description, enter text identifying the local CTI Port pool.
Step 7 Use the Device Pool drop-down list to choose the device pool to which you want network CTIPort pool

assigned. (The device pool defines sets of common characteristics for devices.)
Step 8 Click Save.
Step 9 Highlight a record and select Add a New DN.
Step 10 Add a unique directory number for the CTI port you just created.
Step 11 When finished, click Save and Close.
Step 12 Repeat the preceding steps to configure the network CTI Port pool.
Step 13 In Device Name, enter a unique name for the local CTI Port pool name; click OK when finished.

Use the example naming convention format RCPxxxxFyyyy, where:

a) RCP identifies the CTI Port as a network device.
b) xxxx is the peripheral ID for the Unified Communications Manager PIM.
c) yyyy is the network CTI Port.

The name RCP5000F0000 would represent CTI Port: 0 in a network CTI Port pool for the Unified
Communications Manager PIM with the peripheral ID 5000.

Step 14 In Description, enter text identifying the network CTI Port pool.
Step 15 Use the Device Pool drop-down list to choose the device pool to which you want network CTI Port pool

assigned. (The device pool defines sets of common characteristics for devices.)
Step 16 Click Save.
Step 17 Highlight a record and select Add a New DN.
Step 18 Add a unique directory number for the CTI port you just created.
Step 19 When finished, click Save and Close.
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Configure Local Trunk
Complete the following procedure to configure Unified Communications Manager for Local Trunk.

Procedure

Step 1 From Unified Communications Manager Administration choose System > Location info > Location.
Step 2 Click Find to list the locations and add new ones with appropriate bandwidth (8000).
Step 3 For the branch phones, configure each phone so that it is assigned the branch location for that phone.

a) Choose Device > Phone.
b) Click Find to list the phones.
c) Select a phone and set the Location field.

Step 4 Verify that the Cisco AXL Web Service is started and that an Application User is defined and has a role of
Standard AXL API Access.
a) Select Cisco Unified Serviceability from the Navigation drop-down list and click Go.
b) Navigate to Tools > Control Center > Feature Services .
c) Start the Cisco AXL Web Service, if it is not started.
d) FromUnified CommunicationsManager Administration, chooseUser Management > Application User.

Verify you have a user with the role of Standard AXL API Access, or create a new one and add that user
to a group that has the role of Standard AXL API Access.

Deploy SIP Trunk

Complete the following procedure to deploy the SIP trunk for local trunk:

Procedure

Step 1 Using Unified Communications Manager, create a SIP trunk toward the SIP proxy server and select the
Phantom location.

Step 2 Create a SIP trunk for each ingress gateway and make the location of these ingress TDM-IP gateways the
actual branch location.

Step 3 Create a route pattern pointing the Network VRU Label of the Unified Communications Manager routing
client to the SIP trunk toward the SIP proxy.

The SIP proxy should route the Network VRU label of the Unified Communications Manager routing client
to the Unified CVP Servers.

Step 4 For any IP-originated calls, associate the Unified Communications Manager route pattern with the SIP trunk.
Step 5 Using the Unified CommunicationsManager Administration, chooseDevice > Device Settings > SIP Profile

> Trunk Specific Configuration > Reroute Incoming Request to new Trunk based on > Call-Info header
with the purpose equal to x-cisco-origIP.

Step 6 Associate the new SIP profile with the SIP trunk and each ingress gateway.
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Configure Outbound Dialer
Complete the following procedure to configure Unified Communications Manager:

Procedure

Step 1 Log in to the Unified Communications Manager administration page.
Step 2 Select Devices > Trunk.
Step 3 Create a SIP trunk to Outbound gateway.

Configure A-Law Codec
Complete the following procedure to configure Unified Communications Manager.

Procedure

Step 1 Click the System.
Step 2 Select Service Parameters.
Step 3 Select a Server.
Step 4 Select the service as Cisco Call Manager(Active).
Step 5 Under Clusterwide Parameters (system-location and region), ensure the following:

• G.711 A-law Codec Enabled is Enabled.

• G7.11 mu-law Codec Enabled to Disabled.

Step 6 Click Save.

Configure Support for Multiline Agent Control
To enable reporting and control of secondary lines, follow these configuration steps onUnified Communications
Manager. This is required for deployments that have agents using phones that require Join Across Line (JAL)
to be enabled.

Use of JAL and DTAL phone features is deprecated. Do not use these features in new deployments.Note

Multiline Agent Control supports a maximum of four lines per phone, one ACD line and up to three non-ACD
lines.
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Unified CCE does not support shared lines for ACD or Non ACD lines.

Several agents cannot share a common extension on their phones. However, one agent can have two phones
that share a common second line. The agent cannot sign in on both phones at the same time.

Note

Procedure

Step 1 Enable the Application User for the agent peripheral with the role of Standard CTI Allow Control of Phones
supporting Connected Xfer and conf to support phones that require Join Across Line setting.

Step 2 Configure all agent phones with the following parameters:

• Busy Trigger: 1
• Maximum Number of Calls: 2

Configure Caller-Specific Music on Hold

Upload audio file

Follow this procedure to upload an audio file in an existing node or new node in a Cisco Unified
Communications Manager cluster.

If you are uploading to a new node, you must first configure a new and dedicated Music on Hold node that
can have only two Cisco Unified Communications Manager services running: Cisco Call Manager, and Cisco
IP VoiceMedia Streaming Application. Additionally, the Cisco IP VoiceMedia Streaming Application service
must be deactivated in all of the other nodes in the Cisco Unified Communications Manager cluster that
contains the dedicatedMusic onHold node. Formore information, see Installing CiscoUnified Communications
Manager.

Procedure

Step 1 Log in to the Cisco Unified Communications Manager Administration page.
Step 2 Click the Media resources tab, and then click MOH Audio File Management.
Step 3 In the MOH Audio File Management page, click Upload File.
Step 4 In the Upload File window, click Browse, select the audio file that you want to set for Music on Hold, and

then click Open.
Step 5 Click Upload File.

The audio file is now available for use as a Music on Hold audio source.

What to do next

Configure the uploaded audio file so that it can be used as an audio source for Music on Hold.
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Configure audio source

Procedure

Step 1 In the Cisco Unified Communications Manager Administration page, click Media resources tab, and then
click Music On Hold Audio Source.

Step 2 Click Add new.
Step 3 In the MOH Audio Stream Number field, enter a number that you want to assign to the audio file. You cannot

choose a number that has already been assigned to another audio file.
Step 4 In the MOH Audio Source file drop-down menu, choose the audio file that you want to configure as the MoH

audio source.
Step 5 (Optional) The MOH Audio Source Name field automatically populates the name of the audio file that you

chose in the previous step. You can edit the name of the audio file that you selected.
Step 6 Click Save.

What to do next

Configure the audio source in the Unified CCE routing script.

Configure Unified CCE routing script

Procedure

Step 1 Log in to the Unified CCE Administrator workstation.
Step 2 Open the Script Editor.
Step 3 Open the script in which you want to set the caller specific Music on Hold.
Step 4 Set the call variable SIPHeader with the value X-cisco-moh-source~mod~<User Hold MoH Audio File

number>,<Network Hold MoH Audio File number>.

Example:

For example, X-cisco-moh-source~mod~6,7; where 6 and 7 are the numbers that you assigned to the audio
file. In this example, the audio file assigned for number 6 is played when the call is placed on user hold, and
the audio file assigned for number 7 is played when the call is placed on network hold.

• List the new call variable after a Dialed Number (DN) or CallingLineID node. This ensures
that the call is for a particular DN, or from a particular Calling Line ID.

• If only one audio file is specified, the same file is used for both user hold and network hold.

• If the audio stream that you specified is not present in the Cisco Unified Communications
Manager cluster, then the default Music on Hold of the device plays.

Note

Step 5 Click Save.

The audio file is now configured as the source audio file that will play for caller specific Music on Hold.
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Configure Cisco Finesse

Configure Contact Center Enterprise CTI Server Settings
Configure the A Side and B Side CTI servers on the primary Finesse server.

Procedure

Step 1 If you are not already signed in, sign in to the administration console on the primary Finesse server:

http://FQDN hostname, or IP address of Finesse server/cfadmin

Step 2 Sign in with the Application User credentials defined during installation.
Step 3 In the Contact Center Enterprise CTI Server Settings area, enter the CTI server settings as described in the

following table. Refer to your configuration worksheet if necessary.

DescriptionField

Enter the hostname or IP address of the A Side CTI server.

This value is typically the IP address of the Peripheral Gateway (PG).
The CTI server runs on the PG.

A Side Host/IP Address

Enter the port number of the A Side CTI server. The value of this
field must match the port configured during the setup of the A Side
CTI server.

A Side Port

Enter the ID of the Agent PG Routing Client (PIM).

The Agent PG Peripheral ID should be configured to the same value
for the A Side and B Side CTI servers.

Peripheral ID

Enter the hostname or IP address of the B Side CTI server.B Side Host/IP Address

Enter the port of the B Side CTI server. The value of this field must
match the port configured during the setup of the B Side CTI server.

B Side Port

Check this box to enable secure encryption.Enable SSL encryption

Step 4 Click Save.

Configure Contact Center Enterprise Administration & Data Server Settings
Configure the Contact Center Enterprise Administration & Data Server settings to enable authentication for
Cisco Finesse agents and supervisors.

If you are using HTTPS, the first time you access the administration console, you see a browser security
warning. To eliminate browser security warnings each time you sign in, you can trust the self-signed certificate
provided with Finesse or obtain and upload a CA certificate.

Note
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Procedure

Step 1 Sign in to the administration console.
Step 2 In the Contact Center Enterprise Administration &Data Server Settings area, enter the Administration &Data

Server settings as described in the following table. Refer to your configuration worksheet if necessary.

DescriptionField

The hostname or IP address of the Unified CCE Administration &
Data Server. For example, abcd12-5-aw-a.

Primary Host/IP Address

The hostname or IP address of the backup Unified CCE
Administration & Data Server. For example, abcd12-5-aw-b.

Backup Host/IP Address

The port of the Unified CCE Administration & Data Server.

The default value is 1433.

Cisco Finesse expects the primary and backup
Administration & Data Server ports to be the same,
hence the Finesse administration console exposes one
port field. You must ensure that the port is the same for
the primary and backup Administration&Data Servers.

Note

Database Port

The name of the AW Database (AWDB). For example,
ucceinstance_awdb.

AW Database Name

The domain name of the AWDB. For example, cisco.com.Domain

The username required to sign in to the AWDB.

If you specify a domain, this user refers to the
Administrator Domain user that the AWDB uses to
synchronize with the logger. In which case, the AWDB
server must use Windows authentication and the
configured username must be a domain user.

If you do not specify a domain, this user must be an
SQL user.

Note

Username

The password required to sign in to the AWDB.Password

Step 3 Click Save.

Configure Cluster Settings
Configure the cluster settings for the secondary Finesse node. The secondary Finesse node handles agent
requests if the primary server goes down.
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Procedure

Step 1 If you are not already signed in the primary node, sign in to the administration console of the primary node
with the Application User credentials.

Step 2 In the Cluster Settings area, in the Hostname field, enter the hostname of the secondary Finesse server.
Step 3 Click Save.

Restart Cisco Finesse Tomcat
After youmake changes to the Contact Center Enterprise CTI Server, Contact Center Enterprise Administration
& Data Server, or cluster settings, restart Cisco Finesse Tomcat for the changes to take effect.

After you restart Finesse, it can take approximately 6minutes for all server-related services to restart. Therefore,
you wait 6 minutes before you attempt to access the Finesse administration console.

Note

Procedure

Step 1 Access the CLI and run the following command:

utils service restart Cisco Finesse Tomcat

Step 2 You can enter the command utils service list to monitor the Cisco Finesse Tomcat Service. After Cisco Finesse
Tomcat changes to STARTED, the configured agents can sign in to the desktop.

Check Replication Status

Procedure

Step 1 Access the CLI on the primary Finesse server.
Step 2 Sign in with the Administrator User credentials that are defined during installation.
Step 3 Run the following command:

utils dbreplication runtimestate

This command returns the replication status on both the primary and secondary Finesse servers.

Ensure Agents Have Passwords
Agents who do not have a password defined in Unified CCEConfigurationManager cannot sign in to Finesse.

Agent password is an optional field in Unified CCE, but it is mandatory for Cisco Finesse.
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For agents who do not have passwords, you must perform the following steps:

Procedure

Step 1 Launch Unified CCE Configuration Manager.
Step 2 Locate the record for the agent (Agent Explorer > Agent tab).
Step 3 Enter a password, and save the record.

Ensure Logout Non-Activity Time for Agents is Configured
The Logout non-activity time specifies how long an agent can remain inactive in the Not Ready state before
that agent is signed out of Finesse.

For agents who use the Task Routing interface on Finesse for non-voice tasks, set the Logout non-activity
time to blank.

Perform the following steps to configure Logout non-activity time for an agent.

Procedure

Step 1 Launch the Unified CCE Configuration Manager.
Step 2 Launch Agent Desk Settings List (Tools > List Tools).
Step 3 Select Agent Desk Settings List.
Step 4 In the Logout non-activity time field, enter the number of seconds of agent inactivity while in the Not Ready

state before the system software signs the agent out. You can enter a value between 10 seconds and 7200
seconds.

Step 5 Click Save.
The modified settings are applied to all of the agents who use these agent desktop settings.

Ensure Agents Can Sign in to Desktop
After the system administrator defines configuration settings and restarts services, agents who have passwords
and operational handsets can sign in to the Finesse Agent Desktop.

Finesse agents can enter either their AgentID or Login name (in the Username field of the desktop login
screen) to sign in. Ensure that each agent's AgentID and Login name are unique across both sets of data. If
one agent's AgentID matches another agent's Login name, neither agent can sign in.

Note

After you restart Finesse, it takes approximately 6 minutes for all server-related services to restart. Therefore,
you should wait 6 minutes before you attempt to sign in to the desktop.

Note

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
171

Initial Configuration
Ensure Logout Non-Activity Time for Agents is Configured



If you are using HTTPS, the first time you access the agent desktop, you see a browser security warning. To
eliminate browser security warnings each time you sign in, you can trust the self-signed certificate provided
with Finesse or obtain and upload a CA certificate.

Note

Procedure

Step 1 Enter the following URL in the address bar of your browser:

http://FQDN of Finesse server/desktop

Step 2 If you installed the language pack ES file, you can select the language you want to appear on the desktop from
the language selector drop-down list. If you did not install the language pack ES file, the language selector
drop-down list does not appear in the user interface.

If you installed the language pack ES file, you can also select a language by passing the locale
as part of the URL (for example, http://FQDN of Finesse server/desktop?locale=fr_FR) or by
changing your browser preferred language. The default language is English (en_US).

Note

Step 3 Enter your Username, Password, and Extension, and then click Sign In.

If your agent is signed into the Agent Desktop in Single Sign-On Mode or Hybrid Mode, refer to the sections
Sign In to Finesse Desktop Single Sign-On Mode or Sign In to Finesse Desktop Hybrid Mode in the Cisco
Finesse Desktop User Guide for Unified Contact Center Enterprise.

Obtain and Upload CA Certificate

This procedure only applies if you are using HTTPS.

This procedure is optional. If you are using HTTPS, you can choose to obtain and upload a CA certificate or
you can choose to use the self-signed certificate provided with Finesse.

Note

To eliminate browser security warnings each time you sign in, obtain an application and root certificate signed
by a Certificate Authority (CA). Use the Certificate Management utility from Cisco Unified Communications
Operating System Administration.

To open Cisco Unified Communications Operating System Administration, enter the following URL in your
browser:

https://hostname of primary UCCX server/cmplatform

Sign in using the username and password for the Application User account created during the installation of
Finesse.

You can find detailed explanations in the Security topics of the Cisco Unified Communications Operating
System Administration Online Help.

Note
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Procedure

Step 1 Generate a CSR.
a) Select Security > Certificate Management > Generate CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Generate CSR.

For information on updating Subject Alternate Names (SANs), refer toConfiguration Examples
and TechNotes > Unified CCE Solution: Procedure to Obtain and Upload Third-Party CA
certificates.

Note

To avoid certificate exception warnings, you must access the servers using the Fully Qualified
Domain Name (FQDN).

Do not select "Multi-server (SAN)" as multi-server certificates is not supported with Cisco
Finesse.

Note

Step 2 Download the CSR.
a) Select Security > Certificate Management > Download CSR.
b) From the Certificate Name drop-down list, select tomcat.
c) Click Download CSR.

Step 3 Generate and download a CSR for the secondary Finesse server.

To open Cisco Unified Operating System Administration for the secondary server, enter the following URL
in the address bar of your browser:

https://hostname of secondary UCCX server/cmplatform

Step 4 Use the CSRs to obtain the CA root certificate, intermediate certificate, and signed application certificate
from the Certificate Authority.

To set up the certificate chain correctly, you must upload the certificates in the order described
in the following steps.

Note

Step 5 When you receive the certificates, select Security > Certificate Management > Upload Certificate.
Step 6 Upload the root certificate.

a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the root certificate file.
c) Click Upload File.

Step 7 Upload the intermediate certificate.
a) From the Certificate Purpose drop-down list, select tomcat-trust.
b) In the Upload File field, click Browse and browse to the intermediate certificate file.
c) Click Upload File.

Step 8 Upload the application certificate.
a) From the Certificate Purpose drop-down list, select tomcat.
b) In the Upload File field, click Browse and browse to the application certificate file.
c) Click Upload File.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
173

Initial Configuration
Obtain and Upload CA Certificate



Step 9 After the upload is complete, sign out from the Platform Admin page of Finesse.
Step 10 Restart Cisco Tomcat on the primary Unified CCX node.
Step 11 Restart Cisco Finesse Tomcat on the primary Unified CCX node.
Step 12 Restart Cisco Unified Intelligence Center Reporting Service.
Step 13 Restart Unified CCX Notification Service.

It is recommended to delete the self-signed certificates from the clients certificate store. Then
close the browser, relaunch, and reauthenticate.

Note

Step 14 Upload the application certificate to the secondary Unified CCX server.

You do not need to upload the root and intermediate certificates to the secondary Unified CCX server. After
you upload these certificates to the primary server, they are replicated to the secondary server.

Step 15 Restart Cisco Tomcat and Cisco Finesse Tomcat on the secondary Unified CCX node.

Set Up CA Certificate for Chrome and Edge Chromium (Microsoft Edge) Browsers

Procedure

Step 1 In the browser, go to Settings.
Step 2 In the Chrome browser, select Advanced Settings > Privacy and Security, click Manage Certificates.
Step 3 In the Microsoft Edge browser, select Privacy, search, and services. Under Security, click Manage

Certificates.
Step 4 Click Trusted Root Certification Authorities tab.
Step 5 Click Import and browse to the ca_name.cer file.

In the Trusted Root Certification Authorities tab, ensure that the new certificate appears in the list.
Step 6 Restart the browser for the certificate to install.

Accept Security Certificates
Ensure that the pop-ups are enabled for the Finesse desktop.

After you enter the Finesse desktop URL in your browser, the procedure to add a certificate is as follows:

Install certificates on Windows operating system:

The procedure to add a certificate varies for each browser. The procedure for each browser is as follows:

Internet Explorer
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If you are using a Windows client, signed in as a Windows user, you must run Internet Explorer as an
administrator to install the security certificates. In your Start menu, right-click Internet Explorer and select
Run as administrator.

Contact your administrator if you do not have the required permissions to install the security certificates.

Note

1. A page appears that states there is a problem with the website's security certificate. Click Continue to
this website (not recommended) link to open the Finesse sign in page. The Finesse sign in screen
appears with a certificate error in the address bar.

2. Click on the certificate error that appears in the address bar and then click View Certificates.

3. In the Certificate dialog box, click Install Certificate to open the Certificate Import Wizard.

4. SelectCurrent User to install the certificate for the current user only, or selectLocal Machine to install
the certificate for all Windows users.

5. On the Certificate Import Wizard, click Next.

6. Select Place all certificates in the following store and click Browse.

7. Select Trusted Root Certification Authorities and click OK.

8. Click Next and then click Finish. A Security Warning dialog box appears.

9. Click Yes to install the certificate. The Certificate Import dialog box appears.

10. Click OK and close the Certificate Import dialog box.

11. Close the browser tab. The accepted certificate link is removed from the SSL Certificate Not Accepted
dialog box.

Repeat the preceding steps for all the certificate links. After you accept all the certificates, the sign-in process
is complete.

To remove the certificate error from the desktop, you must close and reopen your browser.Note

Firefox

1. On Your connection is not secure page, click Advanced > Add Exception.

Ensure that the Permanently store this exception box is checked.Note

2. Click Confirm Security Exception.

3. On and click Sign In.

4. In the SSL Certificate Not Accepted dialog box, click the certificate link. A browser tab opens for the
certificate that you must accept.
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5. On the browser tab, click I Understand the Risks > Add Exception. Ensure that the Permanently store
this exception box is checked.

6. ClickConfirm Security Exception. The browser tab closes after you accept the certificate and the accepted
certificate link is removed from the SSL Certificate Not Accepted dialog box. Close the browser tab if
it does not automatically close.

Repeat the preceding steps for all the certificate links. After you accept all the certificates, the sign-in process
is complete.

Chrome and Edge Chromium (Microsoft Edge)

1. A page appears that states your connection is not private. To open the Finesse sign in page,

In Chrome, click Advanced > Proceed to <Hostname> (unsafe).

In Microsoft Edge, click Advanced > Continue to <Hostname> (unsafe).

2. Enter your agent ID or username, password, and extension, and then click Sign In.

3. In the SSL Certificate Not Accepted dialog box, click the certificate link. A browser tab opens for the
certificate that you must accept.

4. On the browser tab,

In Chrome, click Advanced > Proceed to <Hostname> (unsafe).

In Microsoft Edge, click Advanced > Continue to <Hostname> (unsafe).

The browser tab closes after you accept the certificate and the accepted certificate link is removed from
the SSL Certificate Not Accepted dialog box. Close the browser tab if it does not automatically close.

If you click the certificate link and do not accept it, the certificate link stays enabled in the SSL Certificate
Not Accepted dialog box. The certificate error appears every time you sign in. The procedure to permanently
accept the certificate is as follows.

Note

5. Click on the certificate error that appears in the address bar and then,

In Chrome, select Certificate (Invalid).

In Microsoft Edge, select Certificate (not valid).

The Certificate dialog box appears.

6. In the Details tab, click Copy to File. The Certificate Export Wizard appears.

7. Click Next.

8. Keep the default selection DER encoded binary X.509 (.CER) and click Next.

9. Click Browse and select the folder in which you want to save the certificate, enter a recognizable file
name and click Save.

10. Browse to the folder where you have saved the certificate (.cer file), right-click on the file, and click
Install Certificate. The Certificate Import Wizard appears.

11. Keep the default selection Current User and click Next.
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12. Select Place all certificates in the following store and click Browse. The Select Certificate Store
dialog box appears.

13. Select Trusted Root Certification Authorities and click OK.

14. Click Next and then click Finish. A Security Warning dialog box appears that asks if you want to
install the certificate.

15. Click Yes. A Certificate Import dialog box that states the import was successful appears.

Close the browser and sign in to Finesse. The security error does not appear in the address bar.

Install certificates on macOS:

The procedure to download a certificate varies for each browser. The procedure for each browser is as follows:

Chrome and Edge Chromium (Microsoft Edge)

1. A warning page appears which states that your connection is not private. To open the Finesse Console
sign in page,

In Chrome, click Advanced > Proceed to <Hostname> (unsafe).

In Microsoft Edge, click Advanced > Continue to <Hostname> (unsafe).

2. Click on the certificate error that appears in the address bar and then,

In Chrome, select Certificate (Invalid).

In Microsoft Edge, select Certificate (Not Valid).

A certificate dialog box appears with the certificate details.

3. Drag the Certificate icon to the desktop.

4. Double-click the certificate. The Keychain Access application opens.

5. In the right pane of Keychains dialog, browse to the certificate, right-click on the certificate, and select
Get Info from the options that are listed. A dialog appears with more information about the certificate.

6. Expand Trust. From the When using this certificate drop-down, select Always Trust.

7. Close the dialog box that has more information about the certificate. A confirmation dialog box appears.

8. Authenticate the modification of Keychains by providing a password.

9. The certificate is now trusted, and the certificate error does not appear on the address bar.

Firefox

1. In your Firefox browser, enter the Finesse desktop URL. A warning page appears which states that there
is a security risk.

2. Click Advanced and then click View Certificate link. The Certificate Viewer dialog box appears.

3. Click Details and then click Export. Save the certificate (.crt file) in a local folder.

If .crt file option is not available, select .der option to save the certificate.Note
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4. From the menu, select Firefox > Preferences. The Preferences page is displayed.

5. In the left pane, select Privacy & Security.

6. Scroll to the Certificates section and click View Certificates .... The Certificate Manager window is
displayed.

7. Click Import and select the certificate.

8. The certificate is now authorized, and the certificate error does not appear on the address bar.

Configure DNS on Clients

This procedure is required for uncommon environments where non-hierarchical DNS configuration exists. If
your environment has hierarchical DNS configuration, you do not need to perform this procedure. This
procedure applies to clients that use a Windows operating system. For information about configuring DNS
on Mac clients, see your Apple documentation (www.apple.com/mac).

Note

Configuring DNS on client computers allows the clients to resolve the fully-qualified domain name (FQDN)
of the active Finesse server during a failover.

Procedure

Step 1 Go to Control Panel > Network and Internet > Network and Sharing Center. (Open the Control Panel,
enter Network Connections in the search bar, and then click View network connections.)

Step 2 Click the appropriate network connection.
A dialog box showing the status of the connection appears.

Step 3 Click Properties.
Step 4 On the Networking tab, select Internet protocol version 4 (TCP/IPv4) or Internet protocol version 6 (TCP/IPv6)

if the client is IPV6, and then click Properties.
Step 5 Click Advanced.
Step 6 On the DNS tab, under DNS server addresses, in order of use, click Add.
Step 7 Enter the IP address of the DNS server that was entered during installation and click Add.
Step 8 If a secondary DNS was entered during installation, repeat Step 5 and Step 6 to add its IP address.

Live Data Reports
Cisco Unified Intelligence Center provides Live Data real-time reports that you can add to the Finesse desktop.

Prerequisites for Live Data

Before you add Live Data reports to the desktop, you must meet the following prerequisites:

• You must have the Live Data reports configured and working in Cisco Unified Intelligence Center.
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• Youmust use either HTTP or HTTPS for both Cisco Unified Intelligence Center and Finesse. You cannot
use HTTP for one and HTTPS for the other. The default setting for both after a fresh installation is
HTTPS. If you want to use HTTP, you must enable it on both Cisco Unified Intelligence Center and
Finesse. For information about enabling HTTP for Cisco Unified Intelligence Center, see the
Administration Console User Guide for Cisco Unified Intelligence Center at http://www.cisco.com/c/
en/us/support/customer-collaboration/unified-intelligence-center/products-maintenance-guides-list.html.

• Ensure that user integration synchronization is enabled for Cisco Unified Intelligence Center. For more
information, see the Administration Console User Guide for Cisco Unified Intelligence Center .

• If your deployment uses HTTPS, you must upload security certificates to the Finesse, Cisco Unified
Intelligence Center, and Live Data servers depending your deployment:

Import Certificates FromOn Server

Live Data and Cisco Unified Intelligence CenterFinesse

None requiredLive Data

Live DataCisco Unified Intelligence Center

Finesse, Cisco Unified Intelligence Center, and Live Data are installed with self-signed certificates.
However, if you use the self-signed certificates, agents and supervisors must accept certificates in the
Finesse desktop when they sign in before they can use the Live Data gadget. To avoid this requirement,
you can provide a CA certificate instead. You can obtain a CA certificate from a third-party certificate
vendor or produce one internal to your organization.

Add Live Data Reports to Finesse

The following sections describe how to add the Live Data reports to the Finesse desktop. The procedure that
you follow depends on several factors, described in the following table.

When to useProcedure

Use this procedure if you want to add Live Data
reports to the Finesse desktop after a fresh installation
or after an upgrade if you have not customized the
default desktop layout.

Add Live Data reports to default desktop layout

Use this procedure if you have customized the Finesse
desktop layout.

Add Live Data reports to custom desktop layout

Use this procedure if you want to add Live Data
reports to the desktop layout for specific teams only.

Add Live Data reports to team layout

Add Live Data Reports to Default Desktop Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to the default desktop layout. Use this
procedure after a fresh installation of Finesse. If you upgraded Finesse but do not have a custom desktop
layout, clickRestore Default Layout on the Manage Desktop Layout gadget and then follow the steps in this
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procedure. Note that line breaks and spaces that appear in the example text are provided only for readability
and must not be included in the actual code.

Procedure

Step 1 Sign in to the Finesse administration console (https://FQDN of Finesse server:Port
Number(8445)/cfadmin), in which FQDN refers to the fully qualified domain name.

Step 2 Click the Desktop Layout tab.
Step 3 Remove the comment characters (<!-- and -->) from each report that you want to add to the desktop layout.

Make sure you choose the reports that match the method your agents use to access the Finesse desktop (HTTP
or HTTPS).

Step 4 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 5 Optionally, change the gadget height.

Example:

The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows, replacing 310 with 400:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 6 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Add Live Data Reports to Custom Desktop Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to a custom desktop layout. Note that line
breaks and spaces that appear in the example text are provided only for readability and must not be included
in the actual code.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
180

Initial Configuration
Add Live Data Reports to Custom Desktop Layout



Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the XML code for the report you want to add from the Finesse default layout XML. If your agents use

HTTP to access Finesse, copy the XML code for the HTTP report. If they use HTTPS, copy the XML code
for the HTTPS report.

Example:

To add the Agent Report for HTTPS, copy the following:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>

Step 5 Paste the XML within the tab tags where you want it to appear.

Example:

To add the report to the home tab of the agent desktop:
<layout>
<role>Agent</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>

</page>
<tabs>
<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>
</tab>
<tab>
<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>

</tab>
</tabs>

</layout>

Step 6 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 7 Optionally, change the gadget height.

Example:

The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
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filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 8 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Add Live Data Reports to Team Layout

The Finesse default layout XML contains commented XML code for the Live Data report gadgets available
for the Finesse desktop. The gadgets are divided into two categories: HTTPS version of Live Data gadgets
and HTTP version of Live Data gadgets.

This procedure explains how to add the Live Data report gadgets to the desktop layout of a specific team.
Note that line breaks and spaces that appear in the example text are provided only for readability and must
not be included in the actual code.

Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the XML code for the report you want to add from the Finesse default layout XML. If your agents use

HTTP to access Finesse, copy the XML code for the HTTP report. If they use HTTPS, copy the XML code
for the HTTPS report.

Example:

To add the Agent Report for HTTPS, copy the following:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Step 5 Click the Team Resources tab.
Step 6 Select the team from the list of teams for which you want to add the report.
Step 7 In the Resources for <team name> area, click the Desktop Layout tab.
Step 8 Check the Override System Default check box.
Step 9 Paste the XML within the tab tags where you want it to appear.
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Example:

To add the report to the home tab of the agent desktop:
<layout>
<role>Agent</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>

</page>
<tabs>
<tab>
<id>home</id>
<label>finesse.container.tabs.agent.homeLabel</label>
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&
viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName

</gadget>
</tab>
<tab>
<id>manageCall</id>
<label>finesse.container.tabs.agent.manageCallLabel</label>

</tab>
</tabs>

</layout>

Step 10 Replace my-cuic-server with the fully qualified domain name of your Cisco Unified Intelligence Center Server.
Step 11 Optionally, change the gadget height.

Example:

The height specified in the Live Data gadget URLs is 310 pixels. If you want to change the height, change
the gadgetHeight parameter in the URL to the desired value. For example, if you want the gadget height to
be 400 pixels, change the code as follows:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=400&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Tomaintain the optimal display of the gadget with scroll bars, set the value for the gadget height to a minimum
of 200 pixels. If the report does not require scroll bars, for example a one-row report, you can set a smaller
gadget height (for example, 100 pixels). If you do not specify anything for the gadget height (if you remove
the 310 from the URL), it defaults to 170 pixels.

Step 12 Click Save.

After you add a gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without needing to scroll down.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note
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Modify Live Data Stock Reports for Finesse

This procedure describes how to modify the Live Data stock reports in Cisco Unified Intelligence Center and
add the modified report to the Finesse desktop layout. Note that line breaks and spaces that appear in the
example text are provided only for readability and must not be included in the actual code.

To make sure the modified gadget renders in the Finesse desktop, you must give the appropriate permission
for that report in Cisco Unified Intelligence Center.

Note

Procedure

Step 1 Sign in to the Finesse administration console.
Step 2 Click the Desktop Layout tab.
Step 3 Click Finesse Default Layout XML to show the default layout XML.
Step 4 Copy the gadget URL for the report you want to modify from the Finesse default layout XML and paste it

into a text editor.

Example:

If you want to modify the Agent Report for HTTPS, copy the following URL and paste it into a text editor:
<gadget>https://my-cuic-server:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?

gadgetHeight=310&viewId_1=99E6C8E210000141000000D80A0006C4&
filterId_1=agent.id=CL%20teamName&viewId_2=9AB7848B10000141000001C50A0006C4&
filterId_2=agent.id=CL%20teamName
</gadget>

Step 5 In Cisco Unified Intelligence Center, in Edit view of the report, select the view for which you want to create
a gadget URL and then click Links.

The HTML Link field displays the permalink of the customized report.

Step 6 Copy the permalink of the customized report from the HTML Link field, and paste it in a text editor. Then
copy the viewId value from this link into the desired view.

Example:

Copy the viewId, which is underlined in this example, from the permalink for the report.

https://<Server Name>:8444/cuic/permalink/PermalinkViewer.htmx?
viewId=5C90012F10000140000000830A4E5B33&linkType=htmlType&viewType=Grid

Step 7 Replace the desired viewId value in the gadget URLwith the viewId value from the permalink of the customized
report.

Step 8 Replace my-cuic-server with the FQDN of the Cisco Unified Intelligence Center Server.
Step 9 Add the customized gadget URL to the desktop layout XML in the Manage Desktop Layout gadget and click

Save.
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After you add the gadget, sign in to the Finesse desktop and make sure it appears the way you
want. If you use a report with a large number of rows, you may want to adjust the gadget height
or the screen resolution on the computer used to access the desktop to make the report easier to
read or make more rows appear on the screen without the need to scroll.

Agents who are signed in when you change the desktop layout must sign out and sign back in to
see the change on their desktops.

Note

Initial Configuration Troubleshooting

ThenIf

1. Clear your browser cache (delete browsing history and cookies).

2. If the problem persists, restart the Cisco Finesse Tomcat service or
restart the Finesse server.

The administration console does
not load after a fresh installation.
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ThenIf

Agents cannot sign in to the
desktop after a fresh installation.
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ThenIf

1. Verify that the agent ID and password are correct.

Finesse agents can use either their loginID or
loginName to sign in. Ensure that each agent's loginID

Note

and loginName are unique across both sets of data. If
one agent's loginID matches another agent's
loginName, neither agent can sign in.

2. Verify that a valid domain was configured during installation and
that forward and reverse DNS are set up correctly. To check whether
DNS was configured during installation, check the install.log for
the following:

InstallWizard|USER_ACTION_BTN_PUSH: Screen =DNSClient
Configuration, button pushed = No|<LVL::Info

The precedingmessage indicates that DNSwas not configured during
the installation. Reinstall Finesse and configure the DNSwith a valid
domain.

3. Verify that the agent is configured in Unified CCE.

4. Verify that the AWDB is configured correctly.

a. Check the realm.log for the following line:

"ERROR
com.cisco.ccbu.finesse.realms.ccerealm.CCERealmConfig -
Cannot connect to any AWDB! Ensure that at least one AWDB
is configured properly and running!"

This line indicates that Finesse cannot connect to the AWDB.

b. Check that the values entered in the Contact Center Enterprise
Administration & Data Server Settings gadget are correct.

• Verify that the username entered is a Windows domain
user.

• Verify that the username is not prepended with the domain
(for example, domain\username).

• Verify that the port configured is open to the Finesse server.

c. Check that the AWDB is set up correctly and running.

• The AWDBSQL server must useWindows authentication.

• Verify that the AWDB server is up and that the Distributor
service is running.

5. Restart Cisco Finesse Tomcat on the primary and secondary Finesse
servers.

6. Verify that the agent's device is properly configured in Unified
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ThenIf

Communications Manager and is active.
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C H A P T E R 6
Upgrade Overview

• Upgrade Overview, on page 189
• Multistage Upgrades and Maintenance Windows, on page 192
• Unified CCE Contact Center Upgrade Flowcharts, on page 195
• Data Migration Considerations, on page 210
• Enable and Disable TDE on a Database, on page 212
• Silent Upgrade, on page 213
• Unified CCE Upgrade Overview, on page 213

Upgrade Overview
Redundant Central Controller Upgrade Flow

The central controller consists of the Logger, Router, and Administration & Data Server. When upgrading
the portion of your Cisco Contact Center, the central controller is upgraded before the other components.
While one side (Side A or B) of the redundant system is being upgraded, the other side (Side A or B) operates
in stand-alone mode.

For redundant systems, the general flow for upgrading the central controller is as follows:

1. Upgrade the Side A Logger and Router along with the Administration & Data Server identified to be
upgraded first to verify operations on the upgraded Side A Logger and Router.

2. Bring Side A into service and verify the operation. Side B is brought down as Side A is coming into
service along with other non-upgraded Administration & Data Server(s).

3. Upgrade the Side B Logger and Router along with remaining Administration & Data Server(s).

4. Bring Side B into service and verify that duplexed operation begins.

Update VM Properties

Rather than re-create the VMs in the new version of the OVA, you can manually update the VM properties
to match the new OVA. After you upgrade the vSphere ESXi and before you upgrade the components, update
the properties of each VM to match the appropriate OVA, as follows:

1. Stop the VM.

2. Restart the VM.
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Be careful when you upgrade the virtual machine network adapters. Done incorrectly, this upgrade can
compromise the fault tolerance of your Cisco Contact Center.

Caution

SQL Security Hardening

You can optionally apply SQL security hardening when running the installer. If your company employs custom
security policies, bypass this option. Most other deployments benefit from SQL security hardening.

For more information about SQL security hardening, see the Security Guide for Cisco Unified ICM/Contact
Center Enterprise at http://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-installation-and-configuration-guides-list.html.

Self-signed Certificate for Unified CCE Web Application

As part of the upgrade of Unified CCE servers, self-signed certificates employed by Unified CCE web
applications such as Unified CCE web administration tool and Websetup, may get regenerated. You must add
the new certificates to the trust list on the appropriate end devices.

Note

Upgrade Tools

During the upgrade process, use the following tools as required:

• AdminClientInstaller—Installs the Administration Client on a system that is not running other components.

The AdminClientInstaller is delivered on the installation media with the installer.

• 12.0 ICM-CCE-Installer—Themain Unified CCE installer. It copies all files into relevant folders, creates
the base registries, and installs needed third-party software such as JRE, Apache Tomcat, and Microsoft
.NET Framework.

Optionally, update the JRE installed by the Unified CCE Installer with a later
version of the JRE. See Update the Java Runtime Environment (Optional), on
page 55.

If the ICM-CCE installer installs JRE on theWindows platform, the system retains
only the Cisco approved CA certificates in the java certificate store, and removes
all the unapproved certificates.

Note

You cannot run the installer remotely. Mount the installer ISO file only to a local machine.

• Cisco Unified Intelligent Contact Management Database Administration (ICMDBA) Tool—Used
to create new databases, modify or delete existing databases, and perform limited SQL Server
configuration tasks.

• Domain Manager—Used to provision Active Directory.

• Web Setup—Used to set up the Call Routers, Loggers, and Administration & Data Servers.

• Peripheral Gateway Setup—Used to set up PGs, the CTI server, and the Outbound Option dialer.
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• 12.0 AdminClientInstaller—Installs the Administration Client on a system that is not running other
components.

The AdminClientInstaller is delivered on the installation media with the installer.

• Administration Client Setup—Used to add, edit, or remove Administration Clients and Administration
Client Instances.

The Administration Client Setup is delivered on the installation media with the installer.

• Enhanced Database Migration Tool (EDMT)—A wizard application that is used for all upgrades to
migrate the HDS, Logger, and BA databases during the upgrade process.

You can download the EDMT from Cisco.com by clicking Cisco Enhanced Data Migration Tool
Software Releases.

The prerequisites for running EDMT are:

• EDMT also requiresMicrosoft®ODBCDriver 11 for SQL Server® and Visual C++ Redistributable
for Visual Studio 2015. The latest version of these packages can be downloaded from the Microsoft
website. However, a copy of the same is also available in the Prerequisites folder of EDMT.

The EDMT displays status messages during the migration process, including warnings and errors.
Warnings are displayed for informational purposes only and do not stop the migration. On the other hand,
errors stop the migration process and leave the database in a corrupt state. If an error occurs, restore the
database from your backup, fix the error, and run the tool again.

• You can select either SQL Server Authentication or Windows
Authentication during databasemigration. In certain scenarios, for example,
where the source and destination machines are in different domains, SQL
Server Authentication can be used.

• If you are configuring SQL services to run as Virtual account (NT SERVICE)
or Network Service account (NT AUTHORITY\NETWORK SERVICE),
you must run EDMT as an administrator.

• The installer, not the EDMT, upgrades the AW database for the
Administration & Data Server.

Note

• User Migration Tool—A standalone Windows command-line application that is used for all upgrades
that involve a change of domain. The tool imports the previously exported user accounts into the target
domain during the upgrade.

You can download the User Migration Tool from Cisco.com by clicking ICM User Migration Tool
Software.

User Migration Tool cannot be used for migrating users that are SSO enabled.Note
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Multistage Upgrades and Maintenance Windows
A Unified CCE solution upgrade likely involves a multistage process; components are grouped in several
stages for upgrading. At each stage in the upgrade, the upgraded components must interoperate with components
that have not yet been upgraded to ensure the overall operation of the contact center. Therefore, it is important
to verify this interoperability during the planning stages of the upgrade.

Before upgrading a production system, perform the upgrade on a lab system that mirrors your production
system to identify potential problems safely.

The following table details the required sequence for upgrading Unified CCE solution components, and the
minimum component groupings that must occur together within each stage. Follow each stage to completion
within each maintenance window. Each maintenance window must accommodate any testing required to
ensure system integrity and contact center operation.

You can combine more than one complete stage into a single maintenance window, but you cannot break any
one stage into multiple maintenance windows.

• For co-resident configurations, upgrade Finesse and ECE along with the CUIC/LiveData /IdS server
upgrade.

Note

Upgrade the components that apply to your Unified CCE contact center as follows:

In case of 4K deployment, the Unified CCE components consists of Rogger VM instead of Router and Logger
VMs.

Note

NotesComponentsComponent GroupStage

• Before you upgrade to Unified CVP 12.0, the ES84 or
later patch has to be applied to Cisco VVB 11.6 in order
to maintain compatibility between Unified CVP 12.0
and Cisco VVB 11.6.

• Before you upgrade to Unified CVP 12.5, you must
apply the latest ES of CCE 12.0.

For more information, see Installation and Upgrade
Guide for Cisco Unified Customer Voice Portal at
h t t p s : / / www. c i s c o . c om / c / e n / u s / s u p p o r t /
customer-collaboration/unified-customer-voice-portal/
products-installation-guides-list.html.

Cisco Unified Customer
Voice Portal (CVP)
(Operations Console,
Reporting Server, Call
Server/VXMLServer, Unified
Call Studio)

Queuing and self-service31
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NotesComponentsComponent GroupStage

• IOS Gateways (If used
for ingress access only.
If used for Outbound
Option Dialer, see Stage
7 .)

• IOS VXML Gateways

• Cisco Virtualized Voice
Browser

Gateways2

• SSO is an optional feature and exchanges authentication
and authorization details between the IdS component
and IdP provider.

For more information, see Unified CCEContact Center
Upgrade Flowcharts, on page 195.

• For IdS upgrade, see the procedure as documented in
the Upgrades section of Unified Intelligence Center
Installation and Upgrade Guide at:

https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

IdS ServerIdentity Service (IdS)/Single
Sign-On(SSO)

3

• Before you upgrade to Finesse 12.0, apply the latest ES
patch on Cisco Unified Intelligence Center 11.6 for the
reporting gadgets to continue to work on the new
Finesse desktop.

• To load any gadget to Finesse, you must first import
the certificate to Finesse.

For FinesseVM, you have to increase the
RAM before upgrading. See
https://www.cisco.com/c/dam/en/us/td/
docs/voice_ip_comm/uc_system/
virtualization/
cisco-collaboration-virtualization.html

Note

For more information, see Cisco Finesse Installation
and Upgrade Guide at https://www.cisco.com/c/en/us/
support/customer-collaboration/finesse/
products-installation-guides-list.html.

• For more information about ECE, see
https://www.cisco.com/c/en/us/support/
customer-collaboration/cisco-enterprise-chat-email/
products-installation-guides-list.html.

Cisco Finesse

ECE

Agent and supervisor
desktops

4
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NotesComponentsComponent GroupStage

• Cisco Unified Intelligence Center supports TLS 1.2
only. For Cisco Unified Intelligence Center 12.0 to be
compatible with releases earlier than Unified CCE
Release 11.6(1), run the CLI command set client tls
min-version. This command allows you to set the
minimum TLS version in the client for outbound SSL
connections to TLS 1.0 or 1.1. Restart the system for
the changes to take effect.

• For information about the CLI command to display the
current TLS minimum version for client, see Transport
Layer Security CLI Commands, on page 280.

CUIC serverReporting server5

• After you upgrade the Standalone Live Data server,
upgrade the VMware Tools manually. After upgrading
the VMware Tools, check the Check and upgrade
VMware Tools before each power on box in VM
Options > VM Edit Settings.

• Unified CCE Router

• Unified CCE Logger

• Admin & Data server
(AW/HDS/DDS)

• Standalone Live Data (if
Deployed)

• CUIC Reporting
Templates

• CCMP

• Administration Client

Central Controller6

You can have many PGs located on different virtual
machines. You can upgrade each PG virtual machine in its
own maintenance window.

• Agent (Unified
Communications
Manager) PG or System
PG, plus

• CTI Server

• CTI OS Server

• OutboundOption Dialer
and SIP IOS Gateway

Peripherals7

You can have many PGs located on different virtual
machines. You can upgrade each PG virtual machine in its
own maintenance window.

• MR PG (if not
collocated with Agent
PG on VM), plus VRU
PG (if not collocated
with Agent PG on VM)

• CRM connector

Peripherals8
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NotesComponentsComponent GroupStage

You can have many desktops located in many different sites.
You can upgrade CTI OS desktops in multiple maintenance
windows; the later upgrade stages are not dependent on the
completion of this stage.

CTI OS (Agent/Supervisor
Desktops)

Agent desktop client software9

If you upgrade to CUCM12.5 on theM4 servers, ensure that
you deploy CUCMoff-box. CUCM12.5 on-box deployment
are only supported for M5 and HX M5 servers.

For more information, refer to Virtualization for Unified
Contact Center Enterprise at http://www.cisco.com/c/dam/
en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

• Cisco Unified
Communications
Manager (Unified
Communications
Manager)

• JTAPI on Agent
(Unified
Communications
Manager) PG

Call Processing10

3 If you are using Unified IP IVR for self-service and queueing, see Getting Started with Cisco Unified IP IVR.

Unified CCE Contact Center Upgrade Flowcharts

The multi-stage upgrade flowchart is not applicable for Centralized UCCE 2K deployments that essentially
employ a co-resident CUIC/LiveData/IdS server, and have a single Agent PG VM pair.

Note

After upgrading Finesse, IdS, and CUIC, import IdS certificates on Finesse and CUIC servers.Note
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• When you upgrade Unified CVP to Release 12.0, the following considerations apply:

• If you are upgrading Cisco VVB to Release 12.0, upgrade Unified CVP and Cisco VVB to Release
12.0 in the same maintenance window.

• If you are upgrading to Unified CVP, Release 12.0 with VVB, Release 11.6(1), you must install
VVB, Release 11.6(1) ES84 before you upgrade Unified CVP to Release 12.0.

• Cisco VVB, Release 11.5(1) is incompatible with Unified CVP, Release 12.0.

Note

The following diagrams illustrate the stages of the component-level upgrade flows for a Cisco Unified Contact
Center Enterprise solution upgrade. Each diagram covers one of the stages. The letter at the end of each flow
indicates the start of the next flow that you are required to perform.
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Data Migration Considerations
The data migration set is identical no matter what migration path you follow.

During the Technology Refresh upgrade, EDMT does the following:

• Backups and restores the data.

• Performs data migration.

The EDMT may take a long time to migrate, backup, or restore the data, as the file sizes can be several
gigabytes (GB). If the EDMT tool is not responding during data migration or the data migration takes a long
time, check the Event logs in theMicrosoftWindows Event Viewer tool. The logs may show SQL or BACKUP
failure events. These events may occur because of file system errors or hardware errors and failures. Analyze
and fix these errors before re-running the EDMT tool.

Note

For Technology Refresh upgrades, use the fastest possible network (gigabit through one network switch)
between the source and the destination machines. Use of a crossover cable is not supported because it lacks
buffer memory and can cause data loss.

To reduce data migration time, consider reducing the database size by:

• Removing redundant records, especially call detail records (RCD, RCV, TCD, and TCV tables). However,
removing records affects the availability of historical reports; knowledge of the HDS schema is required.

• Purging the Logger database of all data that was already replicated to the HDS (25 GB or less).

• Using more efficient hardware, especially on I/O subsystems:

• RAID 1 + 0

• I/O Cache – more is better

Enable the Tempdb log to expand up to 3 GB.

When you upgrade to Cisco Unified Contact Center Enterprise, Release , the Do Not Call table that existed
before the upgrade is not available. Therefore, you must import the Do Not Call table.

Note

Required Disk Space for Migration

1. Run EXEC sp_spaceused command in the SQL Server.

2. Determine the following:

• DUS (Database Used Size).

Calculated as:

Database Used Size (DUS) = (database_size – unallocated space)

• Required disk space by EDMT for backup of database

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
210

Upgrade Overview
Data Migration Considerations



Calculated as:

Space that is used for backup = 1.2 times of DUS.

Note: When the backup and restore drive are same, then required disk space by EDMT is equal to restore
database size plus space used for backup.

Note

When the backup and restore has to be done through EDMT, and since the database backup contains encrypted
data, this process cannot be performed unless the source certificate that encrypted the database is copied to
the destination server.

Follow the procedures outlined in the belowMicrosoft documentation to restore the certificate on destination
server.

• https://docs.microsoft.com/en-us/sql/relational-databases/security/encryption/
move-a-tde-protected-database-to-another-sql-server?view=sql-server-ver15

• https://www.sqlshack.com/
restoring-transparent-data-encryption-tde-enabled-databases-on-a-different-server/

• https://www.databasejournal.com/tips/
how-to-move-a-tde-encryption-key-to-another-sql-server-instance.html

If you do not want to move the encrypted backup, then disable TDE on the source database, perform the
backup and restore through EDMT, and enable TDE on destination database. To enable and disable TDE on
the database, see Enable and Disable TDE on a Database, on page 212.

Note

Time Guidelines and Migration Performance Values

For a close estimate of time and space requirements, run EDMT against a copy of your production database
on hardware that is similar to your production environment, in a lab environment. For customers who do not
have the facility, the following sections provide information that is gathered while performance testing in the
labs at Cisco Systems, Inc.

• Typical database migration performance values: The following table provides high-level guidelines
for the time that is taken to upgrade the Loggers and HDSs based on internal upgrade testing with hardware
Cisco UCS C240 M4SX. Actual times may vary based on the parameters previously mentioned.

• Backup and Restore - Technology Refresh only: The backup speed depends on the speed of the network,
and the speed of the disk sub-system. The faster the network, the sooner the network copy.

Total Time (hours)Data Migration
Time (minutes)

Backup/Restore Time (hours)Database Used
Size (GB)

2 - 2.5 hrs< 2 mins1.5-2 hrs500 GB
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• The values in the Database Used Size column are based on the amount of disk space that is used by the
source database, and not the size of the disk it resides on.

• The values in the Backup Time and Restore Time columns assumes that the network meets the minimum
requirements.

For more information about the minimum requirements, refer to the at .

Note

Enable and Disable TDE on a Database
To enable Transparent Data Encryption (TDE) on a database, perform the following:

These steps are to be performed with sysadmin user permission.Note

1. Create a server certificate data encryption key.
USE master
GO
CREATE CERTIFICATE DEKCert WITH SUBJECT = 'DEK Certificate'
GO

2. Create a backup of the server certificate data encryption key.
BACKUP CERTIFICATE DEKCert TO FILE = '<SystemDrive>:\DEKCert'
WITH PRIVATE KEY ( FILE = '<SystemDrive>:\temp\DEKCertPrivKey' ,
ENCRYPTION BY PASSWORD = 'C1sco123=' )
GO

3. Create database encryption key for the database to configure transparent data encryption. In the following
query, ucce_sideA is the name of the active database.
USE ucce_sideA
GO
CREATE DATABASE ENCRYPTION KEY
WITH ALGORITHM = AES_256
ENCRYPTION BY SERVER CERTIFICATE DEKCert
GO

4. Enable database encryption. Run the following query where ucce_sideA is the name of the active database.
ALTER DATABASE ucce_sideA SET ENCRYPTION ON

By setting encryption on, a background task starts encrypting all the data pages and the log file. This can take
a considerable amount of time, depending on the size of the database. Database maintenance operations should
not be performed when this encryption scan is running.

Note

5. To query the status of the database encryption and its percentage completion, query the new
sys.dm_database_encryption_keys.
SELECT DB_NAME(e.database_id) AS DatabaseName,
e.database_id,
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e.encryption_state,
CASE e.encryption_state
WHEN 0 THEN 'No database encryption key present, no encryption'
WHEN 1 THEN 'Unencrypted'
WHEN 2 THEN 'Encryption in progress'
WHEN 3 THEN 'Encrypted'
WHEN 4 THEN 'Key change in progress'
WHEN 5 THEN 'Decryption in progress'
END AS encryption_state_desc,
c.name,
e.percent_complete
FROM sys.dm_database_encryption_keys AS e
LEFT JOIN master.sys.certificates AS c
ON e.encryptor_thumbprint = c.thumbprint

To disable TDE on a database, perform the following:

USE master;
GO
ALTER DATABASE ucce_sideA SET ENCRYPTION OFF;
GO
-- Remove Encryption Key from Database
USE ucce_sideA;
GO
DROP DATABASE ENCRYPTION KEY;
GO

Silent Upgrade
There are situations when silent upgrade can be used in running an installation wizard. You can run a silent
installation while performing a fresh install or an upgrade.

For more information, see Silent Installation, on page 58.

Unified CCE Upgrade Overview
The supported upgrade paths to Unified CCE 12.0(1) are as follows:

• Unified CCE 11.0(x) to Unified CCE 12.0(1)

• Unified CCE 11.5(x) to Unified CCE 12.0(1)

• Unified CCE 11.6(x) to Unified CCE 12.0(1)

Upgrade Prerequisites

Before you begin

• Make sure that Windows Update is not running in parallel when you begin installation.

• Before you upgrade the Cisco VOS based servers such as the Live Data server, check the Check and
upgrade VMware Tools before each power on box in the VM's Options > Edit Settings.

For more information on VMware Tools upgrade, see the VMware documentation.
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• The minimum disk space required to perform the upgrade is 2175 MB.
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C H A P T E R 7
Common Ground Upgrade

• Preupgrade Overview, on page 215
• Common Ground Preupgrade Task Flow, on page 216
• Common Ground Preupgrade Tasks, on page 217
• Common Ground Upgrade Task Flow, on page 219
• Common Ground Upgrade Tasks, on page 223

Preupgrade Overview
The preupgrade process ensures that your systems have the necessary software to support your contact center.
These tasks prepare the way for a successful upgrade of your Cisco contact center components to the new
release.

Upgrade Tools

During the preupgrade process, use the following tools as required:

• User Migration Tool—A standalone Windows command-line application that is used for all upgrades
that involve a change of domain. The tool exports all existing user accounts (config/setup and supervisors)
from the source domain to a .bin file. The file is used in the target domain during the upgrade.

You can download the User Migration Tool from Cisco.com by clicking ICM User Migration Tool
Software.

• Regutil Tool—Used in Technology Refresh upgrades, exports the Cisco Systems, Inc. registry from the
source machine during the preupgrade process. The output of the tool is required on the destination
machine when running the Unified CCE Installer during the upgrade process.

You can download the Regutil Tool from Cisco.com by clicking Contact Center Enterprise Tools.

• Domain Manager—Used to provision Active Directory.

The Domain Manager Tool is delivered with the main installer.

• Upgrade.exe—Used to upgrade the schema of the logger, AW DB, HDS DB, and BA databases to a
version compatible with the current Unified CCE Software version. It is typically used when the installer
fails to automatically upgrade the schema of the AW database. The other databases are typically upgraded
using EDMT and not the installer.

Perform the following steps to use the tool:
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<ICM install directory>:\icm\bin>upgrade.exe -s <Server Name> -d
<Database name> -dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds" or "aw" or "ba", depending on the database that
requires the schema to be upgraded.

• Enhanced Database Migration Tool (EDMT)—A wizard application that is used for all upgrades to
migrate the HDS, Logger, and BA databases during the upgrade process.

You can download the EDMT from Cisco.com by clicking Cisco Enhanced Data Migration Tool
Software Releases.

The prerequisites for running EDMT are:

• EDMT also requiresMicrosoft®ODBCDriver 11 for SQL Server® and Visual C++ Redistributable
for Visual Studio 2015 (or higher). The latest version of these packages can be downloaded from
the Microsoft website. However, a copy of the same is also available in the Prerequisites folder of
EDMT.

The EDMT displays status messages during the migration process, including warnings and errors.
Warnings are displayed for informational purposes only and do not stop the migration. Errors stop the
migration process and leave the database in a corrupt state. If an error occurs, restore the database from
your backup, fix the error, and run the tool again.

• If you are configuring SQL services to run as Virtual account (NT SERVICE)
or Network Service account (NT AUTHORITY\NETWORK SERVICE),
you must run EDMT as an administrator.

• The installer, not the EDMT, upgrades the AW database for the
Administration & Data Server.

•

Note

Common Ground Preupgrade Task Flow
Perform the following Common Ground preupgrade tasks in any order.

The Common Ground upgrade assumes the host server runs on Windows Server.Note

SeeTask

Release Notes for Cisco Unified Contact Center Enterprise Solutions at
https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-enterprise/products-release-notes-list.html

Review target
Release Notes

ESXi Supportability, on page 5ESXi
Supportability
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SeeTask

Virtual Machine Snapshot for Unified CCE Component Virtual Machines, on page 218Virtual Machine
Snapshot for
Unified CCE
Component
Virtual Machines

Upgrade Overview, on page 189Download the
Enhanced
Database
Migration Tool

Notify all
stakeholders,
including:

• Cisco
Technical
Assistance
Center
(TAC)

• Local Cisco
Representatives

• Customer
Operations
and
Emergency
Management
Center

• Third-party
vendors as
applicable

Common Ground Preupgrade Tasks

Disable Configuration Changes

Procedure

Step 1 To disable configuration changes during the upgrade, set the following registry key to 1 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.
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Live data services connect to the new Central controller machines only after you upgrade both
sides of Central controller, and enable the configuration changes.

Note

Step 2 Confirm that configuration changes are disabled by attempting to save a configuration change.

When you try to save the change, a message is displayed confirming the change failure.

Virtual Machine Snapshot for Unified CCE Component Virtual Machines
Uninstallation of Unified CCE 12.5(1)12.0(1) installed on server machines using the ICM-CCE-Installer ISO
is not supported.

Uninstallation of Unified CCE 12.0(1) installed on server machines using the ICM-CCE-Installer ISO is not
supported.

To revert to the previous versions that existed before you did a Common Ground in-place upgrade of
installations to Unified CCE 12.0(1) , perform one of the following tasks:

1. Take a Virtual Machine Snapshot in the powered off state before the upgrade.

2. Clone the Virtual Machine before the upgrade.

Delete these snapshots or clones after the upgrades are successfully completed. Such deletions will prevent
performance issues.

Uninstallation and re-installation of other packages like Administration Client and Internet Script Editor (ISE)
will continue to be supported.

VM Hardware Version Upgrade
Perform the following procedure to upgrade the hardware version of the virtual machine (VM).

The hardware compatibility of the VM must be set to ESXi 6.0 and later.Note

Before you begin

• Power off the VM.

• Upgrade to the ESXi version compatible with this release. For more information, see
https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

Procedure

Step 1 Launch the vSphere Web Client using the browser.
Step 2 Log in to the vCenter Server.
Step 3 Right-click on the VM, and select the menu option Compatibility > Upgrade VM Compatibility.
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The Upgrade VM Compatibility option appears only if the hardware version on the VM
is not the latest version supported.

Note

Step 4 In the Compatible with field, select ESXi 6.0 and later.
This sets the hardware version of the VM to 11.

Step 5 Click Ok.
Step 6 Power on the VM.

If the system prompts, upgrade the VMware tools. For more information, see Install Vmware
Tools, on page 17.

Note

Increase the Provisioned Disk Size for Unified Intelligence Center VMs
(Standalone and Coresident)

Procedure

Step 1 Power off the virtual machine.
Step 2 Click Edit Settings.
Step 3 Click the Hardware tab, and select the hard disk to modify.
Step 4 In the Disk Provisioning pane, increase the provisioned size from 146 GB to 200 GB.
Step 5 Click OK to save your changes and close the dialog box.
Step 6 Start the virtual machine.

Common Ground Upgrade Task Flow
For the Unified CCE core components, there is a general flow for redundant systems to ensure that Cisco
Contact Center operation continues during the entire upgrade process. Sides A and B are brought down,
upgraded, tested, and brought back up in a sequence that ensures continuous operation of the Cisco Contact
Center.

For coresident configurations, upgrade Finesse and ECE along with the CUIC/LiveData /IdS server upgrade.Note

For Common Ground upgrades, perform the following upgrade tasks:

SeeTask

Identity Service/SSO
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SeeTask

SSO is an optional feature and exchanges authentication and authorization details between an identity
provider (IdP) and an identity service (IdS).

For more information, see Unified CCE Contact Center Upgrade Flowcharts, on page 195

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

Identity Service (IdS)/Single
Sign-On(SSO)

For ECE installation or upgrade instructions, see the Enterprise Chat and Email Installation and
Configuration Guide for Unified Contact Center Enterprise at https://www.cisco.com/c/en/us/support/
customer-collaboration/cisco-enterprise-chat-email/products-installation-guides-list.html

Upgrade Enterprise Chat
and Email (ECE)

Before you upgrade to Finesse 12.0, apply the ES11 patch on Cisco Unified Intelligence
Center 11.6 for the reporting gadgets to continue to work on the new Finesse desktop.

Note

For more information, see Cisco Finesse Installation and Upgrade Guide at https://www.cisco.com/
c/en/us/support/customer-collaboration/finesse/products-installation-guides-list.html.

ES69 provides the ability to connect a maximum of two versions of Finesse to the same
peripheral gateway during the upgrade or migration process to facilitate the migration of
agents and supervisors to the new Finesse version. However, this mode of operation is
not supported for production use beyond the upgrade or migration phase.

Note

Upgrade Finesse

Queuing and self-service components

Before you upgrade to Unified CVP 12.0, the ES84 patch has to be applied to Cisco VVB
11.6 in order to maintain compatibility between Unified CVP 12.0 and Cisco VVB 11.6.

Note

Installation and Upgrade Guide for Cisco Unified Customer Voice Portal at https://www.cisco.com/
c/en/us/support/customer-collaboration/unified-customer-voice-portal/
products-installation-guides-list.html

Upgrade Cisco Unified
Customer Voice Portal.4

Infrastructure and media resource components

Installation and Upgrade Guide for Cisco Virtualized Voice Browser at

https://www.cisco.com/c/en/us/support/customer-collaboration/virtualized-voice-browser/
products-installation-guides-list.html

Cisco Virtualized Voice
Browser

Upgrade Voice and Data Gateways, on page 231Upgrade voice and data
gateways.

Reporting server

Installation and Upgrade Guide for Cisco Unified Intelligence Center at

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

Upgrade Cisco Unified
Intelligence Center server.

Unified CCE Central Controller and Administration & Data Server components

Upgrade Windows Server, on page 223

Upgrade SQL Server , on page 225

Bring down Side A Logger,
and upgrade the VM to the
new platform of Windows
Server and SQL Server.
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SeeTask

Migrate Unified CCE Logger Database and Upgrade Logger, on page 225Migrate Side A Logger
database, and upgrade the
Logger.

Upgrade Windows Server, on page 223Bring down Side A Call
Router, and upgrade the VM
to new platform ofWindows
Server.

Upgrade Unified CCE Call Router, on page 227Upgrade Side ACall Router.

Upgrade Windows Server, on page 223

Upgrade SQL Server , on page 225

Upgrade the VM for the
Administration & Data
Server connected to Side A
to the new platform of
Windows Server and SQL
Server.

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server, on page 227Upgrade the Administration
& Data Server connected to
Side A.

Bring Upgraded Side A into Service, on page 231Bring Side A Logger and
Call Router into service,
bring down Side B Logger
and Call Router.

Upgrade Windows Server, on page 223

Upgrade SQL Server , on page 225

Upgrade the VM for the
Side B Logger to the new
platform ofWindows Server
and SQL Server.

Migrate Unified CCE Logger Database and Upgrade Logger, on page 225Migrate Side B Logger
database and upgrade the
Logger.

Upgrade Windows Server, on page 223Upgrade the VM for the
Side B Call Router to new
platform of Windows
Server.

Upgrade Unified CCE Call Router, on page 227Upgrade Side BCall Router.

Verify Operation of Upgraded Side B Call Router and Logger, on page 233Bring Side B Call Router
into service and verify
operation. Bring Side B
Logger into service and
verify operation.
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SeeTask

Upgrade Windows Server, on page 223

Upgrade SQL Server , on page 225

Upgrade the VM for the
Administration & Data
Server connected to Side B
to the new platform of
Windows Server and SQL
Server.

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server, on page 227Upgrade the Administration
& Data Server connected to
Side B.

Installation and Upgrade Guide for Cisco Unified Intelligence Center at https://www.cisco.com/c/en/
us/support/customer-collaboration/unified-intelligence-center/products-installation-guides-list.html

Upgrade Cisco Unified
IntelligenceCenter reporting
templates.

Installation and Configuration Guide for Cisco Unified Contact Center Management Portal at

https://www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-management-portal/products-installation-guides-list.html

Upgrade Unified Contact
Center Management
Portal(Unified CCMP).

Upgrade Unified CCE Administration Client, on page 251Upgrade Administration
Client.

Database Performance Enhancement, on page 235Database Performance
Enhancement.

Unified CCE Peripheral Gateways and associated components

Upgrade Windows Server, on page 223Upgrade VM for the PG to
the new platform of
Windows Server.

Upgrade Peripheral Gateways, on page 228Upgrade PGs.

Upgrade Outbound Option Dialer, on page 229Upgrade Outbound Option
Dialer.

Cisco Agent Desktop Installation Guide at https://www.cisco.com/c/en/us/support/
customer-collaboration/computer-telephony-integration-option/products-installation-guides-list.html

Upgrade CTI OS server.

Desktop client components

Cisco Agent Desktop Installation Guide at https://www.cisco.com/c/en/us/support/
customer-collaboration/agent-desktop/products-installation-guides-list.html

The CTI Toolkit Desktop is only supported for System PG and other TDM PG
deployments like Avaya PG.

Note

CTI OS Client desktop
applications.

Call processing components

Upgrade and Migration Guide for Cisco Unified Communications Manager and IM and Presence
Service at http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/ products-installation-guides-list.html

Upgrade Cisco Unified
Communications Manager.
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SeeTask

Upgrade Cisco JTAPI Client on PG, on page 235Upgrade (uninstall and
reinstall) the JTAPI client
on the Cisco Unified
Communications Manager
PG.

Media recording components

Installation and Administration Guide for Cisco MediaSense at

https://www.cisco.com/c/en/us/support/customer-collaboration/mediasense/
products-installation-guides-list.html

Upgrade MediaSense. 5

4 If you are using IP IVR for self-service and queuing, see Getting Started with Cisco Unified IP IVR.
5 UCCE 12.0 supports only Cisco MediaSense 11.5.

The CTI Toolkit Desktop was deprecated in Unified CCE Release 11.0(1).Note

Common Ground Upgrade Tasks
The following section provides instructions about upgrading the virtual environment and the Unified CCE
components. For instructions about upgrading non-Unified CCE components in a Unified CCE solution, for
example Finesse and CUIC, see the links to component-specific documents in the Common Ground Upgrade
Task Flow, on page 219.

Upgrade Windows Server

To upgrade to Windows Server 2016, select Windows Server 2016 (Desktop Experience) option and then
select Keep personal files and apps option. For more information, see the corresponding Microsoft
documentation.

Note

For information about supported editions, see the Contact Center Enterprise Compatibility Matrix at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/
products-device-support-tables-list.html.

Before you begin

• Using Unified CCE Service Control, stop all Unified CCE services on the Unified CCE servers that you
are upgrading, and set the startup type as Manual.

If you are upgrading the Logger, ensure that you have disabled configuration changes by performing the
following steps:

1. On the A side of the CallRouter in the system that you are upgrading, set the
HKEY_LOCAL_MACHINE\Software\Cisco Systems,
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Inc.\ICM\<instance_name>\RouterA\Router\CurrentVersion\Configuration\Global\DBMaintenance
key to 1.

2. On the B side of the CallRouter in the system that you are upgrading, set the
HKEY_LOCAL_MACHINE\Software\Cisco Systems,
Inc.\ICM\<instance_name>\RouterB\Router\CurrentVersion\Configuration\Global\DBMaintenance
key to 1.

3. Verify that configuration changes are prevented. When you attempt to save a configuration change,
you should see the following message: Failed to update the database. Exclusive
access to the CallRouter denied because configuration changes are
currently disabled in the router registry.

• You must upgrade the hardware version of the VM to the version supported in this release. For more
information, see https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/
virtualization-unified-contact-center-enterprise.html.

• Ensure that the virtual machine has enough space before the upgrade. Operating System upgrade to
Windows Server 2016 requires minimum of 32-GB primary hard disk space. If the virtual machine is a
Logger/Distributor machine, the upgrade to SQL Server 2017 Standard or Enterprise edition requires an
extra 6 GB.

If the disk space of the CCE or CVP virtual machines is expanded to support this upgrade, you must
install ICM 12.0(1) ES26 patch on the system. You can download the CCE 12.0 Mandatory
Update for Fresh Install/Tech Refresh from https://software.cisco.com/download/home/
268439622/type/280840583/release/12.0(1). Failing to do so displays alerts in the Inventory page of
Unified CCE Administration and may result in the Inventory page being inaccessible.

• Change the guest operating system to Microsoft Windows Server 2016 (64 bit). To do so, right-click the
virtual machine, selectEdit settings >Options >General Options and select the guest operating system
as Microsoft Windows Server 2016 (64 bit) and ensure the VM is powered off during this procedure.

To be able to select the Microsoft Windows Server 2016 (64 bit) guest operating
system, you must set the VM hardware compatibility to ESXi 6.0 and later. For
more information, see VM Hardware Version Upgrade, on page 218.

Note

• Server for NIS Tools is not supported when you upgrade the system to Microsoft Windows Server 2016.
Therefore, remove the Server for NIS Tools feature from Server Manager before upgrading the system.
To do that:

1. Go to Server Manager and open Remove Roles and Features Wizard.

2. On the Remove Features page, expand Remote Server Administration Tools > Role
Administration Tools > AD DS and AD LDS Tools > AD DS Tools.

3. Uncheck Server for NIS Tools [DEPRECATED] and continue with the wizard.

What to do next

After upgrading your Windows Server, do the following:
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• If your Windows Server supports the Multilingual language pack, it will be uninstalled. You must install
the language pack manually. For more information on installing language pack, see Microsoft
documentation at https://devicepartner.microsoft.com/en-IN/#fbid=bSYXlh5sO3X.

Upgrade SQL Server
Microsoft supports in-place upgrade of operating system and SQL Server. After you upgrade the operating
system, upgrade SQL Server.

Contact Center Enterprise Compatibility Matrix at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html

Note

Before you begin

• Upgrading SQL Server requires a minimum of 6-GB hard disk space. Ensure that the virtual machine
has the required space before you begin the upgrade.

• If the virtual machine has SQL Server Enterprise, then it can be upgraded only to the Enterprise version.
However, if the virtual machine has SQL Standard Edition, then it can be upgraded to either SQL Server
Standard or Enterprise Edition.

Procedure

Step 1 Run the SQL Server installer. Consult Microsoft documentation as needed.
Step 2 Step through the wizard. As appropriate, accept the default or choose the correct instance for your deployment.

Select Rebuild on the Full-Text Search Upgrade Options page.

• Microsoft SQL Server 2017 does not contain SQL Server Management Studio in the default toolkit.
Re-run the SQL Server setup to install Management Studio by going to SQL Selection Center >
Installation > Install SQL Server Management Tools. If your computer has no internet connection,
download and install SQL server 2017 Management Studio manually.

• SQL Server Client Tools from the previous version remain on the server along with the same tools of
SQL Server 2017. These tools include SQL ServerManagement Studio, SQL Server Profiler, the Database
Engine Tuning Advisor, sqlcmd, and osql.

Note

Migrate Unified CCE Logger Database and Upgrade Logger
To upgrade the Logger, you do the following tasks:

1. Migrate the Logger database.

2. If you use Outbound Option High Availability, migrate the Outbound Option database.
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3. Install the new software.

Procedure

Step 1 Using Unified CCE Service Control, stop all Unified CCE services on the server and change to Manual Start.
Step 2 Download the EDMT tool from Cisco.com, and ensure pre-requisites for the same have been installed on the

Logger system, prior to launching EDMT. These include the ODBC Driver 11 for SQL Server, and Visual
C++ Redistributable for Visual Studio 2015.
For more information about EDMT, see Preupgrade Overview, on page 215.

Step 3 Launch the EDMT and click Next.
Step 4 Select Common Ground, and click Next.
Step 5 On the warning message, click Yes if you have taken a backup of your database, and no services are currently

running.

If you have not taken the backup of your database, click No to exit the installer.Note

Step 6 In the Database Connection section, highlight the database that you want to upgrade, and then click Next.
Step 7 Click Start Migration. A warning message is displayed asking for confirmation of the data migration.
Step 8 Click Yes to confirm.
Step 9 ClickOK to acknowledge the message. After completion of the data migration, a warningmessage is displayed

asking you to select a valid deployment type.

This message notification is applicable only when EDMT finds the DeploymentType as 0(Zero)
in the Congestion_Control table during data migration.

Note

Step 10 Exit the EDMT.

Set the TempDB AutoGrowth of Data files to 100 MB manually.Note

Step 11 (Optional) If Outbound Option High Availability is deployed, repeat steps 1 through 12 to migrate the BA
database.

Step 12 To upgrade the Logger, launch the ICM-CCE-Installer, and click Next.
Step 13 (Optional) To apply the Unified ICM Minor/Maintenance Release, click Browse and navigate to the

Minor/Maintenance Release software. Click Next.
Step 14 (Optional) Select SQL Server Security Hardening and click Next.
Step 15 Click OK on any informational messages that display.
Step 16 Click Install.
Step 17 Reboot the server when the upgrade completes.
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Upgrade Unified CCE Call Router

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply the Unified ICM Minor/Maintenance Release, click Browse and navigate to the

Minor/Maintenance Release software. Click Next.
Step 3 Click OK on any informational messages that display.
Step 4 Click Install.
Step 5 Reboot the server when the upgrade completes.

Migrate HDS Database and Upgrade Unified CCE Administration & Data Server
The deployment of the Administration & Database Server determines which tools to use for an upgrade:

• For an AW-only deployment, the EDMT is not required; the ICM-CCE-Installer completes the upgrade.

• For any deployment that involves an HDS database, use the EDMT to migrate the HDS database before
running the installer.

Procedure

Step 1 Using Unified CCE Service Control, stop all Unified CCE services on the Server and change to Manual Start.
Step 2 For HDS-related deployments. Download the EDMT tool from Cisco.com, and ensure pre-requisites for the

same have been installed on the Administration & Database Server system, before launching EDMT. These
include the ODBC Driver 11 for SQL Server, and Visual C++ Redistributable for Visual Studio 2015.

For more information about EDMT, see Preupgrade Overview, on page 215.

Step 3 Launch the EDMT and clickNext. SelectCommon Ground and clickNext. Review or change the information
that is displayed as required and click Start Migration. Click Yes on the warning message that displays. Exit
the EDMT.

This message notification is applicable only when EDMT finds the DeploymentTypeas 0(Zero)
in the Congestion_Control table during data migration.

Note

Set the TempDB AutoGrowth of Data files to 100 MB manually.Note

Step 4 Launch the ICM-CCE-Installer and click Next.
Step 5 (Optional) To apply the Unified ICM Minor/Maintenance Release, click Browse and navigate to the

Minor/Maintenance Release software. Click Next.
Step 6 (Optional) Select SQL Server Security Hardening and click Next.
Step 7 Click OK on any informational messages that display.
Step 8 Click Install.
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Step 9 Reboot the server when the upgrade completes.

Upgrade Unified CCE Administration Client

Procedure

Step 1 Launch the 12.5 AdminClientInstaller and click Next.
Step 2 (Optional) To apply any Minor/Maintenance Releases, click Browse, and navigate to the Minor/Maintenance

Release software. Click Next.
Step 3 Click OK on any informational messages that display.
Step 4 Click Install.
Step 5 Reboot the server when the upgrade completes.

For more information about configuring permissions in your local machine, see Configure Permissions in the
Local Machine, on page 90.

Enable Configuration Changes

Procedure

Step 1 To enable configuration changes during the upgrade, set the following registry key to 0 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.

Step 2 To confirm that configuration changes are enabled, save a configuration change.

Save your changes.

Upgrade Peripheral Gateways
You can upgrade different Peripheral Gateways (PGs) within a contact center within different maintenance
windows. However, upgrade all PGs that reside on the same virtual machine and their redundant PGs (Side
A and then the corresponding Side B; or vice-versa) during the same maintenance window.

The following dependencies occur when upgrading the Unified Communications Manager PG:

• If your contact center uses Outbound Option, upgrade any Outbound Option Dialers that are associated
with Unified Communications Manager PGs at the same time.

• When you upgrade the Unified Communications Manager application, upgrade the JTAPI client that is
associated with the Unified Communications Manager PG at the same time.
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When the CTI server that is associated with the PG gets upgraded, the CTI server connection mode is set to
the Mixed mode by default. The Mixed mode enables both Secured and Non-Secured mode of connection.
For the Secured mode of connection, a new port is selected based on the port selection logic. For more
information on Port Utilization, see the Port Utilization Guide for Cisco Unified Contact Center Solutions.
If the port that is selected by default conflicts with the existing ports, then you need to either release the default
port or change the Secured mode port to an available port after the upgrade.

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply the Unified ICM Minor/Maintenance Release, click Browse and navigate to the

Minor/Maintenance Release software. Click Next.
Step 3 Click OK on any informational messages that display.
Step 4 Click Install.
Step 5 Reboot the server when the upgrade completes.

Upgrade Outbound Option Dialer
During the upgrade, information about which contacts were called and which you need call is lost for in-process
outbound campaigns. Plan the timing of the upgrade accordingly.

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply the Unified ICM Minor/Maintenance Release, click Browse and navigate to the

Minor/Maintenance Release software. Click Next.
Step 3 Click OK on any informational messages that display.
Step 4 Click Install.
Step 5 Reboot the server when the upgrade completes.
Step 6 Use Unified CCE Service Control to set all Unified CCE services to Automatic Start.
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C H A P T E R 8
Common Upgrade Tasks

• Upgrade Voice and Data Gateways, on page 231
• Bring Upgraded Side A into Service, on page 231
• Verify Operation of Upgraded Side B Call Router and Logger, on page 233
• Upgrade Cisco JTAPI Client on PG, on page 235
• Database Performance Enhancement, on page 235

Upgrade Voice and Data Gateways
Perform the following procedure on eachmachine that hosts gateways that are used for TDM ingress, Outbound
Option dialer egress, and VXML processing.

Procedure

Step 1 For VXML gateways only, perform this step. For all other gateways, proceed to the next step.

Run the #copy tftp flash <IP Address> <filename>.bin command to copy the flash from a remote
machine to the gateway.

Step 2 Run the #sh flash command to check the version.
Step 3 Run the following commands in order:

a) #conf t

b) #no boot system flash: <old image>

c) #boot system flash: <new image>

d) #wr

e) #reload

Step 4 Run the #sh version command to verify that the new version shows in the gateway.

Bring Upgraded Side A into Service
After the Side A Unified CCE Logger, Call Router, and Administration & Data Server are upgraded, follow
this procedure to bring Side A into service.
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The logger and distributor services run with existing service logon account and is authorized by service security
group in the domain. If you want to run logger and distributor services with local authorization, then you have
to modify the service accounts using Service Account Manager Tool.

For more information on how to run Service Account Manager tool, see the Staging Guide for Cisco Unified
ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the side B Call Router and Logger.
However, before stopping Side B Router and Logger, also make sure that all non-upgraded Adminitration
and Data Servers are stopped and shutdown, before starting the upgraded Side A Logger and Router servers.

Step 2 Manually start the Unified CCE services on the Side ACall Router and Logger, and the upgradedAdministration
& Data Server. Verify the following basic operations of the Side A Central Controller categories:

OperationCategory

• Setup logs indicate no errors or failure conditions.

• AD domain has all users.

• Schema upgrade is successful for all databases (no loss of data integrity or loss of data).

• All component services start without errors.

• Calls are successfully processed.

General

• The Rtsvr logs indicate that the upgraded Administration & Data Server has connected
successfully.

Call
Router

• Recovery process that is not required, no activity other than process start up.

• Users are in correct domain.

• Configuration information is passed to Call Router.

• Replication process begins when HDS comes online.

Logger

• The updateAW process logs indicate that the Administration & Data Server is waiting for
work.

• Replication process begins with no errors.6

Administration
& Data
Server

• Specified users are able to use configuration manager.Security

• Previous settings for users are present when application is opened.

• Validate All script yields the same results that the preupgrade test yielded.

• You can open, edit, delete, or create new scripts.

Script
Editor

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
232

Common Upgrade Tasks
Bring Upgraded Side A into Service

http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html


OperationCategory

• Import or Export functionality is present.

• Database space allocation and percent used are correct.

ICMDBA

6 During replication, data from Config_Message_Log table is replicated from Logger database to
AW database. A purge mechanism is also introduced for Config_Message_Log table in AW
Database. The default retention period is set to 90 days. To change the retention period, modify
the following registry key:

Cisco Systems,

Inc.\ICM\<instancename>\Distributor\RealTimeDistributor
\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog

Step 3 Use Unified CCE Service Control to set the Unified CCE services to Automatic Start on each of the upgraded
Unified CCE components.

Step 4 Verify production system operation while running with the upgraded Side A Call Router and Side A Logger.

Verify Operation of Upgraded Side B Call Router and Logger
Before you begin

The logger and distributor services that are run with existing service logon account and is authorized by service
security group in the domain. If you want to run logger and distributor services with local authorization, then
you have to modify the service accounts using Service Account Manager Tool.

For more information on how to run Service Account Manager tool, see the Staging Guide for Cisco Unified
ICM/Contact Center Enterprise at
http://www.cisco.com/c/en/us/support/customer-collaboration/unified-contact-center-enterprise/products-installation-guides-list.html.

Procedure

Step 1 Before bringing Side B into service, manually synchronize Logger B to Logger A using ICMDBA.
Step 2 Start the Side B Call Router and Logger services.

As each node starts up, it searches for the other server components and attempts to register with them. If you
completed the ICM-CCE-Installer and network testing successfully, no major errors should occur.

To verify whether a process is up, use the Diagnostic Framework Portico ListProcess option, available through
the Unified CCE Tools shortcut that is created by the installer.

In order to add configuration data, the Central Controller, and Administration &Data Servers must be running.

Verify that the Unified CCE processes have no errors:
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OperationCategory

• Router: Running and synchronized with peer.

• Rtsvr: Indicates no connectivity to Administration & Data Server
currently.

Call Routers

• Logger: Connected to its respective database and synchronized with
peer. MDS is in service.

• Replication: No connectivity to Administration & Data Server HDS
currently.

Loggers

Step 3 To start the Unified CCE Distributor services, verify that the Unified CCE processes have no errors.

OperationCategory

• Router: Running and synchronized with peer.

• CCAgent: In service, and without any errors.

• Rtsvr: Feed activated to Administration & Data Server.

Call
Routers

• Logger: Connected to its respective database and synchronized with peer. MDS is in service.

• Replication: Connected to the Administration & Data Server.

Loggers

• Updateaw: Displays "Waiting for new work."

• Iseman: Listen thread waiting for client connection. (Exists only if Internet Script Editor is
configured).

• Replication: Replication and recovery client connection initialized. 7

Administration
& Data
Server

7 During replication, data from Config_Message_Log table is replicated from Logger
database to AW database. A purge mechanism is also introduced for
Config_Message_Log table in AW Database. The default retention period is set to
90 days. To change the retention period, modify the following registry key:

Note

Cisco Systems, Inc.\ICM\<instancename>\Distributor\RealTimeDistributor
\CurrentVersion\Recovery\CurrentVersion\Purge\Retain\System\ConfigMessageLog

Step 4 Validate the following settings from the system diagram for the Production Environment andmake the required
changes before you place the systems in production:
a) Clear event logs.
b) Remove any media from drives.
c) Ensure that all services are set to Manual Start. Services are not set to Automatic Start until after the

implementation testing in the production environment.

Step 5 Verify overall system operation.
Step 6 Enable configuration changes.
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a) Set the following registry key to 0 on the Side A and Side B Call Routers of the system:
HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance
name>\Router<A/B>\Router\CurrentVersion\Configuration\Global\DBMaintenance.

b) Verify that configuration changes can be made.

Step 7 Upgrade any other Administration & Data Servers or HDSs using the steps that are documented in Migrate
HDS Database and Upgrade Unified CCE Administration & Data Server, on page 227.

Upgrade Cisco JTAPI Client on PG
If you upgrade Unified CommunicationsManager (Unified CM) in the contact center, also upgrade the JTAPI
client that resides on the PG. To upgrade the JTAPI client, uninstall the old version of the client, restart the
server, and reinstall a new version. You install the JTAPI client using the Unified Communications Manager
Administration application.

To install the JTAPI client for the Unified CM release that you have upgraded to, see the Install Cisco JTAPI
Client on PG, on page 49 topic.

Before you begin

Before you perform this procedure, you must:

• Uninstall the old JTAPI client from the Unified Communications Manager PG

• Restart the PG server.

Database Performance Enhancement
After you perform a Common Ground or a Technology Refresh upgrade, complete the procedures described
in this section to enhance the performance of the database. This is a one-time process and must be run only
on the Logger and AW-HDS databases during a maintenance window.

• Performance Enhancement of TempDB, on page 235 (You can skip this when performing a Technology
Refresh upgrade)

• Performance Enhancement of Logger Database, on page 236

• Performance Enhancement of AW-HDS Database, on page 237

Performance Enhancement of TempDB
Perform this procedure on Logger, Rogger, AW-HDS-DDS, AW-HDS and HDS-DDS machines to get the
benefits of TempDB features for SQL Server. For more information about the SQL Server TempDBDatabase
and its use, see the Microsoft SQL Server documentation for TempDB Database.

This procedure applies to the Common Ground upgrade process only.Note
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Procedure

Step 1 Use Unified CCE Service Control to stop the Logger and Distributor services.
Step 2 Login to SQL Server Management Studio and run the following queries on the master database.

• To modify the existing TempDB Initial size to the recommended value:
ALTER DATABASE tempdb MODIFY FILE

(NAME = 'tempdev', SIZE = 800, FILEGROWTH = 100)
ALTER DATABASE tempdb MODIFY FILE

(NAME = 'templog', SIZE = 600, FILEGROWTH = 10%)

• To add multiple TempDB files:

USE [master];
GO
ALTER DATABASE [tempdb] ADD FILE (NAME = N'tempdev2', FILENAME = N'<SQL Server TempDB
path>' , SIZE = 800 , FILEGROWTH = 100);
ALTER DATABASE [tempdb] ADD FILE (NAME = N'tempdev3', FILENAME = N'<SQL Server TempDB
path>' , SIZE = 800 , FILEGROWTH = 100);
ALTER DATABASE [tempdb] ADD FILE (NAME = N'tempdev4', FILENAME = N'<SQL Server TempDB
path>' , SIZE = 800 , FILEGROWTH = 100);
GO

• For example,
<SQL Server TempDB path> = C:\Program Files\Microsoft SQL
Server\MSSQL12.MSSQLSERVER\MSSQL\DATA\tempdev2.ndf

• Make sure that you modify the values in the query based on the machines. For more
information, see Increase Database and Log File Size for TempDB, on page 22.

Note

Step 3 Restart the SQL Services.
Step 4 Start the Logger and Distributor services.

Performance Enhancement of Logger Database
Perform this procedure on Side A and Side B of the Logger database.

Procedure

Step 1 Use the Unified CCE Service Control to stop the Logger service.
Step 2 From the command prompt, run the RunFF.bat file which is located in the <ICM install

directory>:\icm\bin directory.
Step 3 Proceed with the application of fill factor to Unified ICM databases.

Note: Based on the size of the database, it takes several minutes to several hours to apply fill factor to the
database. For example, it takes anywhere between 2 to 3 hours for a 300-GB HDS. After the process is
completed, the log file is stored in <SystemDrive>:\temp\<DatabaseName>_Result.txt.

Step 4 Use the Unified CCE Service Control to start the Logger service.
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Troubleshooting Tips

See the RunFF.bat/help file for more information.

Performance Enhancement of AW-HDS Database

Procedure

Step 1 Use the Unified CCE Service Control to stop the Distributor service.
Step 2 From the command prompt, run the RunFF.bat file which is located in the <ICM install

directory>:\icm\bin directory.
Step 3 Proceed with the application of fill factor to Unified ICM databases.

Note: Based on the size of the database, it takes several minutes to several hours to apply fill factor to the
database. For example, it takes between 2 to 3 hours for a 300-GB HDS. After the process is completed, the
log file is stored in <SystemDrive>:\temp\<DatabaseName>_Result.txt.

Step 4 Use the Unified CCE Service Control to start the Distributor service.

Troubleshooting Tips

See the RunFF.bat/help file for more information.

Improve Reporting Performance
To improve the performance of the reporting application, modify the following Windows settings on the
database servers (AW-HDS, AW-HDS-DDS, HDS-DDS).

• Increase the Paging File Size to 1.5 times the server's memory.

To change the Paging File Size, from the Control Panel search for Virtual Memory. In the Virtual Memory
dialog box, selectCustom size. Set both Initial size andMaximum size to 1.5 times the server memory.

• Set the server's Power Options to High Performance.

From the Control Panel, select Power Options. By default, the Balanced plan is selected. Select Show
additional plans and select High performance.

In SQL Server, disable Auto Update Statistics for AW and HDS databases.

In the SQL Server Management Studio, right-click the database name in the Object Explorer and select
Properties. Select the Options page. In the Automatic section of the page, set Auto Create Statistics and
Auto Update Statistics to False.

Reduce Reserved Unused Space for HDS
Enable trace flag 692 on HDS database server to reduce the growth of reserved unused space on the AW-HDS,
AW-HDS-DDS, HDS-DDS database servers , after you upgrade or migrate toMicrosoft SQL 2017 . For more
information about the trace flag 692, see the Microsoft Documentation.
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Procedure

Run the following command to enable trace flag 692 on HDS database server :

DBCC TRACEON (692, -1);

GO

An increase in the unused space may lead to unexpected purge trigger in HDS , trace flag 692
helps in mitigating this unexpected purge issue. After you enable the trace flag, there will be an
increase of 10% to 15% CPU for a short duration.

Note

Update User Role
To update the User Role in the database for the existing users, do the following in any one of the AW
(distributor) machines:

• Go to the link https://software.cisco.com/download/home/268439622/type and select User Role Update
Bulk Tool from the list.

• Download the file UserRoleUpdateScript_1201.zip and extract it.

• Open Windows Powershell and run the script UserRoleUpdate.PS1.
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C H A P T E R 9
Technology Refresh Upgrade

• Preupgrade Overview, on page 239
• Technology Refresh Preupgrade Task flow, on page 240
• Technology Refresh Upgrade Task Flow, on page 241
• Technology Refresh Upgrade Tasks, on page 244

Preupgrade Overview
The preupgrade process ensures that your systems have the necessary software to support your contact center.
These tasks prepare the way for a successful upgrade of your Cisco contact center components to the new
release.

Preupgrade Tools

During the preupgrade process, use the following tools as required:

• User Migration Tool—A standalone Windows command-line application used for all upgrades that
involve a change of domain. The tool exports all existing user accounts (config/setup and supervisors)
from the source domain to a .bin file. The file is used in the target domain during the upgrade.

You can download the User Migration Tool from Cisco.com by clicking ICM User Migration Tool
Software.

• Regutil Tool—Used in Technology Refresh upgrades, the tool exports the Cisco Systems, Inc. registry
from the source machine during the preupgrade process. The output of the tool is required on the
destination machine when running the Unified CCE Installer during the upgrade process.

You can download the Regutil Tool from Cisco.com by clicking Contact Center Enterprise Tools.

• Cisco Unified Intelligent Contact Management Database Administration (ICMDBA) Tool—Used to
create new databases, modify or delete existing databases, and perform limited SQL Server configuration
tasks.

The ICMDBA Tool is delivered with the main installer.

• Domain Manager—Used to provision Active Directory.

The Domain Manager Tool is delivered with the main installer.
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• Upgrade.exe—Used to upgrade the schema of the logger, AW DB, HDS DB, and BA databases to a
version compatible with the current Unified CCE software version. It is typically used when the installer
fails to automatically upgrade the schema.

Perform the following steps to use the tool:

<ICM install directory>:\icm\bin>upgrade.exe -s <Server Name> -d
<Database name> -dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds" or "aw" or "ba", depending on the database that
requires the schema to be upgraded.

Technology Refresh Preupgrade Task flow

Disable Outbound Options High Availability (If Applicable)

Before you begin

If Outbound Options High Availability is enabled, you must disable it on source machines before you perform
the upgrade.

Before proceeding with the following steps, ensure that Outbound Options feature is in maintenance mode.
There must not be any customer records getting imported to Outbound database. The outbound campaigns
must not be active and outbound callflow must not be in progress.

Perform the following steps on Side A:

Procedure

Step 1 Launch Websetup. Navigate to Component Management > Loggers.
Step 2 Edit the Logger and navigate to Additional Options. Uncheck Enable High Availability under Outbound

Option. Enter the SQL Server Admin credentials and click Next.
Step 3 Enable Stop and then start(cycle) the Logger Service for this instance (if it is running) checkbox . Click

Next to complete the setup.
Step 4 Repeat similar steps (steps 1, 2, and 3) for side B.

What to do next

You can enable Outbound Options High Availability after the upgrade is successful.

Disable Configuration Changes
Perform this step on one side only. It is automatically replicated to the other side.
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Procedure

Step 1 To disable configuration changes during the upgrade, set the following registry key to 1 on the Side A Call
Router: HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<instance name>\Router
A\Router\CurrentVersion\Configuration\Global\DBMaintenance.

Step 2 Confirm that configuration changes are disabled by attempting to save a configuration change.

When you try to save the change, a message is displayed confirming the change failure.

Export the Server Registry
Export the Cisco registry on each source machine that is involved in a Technology Refresh upgrade.

During the upgrade process, you are prompted for the path to the exported registry file location. Perform the
following procedure and note the location of the resulting file for later in the upgrade process.

Each time you run the RegUtil with the export option, if a RegUtil_<hostname>.dat file exists, the utility
renames that file to RegUtil_<hostname>.dat.bak<number>.

Procedure

Step 1 Open a command prompt and change the directory to the location where the RegUtil.exe resides.
Step 2 Run the RegUtil tool to export the Cisco Systems, Inc. registry using the following command:RegUtil -export

[target directory] , for example, <ICM install directory>:\icm\bin>RegUtil -export C:\RegUtil

The target directory must have write access. Therefore, you cannot select the install media on a DVD. The
target directory is optional. If it is not specified, the tool outputs the result of the Registry export to the current
directory. The output filename is of the format RegUtil_<hostname>.dat, where hostname is the name of the
source machine.

Technology Refresh Upgrade Task Flow
For the Unified CCE core components, there is a general flow for redundant systems; Sides A and B are
brought down, upgraded, tested, and brought back up in sequence. That sequence ensures the operation of the
Cisco Contact Center during the entire upgrade process.

For coresident configurations, upgrade Finesse and ECE along with the CUIC/LiveData /IdS server upgrade.Note

For Technology Refresh upgrades, perform the following upgrade tasks:

SeeTask
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SeeTask

Identity Service/SSO

SSO is an optional feature and exchanges authentication and authorization details between an identity
provider (IdP) and an identity service (IdS).

For more information, see Unified CCE Contact Center Upgrade Flowcharts, on page 195

For IdS upgrade, refer to the same steps as documented in the upgrades section of Unified Intelligence
Center Installation and Upgrade Guide at:

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

Identity Service (IdS)
/Single Sign-On(SSO)

For ECE installation or upgrade instructions, see the Enterprise Chat and Email Installation and
Configuration Guide for Unified Contact Center Enterprise at https://www.cisco.com/c/en/us/support/
customer-collaboration/cisco-enterprise-chat-email/products-installation-guides-list.html

Upgrade Enterprise Chat
and Email (ECE)

Before you upgrade to Finesse 12.0, apply the ES11 patch on Cisco Unified Intelligence
Center 11.6 for the reporting gadgets to continue to work on the new Finesse desktop.

Note

For more information, see Cisco Finesse Installation and Upgrade Guide at

https://www.cisco.com/c/en/us/support/customer-collaboration/finesse/
products-installation-guides-list.html

ES69 provides the ability to connect a maximum of two versions of Finesse to the same
PG during the upgrade or migration process to facilitate the migration of agents and
supervisors to the new Finesse version. However, this mode of operation is not supported
for production use beyond the upgrade or migration phase.

Note

Upgrade Finesse

Cisco SocialMiner User Guide at

http://www.cisco.com/c/en/us/support/customer-collaboration/socialminer/
products-installation-guides-list.html.

Upgrade SocialMiner

Queuing and self-service components

Before you upgrade to Unified CVP 12.0, the ES84 patch has to be applied to Cisco VVB
11.6 in order to maintain compatibility between Unified CVP 12.0 and Cisco VVB 11.6.

Note

Installation and Upgrade Guide for Cisco Unified Customer Voice Portal at

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-customer-voice-portal/
products-installation-guides-list.html

Upgrade Cisco Unified
Customer Voice Portal8

Infrastructure and media resource components

Upgrade Voice and Data Gateways, on page 231Upgrade voice and data
gateways

Reporting server
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SeeTask

Installation and Upgrade Guide for Cisco Unified Intelligence Center at

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

Upgrade Cisco Unified
Intelligence Center server

Unified CCE Central Controller and Administration & Data Server components

Migrate the Logger Database and Upgrade the Logger, on page 245Bring down Side A
Logger, migrate Logger
database, and upgrade
Logger

Upgrade Unified CCE Call Router, on page 246Bring down Side A Call
Router, and upgrade

Migrate the HDS Database and Upgrade the Unified CCE Administration & Data Server, on page 247UpgradeAdministration&
Data Server connected to
Side A.

Bring Upgraded Side A into Service, on page 231Bring Side A Logger and
Call Router into service,
bring down Side B Logger
and Call Router

Migrate the Logger Database and Upgrade the Logger, on page 245Migrate Side B Logger
database and upgrade
Logger

Upgrade Unified CCE Call Router, on page 246Upgrade Side B Call
Router

Verify Operation of Upgraded Side B Call Router and Logger, on page 233Bring Side B Call Router
into service and verify
operation

Bring Side B Logger into
service and verify
operation.

Migrate the HDS Database and Upgrade the Unified CCE Administration & Data Server, on page 247UpgradeAdministration&
Data Server connected to
Side B.

Installation and Upgrade Guide for Cisco Unified Intelligence Center at

https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-installation-guides-list.html

Upgrade Cisco Unified
Intelligence Center
reporting templates

Upgrading Dual Sided Unified CCMP at

http://www.cisco.com/c/en/us/support/unified-communications/
unified-communications-manager-callmanager/products-installation-guides-list.html

Upgrade Cisco Unified
Contact Center
Management Portal
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SeeTask

Upgrade Unified CCE Administration Client, on page 251Upgrade Administration
Client

Database Performance Enhancement, on page 235Database Performance
Enhancement

Unified CCE Peripheral Gateways and associated components

Upgrade Peripheral Gateways, on page 250Upgrade PGs

Upgrade Outbound Option Dialer, on page 251UpgradeOutboundOption
Dialer

CTI OS System Manager Guide for Cisco Unified ICM at

https://www.cisco.com/c/en/us/support/customer-collaboration/computer-telephony-integration-option/
products-installation-guides-list.html

Upgrade CTI OS server

Desktop Client components

CTI OS System Manager Guide for Cisco Unified ICM at

https://www.cisco.com/c/en/us/support/customer-collaboration/computer-telephony-integration-option/
products-installation-guides-list.html

Upgrade CTI OS Agent
and Supervisor Desktops

Call Processing components

Upgrade Guide for Cisco Unified Communications Manager at https://www.cisco.com/c/en/us/support/
customer-collaboration/unified-contact-center-management-portal/
tsd-products-support-install-and-upgrade-technotes-list.html

Upgrade Cisco Unified
CommunicationsManager

Upgrade Cisco JTAPI Client on PG, on page 235(Install) the JTAPI client
on the Cisco Unified
CommunicationsManager
PG

Media Recording components

Installation and Administration Guide for Cisco MediaSense at

https://www.cisco.com/c/en/us/support/customer-collaboration/mediasense/
products-installation-guides-list.html

Upgrade MediaSense 9

8 If you are using Unified IP IVR for self-service and queuing, see Getting Started with Cisco Unified IP IVR.
9 UCCE 12.0 supports only Cisco MediaSense 11.5.

Technology Refresh Upgrade Tasks
The following section provides instructions about upgrading Unified CCE components. For instructions about
upgrading non-Unified CCE components in a Unified CCE solution, see the links to component-specific
documents in the Technology Refresh Upgrade Task Flow, on page 241.
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Migrate the Logger Database and Upgrade the Logger
To upgrade the Logger, do the following tasks:

• Migrate the Logger database.

• If you use Outbound Option High Availability, migrate the Outbound Option database.

• Install the new software.

Before you begin

• Create a shared folder in any desired location. Ensure that:

• In the Properties window > Sharing tab > Advanced Sharing, the Share this folder check box
is checked.

• In the Propertieswindow > Security tab >Advanced Sharing > Permission, the permission level
is set as Full control for the user group everyone.

If the user group everyone is not available, add it using the Add button.Note

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the Logger.
Step 2 Download the EDMT tool from Cisco.com, and ensure prerequisites for the same are installed on the

target/destination system, before launching EDMT. These include the ODBC Driver 11 for SQL Server, and
Visual C++ Redistributable for Visual Studio 2015.

Step 3 Run the EDMT from the server that will host the destination Logger and click Next.
Step 4 Select Technology Refresh and click Next.
Step 5 Under Source Database Connection, in the HostName\IP Address field, type the Source IP and click

Refresh Database List.
Step 6 Select the Logger Database name, and click Next.
Step 7 In the Windows Share Name field, type the name of the shared folder that you created.
Step 8 In the Windows Share Password field, type the password of the destination machine, and click Next.
Step 9 Review or change the information as required and click Start Migration.
Step 10 Exit the EDMT.

Set the TempDB AutoGrowth of Data files to 100 MB manually.Note

Step 11 (Optional) If Outbound Option High Availability is deployed, repeat steps 1 through 12 to migrate the BA
database.

Step 12 Launch the ICM-CCE-Installer and click Next.
Step 13 Select Technology Refresh and click Next.
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Step 14 Click Browse and specify the path for the RegUtil file you exported from the source machine during the
preupgrade process.

Step 15 To apply any Minor/Maintenance Release, click Browse and navigate to the Minor/Maintenance Release
software. Click Next.

Step 16 (Optional) Select SQL Server Security Hardening and click Next.
Step 17 Click OK on any informational messages that display.
Step 18 Click Install.
Step 19 Restart the server when the upgrade completes.
Step 20 Open the Web Setup tool from the desktop shortcut.
Step 21 Edit the instance as necessary.
Step 22 (Optional) In case of Cross Domain upgrade, launchWeb Setup, select instance and click onChange Domain

to use the new domain for destination Unified CCE.

Edit instance and you might need to change the facility or instance number if required.

Step 23 Edit the Logger component as necessary.

Edit the Logger component. In the Summary window, update the service account management section, with
a pre-existing domain user that the Logger service would run under.

If there are references to out-of-date network interface names or IP addresses for the public and private
networks for the Logger, update this information.

Ensure that the domain user is created in the new domain to perform the service operation of
Loggers and Administration & Data Servers component.

Note

Use the same domain user account for all the distributor and logger services. If you want to use
different domain accounts for the logger and the distributor, ensure that the distributor service
user account is added to the local logger UcceService groups on Side A and Side B.

Caution

Step 24 (Optional) If it's a Cross Domain upgrade, use the User Migration tool to import the users and OU information
which you exported from the source machine during the pre-upgrade process. See User Migration Tool in
Preupgrade Overview, on page 215.

Step 25 Use Unified CCE Service Control to set all Unified CCE services on the new Logger to Manual Start.

Upgrade Unified CCE Call Router
To upgrade the Call Router, do the following tasks:

• Import the Cisco registry information.

• Install the new software.

• Set up the new Call Router using the Web Setup tool.

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 Select Technology Refresh and click Next.
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Step 3 Click Browse and specify the path for the RegUtil file you exported from the source machine during the
preupgrade process.

Step 4 To apply the Unified ICMMinor/Maintenance Release, click Browse and navigate to the Minor/Maintenance
Release software. Click Next.

Step 5 Click OK on any informational messages that display.
Step 6 Click Install.
Step 7 Restart the server when the upgrade completes.
Step 8 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade

planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

Step 9 Open the Web Setup tool from the desktop shortcut.
Step 10 Edit the instance as necessary.

For a domain change, change the domain of the instance. Additionally, you might need to change the facility
or instance number as required.

Step 11 Edit the Call Router component as necessary.

If there are references to out-of-date network interfce names or IP addresses for the public and private networks
for the Router, update this information.

Step 12 Use Unified CCE Service Control to set all Unified CCE services on the new Call Router to Manual Start.

Migrate the HDS Database and Upgrade the Unified CCE Administration &
Data Server

To upgrade the Administration & Data Server, do the following tasks:

• Migrate the HDS database (if applicable. Non-HDS configurations do not require this action.)

• Import the Cisco registry information.

• Install the new software.

• Set up the new Administration & Data Server through the Web Setup tool.

The Installer upgrades the AW database that is associated with the Administration & Data server. The EDMT
does not upgrade the AW database.

Before you begin

• Create a shared folder in any desired location. Ensure that:

• In the Properties window > Sharing tab > Advanced Sharing, the Share this folder check box
is checked.

• In the Propertieswindow > Security tab >Advanced Sharing > Permission, the permission level
is set as Full control for the user group everyone.
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If the user group everyone is not available, add it using the Add button.Note

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE services on the server.
Step 2 Download the EDMT tool from Cisco.com, and ensure pre-requisites for the same have been installed on the

target/destination system, prior to launching EDMT. These include the ODBC Driver 11 for SQL Server, and
Visual C++ Redistributable for Visual Studio 2015.

Step 3 Launch the EDMT tool on the destination server that hosts the Administration and Data Server with HDS
database and click Next. For non-HDS Server configurations, skip to step 11.

Step 4 Select Technology Refresh and click Next.
Step 5 Under Source Database Connection, in the HostName\IP Address field, type the Source IP, and click

Refresh Database List.
Step 6 UnderDestination Database Connection, in the SQL Server Port Number field, enter the destination SQL

server port number, and then click Next.
Step 7 Select the HDS Database name, and click Next.
Step 8 In the Windows Share Name field, type the name of the shared folder that you created.
Step 9 In the Windows Share Password field, type the password of the destination machine, and click Next.
Step 10 Review or change the information as required, highlight the HDS database, and click Start Migration.
Step 11 Exit the EDMT.

Set the TempDB AutoGrowth of Data files to 100 MB manually.Note

Step 12 Launch the ICM-CCE-Installer and click Next.
Step 13 Select Technology Refresh and click Next.
Step 14 Click Browse and specify the path for the RegUtil file you exported from the source machine during the

preupgrade process.
Step 15 To apply the Unified ICMMinor/Maintenance Release, click Browse and navigate to the Minor/Maintenance

Release software. Click Next.
Step 16 (Optional) Select SQL Server Security Hardening and click Next.
Step 17 Click OK on any informational messages that display.
Step 18 Click Install.
Step 19 Restart the server when the upgrade completes.
Step 20 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade

planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

Step 21 Open the Web Setup tool from the desktop shortcut.
Step 22 Edit the instance as necessary.
Step 23 (Optional) In case of Cross Domain upgrade, launch Websetup, select the instance and click on Change

Domain in order to use the new domain for destination Unified CCE.
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Edit the instance. You might need to change the facility or instance number if required.

Step 24 Edit the Administration & Data Server component as necessary and in the Summary window, update the
Service Account manager with the domain user to perform the service operation.

If there are references to out-of-date network interface names or IP addresses for the public and private
networks for the Logger, update this information.

Ensure that the domain user is created in the new domain to perform the service operation of
Loggers and Administration & Data Servers component.

Note

Use the same domain user account for all the distributor and logger services. If you want to use
different domain accounts for the logger and the distributor, ensure that the distributor service
user account is added to the local logger UcceService groups on Side A and Side B.

Caution

For more information about configuring permissions in your local machine, see Configure Permissions in the
Local Machine, on page 90.

Step 25 Use Unified CCE Service Control to set all Unified CCE services on the new Administration & Data Server
to Manual Start.

Step 26 Start the Unified CCE services for Logger and Router on both Side A and Side B. Also, start the Distributor
service for the all sites. Then, launch the Configuration Manager tool to check if it is working fine.

The time required to complete a data migration varies in a direct relationship to the database size
(the larger the database size, the longer it takes to migrate) and the server hardware performance
level.

Note

If Outbound Options High Availability was disabled on source machines prior to the upgrade,
you can enable it on Side A and Side BDestination machines if both the sides have been migrated
successfully.

Note

Synchronizing or Updating Configuration and Historical Data from Production
Server to Staged Server During Cut Over

The EDMT tool can also be used to migrate data from a Logger or HDS production server, to the one that has
already been staged on version 12.0 (1) . These two pronged upgrade steps are typically performed to reduce
the downtime needed during cut-over to the new version.

While the parallel 12.0(1) systems are staged and tested, the 11.0(x)/11.5(x)/11.6(x) production servers
continue to process calls. On the day of the cut-over, the data in the 12.0 (1) staged servers, can be updated
or synchronized with that of the production server, by running the EDMT tool, for each of the Logger and
HDS database.

This will synchronize the database with 12.5(1) schema. However, due to the 12.6(1) database schema version
being different from its base 12.5(1) version, the synchronized database will be incompatible with 12.6(1).
The administrator would have to manually use upgrade.exe utility to upgrade the database schema before
starting the CCE Logger or Distributor service.

The utility is present in the icm\bin folder, and needs to be run against each of the database that was updated
/ synchronized from the production server.

Perform the following steps to use the tool:
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<Install Drive>: \icm\bin>upgrade.exe -s <Server Name> -d <Database name>
-dt <Database Type> -i <Instance Name>

Where

<Database Type> - can be either " logger" or "hds", depending on the database that requires the schema to
be upgraded.

For Example C:\icm\bin>upgrade -s PRGR-A -d abc_sideA -dt logger -i abc

# - The value as stored in columns Major,CCMinor, and AWMinor of Version table in the CCE database.

Upgrade Peripheral Gateways
You can upgrade different Peripheral Gateways (PG) within a contact center at different times within different
maintenance windows. However, upgrade all PGs that reside on the same virtual machine and redundant PGs
(Side A and corresponding Side B) during the same maintenance window.

The following dependencies occur when upgrading the Unified Communications Manager PG:

• If your contact center uses the CTI OS component, upgrade the CTI OS server at the same time as the
associated Unified Communications Manager PG.

• If your contact center uses Outbound Option, upgrade any Outbound Option Dialers associated with
Unified Communications Manager PGs at the same time.

• If the Unified Communications Manager application is upgraded, upgrade the JTAPI client associated
with the Unified Communications Manager PG at the same time.

Procedure

Step 1 Use Unified CCE Service Control to stop all Unified CCE and CTI OS (if applicable when upgrading the
Unified Communications Manager PG) services on the PG server. Change the services to Manual Start.

Step 2 Launch the ICM-CCE-Installer and click Next.
Step 3 (Optional) To apply the Unified ICM MinorMinor/Maintenance Release, click Browse and navigate to the

Minor Minor/Maintenance Release software. Click Next.
Step 4 Select Technology Refresh and click Next.
Step 5 Click Browse and specify the path for the RegUtil file you exported from the source machine during the

preupgrade process.

The registry information for the Unified Communications Manager PG also contains information for the CTI
OS server (if applicable).

Step 6 Click OK on any informational messages that display.
Step 7 Click Install.
Step 8 Reboot the system after the upgrade completes.
Step 9 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade

planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).
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Step 10 After reboot, open the Peripheral Gateway Setup tool from the desktop shortcut and make any necessary
changes. See the "Install" section of this document for specific information.

If there are references to out-of-date network interface names or IP addresses for the public and private
networks for the Logger, update this information.

Step 11 Open the Peripheral Gateway Setup tool from the Installer dialog box or desktop shortcut and edit the Dialer
as required.

Step 12 Use Unified CCE Service Control to set all Unified CCE services to Automatic Start.

Upgrade Outbound Option Dialer
To upgrade the Outbound Option Dialer, import the Cisco registry information, install the new software, and
set up the new Dialer using the PG Setup tool.

Before you begin

You must have previously migrated the Outbound Option database during the Logger upgrade.

Procedure

Step 1 Launch the ICM-CCE-Installer and click Next.
Step 2 (Optional) To apply any Maintenance Releases, click Browse and navigate to the Maintenance Release

software. Click Next.
Step 3 Select Technology Refresh and click Next.
Step 4 Click Browse and specify the path for the RegUtil file you exported from the source machine during the

preupgrade process.
Step 5 Click OK on any informational messages that display.
Step 6 Click Install.
Step 7 Reboot the system after the upgrade completes.
Step 8 Run the mandatory update before applying any ES, if you have a fresh install or Technology Refresh upgrade

planned for PCCE or UCCE 12.0(1), on the Windows Server 2016. You can download the CCE 12.0
Mandatory Update for Fresh Install/Tech Refresh from
https://software.cisco.com/download/home/268439622/type/280840583/release/12.0(1).

Step 9 Open the Peripheral Gateway Setup tool from the Installer dialog box or desktop shortcut and edit the Dialer
as required.

Step 10 Use Unified CCE Service Control to set all Unified CCE services to Automatic Start.

Upgrade Unified CCE Administration Client
There is no support for Administration Clients to be upgraded via Technology Refresh upgrade. Either perform
an in-place common ground upgrade of Administration Clients, and make edits as necessary using the
Administration Client setup, or perform a fresh installation of Administration Client on a new system.
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C H A P T E R 10
Upgrade from a Standalone Deployment to a
Coresident Deployment (Cisco Unified
Intelligence Center with Live Data and IdS)

• Set Deployment Type in Unified CCE Administration Configuration, on page 253
• Install and Upgrade COP File, on page 254
• Install Publisher/Primary Nodes of VOS-Based Contact Center Applications, on page 254
• Install Subscribers/Secondary Nodes of VOS-Based Contact Center Applications, on page 256
• Set Up the System Inventory, on page 257
• Configure Live Data with AW, on page 258
• Configure Live Data Unified Intelligence Center Data Sources, on page 259
• Restart Live Data, on page 259

Set Deployment Type in Unified CCE Administration
Configuration

Ensure that the deployment type has been set to UCCE: 2000 Agents Rogger via CCE Web Administration
tool.

Perform the following steps to set the deployment:

Procedure

Step 1 On Administration & Data Server open the Unified CCE Tools folder.
Step 2 Go to Administration Tools > CCE Web Administration.

Step 3 Log in as a Config security group member in the user@domain.
Step 4 Double-click Unified CCE Administration.
Step 5 Go to Infrastructure Settings > Deployment Settings.
Step 6 On the Deployment Type page, select UCCE: 2000 Agents Rogger deployment from the drop-down list

and then click Next.
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Whenever you change the deployment type, you need to restart the Apache Tomcat on Logger
and AWs.

Note

Install and Upgrade COP File
Before upgrading a standalone deployment to a coresident UCCE:2000 Agents deployment (CUIC with Live
Data and IdS), perform the following steps:

Procedure

Step 1 Install the COP file:

• To upgrade from UCCE 11.0(1) to 12.0:

a. In case of "UCCE 2000 Agents Rogger model, install co-resident deployment COP
"ciscocuic.cce2k-cores-deployment.cop.sgn" on CUICVM to get the benefits of Coresident of CUIC,
LD and IDS

b. Upgrade CUIC 11.0(1) to CUIC 12.0:

For detailed steps on installing and upgrading COP files, see https://www.cisco.com/c/en/us/td/docs/voice_
ip_comm/cust_contact/contact_center/intelligence_suite/intelligence_suite_1105/install/gudie/CUIC_BK_
IF498FAF_00_installation-and-upgrade-guide-for/CUIC_BK_IF498FAF_00_
installation-and-upgrade-guide-for_chapter_01000.html?bookSearch=true#task_
E972191E3AB1E59C20C9B653359792B9.

Step 2 Delete the standalone Live Data virtual machine after you have upgraded the standalone deployment to a
coresident deployment.

Install Publisher/Primary Nodes of VOS-Based Contact Center
Applications

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, Cisco Finesse and Cisco Identity Service (IdS). To configure DNS, add the VMs to the
forward and reverse lookups of the DNS.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
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Step 3 Select the virtual machine, power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center with
Live Data and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

d) In the Proceed with Install screen, select Yes.
e) In the Platform Installation Wizard screen, select Proceed.
f) In the Apply Patch screen, select No.
g) In the Basic Install screen, select Continue.
h) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note

i) In the Auto Negotiation Configuration screen, select Continue.
j) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
k) In the DHCP Configuration screen, select No.
l) In the Static Network Configuration screen, enter static configuration values. Select OK.
m) In the DNS Client Configuration screen, click Yes to enable DNS client.
n) Enter your DNS client configuration. Select OK.
o) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
p) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
q) In the First Node Configuration screen, select Yes.
r) In the Network Time Protocol Client Configuration screen, enter a valid NTP server IP address and

select OK.
s) In the Security Configuration screen, enter the security password and select OK.
t) In the SMTP Host Configuration screen, select No.
u) In the Application User Configuration screen, enter the application username. Enter, and confirm the

application user password. Select OK.
v) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 5 Unmount the ISO image.
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Install Subscribers/Secondary Nodes of VOS-Based Contact
Center Applications

This task is required for installation of the subscriber/secondary nodes of the three VOS-based contact center
applications: Cisco Finesse, Cisco Unified Communications Manager, and Cisco Unified Intelligence Center.

Note

Before you begin

DNS Configuration is mandatory for installation of Cisco Unified Communications Manager, Cisco Unified
Intelligence Center, and Cisco Finesse. To configure DNS, add the VMs to the forward and reverse lookups
of the DNS.

Before you install the subscriber/secondary nodes, youmust install the publisher/primary nodes and configure
the clusters.

Procedure

Step 1 Create a virtual machine for your VOS-based contact center application using the OVA.
Step 2 Mount the ISO image for the software to the virtual machine.
Step 3 Select the virtual machine and power it on, and open the console.
Step 4 Follow the Install wizard, making selections as follows:

a) In the Disk Found screen, click OK to begin the verification of the media integrity.
b) In the Success screen, select OK.
c) In the Product Deployment Selection screen:

• For the Progger (Lab only) or 2000 agent reference design, choose the coresident deployment option
Cisco Unified Intelligence Center with Live Data and IdS, and then selectOK. TheCisco Unified
Intelligence Center with Live Data and IdS option installs Cisco Unified Intelligence Center, Live
Data, and Cisco Identity Service (IdS) on the same server.

• For all other deployments, select one of the standalone install options. For example, select Cisco
Unified Intelligence Center, Live Data, or Cisco Identity Service (IdS). Then select OK.

Step 5 Follow the Install wizard, making selections as follows:
a) In the Proceed with Install screen, select Yes.
b) In the Platform Installation Wizard screen, select Proceed.
c) In the Apply Patch screen, select No.
d) In the Basic Install screen, select Continue.
e) In the Timezone Configuration screen, use the down arrow to choose the local time zone that most

closely matches where your server is located. Select OK.

For Live Data servers, use the same timezone for all the nodes.Note
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f) In the Auto Negotiation Configuration screen, select Continue.
g) In the MTU Configuration screen, select No to keep the default setting for Maximum Transmission

Units.
h) In the DHCP Configuration screen, select No.
i) In the Static Network Configuration screen, enter static configuration values. Select OK.
j) In the DNS Client Configuration screen, click Yes to enable DNS client.
k) In the Administrator Login Configuration screen, enter the Platform administration username. Enter

and confirm the password for the administrator. Select OK.
l) In theCertificate Information screen, enter data to create your Certificate Signing Request: Organization,

Unit, Location, State, and Country. Select OK.
m) In the First Node Configuration screen, select No.
n) In the warning screen, select OK.
o) In the Network Connectivity Test Configuration screen, select No.
p) In the First Node Access Configuration screen, enter the host name and IP address of the first node.

Enter and confirm the security password. Select OK.
q) In the SMTP Host Configuration screen, select No.
r) In the Platform Configuration Confirmation screen, select OK. The installation begins and runs

unattended.

• There is a reboot in the middle of the installation.

• The installation ends at a sign-in prompt.

Step 6 Unmount the ISO image.

Set Up the System Inventory
Procedure

Step 1 In Unified CCE Administration, navigate to Infrastructure Settings > Inventory .
Step 2 Add the new machine to the System Inventory:

a) Click New.

The Add Machine popup window opens.

b) From the Type drop-down menu, select the following machine type:

CUIC_LD_IdS Publisher, for the coresident Unified Intelligence Center, Live Data, and Identity Service
machine available in the 2000 agent reference design.

c) In the Address field, enter the FQDN or IP address of the machine.
d) Enter the machine's Administration credentials.
e) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.
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Configure Live Data with AW
This command tells Live Data how to access the primary AW DB and the secondary AW DB. The command
also automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want the test performed. When you include the
skip-test parameter, no checking is done to see if the configured user has appropriate AW DB access, and no
results are reported.

You do not need to configure the AW DB on both the Publisher and the Subscriber. The configuration is
replicated between the Publisher and the Subscriber.

Note

Before you begin

Before you can configure Live Data, you must first configure a SQL user (with special permissions) to work
with Live Data, as described in Configure SQL User Account, on page 132.

The SQL administrative user "sa" or a user with sysadmin privileges must then execute the following SQL
queries for the SQL user configured to work with Live Data.
USE master
GO
GRANT CONTROL ON CERTIFICATE :: UCCESymmetricKeyCertificate TO "<user>"
GRANT VIEW DEFINITION ON SYMMETRIC KEY :: UCCESymmetricKey TO "<user>"

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure Live Data with the primary AW DB. The command automatically

tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed).

set live-data aw-access primary addr port db user [skip-test]

Step 3 Run the following command to configure Live Data with the secondary AWDB. The command automatically
tests the connection from Live Data, checks the user permission, and displays results.

(The skip-test parameter is optional; include it only if you do not want the test performed).

(The skip-test parameter is optional; include it only if you do not want the test performed).

show live-data aw-access [skip-test]
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Configure Live Data Unified Intelligence Center Data Sources
This command tells Unified Intelligence Center how to access Live Data.

Procedure

Step 1 Log in to your Live Data server.
Step 2 Run the following command to configure your Live Data Unified Intelligence Center data sources:

set live-data cuic-datasource cuic-addr cuic-port cuic-user

Restart Live Data
After you complete the configuration procedures for the AW and the Unified Intelligence Center data source,
restart the Live Data system to enable the changes.

Procedure

Access the Live Data CLI and run the following command:
utils system restart
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C H A P T E R 11
Uninstall Unified CCE Release 12.0(1)

• Uninstallation of Unified ICM/CCE base version 12.5(1), on page 261

Uninstallation of Unified ICM/CCE base version 12.5(1)
Uninstallation of Unified ICM/CCE base of 12.0 is not supported for Unified CCE components that are
deployed on Windows Server using the ICM-CCE-Installer. However, support for uninstallation and
re-installation of client installer packages like Administration Client and Internet Script Editor continues.

The option to roll back to previous versions is only available with minor and maintenance releases.Note
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C H A P T E R 12
Testing

• Testing Overview, on page 263
• Testing Tasks, on page 263

Testing Overview
System testing is a part of the installation, upgrade, and ongoing maintenance of a Unified CCE solution.
Testing requirements and processes vary from customer to customer. Therefore, specific steps for executing
tests are not included in this document.

For installations, testing must ensure all aspects of contact center operation before going live.

For upgrades, at the beginning of each maintenance window, consider running preupgrade tests to establish
a benchmark. The benchmark is used when you run the postupgrade tests. Postupgrade tests are necessary for
each maintenance window to ensure continued contact center operation throughout the entire upgrade process,
which can span multiple maintenance windows.

If you require assistance with Unified CCE solution testing, work with your Cisco representative.

Contact centers need established tests plans and processes for all aspects of contact center operation. Have
the plans, tools, and processes in place to test your contact center.

Testing Tasks

Verify Upgrade to Cisco Unified Customer Voice Portal
After upgrading Unified CVP, verify the following:

Procedure

Step 1 Verify that error messages did not display during the upgrade process.
Step 2 Check the upgrade logs for error messages.
Step 3 Ensure that the Unified CVPOperations, Administration,Monitoring and Provisioning (OAMP)Web interface

is available for use.
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Step 4 Use the diagnostic page at http://<CVPHOST>:8000/cvp/diag to verify the status of the Unified CVP system.
Step 5 Use the Operations Console (System > Control Center, Device Pool tab) to verify that the upgraded Unified

CVP Call Servers, Unified CVP VXML Server and Unified CVP Reporting Server show a status of “Up”.
Step 6 Use the Operations Console (Device Management >Unified CVP Call Server, General tab for selected Call

Server) to verify that the Device Version reflects the correct upgraded version.
Step 7 Verify that the appropriate voice prompt is heard when the call is made.
Step 8 Ensure that the Unified CVP license is properly installed.

Verify IOS Gateway Upgrade
After upgrading IOS gateways, verify the following:

Procedure

Step 1 At the Cisco IOS exec level, execute the following CLI commands:

• To check that the upgraded IOS target image is running:

show version

• To verify that the boot system is configured to boot the correct image:

show running-config

• To verify that configuration done previously is not lost:

show running-config

• To verify that the ISDN connection status is at MULTIFRAME_ESTABLISHED:

show isdn status

• To verify that configured interfaces are in up/up state:

show ip interface brief

• To verify manually placed incoming calls:

show isdn history

• To verify IP routing from branch site to a data center:

ping or traceroute

• To verify IP routing from one branch site to another branch site:

ping or traceroute

Step 2 Ensure that the following devices are configured and registered correctly: Gatekeeper, trunks, and CTI Route
Point.

Step 3 Ensure that all MGCP end points (FXS, FXO, PRI, T1 CAS and BRI) are properly registered with Unified
Communications Manager.

Step 4 Manually spot check calls as appropriate from the PSTN vis SIP Gateways.
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Step 5 Verify that a PSTN user who places an inbound call from the PSTN to a Unified IP Phone in a Unified
CommunicationsManager cluster through gateways and puts the call on hold can hearMusic-on-Hold (MOH)
and can also finally resume the call.

Verify Upgrade to Cisco IOS-Based Transcoders and Conference Bridges
After upgrading Cisco IOS-based transcoders and conference bridges, verify the following:

Procedure

Step 1 Check if the complete configuration before the upgrade still exists.
Step 2 Check if all DSPs are registered and are functioning normally.
Step 3 Check if there are no error messages in the buffer log or console.
Step 4 Check if no dump file is created in the flash memory.
Step 5 To verify that the configuration is not lost, type the “show running-config” command.
Step 6 To verify that the interfaces are in up state, type the “show ip interface brief” command.
Step 7 Verify IOS Transcoding is working with G711 codec configure for one device while G729 codec is configured

on another device.

Verify Upgrade to Cisco Unified CCE Router and Logger
After upgrading the Cisco Unified CCE Router and Logger, verify the following:

Procedure

Step 1 Verify basic operations such as the following:

• Setup logs indicate no errors or failure conditions (icmsetup.txt and ICMInstall.txt, located in the \Temp
directory of the disk on which the application was installed).

• All components can “ping” public and private IP addresses as applicable.
• Schema upgrade is successful for all databases and there is no loss of data integrity or data.
• All component services start correctly without generating errors.
• Firewalls and other security measures do not block the ability to access Microsoft SQL Server and to
run third-party software components, like VNC or PCAnywhere.

• Ccagent is in service and connected to any Peripheral Gateways located in Side A.
• Recovery process not required, no activity other than process start-up.
• Configuration information is passed to the Router by the Logger. Replication process begins when the
Historical Database Server comes online.

• Replication process begins with no errors. (Use the Windows Event Viewer to view Windows Event
logs).

• The Router is in a synchronized state. (Use the Diagnostic Framework Portico, under ListProcesses,
verify that the status of ccagent and mdsproc is "InSvc".)
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• Database space allocation and % used are reported correctly. (Use the dumplog utility to view the hlgr
and rcv processes on the Logger server. The trace messages display the percentage of available free space
and the log space of the database at 30-second intervals. Verify this using Microsoft SQL Management
Studio to view the Logger database properties.)

Step 2 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 3 Verify that configuration changes can be made and are passed to the Logger and AW databases.
Step 4 Ensure that basic calls and call functionality such as transfers, conferences, call treatment and queuing are

working properly.

Verify Upgrade to Cisco Real Time Administration Workstation, Historical
Database Server

After upgrading the Real Time AW/HDS software, verify the following:

Procedure

Step 1 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 2 After Side A Central Controller components have been upgraded, verify basic operations such as the following:

• Setup logs indicate no errors or failure conditions (icmsetup.txt and ICMInstall.txt located in the \Temp
directory of the disk on which the application was installed).

• All components can “ping” public and private IP addresses as applicable.
• Schema upgrade is successful for all databases and there is no loss of data integrity or data.
• All component services start correctly without generating errors.
• All general activities such as the ability to access SQL server and to run third-party software components
like VNC or PCAnywhere, etc. are not stopped by any security application.

• Rtsvr, the process that provides real time data from the Router to the AW database, is connected to the
primary Administrative Workstation. (Open the Configuration Manager tool on Administration & Data
server. If the tool opens without any errors, the feed is active. Additionally, use the Dumplog utility to
view the uaw process. The uaw trace message shows "Waiting for new work…".)

• Configuration information is passed to the router by the Logger. Replication process begins when the
Historical Database Server comes online.

• Real Time Administrative Workstation indicates that it is ready.
• Replication process begins with no errors. (use the Windows Event Viewer to view Windows Event
logs).

• Authorized users are able to use the ConfigurationManager on the Real TimeAdministrativeWorkstation.
• Authorized users are able to log into Cisco Unified Intelligence Center and can access both public and
private reports and that all previously existing reports are still available.

• Previous settings for users are still valid when any application is opened.
• The “Validate All” script yields the same results after the upgrade as prior to the upgrade.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
266

Testing
Verify Upgrade to Cisco Real Time Administration Workstation, Historical Database Server



All existing scripts can be opened and edited and new scripts can be created.Note

• Database space allocation and % used are reported correctly. (Use the dumplog utility to view the hlgr
and rcv processes on the Logger server. The trace messages display the percentage of available free space
and the log space of the database at 30 second intervals. Verify this using Microsoft SQL Management
Studio to view the Logger database properties.)

• Diagnostic Framework Portico can acquire logs, capture registry information, and schedule collection
of logs.

• Verify that configuration changes are possible.

Verify Upgrade to Peripheral Gateways
After upgrading the peripheral gateways, verify the following:

Procedure

Step 1 Use the Windows Event Viewer on each server to check that no exceptions, errors, or unexpected events have
occurred. Select Administrative Tools > Event Viewer, then expand Windows Logs and review the
Application and System logs.

Step 2 Ensure that real time and historical data is sent to the Router and AW database.
Step 3 Ensure that basic calls and call functionality (such as transfers, conferences, call treatment and queuing) are

working properly.
Step 4 Ensure that the peripheral is running properly on the upgraded gateway by verifying call flows, CTI desktops,

Outbound Option, and other applications.

Verify Redundancy
After you upgrade both sides of all redundant components, verify the following:

Procedure

Step 1 Stop each active component.
Step 2 Ensure that the backup component assumes an active state and that the system operation switches to the backup

component with no loss of functionality.

Verify Upgrade to Cisco Unified Communications Manager
After upgrading Unified Communications Manager, verify the following:

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
267

Testing
Verify Upgrade to Peripheral Gateways



Procedure

Step 1 Verify that no error messages have occurred during the upgrade process.
Step 2 Check the upgrade log file for any errors.
Step 3 Start all first node and subsequent node servers.
Step 4 Verify that there is no replication failure between the first node and subsequent node servers.
Step 5 Verify that SIP and SCCP IP Phones are registered with Unified Communications Manager.
Step 6 Ensure that the following devices are configured correctly: gatekeeper, trunks, and CTI route points.
Step 7 Ensure that the media resources (conference bridges, MTP and transcoders) are configured correctly by

checking their status.
Step 8 Verify if the end users are able to connect to their CTI managers.
Step 9 Check if the license usage is correct as reported in the License Unit Report.
Step 10 Check if services on all servers in the cluster are up.
Step 11 Perform the Unified Communications Manager first node and subsequent node process verification using the

following Real Time Monitoring Tool feature verification process:
a) Verify if Multiple Route Patterns and Route Lists are configured and working properly.
b) Verify if Extension Mobility is configured and working properly.
c) Verify if Unified IP Phone Services are configured and working properly.
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A P P E N D I X A
CLI Commands during Installation and Upgrade

• Live Data CLI Commands, on page 269
• Transport Layer Security CLI Commands, on page 280

Live Data CLI Commands

Supported Character Set for Live Data Installation CLI Commands
When working with the CLI (and not exclusively for Live Data), you can use plain alphanumeric characters
[0-9] [A-Z] [a-z] and the following additional characters:

• ". " (dot)

• "!" (exclamation mark)

• "@" (at sign)

• "#" (number sign)

• "$" (dollar)

• "%" (percent)

• "^" (caret)

• "*" (star)

• "_" (underscore)

• "+" (plus sign)

• "=" (equal sign)

• "~" (tilde)

• ":" (colon)

• "(" and ")" (open and close parentheses)

• "{" and "}" (open and close brackets)

• "[" and "]" (open and close square brackets)
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Spaces are used as input separators.Most special characters carry specific meaning to the Cisco Voice Operating
System (VOS) command console (for example, "\", "|", and so on). Characters above standard ASCII are
mostly ignored.

Privilege Levels for Live Data Commands
The Live Data CLI commands support the following privilege levels:

• Ordinary

• Advanced

Each Live Data command has a required privilege level related to the sensitivity of data it exposes or its ability
to severely affect the operation of the application. The privilege level for each command is the minimum level
required; a user with a higher privilege level also has access to the command.

The Cisco Voice Operating System (VOS) also supports a higher privilege level for the administrative user;
this user is configured at installation. When the administrative user creates other users (with the set account
name command), the administrative user sets each newly created user's privilege level. (For more information
about the set account command, see the Administration Console User Guide for Cisco Unified Intelligence
Center at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html. )

Live Data AW DB Access

The Live Data AW DB access commands allow you to configure and display CCE AW DB (real-time
distributor) access for the Contact Center Enterprise Live Data Product Deployment Selection. By default,
the set and show commands also test the connection from Live Data to the primary or secondary AWdatabase,
check to see if the configured user has appropriate AW DB access, and report the results.

set live-data aw-access
Required Minimum Privilege Level: Advanced

Use this command to set the access information to the primary or secondary CCE AW. The command also
automatically tests the connection from Live Data to the primary or secondary AW, checks to see if the
configured user has appropriate AW DB access, and reports the results.

You can use the optional skip-test parameter if you do not want the test performed. No checking is done to
see if the configured user has appropriate AW DB access, and no results are reported.

Command Syntax
set live-data aw-access {primary | secondary} addr port db user [skip-test]
addr

Specifies the hostname or IP address of the primary or secondary CCE AW (maximum 255 characters).

port

Specifies the listening port of the database server (range 1 through 65535).

db

Specifies the database name (maximum 128 characters).

user
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Specifies the login user (maximum128 characters).

skip-test

Skips the testing of the connection from Live Data to the primary or secondary AW. No checking is done to
see if the configured user has appropriate AWDB access, and no results are reported. The skip-test parameter
is optional.

Command Default When you execute this command, it prompts you to specify the login password (maximum 128 characters)
to use for authentication with AW database access.

unset live-data aw-access
Required Minimum Privilege Level: Advanced

Use this command to unset the access information to the primary or secondary CCE AW DB.

Command Syntax
unset live-data aw-access {primary | secondary}

There is a single, required parameter with two possible values.

show live-data aw-access
Required Minimum Privilege Level: Ordinary

Use this command to display the primary and secondary CCE AW DB access information and test the
connection from Live Data to each AWDB, check to see if the configured user (on each node) has appropriate
AW DB access, and report the results.

You can use the optional skip-test parameter if you do not want the test performed. No checking is done to
see if the configured user (on each node) has appropriate AW DB access, and no results are reported.

Command Syntax
show live-data aw-access [skip-test]

Shows the configured primary and secondary CCE AW DB access information. There are no required
parameters.

skip-test

Skips the testing of the connection from Live Data to the primary or secondary AW. No checking is done to
see if the configured user (on each node) has appropriate AW DB access, and no results are reported. The
skip-test parameter is optional.

Live Data Cluster Configuration
Use the following commands to set, unset, or show Live Data cluster configuration information.

set live-data secondary
Required Minimum Privilege Level: Advanced

Use this command to register the Live Data secondary node.

Command Syntax
set live-data secondary name

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
271

CLI Commands during Installation and Upgrade
unset live-data aw-access



name

Specifies the hostname or ip address of the Live Data secondary node.

unset live-data secondary
Required Minimum Privilege Level: Advanced

Use this command to unset Live Data secondary node configuration.

unset live-data secondary

There are no required parameters.

show live-data secondary
Required Minimum Privilege Level: Ordinary

Use this command to show Live Data secondary node configuration information.

show live-data secondary

There are no required parameters.

Live Data CORS Configuration
Live Data CORS commands allow you to configure CORS and hence allow web applications running on
different origins to communicate with Live Data.

Live Data CORS commands are available only after installing Cisco Unified Intelligence Center Release
11.6(1) ES18 or later in Unified CCE 11.6 release and Cisco Unified Intelligence Center Release 12.0(1)
ES06 or later in Unified CCE 12.0 release respectively.

Ensure that the CORS update commands are run on all the live data nodes in the cluster.

After you make changes to the CORS status, allowed origins, allowed headers, or exposed headers, restart
the Unified CCE Live Data NGINX service.

Note

utils live-data cors status

Required Minimum Privilege Level: Ordinary

Use this command to query the Live Data CORS status.

Command Syntax
utils live-data cors status

There are no required parameters.
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utils live-data cors enable

Required Minimum Privilege Level: Advanced

Use this command to enable CORS in Live Data.

Command Syntax
utils live-data cors enable

There are no required parameters.

For Unified Intelligence Centre gadgets (Live Data) to load in Cisco Finesse, ensure to:

• Enable CORS using utils cuic cors enable and utils live-data cors enable commands.

• Set the Finesse host URL in utils cuic cors allowed_origin add URLs and utils live-data cors

allowed_origin add URLs commands.

Examples:

• https://<finesse-FQDN>

• https://<finesse-FQDN>:port

Note

utils live-data cors disable

Required Minimum Privilege Level: Advanced

Use this command to disable CORS in Live Data.

Command Syntax
utils live-data cors disable

There are no required parameters.

utils live-data cors allowed_origin list

Required Minimum Privilege Level: Ordinary

Use this command to display the list of allowed URLS that can make CORS request to Live Data.

Command Syntax
utils live-data cors allowed_origin list

There are no required parameters.

utils live-data cors allowed_origin add

Required Minimum Privilege Level: Advanced

Use this command to add the given list of URLs to the allowed origin list.
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Command Syntax
utils live-data cors allowed_origin add URLs

URLs

Comma separated list of URLs (without spaces) that has to be added to the allowed origins list. The URL
should be of the format: http[s]://<hostname>[:port]

utils live-data cors allowed_origin delete

Required Minimum Privilege Level: Advanced

Use this command to delete a particular URL entry or all the URL entries from the allowed origins list.

Command Syntax
utils live-data cors allowed_origin delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
URL entries from allowed origins list.

Example

Utils live-data cors allowed_origin delete

1. https://cisco.com

2. https://google.com

a: all

q: quit

utils live-data cors allowed_headers list

Required Minimum Privilege Level: Ordinary

Use this command to display the list of allowed headers that the client can use to make CORS request to Live
Data.

Command Syntax
utils live-data cors allowed_headers list

There are no required parameters.

utils live-data cors allowed_headers add

Required Minimum Privilege Level: Advanced

Use this command to add the given list of headers to the allowed header list.

Command Syntax
utils live-data cors allowed_headers add headers

headers

Comma separated list of headers (without spaces) that has to be added to the allowed headers list.
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utils live-data cors allowed_headers delete

Required Minimum Privilege Level: Advanced

Use this command to delete a particular header entry or all the header entries from the allowed headers list.
The header names are case-insensitive and any duplicate header name will be ignored.

Command Syntax
utils live-data cors allowed_headers delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
the header entries from the allowed headers list.

Example

Utils live-data cors allowed_headers delete

1. Header1

2. Header2

a: all

q: quit

utils live-data cors exposed_headers list

Required Minimum Privilege Level: Oridnary

This command displays the list of exposed headers that the client can expect from Live Data when it makes
CORS request to Live Data .

Command Syntax
utils live-data cors exposed_headers list

There are no required parameters.

utils live-data cors exposed_headers add headers

Required Minimum Privilege Level: Oridnary

This command adds given list of headers to the exposed header list.

Command Syntax
utils live-data cors exposed_headers add headers

headers

Comma separated list of headers that has to be added to the exposed headers list.
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utils live-data cors exposed_headers delete

Required Minimum Privilege Level: Oridnary

This command deletes a particular header entry or all the header entries from the exposed headers list. The
header names are case-insensitive, any duplicate header name will be ignored.

Command Syntax
utils live-data cors exposed_headers delete

There are no required parameters. This command will prompt for a choice to delete a particular entry or all
header entries from exposed headers list.

Example

Utils live-data cors exposed_headers delete.

1. Header1

2. Header2

a: all

q: quit

Live Data Reporting Configuration

set live-data reporting-interval
Required Minimum Privilege Level: Advanced

Use this command to set the Live Data reporting interval in minutes. The reporting interval is the duration of
time for which values are aggregated and reported for the To Interval fields.

Command Syntax
set live-data reporting-interval reporting-interval-in-minutes
reporting-interval-in-minutes

Specifies the reporting interval in minutes. The valid values are 5, 10, 15, 30, and 60 minutes.

When you set the Live Data reporting interval, restart the publisher and then the subscriber. Restart the inactive
node and then the active node by using the utils system restart command. (For more information about the
command, refer to the Administration Console User Guide for Cisco Unified Intelligence Center at
https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html.)

If you restart only the publisher and not the subscriber, the new reporting interval takes effect only on the
publisher; likewise, if you restart the subscriber but not the publisher, only the subscriber uses the newly set
reporting interval.

When the publisher and the subscriber restart, use the show live-data reporting-interval command to validate
the new interval.
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show live-data reporting-interval
Required Minimum Privilege Level: Ordinary

Use this command to show the configured and current reporting interval for both the Live Data publisher and
subscriber.

Command Syntax
show live-data reporting-interval

unset live-data reporting-interval
Required Minimum Privilege Level: Advanced

Use this command to reset the Live Data reporting interval to the default value (which is five minutes).

Command Syntax
unset live-data reporting-interval

When you reset the Live Data reporting interval, restart the publisher and then the subscriber. Restart the
inactive node and then the active node by using the utils system restart command. (For more information
about the command, refer to the Administration Console User Guide for Cisco Unified Intelligence Center
at https://www.cisco.com/c/en/us/support/customer-collaboration/unified-intelligence-center/
products-maintenance-guides-list.html.)

If you restart only the publisher and not the subscriber, the reset interval takes effect only on the publisher;
likewise, if you restart the subscriber but not the publisher, only the subscriber uses the reset reporting interval.

When the publisher and the subscriber restart, use the show live-data reporting-interval command to validate
the new interval.

Live Data Services Registration

set live-data cuic-datasource
Required Minimum Privilege Level: Advanced

Use this command to create or update the Live Data data source in Cisco Unified Intelligence Center.

You can run the command from either the Side A or Side B (not both) Live Data node; and you must run it
once for each of the Cisco Unified Intelligence Center Publisher nodes. The AWDistributor and Cisco Unified
Intelligence Center Publisher must be in service.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.
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You must run this command when there is a change in machine service inventory table. The changes can
occur when,

• Recreating the node in Unified CCE Inventory

• Restoring AW database using EDMT

• Running the set livedata machine-services CLI command (for 4K and above)

Note

Command Syntax
set live-data cuic-datasource cuic-addr cuic-port cuic-user
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN). This
node must be in service.

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).

This user must have system configuration administrative privileges.

Command Default When you execute this command, it prompts you to specify the password to use for authentication with Cisco
Unified Intelligence Center.

show live-data cuic-datasource
Required Minimum Privilege Level: Ordinary

Use this command to list the Live Data data source configuration in Cisco Unified Intelligence Center.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.

Command Syntax
show live-data cuic-datasource cuic-addr cuic-port cuic-user
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN).

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).
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Command Default When you execute this command, it prompts you to specify the password to use for authentication with Cisco
Unified Intelligence Center.

unset live-data cuic-datasource
Required Minimum Privilege Level: Advanced

Use this command to delete the existing Live Data data source. Ensure that there are no existing reports or
report templates that reference the Live Data data source before you run the command; otherwise, the command
fails.

After you run this command successfully, you can no longer generate Live Data reports.

You can use this command after you:

• Set the AW DB connection information on the same node where you want to run this command.

• Configure Live Data endpoints in the Machine Service table.

Command Syntax
unset live-data cuic-datasource cuic-addr cuic-port cuic-user
cuic-addr

Specifies the Cisco Unified Intelligence Center publisher node's fully qualified domain name (FQDN).

cuic-port

Specifies the Cisco Unified Intelligence Center REST API port, which must be 8444.

cuic-user

Specifies the user name to use for authentication with Cisco Unified Intelligence Center. By default, Cisco
Unified Intelligence Center requires that you specify CUIC as the domain with the user name (for example,
CUIC\administrator).

This user must have system configuration administrative privileges.

Command Default When you execute this command, it prompts you to specify the password to use for authentication with Cisco
Unified Intelligence Center.

set live-data machine-services

This command is not valid for coresident deployments. If you have a coresident deployment, use the System
Inventory in the Unified CCE Administration tool.

Note

Required Minimum Privilege Level: Advanced

Use this command to set or update the Machine Service table with the latest information from Live Data
services (publisher and subscriber).

You must run the set live-data cuic-datasource CLI command after executing the set live-data
machine-services command.

Note
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Command Syntax
set live-data machine-services awdb-user
awdb-user

Use the user@domain format to specify the AW database domain user with write-access permission. The
domain is a fully qualified domain name (FQDN). The username is a user principal name. The user must be
authorized to change Unified CCE configuration.

Command Default When you execute this command, it prompts you to specify the login password to use for authentication with
AW database access.

show live-data machine-services
Required Minimum Privilege Level: Ordinary

Use this command to display Live Data entries in the Machine Services table.

Command Syntax
show live-data machine-services [awdb-user]
awdb-user

Use the user@domain format to specify the AWdatabase domain user with at least read-access permission.

Command Default When you execute this command, it prompts you to specify the login password to use for authentication with
AW database access.

Transport Layer Security CLI Commands

These CLI commands are only for VOS systems. They are not available for VMs running Windows Server.Note

TLS Server Minimum Version

set tls server min-version
Use this command to set the current TLS minimum version for inbound connections.

Command Syntax

set tls server min-version {1.0|1.1|1.2}
1.0

Specifies the TLS server minimum version 1.0 for inbound connections.

1.1

Specifies the TLS server minimum version 1.1 for inbound connections.

1.2

Specifies the TLS server minimum version 1.2 for inbound connections.

Cisco Unified Contact Center Enterprise Installation and Upgrade Guide, Release 12.0(1)
280

CLI Commands during Installation and Upgrade
show live-data machine-services



show tls server min-version
Use this command to display the current TLS minimum version for inbound connections.

Command Syntax
show tls server min-version

TLS Client Minimum Version

set tls client min-version
Use this command to set the current TLS minimum version for outbound connections.

Command Syntax

set tls client min-version {1.0|1.1|1.2}
1.0

Specifies the TLS client minimum version 1.0 for outbound connections.

1.1

Specifies the TLS client minimum version 1.1 for outbound connections.

1.2

Specifies the TLS client minimum version 1.2 for outbound connections.

show tls server min-version
Use this command to display the current TLS minimum version for inbound connections.

Command Syntax
show tls server min-version
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A P P E N D I X B
Certificates for Live Data

• Certificates and Secure Communications, on page 283
• Export Self-Signed Live Data Certificates, on page 284
• Import Self-Signed Live Data Certificates, on page 285
• Produce Certificate Internally, on page 285
• Deploy Root Certificate for Browsers , on page 286
• Set Up CA Certificate for Internet Explorer Browser, on page 287
• Set Up CA Certificate for Firefox Browser, on page 288

Certificates and Secure Communications
For secure Cisco Finesse, Cisco Unified Intelligence Center, and Live Data server-to-server communication,
perform any of the following:

• Use the self-signed certificates provided with Live Data.

When using self-signed certificates, agents must accept the Live Data certificates
in the Finesse desktop when they sign in before they can use the Live Data gadget.

Note

• Obtain and install a Certification Authority (CA) certificate from a third-party vendor.

• Produce a Certification Authority (CA) certificate internally.

Obtain and Upload Third-party CA Certificate
You can use a Certification Authority (CA) certificate provided by a third-party vendor to establish an HTTPS
connection between the Live Data, Cisco Finesse, and Cisco Unified Intelligence Center servers.

To use third-party CA certificates:

• From the Live Data servers, generate and download a Certificate Signing Requests (CSR).

• Obtain root and application certificates from the third-party vendor.

• Upload the appropriate certificates to the Live Data, Unified Intelligence Center, and Cisco Finesse
servers.
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Follow the instructions provided in the Unified CCE Solution: Procedure to Obtain and Upload Third-Party
CA certificates (Version 11.x) technical note at https://www.cisco.com/c/en/us/support/docs/
customer-collaboration/unified-contact-center-enterprise-1101/
200286-Unified-CCE-Solution-Procedure-to-Obtai.html .

Export Self-Signed Live Data Certificates
Live Data installation includes the generation of self-signed certificates. If you choose to work with these
self-signed certificates (rather than producing your own CA certificate or obtaining a CA certificate from a
third-party certificate vendor), you must first export the certificates from Live Data and Cisco Unified
Intelligence Center, as described in this procedure. You must export from both Side A and Side B of the Live
Data and Cisco Unified Intelligence Center servers. You must then import the certificates into Finesse,
importing both Side A and Side B certificates into each side of the Finesse servers.

As is the case when using other self-signed certificates, agents must accept the Live Data certificates in the
Finesse desktop when they sign in before they can use the Live Data gadget.

Procedure

Step 1 Sign in to Cisco Unified Operating System Administration on Cisco Unified Intelligence Center
(https://hostname of Cisco Unified Intelligence Center server/cmplatform).

Step 2 From the Security menu, select Certificate Management.
Step 3 Click Find.
Step 4 Do one of the following:

• If the tomcat certificate for your server is on the list, click the certificate to select it. (Ensure that the
certificate you select includes the hostname for the server.)

• If you are using self-signed certificate, do the following:

a. Click Generate New.

b. When the certificate generation is complete, restart the Cisco Tomcat service and the Cisco Live
Data NGNIX service.

c. Restart this procedure.

Step 5 Click Download .pem file and save the file to your desktop.

Be sure to perform these steps for both Side A and Side B.

Step 6 After you have downloaded the certificates from Cisco Unified Intelligence Center, sign in to Cisco Unified
Operating System Administration on the Live Data server (http://hostname of LiveData server/cmplatform),
and repeat steps 2 to 5. This is applicable only for Standalone LiveData.

What to do next

Youmust now import the Live Data and Cisco Unified Intelligence Center certificates into the Finesse servers.
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Import Self-Signed Live Data Certificates
To import the certificates into the Finesse servers, use the following procedure.

Procedure

Step 1 Sign in to Cisco Unified Operating System Administration on the Finesse server using the following URL:

http://FQDN of Finesse server:8443/cmplatform

Step 2 From the Security menu, select Certificate Management.
Step 3 Click Upload Certificate.
Step 4 From the Certificate Name drop-down list, select tomcat-trust.
Step 5 Click Browse and browse to the location of the Cisco Unified Intelligence Center certificate (with the .pem

file extension).
Step 6 Select the file, and click Upload File.
Step 7 After you have uploaded the Cisco Unified Intelligence Center certificate repeat steps 3 to 6 for Live Data

certificates.This is applicable only for standalone Live Data.
Step 8 After you upload both the certificates, restart Cisco Finesse Tomcat on the Finesse server.

What to do next

Be sure to perform these steps for both Side A and Side B.

Produce Certificate Internally

Set up Microsoft Certificate Server for Windows Server
This procedure assumes that your deployment includes a Windows Server Active Directory server. Perform
the following steps to add the Active Directory Certificate Services role on the Windows Server domain
controller.

Before you begin

Before you begin, Microsoft .Net Framework must be installed. See Windows Server documentation for
instructions.

Procedure

Step 1 In Windows, open the Server Manager.
Step 2 In the Quick Start window, click Add Roles and Features .
Step 3 In the Set Installation Type tab, select Role-based or feature-based installation , and then click Next.
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Step 4 In the Server Selection tab, select the destination server then click Next.
Step 5 In the Server Roles tab, check theActive Directory Certificate Services box, and then click theAdd Features

button in the pop-up window.
Step 6 In the Features and AD CS tabs, click Next to accept default values.
Step 7 In the Role Services tab, verify that Certification Authority box is checked, and then click Next.
Step 8 In the Confirmation tab, click Install.
Step 9 After the installation is complete, click theConfigure Active Directory Certificate Service on the destination

server link.
Step 10 Verify that the credentials are correct (for the domain Administrator user), and then click Next.
Step 11 In the Role Services tab, check the Certification Authority box, and then click Next.
Step 12 In the Setup Type tab, select Enterprise CA, and then click Next.
Step 13 In the CA Type tab, select Root CA, and then click Next.
Step 14 In the Private Key, Cryptography, CA Name, Validity Period, and Certificate Database tabs, click Next

to accept default values.
Step 15 Review the information in the Confirmation tab, and then click Configure.

Download CA certificate
This procedure assumes that you are using the Windows Certificate Services. Perform the following steps to
retrieve the root CA certificate from the certificate authority. After you retrieve the root certificate, each user
must install it in the browser used to access Finesse.

Procedure

Step 1 On the Windows domain controller, run the CLI command certutil -ca.cert ca_name.cer, in which ca_name
is the name of your certificate.

Step 2 Save the file. Note where you saved the file so you can retrieve it later.

Deploy Root Certificate for Browsers
In environments where group policies are enforced via the Active Directory domain, the root certificate can
be added automatically to each user's browser. Adding the certificate automatically simplifies user requirements
for configuration.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note
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Procedure

Step 1 On the Windows domain controller, navigate to Administrative Tools > Group Policy Management.

Users who have strict Group Policy defined on the Finesse Agent Desktop are required to disable
Cross Document Messaging from Group Policy Management to ensure proper functioning of
Finesse on browser.

Note

Step 2 Right-click Default Domain Policy and select Edit.
Step 3 In the Group Policy Management Console, go to Computer Configuration > Policies > Window Settings >

Security Settings > Public Key Policies.
Step 4 Right-click Trusted Root Certification Authorities and select Import.
Step 5 Import the ca_name.cer file.
Step 6 Go toComputer Configuration > Policies >Windows Settings > Security Settings > Public Key Policies >

Certificate Services Client - Auto-Enrollment.
Step 7 From the Configuration Model list, select Enabled.
Step 8 Sign in as a user on a computer that is part of the domain and open browser.
Step 9 If the user does not have the certificate, run the command gpupdate.exe /target:computer /force on the user's

computer.

Set Up CA Certificate for Internet Explorer Browser
After obtaining and uploading the CA certificates, either the certificate must be automatically installed via
group policy or all users must accept the certificate.

In environments where users do not log directly in to a domain or group policies are not utilized, every Internet
Explorer user in the system must perform the following steps once to accept the certificate.

Procedure

Step 1 In Windows Explorer, double-click the ca_name.cer file (in which ca_name is the name of your certificate)
and then click Open.

Step 2 Click Install Certificate > Next > Place all certificates in the following store.
Step 3 Click Browse and select Trusted Root Certification Authorities.
Step 4 Click OK.
Step 5 Click Next.
Step 6 Click Finish.

A message appears that states you are about to install a certificate from a certification authority (CA).

Step 7 Click Yes.

A message appears that states the import was successful.
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Step 8 To verify the certificate was installed, open Internet Explorer. From the browser menu, selectTools > Internet
Options.

Step 9 Click the Content tab.
Step 10 Click Certificates.
Step 11 Click the Trusted Root Certification Authorities tab.
Step 12 Ensure that the new certificate appears in the list.
Step 13 Restart the browser for certificate installation to take effect.

If using Internet Explorer 11, you may receive a prompt to accept the certificate even if signed
by private CA.

Note

Set Up CA Certificate for Firefox Browser
Every Firefox user in the system must perform the following steps once to accept the certificate.

To avoid certificate warnings, each user must use the fully-qualified domain name (FQDN) of the Finesse
server to access the desktop.

Note

Procedure

Step 1 From the Firefox browser menu, select Options.
Step 2 Click Advanced.
Step 3 Click the Certificates tab.
Step 4 Click View Certificates.
Step 5 Click Authorities.
Step 6 Click Import and browse to the ca_name.cer file (in which ca_name is the name of your certificate).
Step 7 Check the Validate Identical Certificates check box.
Step 8 Restart the browser for certificate installation to take effect.
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A P P E N D I X C
Migrate from Co-resident Deployment to
Standalone Deployment

• Upgrade from Co-resident to Standalone Deployments, on page 289
• Upgrading Live Data for 24k Deployment Type, on page 290

Upgrade from Co-resident to Standalone Deployments
If your solution exceeds the configuration limits of 2000 Agent Reference Design, use a Reference Design
with higher limits and replace the co-resident deployment of CUIC with a standalone deployment of CUIC,
Live Data, and IdS. A standalone deployment allows higher capacity and increased reporting end users. You
cannot convert the existing co-resident server to a standalone server.

You can export the CUIC reports from the co-resident deployment and import them into the new standalone
CUIC.

Note

For a new standalone deployment, you must perform fresh install of the following servers, using the method
outlined below:

TaskSequence

Set up the System Inventory for Standalone Deployment, on page 2901

Install Cisco Unified Intelligence Center Standalone (4000, 8000, 12000 Agent Deployment).
See Installation and Upgrade Guide for Cisco Unified Intelligence Center at
http://www.cisco.com/en/US/products/ps9755/prod_installation_guides_list.html.

2

Install Live Data. See Live Data Standalone Installation, on page 75.3

Install the Identity Service. See Install Cisco Identity Service Standalone Deployment, on
page 71 .

4
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Set up the System Inventory for Standalone Deployment

Procedure

Step 1 In Unified CCE Administration, navigate to System > Deployment.
Step 2 Add the new machine to the System Inventory:

a) Select the coresident machine to remove. Cick Delete.
b) Click New. The Add Machine popup window opens.

The Add Machine popup window opens.

c) From the Type drop-down menu, select the following machine type:

Unified Intelligence Center Publisher.

d) In the Hostname field, enter the FQDN, hostname, or IP address of the machine.

The system attempts to convert the value you enter to FQDN.

e) Enter the machine's Administration credentials.
f) Click Save.

The machine and its related Subscriber or Secondary machine are added to the System Inventory.

What to do next

If you remove a component from your deployment, delete it from your System Inventory. If you add the
component again, or add more components, add those components to the System Inventory.

Upgrading Live Data for 24k Deployment Type
After installing Cisco Unified CCE, follow this procedure to upgrade the Live Data server in VM.

Procedure

Step 1 In the Virtual Machine:
a) Click the Edit virtual machine settings option in VM Hardware on the ESXi/ESX host.
b) Increase the CPU cores to 12 and CPU reservation to 24000MHz.
c) Increase the Memory is 36GB and Memory reservation to 36864MB.

For details about how to edit the VM Hardware settings, see the VMware hardware documentation.

Step 2 Upgrade live data.

The System Memory and CPU should be increased before upgrade. If the upgrade is applied
before increasing the system memory, use the CLI command in step 3 to set the memory profile
parameters correctly.

Note
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Step 3 Execute the set live-data memory profile CLI command to set the parameters correctly.

This CLI command updates the memory parameters only if the total RAM on the VM is at least
36 GB. If the RAM is lesser than 36 GB, the CLI resets the memory parameters to default values.

Note
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A P P E N D I X D
IPv6 Configuration

• Configure NAT64 for IPv6-Enabled Deployment, on page 293
• Set Up IPv6 for VOS-Based Contact Center Applications, on page 295

Configure NAT64 for IPv6-Enabled Deployment
NAT64 allows communication between IPv6 and IPv4 networks. For IPv6-enabled deployments, you must
set up NAT64 so that supervisors on an IPv6 network can access Unified CCE Administration web tools on
an IPv4 network.

You can use either Stateful and Stateless NAT64. To read more about which translation type is the most
appropriate for your deployment see Table 2. Comparison Between Stateless and Stateful NAT64 here:
https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/enterprise-ipv6-solution/white_paper_
c11-676278.html

NAT64 is NOT supported on M train IOS. T train is required.

For more information on Contact Center Enterprise Compatibility Matrix, see https://www.cisco.com/c/en/
us/support/customer-collaboration/unified-contact-center-enterprise/products-device-support-tables-list.html.

Note

The following example network diagram and interface configuration demonstrates Stateful NAT64 translation
between an IPv6 network and an IPv4 network.

interface GigabitEthernet0/0
description ipv4-only interface
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ip address 10.10.10.81 255.255.255.128
duplex auto
speed auto
nat64 enable
no mop enabled

interface GigabitEthernet0/1
description ipv6-only interface
no ip address
duplex auto
speed auto
nat64 enable
ipv6 address 2001::1/64
ipv6 enable

ipv6 unicast-routing
ipv6 cef
!
nat64 prefix stateful 3001::/96
nat64 v4 pool POOL1 10.10.10.129 10.10.10.250
nat64 v6v4 list V6ACL1 pool POOL1 overload
ipv6 router rip RIPv6
!
ipv6 router rip RIP

!
ipv6 access-list V6ACL1
permit ipv6 2001::/64 any

Configure DNS for IPv6
To meet the requirement that Unified CCE Administration be accessed by FQDN, a Forward lookup AAAA
record for the AW must be created in DNS.

The steps in this procedure are for a Windows DNS server.

Procedure

Step 1 In Windows, navigate to Administrative Tools > DNS. This opens the DNS Manager.
Step 2 In the Forward lookup zone, navigate to your deployment's domain name.
Step 3 Right-click the domain name and select New Host (A or AAAA).
Step 4 In the New Host dialog box, enter the computer name and IP address of the AW. Click Add Host.

Determine IPv6 Translation of IPv4 Address for DNS Entry
You can determine the IPv6 address needed for the AAAA DNS record by running a ping command on any
Windows machine using mixed notation. Type “ping -6” followed by your IPv6 Nat64 Prefix, two colons,
and then the IPv4 address.
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In the ping response, the IPv4 address is converted to the hexadecimal equivalent. Use this address in your
static AAAA record.

Optionally, DNS64 can be used in place of static DNS entries. Use of DNS64 helps facilitate translation
between IPv6 and IPv4 networks by synthesizing AAAA resource records from A resource records.

The NAT64 Technology: Connecting IPv6 and IPv4 Networks whitepaper gives an overview of DNS64 and
how it is used with IPv6: https://www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/
enterprise-ipv6-solution/white_paper_c11-676278.html.

Note

Set Up IPv6 for VOS-Based Contact Center Applications
By default, only IPv4 is enabled for Unified CommunicationsManager, Cisco Finesse, and Unified Intelligence
Center.

If you choose to enable IPv6 on these applications, you must enable it on both the publisher/primary nodes
and subscriber/secondary nodes for those applications.

You can use Cisco Unified Operating System Administration or the CLI to enable IPv6.

See the Solution Design Guide for Cisco Unified Contact Center Enterprise at https://www.cisco.com/c/en/
us/support/customer-collaboration/unified-contact-center-enterprise/
products-implementation-design-guides-list.html for more information about IPv6 support in Unified CCE.

Set Up IPv6 Using Cisco Unified Operating System Administration
To set up IPv6 using Cisco Unified Operating System Administration, perform the following procedure on
the primary and secondary VOS servers.

Procedure

Step 1 Sign into Cisco Unified Operating System Administration on the Publisher/Primary node:.
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• Unified Communications Manager and Unified Intelligence Center: https://<host or IP
address of the Publisher or Primary node>/cmplatform

• Finesse: https://FQDN of the Primary node:8443/cmplatform

Step 2 Navigate to Settings > IP > Ethernet IPv6.
Step 3 Check the Enable IPv6 check box.
Step 4 Enter values for IPv6Address, Prefix Length, and Default Gateway.
Step 5 Check the Update with Reboot check box.
Step 6 Click Save.

The server restarts.
Step 7 Repeat this procedure on the subscriber/secondary node.

Set Up IPv6 for VOS-Based Applications Using the CLI
To set up IPv6 using the CLI, perform the following procedure on both the primary and secondary VOS
servers.

Procedure

Step 1 Access the CLI on the VOS server.
Step 2 To enable or disable IPv6, enter:

set network ipv6 service {enable | disable}

Step 3 Set the IPv6 address and prefix length:
set network ipv6 static_address addr mask

Example:

set network ipv6 static_address 2001:db8:2::a 64

Step 4 Set the default gateway:
set network ipv6 gateway addr

Step 5 Restart the system for the changes to take effect.
utils system restart

Step 6 To display the IPv6 settings, enter:
show network ipv6 settings
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