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Cisco Spectrum Expert Software Overview

Note If your computer has an 802.11 interface, it should be enabled in order to detect Wi-Fi devices. If you 
are connected to an AP or ad-hoc network through the 802.11 interface, you will occasionally see strong 
signals on the spectrum plots that are measurements of your own 802.11 transmissions. But as long as 
your network transmissions are not excessive, Cisco Spectrum Expert Software will still operate 
correctly in the presence of these signals. 

Figure 4-1: The Cisco Spectrum Expert Software 

Status Bar
The Cisco Spectrum Expert Software has a Status Bar at the bottom which may be toggled on and off 
using View > Status Bar. The Status Bar displays the following information:

• Current antenna in use
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• System uptime

• User band selections

• Current mode—Live, Playback, or Recording. 

Note See “Spectrum Recording and Playback” for more information.

Note If Spectrum Expert does not detect a local WLAN card, the message “Wireless LAN Card Not Detected” 
in displayed in the status bar.

Active Device Tree
The Active Device tree shows all access points, ad-hoc networks, and interferer devices currently 
detected by Cisco Spectrum Expert Software. The tree is normally on display on the left side of the 
application, but can be toggled on and off by selecting View > Device Tree. See “Active Device Tree” 
for more information.

Cisco Spectrum Expert Software Tabs and Operational Features
These five modes of operation are accessed by selecting any of the five tabs running across the top of the 
application display: Spectrum, Spectrum (2), Devices, Channel Summary, and Device Finder. 
Table 5-1 shows the relationship between the display tabs and the application’s operational capabilities.

Table 5-1 Cisco Spectrum Expert Software Operational Features

Display Tab Reference Comments

Spectrum See “Spectrum 
Tabs, Plots, and 
Charts Overview”, 
“Using Spectrum 
View Plots”, or 
See “Using 
Spectrum View 
Charts”.

Each Spectrum tab can display a mixture of Spectrum 
Plots and Charts. The application provides two 
Spectrum tabs, allowing for two different, 
user-configurable, default configurations of Plots and 
Charts.

Spectrum(2)

Devices See “Working 
With Devices 
View”.

Detailed information on detected devices. Unlike the 
Active Devices list, this will also show historical 
devices (i.e., devices which are no longer active).

Channel Summary See “Working with 
the Channel 
Summary”.

Summary of RF activity on all monitored channels.

Device Finder See “Device 
Finder Mode”.

Cisco’s “sniffer” for locating unwanted RF devices.
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Control Panel
Several of the viewing modes have specific controls which enable 
you to fine-tune the features of the display. For example, one of 
the Spectrum Plot Controls panel is shown at left. Normally, the 
Control Panel automatically comes into view when you select an 
appropriate mode, such as Spectrum mode (see “Using Spectrum 
View Plots”), Devices mode (see “Device Finder Mode”), or 
Device Finder (see “Working With Devices View”).

• If the Control Panel is not displayed, select View > Control 
Panel. Select the same menu option to toggle the Control 
Panel off.

• In the Spectrum view, each plot or chart has its own unique 
controls. If the Control Panel is showing but the controls for 
the plot or chart of interest are not displayed, click on the plot 
or chart of interest. The appropriate controls will then be 
shown on the Control Panel.

• You can adjust the size of the Control Panel and the Active 
Devices view by placing the cursor over the line which 
divides them, left-click and hold the mouse button, and drag 
up or down.

Hiding/Unhiding the Active Devices List and Control Panel
You can use options on the View menu to hide or display the Active Devices tree and the Control Panel. 
You can also use the mouse to control the display of the Active Devices tree and the Control Panel, as 
illustrated here. 

Note This guide shows examples of the Control Panel, but the techniques apply to the Active Devices tree as 
well.

Close 

You can close the Control Panel or Active Devices tree by 
clicking the Close button.

Auto-Hide

You can hide the Control Panel or Active Devices list by 
clicking the Auto-Hide button, which has a small push-pin 
symbol on it.
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Hiding the Control Panel allows more room for 
other display features (such as a larger view of the 
Spectrum tab shown at right). However, a small 
vertical Control Panel tab is still shown at left.

Note If you hover (without clicking) the mouse 
pointer over the vertical tab for the Control 
Panel, the Control Panel is temporarily 
restored to view. This allows you to make changes or make selections on the Active Devices tree.

Note To restore the Control Panel/Active Devices tree to permanent status on the display, click the 
Auto-Hide button. 

Menu Options
The Cisco Spectrum Expert Software has the following menu options.

File Menu

The File menu offers the following options:

• Open Capture File—Allows you to play back a previously recorded Cisco Capture File. See 
“Spectrum Recording and Playback” for more information.

• Save Replay As—Captures Instant Replay spectrum data to a Cisco Capture File for later playback. 
See “Spectrum Recording and Playback” for more information.

• Instant Replay—Enables a 1 to 60 minute replay of stored running FIFO capture data.

• Record Capture File—Captures spectrum data to a Cisco Capture File for later playback. See 
“Spectrum Recording and Playback” for more information.

• Stop Capture File—Terminates the recording of spectrum data.

• Connect To Sensor—Allows you to select a different Sensor card or to open a CSC file. 

Note Select the Browse button to locate the CSC file of interest.

Note Some Sensor cards automatically use the external antenna if one is connected, and will override 
any contrary setting here.

Note If you expect to use these settings in the future, check the Automatically Use These Settings 
Next Time box.

• Import Settings—Allows you to import Local Settings into Spectrum Expert.

• Export Settings—Allows you to export Local Settings into Spectrum Expert.

• Exit—Closes the Cisco Spectrum Expert Software.
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View Menu

This menu provides access to most of the main Cisco Spectrum Expert Software features:

• Spectrum—Enables you to create a variety of plots and charts which provide real-time views of RF 
activity. You can save your configuration of plots and charts. See “Using Spectrum View Plots” for 
more information.

• Spectrum (2)—The same as with Spectrum; you can create a variety of plots and charts, and save 
your configuration.

• Devices—Shows all RF devices detected by Cisco Spectrum Expert Software. See “Working With 
Devices View” for more information.

• Channel Summary—Shows RF activity—such as power levels, and the presence of 802.11 and 
interferer devices—on a channel-by-channel basis. See “Working with the Channel Summary” for 
more information.

• Device Finder—Enables you to track down the location of interfering devices. See “Working With 
Device Finder” for more information.

• Active Devices—Shows all access points, ad-hoc networks, and interferer devices currently 
detected by Cisco Spectrum Expert Software. See “Active Devices” for more information.

• Control Panel—Toggles the Control Panel on and off. The Control Panel sets the details of your 
view in several different modes: Spectrum View, Devices View, and Device Finder. See “Control 
Panel” for more information.

• Status Bar—Provides various system status information and user band selections. Use this menu 
option to toggle the Status Bar display on or off.

Spectrum Menu

This menu is only visible when the Spectrum or Spectrum (2) tab is selected.

• Add Plot—Adds one of the available plot types.

• Add Chart—Adds one of the available chart type.

• Remove Selected Items—Removes the currently selected plot or chart from the display. (You must 
first select a spectrum plot or chart for this menu option to be active.)

• Pause Selected Items—Freezes the display of data on the currently selected plot or chart.

• Resume Selected Items—Only shown if you first select a plot or chart which was previously 
paused. Resumes the real-time update of data for that plot or chart.

• Zoom In/Out—Maximizes or minimizes the size of a selected plot or chart. 

• Export Selected Items Data—Captures and exports data from a specified spectrum plot or chart 
and saves it to a file.

• Cut—Deletes the currently selected spectrum plot from the display and pastes it to the clipboard. 

• Copy—Captures the currently selected plot or chart.

• Paste—Retrieves a spectrum plot or chart from the clipboard and pastes it in the display area. 

• Select All Items—Selects all spectrum plots and charts currently displayed on the spectrum tab.

• Open Spectrum View Configuration—Once you have configured plots and charts on one of the 
two Spectrum tabs, you can save the plot/chart configuration. This enables you to easily restore the 
same configuration at a later time. See “Saving and Restoring Spectrum View Layouts” for more 
information.
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• Save Spectrum View Configuration—See “Saving and Restoring Spectrum View Layouts” for 
more information.

• New Spectrum View Configuration—See “Saving and Restoring Spectrum View Layouts” for 
more information.

See “Using Spectrum View Plots” for more information.

Tools Menu

This menu provides access to the Settings dialog. The Settings dialog has five panels:

• Sensors and Antennas—Selects which Spectrum Sensor card (and, in some cases, which antenna) 
the Cisco Spectrum Expert Software uses for spectrum data acquisition.

• Console Settings—Modifies the date and time on the Cisco Spectrum Expert Software, configures 
the Spectrum view to use for playback, enables the Instant Replay feature, selects the Default AP 
Category (In-Network or Unknown), and modifies the color of the plot’s background.

• Band and Channel Settings—This panel determines, by Regulatory Domain (USA, Japan,.), which 
RF bands and channels are monitored for RF activity and reported on by Cisco Spectrum Expert 
Software. The default setting is to monitor the channels indicated on the 802.11b/g Channel 
Settings panel. However, there are also options for other predefined 802.11a bands, including the 
US Public Safety Band and user-selected channels in middle and upper bands as well.

• Alert Settings—Used to enable or disable security and performance alerts for an interferer type or 
category.

• SNMP Option / Cisco WCS Settings

– SNMP Option—Cisco Spectrum Expert Software has an ability to send SNMP traps when it 
detects interfering devices. This screen is used to configure the trap filters and threshold levels 
that will trigger the sending of an SNMP trap. The Settings – SNMP Option screen is used to 
configure the trap filters and threshold levels that will trigger the sending of an SNMP trap.

Note The SNMP Option icon appears in the Cisco Spectrum Expert Software standard version. 
See “SNMP Option Settings” to configure the SNMP settings.

– WCS Settings—The WCS-enabled Cisco Spectrum Expert Software provides the ability to 
send and receive Air Quality (AQ) data using the Cisco proprietary mode of streaming 
communication between Cisco Spectrum Expert Software and a Wireless Control System 
(WCS). The Settings - Cisco Option screen is used to configure the sending of data to the WCS.

Note The WCS Settings icon appears in the Cisco WCS-enabled Cisco Spectrum Expert Software 
version. See “Cisco WCS Settings” to configure the WCS settings.

See “Local Settings Overview” for more information.

Help

• Help Topics—Provides access to the Cisco Spectrum Expert Software Help system.

• About Cisco Spectrum Expert Software—Provides copyright and version information for the 
Cisco Spectrum Expert Software.

• About Spectrum Sensor Card—Provides technical data for the Sensor card currently in use.
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• Capture File Properties—This option is active when a CCF file is playing and will display file 
information when invoked. 

Spectrum Recording and Playback
The Mobile software enables you to record spectrum data in Cisco Spectrum Capture (CSC) files. You 
can then play these files back at a later time. Each CSC stores the following information to disk:

Note Cisco Spectrum Capture files are subject to a size limitation of 512 MB. You should estimate CCF file 
size growth at a rate of 6 MB per hour/per band selected when considering the 512 MB size limitation.

• Active Devices—A list of active devices vs. time, plus all information needed to reproduce the 
Devices View and any of its subviews and columns for all monitored bands during playback. 
(During playback you will be able to change columns and see meaningful information that changes 
with time, just as with live mode.) 

• Spectrum Plot Data—All information needed to reproduce any of the Spectrum Analyzer plots 
(except Power vs. Time and Power vs. Frequency – these plots will not be available during 
playback). You can adjust the settings for the other plots and charts during playback. 

• Spectrum Chart Data—All information needed to reproduce any of the spectrum charts during 
playback.

• Reference Information—This includes the date and time of capture, the Windows user/login name, 
and the Sensor card revision and serial number.

The diagram at right shows the controls 
used for spectrum recording and 
playback:

The controls are described briefly below:

• Record—Opens a dialog box where 
you can define the name and file 
location of a CSC file. Upon closing 
the dialog box, recording begins 
automatically. You can also initiate 
this operation by selecting File ‡ 
Record Capture File.

• Open—Opens a previously captured 
CCF file for playback. You can also 
select File ‡ Open Capture File. Use 
the Open Capture File dialog box to 
select the recording of interest.

• Playback—Once you have opened a 
CSC file, select this to start playback.

• Stop—Stops the recording process, and also stops the in-progress playback of a CSC file.

• Go Live—Returns you to live mode. Any playback or recording that was in progress is halted.

• Slider Control—You can use this control to move to any particular time during the playback 
interval.

You may select any combination of Spectrum Analyzer plots or charts during playback. 
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Just as in a live spectrum session, you can right-click within the display area to get pop-up menus used to 
navigate to specific information. Additionally, you can use all other plot icons and features, such as adding, 
moving, zooming, and removing a plot or chart during playback. 

Note The Power Vs. Time and Power Vs. Frequency plots are not supported during playback.

Spectrum Instant Replay
The Instant Replay feature allows you to review the most recent spectrum information up to the past 60 
minutes, without having to record it in a CCF file, and play it back much as if it were being viewed live 
for the first time without interrupting receipt of current spectrum information. Spectrum information of 
interest viewed as an Instant Replay may then be saved as Cisco Spectrum Capture (CCF) files to share 
information on what is happening in the spectrum.

The screens at right show the two access methods used for Instant Replay.

Navigate from Tools > Settings > Console Settings to display the Instant 
Replay settings options as shown at right. The controls are described 
briefly below and detailed instructions on Instant Replay Settings, 
Initiating an Instant Replay and Converting an Instant Replay to a CCF can 
be found in the Online Help.

Enable Instant Replay of the 
last—Select to enable the Instant 
Replay function.

Minutes—Select the length of the 
Instant Replay (range 1 to 60 
minutes).

What If I’m Not Seeing Any Data?
It may happen that you are viewing one of the Cisco Spectrum Expert Software displays, such as a 
spectrum plot, but you are not seeing any data; or data is missing for part of a plot. (For example, some 
of the channels on the plot have spectrum data, and others do not.) Or, you may know perfectly well that 
some kind of interfering device is present in the environment, but the Devices List and/or Device Finder 
are not detecting it.

Sensor Card Not Properly Inserted

One possible cause of this problem could be a complete lack of communication between the Sensor card 
and the Cisco Spectrum Expert Software. Normally, however, if communication is lost with the Sensor 
card, the Cisco Spectrum Expert Software will present a warning message, and then shut down.

To resolve such problems, check to ensure the Sensor card remains properly seated in the card slot. 
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Faulty Configuration Settings

Another possibility is that, while you have set your spectrum plots to display certain channels or bands, 
your configuration settings for Cisco Spectrum Expert Software as a whole do not include those 
channels/bands.

To determine if this is the problem—and to rectify if—you need to check your Channel Settings and 
Monitored Bands under the Cisco Spectrum Expert Software’s Settings panel. See “Local Settings 
Overview” for more information.

Erroneous Scale Settings

With the spectrum plots (see “Using Spectrum View Plots”), it is possible you may fail to see any data 
if you have an amplitude setting that is inappropriate for the actual data being monitored. For example, 
suppose you are monitoring the RF duty cycle, and have the vertical axis amplitude set to range from 0% 
to 100% (the default setting). If in fact the actual duty cycle values are very low (say, ranging from 0% 
to 1% or 2%), you may not see any data.

This can be a particular problem with the Swept Spectrogram plot, where RF power values and duty 
cycle values are mapped to colors. If all the measured data falls in a very narrow range compared with 
the Color Scale, you may see nothing but a solid block of a single color – in fact, you are seeing the 
correct data, but it seems as if you are seeing no data at all.

Selecting the [Auto Scale] option on these plots should normally correct this problem, but sometimes it 
helps to manually adjust the measurement scale.

Wrong Antenna Settings

Another possibility is that you may have an internal Sensor card with an external antenna, but you are 
using the Sensor card’s internal antenna. (This might account, for instance, for why you might fail to see 
some interfering devices you expect to see.) Check your Sensors and Antennas settings. See “Sensors 
and Antennas ” for more information.

Miscellaneous Device Issues

There are various RF effects that can prevent or partly hinder device detection. These are discussed in 
detail in the “Working With Devices View” section.
5-9
Cisco Spectrum Expert Users Guide

OL-15327-03



Chapter 5      Cisco Spectrum Expert Software Overview
  
5-10
Cisco Spectrum Expert Users Guide

OL-15327-03


	Cisco Spectrum Expert Software Overview
	Status Bar
	Active Device Tree
	Cisco Spectrum Expert Software Tabs and Operational Features
	Control Panel
	Hiding/Unhiding the Active Devices List and Control Panel
	Menu Options
	File Menu
	View Menu
	Spectrum Menu
	Tools Menu
	Help

	Spectrum Recording and Playback
	Spectrum Instant Replay
	What If I’m Not Seeing Any Data?
	Sensor Card Not Properly Inserted
	Faulty Configuration Settings
	Erroneous Scale Settings
	Wrong Antenna Settings
	Miscellaneous Device Issues



