アップグレード手順を実行する前にブートストラップ設定ファイルを手動で作成する必要がある場合は、現在のデバイス設定から引き継ぐ詳細設定を持ったブートストラップ設定ファイルを作成します。ファイルには、アップグレード手順実行後に使用するルータの完全な
running-config が含まれている必要があります。
ここでは、次のタスクのブートストラップ設定ファイルの例を示します。
-
GigabitEthernet インターフェイスを使用するデバイスにおける Cisco IOS XE SD-WAN へのアップグレード
-
GigabitEthernet インターフェイスを使用するデバイスにおける Cisco vEdge ソフトウェアへのアップグレード
-
セルラー(LTE)インターフェイスを使用するデバイスにおける Cisco IOS XE SD-WAN へのアップグレード(LTE インターフェイスを備えたデバイスに適用可能)
-
セルラー(LTE)インターフェイスを使用するデバイスにおける Cisco vEdge ソフトウェアへのアップグレード(LTE インターフェイスを備えたデバイスに適用可能)
Cisco IOS XE SD-WAN にアップグレードするためのブートストラップファイルの例
この ciscomigration.cfg ブートストラップファイルは、GigabitEthernet インターフェイスを使用するデバイスに使用します。
(注) |
ciscomigration.cfg を使用してデバイス設定をロードする場合は、ブートストラップファイルで次のコマンドが必要となります。このコマンドがないと、デバイスにログインできない場合があります。
username admin privilege 15 secret 0 admin
|
system
system-ip 10.0.0.1
site-id 2
admin-tech-on-failure
sp-organization-name YOUR-SP-ORG
organization-name YOUR-ORG
vbond vbond.org.com port 12346
!
hostname Router
username admin privilege 15 secret 0 admin
vrf definition 1
rd 100:1
address-family ipv4
route-target export 100:1
route-target import 100:1
exit-address-family
!
address-family ipv6
exit-address-family
!
route-target export 100:1
route-target import 100:1
!
no ip finger
no ip rcmd rcp-enable
no ip rcmd rsh-enable
no ip dhcp use class
ip multicast route-limit 2147483647
ip route 0.0.0.0/0 192.168.0.1
no ip source-route
ip ssh version 2
ip http authentication local
ip http server
ip http secure-server
no ip igmp ssm-map query dns
ip nat settings central-policy
ip nat settings gatekeeper-size 1024
interface GigabitEthernet0/0/0
no shutdown
ip address 192.0.2.1 255.255.255.0
negotiation auto
exit
interface GigabitEthernet0/0/1
no shutdown
negotiation auto
exit
interface GigabitEthernet0/0/2
no shutdown
negotiation auto
exit
interface GigabitEthernet0/0/3
no shutdown
negotiation auto
exit
interface Tunnel0
no shutdown
ip unnumbered GigabitEthernet0/0/0
tunnel source GigabitEthernet0/0/0
tunnel mode sdwan
exit
aaa authentication login default local
aaa authorization exec default local
login on-success log
line con 0
login authentication default
stopbits 1
!
line vty 0 4
login authentication default
transport input ssh
!
line vty 5 80
login authentication default
transport input ssh
!
sdwan
interface GigabitEthernet0/0/0
tunnel-interface
encapsulation ipsec
color biz-internet
allow-service all
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
allow-service sshd
allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
no allow-service snmp
no allow-service bfd
exit
exit
!
omp
no shutdown
graceful-restart
no as-dot-notation
address-family ipv4
advertise connected
advertise static
!
address-family ipv6
advertise connected
advertise static
!
!
!
security
ipsec
authentication-type ah-sha1-hmac sha1-hmac
!
!
Cisco vEdge ソフトウェアにアップグレードするためのブートストラップファイルの例
この vedgemigration.cfg ブートストラップファイルは、GigabitEthernet インターフェイスを使用するデバイスに使用します。
system
host-name vedge
system-ip 10.0.0.1
site-id 2
control-session-pps 10000
no route-consistency-check
no vrrp-advt-with-phymac
organization-name YOUR-ORG
upgrade-confirm 15
vbond vbond.org.com
aaa
auth-order local radius tacacs
usergroup basic
task system read write
task interface read write
!
usergroup netadmin
!
usergroup operator
task system read
task interface read
task policy read
task routing read
task security read
!
usergroup tenantadmin
!
user admin
!
!
logging
disk
enable
!
!
ntp
master
no enable
stratum 5
exit
!
!
omp
no shutdown
graceful-restart
advertise connected
advertise static
!
security
ipsec
authentication-type ah-sha1-hmac sha1-hmac
!
!
vpn 0
interface ge0/0
ip address 192.0.2.1/24
ipv6 dhcp-client
tunnel-interface
encapsulation ipsec
color public-internet
allow-service all
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
no allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
!
no shutdown
!
interface ge0/1
no shutdown
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
vpn 512
!
Cisco IOS XE SD-WAN(セルラーインターフェイス)にアップグレードするためのブートストラップファイルの例
この ciscomigration.cfg ブートストラップファイルは、セルラー(LTE)インターフェイスを使用するデバイスに使用します。
(注) |
ciscomigration.cfg を使用してデバイス設定をロードする場合は、ブートストラップファイルで次のコマンドが必要となります。このコマンドがないと、デバイスにログインできない場合があります。
username admin privilege 15 secret 0 admin
|
system
system-ip 10.0.0.1
site-id 200
admin-tech-on-failure
organization-name spaal-LTE-Test
vbond vbond-dev-231945.viptela.info port 12346
!
memory free low-watermark processor 68335
no service tcp-small-servers
no service udp-small-servers
platform qfp utilization monitor load 80
hostname Routerusername admin privilege 15 secret 0 admin
controller Cellular 0/1/0
!
no ip finger
no ip rcmd rcp-enable
no ip rcmd rsh-enable
no ip dhcp use class
no ip source-route
ip ssh version 2
no ip http server
ip http secure-server
ip nat settings central-policy
ip nat settings gatekeeper-size 1024
interface GigabitEthernet0/0/0
shutdown
negotiation auto
exit
interface GigabitEthernet0/0/1
shutdown
negotiation auto
exit
interface GigabitEthernet0/0/2
shutdown
negotiation auto
exit
interface GigabitEthernet0/0/3
shutdown
negotiation auto
exit
interface Cellular0/1/0
no shutdown
ip address negotiated
ipv6 enable
exit
interface Cellular0/1/1
shutdown
ip address negotiated
exit
interface Tunnel0
no shutdown
ip unnumbered Cellular0/1/0
ipv6 unnumbered Cellular0/1/0
tunnel source Cellular0/1/0
tunnel mode sdwan
exit
no logging rate-limit
aaa authentication login default local
aaa authorization exec default local
login on-success log
line aux 0
login authentication default
!
line con 0
login authentication default
speed 115200
stopbits 1
!
line vty 0 4
login authentication default
transport input ssh
!
line vty 5 80
login authentication default
transport input ssh
!
sdwan
interface Cellular0/1/0
tunnel-interface
encapsulation ipsec
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
no allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
no allow-service snmp
no allow-service bfd
exit
exit
appqoe
no tcpopt enable
!
omp
no shutdown
graceful-restart
no as-dot-notation
address-family ipv4
advertise connected
advertise static
!
address-family ipv6
advertise connected
advertise static
!
!
!
licensing config enable false
licensing config privacy hostname false
licensing config privacy version false
licensing config utility utility-enable false
security
ipsec
authentication-type ah-sha1-hmac sha1-hmac
!
!
Cisco vEdge ソフトウェア(セルラーインターフェイス)にアップグレードするためのブートストラップファイルの例
この vedgemigration.cfg ブートストラップファイルは、セルラー(LTE)インターフェイスを使用するデバイスに使用します。
system
host-name vedge
system-ip 10.0.0.1
site-id 200
no daemon-restart
no daemon-reboot
no reboot-on-failure
admin-tech-on-failure
no route-consistency-check
no fp-buffer-check
no vrrp-advt-with-phymac
port-bp-threshold 32
fp-sw-bp-threshold 8192
sp-organization-name spaal-LTE-Test
fp-qos-interval 100
fp-qos-weight-percent-factor 100
organization-name spaal-LTE-Test
console-baud-rate 9600
vbond vbond-dev-231945.viptela.info
aaa
auth-order local radius tacacs
usergroup basic
task system read write
task interface read write
!
usergroup netadmin
!
usergroup operator
task system read
task interface read
task policy read
task routing read
task security read
!
user admin
password $6$siwKBQ==$wT2lUa9BSreDPI6gB8sl4E6PAJoVXgMbgv/whJ8F1C6sWdRazdxorYYTLrL6syiG6qnLABTnrE96HJiKF6QRq1
!
user ciscotacro
description CiscoTACReadOnly
group operator
status enabled
!
user ciscotacrw
description CiscoTACReadWrite
group netadmin
status enabled
!
!
logging
disk
enable
!
!
ntp
master
no enable
stratum 5
exit
!
support
zbfw-tcp-finwait-time 30
zbfw-tcp-idle-time 3600
zbfw-tcp-synwait-time 30
zbfw-udp-idle-time 30
!
!
omp
no shutdown
graceful-restart
advertise connected
advertise static
!
security
ipsec
authentication-type sha1-hmac ah-sha1-hmac
!
!
vpn 0
name "Transport VPN"
interface cellular0
ip dhcp-client
tunnel-interface
encapsulation ipsec
color lte
no allow-service bgp
allow-service dhcp
allow-service dns
allow-service icmp
no allow-service sshd
no allow-service netconf
no allow-service ntp
no allow-service ospf
no allow-service stun
allow-service https
!
mtu 1428
profile 0
no shutdown
!
!
vpn 512
name "Transport VPN"
!