- auto-summary (RIP)
- bfd all-interfaces
- default-information originate (RIP)
- default-metric (RIP)
- flash-update-threshold
- input-queue
- ip rip authentication key-chain
- ip rip authentication mode
- ip rip initial-delay
- ip rip receive version
- ip rip send version
- ip rip triggered
- ip rip v2-broadcast
- ip split-horizon (RIP)
- ip summary-address rip
- neighbor (RIP)
- network (RIP)
- offset-list (RIP)
- output-delay
- router rip
- service-module ip rip relay
- show ip rip database
- show ip rip neighbors
- skeptical interval
- throttle (router configuration)
- timers basic (RIP)
- validate-update-source
- version
Routing Information Protocol Commands
auto-summary (RIP)
To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.
auto-summary
no auto-summary
Syntax Description
This command has no arguments or keywords.
Command Default
Enabled (the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries).
Command Modes
Router configuration
Command History
Usage Guidelines
Route summarization reduces the amount of routing information in the routing tables.
RIP Version 1 always uses automatic summarization. If you are using RIP Version 2, you can turn off automatic summarization by specifying the no auto-summary command. Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised.
Examples
In the following example, network numbers are not summarized automatically:
router rip
version 2
no auto-summary
bfd all-interfaces
To enable Bidirectional Forwarding Detection (BFD) for all interfaces participating in the routing process, use the bfd all-interfaces command in router configuration or address-family interface configuration mode. To disable BFD for all neighbors on a single interface, use the no form of this command.
bfd all-interfaces
no bfd all-interfaces
Syntax Description
This command has no arguments or keywords.
Command Default
BFD is disabled on the interfaces participating in the routing process.
Command Modes
Router configuration (config-router) and address-family interface configuration (config-router-af)
Command History
Usage Guidelines
There are two methods to configure routing protocols to use BFD for failure detection. To enable BFD for all interfaces, enter the bfd all-interfaces command in router configuration mode. In Cisco IOS Release 12.4(24)T, Cisco IOS 12.2(33)SRA and earlier releases, the bfd all-interfaces command works in router configuration mode and address-family interface mode.
In Cisco IOS Release 15.0(1)M and later releases, the bfd all-interfaces command in named router configuration mode is replaced by the bfd command in address-family interface configuration mode. Use the bfd command in address-family interface configuration mode to achieve the same functionality as that of the bfd all interfaces command in router configuration mode.
Examples
The following example shows how to enable BFD for all Enhanced Interior Gateway Routing Protocol (EIGRP) neighbors:
Router> enable
Router# configure terminal
Router(config)# router eigrp 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end
The following example shows how to enable BFD for all Intermediate System-to-Intermediate System (IS-IS) neighbors:
Router> enable
Router# configure terminal
Router(config)# router isis tag1
Router(config-router)# bfd all-interfaces
Router(config-router)# end
The following example shows how to enable BFD for all Open Shortest Path First (OSPF) neighbors:
Router> enable
Router# configure terminal
Router(config)# router ospf 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end
The following example shows how to enable BFD for all EIGRP neighbors, using the bfd command in address-family interface configuration mode:
Router> enable
Router# configure terminal
Router(config)# router eigrp my_eigrp
Router(config-router)# address-family ipv4 autonomous-system 100
Router(config-router-af)# af-interface FastEthernet 0/0
Router(config-router-af-interface)# bfd
The following example shows how to enable BFD for all Routing Information Protocol (RIP) neighbors:
Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# bfd all-interfaces
Router(config-router)# end
Related Commands
|
|
---|---|
bfd |
Sets the baseline BFD session parameters on an interface. |
default-information originate (RIP)
To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.
default-information originate [on-passive | route-map map-name]
no default-information originate
Syntax Description
Command Default
No default routes are generated into RIP.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
The route map referenced in the default-information originate command cannot use an extended access list; it can use a standard access list.
When you configure the default-information originate on-passive command, RIP sends the default route on a passive interface. A default route is the network route with which a router communicates when no other known route exists for a given IP packet's destination address. Before a RIP provider edge (PE) router can send the default route to the customer edge (CE) router, you must configure the interfaces facing the CE as passive interfaces by using the default-information originate on-passive command.
Once you configure the default-information originate on-passive command, the output of the show ip protocols command displays that RIP default routes are sent on passive interfaces.
Applying a condition to determine when the default route is originated is called conditional default origination.
Examples
The following example shows how to originate a default route (0.0.0.0/0) over a certain interface when 172.17.0.0/16 is present. In this example a route map condition is applied.
router rip
version 2
network 172.17.16.0
default-information originate route-map condition
!
route-map condition permit 10
match ip address 10
set interface s1/0
!
access-list 10 permit 172.17.16.0 0.0.0.255
!
Related Commands
default-metric (RIP)
To set default metric values for Routing Information Protocol (RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.
default-metric number-value
no default-metric [number-value]
Syntax Description
number-value |
Default metric value. |
Defaults
Built-in, automatic metric translations, as appropriate for each routing protocol
Command Modes
Router configuration
Command History
Usage Guidelines
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.
Examples
The following example shows a router in autonomous system 109 using both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10.
router rip
default-metric 10
redistribute ospf 109
Related Commands
|
|
redistribute (IP) |
Redistributes routes from one routing domain into another routing domain. |
flash-update-threshold
To suppress regularly scheduled flash updates, use the flash-update-threshold command in router configuration mode. To return to the default state, use the no form of this command.
flash-update-threshold seconds
no flash-update-threshold
Syntax Description
seconds |
The time interval in seconds for which the suppression of flash updates can be configured. The range is from 1 to 30 seconds. |
Defaults
This command is disabled by default.
Command Modes
Router configuration
Command History
Usage Guidelines
This command suppresses flash updates when the arrival of a regularly scheduled update matches the number of seconds that is configured with the seconds argument. The range of seconds that can be configure is from 0 to 30 seconds. If the number of seconds matches the number of seconds or is less than the number seconds that is configured with the seconds argument, the flash update is suppressed. If the numbers seconds until the flash update arrives exceeds the number of seconds that is configured with the seconds argument, the flash update is not suppressed. The regular scheduled interval for flash updates and the configuration of the suppression of flash updates can be verified with the show ip protocol command.
Examples
The following example configures a router to suppress a regularly scheduled flash update if the update is due in 10 seconds or less:
router rip
flash-update-threshold 10
Related Commands
|
|
show ip protocols |
Displays the parameters and current state of the active routing protocol process. |
input-queue
The input-queue command defines the number of received, but not yet processed RIP update packets contained in the Routing Information Protocol (RIP) input queue. Use the input-queue command in router configuration mode. To remove the configured depth and restore the default depth, use the no form of this command.
input-queue depth
no input-queue
Syntax Description
Defaults
A depth of 50.
Command Modes
Router configuration
Command History
Usage Guidelines
Consider using the input-queue command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.
Another way to prevent the routing table from losing information is to use the output-delay command to change the interpacket delay for RIP updates.
Examples
The following example sets the depth of the RIP input queue to 100:
router rip
input-queue 100
Related Commands
|
|
output-delay |
Changes the interpacket delay for RIP updates sent. |
ip rip authentication key-chain
To enable authentication for Routing Information Protocol (RIP) Version 2 packets and to specify the set of keys that can be used on an interface, use the ip rip authentication key-chain command in interface configuration mode. To prevent authentication, use the no form of this command.
ip rip authentication key-chain name-of-chain
no ip rip authentication key-chain [name-of-chain]
Syntax Description
name-of-chain |
Enables authentication and specifies the group of keys that are valid. |
Defaults
No authentication is provided for RIP packets.
Command Modes
Interface configuration
Command History
Usage Guidelines
If no key chain is configured with the key-chain command, no authentication is performed on the interface (not even the default authentication).
Examples
The following example configures the interface to accept and send any key belonging to the key chain named trees:
ip rip authentication key-chain trees
Related Commands
|
|
key chain |
Enables authentication for routing protocols. |
ip rip authentication mode
To specify the type of authentication used in Routing Information Protocol (RIP) Version 2 packets, use the ip rip authentication mode command in interface configuration mode. To restore clear text authentication, use the no form of this command.
ip rip authentication mode {text | md5}
no ip rip authentication mode
Syntax Description
text |
Clear text authentication. |
md5 |
Keyed Message Digest 5 (MD5) authentication. |
Defaults
Clear text authentication is provided for RIP packets.
Command Modes
Interface configuration
Command History
Usage Guidelines
RIP Version 1 does not support authentication.
Examples
The following example configures the interface to use MD5 authentication:
ip rip authentication mode md5
Related Commands
ip rip initial-delay
To delay the initiation of RIPv2 neighbor sessions using MD5 authentication until the network connectivity between the neighbor routers is fully operational, use the ip rip initial-delay command in interface, or subinterface configuration mode. To remove the configured delay, use the no form of this command.
ip rip initial-delay delay
no ip rip initial-delay
Syntax Description
delay |
The number of seconds to wait before sending the first MD5 authentication packet to the RIPv2 neighbor. The range is from 0 to 1800. |
Command Default
The delay of RIPv2 neighbor sessions is not configured.
Command Modes
Interface configuration (config-if)
Subinterface configuration (config-subif)
Command History
|
|
---|---|
12.4(12) |
This command was introduced. |
Cisco IOS XE Release 2.6 |
This command was integrated into Cisco IOS XE Release 2.6. |
Usage Guidelines
Some non-Cisco routers will not allow an MD5-authenticated RIPv2 neighbor session to start when the sequence number of the first MD5 packet received from the Cisco router is greater than 0. The IP-RIP Delay Start feature is used on Cisco routers to delay the initiation of RIPv2 neighbor sessions using MD5 authentication until the network connectivity between the neighbor routers is fully operational. This ensures the sequence number of the first MD5 packet that the router sends to the non-Cisco neighbor router is 0.
Examples
The following example configures the router to wait 45 seconds before sending the first MD5 authentication packet to a non-Cisco device:
Router(config)# interface POS 0/1/0
Router(config-subif)# ip rip initial-delay 45
Related Commands
ip rip receive version
To specify a Routing Information Protocol (RIP) version to receive on an interface basis, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.
ip rip receive version [1] [2]
no ip rip receive version
Syntax Description
1 |
(Optional) Accepts only RIP Version 1 packets on the interface. |
2 |
(Optional) Accepts only RIP Version 2 packets on the interface. |
Defaults
This command is disabled by default.
Command Modes
Interface configuration
Command History
Usage Guidelines
Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.
Examples
The following example configures the interface to receive both RIP Version 1 and Version 2 packets:
ip rip receive version 1 2
The following example configures the interface to receive only RIP Version 1 packets:
ip rip receive version 1
Related Commands
ip rip send version
To specify a Routing Information Protocol (RIP) version to send on an interface basis, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.
ip rip send version [1] [2]
no ip rip send version
Syntax Description
1 |
(Optional) Sends only RIP Version 1 packets out the interface. |
2 |
(Optional) Sends only RIP Version 2 packets out the interface. |
Defaults
This command is disabled by default.
Command Modes
Interface configuration
Command History
Usage Guidelines
Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured.
Examples
The following example configures the interface to send both RIP Version 1 and Version 2 packets out the interface:
ip rip send version 1 2
The following example configures the interface to send only RIP Version 2 packets out the interface:
ip rip send version 2
Related Commands
|
|
ip rip receive version |
Specifies a RIP version to receive on an interface basis. |
version |
Specifies a RIP version used globally by the router. |
ip rip triggered
To enable triggered extensions to Routing Information Protocol (RIP), use the ip rip triggered command in interface configuration mode. To disable triggered extensions to RIP, use the no form of this command.
ip rip triggered
no ip rip triggered
Syntax Description
This command has no arguments or keywords.
Defaults
This command is disabled by default.
Command Modes
Interface configuration
Command History
Usage Guidelines
When triggered extensions to RIP are enabled, routing updates are sent on the WAN only if one of the following events occurs:
•The router receives a specific request for a routing update. (Full database is sent.)
•Information from another interface modifies the routing database. (Only latest changes are sent.)
•The interface comes up or goes down. (Partial database is sent.)
•The router is first powered on, to ensure that at least one update is sent. (Full database is sent.)
You might want to enable this feature if you are using an on-demand circuit and you are charged for usage time. Fewer routing updates will incur lower usage costs.
Entries in the routing database can be either temporary or semipermanent. Entries learned from broadcasts on LANs are temporary; they will expire if not periodically refreshed by more broadcasts.
Entries learned from a triggered response on the WAN are semipermanent; they do not time out like other entries. Certain events can cause these routes to time out, such as the interface going down, or if the outgoing interface is the same as the incoming interface. Neighbor updates of the routes with a metric of 16 (infinity) mean the route is unreachable, and those routes are eventually removed from the routing table.
Examples
The following example enables triggered extensions to RIP:
interface serial 0
ip rip triggered
Related Commands
|
|
show ip rip database |
Displays the contents of the RIP private database when triggered extensions to RIP are enabled. |
ip rip v2-broadcast
To allow Routing Information Protocol (RIP) Version 2 update packets to be sent as broadcast packets instead of multicast packets, use the ip rip v2-broadcast command in interface configuration mode. To disable the broadcast of IP RIP Version 2 update packets that are sent as broadcast packets, use the no form of this command.
ip rip v2-broadcast
no ip rip v2-broadcast
Syntax Description
This command has no arguments or keywords.
Command Default
This command is disabled by default. Unless the ip rip v2-broadcast commend is entered, RIP Version 2 update packets are sent as multicast packets.
Command Modes
Interface configuration (config-if)
Command History
Usage Guidelines
Use the ip rip v2-broadcast command to broadcast RIP Version 2 broadcast updates to hosts that do not listen to multicast broadcasts. Version 2 updates (requests and responses) will be sent to the IP broadcast address 255.255.255.255 instead of the IP multicast address 224.0.0.9.
In order to reduce unnecessary load on those hosts that are not listening to RIP Version 2 broadcasts, the system uses an IP multicast address for periodic broadcasts. The IP multicast address is 224.0.0.9.
Note It is not necessary to configure Internet Group Management Protocol (IGMP) because the periodic broadcasts are interrouter messages that are not forwarded.
Examples
The following example configures Version 2 IP broadcast updates on RIP Ethernet interface 3/1:
Router(config) interface ethernet3/1
Router(config-if) ip address 172.16.1.1 255.255.255.0
Router(config-if) ip rip v2-broadcast
.
.
.
Router(config-if) router rip
Router(config-if) version 2
Router(config-if) network 172.0.0.0
Enter debug ip rip command to verify that RIP Version 2 IP broadcast updates are being sent to the IP broadcast address 255.255.255 instead of IP multicast address 224.0.0.9:
Router# debug ip rip
14:41:59: RIP: sending v2 update to 255.255.255.255 via Ethernet3/1 (172.16.1.1)
If the ip rip v2-broadcast command has not been entered, the output from the debug ip rip command verifies that the RIP Version 2 IP broadcast updates are being sent to the IP multicast address 224.0.0.9:
Router# debug ip rip
15:45:16: RIP: sending v2 update to 224.0.0.9 via Ethernet3.1 (172.16.1.1)
Related Commands
|
|
---|---|
debug ip rip |
Displays information on RIP routing transactions. |
ip split-horizon (RIP)
To enable the split horizon mechanism, use the ip split-horizon command in interface configuration mode. To disable the split horizon mechanism, use the no form of this command.
ip split-horizon
no ip split-horizon
Syntax Description
This command has no arguments or keywords.
Defaults
Default behavior varies with media type.
Command Modes
Interface configuration
Command History
Usage Guidelines
For all interfaces except those for which either Frame Relay or Switched Multimegabit Data Service (SMDS) encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds command, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.
Note For networks that include links over X.25 packet switched networks (PSNs), the neighbor router configuration command can be used to defeat the split horizon feature. You can as an alternative explicitly specify the no ip split-horizon command in your configuration. However, if you do so you must similarly disable split horizon for all routers in any relevant multicast groups on that network.
Note If split horizon has been disabled on an interface and you want to enable it, use the ip split-horizon command to restore the split horizon mechanism.
Note In general, changing the state of the default for the ip split-horizon command is not recommended, unless you are certain that your application requires a change in order to properly advertise routes. If split horizon is disabled on a serial interface (and that interface is attached to a PSN), you must disable split horizon for all routers and access servers in any relevant multicast groups on that network.
Examples
The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network.
interface serial 0
encapsulation x25
no ip split-horizon
Related Commands
|
|
neighbor (RIP) |
Defines a neighboring router with which to exchange routing information. |
ip summary-address rip
To configure a summary aggregate address under an interface for the Routing Information Protocol (RIP), use the ip summary-address rip command in interface configuration mode. To disable summarization of the specified address or subnet, use the no form of this command.
ip summary-address rip ip-address ip-network-mask
no ip summary-address rip ip-address ip-network-mask
Syntax Description
ip-address |
IP address to be summarized. |
ip-network-mask |
IP network mask that drives route summarization for the specified IP address. |
Command Default
RIP automatically summarizes to classful network boundaries.
Command Modes
Interface configuration
Command History
Usage Guidelines
The ip summary-address rip command is used to summarize an address or subnet under a specific interface. RIP automatically summarizes to classful network boundaries. Only one summary address can be configured for each classful subnet.
Examples
In the following example the major network is 10.0.0.0. The summary address 10.2.0.0 overrides the autosummary address of 10.0.0.0, so that 10.2.0.0 is advertised out Ethernet interface 1 and 10.0.0.0 is not advertised.
Note If split horizon is enabled, neither autosummary nor interface summary addresses (those configured with the ip summary-address rip command) are advertised.
interface Ethernet1
ip address 10.1.1.1 255.255.255.0
ip summary-address rip 10.2.0.0 255.255.0
exit
router rip
network 10.0.0.0
end
Related Commands
|
|
auto-summary (RIP) |
Restores the default behavior of automatic summarization of subnet routes into network-level routes. |
ip split-horizon (RIP) |
Enables the split horizon mechanism. |
neighbor (RIP)
To define a neighboring router for exchanging routing information, use the neighbor command in router configuration mode. To remove a neighboring router entry, use the no form of this command.
neighbor ip-address [bfd]
no neighbor ip-address [bfd]
Syntax Description
ip-address |
IP address of a peer router with which the routing information is exchanged. |
bfd |
(Optional) Sets the baseline Bidirectional Forwarding Detection (BFD) session parameters on an interface. |
Command Default
No neighboring routers are defined.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
This command permits point-to-point (nonbroadcast) exchange of routing information. When it is used in combination with the passive-interface command, routing information can be exchanged between a subset of routers and access servers on a LAN.
Use multiple neighbor commands to specify additional neighbors or peers.
Examples
In the following example, RIP updates are sent to all interfaces on network 10.108.0.0 except Ethernet interface 1. However, in this case, a neighbor router configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor.
Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# network 10.108.0.0
Router(config-router)# passive-interface Ethernet 1
Router(config-router)# neighbor 10.108.20.4
Router(config-router)# end
The following example shows how to enable BFD for RIP neighbors:
Router> enable
Router# configure terminal
Router(config)# neighbor 10.0.0.1 bfd
Router(config-router)# end
Related Commands
|
|
passive-interface |
Disables sending routing updates on an interface. |
network (RIP)
To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.
network ip-address
no network ip-address
Syntax Description
ip-address |
IP address of the network of directly connected networks. |
Defaults
No networks are specified.
Command Modes
Router configuration
Command History
Usage Guidelines
The network number specified must not contain any subnet information. There is no limit to the number of network commands you can use on the router. RIP routing updates will be sent and received only through interfaces on this network.
RIP sends updates to the interfaces in the specified networks. Also, if the network of an interface is not specified, the interface will not be advertised in any RIP update.
Examples
The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0:
router rip
network 10.99.0.0
network 192.168.7.0
Related Commands
|
|
router rip |
Configures the RIP routing process. |
offset-list (RIP)
To add an offset to incoming and outgoing metrics to routes learned via Routing Information Protocol (RIP), use the offset-list command in router configuration mode. To remove an offset list, use the no form of this command.
offset-list {access-list-number | access-list-name} {in | out} offset [interface-type interface-number]
no offset-list {access-list-number | access-list-name} {in | out} offset [interface-type interface-number]
Syntax Description
Defaults
This command is disabled by default.
Command Modes
Router configuration
Command History
Usage Guidelines
The offset value is added to the routing metric. An offset list with an interface type and interface number is considered extended and takes precedence over an offset list that is not extended. Therefore, if an entry passes the extended offset list and the normal offset list, the offset of the extended offset list is added to the metric.
Examples
In the following example, the router applies an offset of 10 to the delay component of a router only to access list 21:
offset-list 21 out 10
In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:
offset-list 21 in 10 ethernet 0
output-delay
To change the interpacket delay for Routing Information Protocol (RIP) updates sent, use the output-delay command in router configuration mode. To remove the delay, use the no form of this command.
output-delay delay
no output-delay
Syntax Description
delay |
Delay between packets in a multiple-packet RIP update (in milliseconds). The range is from 8 to 50. The default is 0. |
Command Default
The default interpacket delay is 0 milliseconds.
Command Modes
Router configuration
Command History
Usage Guidelines
Consider using this command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.
Examples
The following example sets the interpacket delay to 10 milliseconds:
router rip
output-delay 10
router rip
To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.
router rip
no router rip
Syntax Description
This command has no arguments or keywords.
Command Default
No RIP routing process is defined.
Command Modes
Global configuration
Command History
Examples
The following example shows how to begin the RIP routing process:
router rip
Related Commands
|
|
network (RIP) |
Specifies a list of networks for the RIP process. |
service-module ip rip relay
To enable the delivery of RIP update messages from a Cisco IOS router containing an integrated cable modem or a cable modem HWIC to a Hybrid Fiber-Coaxial (HFC) CMTS when they are on different subnets, use the service-module ip rip relay command in interface configuration mode. To disable RIP relay, use the no form of this command.
service-module ip rip relay
no service-module ip rip relay
Syntax Description
This command has no keywords or arguments.
Command Default
RIP relay is disabled.
Command Modes
Interface configuration (config-if)
Command History
|
|
---|---|
12.4(15)XY |
This command was introduced. |
12.4(20)T |
This command was integrated into Cisco IOS Release 12.4(20)T. |
Usage Guidelines
The service-module ip rip relay command is used to enable the HFC RIP Relay feature that allows the delivery of RIP messages from a Cisco IOS router containing an integrated cable modem or a cable modem High-Speed WAN Interface Card (HWIC) to the Cable Modem Termination system (CMTS) when they are on different subnets. In Cisco IOS releases prior to 12.4(15)XY and 12.4(20)T, RIP messages were rejected by the CMTS because the interface on the Cisco IOS router was in a different subnet from the CMTS.
Examples
The following example enables RIP relay on an Integrated Services Router (ISR) cable modem. A static IP address is configured for the cable modem interface, and RIP relay is enabled on the interface. To allow RIP updates from unknown sources, the normal validation of the source IP address of incoming RIP routing updates is disabled. RIP is defined as the routing protocol to be used on all interfaces that are connected to networks 10.0.0.0 and 172.18.0.0.
interface Cable-Modem0/3/0
ip address 10.5.5.5 255.255.255.0
service-module ip rip relay
exit
router rip
version 2
no validate-update-source
network 10.0.0.0
network 172.18.0.0
Related Commands
|
|
---|---|
show controllers |
Displays information that is specific to the hardware. |
show ip rip database
To display summary address entries in the Routing Information Protocol (RIP) routing database entries if relevant are routes being summarized based upon a summary address, use the show ip rip database command in privileged EXEC mode.
show ip rip database [ip-address mask]
Syntax Description
Command Default
No default behavior or values.
Command Modes
Privileged EXEC
Command History
Usage Guidelines
Summary address entries will appear in the database only if relevant child routes are being summarized. When the last child route for a summary address becomes invalid, the summary address is also removed from the routing table.
The RIP private database is populated only if triggered extensions to RIP are enabled with the ip rip triggered command.
Examples
The following output shows a summary address entry for route 10.11.0.0/16, with three child routes active:
Router# show ip rip database
10.0.0.0/8 auto-summary
10.11.11.0/24 directly connected, Ethernet2
10.1.0.0/8 auto-summary
10.11.0.0/16 int-summary
^^^^^^^^^^^^^^^^^^^^^^^^^^^
10.11.10.0/24 directly connected, Ethernet3
10.11.11.0/24 directly connected, Ethernet4
10.11.12.0/24 directly connected, Ethernet5
The following is sample output from the show ip rip database command with a prefix and mask:
Router# show ip rip database 172.19.86.0 255.255.255.0
172.19.86.0/24
[1] via 172.19.67.38, 00:00:25, Serial0
[2] via 172.19.70.36, 00:00:14, Serial1
Table 8 describes the fields in the display.
Related Commands
show ip rip neighbors
To display Routing Information Protocol (RIP) neighbors for which Bidirectional Forwarding Detection (BFD) sessions are created, use the show ip rip neighbors command in privileged EXEC mode.
show ip rip neighbors
Syntax Description
This command has no argument or keywords.
Command Modes
Privileged EXEC (#)
Command History
|
|
---|---|
Cisco IOS XE Release 3.3 |
This command was introduced. |
15.1(2)S |
This command was integrated into Cisco IOS Release 15.1(2)S. |
Usage Guidelines
Use the show ip rip neighbors command to display RIP neighbors for which BFD sessions are created.
Examples
The following is sample output from the show ip rip neighbors command:
Router# show ip rip neighbors
BFD sessions created for the RIP neighbors
Neighbor Interface SessionHandle
10.10.10.2 Ethernet0/0 1
10.10.20.2 Ethernet1/0 2
Table 9 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show ip rip database |
Displays summary address entries in the RIP database. |
skeptical interval
To configure cautious Cisco nonstop forwarding (NSF) helper functionality with a neighbor with an interval, use the skeptical interval command in router configuration mode. To configure a cautious NSF helper with the default interval, use the no form of this command.
skeptical interval minutes
no skeptical interval
Syntax Description
minutes |
Number of minutes for the interval. Range: 0 to 1440. Default: 5. |
Command Default
The default interval for configuring an NSF helper is 5 minutes.
Command Modes
Router configuration (config-router)
Command History
|
|
---|---|
12.2(33)SXI |
This command was introduced. |
Usage Guidelines
When the skeptical interval command is configured with an interval, NSF will not be supported with the neighbor during this period. If you configure the skeptical interval 0 command, it means that you always support NSF with the neighbor. Whenever you configure the skeptical interval command, you should also configure the nsf interval command.
Examples
The following example configures the skeptical interval to 30 minutes:
Router(config)# router isis
Router(config-router)# skeptical interval 30
Related Commands
throttle (router configuration)
To enable throttle for Routing Information Protocol (RIP) requests, use the throttle command in router configuration mode. To disable the configuration, use the no form of this command.
throttle
no throttle
Syntax Description
This command has no arguments or keywords.
Command Default
Throttle is not enabled by default.
Command Modes
Router configuration (config-router)
Command History
|
|
---|---|
12.2(31)SB14 |
This command was introduced. |
Usage Guidelines
You can use the throttle command if you are using RIP as a routing protocol to serve a large number of routers. This command prevents RIP from generating update packets in response to RIP requests from a faulty neighbor. Because only one RIP request per minute will be serviced from a neighbor, incoming regular updates are less likely to be dropped.
You can configure the throttle command only when the interpacket delay is configured using the output-delay command.
Examples
The following example shows how to enable throttle for RIP requests:
Router# configure terminal
Router(config-router)# network 192.0.2.1
Router(config-router)# output-delay 20
Router(config-router)# throttle
Related Commands
|
|
---|---|
output-delay |
Changes the interpacket delay for RIP updates sent. |
timers basic (RIP)
To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.
timers basic update invalid holddown flush
no timers basic
Syntax Description
Command Default
No RIP network timers are adjusted.
Command Modes
Router configuration
Command History
Usage Guidelines
The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.
Note The current and default timer values can be seen by inspecting the output of the show ip protocols EXEC command. The relationships of the various timers should be preserved as described previously.
In addition, an address family can have explicitly specified timers that apply to that address-family (or VRF) only. The timers basic command must be specified for an address family or the system defaults for the timers basic command are used regardless of what is configured for RIP routing. The VRF does not inherit the timer values from the base RIP configuration. The VRF will always use the system default timers unless explicitly changed using the timers basic command.
Examples
The following example sets updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.
router rip
timers basic 5 15 15 30
Note By setting a short update period, you run the risk of congesting slow-speed serial lines. A short update period can be a concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.
The following example show adjusting address family timers.
router rip
version 2
timers basic 5 10 15 20
redistribute connected
network 5.0.0.0
default-metric 10
no auto-summary
!
address-family ipv4 vrf foo
timers basic 10 20 20 20
redistribute connected
network 10.0.0.0
default-metric 5
no auto-summary
version 2
exit-address-family
!
address-family ipv4 vrf bar
timers basic 20 40 60 80
redistribute connected
network 20.0.0.0
default-metric 2
no auto-summary
version 2
exit-address-family
!
validate-update-source
To have the Cisco IOS software validate the source IP address of incoming routing updates for Routing Information Protocol (RIP) and Interior Gateway Routing Protocol (IGRP) routing protocols, use the validate-update-source command in router configuration mode. To disable this function, use the no form of this command.
validate-update-source
no validate-update-source
Syntax Description
This command has no arguments or keywords.
Defaults
The behavior of this command is enabled by default.
Command Modes
Router configuration
Command History
Usage Guidelines
This command is applicable only to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.
Disabling split horizon on the incoming interface will also cause the system to perform this validation check.
For unnumbered IP interfaces (interfaces configured as IP unnumbered), no checking is performed.
Examples
The following example configures a router not to perform validation checks on the source IP address of incoming RIP updates:
router rip
network 10.105.0.0
no validate-update-source
version
To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.
version {1 | 2}
no version
Syntax Description
1 |
Specifies RIP Version 1. |
2 |
Specifies RIP Version 2. |
Command Default
The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.
Command Modes
Router configuration
Command History
Usage Guidelines
To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.
Examples
The following example enables the software to send and receive RIP Version 2 packets:
version 2