- set metric (EIGRP)
- show eigrp address-family accounting
- show eigrp address-family events
- show eigrp address-family interfaces
- show eigrp address-family neighbors
- show eigrp address-family timers
- show eigrp address-family topology
- show eigrp address-family traffic
- show eigrp plugins
- show eigrp protocols
- show eigrp tech-support
- show ip eigrp accounting
- show ip eigrp events
- show ip eigrp interfaces
- show ip eigrp neighbors
- show ip eigrp topology
- show ip eigrp traffic
- show ip eigrp vrf accounting
- show ip eigrp vrf interfaces
- show ip eigrp vrf neighbors
- show ip eigrp vrf topology
- show ip eigrp vrf traffic
- shutdown (address-family)
- split-horizon (EIGRP)
- stub
- summary-address (EIGRP)
- summary-metric
- timers active-time
- timers graceful-restart purge-time
- timers nsf converge
- timers nsf route-hold
- timers nsf signal
- topology (EIGRP)
- traffic-share balanced
- variance (EIGRP)
set metric (EIGRP)
To set the metric value for Enhanced Interior Gateway Routing Protocol (EIGRP) in a route map, use the set metric route-map configuration command. To return to the default metric value, use the no form of this command.
set metric bandwidth delay reliability loading mtu
no set metric bandwidth delay reliability loading mtu
Syntax Description
Defaults
No metric will be set in the route map.
Command Modes
Route-map configuration (config-route-map)
Command History
Usage Guidelines
We recommend you consult your Cisco technical support representative before changing the default value.
Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The set route-map configuration commands specify the redistribution set actions to be performed when all of the match criteria for a router are met. When all match criteria are met, all set actions are performed.
Examples
The following example sets the bandwidth to 10,000, the delay to 10, the reliability to 255, the loading to 1, and the MTU to 1500:
Router(config-route-map)# set metric 10000 10 255 1 1500
show eigrp address-family accounting
To display prefix accounting information for Enhanced Interior Gateway Routing Protocol (EIGRP) processes, use the show eigrp address-family accounting command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] accounting
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command Default
Prefix accounting information for all EIGRP processes is displayed.
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp accounting command. Cisco recommends using the show eigrp address-family accounting command.
Examples
The following example shows how to display EIGRP prefix accounting information for autonomous-system 22:
Router# show eigrp address-family ipv4 22 accounting
EIGRP-IPv4 VR(saf) Accounting for AS(22)/ID(10.0.0.1)
Total Prefix Count: 3 States: A-Adjacency, P-Pending, D-Down
State Address/Source Interface Prefix Restart Restart/
Count Count Reset(s)
A 10.0.0.2 Et0/0 2 0 0
P 10.0.2.4 Se2/0 0 2 114
D 10.0.1.3 Et0/0 0 3 0
Table 3 describes the significant fields shown in the display.
Related Commands
show eigrp address-family events
To display information about Enhanced Interior Gateway Routing Protocol (EIGRP) address-family events, use the show eigrp address-family events command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] events [starting-event-number ending-event-number] [errmsg [starting-event-number ending-event-number]] [sia [starting-event-number ending-event-number]] [type]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command Default
All EIGRP address-family events are displayed.
Command History
Usage Guidelines
The event log is used by Cisco technical support to display a history of EIGRP internal events that are specific to a particular address family.
To display information about EIGRP service-family events, use the show eigrp service-family events command.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp events command. Cisco recommends using the show eigrp address-family events command.
Examples
The following example shows how to display EIGRP address-family events for autonomous-system 3:
Router# show eigrp address-family ipv4 3 events
Event information for AS 3:
1 15:37:47.015 Change queue emptied, entries: 1
2 15:37:47.015 Metric set: 10.0.0.0/24 307200
3 15:37:47.015 Update reason, delay: new if 4294967295
4 15:37:47.015 Update sent, RD: 10.0.0.0/24 4294967295
5 15:37:47.015 Update reason, delay: metric chg 4294967295
6 15:37:47.015 Update sent, RD: 10.0.0.0/24 4294967295
7 15:37:47.015 Route installed: 10.0.0.0/24 1.1.1.2
8 15:37:47.015 Route installing: 10.0.0.0/24 10.0.1.2
Related Commands
show eigrp address-family interfaces
To display information about interfaces that are configured for Enhanced Interior Gateway Routing Protocol (EIGRP), use the show eigrp address-family interfaces command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] interfaces [detail] [interface-type interface-number]
Syntax Description
Command Default
All enabled EIGRP interfaces are displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp address-family interfaces command to determine on which interfaces EIGRP is active and to learn EIGRP information about those interfaces.
If an interface is specified, only information about that interface is displayed. Otherwise, information about all interfaces on which EIGRP is running is displayed.
If an autonomous system is specified, only the routing process for the specified autonomous system is displayed. Otherwise, all EIGRP processes are displayed.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp interfaces command. Cisco recommends using the show eigrp address-family interfaces command.
Examples
The following example shows how to display information about EIGRP interfaces for autonomous-system 4453:
Router# show eigrp address-family ipv4 4453 interfaces
EIGRP-IPv4 VR(Virtual-name) Address-family Neighbors for AS(4453)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Services
Se0 1 0/0 28 0/15 127 0
Se1 1 0/0 44 0/15 211 0
The following example shows how to display detailed information about Loopback interface 1 in autonomous-system 2:
Router# show eigrp address-family ipv4 2 interfaces detail Loopback1
EIGRP-IPv4 VR(saf2) Address-family Neighbors for AS(2)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Services
Lo1 166 0/0 48 0/1 258 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 10148/67233
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 8719
Retransmissions sent: 2696 Out-of-sequence rcvd: 594
Interface has all stub peers
Topology-ids on interface - 0
Authentication mode is not set
Table 4 describes the significant fields shown in the display.
Related Commands
show eigrp address-family neighbors
To display the neighbors that are discovered by Enhanced Interior Gateway Routing Protocol (EIGRP), use the show eigrp address-family neighbors command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] neighbors [static] [detail] [interface-type interface-number]
Syntax Description
Command Default
Information about all neighbors discovered by EIGRP is displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp address-family neighbors command to determine when neighbors become active and inactive. It is also useful for debugging certain types of transport problems.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp neighbors command. Cisco recommends using the show eigrp address-family neighbors command.
Examples
The following example shows how to display neighbors that are discovered by EIGRP:
Router# show eigrp address-family ipv4 4453 neighbors
EIGRP-IPv4 VR(Virtual-name) Address-family Neighbors for AS(4453)
Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) (ms) Cnt Num
172.16.81.28 Ethernet1 13 0:00:41 0 11 4 20
172.16.80.28 Ethernet0 14 0:02:01 0 10 12 24
172.16.80.31 Ethernet0 12 0:02:02 0 4 5 20
Table 5 describes the significant fields shown in the display.
The following example shows how to display detailed information about neighbors that are discovered by EIGRP, including whether a neighbor has been gracefully restarted:
Router# show eigrp address-family ipv4 neighbors detail
EIGRP-IPv4 VR(test) Address-Family Neighbors for AS(3)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
172.16.81.28 Et1/1 11 01:11:08 10 200 0 8
Time since Restart 00:00:05
Version 5.0/3.0, Retrans: 2, Retries: 0, Prefixes: 2
Topology-ids from peer - 0
Related Commands
show eigrp address-family timers
To display information about Enhanced Interior Gateway Routing Protocol (EIGRP) timers and expiration times, use the show eigrp address-family timers command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] timers
Syntax Description
Command Default
Information about all EIGRP timers is displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
This command is useful for debugging and troubleshooting by Cisco technical support, but it is not intended for normal EIGRP administration tasks. This command should not be used without guidance from Cisco technical support.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp timers command. Cisco recommends using the show eigrp address-family timers command.
Examples
The following example shows how to display information about EIGRP timers:
Router# show eigrp address-family ipv4 4453 timers
EIGRP-IPv4 VR(Virtual-name) Address-family Timers for AS(4453)
Hello Process
Expiration Type
| 1.022 (parent)
| 1.022 Hello (Et0/0)
Update Process
Expiration Type
| 14.984 (parent)
| 14.984 (parent)
| 14.984 Peer holding
SIA Process
Expiration Type for Topo(base)
| 0.000 (parent)
Related Commands
show eigrp address-family topology
To display entries in the Enhanced Interior Gateway Routing Protocol (EIGRP) topology table, use the show eigrp address-family topology command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] topology [topology-name] [ip-address] [active] [all-links] [detail-links] [pending] [summary] [zero-successors] [route-type {connected | external | internal | local | redistributed | summary | vpn}]
Syntax Description
Command Default
If this command is used without any keywords or arguments, only routes that are feasible successors are displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp topology command. Cisco recommends using the show eigrp address-family topology command.
Examples
The following example shows how to display entries in the EIGRP topology table:
Router# show eigrp address-family ipv4 4453 topology
EIGRP-IPv4 VR(Virtual-name) Topology Table for AS(4453)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status, s - sia Status
P 10.17.17.0/24, 1 successors, FD is 409600
via 10.10.10.2 (409600/128256), Ethernet3/0
P 172.16.19.0/24, 1 successors, FD is 409600
via 10.10.10.2 (409600/128256), Ethernet3/0
P 192.168.10.0/24, 1 successors, FD is 281600
via Connected, Ethernet3/0
P 10.10.10.0/24, 1 successors, FD is 281600
via Redistributed (281600/0)
The following example shows how to display EIGRP metrics for specified internal services and external services:
Router# show eigrp address-family ipv4 4453 topology 10.10.10.0/24
EIGRP-IPv4 VR(virtual-name) Topology Entry for AS(4453)/ID(10.0.0.1) for 10.10.10.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 128256
Descriptor Blocks:
0.0.0.0 (Null0), from Connected, Send flag is 0x0
Composite metric is (128256/0), service is Internal
Vector metric:
Minimum bandwidth is 10000000 Kbit
Total delay is 5000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1514
Hop count is 0
Originating router is 10.0.0.1
Table 6 describes the significant fields shown in the display.
Related Commands
show eigrp address-family traffic
To display the number of Enhanced Interior Gateway Routing Protocol (EIGRP) packets that are sent and received, use the show eigrp address-family traffic command in user EXEC or privileged EXEC mode.
show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] traffic
Syntax Description
Command Default
The number of all EIGRP packets sent and received is displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show ip eigrp traffic command. Cisco recommends using the show eigrp address-family traffic command.
Examples
The following example shows how to display the number of EIGRP packets sent and received for autonomous system number 4453:
Router# show eigrp address-family ipv4 4453 traffic
EIGRP-IPv4 VR(virtual-name) Address-family Traffic Statistics for AS(4453)
Hellos sent/received: 122/122
Updates sent/received: 3/1
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 0/3
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
Hello Process ID: 128
PDM Process ID: 191
Socket Queue: 0/2000/1/0 (current/max/highest/drops)
Input Queue: 0/2000/1/0 (current/max/highest/drops
Table 7 describes the significant fields shown in the display.
Related Commands
show eigrp plugins
To display general information including the versions of the Enhanced Interior Gateway Routing Protocol (EIGRP) protocol features that are currently running, use the show eigrp plugins command in user EXEC or privileged EXEC mode.
show eigrp [vrf-name] [as-number] plugins [plugin-name] [detailed]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp plugins command in user EXEC or privileged EXEC mode to determine if a particular EIGRP feature is available in your Cisco IOS image. This command displays a summary of information about EIGRP service families and address families.
This command is useful when contacting Cisco technical support.
Examples
The following example shows how to display EIGRP plugin information:
Router# show eigrp plugins
EIGRP feature plugins:::
eigrp-release : 5.00.00 : Portable EIGRP Release
: 19.00.00 : Source Component Release(rel5)
igrp2 : 3.00.00 : Reliable Transport/Dual Database
bfd : 1.01.00 : BFD Platform Support
mtr : 1.00.01 : Multi-Topology Routing(MTR)
eigrp-pfr : 1.00.01 : Performance Routing Support
ipv4-af : 2.01.01 : Routing Protocol Support
ipv4-sf : 1.01.00 : Service Distribution Support
external-client : 1.02.00 : Service Distribution Client Support
ipv6-af : 2.01.01 : Routing Protocol Support
ipv6-sf : 1.01.00 : Service Distribution Support
snmp-agent : 1.01.01 : SNMP/SNMPv2 Agent Support
Table 8 describes the significant fields shown in the display.
Related Commands
show eigrp protocols
To display general information about Enhanced Interior Gateway Routing Protocol (EIGRP) protocols that are currently running, use the show eigrp protocols command in user EXEC or privileged EXEC mode.
show eigrp protocols [vrf vrf-name]
Syntax Description
vrf vrf-name |
(Optional) Displays information about the specified VRF. |
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp protocols command in user EXEC or privileged EXEC mode to see a summary of information on EIGRP IPv4 service families or address families.
Examples
The following example shows how to display general EIGRP information:
Router# show eigrp protocols
EIGRP-IPv4 Protocol for AS(10)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
EIGRP-IPv4 Protocol for AS(5) VRF(red)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 0
Total Redist Count: 0
The following example shows how to display general EIGRP information for VRF1:
Router# show eigrp protocols vrf vrf1
EIGRP-IPv4 Protocol for AS(5) VRF(vrf1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 0
Total Redist Count: 0
Table 9 describes the significant fields shown in the display.
Related Commands
show eigrp tech-support
To generate a report of Enhanced Interior Gateway Routing Protocol (EIGRP) internal state information, use the show eigrp tech-support command in privileged EXEC mode.
show eigrp tech-support [detailed]
Syntax Description
detailed |
(Optional) Displays additional detail not shown with the basic command. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp tech-support command in privileged EXEC mode to display various internal EIGRP states.
Note This command is useful for debugging and troubleshooting by Cisco technical support, but it is not intended for normal EIGRP administration tasks. This command should not be used without guidance from Cisco technical support.
Examples
The following is sample output from the show eigrp tech-support detailed command:
Router# show eigrp tech-support detailed
EIGRP Internal Process States
procinfoQ:
1: 0x54ABD10 vrid:2 afi:1 as:2 tableid:0 vrfid:0 tid:0 name:
topo_ddbQ(1) 0x55243E8 tableid:0 name:base
topo_ddbQ.count: 1
procinfoQ.count: 1
deadQ:
ddbQ:
1: 0x55243E8 name:base
ddbQ.count: 1
---------------------------------------------------------
EIGRP-IPv4 Protocol for AS(2)
{vrid:2 afi:1 as:2 tableid:0 vrfid:0 tid:0 name: }
PIDs: Hello: 204 PDM: 203
Router-ID: 6.6.6.6
Threads: procinfo: 0x4A3EC70 ddb: 0x4A3EE50
workQ:
iidbQ: Se2/0 Se2/1 Se3/0 Et0/1
count: 4
temp_iidbQ:
passive_iidbQ: Et0/0
count: 1
peerQ:
static_peerQ:
suspendQ:
networkQ: 1.0.0.0
2.0.0.0
count: 2
summaryQ: 2.0.0.0/16 - Et0/1 (intf: 1)
1.0.0.0/8 - Et0/1 (intf: 1)
count: 2
Socket Queue: 0/2000/2/0 (current/max/highest/drops)
Input Queue: 0/2000/2/0 (current/max/highest/drops)
GRS/NSF: enabled hold-timer: 240
Active Timer: 3 min
Distance: internal 90 external 170
Max Path: 4
Max Hopcount: 100
Variance: 1
---------------------------------------------------------
Related Commands
|
|
---|---|
show eigrp plugins |
Displays general information including the versions of the EIGRP protocol features currently running. |
show ip eigrp accounting
To display prefix accounting information for Enhanced Interior Gateway Routing Protocol (EIGRP) processes, use the show ip eigrp accounting command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] accounting
Syntax Description
vrf vrf-name |
(Optional) Displays information about the specified VRF. |
vrf * |
(Optional) Displays information about all VRFs. |
autonomous-system-number |
(Optional) Autonomous system number. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family accounting command. Cisco recommends using the show eigrp address-family accounting command.
Examples
The following is sample output from the show ip eigrp accounting command:
Router# show ip eigrp vrf RED accounting
EIGRP-IPv4 Accounting for AS(100)/ID(10.0.2.1) VRF(RED)
Total Prefix Count: 4 States: A-Adjacency, P-Pending, D-Down
State Address/Source Interface Prefix Restart Restart/
Count Count Reset(s)
P Redistributed ---- 0 3 211
A 10.0.1.2 Et0/0 2 0 84
P 10.0.2.4 Se2/0 0 2 114
D 10.0.1.3 Et0/0 0 3 0
Note Connected and summary routes are not listed individually in the output of this command but are counted in the total aggregate count per process.
Table 10 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family accounting |
Displays prefix accounting information for EIGRP processes. |
show ip eigrp events
To display the Enhanced Interior Gateway Routing Protocol (EIGRP) event log, use the show ip eigrp events command in user EXEC or privileged EXEC mode.
show ip eigrp [vrf vrf-name] events [starting-event-number ending-event-number] | [errmsg [starting-event-number ending-event-number]] [sia [starting-event-number ending-event-number]] [type]
Syntax Description
Command Default
All events in the EIGRP event log are displayed.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
The EIGRP event log is used by Cisco technical support to display a history of EIGRP internal events.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family events command. Cisco recommends using the show eigrp address-family events command.
The output of this command is displayed in reverse order, with the most recent events displayed first and the oldest events displayed last.
Examples
The following example shows how to display the EIGRP event log:
Router# show ip eigrp events
1 02:37:58.171 NSF stale rt scan, peer: 10.0.0.0
2 02:37:58.167 Metric set: 10.0.0.1/24 284700416
3 02:37:58.167 FC sat rdbmet/succmet: 284700416 0
4 02:37:58.167 FC sat nh/ndbmet: 10.0.0.2 284700416
5 02:37:58.167 Find FS: 10.0.0.0/24 284700416
6 02:37:58.167 Rcv update met/succmet: 284956416 284700416
7 02:37:58.167 Rcv update dest/nh: 10.0.0.0/24 10.0.0.1
8 02:37:58.167 Peer nsf restarted: 10.0.0.1 Tunnel0
9 02:36:38.383 Metric set: 10.0.0.0/24 284700416
10 02:36:38.383 RDB delete: 10.0.0.0/24 10.0.0.1
11 02:36:38.383 FC sat rdbmet/succmet: 284700416 0
12 02:36:38.383 FC sat nh/ndbmet: 0.0.0.0 284700416
Related Commands
|
|
---|---|
eigrp event-log size |
Specifies the size of the EIGRP event log. |
show eigrp address-family events |
Displays the EIGRP event log. |
show ip eigrp interfaces
To display information about interfaces that are configured for Enhanced Interior Gateway Routing Protocol (EIGRP), use the show ip eigrp interfaces command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] interfaces [type number] [detail]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show ip eigrp interfaces command to display active EIGRP interfaces, as well as EIGRP-specific interface settings and statistics.
If an interface is specified, only information about that interface is displayed. Otherwise, information about all interfaces on which EIGRP is running is displayed.
If an autonomous system is specified, only the routing process for the specified autonomous system is displayed. Otherwise, all EIGRP processes are displayed.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family interfaces command. Cisco recommends using the show eigrp address-family interfaces command.
Examples
The following is sample output from the show ip eigrp interfaces command:
Router# show ip eigrp interfaces
EIGRP-IPv4 Interfaces for AS(60)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Di0 0 0/0 0 11/434 0 0
Et0 1 0/0 337 0/10 0 0
SE0:1.16 1 0/0 10 1/63 103 0
Tu0 1 0/0 330 0/16 0 0
The following is sample output that displays detailed information about all active EIGRP interfaces:
Router# show ip eigrp interfaces detail
EIGRP-IPv4 Interfaces for AS(1)
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et0/0 0 0/0 0 0/1 0 0
Hello-interval is 7, Hold-time is 21
Split-horizon is disabled
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Next-hop-self disabled, next-hop info forwarded
Topology-ids on interface - 0
Authentication mode is md5, key-chain is "TEST"
BFD is enabled
Et0/1 0 0/0 0 0/10 0 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Table 11 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show ip eigrp neighbors |
Displays the neighbors discovered by EIGRP. |
show eigrp address-family interfaces |
Displays information about interfaces configured for EIGRP. |
show ip eigrp neighbors
To display neighbors discovered by Enhanced Interior Gateway Routing Protocol (EIGRP), use the show ip eigrp neighbors command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] neighbors [interface-type | static | detail]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show ip eigrp neighbors command to display dynamic and static neighbor states. It is also useful for debugging certain types of transport problems.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family neighbors command. Cisco recommends using the show eigrp address-family neighbors command.
Examples
The following is sample output from the show ip eigrp neighbors command:
Router# show ip eigrp neighbors
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.2 Et0/0 13 00:00:03 1996 5000 0 5
2 10.1.1.9 Et0/0 14 00:02:24 206 5000 0 5
1 10.1.2.3 Et0/1 11 00:20:39 2202 5000 0 5
Table 12 describes the significant fields shown in the display.
The following is sample output from the show ip eigrp neighbors command when issued with the detail keyword:
Router# show ip eigrp neighbors detail
EIGRP-IPv4 Neighbors for AS(60)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 1.1.1.3 Et0/0 12 00:04:48 1832 5000 0 14
Version 12.2/1.2, Retrans:0, Retries:0
Restart time 00:01:05
0 10.4.9.5 Fa0/0 11 00:04:07 768 4608 0 4
Version 12.2/1.2, Retrans: 0, Retries: 0
2 10.4.9.10 Fa0/0 13 1w0d 1 3000 0 6
Version 12.2/1.2, Retrans: 1, Retries: 0
1 10.4.9.6 Fa0/0 12 1w0d 1 3000 0 4
Version 12.2/1.2, Retrans: 1, Retries: 0
Table 13 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family neighbors |
Displays the neighbors discovered by EIGRP. |
show ip eigrp topology
To display entries in the Enhanced Interior Gateway Routing Protocol (EIGRP) topology table, use the show ip eigrp topology command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] topology [ip-address [mask]] | [name] [active | all-links | detail-links | pending | summary | zero-successors]
Syntax Description
Command Default
If this command is used without any optional keywords, then only topology entries with feasible successors are displayed and only the feasible paths are shown.
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Us the show ip eigrp topology command to display topology entries, feasible and non-feasible paths, metrics, and states. This command can be used without any keywords or arguments, in which case only topology entries with feasible successors are displayed, and only the feasible paths are shown. The all-links keyword displays all paths, whether feasible successors or not, and the detail-links keyword displays additional detail about these paths.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family topology command. Cisco recommends using the show eigrp address-family topology command.
Examples
The following is sample output from the show ip eigrp topology command:
Router# show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status, s - sia status
P 10.0.0.0/8, 1 successors, FD is 409600
via 1.1.1.2 (409600/128256), Ethernet0/0
P 172.16.1.0/24, 1 successors, FD is 409600
via 1.1.1.2 (409600/128256), Ethernet0/0
P 10.0.0.0/8, 1 successors, FD is 281600
via Summary (281600/0), Null0
P 10.0.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
The following example displays detailed information for a single prefix. The prefix shown is an EIGRP internal route:
Router# show ip eigrp topology 10.0.0.0/8
EIGRP-IPv4 Topology Entry for AS(1)/ID(10.0.0.1) for 10.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Descriptor Blocks:
10.0.0.2 (Ethernet0/0), from 10.0.1.2, Send flag is 0x0
Composite metric is (409600/128256), route is Internal
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 10.0.1.2
The following example displays detailed information for a single prefix. The prefix shown is an EIGRP external route:
Router# show ip eigrp topology 172.16.1.0/24
EIGRP-IPv4 Topology Entry for AS(1)/ID(10.0.0.1) for 10.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Descriptor Blocks:
10.0.0.2 (Ethernet0/0), from 10.0.1.2, Send flag is 0x0
Composite metric is (409600/128256), route is External
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 10.0.1.2
External data:
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
The following example demonstrates the all-links keyword, which displays all paths, even those that are not feasible:
Router# show ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.16.1.0/24, 1 successors, FD is 409600, serno 14
via 10.10.1.2 (409600/128256), Ethernet0/0
via 10.1.04.3 (2586111744/2585599744), Serial3/0, serno 18
The following example demonstrates the detail-links keyword, which displays additional detail about the routes:
Router# show ip eigrp topology detail-links
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.0.0.0/8, 1 successors, FD is 409600, serno 6
via 1.1.1.2 (409600/128256), Ethernet0/0
P 172.16.1.0/24, 1 successors, FD is 409600, serno 14
via 1.1.1.2 (409600/128256), Ethernet0/0
P 10.0.0.0/8, 1 successors, FD is 281600, serno 3
via Summary (281600/0), Null0
P 10.1.1.0/24, 1 successors, FD is 281600, serno 1
via Connected, Ethernet0/0
Table 14 describes the significant fields shown in the displays.
Related Commands
|
|
---|---|
show eigrp address-family topology |
Displays entries in the EIGRP topology table. |
show ip eigrp traffic
To display the number of Enhanced Interior Gateway Routing Protocol (EIGRP) packets sent and received, use the show ip eigrp traffic command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] traffic
Syntax Description
vrf vrf-name |
(Optional) Displays information about the specified VRF. |
vrf * |
(Optional) Displays information about all VRFs. |
autonomous-system-number |
(Optional) Autonomous system number. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family traffic command. Cisco recommends using the show eigrp address-family traffic command.
Examples
The following is sample output from the show ip eigrp traffic command:
Router# show ip eigrp traffic
EIGRP-IPv4 Traffic Statistics for AS(60)
Hellos sent/received: 21429/2809
Updates sent/received: 22/17
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 16/13
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
Hello Process ID: 204
PDM Process ID: 203
Socket Queue: 0/2000/2/0 (current/max/highest/drops)
Input Queue: 0/2000/2/0 (current/max/highest/drops)
Table 15 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family traffic |
Displays the number of EIGRP packets sent and received. |
show ip eigrp vrf accounting
Note Effective with Cisco IOS Release 15.0(1)M, this command was replaced by the show ip eigrp accounting command. See the show ip eigrp accounting command for more information.
To display prefix accounting information for an Enhanced Interior Gateway Routing Protocol (EIGRP) VPN routing and forwarding instance (VRF), use the show ip eigrp vrf accounting command in privileged EXEC mode.
show ip eigrp vrf {vrf-name | *} accounting [autonomous-system-number]
Syntax Description
vrf-name |
Specifies the VRF name. |
* |
Displays all VRFs. |
autonomous-system-number |
(Optional) Specifies the autonomous system number. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family accounting command. Cisco recommends using the show eigrp address-family accounting command.
Examples
The following is sample output from the show ip eigrp vrf accounting command:
Router# show ip eigrp vrf RED accounting
IP-EIGRP accounting for AS(100)/ID(10.0.2.1) Routing Table: RED
Total Prefix Count: 4 States: A-Adjacency, P-Pending, D-Down
State Address/Source Interface Prefix Restart Restart/
Count Count Reset(s)
P Redistributed ---- 0 3 211
A 10.0.1.2 Et0/0 2 0 84
P 10.0.2.4 Se2/0 0 2 114
D 10.0.1.3 Et0/0 0 3 0
Note Connected and summary routes are not listed individually in the output of this command but are counted in the total aggregate count per process.
Table 16 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family accounting |
Displays prefix accounting information for EIGRP processes. |
show ip eigrp vrf interfaces
Note Effective with Cisco IOS Release 15.0(1)M, this command was replaced by the show ip eigrp interfaces command. See the show ip eigrp interfaces command for more information.
To display information about interfaces that carry VPN routing and forwarding (VRF) information and that are configured for Enhanced Interior Gateway Routing Protocol (EIGRP), use the show ip eigrp vrf interfaces command in privileged EXEC mode.
show ip eigrp vrf {vrf-name | *} interfaces [autonomous-system-number] [interface-type] [detail interface-type] [static interface-type]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show ip eigrp vrf interfaces command to display EIGRP interfaces that are defined under the specified VRF. If an interface is specified with the interface-type argument, only the specified interface is displayed. Otherwise, all interfaces on which EIGRP is running as part of the specified VRF are displayed.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family interfaces command. Cisco recommends using the show eigrp address-family interfaces command.
Examples
The following is sample output from the show ip eigrp vrf interfaces command:
Router# show ip eigrp vrf VRF-PINK interfaces
IP-EIGRP interfaces for process 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et3/0 1 0/0 131 0/10 528 0
Table 17 describes the significant fields shown in the display.
Related Commands
show ip eigrp vrf neighbors
Note Effective with Cisco IOS Release 15.0(1)M, this command was replaced by the show ip eigrp neighbors command. See the show ip eigrp neighbors command for more information.
To display Enhanced Interior Gateway Routing Protocol (EIGRP) neighbors that are on interfaces that are part of the specified Virtual Private Network (VPN) routing and forwarding instance (VRF), use the show ip eigrp vrf neighbors command privileged EXEC mode.
show ip eigrp vrf {vrf-name | *} neighbors [autonomous-system-number] [interface-type] [detail interface-type] [static interface-type]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show ip eigrp vrf neighbors command to determine when VRF neighbors become active and inactive. This command is also useful for debugging certain types of transport problems.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family neighbors command. Cisco recommends using the show eigrp address-family neighbors command.
Examples
The following is sample output from the show ip eigrp vrf neighbors command:
Router# show ip eigrp vrf VRF-GREEN neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q
Seq Type
(sec) (ms) Cnt
Num
0 10.10.10.2 Et3/0 10 1d16h 131 786 0 3
Table 18 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family neighbors |
Displays neighbors discovered by EIGRP. |
show ip eigrp vrf topology
Note Effective with Cisco IOS Release 15.0(1)M, this command was replaced by the show ip eigrp topology command. See the show ip eigrp topology command for more information.
To display Virtual Private Network (VPN) routing and forwarding instance (VRF) entries in the Enhanced Interior Gateway Routing Protocol (EIGRP) topology table, use the show ip eigrp topology command in privileged EXEC mode.
show ip eigrp vrf {vrf-name | *} topology [as-number] [ip-address [mask]] [active | all-links | pending | summary | zero-successors]
Syntax Description
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
The show ip eigrp vrf topology command can be used without any keywords or arguments, but you must specify either a VRF name or use the * character as a wild card. If this command entered this way, only routes that are feasible successors are displayed. The show ip eigrp vrf topology command can be used to determine Diffusing Update Algorithm (DUAL) states and to debug possible DUAL problems.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family topology command. Cisco recommends using the show eigrp address-family topology command.
Examples
The following is sample output from the show ip eigrp vrf topology command:
Router# show ip eigrp vrf VRF-PINK topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.10.1) Routing Table:VRF-PINK
Codes:P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.17.17.0/24, 1 successors, FD is 409600
via 10.10.10.2 (409600/128256), Ethernet3/0
P 172.16.19.0/24, 1 successors, FD is 409600
via 10.10.10.2 (409600/128256), Ethernet3/0
P 192.168.10.0/24, 1 successors, FD is 281600
via Connected, Ethernet3/0
P 10.10.10.0/24, 1 successors, FD is 281600
via Redistributed (281600/0)
Table 19 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family topology |
Displays entries in the EIGRP topology table. |
show ip eigrp vrf traffic
Note Effective with Cisco IOS Release 15.0(1)M, the show ip eigrp vrf traffic command is replaced by the show ip eigrp traffic command. See the show ip eigrp traffic command for more information.
To display sent and received statistics for Enhanced Interior Gateway Routing Protocol (EIGRP) Virtual Private Networking (VPN) routing and forwarding instance (VRF) packets, use the show ip eigrp vrf traffic command in privileged EXEC mode.
show ip eigrp vrf {vrf-name | *} traffic [as-number]
Syntax Description
vrf-name |
VRF name. |
* |
Displays all VRFs. |
as-number |
(Optional) Autonomous system number. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family traffic command. Cisco recommends using the show eigrp address-family traffic command.
Examples
The following is sample output from the show ip eigrp vrf traffic command:
Router# show ip eigrp vrf VRF-RED traffic
IP-EIGRP Traffic Statistics for AS 101
Hellos sent/received: 600/585
Updates sent/received: 23/22
Queries sent/received: 7/0
Replies sent/received: 0/6
Acks sent/received: 55/42
Input queue high water mark 0, 0 drops
Table 20 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
show eigrp address-family traffic |
Displays the number of EIGRP packets sent and received. |
shutdown (address-family)
To disable the Enhanced Interior Gateway Routing Protocol (EIGRP) address-family protocol for a specific routing instance without removing any existing address-family configuration parameters, use the shutdown command in the appropriate configuration mode. To reenable the EIGRP address-family protocol, use the no form of this command.
shutdown
no shutdown
Syntax Description
This command has no arguments or keywords.
Command Default
The EIGRP address-family protocol for routing instances is not disabled.
Command Modes
Router configuration (config-router)
Address-family configuration (config-router-af)
Address-family interface configuration (config-router-af-interface)
Command History
Usage Guidelines
When you configure the shutdown (address-family) command, the EIGRP address-family protocol continues to run on the router and you can continue to use the current address-family configuration. The address-family will not form any adjacencies on any interface and the address-family topology database is cleared.
Configure the shutdown command in address-family configuration mode to shut down all topologies under that address family. Configure this command in router configuration mode to shut down all address and service families and their topologies.
Examples
The following example shows how to disable the address-family protocol in router configuration mode:
Router(config)# router eigrp virtual-name
Router(config-router)# shutdown
The following example shows how to disable the address-family protocol in address-family configuration mode:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# shutdown
The following example shows how to disable the address-family protocol in address-family interface configuration mode:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# shutdown
Related Commands
split-horizon (EIGRP)
To enable Enhanced Interior Gateway Routing Protocol (EIGRP) split-horizon, use the split-horizon command in address-family interface configuration mode or service-family interface configuration mode. To disable EIGRP split-horizon, use the no form of this command.
split-horizon
no split-horizon
Syntax Description
This command has no arguments or keywords.
Command Default
EIGRP split-horizon is enabled by default. However, for ATM interfaces and subinterfaces split-horizon is disabled by default.
Command Modes
Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)
Command History
Usage Guidelines
The split-horizon rule prohibits a router from advertising a route through an interface that the router itself uses to reach the destination. The following are general rules for EIGRP split-horizon:
•Split-horizon behavior is turned on by default.
•When you change the EIGRP split-horizon setting on an interface, all adjacencies with EIGRP neighbors reachable over that interface are reset.
•Split-horizon should typically be disabled only on non-broadcast multi-access interfaces.
•The EIGRP split-horizon behavior is not controlled or influenced by the ip split-horizon command.
To configure split-horizon for an EIGRP address family, use the split-horizon command in address-family interface configuration mode.
To configure split-horizon for an EIGRP service family, use the split-horizon command in service-family interface configuration mode.
Examples
The following example disables EIGRP split-horizon for serial interface 3/0 in address-family 5400:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface serial3/0
Router(config-router-af-interface)# no split-horizon
The following example disables EIGRP split-horizon for serial interface 3/0 in service-family 5400:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 5400
Router(config-router-sf)# sf-interface serial3/0
Router(config-router-sf-interface)# no split-horizon
Related Commands
stub
Note Effective with Cisco IOS Release 15.0(1)M and 12.2(33)SRE, the stub command was replaced by the eigrp stub command. See the eigrp stub command for more information.
To configure a router as a stub using Enhanced Interior Gateway Routing Protocol (EIGRP), use the stub command in router configuration mode. To disable the EIGRP stub routing feature, use the no form of this command.
stub [receive-only | connected | static | summary | redistributed]
no stub [receive-only | connected | static | summary | redistributed]
Syntax Description
Command Default
Stub routing is not enabled.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
Use the stub command to configure a router as a stub where the router directs all IPv6 traffic to a distribution router.
The stub command can be modified with keywords, and more than one keyword can be used in the same syntax. These options can be used in any combination, except for the receive-only keyword. The receive-only keyword will restrict the router from sharing any of its routes with any other router in that EIGRP autonomous system, and the receive-only keyword will not permit any other option to be specified because it prevents any type of route from being sent. The connected, static, summary, and redistributed keywords can be used in any combination but cannot be used with the receive-only keyword.
If any of these four keywords is used with the stub command, only the route types specified by the particular keywords will be sent. Route types specified by the nonused keywords will not be sent.
The connected keyword permits the EIGRP stub routing feature to send connected routes. If the connected routes are not covered by a network statement, it may be necessary to redistribute connected routes with the redistribute connected command under the EIGRP process. This option is enabled by default.
The static keyword permits the EIGRP stub routing feature to send static routes. Without the configuration of this option, EIGRP will not send any static routes, including internal static routes that normally would be automatically redistributed. It will still be necessary to redistribute static routes with the redistribute static command.
The summary keyword permits the EIGRP stub routing feature to send summary routes. Summary routes can be created manually with the ipv6 summary address eigrp command or automatically at a major network border router with the auto-summary command enabled. This option is enabled by default.
The redistributed keyword permits the EIGRP stub routing feature to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP will not advertise redistributed routes.
Note Multiaccess interfaces such as ATM, Ethernet, Frame Relay, ISDN PRI, and X.25 are supported by the EIGRP stub routing feature only when all routers on that interface, except the hub, are configured as stub routers.
Examples
In the following example, the stub command is used to configure the router as a stub that advertises connected and summary routes:
ipv6 router eigrp 1
network 3FEE:12E1:2AC1:EA32::/64
stub
In the following example, the stub command is issued with the connected and static keywords to configure the router as a stub that advertises connected and static routes (sending summary routes will not be permitted):
ipv6 router eigrp 1
network 3FEE:12E1:2AC1:EA32::/64
stub connected static
In the following example, the stub command is issued with the receive-only keyword to configure the router as a receive-only neighbor (connected, summary, and static routes will not be sent):
ipv6 router eigrp 1
network 3FEE:12E1:2AC1:EA32::/64 eigrp
stub receive-only
In the following example, the stub command is issued with the redistributed keyword to configure the router to advertise other protocols and autonomous systems:
ipv6 router eigrp 1
network 3FEE:12E1:2AC1:EA32::/64 eigrp
stub redistributed
Related Commands
summary-address (EIGRP)
To configure a summary address for Enhanced Interior Gateway Routing Protocol (EIGRP), use the summary-address (EIGRP) command in address-family interface configuration mode. To remove an EIGRP summary address, use the no form of this command.
summary-address ip-address mask [administrative-distance [leak-map leak-map-name]]
no summary-address ip-address mask [administrative-distance [leak-map leak-map-name]]
Syntax Description
Command Default
All routes are advertised individually.
Command Modes
Address-family interface configuration (config-router-af-interface)
Command History
Usage Guidelines
The summary-address (EIGRP) command is used to configure interface-level address summarization. EIGRP summary routes are given an administrative distance value of 5. The administrative distance metric is used to advertise a summary address without installing it in the routing table.
By default, EIGRP summarizes subnet routes to the network level. The no auto-summary command can be entered to configure subnet-level summarization.
EIGRP Support for Leaking Routes
Configuring the leak-map keyword allows you to advertise a component route that would otherwise be suppressed by the manual summary. Any component subset of the summary routes or addresses can be leaked. A route map and access list must be defined to source the leaked route.
The following is default behavior if an incomplete configuration is entered:
•If the leak-map keyword is configured to reference a nonexistent route map, the configuration of this keyword has no effect. The summary address is advertised, but all component routes are suppressed.
•If the leak-map keyword is configured but the access list does not exist or the route map does not reference the access list, the summary address and all component routes are sent.
Examples
The following example shows how to configure an EIGRP summary address:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# summary-address 192.168.0.0 255.255.0.0 95
Related Commands
summary-metric
To configure a fixed metric for an Enhanced Interior Gateway Routing Protocol (EIGRP) summary aggregate address, use the summary-metric command in address-family topology configuration mode. To remove a configured metric, use the no form of this command.
summary-metric network-address subnet-mask [bandwidth delay reliability load mtu] [distance administrative-distance]
no summary-metric network-address subnet-mask
Syntax Description
Command Default
EIGRP summary aggregate addresses do not have a fixed metric.
Command Modes
Address-family topology configuration (config-router-af-topology)
Command History
Usage Guidelines
When EIGRP creates a summary route, it includes a metric with the route in order to advertise it.
EIGRP searches for components of the summary to be suppressed and represented by the summary. EIGRP finds the component with the best metric and copies the metric from it into the summary. Components of the summary may come and go, which means that every time the best component changes, the summary needs to be re-advertised to all of its peers. Even if the best component is not the one that changed, EIGRP still has to search every topology entry to make sure the summary is not affected. This can add significant processing overhead.
Use the summary-metric command to mitigate this metric churn and processing overhead. Rather than searching for the best component metric, EIGRP uses the values configured with the summary-metric command.
Changes Beginning in Cisco IOS XE 3.2S
One of the sets of optional values is required after the subnet mask. That is, you can configure bandwidth, delay, reliability, load, and MTU, along with administrative distance, without administrative distance, or you can configure only administrative distance.
The preferred way to configure administrative distance for summaries is by using the summary-metric command; the administrative distance option in the summary-address command is being deprecated.
If the summary-address with administrative distance is entered, and:
•if a summary-metric command with administrative distance already exists, the summary-address command is accepted, but the administrative distance value is ignored.
•if a summary-metric command does not exist or does not have the administrative distance specified, then the summary-address administrative distance value is used to automatically create a summary-metric (or set the administrative distance value on an existing summary-metric when administrative distance is not specified).
Examples
The following example configures an EIGRP summary address and sets the bandwidth to 10,000, the delay to 10, the reliability to 255, the load to 1, and the MTU to 1500 for the summary address 192.168.0.0/16:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# summary-address 192.168.0.0 255.255.0.0
Router(config-router-af-interface)# exit
Router(config-router-af)# topology base
Router(config-router-af-topology)# summary-metric 192.168.0.0/16 10000 10 255 1 1500
In the following example, for summary address 2.0.0.0/8, only administrative distance is specified. For summary address 3.0.0.0/8, metrics are specified, but no distance. For summary address 4.0.0.0/8, both metrics and distance are specified. For summary address 2.0.0.0/8 in VRF red, a different distance is specified.
router eigrp 1
summary-metric 2.0.0.0/8 distance 20 ! <-- Specify admin distance only for 2.0.0.0/8
summary-metric 3.0.0.0/8 10000 10 255 1 1500 ! <-- Specify metric only for 3.0.0.0/8
summary-metric 4.0.0.0/8 1 1 1 1 1 distance 20 ! <-- metric and distance for 4.0.0.0/8
!
address-family ipv4 vrf red autonomous-system 2
summary-metric 2.0.0.0/8 distance 55 ! <-- different distance for 2.0.0.0/8 in vrf red
In the following VRF Lite example, the user specifies the summary-address command with an administrative distance of 33 and receives a message that the command is being deprecated. Then the system automatically creates a summary-metric with the distance of 33 in address-family blue.
Router(config)# interface ethernet 1
Router(config-if)# vrf forwarding blue
Router(config-if)# ip summary-address eigrp 1 1.0.0.0 255.0.0.0 33
%EIGRP: summary-address accepted but distance option deprecated; use summary-metric command for distance.
Router(config-if)#do show run | s vrf blue
address-family ipv4 vrf blue autonomous-system 1
summary-metric 1.0.0.0/8 distance 33
Related Commands
timers active-time
To adjust Enhanced Interior Gateway Routing Protocol (EIGRP) routing wait time, use the timers active-time command in router configuration mode or address-family topology configuration mode. To disable this function, use the no form of the command.
timers active-time [time-limit | disabled]
no timers active-time
Syntax Description
time-limit |
(Optional) EIGRP active-time limit (in minutes). Valid range is 1 to 65535. |
disabled |
(Optional) Disables the timers and permits the routing wait time to remain active indefinitely. |
Command Default
This command is disabled by default.
Command Modes
Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)
Command History
Usage Guidelines
In EIGRP, there are timers that control the time that the router waits (after sending a query) before declaring the route to be in the stuck in active (SIA) state.
Examples
In the following example, the routing wait time is 200 minutes on the specified route:
Router(config)# router eigrp 5
Router(config-router)# timers active-time 200
In the following example, the routing wait time is 200 minutes on the specified address-family route:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# timers active-time 200
In the following example, the routing wait time is indefinite if a route becomes active:
Router(config)# router eigrp 5
Router(config-router)# timers active-time disabled
In the following example, the routing wait time is indefinite on the specified address-family route:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# timers active-time disabled
In the following example, the routing wait time is 100 minutes on the specified route:
Router(config)# ipv6 router eigrp 1
Router(config-router)# timers active-time 100
In the following example, the routing wait time is 100 minutes on the specified address-family route:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv6 autonomous-system 4453
Router(config-router-af)# topology base
Router(config-router-af-topology)# timers active-time disabled
Related Commands
timers graceful-restart purge-time
To set the route-hold timer to determine how long a nonstop forwarding (NSF)-aware router that is running Enhanced Interior Gateway Routing Protocol (EIGRP) will hold routes for an inactive peer, use the timers graceful-restart purge-time command in router configuration, address-family, or service-family configuration mode. To return the route-hold timer to the default value, use the no form of this command.
timers graceful-restart purge-time seconds
no timers graceful-restart purge-time
Syntax Description
seconds |
Time, in seconds, for which EIGRP will hold routes for an inactive peer. The configurable time range is from 20 to 300 seconds. The default is 240 seconds. |
Command Default
EIGRP NSF awareness is enabled by default. The default value for the route-hold timer is 240 seconds.
Command Modes
Router configuration (config-router)
Address-family configuration (config-router-af)
Service-family configuration (config-router-sf)
Command History
Usage Guidelines
The route-hold timer sets the maximum period of time for which the NSF-aware router will hold known routes for an NSF-capable neighbor during a switchover operation or a well-known failure condition. The route-hold timer is configurable so that you can tune network performance and avoid undesired effects, such as "black holing" routes if the switchover operation takes too much time. When this timer expires, the NSF-aware router scans the topology table and discards any stale routes, allowing EIGRP peers to find alternate routes instead of waiting during a long switchover operation.
Examples
The following configuration example sets the route-hold timer value for an NSF-aware address family. In the example, the route-hold timer is set to 1 minute:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# timers graceful-restart purge-time 60
The following configuration example sets the route-hold timer value for an NSF-aware service-family. In this example, the route-hold timer is set to 300 seconds:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# timers graceful-restart purge-time 300
Related Commands
timers nsf converge
To adjust the maximum time that a restarting router will wait for the end of table (EOT) notification from a nonstop forwarding (NSF)-capable or NSF-aware peer, use the timers nsf converge command in router configuration mode or address-family configuration mode. To return the signal timer to the default value, use the no form of this command.
timers nsf converge seconds
no timers nsf converge
Syntax Description
seconds |
Time, in seconds, for which a restarting router will wait for an EOT notification. Valid range is 60 to 180 seconds. The default is 120 seconds. |
Command Default
Enhanced Interior Gateway Routing Protocol (EIGRP) NSF awareness is enabled by default. EIGRP NSF awareness uses 120 seconds as the default value if this command is not configured or if the no form of this command is entered.
Command Modes
Router configuration (config-router)
Address-family configuration (config-router-af)
Command History
Usage Guidelines
This command is entered only on an NSF-capable router. The converge timer is be used to wait for the last EOT update if all startup updates have not been received within the signal timer period. If an EIGRP process discovers no neighbor, or if it has received all startup updates from its neighbor within the signal timer period, the converge timer will not be started.
Examples
The following configuration example adjusts the converge timer on an NSF-capable router. In the example, the converge timer is set to 1 minute:
Router(config-router)# timers nsf converge 60
The following EIGRP named configuration example adjusts the converge timer on an NSF-capable router. In the example, the converge timer is set to 1 minute:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# timers nsf converge 60
Related Commands
timers nsf route-hold
Note Effective with Cisco IOS Release 15.0(1)M and 12.2(33)SRE, the timers nsf route-hold command was replaced by the timers graceful-restart purge-time command. See the timers graceful-restart purge-time command for more information.
To set the route-hold timer to determine how long a nonstop forwarding (NSF)-aware router that is running Enhanced Interior Gateway Routing Protocol (EIGRP) will hold routes for an inactive peer, use the timers nsf route-hold command in router configuration mode. To return the route-hold timer to the default value, use the no form of this command.
timers nsf route-hold seconds
no timers nsf route-hold
Syntax Description
seconds |
Time, in seconds, for which EIGRP will hold routes for an inactive peer. Valid range is 20 to 300 seconds. The default is 240 seconds. |
Command Default
EIGRP NSF awareness is enabled by default. The default value for the route-hold timer is 240 seconds.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
The route-hold timer sets the maximum period of time that the NSF-aware router will hold known routes for an NSF-capable neighbor during a switchover operation or a well-known failure condition. The route-hold timer is configurable so that you can tune network performance and avoid undesired effects, such as "black holing" routes if the switchover operation takes too much time. When this timer expires, the NSF-aware router scans the topology table and discards any stale routes, allowing EIGRP peers to find alternate routes instead of waiting during a long switchover operation.
Examples
The following configuration example sets the route-hold timer value for an NSF-aware router. In the example, the route-hold timer is set to 2 minutes:
Router(config-router)# timers nsf route-hold 120
Related Commands
timers nsf signal
To adjust the maximum time for the initial signal timer restart period, use the timers nsf signal command in router configuration mode or address-family configuration mode. To return the signal timer to the default value, use the no form of this command.
timers nsf signal seconds
no timers nsf signal
Syntax Description
seconds |
Time, in seconds, for which Enhanced Interior Gateway Routing Protocol (EIGRP) will hold routes for an inactive peer. Valid range is 10 to 30 seconds. The default is 20 seconds. |
Command Default
EIGRP NSF awareness is enabled by default. EIGRP NSF awareness uses 20 seconds as the default value if this command is not configured or if the no form of this command is entered.
Command Modes
Router configuration (config-router)
Address-family configuration (config-router-af)
Command History
Usage Guidelines
This command is entered only on a nonstop forwarding (NSF)-capable router. The EIGRP process starts a signal timer when it is notified of a switchover event. Hello packets with the RS bit set are sent during this period.
The converge timer is used to wait for the last end of table (EOT) update if all startup updates have not been received within the signal timer period. If an EIGRP process discovers no neighbor, or if it has received all startup updates from its neighbor within the signal timer period, the converge timer will not be started.
Examples
The following configuration example adjusts the signal timer value on an NSF-capable router. In the example, the signal timer is set to 30 seconds:
Router(config-router)# timers nsf signal 30
The following EIGRP named configuration example adjusts the signal timer value on an NSF-capable router. In the example, the signal timer is set to 30 seconds:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# timers nsf signal 30
Related Commands
topology (EIGRP)
To configure an Enhanced Interior Gateway Routing Protocol (EIGRP) process to route IP traffic under the specified topology instance and to enter address-family topology configuration mode, use the topology command in address-family configuration mode. To disassociate the EIGRP routing process from the topology instance, use the no form of this command.
topology {base | topology-name tid number}
no topology topology-name
Syntax Description
Command Default
EIGRP routing processes are not configured to route IP traffic under a topology instance.
Command Modes
Address-family configuration (config-router-af)
Command History
Usage Guidelines
The topology command is used in a Multi-Topology Routing (MTR) configuration to enable an EIGRP process under the specified topology. The topology command is entered under address-family configuration mode. Command configurations are applied only to the topology instance. The topology must be defined globally with the global-address-family command in global address-family configuration mode before the topology can be configured under the EIGRP process.
The tid keyword associates an ID with the topology instance. Each topology must be configured with a unique topology ID. The topology ID is used to identify and group Network Layer Reachability Information (NLRI) for each topology in EIGRP updates.
The topology ID must be consistent across routers so that EIGRP can correctly associate topologies.
Examples
The following example configures EIGRP process 1 to route traffic for the 192.168.0.0/16 network under the VOICE topology instance:
Router(config)# router eigrp 1
Router(config-router)# address-family ipv4 unicast autonomous-system 3
Router(config-router-af)# topology VOICE tid 100
Router(config-router-af-topology)# no auto-summary
Router(config-router-af-topology)# network 192.168.0.0 0.0.255.255
Router(config-router-af-topology)# end
Related Commands
traffic-share balanced
To control how traffic is distributed among routes when multiple routes for the same destination network have different costs, use the traffic-share balanced command in router configuration mode or address-family topology configuration mode. To disable this function, use the no form of the command.
traffic-share balanced
no traffic-share balanced
Syntax Description
This command has no arguments or keywords.
Command Default
Traffic is distributed proportionately to the ratios of the metrics.
Command Modes
Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)
Command History
Usage Guidelines
This command applies only to Enhanced Interior Gateway Routing Protocol (EIGRP). With the default setting, routes that have higher metrics represent less-preferable routes and get less traffic.
Examples
In the following example, traffic is balanced across multiple routes:
Router(config)# router eigrp 5
Router(config-router)# traffic-share balanced
Router(config-router)# variance 1
In the following EIGRP named configuration example, traffic is balanced across multiple routes:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# traffic-share balanced
Router(config-router-af-topology)# variance 1
Related Commands
|
|
---|---|
variance (EIGRP) |
Controls load balancing in an EIGRP network. |
variance (EIGRP)
To control load balancing in an internetwork based on the Enhanced Interior Gateway Routing Protocol (EIGRP), use the variance command in router configuration mode or address-family topology configuration mode. To reset the variance to the default value, use the no form of this command.
variance multiplier
no variance
Syntax Description
multiplier |
Metric value used for load balancing. It can be a value from 1 to 128. The default is 1, which means equal-cost load balancing. |
Command Default
EIGRP uses equal-cost load balancing.
Command Modes
Router configuration (config-router)
Address-family topology configuration (config-router-af-topology)
Command History
Usage Guidelines
Setting a variance value enables EIGRP to install multiple loop-free routes with unequal cost in a local routing table. A route learned through EIGRP must meet two criteria to be installed in the local routing table:
•The route must be loop- free. This condition is satisfied when the reported distance is less than the total distance or when the route is a feasible successor.
•The metric of the route must be lower than the metric of the best route (the successor) multiplied by the variance configured on the router.
Thus, if the variance is set to 1, only routes with the same metric as the successor are installed in the local routing table. If the variance is set to 2, any EIGRP-learned route with a metric less than 2 times the successor metric will be installed in the local routing table.
Note EIGRP does not load-share between multiple routes; it only installs the routes in the local routing table. Then, the local routing table enables switching hardware or software to load-share between the multiple paths.
Examples
The following example sets a variance value of 4:
Router(config)# router eigrp 109
Router(config-router)# variance 4
The following example sets a variance value of 4 in address-family topology configuration mode:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# variance 4