To configure a PPP over Ethernet (PPPoE) client and to specify the dial-on-demand routing (DDR) functionality, use the
pppoe-client
dial-pool-number command in interface configuration mode or ATM virtual circuit configuration mode. To disable the configured dial-on-demand
functionality, use the
no form of this command.
pppoe-client
dial-pool-number number [dial-on-demand | restart number | service-name name | mac-override]
no pppoe-client dial-pool-number number [dial-on-demand | restart number | service-name name | mac-override]
Syntax Description
number
|
A number that is assigned to a configured dialer pool. The range is from 1 to 255.
|
dial-on-demand
|
(Optional) Enables the DDR functionality for the PPPoE connection.
|
restart
number
|
(Optional) Allows the timer to be configured in seconds. The range is from 1 to 3600. The default value is 20.
|
service-name
name
|
(Optional) Specifies the service name requested by the PPPoE client.
|
mac-override
|
(Optional) Specifies the MAC address to be used as the local MAC address in the corresponding dialer interface when a session
is established.
|
Command Default
A PPPoE client is not configured and the DDR functionality is disabled.
Command Modes
Interface configuration (config-if)
ATM virtual circuit configuration (config-if-atm-vc)
Command History
Release
|
Modification
|
12.1(3)XG
|
This command was introduced.
|
12.2(2)T
|
This command was integrated into Cisco IOS Release 12.2(2)T.
|
12.2(13)T
|
This command was modified. The
dial-on-demand keyword was added to allow the configuration of the DDR interesting traffic control list functionality.
|
12.2(28)SB
|
This command was integrated into Cisco IOS Release 12.2(28)SB.
|
12.4(24)T
|
This command was integrated into Cisco IOS Release 12.4(24)T and the PPPoE client functionality was modified to support multiple
clients on a single ATM PVC.
|
15.2(4)M
|
This command was modified. The
mac-override keyword was added.
|
Usage Guidelines
One PVC supports multiple PPPoE clients, enabling second line connection and redundancy. Use the
pppoe-client
dial-pool-number command to configure one or more concurrent client PPPoE sessions on a single ATM PVC. When a PPPoE session is established
in a single PVC, a MAC address that is configured on a dialer interface is used as the local address for multiple PPPoE clients.
Use this command to configure the DDR interesting traffic control list functionality of the dialer interface with a PPPoE
client. When the DDR functionality is configured for this command, the following DDR commands must also be configured:
dialer-group ,
dialer
hold-queue ,
dialer
idle-timeout , and
dialer-list .
Tips for Configuring the Dialer Interface
If you are configuring a hard-coded IP address under the dialer interface, you can configure a default IP route using the
ip
route command:
ip route 0.0.0.0 0.0.0.0 dialer1
But, if you are configuring a negotiated IP address using the
ip
address
negotiated command under the dialer interface, you must configure a default IP route using the
ip
route command:
ip route 0.0.0.0 0.0.0.0 dialer1 permanent
The reason for this configuration is that the dialer interface will lose its IP address when a PPPoE session is brought down
(even if the dialer does not go down), and thereby risk removing routes and all IP routes pointed at the dialer interface,
including the default IP route. Although the default IP routed back within a minute by IP background processes, you may risk
losing incoming packets during the interval.
Examples
The following example shows how to configure multiple PPPoE clients on a single ATM PVC:
Device(config)# interface ATM0
Device(config-if)# no ip address
Device(config-if)# no ip mroute-cache
Device(config-if)# no atm ilmi-keepalive
Device(config-if)# pvc 4/20
Device(config-if)# pppoe-client dial-pool-number 1
Device(config-if)# pppoe-client dial-pool-number 2
The following example shows how to configure restart time:
Device(config)# pppoe-client dial-pool-number 8 restart 80 service-name "test 4"
Device(config)# pppoe-client dial-pool-number 2 dial-on-demand restart 10
The following example shows how to configure multiple PPPoE clients on a dialer PVC interface with a configurable MAC address:
Device(config)# interface ATM0
Device(config-if)# no ip address
Device(config-if)# no atm ilmi-keepalive
Device(config-if)# pvc 1/32
Device(config-if)# pppoe-client dial-pool-number 2 mac-override
Device(config-if)# pppoe-client dial-pool-number 1 mac-override
Device(config)# interface Dialer1
Device(config-if)# mac-address aaaa.aaaa.aaaa
Device(config-if)# ip address negotiated
Device(config-if)# encapsulation ppp
Device(config-if)# dialer pool 1
Device(config)# interface Dialer2
Device(config-if)# mac-address 0002.0002.0002
Device(config-if)# ip address negotiated
Device(config-if)# encapsulation ppp
Device(config-if)# dialer pool 2
Examples
The following example shows how to configure the PPPoE client DDR idle timer on an Ethernet interface and includes the required
DDR commands:
Device(config)# vpdn enable
Device(config)# no vpdn logging
Device(config)# vpdn-group 1
Device(config)# request-dialin
Device(config)# protocol pppoe
Device(config)# interface Ethernet1
Device(config-if)# pppoe enable
Device(config-if)# pppoe-client dial-pool-number 1 dial-on-demand
Device(config)# interface Dialer1
Device(config-if)# ip address negotiated
Device(config-if)# ip mtu 1492
Device(config-if)# encapsulation ppp
Device(config-if)# dialer pool 1
Device(config-if)# dialer idle-timeout 180 either
Device(config-if)# dialer hold-queue 100
Device(config-if)# dialer-group 1
Device(config-if)# dialer-list 1 protocol ip permit
Examples
The following example shows how to configure the PPPoE client DDR idle timer on an ATM PVC interface and how to include the
required DDR commands:
Device(config)# vpdn enable
Device(config)# no vpdn logging
Device(config)# vpdn-group 1
Device(config)# request-dialin
Device(config)# protocol pppoe
Device(config)# interface ATM2/0
Device(config-if)# pvc 2/100
Device(config-if)# pppoe-client dial-pool-number 1 dial-on-demand
Device(config)# interface Dialer1
Device(config-if)# ip address negotiated
Device(config-if)# ip mtu 1492
Device(config-if)# encapsulation ppp
Device(config-if)# dialer pool 1
Device(config-if)# dialer idle-timeout 180 either
Device(config-if)# dialer hold-queue 100
Device(config-if)# dialer-group 1
Device(config-if)# dialer-list 1 protocol ip permit