To configure an
IPv4 multicast boundary on an interface for a specified scope, use the
ip
multicast
boundary command in interface configuration mode
and virtual network interface . To remove the boundary, use the
no form of this
command.
ip multicast boundary access-list [filter-autorp]
no ip multicast boundary access-list [filter-autorp]
Cisco IOS Release 12.3(11)T
and Subsequent T and Mainline Releases
ip multicast boundary access-list [filter-autorp | in | out]
no ip multicast boundary access-list [filter-autorp | in | out]
Cisco IOS XE Release 3.13S
and Later Releases
ip multicast boundary block source
no ip multicast boundary block source
Syntax Description
access-list
|
Number or
name that identifies an access control list (ACL) that controls the range of
group addresses or (S, G) traffic affected by the boundary.
|
block source
|
Blocks
the source of all incoming multicast traffic on an interface.
|
filter-autorp
|
(Optional) Filters auto-rendezvous point (Auto-RP) messages denied by the
boundary ACL.
|
in
|
(Optional) Filters source traffic coming into the interface that is denied by
the boundary ACL.
|
out
|
(Optional) Prevents multicast route (mroute) states from being created on an
interface by filtering Protocol Independent Multicast (PIM) joins and Internet
Group Management Protocol (IGMP) reports for groups or channels that are denied
by the boundary ACL.
|
Command Default
No user-defined
boundaries are configured.
Command Modes
Interface configuration (config-if)
Virtual network interface (config-if-vnet)
Command History
Release
|
Modification
|
Cisco
IOS 11.1
|
This
command was introduced.
|
Cisco
IOS 12.0(22)S
|
This
command was modified. The
filter-autorp
keyword was added.
|
Cisco
IOS 12.1(12c)E
|
This
command was modified. The
filter-autorp
keyword was integrated into Cisco IOS Release 12.1(12c)E.
|
Cisco
IOS 12.2(11)
|
This
command was modified. The
filter-autorp
keyword was integrated into Cisco IOS Release 12.2(11).
|
Cisco
IOS 12.2(13)T
|
This
command was modified. The
filter-autorp
keyword was integrated into Cisco IOS Release 12.2(13)T.
|
Cisco
IOS 12.3(11)T
|
This
command was modified. The
in and
out keywords
were added.
|
Cisco
IOS 12.2(33)SRA
|
This
command was integrated into Cisco IOS Release 12.2(33)SRA.
|
Cisco
IOS 12.2SX
|
This
command is supported in the Cisco IOS Release 12.2SX train. Support in a
specific 12.2SX release of this train depends on your feature set, platform,
and platform hardware.
|
Cisco
IOS XE 3.2S
|
This
command was modified. Support was added for this command in virtual network
interface configuration mode. The
access-list
argument and
filter-autorp
keyword are no longer required with the
no form of
this command to remove the boundary ACL configuration.
|
Cisco
IOS XE 3.13S
|
This
command was modified. The
block and
source
keywords were added.
|
Usage Guidelines
Use the
ip
multicast
boundary command to configure an administratively
scoped (user-defined) boundary on an interface in order to filter source
traffic coming into the interface and prevent mroute states from being created
on the interface.
Note |
An IP multicast
boundary enables reuse of the same multicast group address in different
administrative domains.
|
A standard ACL is
used with the
ip
multicast
boundary command to define the group address range
to be permitted or denied on an interface. An extended ACL is used with the
ip
multicast
boundary to define (S, G) traffic to be permitted
or denied on an interface. Extended ACLs can also be used to define the (*, G)
state to be permitted or denied on an interface, by specifying
host
0.0.0.0 for the source address in the permit
statements that compose the extended ACL.
When you
configure IP multicast boundaries for (S, G) traffic in an Any Source Multicast
(ASM) network environment-to ensure that the IP multicast boundaries function
properly-you must configure an extended ACL on routers along the rendezvous
point tree (RPT) that permits:
-
(S, G)
traffic by specifying the source and group address range in permit statements.
-
(*, G)
traffic by specifying
host
0.0.0.0 for the source address followed by the
group address or group address range in permit statements.
-
Traffic
destined to the rendezvous point (RP) by including permit statements for (RP,
G), where the IP address of the RP is specified for the source followed by the
group address or group address range.
The IP multicast boundary
guideline for ASM applies only to the routers on the RPT from the last-hop
router to the RP. For routers on the RP-to-source branch, you need to define
only the (S, G) traffic in the extended ACL (by specifying the source and group
address range in permit statements).
When you
configure IP multicast boundaries for (S, G) traffic in a Source Specific
Multicast (SSM) network environment, you need to define only the (S, G) traffic
to be permitted or denied on an interface in the extended ACL.
IP multicast boundaries
filter data and control plane traffic including IGMP, PIM Join and Prune, and
Auto-RP messages. The following messages are not filtered by IP multicast
boundaries:
-
PIM Register
messages are sent using multicast and not filtered.
-
PIM Hellos for
neighbor-ship to 224.0.0.13 are not filtered.
-
Link local
messages are not affected and PIM hellos on the local segment are not filtered.
To disallow PIM adjacency formation on each link, use the
ip pim
neighbor-filter command in the interface or virtual network
interface configuration mode.
If you configure
the
filter-autorp
keyword, the user-defined boundary also examines Auto-RP discovery and
announcement messages and removes any Auto-RP group range announcements from
the Auto-RP packets that are denied by the boundary ACL. An Auto-RP group range
announcement is permitted and passed by the boundary only if all addresses in
the Auto-RP group range are permitted by the boundary ACL. If any address is
not permitted, the entire group range is filtered and removed from the Auto-RP
message before the Auto-RP message is forwarded.
Note |
Extended ACLs
cannot be used with the
filter-autorp
keyword because Auto-RP announcements do not contain source addresses.
|
In Cisco IOS
software releases that do not support the
in and
out keywords,
the IP multicast boundary both filters source traffic coming into the interface
and prevents mroute states from being created on the interface.
In Cisco IOS
releases that support the
in and
out keywords,
these keywords are used as follows:
-
The
in keyword is
used to filter source traffic coming into the interface.
-
The
out keyword
is used to prevent mroute states from being created on an interface; that is,
it will prevent IGMP reports and PIM joins from creating mroutes states for
groups and channels denied by the boundary ACL, and the interface will not be
included in the outgoing interface list (OIL).
-
If a
direction is not specified with the
ip
multicast
boundary command, the IP multicast boundary both
filters source traffic coming into the interface and prevents mroute states
from being created on the interface.
In addition, the
following rules govern the use of the
in ,
out , and
filter-autorp
keywords with the
ip
multicast
boundary command:
-
The
in and
out keywords
support standard or extended ACLs for (S, G) filtering.
-
The
in and
out keywords
support standard or extended ACLs for SSM filtering.
-
One instance
of the
in and
out keywords
can be configured on an interface.
-
Only standard
ACLs are permitted with the use of the
filter -autorp keyword.
In Cisco 7600
series routers:
-
A deny any
statement at the end of the boundary ACL will cause all multicast boundaries
including the link local address in the range (224.0.0.0 - 224.0.0.255) to be
dropped in the hardware.
-
When the ip
multicast boundary
access -list [filter -autorp ] command is configured with an empty ACL,
it interferes in the proper functioning of Auto-RP in the hardware. Hence, it
is important to specify the address you want to allow or deny in the
access-list.
In Cisco IOS XE
Release 3.2S and later releases, the
access-list
and
filter-autorp
argument and keyword are no longer required with the
no form of
this command.
In Cisco IOS XE
Release 3.1S and earlier releases, the
no
ip
multicast
boundary command must be configured with the ACL
and the
filter-autorp
keyword to remove the boundary ACL configuration.
A maximum of three
instances of an
ip
multicast
boundary command is allowed on an interface: one
instance of the command with the
in keyword,
one instance of the command with the
out keyword,
and one instance of the command with or without the
filter -autorp keyword.
Use the
ip
multicast
boundary
block
source command to block all incoming multicast
traffic on an interface. However, this command allows the multicast traffic to
flow out the interface and allows any reserved multicast packets to flow in the
interface. This command is primarily used at first-hop routers to prevent local
hosts from functioning as multicast sources.
Examples
The following
example shows how to set up an IP multicast boundary for all user-defined IPv4
multicast addresses by denying the entire user-defined IPv4 multicast address
space (239.0.0.0/8). All other Class D addresses are permitted (224.0.0.0/4).
access-list 1 deny 239.0.0.0 0.255.255.255
access-list 1 permit 224.0.0.0 15.255.255.255
interface ethernet 0
ip multicast boundary 1
The following
example shows how to set up an IP multicast boundary in an SSM network
environment. In this example, the IP multicast boundary is configured to permit
mroute states for (172.16.2.201, 232.1.1.1) and (172.16.2.202, 232.1.1.1). All
other (S, G) traffic is implicitly denied.
ip access-list extended acc_grp1
permit ip host 172.16.2.201 host 232.1.1.1
permit ip host 172.16.2.202 host 232.1.1.1
interface ethernet 2/3
ip multicast boundary acc_grp1 out
The following
example shows how to configure an IP multicast boundary in an ASM network
environment. In this example, the IP multicast boundary configuration on the
last-hop router is shown. The topology for this example is not illustrated;
however, assume that the IP address of the RP in this scenario is 10.1.255.104.
The IP multicast boundary is configured to filter outgoing IP multicast traffic
on Fast Ethernet interface 0/0. The boundary ACL used for the IP multicast
boundary in this scenario contains three permit statements:
-
The first
permit statement specifies the (S, G) traffic to be permitted.
-
The second
permit statement specifies the (RP, G) traffic to be permitted.
-
The third
permit statement specifies the (*, G) traffic to be permitted.
All other
outgoing multicast traffic on this interface is implicitly denied.
ip access-list extended bndry-asm-3
permit ip host 10.1.248.120 239.255.0.0 0.0.255.255
permit ip host 10.1.255.104 239.255.0.0 0.0.255.255
permit ip host 0.0.0.0 239.255.0.0 0.0.255.255
interface FastEthernet0/0
ip multicast boundary bndry-asm-3 out
The following
example shows how to block the source of all incoming multicast traffic on the
interface:
Device> enable
Device# configure terminal
Device(config)# int GigabitEthernet0/0/0
Device(config-if)# ip multicast boundary block source