To control the use of switching methods for forwarding IP packets, use the
ip
route-cache command in interface configuration mode. To disable any of these switching methods, use the
no form of this command.
ip route-cache [cef | distributed | flow | policy | same-interface]
no ip route-cache [cef | distributed | flow | policy | same-interface]
Syntax Description
cef
|
(Optional) Enables Cisco Express Forwarding operation on an interface.
|
distributed
|
(Optional) Enables distributed switching on the interface. (This keyword is not supported on the Cisco 7600 routers.) Distributed
switching is disabled by default.
|
flow
|
(Optional) Enables NetFlow accounting for packets that are received by the interface. The default is disabled.
|
policy
|
(Optional) Enables fast-switching for packets that are forwarded using policy-based routing (PBR). Fast Switching for PBR
(FSPBR) is disabled by default.
|
same-interface
|
(Optional) Enables fast-switching of packets onto the same interface on which they arrived.
|
Command Default
The switching method is not controlled.
Command Modes
Interface configuration (config-if)
Command History
Release
|
Modification
|
10.0
|
This command was introduced.
|
11.1
|
The
flow keyword was added.
|
11.2GS
|
The
cef and
distributed keywords were added.
|
11.1CC
|
cef
keyword support was added for multiple platforms.
|
12.0
|
The
policy keyword was added.
|
12.2(25)S
|
This command was integrated into Cisco IOS Release 12.2(25)S. The ip route-cache flow command is automatically remapped to
the ip flow ingress command.
|
12.2(28)SB
|
This command was integrated into Cisco IOS Release 12.2(28)SB. This command is not supported on the Cisco 10000 series router.
|
12.2(33)SRA
|
This command was integrated into Cisco IOS Release 12.2(33)SRA.
|
12.4(20)T
|
This command was integrated into Cisco IOS Release 12.4(20)T.
|
12.2(33)SXI
|
This command was integrated into Cisco IOS Release 12.2(33)SXI.
|
Usage Guidelines
IP Route Cache
Note |
The Cisco 10000 series routers do not support the
ip
route-cache command.
|
Using the route cache is often called
fast switching . The route cache allows outgoing packets to be load-balanced on a
per-destination basis rather than on a per-packet basis. The
ip
route-cache command with no additional keywords enables fast switching.
Entering the
ip
route-cache command has no effect on a subinterface. Subinterfaces accept the
no form of the command; however, this disables Cisco Express Forwarding or distributed Cisco Express Forwarding on the physical
interface and all subinterfaces associated with the physical interface
The default behavior for Fast Switching varies by interface and media.
Note |
IPv4 fast switching is removed with the implementation of the Cisco Express Forwarding infrastructure enhancements for Cisco
IOS 12.2(25)S-based releases and Cisco IOS Release 12.4(20)T. For these and later Cisco IOS releases, switching path are Cisco
Express Forwarding switched or process switched.
|
IP Route Cache Same Interface
You can enable IP fast switching when the input and output interfaces are the same interface, using the
ip
route-cache
same-interface command. This configuration normally is not recommended, although it is useful when you have partially meshed media, such
as Frame Relay or you are running Web Cache Communication Protocol (WCCP) redirection. You could use this feature on other
interfaces, although it is not recommended because it would interfere with redirection of packets to the optimal path.
IP Route Cache Flow
The flow caching option can be used in conjunction with Cisco Express Forwarding switching to enable NetFlow, which allows
statistics to be gathered with a finer granularity. The statistics include IP subprotocols, well-known ports, total flows,
average number of packets per flow, and average flow lifetime.
Note |
The
ip
route-cache
flow command has the same functionality as the
ip
flow
ingress command, which is the preferred command for enabling NetFlow. If either the
ip
route-cache
flow command or the
ip
flow
ingress command is configured, both commands will appear in the output of the
show
running-config command.
|
IP Route Cache Distributed
The distributed option is supported on Cisco routers with line cards and Versatile Interface Processors (VIPs) that support
Cisco Express Forwarding switching.
On Cisco routers with Route/Switch Processor (RSP) and VIP controllers, the VIP hardware can be configured to switch packets
received by the VIP with no per-packet intervention on the part of the RSP. When VIP distributed switching is enabled, the
input VIP interface tries to switch IP packets instead of forwarding them to the RSP for switching. Distributed switching
helps decrease the demand on the RSP.
If the
ip
route-cache
distributed ,
ip
cef
distributed , and
ip
route-cache
flow commands are configured, the VIP performs distributed Cisco Express Forwarding switching and collects a finer granularity
of flow statistics.
IP Route-Cache Cisco Express Forwarding
In some instances, you might want to disable Cisco Express Forwarding or distributed Cisco Express Forwarding on a particular
interface because that interface is configured with a feature that Cisco Express Forwarding or distributed Cisco Express Forwarding
does not support. Because all interfaces that support Cisco Express Forwarding or distributed Cisco Express Forwarding are
enabled by default when you enable Cisco Express Forwarding or distributed Cisco Express Forwarding operation globally, you
must use the
no form of the
ip
route-cache
distributed command in the interface configuration mode to turn Cisco Express Forwarding or distributed Cisco Express Forwarding operation
off a particular interface.
Disabling Cisco Express Forwarding or distributed Cisco Express Forwarding on an interface disables Cisco Express Forwarding
or distributed Cisco Express Forwarding switching for packets forwarded to the interface, but does not affect packets forwarded
out of the interface.
Additionally, when you disable distributed Cisco Express Forwarding on the RSP, Cisco IOS software switches packets using
the next-fastest switch path (Cisco Express Forwarding).
Enabling Cisco Express Forwarding globally disables distributed Cisco Express Forwarding on all interfaces. Disabling Cisco
Express Forwarding or distributed Cisco Express Forwarding globally enables process switching on all interfaces.
Note |
On the Cisco 12000 series Internet router, you must not disable distributed Cisco Express Forwarding on an interface.
|
IP Route Cache Policy
If Cisco Express Forwarding is already enabled, the
ip
route-cache
route command is not required because PBR packets are Cisco Express Forwarding-switched by default.
Before you can enable fast-switched PBR, you must first configure PBR.
FSPBR supports all of PBR’s
match commands and most of PBR’s
set commands, with the following restrictions:
-
The
set
ip
default
next-hop and
set
default
interface commands are not supported.
-
The
set
interface command is supported only over point-to-point links, unless a route cache entry exists using the same interface specified
in the
set
interface command in the route map. Also, at the process level, the routing table is consulted to determine if the interface is on
a reasonable path to the destination. During fast switching, the software does not make this check. Instead, if the packet
matches, the software blindly forwards the packet to the specified interface.
Note |
Not all switching methods are available on all platforms. Refer to the
Cisco
Product
Catalog for information about features available on the platform you are using.
|
Examples
The following example shows how to enable fast switching and disable Cisco Express Forwarding switching:
Router(config)# interface ethernet 0/0/0
Router(config-if)# ip route-cache
The following example shows that fast switching is enabled:
Router# show ip interface fastEthernet 0/0/0
FastEthernet0/0/0 is up, line protocol is up
Internet address is 10.1.1.254/24
Broadcast address is 255.255.255.224
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Distributed switching is disabled
IP Feature Fast switching turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
The following example shows that Cisco Express Forwarding switching is disabled:
Router# show cef interface fastEthernet 0/0/0
FastEthernet0/0/0 is up (if_number 3)
Corresponding hwidb fast_if_number 3
Corresponding hwidb firstsw->if_number 3
Internet address is 10.1.1.254/24
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
Hardware idb is FastEthernet0/0/0
Fast switching type 1, interface type 18
IP CEF switching disabled
IP Feature Fast switching turbo vector
IP Null turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 1(1)
Slot 0 Slot unit 0 VC -1
Transmit limit accumulator 0x48001A02 (0x48001A02)
IP MTU 1500
The following example shows the configuration information for FastEthernet interface 0/0/0:
Router# show running-config
.
.
!
interface FastEthernet0/0/0
ip address 10.1.1.254 255.255.255.0
no ip route-cache cef
no ip route-cache distributed
!
The following example shows how to enable Cisco Express Forwarding (and to disable distributed Cisco Express Forwarding if
it is enabled):
Router(config-if)# ip route-cache cef
The following example shows how to enable VIP distributed Cisco Express Forwarding and per-flow accounting on an interface
(regardless of the previous switching type enabled on the interface):
Router(config)# interface e0
Router(config-if)# ip address 10.252.245.2 255.255.255.0
Router(config-if)# ip route-cache distributed
Router(config-if)# ip route-cache flow
The following example shows how to enable Cisco Express Forwarding on the router globally (which also disables distributed
Cisco Express Forwarding on any interfaces that are running distributed Cisco Express Forwarding), and disable Cisco Express
Forwarding (which enables process switching) on Ethernet interface 0:
Router(config)# ip cef
Router(config)# interface e0
Router(config-if)# no ip route-cache cef
The following example shows how to enable distributed Cisco Express Forwarding operation on the router (globally), and disable
Cisco Express Forwarding operation on Ethernet interface 0:
Router(config)# ip cef distributed
Router(config)# interface e0
Router(config-if)# no ip route-cache cef
The following example shows how to reenable distributed Cisco Express Forwarding operation on Ethernet interface 0:
Router(config)# ip cef distributed
Router(config)# interface e0
Router(config-if)# ip route-cache distributed
Examples
The following example shows how to enable fast switching and disable Cisco Express Forwarding switching:
Router(config)# interface ethernet 0/0/0
Router(config-if)# ip route-cache same-interface
The following example shows that fast switching on the same interface is enabled for interface fastethernet 0/0/0:
Router# show ip interface fastEthernet 0/0/0
FastEthernet0/0/0 is up, line protocol is up
Internet address is 10.1.1.254/24
Broadcast address is 255.255.255.224
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is enabled
IP Flow switching is disabled
IP Distributed switching is disabled
IP Feature Fast switching turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled
The following example shows the configuration information for FastEthernet interface 0/0/0:
Router# show running-config
.
.
!
interface FastEthernet0/0/0
ip address 10.1.1.254 255.255.255.0
ip route-cache same-interface
no ip route-cache cef
no ip route-cache distributed
!
Examples
The following example shows how to enable NetFlow switching:
Router(config)# interface ethernet 0/0/0
Router(config-if)# ip route-cache flow
The following example shows that NetFlow accounting is enabled for FastEthernet interface 0/0/0:
Router# show ip interface fastEthernet 0/0/0
FastEthernet0/0/0 is up, line protocol is up
Internet address is 10.1.1.254/24
Broadcast address is 255.255.255.224
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is enabled
IP Distributed switching is disabled
IP Flow switching turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, Flow
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled
Examples
The following example shows how to enable distributed switching:
Router(config)# ip cef distributed
Router(config)# interface ethernet 0/0/0
Router(config-if)# ip route-cache distributed
The following example shows that distributed Cisco Express Forwarding switching is for FastEthernet interface 0/0/0:
Router# show cef interface fastEthernet 0/0/0
FastEthernet0/0/0 is up (if_number 3)
Corresponding hwidb fast_if_number 3
Corresponding hwidb firstsw->if_number 3
Internet address is 10.1.1.254/24
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
Hardware idb is FastEthernet0/0/0
Fast switching type 1, interface type 18
IP Distributed CEF switching enabled
IP Feature Fast switching turbo vector
IP Feature CEF switching turbo vector
Input fast flags 0x0, Output fast flags 0x0
ifindex 1(1)
Slot 0 Slot unit 0 VC -1
Transmit limit accumulator 0x48001A02 (0x48001A02)
IP MTU 1500
Examples
The following example shows how to configure a simple policy-based routing scheme and to enable FSPBR:
Router(config)# access-list 1 permit 10.1.1.0 0.0.0.255
Router(config)# route-map mypbrtag permit 10
Router(config-route-map)# match ip address 1
Router(config-route-map)# set ip next-hop 10.1.1.195
Router(config-route-map)# exit
Router(config)# interface fastethernet 0/0/0
Router(config-if)# ip route-cache policy
Router(config-if)# ip policy route-map mypbrtag
The following example shows that FSPBR is enabled for FastEthernet interface 0/0/0:
Router# show ip interface fastEthernet 0/0/0
FastEthernet0/0/0 is up, line protocol is up
Internet address is 10.1.1.254/24
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Distributed switching is enabled
IP Feature Fast switching turbo vector
IP Feature CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, Distributed, Policy, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is enabled, using route map my_pbr_tag
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect inbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled