Flow-Based per Port-Channel Load Balancing

The Flow-Based per Port-Channel Load Balancing feature allows different flows of traffic over a Ten Gigabit EtherChannel (GEC) interface to be identified based on the packet header and then mapped to the different member links of the port channel. This feature enables you to apply flow-based load balancing and VLAN- manual load balancing to specific port channels.

Finding Feature Information

Your software release may not support all the features that are documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. The Feature Information Table at the end of this document provides information about the documented features and lists the releases in which each feature is supported.

Contents

Hardware Compatibility Matrix for the Cisco cBR Series Routers


Note


The hardware components that are introduced in a given Cisco IOS-XE Release are supported in all subsequent releases unless otherwise specified.
Table 1. Hardware Compatibility Matrix for the Cisco cBR Series Routers

Cisco CMTS Platform

Processor Engine

Interface Cards

Cisco cBR-8 Converged Broadband Router

Cisco IOS-XE Release 16.5.1 and Later Releases

Cisco cBR-8 Supervisor:

  • PID—CBR-SUP-250G

  • PID—CBR-CCAP-SUP-160G

  • PID—CBR-CCAP-SUP-60G

  • PID—CBR-SUP-8X10G-PIC

Cisco IOS-XE Release 16.5.1 and Later Releases

Cisco cBR-8 CCAP Line Cards:

  • PID—CBR-LC-8D30-16U30

  • PID—CBR-LC-8D31-16U30

  • PID—CBR-RF-PIC

  • PID—CBR-RF-PROT-PIC

  • PID—CBR-CCAP-LC-40G

  • PID—CBR-CCAP-LC-40G-R

Cisco cBR-8 Downstream PHY Modules:

  • PID—CBR-D30-DS-MOD

  • PID—CBR-D31-DS-MOD

Cisco cBR-8 Upstream PHY Modules:

  • PID—CBR-D30-US-MOD

  • PID—CBR-D31-US-MOD

Restrictions for Flow-Based per Port-Channel Load Balancing

  • Supports up to 64 Ten GEC interfaces.

  • Supports up to 8 member links per Ten GEC interface.

  • dot1q L2VPN is not supported over a port-channel with load-balancing vlan configured.

Information About Flow-Based per Port-Channel Load Balancing

Flow-Based Load Balancing

Flow-based load balancing identifies different flows of traffic based on the key fields in the data packet. For example, IPv4 source and destination IP addressees can be used to identify a flow. The various data traffic flows are then mapped to the different member links of a port channel. After the mapping is done, the data traffic for a flow is transmitted through the assigned member link. The flow mapping is dynamic and changes when there is any change in the state of a member link to which a flow is assigned. The flow mappings can also change if member links are added to or removed from the GEC interface. Multiple flows can be mapped to each member link.

Buckets for Flow-Based Load Balancing

Load balancing dynamically maps traffic flows to the member links of a Ten GEC interface through the concept of buckets. The various defined traffic flows are mapped to the buckets and the buckets are evenly distributed among the member links. Each port channel maintains 16 buckets, with one active member link associated with each bucket. All traffic flows mapped to a bucket use the member link to which the bucket is assigned.

The router creates the buckets-to-member links mappings when you apply flow-based load balancing to a port channel and the port channel has at least one active member link. The mappings are also created when the first member link is added, or comes up, and the load-balancing method is set to flow-based.

When a member link goes down or is removed from a port channel, the buckets associated with that member link are redistributed among the other active member links in a round-robin fashion. When a member link comes up or is added to a port channel, some of the buckets associated with other links are assigned to this link.

If you change the load-balancing method, the bucket-to-member link mappings for flow-based load balancing are deleted. The mappings are also deleted if the port channel is deleted or the last member link in the port channel is deleted or goes down.

Load Balancing on Port Channels

GEC interfaces can use either dynamic flow-based load balancing or VLAN-manual load balancing. You can configure the load-balancing method globally for all port channels or directly on specific port channels. The global configuration applies only to those port channels for which you have not explicitly configured load balancing. The port-channel configuration overrides the global configuration.

Flow-based load balancing is enabled by default at the global level. You must explicitly configure VLAN load balancing or the load-balancing method is flow-based.

The table below lists the load-balancing method that is applied to port channels based on the configuration:

Table 2. Flow-Based Load Balancing Configuration Options

Global Configuration

Port-Channel Configuration

Load Balancing Applied

Not configured

Not configured

Flow-based

Flow-based

Flow-based

VLAN-manual

VLAN-manual

VLAN-manual

Not configured

VLAN-manual

Flow-based

Flow-based

VLAN-manual

VLAN-manual

The table below lists the configuration that results if you change the global load-balancing method.

Table 3. Results When Global Configuration Changes

Port-Channel Configuration

Global Configuration

Action Taken at Port-Channel

From

To

Not configured

Not configured

VLAN-manual

Changed from flow-based to VLAN-manual

VLAN-manual

Not configured

Changed from VLAN- manual to flow-based

Configured

Any

Any

No change

The table below lists the configuration that results if you change the port-channel load-balancing method.

Table 4. Results When Port-Channel Configuration Changes

Port-Channel Configuration

Global Configuration

Action Taken at Port-Channel

From

To

Not configured

Not configured

VLAN-manual

Changed from flow-based to VLAN-manual

Not configured

Flow-based

No action taken

VLAN-manual

Flow-based

Changed from VLAN-manual to flow-based

VLAN-manual

Not configured

Changed from VLAN- manual to flow-based

Flow-based

VLAN-manual

Changed from flow-based to VLAN-manual

Flow-based

Not configured

No action taken

Configured

Not configured

VLAN-manual

No action taken

Not configured

Flow-based

Changed from VLAN- manual to flow-based

VLAN-manual

Flow-based

Changed from VLAN-manual to flow-based

VLAN-manual

Not configured

No action taken

Flow-based

VLAN-manual

Changed from flow-based to VLAN-manual

Flow-based

Not configured

Changed from flow-based to VLAN-manual

How to Enable Flow-Based per Port-Channel Load Balancing

Configuring Load Balancing on a Port Channel

To configure load balancing on a port channel, perform the following steps. Repeat these steps for each GEC interface.

Before you begin

If you have already configured your desired load-balancing method globally and want to use that method for all port channels, you need not perform this task. To configure load balancing globally, use the port-channel load-balancing vlan-manual command. If you do not configure the global command, flow-based load balancing is applied to all port channels.

Procedure

  Command or Action Purpose

Step 1

enable

Example:


Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Router# configure terminal

Enters global configuration mode.

Step 3

interface port-channel channel-number

Example:


Router(config)# interface port-channel 1

Enters interface configuration mode and defines the interface as a port channel.

Step 4

load-balancing { flow | vlan }

Example:


Router(config-if)# load-balancing flow

Applies a load-balancing method to the specific port channel.

  • If you do not configure this command, the port channel uses the global load-balancing method configured with the port-channel load-balancing vlan-manual command. The global default is flow-based.

Step 5

end

Example:


Router(config-if)# end

Exits configuration mode.

Verifying Load Balancing Configuration on a Ten GEC Interface

  • show running-config interface port-channel channel-number —Displays the port channel configuration.

    Following is a sample output of this command:

    Router# show running-config interface port-channel 62
    Building configuration...
    
    Current configuration : 108 bytes
    !
    interface Port-channel62
     ip address 12.1.1.1 255.255.255.0
     ipv6 address 2001:12:1:1::1/64
     mpls 
    
    
  • show etherchannel load-balancing — Displays the load balancing method applied to each port channel.

    The following is a sample output of this command:

    Router# show etherchannel load-balancing
     
    EtherChannel Load-Balancing Method:
    Global LB Method: flow-based
    
      Port-Channel:                       LB Method
        Port-channel62                  :  flow-based
        Port-channel63                  :  flow-based
    
    
  • show interfaces port-channel channel-number etherchannel —Displays the bucket distribution currently in use.

    The following is a sample output for an interface with load balancing set to flow-based:

    
    Router(config)# show interface port-channel 62 etherchannel
     
     All IDBs List contains 8 configured interfaces
      Port: TenGigabitEthernet4/1/0 (index: 0)
      Port: TenGigabitEthernet4/1/1 (index: 1)
      Port: TenGigabitEthernet4/1/2 (index: 2)
      Port: TenGigabitEthernet4/1/3 (index: 3)
      Port: TenGigabitEthernet4/1/4 (index: 4)
      Port: TenGigabitEthernet4/1/5 (index: 5)
      Port: TenGigabitEthernet4/1/6 (index: 6)
      Port: TenGigabitEthernet4/1/7 (index: 7)
    
     Active Member List contains 8 interfaces
      Port: TenGigabitEthernet4/1/0
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/1
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/2
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/3
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/4
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/5
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/6
        LACP Mode: Active
    
      Port: TenGigabitEthernet4/1/7
        LACP Mode: Active
    
     Passive Member List contains 0 interfaces
     Load-Balancing method applied: flow-based
    
     Bucket Information for Flow-Based LB:
     Interface:                                Buckets
        TenGigabitEthernet4/1/0: 
                               Bucket 0 , Bucket 1
        TenGigabitEthernet4/1/1:
                               Bucket 2 , Bucket 3
        TenGigabitEthernet4/1/2:
                               Bucket 4 , Bucket 5
        TenGigabitEthernet4/1/3:
                               Bucket 6 , Bucket 7
        TenGigabitEthernet4/1/4:
                               Bucket 8 , Bucket 9
        TenGigabitEthernet4/1/5:
                               Bucket 10, Bucket 11
        TenGigabitEthernet4/1/6:
                               Bucket 12, Bucket 13
        TenGigabitEthernet4/1/7:
                               Bucket 14, Bucket 15
    
    

Configuration Examples for Flow-Based per Port-Channel Load Balancing

Example: Flow-Based Load Balancing

The following example shows a configuration where flow-based load balancing is configured on port-channel 2 while the VLAN-manual method is configured globally:


!
no aaa new-model
port-channel load-balancing vlan-manual
ip source-route
.
.
.
interface Port-channel2
 ip address 10.0.0.1 255.255.255.0
 no negotiation auto
 load-balancing flow
!
interface Port-channel2.10
 ip rsvp authentication key 11223344
 ip rsvp authentication
!
interface Port-channel2.50
 encapsulation dot1Q 50
!
interface TenGigabitEthernet4/1/0
 no ip address
 negotiation auto
 cdp enable
 channel-group 2
!

Additional References

Technical Assistance

Description Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/support

Feature Information for Flow-Based per Port-Channel Load Balancing

Use Cisco Feature Navigator to find information about the platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to the www.cisco.com/go/cfn link. An account on the Cisco.com page is not required.


Note


The following table lists the software release in which a given feature is introduced. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 5. Feature Information for Flow-Based per Port-Channel Load Balancing

Feature Name

Releases

Feature Information

Flow-based per port-channel Load balancing

Cisco IOS XE Everest 16.6.1

This feature was integrated into Cisco IOS XE Everest 16.6.1 onCisco cBR Series Converged Broadband Routers.