FEX QoS Configuration

FEX QoS Configuration Information


Note


FEX QoS is not supported on the Cisco Nexus 9508 switch (NX-OS 7.0(3)F3(3).



Note


Only 4Q queuing policy model is supported on FEX. When you try to bring up FEX in 8Q queuing policy mode you will get an error message.


  • Classification (system type qos policy)

    Type

    System Level

    Action

    Hardware Implementation

    Direction: IN

    FEX

    Switch

    match

    cos

    Yes

    No

    ip access list

    No

    No

    dscp

    No

    No

    ip

    No

    No

    precedence

    No

    No

    protocol

    No

    No

    set

    qos-group

    Yes

    No

    precedence

    No

    No

    dscp

    No

    No

    cos

    No

    No

    Type

    Interface Level

    Action

    Hardware Implementation

    Direction: IN

    FEX

    Switch

    match

    cos

    No

    Yes

    ip access list

    No

    Yes

    dscp

    No

    Yes

    ip

    No

    Yes

    precedence

    No

    Yes

    protocol

    No

    Yes

    set

    dscp

    No

    Yes

    precedence

    No

    Yes

    qos-group

    No

    Yes

    cos

    No

    Yes

  • Input queuing

    System Level

    Action

    Hardware Implementation

    Direction: IN

    FEX

    Switch

    Bandwidth

    Yes

    No

    Bandwidth Remaining

    Yes

    No

    Priority (only level 1)

    Yes

    No

    Interface Level

    Action

    Hardware Implementation

    Direction: IN

    FEX

    Switch

    Bandwidth

    No

    No

    Bandwidth Remaining

    No

    No

    Priority

    No

    No

  • Output queuing

    System Level

    Action

    Hardware Implementation

    Direction: OUT

    FEX

    Switch

    Bandwidth

    Yes

    Yes

    Bandwidth Remaining

    Yes

    Yes

    Priority

    (only level 1 on FEX, 3 levels on switch)

    Yes

    Yes

    Interface Level

    Action

    Hardware Implementation

    Direction: OUT

    FEX

    Switch

    Bandwidth

    No

    Yes

    Bandwidth Remaining

    No

    Yes

    Priority

    No

    Yes

TCAM Carving for FEX QoS

You must free up unused TCAM space to accommodate TCAM carving for FEX QoS.


Note


FEX QoS is not supported on the Cisco Nexus 9508 switch (NX-OS 7.0(3)F3(3).


  • For FEX QoS TCAM carving for IPv4 traffic, you can use the hardware access-list tcam region fex-qos 256 command.

    As a best practice, you can use the hardware access-list tcam region fex-qos-lite 256 command when policers are not used.


    Note


    The fex-qos-lite region does not have conformed policer statistics support for IPv4.
  • For IPv6 QoS TCAM carving support, you can use the hardware access-list tcam region fex-ipv6-qos 256 command.

  • For MAC based QoS TCAM carving support, you can use the hardware access-list tcam region fex-mac-qos 256 command.

  • When configuring end to end queuing from the HIF to the front panel port, the QoS classification policy needs to be applied to both system and HIF. This allows the FEX to queue on ingress appropriately (system) and allows the egress front panel port to queue appropriately (HIF).

    Example:

    
    system qos
      service-policy type qos input LAN-QOS-FEX
    
    interface Ethernet101/1/12
      service-policy type qos input LAN-QOS-FEX
    

Example of a FEX QoS Marking Policy Configuration

The following example is to configure set cos when the incoming traffic is untagged on the Layer 3 uplink port with DSCP values. In this way, it carries cos values to the FEX ports when traffic comes on the Layer 3 port and egress out on the FEX HIF port.


class-map type qos match-all DSCP8
       match dscp 8
class-map type qos match-all DSCP16
       match dscp 16
class-map type qos match-all DSCP32
       match dscp 32
policy-map type qos-remark
      class  DSCP8
           set qos-group 1
           set cos 0
      class  DSCP16
           set qos-group 2
           set cos 1
      class  DSCP32
           set qos-group 3
           set cos 3
     class  class-default

For configuring the uplink Layer 3 ports:


Int ethx/y
     Service-policy type qos input qos-remark

FEX QoS Configuration Example


Note


FEX QoS is not supported on the Cisco Nexus 9508 switch (NX-OS 7.0(3)F3(3).


The following are examples of the aspects of a FEX QoS configuration.

Classification (system type qos policy)

Policies of type qos are applied to classify incoming packets.

  • Class map configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    switch(config)# class-map type qos match-all cos0
    switch(config-cmap-qos)# match cos 0
    switch(config-cmap-qos)#
    switch(config-cmap-qos)# class-map type qos match-all cos1
    switch(config-cmap-qos)# match cos 1
    switch(config-cmap-qos)#
    switch(config-cmap-qos)# class-map type qos match-all cos2
    switch(config-cmap-qos)# match cos 2
    switch(config-cmap-qos)#
    switch(config-cmap-qos)# class-map type qos match-all cos3
    switch(config-cmap-qos)# match cos 3
    switch(config-cmap-qos)#
    
  • Policy map configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    switch(config)# policy-map type qos setpol 
    switch(config-pmap-qos)# class  cos0
    switch(config-pmap-c-qos)# set qos-group 1
    switch(config-pmap-c-qos)# class  cos1
    switch(config-pmap-c-qos)# set qos-group 2
    switch(config-pmap-c-qos)# class  cos3
    switch(config-pmap-c-qos)# set qos-group 3
    switch(config-pmap-c-qos)# class  class-default
    switch(config-pmap-c-qos)#
    
  • Attach service policy to system target configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    switch(config)# system qos 
    switch(config-sys-qos)# service-policy type qos input setpol
    
  • Verifying classification:

    
    switch# show policy-map system type qos
    
              Service-policy (qos) input:   setpol 
                policy statistics status:   disabled (current status: disabled)
    
                Class-map (qos):   cos0 (match-all)
                  Match: cos 0
                  set qos-group 1
    
                Class-map (qos):   cos1 (match-all)
                  Match: cos 1
                  set qos-group 2
    
                Class-map (qos):   cos23 (match-all)
                  Match: cos 2-3
                  set qos-group 3
    
                Class-map (qos):   class-default (match-any)
    
    
    
    switch# show queuing interface ethernet 101/1/1 
    
    slot  1
    =======
    Ethernet101/1/1 queuing information:
      Input buffer allocation:
      Qos-group: ctrl
      frh: 0
      drop-type: drop
      cos: 7
      xon       xoff      buffer-size
      ---------+---------+-----------
      2560      7680      10240    
      Qos-group: 0  1  2  3  (shared)
      frh: 2
      drop-type: drop
      cos: 0 1 2 3 4 5 6
      xon       xoff      buffer-size
      ---------+---------+-----------
      19200     24320     48640    
      Queueing:
      queue    qos-group    cos            priority  bandwidth mtu 
      --------+------------+--------------+---------+---------+----
      ctrl-hi  n/a          7               PRI         0      2400
      ctrl-lo  n/a          7               PRI         0      2400
      2        0            4 5 6           WRR        10      9280
      3        1            0               WRR        20      9280
      4        2            1               WRR        30      9280
      5        3            2 3             WRR        40      9280
      Queue limit: 66560 bytes
    
    Queue Statistics:
      queue  rx              tx              flags
      ------+---------------+---------------+-----
      0      0               68719476760      ctrl
      1      1               1                ctrl
      2      0               0                data
      3      1               109453           data
      4      0               0                data
      5      0               0                data
    
      Port Statistics:
      rx drop         rx mcast drop   rx error        tx drop         mux ovflow    
      ---------------+---------------+---------------+---------------+--------------
      0               0               0               0                InActive
    
      Priority-flow-control enabled: no
      Flow-control status: rx 0x0, tx 0x0, rx_mask 0x0
      cos     qos-group   rx pause  tx pause  masked rx pause
      -------+-----------+---------+---------+---------------
      0              1    xon       xon       xon 
      1              2    xon       xon       xon 
      2              3    xon       xon       xon 
      3              3    xon       xon       xon 
      4              0    xon       xon       xon 
      5              0    xon       xon       xon 
      6              0    xon       xon       xon 
      7            n/a    xon       xon       xon 
    
      DSCP to Queue mapping on FEX
     ----+--+-----+-------+--+---
    
     DSCP to Queue map disabled
    
     FEX TCAM programmed successfully
    
    switch# 
    
    
    switch# attach fex 101 
    
    fex-101# show platform software qosctrl port 0 0 hif 1
    number of arguments 6: show port 0 0 3 1 
    --------------------------------------------------------
    QoSCtrl internal info {mod 0x0 asic 0 type 3 port 1}
    
    PI mod 0 front port 0 if_index 0x00000000 
       ups 0 downs 0 binds 0  
    Media type 0 
    Port speed 0 
    MAC addr b0:00:b4:32:05:e2 
    Port state: , Down
    
    Untagged COS config valid: no 
    Untagged COS dump: 
    rx_cos_def[0]=0, tx_cos_def[0]=0 
    rx_cos_def[1]=3, tx_cos_def[1]=3 
    Last queueing config recvd from supId: 0 
    -----SUP 0  start -----
    
    Queuing config per qos_group
    Interface queueing config valid: no 
    
     Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
    
    
    Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000000
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000000
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    
    -----SUP 0  end -----
    
    -----SUP 1  start -----
             
    Queuing config per qos_group
    Interface queueing config valid: no 
    
     Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
     Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000000
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000000
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
             
    -----SUP 1  end -----
    
    PFC 0 (disabled), net_port 0x0
    END of PI SECTION 
    HIF0/0/1
    
    
    Default CoS: 0
    CoS  Rx-Remap  Tx-Remap  Class
    ----+---------+---------+-----
    0    0         0         3    
    1    1         1         4    
    2    2         2         5    
    3    3         3         5    
    4    4         4         2    
    5    5         5         2    
    6    6         6         2    
    7    7         7         1    
    
    Class  FRH  CT-En  MTU-Cells [Bytes]
    ------+----+------+-----------------
    0      0    0      30  [2400 ]
    1      0    0      30  [2400 ]
    2      2    0      116 [9280 ]
    3      2    0      116 [9280 ]
    4      2    0      116 [9280 ]
    5      2    0      116 [9280 ]
    6      2    0      127 [10160]
    7      2    0      127 [10160]
    
    FRH configuration:
      Port En: 1, Tail Drop En: 0, Emergency Stop En: 1, Err Discard En: 1
    
    FRH  Xon  Xoff  Total  Pause  u-Pause  Class-Map
    ----+----+-----+------+------+--------+---------
    0    2    6     8      1      0        0x03
    1    0    0     0      0      0        0x00
    2    15   19    38     1      0        0x3c
    3    0    0     0      0      0        0x00
    4    0    0     0      0      0        0x00
    5    0    0     0      0      0        0x00
    6    0    0     0      0      0        0x00
    7    0    0     0      0      0        0x00
    
    Global FRH:
      FRH Map: 0x00, Pause Class Map: 0x00
      Xoff Threshold: 0, Total Credits: 0
    
    Pause configuration:
      PFC disabled
      Rx PFC CoS map: 0x00, Tx PFC CoS map: 0x00
    
    
    Index  CoS-to-Class  Class-to-CoS------+-------------+------------
    0      0x00          0xff
    1      0x00          0xff
    2      0x00          0xff
    3      0x00          0xff
    4      0x00          0xff
    5      0x00          0xff
    6      0x00          0xff
    7      0x00          0xff
    
    OQ configuration:
      Credit Quanta: 1, IPG Adjustment: 0
      PQ0 En: 0, PQ0 Class: 0
      PQ1 En: 0, PQ1 Class: 0
    
    Class  XoffToMap  TD  HD  DP  Grp  LSP  GSP  CrDec  bw
    ------+----------+---+---+---+----+----+----+-----+----
    0      0 0        1   0   0   0    1    0    0       0
    1      0 0        1   0   0   1    0    1    0       0
    2      0 0        1   0   0   2    0    0    50     10
    3      0 0        1   0   0   2    0    0    24     20
    4      0 0        1   0   0   2    0    0    16     30
    5      0 0        1   0   0   2    0    0    12     40
    6      0 0        1   0   0   2    0    0    0       0
    7      0 0        1   0   0   2    0    0    0       0
    
    SS statistics:
    Class  Rx (WR_RCVD)            Tx (RD_SENT)          
    ------+-----------------------+----------------------
    0      0                       0                     
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Discard (WR_DISC):               0                     
    Rx Multicast Discard (WR_DISC_MC):  0                     
    Rx Error (WR_RCV_ERR):              0                     
             
    OQ statistics:
    Packets flushed:   0                     
    Packets timed out: 0  
    
    
    Pause statistics:
    CoS    Rx PFC Xoff             Tx PFC Xoff           
    ------+-----------------------+----------------------
    0      0                       0                     
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Xoff:           0                     
    Rx Xon:            0                     
    Tx Xoff:           0                     
    Tx Xon:            0                     
    Rx PFC:            0                     
    Tx PFC:            0                     
    Rx Xoff Status:    0x00
    Tx Xoff Status:    0x00
    
    SS  RdPort  Class  Head   Tail   QCount  RealQCountRx
    ---+-------+------+------+------+-------+------------
    0   1       0      3113   9348   0       0     
    0   1       1      11057  4864   0       0     
    0   1       2      5356   4257   0       0     
    0   1       3      12304  10048  0       0     
    0   1       4      11346  2368   0       0     
    0   1       5      162    165    0       0     
    0   1       6      14500  112    0       0     
    0   1       7      12314  9602   0       0     
    fex-101# 

Input queuing (system type queuing input policy)


Note


System input queuing is applied on NIF Ports for HIF to NIF traffic.


  • Class map (system defined class map) configuration:

    
    switch# show class-map type queuing 
      Type queuing class-maps
      ========================
        class-map type queuing match-any c-out-q3
          Description: Classifier for Egress queue 3
          match qos-group 3
    
        class-map type queuing match-any c-out-q2
          Description: Classifier for Egress queue 2
          match qos-group 2
    
        class-map type queuing match-any c-out-q1
          Description: Classifier for Egress queue 1
          match qos-group 1
    
        class-map type queuing match-any c-out-q-default
          Description: Classifier for Egress default queue
          match qos-group 0
    
        class-map type queuing match-any c-in-q3
          Description: Classifier for Ingress queue 3
          match qos-group 3
    
        class-map type queuing match-any c-in-q2
          Description: Classifier for Ingress queue 2
          match qos-group 2
    
        class-map type queuing match-any c-in-q1
          Description: Classifier for Ingress queue 1
          match qos-group 1
    
        class-map type queuing match-any c-in-q-default
          Description: Classifier for Ingress default queue
          match qos-group 0
    switch# 
  • Policy map configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    switch(config)# policy-map type queuing inq_pri 
    switch(config-pmap-que)# class type queuing c-in-q3
    switch(config-pmap-c-que)# priority level 1
    switch(config-pmap-c-que)# class type queuing c-in-q2
    switch(config-pmap-c-que)# bandwidth remaining percent 50
    switch(config-pmap-c-que)# class type queuing c-in-q1
    switch(config-pmap-c-que)# bandwidth remaining percent 30
    switch(config-pmap-c-que)# class type queuing c-in-q-default
    switch(config-pmap-c-que)# bandwidth remaining percent 20
    switch(config-pmap-c-que)#
    
  • Attach service policy to system target configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    switch(config)# system qos 
    switch(config-sys-qos)# service-policy type queuing input inq_pri
  • Verifying input queuing:

    
    switch# show policy-map system type queuing input 
    
              Service-policy (queuing) input:   inq_pri 
                policy statistics status:   disabled (current status: disabled)
    
                Class-map (queuing):   c-in-q3 (match-any)
                  priority level 1
    
                Class-map (queuing):   c-in-q2 (match-any)
                  bandwidth remaining percent 50
    
                Class-map (queuing):   c-in-q1 (match-any)
                  bandwidth remaining percent 30
    
                Class-map (queuing):   c-in-q-default (match-any)
                  bandwidth remaining percent 20
    
    
    switch# attach fex 101
    
    fex-101# show platform software qosctrl port 0 0 nif 1
    number of arguments 6: show port 0 0 2 1 
    --------------------------------------------------------
    QoSCtrl internal info {mod 0x0 asic 0 type 2 port 1}
    
    PI mod 0 front port 0 if_index 0x00000000 
       ups 0 downs 0 binds 0  
    Media type 3 
    Port speed 10000 
    MAC addr 00:00:00:00:00:00 
    Port state: , Down
     
    fabric_num 0, ctrl_vntag 0 
    ctrl_vlan 0, vntag_etype 0 
    
    Untagged COS config valid: no 
    Untagged COS dump: 
    rx_cos_def[0]=0, tx_cos_def[0]=0 
    rx_cos_def[1]=3, tx_cos_def[1]=3 
    
    Last queueing config recvd from supId: 0 
    
    -----SUP 0  start -----
    
    Queuing config per qos_group
    Interface queueing config valid: no 
    
    
    Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
     Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000004
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000005
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    
    -----SUP 0  end -----
    
    -----SUP 1  start -----
    
    Queuing config per qos_group
    Interface queueing config valid: no 
    
     Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
     Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000004
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000005
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    
    -----SUP 1  end -----
    
    
    PFC 1 (enabled), net_port 0x0
    END of PI SECTION 
    NIF0/0/1
    
    Default CoS: 0
    CoS  Rx-Remap  Tx-Remap  Class
    ----+---------+---------+-----
    0    0         0         3    
    1    1         1         4    
    2    2         2         5    
    3    3         3         5    
    4    4         4         2    
    5    5         5         2    
    6    6         6         2    
    7    7         7         1    
    
    Class  FRH  CT-En  MTU-Cells [Bytes]
    ------+----+------+-----------------
    0      0    1      30  [2400 ]
    1      0    1      30  [2400 ]
    2      2    1      116 [9280 ]
    3      3    1      116 [9280 ]
    4      4    1      116 [9280 ]
    5      5    1      116 [9280 ]
    6      2    1      127 [10160]
    7      2    1      127 [10160]
    
    FRH configuration:
      Port En: 1, Tail Drop En: 1, Emergency Stop En: 1, Err Discard En: 1
    
    FRH  Xon  Xoff  Total  Pause  u-Pause  Class-Map
    ----+----+-----+------+------+--------+---------
    0    2    6     16     1      0        0x03
    1    0    0     0      0      0        0x00
    2    0    0     0      0      0        0x04
    3    0    0     0      0      0        0x08
    4    0    0     0      0      0        0x10
    5    0    0     0      0      0        0x20
    6    0    0     0      0      0        0x00
    7    0    0     0      0      0        0x00
             
    Global FRH:
      FRH Map: 0x3c, Pause Class Map: 0x3c
      Xoff Threshold: 0, Total Credits: 0
    
    
    Pause configuration:
      PFC disabled
      Rx PFC CoS map: 0x00, Tx PFC CoS map: 0x00
    
    Index  CoS-to-Class  Class-to-CoS
    ------+-------------+------------
    0      0x00          0xff
    1      0x00          0xff
    2      0x00          0xff
    3      0x00          0xff
    4      0x00          0xff
    5      0x00          0xff
    6      0x00          0xff
    7      0x00          0xff
    
    OQ configuration:
      Credit Quanta: 1, IPG Adjustment: 0
      PQ0 En: 0, PQ0 Class: 0
      PQ1 En: 0, PQ1 Class: 0
    
    Class  XoffToMap  TD  HD  DP  Grp  LSP  GSP  CrDec  bw
    ------+----------+---+---+---+----+----+----+-----+----
    0      0 0        0   0   1   0    1    0    0       0
    1      0 0        0   0   1   1    0    1    0       0
    2      0 0        0   0   1   2    0    0    24     20
    3      0 0        0   0   1   2    0    0    16     30
    4      0 0        0   0   1   2    0    0    10     50
    5      0 0        0   0   1   2    0    1    255     0
    6      0 0        0   0   1   2    0    0    0       0
    7      0 0        0   0   1   2    0    0    0       0
    
    
    SS statistics:
    Class  Rx (WR_RCVD)            Tx (RD_SENT)          
    ------+-----------------------+----------------------
    0      0                       68719476736           
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Discard (WR_DISC):               0                     
    Rx Multicast Discard (WR_DISC_MC):  0                     
    Rx Error (WR_RCV_ERR):              0                     
    
    OQ statistics:
    Packets flushed:   0                     
    Packets timed out: 0                     
    
    Pause statistics:
    CoS    Rx PFC Xoff             Tx PFC Xoff           
    ------+-----------------------+----------------------
    0      0                       0                     
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Xoff:           0                     
    Rx Xon:            0                     
    Tx Xoff:           0                     
    Tx Xon:            0                     
    Rx PFC:            0                     
    Tx PFC:            0                     
    Rx Xoff Status:    0x00
    Tx Xoff Status:    0x00
    
    fex-101# 
    

Output queuing (system type queuing output policy)


Note


System Output queuing is applied on HIF Ports for NIF to HIF traffic.


  • Policy map (system defined policy map):

    
    switch# show policy-map type queuing default-out-policy 
    
      Type queuing policy-maps
      ========================
    
      policy-map type queuing default-out-policy 
        class type queuing c-out-q3
          priority level 1
        class type queuing c-out-q2
          bandwidth remaining percent 0
        class type queuing c-out-q1
          bandwidth remaining percent 0
        class type queuing c-out-q-default
          bandwidth remaining percent 100
    
  • Policy map (user defined policy map) configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    switch(config)# policy-map type queuing outq 
    switch(config-pmap-que)# class type queuing c-out-q3
    switch(config-pmap-c-que)# bandwidth percent 40 
    switch(config-pmap-c-que)# class type queuing c-out-q2
    switch(config-pmap-c-que)# bandwidth percent 30 
    switch(config-pmap-c-que)# class type queuing c-out-q1
    switch(config-pmap-c-que)# bandwidth percent 20 
    switch(config-pmap-c-que)# class type queuing c-out-q-default
    switch(config-pmap-c-que)# bandwidth percent 10
    switch(config-pmap-c-que)# 
    
  • Attach service policy to system target configuration:

    
    switch# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    
    switch(config)# system qos 
    switch(config-sys-qos)# service-policy type queuing output outq
    
  • Verifying output queuing:

    
    switch# show policy-map system type queuing output 
    
              Service-policy (queuing) output:   outq 
                policy statistics status:   disabled (current status: disabled)
    
                Class-map (queuing):   c-out-q3 (match-any)
                  bandwidth percent 40 
    
                Class-map (queuing):   c-out-q2 (match-any)
                  bandwidth percent 30 
    
                Class-map (queuing):   c-out-q1 (match-any)
                  bandwidth percent 20 
    
                Class-map (queuing):   c-out-q-default (match-any)
                  bandwidth percent 10
    
    
    switch# show queuing interface ethernet 101/1/1 
    
    slot  1
    =======
    Ethernet101/1/1 queuing information:
      Input buffer allocation:
      Qos-group: ctrl
      frh: 0
      drop-type: drop
      cos: 7
      xon       xoff      buffer-size
      ---------+---------+-----------
      2560      7680      10240    
      Qos-group: 0  1  2  3  (shared)
      frh: 2
      drop-type: drop
      cos: 0 1 2 3 4 5 6
      xon       xoff      buffer-size
      ---------+---------+-----------
      19200     24320     48640    
      Queueing:
      queue    qos-group    cos            priority  bandwidth mtu 
      --------+------------+--------------+---------+---------+----
      ctrl-hi  n/a          7               PRI         0      2400
      ctrl-lo  n/a          7               PRI         0      2400
      2        0            4 5 6           WRR        10      9280
      3        1            0               WRR        20      9280
      4        2            1               WRR        30      9280
      5        3            2 3             WRR        40      9280
      Queue limit: 66560 bytes
    
    
    Queue Statistics:
      queue  rx              tx              flags
      ------+---------------+---------------+-----
      0      0               68719476760      ctrl
      1      1               1                ctrl
      2      0               0                data
      3      1               109453           data
      4      0               0                data
      5      0               0                data
    
      Port Statistics:
      rx drop         rx mcast drop   rx error        tx drop         mux ovflow    
      ---------------+---------------+---------------+---------------+--------------
      0               0               0               0                InActive
    
      Priority-flow-control enabled: no
      Flow-control status: rx 0x0, tx 0x0, rx_mask 0x0
      cos     qos-group   rx pause  tx pause  masked rx pause
      -------+-----------+---------+---------+---------------
      0              1    xon       xon       xon 
      1              2    xon       xon       xon 
      2              3    xon       xon       xon 
      3              3    xon       xon       xon 
      4              0    xon       xon       xon 
      5              0    xon       xon       xon 
      6              0    xon       xon       xon 
      7            n/a    xon       xon       xon 
    
      DSCP to Queue mapping on FEX
     ----+--+-----+-------+--+---
    
     DSCP to Queue map disabled
    
     FEX TCAM programmed successfully
    
    switch# 
    
    
    switch# attach fex 101 
    fex-101# show platform software qosctrl port 0 0 hif 1
    number of arguments 6: show port 0 0 3 1 
    --------------------------------------------------------
    QoSCtrl internal info {mod 0x0 asic 0 type 3 port 1}
    
    PI mod 0 front port 0 if_index 0x00000000 
       ups 0 downs 0 binds 0  
    Media type 0 
    Port speed 0 
    MAC addr b0:00:b4:32:05:e2 
    Port state: , Down
    
    Untagged COS config valid: no 
    Untagged COS dump: 
    rx_cos_def[0]=0, tx_cos_def[0]=0 
    rx_cos_def[1]=3, tx_cos_def[1]=3 
    Last queueing config recvd from supId: 0 
    -----SUP 0  start -----
    
    Queuing config per qos_group
    Interface queueing config valid: no 
    
     Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
    
    Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000000
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000000
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    
    -----SUP 0  end -----
    
    -----SUP 1  start -----
             
    Queuing config per qos_group
    Interface queueing config valid: no 
    
     Queueing per qos_group: 00006|
        |id|bw%|bw_unit|priority
    grp |00|100|0000000|00000000
    grp |01|000|0000000|00000000
    grp |02|000|0000000|00000000
    grp |03|000|0000000|00000000
    grp |04|000|0000000|00000000
    grp |05|000|0000000|00000000
    
     Scheduling Classes 00008|
          |id|cbmp|qid|bw%|nor_bw%|bw_unit|prio|dir |q2cos|class_grp|wk_gmap
    class |00|0x01|000|000|0000000|0000007|0001|  TX| 0x80|000000000|0000000
    class |01|0x02|001|000|0000000|0000007|0001|  TX| 0x00|000000000|0000000
    class |02|0x04|002|000|0000000|0000007|0000|  TX| 0x08|000000002|0000000
    class |03|0x08|003|100|0000100|0000007|0000|  TX| 0xf7|000000003|0000000
    class |04|0x10|004|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |05|0x20|005|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |06|0x40|006|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
    class |07|0x80|007|000|0000000|0000007|0000|  TX| 0x00|000000003|0000000
             
    -----SUP 1  end -----
    
    PFC 0 (disabled), net_port 0x0
    END of PI SECTION 
    HIF0/0/1
    
    
    
    Default CoS: 0
    CoS  Rx-Remap  Tx-Remap  Class
    ----+---------+---------+-----
    0    0         0         3    
    1    1         1         4    
    2    2         2         5    
    3    3         3         5    
    4    4         4         2    
    5    5         5         2    
    6    6         6         2    
    7    7         7         1    
    
    Class  FRH  CT-En  MTU-Cells [Bytes]
    ------+----+------+-----------------
    0      0    0      30  [2400 ]
    1      0    0      30  [2400 ]
    2      2    0      116 [9280 ]
    3      2    0      116 [9280 ]
    4      2    0      116 [9280 ]
    5      2    0      116 [9280 ]
    6      2    0      127 [10160]
    7      2    0      127 [10160]
    
    FRH configuration:
      Port En: 1, Tail Drop En: 0, Emergency Stop En: 1, Err Discard En: 1
    
    FRH  Xon  Xoff  Total  Pause  u-Pause  Class-Map
    ----+----+-----+------+------+--------+---------
    0    2    6     8      1      0        0x03
    1    0    0     0      0      0        0x00
    2    15   19    38     1      0        0x3c
    3    0    0     0      0      0        0x00
    4    0    0     0      0      0        0x00
    5    0    0     0      0      0        0x00
    6    0    0     0      0      0        0x00
    7    0    0     0      0      0        0x00
    
    Global FRH:
      FRH Map: 0x00, Pause Class Map: 0x00
      Xoff Threshold: 0, Total Credits: 0
    
    Pause configuration:
      PFC disabled
      Rx PFC CoS map: 0x00, Tx PFC CoS map: 0x00
    
    
    Index  CoS-to-Class  Class-to-CoS------+-------------+------------
    0      0x00          0xff
    1      0x00          0xff
    2      0x00          0xff
    3      0x00          0xff
    4      0x00          0xff
    5      0x00          0xff
    6      0x00          0xff
    7      0x00          0xff
    
    OQ configuration:
      Credit Quanta: 1, IPG Adjustment: 0
      PQ0 En: 0, PQ0 Class: 0
      PQ1 En: 0, PQ1 Class: 0
    
    Class  XoffToMap  TD  HD  DP  Grp  LSP  GSP  CrDec  bw
    ------+----------+---+---+---+----+----+----+-----+----
    0      0 0        1   0   0   0    1    0    0       0
    1      0 0        1   0   0   1    0    1    0       0
    2      0 0        1   0   0   2    0    0    50     10
    3      0 0        1   0   0   2    0    0    24     20
    4      0 0        1   0   0   2    0    0    16     30
    5      0 0        1   0   0   2    0    0    12     40
    6      0 0        1   0   0   2    0    0    0       0
    7      0 0        1   0   0   2    0    0    0       0
    
    SS statistics:
    Class  Rx (WR_RCVD)            Tx (RD_SENT)          
    ------+-----------------------+----------------------
    0      0                       0                     
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Discard (WR_DISC):               0                     
    Rx Multicast Discard (WR_DISC_MC):  0                     
    Rx Error (WR_RCV_ERR):              0                     
             
    OQ statistics:
    Packets flushed:   0                     
    Packets timed out: 0
    
    
    Pause statistics:
    CoS    Rx PFC Xoff             Tx PFC Xoff           
    ------+-----------------------+----------------------
    0      0                       0                     
    1      0                       0                     
    2      0                       0                     
    3      0                       0                     
    4      0                       0                     
    5      0                       0                     
    6      0                       0                     
    7      0                       0                     
    Rx Xoff:           0                     
    Rx Xon:            0                     
    Tx Xoff:           0                     
    Tx Xon:            0                     
    Rx PFC:            0                     
    Tx PFC:            0                     
    Rx Xoff Status:    0x00
    Tx Xoff Status:    0x00
    
    SS  RdPort  Class  Head   Tail   QCount  RealQCountRx
    ---+-------+------+------+------+-------+------------
    0   1       0      3113   9348   0       0     
    0   1       1      11057  4864   0       0     
    0   1       2      5356   4257   0       0     
    0   1       3      12304  10048  0       0     
    0   1       4      11346  2368   0       0     
    0   1       5      162    165    0       0     
    0   1       6      14500  112    0       0     
    0   1       7      12314  9602   0       0     
    fex-101# 
    

Verifying the FEX QoS Configuration

Use the following commands to verify the FEX QoS configuration:

Command

Purpose

show class-map type [qos | queuing]

Displays information about configured class maps of type qos or queuing.

show policy-map type [qos | queueing]

Displays information about configured policy maps of type qos or queuing.

show policy-map system type [qos | queuing]

Displays information about all configured policy maps of type qos or queuing on the system.

show queuing interface ethernet

Displays information about queuing on the ethernet interface.