Configuring the Fabric Extender

This chapter describes how to configure a Cisco Nexus 2000 Series Fabric Extender using a parent device and includes the following sections:

Managing the Fabric Extender Feature Set

Installing the Fabric Extender Feature Set

SUMMARY STEPS

  1. configure terminal
  2. install feature-set fex
  3. exit

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

install feature-set fex

Example:

switch(config)# install feature-set fex

To uninstall the Fabric Extender feature set, use the no install feature-set fex command.

Note

 

Before you can uninstall the feature set, you must ensure that the feature set is installed in the default VDC and that the feature set is not enabled in any VDC.

Step 3

exit

Example:

switch(config)# exit
switch# 

Exits global configuration mode.

Uninstalling the Fabric Extender Feature Set

Ensure that you have enabled the Fabric Extender feature set.

SUMMARY STEPS

  1. configure terminal
  2. no install feature-set fex
  3. exit

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

no install feature-set fex

Example:

switch(config)# no install feature-set fex

Uninstalls the Fabric Extender feature set.

Step 3

exit

Example:

switch(config)# exit
switch#

Exits global configuration mode.

Enabling the Fabric Extender Feature Set

You can enable the installed Fabric Extender feature set in a VDC on the device.

SUMMARY STEPS

  1. configure terminal
  2. feature-set fex
  3. exit

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

feature-set fex

Example:

switch(config)# feature-set fex

Enables the Fabric Extender feature set. The feature set must be installed before it shows as an option to this command.

To disable the Fabric Extender feature set, use the no feature-set fex command.

Note

 

The no feature-set fex command might take some time to complete if the size of the configuration is very large. The command cleans up all of the configurations associated with the Fabric Extender feature set.

Step 3

exit

Example:

switch(config)# exit
switch# 

Exits global configuration mode.

Disabling the Fabric Extender Feature Set

Ensure that you have enabled the Fabric Extender feature set.

SUMMARY STEPS

  1. configure terminal
  2. no feature-set fex
  3. exit

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

no feature-set fex

Example:

switch(config)# no feature-set fex

Disables the installed Fabric Extender feature set in a VDC on the device.

Step 3

exit

Example:

switch(config)# exit
switch#

Exits global configuration mode.

Associating a Fabric Extender to a Fabric Interface

Associating a Fabric Extender to a Port Channel

Before you begin

Ensure that you have enabled the Fabric Extender feature set.

SUMMARY STEPS

  1. configure terminal
  2. interface port-channel channel
  3. switchport mode fex-fabric
  4. fex associate FEX-number
  5. (Optional) show interface port-channel channel fex-intf

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

interface port-channel channel

Example:
switch(config)# interface port-channel 4
switch(config-if)# 

Specifies a port channel to configure.

Step 3

switchport mode fex-fabric

Example:
switch(config-if)# switchport mode fex-fabric

Sets the port channel to support an external Fabric Extender.

Step 4

fex associate FEX-number

Example:
switch(config-if)# fex associate 101

Associates a FEX number to the Fabric Extender unit attached to the interface. The range is from 101 to 199.

Step 5

(Optional) show interface port-channel channel fex-intf

Example:
switch# show interface port-channel 4 fex-intf
(Optional)

Displays the association of a Fabric Extender to a port channel interface.

Example

This example shows how to associate the Fabric Extender to a port channel interface on the parent device:

switch# configure terminal
switch(config)# interface ethernet 1/28
switch(config-if)# channel-group 4
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface ethernet 1/29
switch(config-if)# channel-group 4
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface ethernet 1/30
switch(config-if)# channel-group 4
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface ethernet 1/31
switch(config-if)# channel-group 4
switch(config-if)# no shutdown
switch(config-if)# exit
switch(config)# interface port-channel 4
switch(config-if)# switchport
switch(config-if)# switchport mode fex-fabric
switch(config-if)# fex associate 101

Note


  • The fex associate command must be entered from the port channel interface, not from the physical interface.

  • When adding physical interfaces to port channels, all configurations on the port channel and physical interface must match.


This example shows how to display the association of the Fabric Extender and the parent device:

switch# show interface port-channel 4 fex-intf
Fabric           FEX
Interface        Interfaces
---------------------------------------------------
Po4              Eth101/1/48   Eth101/1/47   Eth101/1/46   Eth101/1/45
                 Eth101/1/44   Eth101/1/43   Eth101/1/42   Eth101/1/41
                 Eth101/1/40   Eth101/1/39   Eth101/1/38   Eth101/1/37
                 Eth101/1/36   Eth101/1/35   Eth101/1/34   Eth101/1/33
                 
 

Disassociating a Fabric Extender from an Fabric Interface

Before you begin

Ensure that you have enabled the Fabric Extender feature set.

SUMMARY STEPS

  1. configure terminal
  2. interface port-channel channel
  3. no fex associate <FEX-id>
  4. default interface ethernet <interface>
  5. no fex <FEX-id>

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:
switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

interface port-channel channel

Example:
switch(config)# interface port-channel 4
switch(config-if)# 

Specifies a port channel to configure.

Step 3

no fex associate <FEX-id>

Example:
switch(config-if)# no fex associate 101

Disassociates the Fabric Extender unit attached to the interface.

Step 4

default interface ethernet <interface>

Example:
switch(config)# default interface ethernet 1/1

Sets the default settings for the member interface of the fabric port channel.

Step 5

no fex <FEX-id>

Example:
switch(config)# no fex 101

Removes the FEX configuration.

Configuring Fabric Extender Global Features

You can configure global features on the Fabric Extender.

Before you begin

Ensure that you have enabled the Fabric Extender feature set.

SUMMARY STEPS

  1. configure terminal
  2. fex FEX-number
  3. (Optional) locator-led fex FEX-number
  4. (Optional) description desc
  5. (Optional) no description
  6. (Optional) no type
  7. (Optional) serial serial
  8. (Optional) no serial

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)# 

Enters global configuration mode.

Step 2

fex FEX-number

Example:

switch(config)# fex 101
switch(config-fex)# 

Enters FEX configuration mode for the specified Fabric Extender. The range of the FEX-number argument is from 101 to 199.

Note

 

If you need to change the FEX number, you must remove the previous configuration (using the no fex FEX-number command) before applying a new FEX number.

Step 3

(Optional) locator-led fex FEX-number

Example:


switch(config)# locator-led fex 101
(Optional)

Turns on the locator LED of a Fabric Extender. The range of the FEX-number argument is from 101 to 199.

Step 4

(Optional) description desc

Example:

switch(config-fex)# description Rack7A-N2K
(Optional)

Specifies the description. The default is the string FEXxxxx where xxxx is the FEX number. If the FEX number is 123, the description is FEX0123.

Step 5

(Optional) no description

Example:

switch(config-fex)# no description
(Optional)

Deletes the description.

Step 6

(Optional) no type

Example:

switch(config-fex)# no type
(Optional)

Deletes the FEX type. When a Fabric Extender is connected to the fabric interfaces and does not match the configured type that is saved in the binary configuration on the parent switch, all configurations for all interfaces on the Fabric Extender are deleted.

Step 7

(Optional) serial serial

Example:

switch(config-fex)# serial JAF1339BDSK
(Optional)

Defines a serial number string. If this command is configured, a switch allows the corresponding chassis ID to associate (using the fex associate command) only if the Fabric Extender reports a matching serial number string.

Caution

 

Configuring a serial number that does not match the specified Fabric Extender forces the Fabric Extender offline.

Step 8

(Optional) no serial

Example:

switch(config-fex)# no serial
(Optional)

Deletes the serial number string.

Configuration Examples

This section contains examples of FEX configurations.

Configuring a Host Interface in a vPC Topology Connected to Two FEXs

This example shows how to configure a host vPC with a FEX (host vPC attached to two different FEXs):

Switch 1 Configuration Switch 2 Configuration
config t
feature lacp
int e101/1/1-2
channel-group 10 mode active
no shutdown

Int port-channel10
switchport
  switchport mode trunk
  switchport trunk allowed vlan 1-20
vpc 10
config t
feature lacp
int e101/1/1-2
channel-group 10 mode active
no shutdown

Int port-channel10
switchport
  switchport mode trunk
  switchport trunk allowed vlan 1-20
vpc 10

Switch vPC Topology and Straight Through FEX Topologies (Host vPC)

The Straight through FEX is supported on the Cisco Nexus 9300-FX2 platform. Beginning with Cisco NX-OS Release 9.3(5) it is supported on the Cisco Nexus 9300-FX3 platform also.

In Cisco NX-OS Release 9.3(5), the following third-party equipment is not supported for straight-through FEX for Cisco Nexus 9300-FX3 platform switches: B22-HP, B22-IBM, B22-Dell, and B22-Fujitsu.

The following is an example of a straight through FEX topology:

Figure 1. Switch vPC Topology


Note that this topology shows:

  • The Cisco Nexus 9000 Series switch ports are directly connected to another switch or host and are configured as part of a port channel that becomes part of a vPC.

  • That vPC 20 is configured on port channel 20, which has Eth1/10 on N9k-1 and Eth2/1 on N9k-2 as members.

Figure 2. FEX Straight-Through Topology (Host vPC)


Note that this topology shows:

  • Each FEX is single-homed (straight-through FEX topology) with a Cisco Nexus 9000 Series switch. The host interfaces on this FEX are configured as port channels and those port channels are configured as vPCs.

  • Eth100/1/1 on N9k-1 and Eth102/1/5 on N9k-2 are configured as members of PO200 and PO200 is configured for vPC 200.

In both topologies, port channels P020 and P0200 must be configured identically on the peer switches and configuration synchronization is used to synchronize the configurations of the vPC switches.

The following table compares the sample running configuration that must be configured for the peer switches shown in the Switch vPC Topology and the FEX Straight-Through Topology (Host vPC).

Table 1. Running Configuration Example for a vPC Straight-Through Topology

Basic Configuration—No Port Profile

Port Profile Configuration

vlan 1-10
vlan 1-10

interface port-channel 20
    switchport mode trunk
    vpc 20
    switchport trunk allowed vlan 1-5

port-profile type port-channel pc-profile
    switchport mode trunk
    state enabled

interface port-channel 200
    switchport mode trunk
    vpc 200
    switchport trunk allowed vlan 1-5

interface port-channel 20
    inherit port-profile pc-profile
    vpc 20
    switchport trunk allowed vlan 1-5

interface Ethernet1/10
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 20

interface port-channel 200
    inherit port-profile pc-profile
    vpc 200
    switchport trunk allowed vlan 1-5

interface Ethernet100/1/1
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200

interface Ethernet1/10
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 20

interface Ethernet100/1/1
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200
New Deployment in a vPC Topology and Straight-Through FEX Topology

In a new deployment, configuration synchronization is introduced initially to synchronize the new configuration. Because it is a new deployment, there is no existing running configuration on the FEX ports.

The following example shows how to configure the peer switches in the Switch vPC Topology and the FEX Straight-Through Topology (Host vPC):

  • Configure the CFS over IPV4 distribution to change the multicast address.

    
    N9k-1(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network
    Are you sure? (y/n) [n] y
    
    N9k-2(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network.
    Are you sure? (y/n) [n] y
  • Configure the CFSoIP multicast address on each peer switch

    
    N9k-1(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
    
    N9k-2# config terminal
    N9k-2(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
  • Enable CFSoIP on both switches.

    
    N9k-1(config)# cfs ipv4 distribute
    
    N9k-2(config)# cfs ipv4 distribute
  • Create a switch profile and configure the peer on both switches.

    
    N9k-1# config sync
    N9k-1(config-sync)# switch-profile Test
    N9k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch
    N9k-2>
    N9k-2# config sync
    N9k-2(config-sync)# switch-profile Test
    N9k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch
    N9k-1>
  • Add the referred global configuration to the switch profile. Because the configuration on the interfaces will be synchronized, all policies that are applied on the interface must be synchronized (for example, port profiles, QoS and ACL policies).

    
    N9k-1(config-sync-sp)# port-profile type port-channel pc-profile
    N9k-1(config-sync-port-prof)# switchport mode trunk
    N9k-1(config-sync-port-prof)# state enabled
  • Create port-channel interfaces inside the switch profile.


    Note


    Use switch profile mode to create the port-channel interfaces.


    
    N9k-1(config-sync-sp)# interface port-channel 20
    N9k-1(config-sync-sp)# interface port-channel 200
  • Commit the configuration in the switch profile.

    
    N9k-1(config-sync-sp)# commit
  • Add members to the port channel in configuration terminal mode on both switches. When the configuration is done in configuration terminal mode, both switches must be configured independently.


    Note


    In this topology, port-channel members must not be identical on the peer switches.


    
    N9k-1(config)# interface Ethernet1/10
    N9k-1(config-if)# channel-group 20 force
    N9k-1(config)# interface Ethernet100/1/1
    N9k-1(config-if)# channel-group 200 force
    
    N9k-2(config)# interface Ethernet2/1
    N9k-2(config-if)# channel-group 20 force
    N9k-2(config)# interface Ethernet102/1/5
    N9k-2(config-if)# channel-group 200 force
    
    N9k-1(config)# interface Ethernet100/1/1
    N9k-1(config-if)# switchport mode trunk
    N9k-1(config-if)# switchport trunk allowed vlan 1-5
    
    N9k-2(config)# interface Ethernet2/1
    N9k-2(config-if)# switchport mode trunk
    N9k-2(config-if)# switchport trunk allowed vlan 1-5
    
    N9k-2(config)# interface Ethernet102/1/5
    N9k-2(config-if)# switchport mode trunk
    N9k-2(config-if)# switchport trunk allowed vlan 1-5
  • Modify the port-channel configuration in the switch profile.

    
    N9k-1(config-sync-sp)# interface port-channel 20
    N9k-1(config-sync-sp-if)# inherit port-profile pc-profile
    N9k-1(config-sync-sp-if)# vpc 20
    N9k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
    N9k-1(config-sync-sp)# interface port-channel 200
    N9k-1(config-sync-sp-if)# inherit port-profile pc-profile
    N9k-1(config-sync-sp-if)# vpc 200
    N9k-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
  • Commit the configuration in the switch profile.

    
    N9k-1(config-sync-sp)# commit
Existing Deployments in a vPC Topology and Straight-Through FEX Topology

In an existing deployment, the configurations are already present and configuration synchronization is used to simplify future configuration modifications.

The following example shows how to configure the peer switches in the Switch vPC Topology and the FEX Straight-Through Topology (Host vPC):

  • Configure the CFS over IPV4 distribution to change the multicast address
    
    N9k-1(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network
    Are you sure? (y/n) [n] y
    
    N9k-2(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network.
    Are you sure? (y/n) [n] y
  • Configure the CFSoIP multicast address on each peer switch
    
    N9k-1(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
    
    N9k-2# config terminal
    N9k-2(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
  • Enable CFSoIP on both switches.
    
    N9k-1(config)# cfs ipv4 distribute
    
    N9k-2(config)# cfs ipv4 distribute
  • Create a switch profile on both switches.
    
    N9k-1# config sync
    N9k-1(config-sync)# switch-profile Test
    
    N9k-2# config sync
    N9k-2(config-sync)# switch-profile Test
  • Import the running configuration.
    
    N9k-1(config-sync-sp)# import running-config
    N9k-1(config-sync-sp-import)# show switch-profile Test buffer
    Import the configuration to the switch profile on both switches. You can import the configuration using one of the following three methods:
    • Running configuration—All configurations that are allowed inside a switch profile are imported.

      You must remove unwanted configurations. For example, you must remove port-channel member configurations.

    • Interface configuration—Only specified interface configurations are imported.

    • Manual mode—Selected configurations are imported. If the configuration that needs to be imported is small, use the manual mode to paste the desired configuration.

      The following shows the command sequence to import the running configuration:

      Table 2. Command Sequence to Import the Running Configuration

      Buffer Sequence Number

      Command

      
      1
      
      
      vlan 1-10
      
      
      2
      2.1
      2.2
      2.3
      
      
      interface port-channel20
         switchport mode trunk
         vpc 20
         switchport trunk allowed vlan 1-5
      
      
      3
      3.1
      3.2
      
      
      interface port-channel100
          switchport mode fex-fabric
          fex associate 101
      
      
      4
      4.1
      4.2
      4.3
      

      Note

       

      Switch vPC Topology

      
      interface port-channel20
          switchport mode trunk
          vpc 20
          switchport trunk allowed vlan 1-5
      
      
      4
      4.1
      4.2
      4.3
      

      Note

       

      FEX Straight-Through Topology (Host vPC)

      
      interface port-channel200
          switchport mode trunk
          vpc 200
          switchport trunk allowed vlan 1-5
      
      
      5
      5.1
      5.2
      5.3
      
      
      interface Ethernet1/1
          fex associate 101
          switchport mode fex-fabric
          channel-group 100
      
      
      6
      6.1
      6.2
      6.3
      
      
      interface Ethernet1/2
          fex associate 101
          switchport mode fex-fabric
          channel-group 100
      
      
      7
      7.1
      7.2
      7.3
      
      
      interface Ethernet1/10
          switchport mode trunk
          switchport trunk allowed vlan 1-5
          channel-group 20
      
      
      8
      8.1
      8.2
      8.3
      
      
      interface Ethernet100/1/1
          switchport mode trunk
          switchport trunk allowed vlan 1-5
          channel-group 200
      
    
    N9k-2(config-sync-sp)# import running-config
  • (Optional) If you do not want to synchronize the fabric configuration, remove the fabric configuration and the member interfaces of PO 20 and PO 200 from the buffer.
    
    N9k-1(config-sync-sp-import)# buffer-delete 3,5,6-8
    

    The buffer-delete command deletes the unwanted configuration from the buffer.

  • Commit the configuration in the switch profile on both switches.
    
    N9k-1(config-sync-sp-import)# commit
    
    N9k-2(config-sync-sp-import)# commit
    
  • Add the sync peer on both switches.


    Note


    When importing a configuration, use the sync-peers command after you import configurations on both switches independently.


    
    N9k-1# config sync
    N9k-1(config-sync)# switch-profile Test
    N9k-1(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch
    N9k-2>
    
    N9k-2# config sync
    N9k-2(config-sync)# switch-profile Test
    N9k-2(config-sync-sp)# sync-peers destination <out of band mgmt0 IP address of peer switch
    N9k-1>
    
    N9K-1# configure sync
    Enter configuration commands, one per line. End with CNTL/Z.
    N9K-1(config-sync)# no switch-profile SP ?
      all-config    Deletion of profile, local and peer configurations
      local-config  Deletion of profile and local configuration
      profile-only  Deletion of profile only and no other configuration
     
    N9396PX-1(config-sync)# no switch-profile SP
    

    Caution


    When you remove a switch profile using the no switch-profile name [all-config | local-config] command, the configuration in the switch profile is immediately removed from the running configuration. This disrupts the configurations that were present in the switch profile, such as port channel and vPC configurations.

    When you remove a switch profile using the no switch-profile name [profile-only] command, the configuration in the switch profile is immediately removed from the switch profile only. This does not disrupt the configurations that were present in running config.


    It is recommended to execute the CLI resync-database on both peer switches before deleting a large configuration in the switch-profile.

    Perform the following action if you received the "Deletion of switch profile failed" error message when attempting to delete switch-profile:
     
    N9K-1(config-sync)# resync-database
    Re-synchronization of switch-profile db takes a few minutes...
    Re-synchronize switch-profile db completed successfully.
    N9K-1(config-sync)#
    N9K-2(config-sync)# resync-database
    Re-synchronization of switch-profile db takes a few minutes...
    Re-synchronize switch-profile db completed successfully.
    N9K-2(config-sync)#

Dual-Homed FEX Topology (Active-Active FEX Topology)

The dual-homed FEX (active-active) topology is supported beginning with Cisco NX-OS Release 7.0(3)I5(2) for Cisco Nexus 9300 and 9300-EX Series switches.

Beginning with Cisco NX-OS Release 9.3(5), the Dual-Homed FEX is supported on the N9K-C9336C-FX2, N9K-C93240YC-FX2, N9K-C93360YC-FX2, and N9K-C93216TC-FX2 switches. The Cisco Nexus 9300-FX2 and FX3 switches are supported on the ST and the AA FEX modes.

In Cisco NX-OS Release 9.3(5), the following third-party equipment is not supported for Dual-Homed FEX for Cisco Nexus 9300-FX2/FX3 platform switches and straight-through FEX for Cisco Nexus 9300-FX3 platform switches: B22-HP, B22-IBM, B22-Dell, and B22-Fujitsu.

The following topology shows that each FEX is dual-homed with two Cisco Nexus 9300 Series switches. The FEX-fabric interfaces for each FEX are configured as a vPC on both peer switches. The host interfaces on the FEX appear on both peer switches.


Note


The port configuration should be the same on both switches.


Figure 3. Dual-Homed FEX Topology


In the dual-homed FEX topology, the vPC is already operational. FEX 101 is dual-homed to both parent switches: N9k-1 and N9k-2 on FEX-fabric interfaces Ethernet 1/1.


Note


A port channel within the same FEX is supported on Cisco Nexus 2200 Series Fabric Extenders.


FEX 101 is configured to have two types of host interfaces. One interface is Ethernet100/1/1, which is singly attached to a server (nonport-channel member), and the other interface is Ethernet 100/1/2-3, which is configured in a port channel to the server (port-channel member).

The following table shows the sample running configuration for the peer switches. Two types of configurations are shown:

  • Basic Configuration.

  • Port profile configuration.

You can use either option or you can use both configurations together.


Note


You can use port profiles to reduce operational overhead although they are not required.


Table 3. Running Configuration of a FEX in a Dual-Homed Topology for the Peer Switches

Basic Configuration—No Port Profile

Port Profile Configuration

vlan 1-10
vlan 1-10

interface port-channel100
    switchport mode fex fabric
    vpc 100
    fex associate 101

port-profile type ethernet eth-profile
    switchport mode trunk
    state enabled

interface port-channel 200
    switchport mode trunk
    switchport trunk allowed vlan 1-5

port-profile type port-channel pc-profile
    switchport mode trunk
    state enabled

interface Ethernet1/1
    fex associate 101
    switchport mode fex fabric
    channel-group 100

interface port-channel100
    switchport mode fex fabric
    vpc 100
    fex associate 101

interface Ethernet100/1/1
    switchport mode trunk
    switchport trunk allowed vlan 1-10

interface port-channel 200
    inherit port-profile pc-profile
    switchport trunk allowed vlan 1-5

interface Ethernet100/1/2
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200

interface Ethernet1/1
    fex associate 101
    switchport mode fex fabric
    channel-group 100

interface Ethernet100/1/3
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200

interface Ethernet100/1/1
    inherit port-profile eth-profile
    switchport trunk allowed vlan 1-10

interface Ethernet100/1/2
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200

interface Ethernet100/1/3
    switchport mode trunk
    switchport trunk allowed vlan 1-5
    channel-group 200
New Deployments in a Dual-Homed FEX Topology

In a new deployment, configuration synchronization is introduced from the beginning to synchronize the configuration across peer switches. As a result, there is no existing running configuration on the FEX ports.

The following example shows how to configure the dual-homed FEX (active-active) topology:

  • Configure the CFS over IPV4 distribution to change the multicast address.

    
    N9K-1(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network
    Are you sure? (y/n) [n] y
    
    N9K-2(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network.
    Are you sure? (y/n) [n] y
  • Configure the CFSoIP multicast address on each peer switch.

    
    N9K-1(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
    
    N9K-2# config terminal
    N9K-2(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
  • Enable CFSoIP on both switches.

    
    N9K-1(config)# cfs ipv4 distribute
    
    N9K-2(config)# cfs ipv4 distribute
  • Create a switch profile on both switches.

    
    N9K-1# config sync
    N9K-1(config-sync)# switch-profile Test
    N9K-1(config-sync-sp)# sync-peers destination /***out of band mgmt0 IP address of peer switch***/
    N9K-2>
    
    N9K-2# config sync
    N9K-2(config-sync)# switch-profile Test
    N9K-2(config-sync-sp)# sync-peers destination /***out of band mgmt0 IP address of peer switch***/
    N9K-1>
  • Add referred global configuration to the switch profile.


    Note


    Because interface configurations will be synchronized, all policies that are applied on the interface must be synchronized (for example, port profiles, QoS, and ACL policies).


    
    N9K-1(config-sync-sp)# port-profile type ethernet eth-profile
    N9K-1(config-sync-port-prof)# switchport mode trunk
    N9K-1(config-sync-port-prof)# state enabled
    
    N9K-1(config-sync-sp)# port-profile type port-channel pc-profile
    N9K-1(config-sync-port-prof)# switchport mode trunk
    N9K-1(config-sync-port-prof)# state enabled
  • Configure the Ethernet interfaces (the non-port-channel members) inside the switch profile.

    
    N9K-1(config-sync-sp)# interface Ethernet100/1/1
    N9K-1(config-sync-sp-if)# inherit port-profile eth-profile
    N9K-1(config-sync-sp-if)# switchport trunk allowed vlan 1-10
  • Create the port-channel interface inside the switch profile.


    Note


    You must configure port-channel interfaces in the switch profile, not in configuration terminal mode.


    This example shows that port channel 100 (vPC 100) is the EtherChannel from N9k to N2k:

    
    N9K-1(config-sync-sp)# interface Port-channel100

    This example shows that port channel 200 is the EtherChannel from N2k to the end device:

    
    N9K-1(config-sync-sp)# interface Port-channel200
  • Commit the configuration inside the switch profile.

    
    N9K-1(config-sync-sp)# commit
  • Add members to the port channel in configuration terminal mode on both switches.


    Note


    The configuration must be done on both switches in configuration terminal mode.


    This example shows that N9k-1- Ethernet1/1 is a FEX-fabric member of port channel 100:

    
    N9K-1(config)# int ether1/1
    N9K-1(config-if)# channel-group 100 force

    This example shows that N9K-1- Ethernet1/100/2-3 are members of port channel 200:

    
    N9K-1(config)# interface Ethernet100/1/2-3
    N9K-1(config-if-range)# channel-group 200 force

    This example shows that N9K-2- Ethernet1/1 is a FEX-fabric interface that is in port channel 100:

    
    N9K-2(config)# int ether1/1
    N9K-2(config-if)# channel-group 100 force

    This example shows that N9K-2- Ethernet1/100/2-3 are members of port channel 200:

    
    N9K-2(config)# interface Ethernet100/1/2-3
    N9K-2(config-if-range)# channel-group 200 force
    
    N9K-1(config)# interface Ethernet100/1/2-3
    N9K-1(config-if-range)# switchport mode trunk
    N9K-1(config-if-range)# switchport trunk allowed vlan 1-5
    
    N9K-2(config)# interface Ethernet100/1/2-3
    N9K-2(config-if-range)# switchport mode trunk
    N9K-2(config-if-range)# switchport trunk allowed vlan 1-5
    
  • Modify the port-channel configuration in the switch profile.

    
    N9K-1(config-sync-sp-if)# interface Port-Channel100
    N9K-1(config-sync-sp-if)# switchport mode fex-fabric
    N9K-1(config-sync-sp-if)# fex associate 101
    N9K-1(config-sync-sp-if)# vpc 100
    
    N9K-1(config-sync-sp)# interface Port-channel200
    N9K-1(config-sync-sp-if)# inherit port-profile pc-profile
    N9K-1(config-sync-sp-if)# switchport trunk allowed vlan 1-5
  • Commit the configuration in the switch profile.

    N9K-1(config-sync-sp)# commit
Existing Deployment with a Dual-Homed FEX Topology

In an existing deployment, the configurations are already present and configuration synchronization is used to simplify future configuration modifications.

The following example shows how to configure the peer switches in the vPC topology for the dual-homed FEX (active-active) topology:

  • Configure the CFS over IPV4 distribution to change the multicast address.
    
    N9K-1(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network
    Are you sure? (y/n) [n] y
    N9K-2(config)# no cfs ipv4 distribute
    This will prevent CFS from distributing over IPv4 network.
    Are you sure? (y/n) [n] y
    
  • Configure the CFSoIP multicast address on each peer switch.
    
    N9K-1(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
    
    N9K-2# config terminal
    N9K-2(config)# cfs ipv4 mcast-address 239.255.1.1
    Distribution over this IP type will be affected
    Change multicast address for CFS-IP?
    Are you sure? (y/n) [n] y
    
  • Enable CFSoIP on both switches.
    
    N9K-1(config)# cfs ipv4 distribute
    
    N9K-2(config)# cfs ipv4 distribute
    
  • Create a switch profile on both switches.
    
    N9K-1# config sync
    N9K-1(config-sync)# switch-profile Test
    
    N9K-2# config sync
    N9K-2(config-sync)# switch-profile Test
    
  • Commit the configuration in the switch profile on both switches.
    
    N9K-1(config-sync-sp)# commit
    
    N9K-2(config-sync-sp)# commit
    
  • Import the running configuration.
    
    N9K-1(config-sync-sp)# import running-config
    
    N9K-1(config-sync-sp-import)# show switch-profile Test buffer
    

    Import the configuration to the switch profile on both switches. You can import the configuration using one of the following three methods:

    • Running configuration—All configurations that are allowed inside a switch profile are imported.

      You must remove unwanted configurations. For example, you must remove port-channel member configurations if the member interfaces do not match on the peer switches.

    • Interface configuration—Only specified interface configurations are imported.

    • Manual mode—Selected configurations are imported. If the configuration that needs to be imported is small, use the manual mode to paste the desired configuration.

      The following shows the command sequence to import the running configuration:

      Table 4. Command Sequence to Import the Running Configuration

      Buffer Sequence Number

      Command

      
      1
      
      
      vlan 1-10
      
      
      2
      2.1
      2.2
      2.3
      
      
      interface port-channel100
          switchport mode fex-fabric
          vpc 100
          fex associate 101
      
      
      3
      3.1
      3.2
      
      
      interface port-channel200
          switchport mode trunk
          switchport trunk allowed vlan 1-5
      
      
      4
      4.1
      4.2
      4.3
      
      
      interface Ethernet1/1
          fex associate 101
          switchport mode fex-fabric
          channel-group 100
      
      
      5
      5.1
      5.2
      5.3
      
      
      interface Ethernet100/1/1
          switchport mode trunk
          switchport trunk allowed vlan 1-10
      
      
      6
      6.1
      6.2
      6.3
      
      
      interface Ethernet100/1/2
          switchport mode trunk
          switchport trunk allowed vlan 1-5
          channel-group 200
      
      
      7
      7.1
      7.2
      7.3
      
      
      interface Ethernet100/1/3
          switchport mode trunk
          switchport trunk allowed vlan 1-5
          channel-group 200
      
  • Remove member interfaces of PO 100 and PO 200 from the buffer.
    
    N9K-1(config-sync-sp-import)# buffer-delete 4, 6, 7
    

    Use the buffer-delete command to delete the unwanted configuration from the buffer.

  • Commit the configuration in the switch profile on both switches.
    
    N9K-1(config-sync-sp-import)# commit
    
    N9K-2(config-sync-sp-import)# commit
    
  • Add the sync peer on both switches.

    Note


    When importing the configuration, you must use the sync-peers command after the configurations are imported independently on both switches.


    
    N9K-1# config sync
    N9K-1(config-sync)# switch-profile sp
    N9K-1(config-sync-sp)# sync-peers destination /***out of band mgmt0 IP address of peer switch***/
    N9K-2>
    
    N9K-2# config sync
    N9K-2(config-sync)# switch-profile sp
    N9K-2(config-sync-sp)# sync-peers destination /***out of band mgmt0 IP address of peer switch***/
    N9K-1>
    
    N9K-1# configure sync
    Enter configuration commands, one per line. End with CNTL/Z.
    N9K-1(config-sync)# no switch-profile SP ?
      all-config    Deletion of profile, local and peer configurations
      local-config  Deletion of profile and local configuration
      profile-only  Deletion of profile only and no other configuration
     
    N9396PX-1(config-sync)# no switch-profile SP
    

    Caution


    When you remove a switch profile using the no switch-profile name [all-config | local-config] command, the configuration in the switch profile is immediately removed from the running configuration. This disrupts the configurations that were present in the switch profile, such as port channel and vPC configurations.

    When you remove a switch profile using the no switch-profile name [profile-only] command, the configuration in the switch profile is immediately removed from the switch profile only. This does not disrupt the configurations that were present in running config.


    It is recommended to execute the CLI resync-database on both peer switches before deleting a large configuration in the switch-profile.

    Perform the following action if you received the "Deletion of switch profile failed" error message when attempting to delete switch-profile:
     
    N9K-1(config-sync)# resync-database
    Re-synchronization of switch-profile db takes a few minutes...
    Re-synchronize switch-profile db completed successfully.
    N9K-1(config-sync)#
    N9K-2(config-sync)# resync-database
    Re-synchronization of switch-profile db takes a few minutes...
    Re-synchronize switch-profile db completed successfully.
    N9K-2(config-sync)#

Verifying the Configuration

This section describes how to display the configuration of the Fabric Extender and verify the chassis hardware status.

Verifying the Fabric Extender Configuration

Use the following commands to display configuration information about the defined interfaces on a Fabric Extender:

Command or Action

Purpose

show fex [ FEX-number] [ detail]

Displays information about a specific Fabric Extender or all attached units.

show interface type number fex-intf

Displays the Fabric Extender ports that are pinned to a specific switch interface.

show interface fex-fabric

Displays the switch interfaces that have detected a Fabric Extender uplink.

show interface ethernet number transceiver [ fex-fabric]

Displays the SFP+ transceiver and diagnostic optical monitoring (DOM) information for the Fabric Extender uplinks.

show feature-set

Displays the status of the feature sets on the device.

Configuration Examples for the Fabric Extender

This example shows how to display all the attached Fabric Extender units:

switch# show fex
  FEX         FEX           FEX                       FEX
Number    Description      State            Model            Serial
------------------------------------------------------------------------
101        FEX0101            Online     N2K-C2248TP-1GE   JAF1418AARL
 

This example shows how to display the detailed status of a specific Fabric Extender:

switch# show fex 101 detail
FEX: 101 Description: FEX0101   state: Online
  FEX version: 5.1(1) [Switch version: 5.1(1)]
  FEX Interim version: 5.1(0.159.6)
  Switch Interim version: 5.1(1)
  Extender Model: N2K-C2248TP-1GE,  Extender Serial: JAF1418AARL
  Part No: 73-12748-05
  Card Id: 99, Mac Addr: 54:75:d0:a9:49:42, Num Macs: 64
  Module Sw Gen: 21  [Switch Sw Gen: 21]
 pinning-mode: static    Max-links: 1
  Fabric port for control traffic: Po101
  Fabric interface state:
    Po101 - Interface Up. State: Active
    Eth2/1 - Interface Up. State: Active
    Eth2/2 - Interface Up. State: Active
    Eth4/1 - Interface Up. State: Active
    Eth4/2 - Interface Up. State: Active
  Fex Port        State  Fabric Port  Primary Fabric
       Eth101/1/1    Up       Po101       Po101
       Eth101/1/2    Up       Po101       Po101
       Eth101/1/3  Down       Po101       Po101
       Eth101/1/4  Down       Po101       Po101
       Eth101/1/5  Down       Po101       Po101
       Eth101/1/6  Down       Po101       Po101
       Eth101/1/7  Down       Po101       Po101
       Eth101/1/8  Down       Po101       Po101
       Eth101/1/9  Down       Po101       Po101
      Eth101/1/10  Down       Po101       Po101
      Eth101/1/11  Down       Po101       Po101
      Eth101/1/12  Down       Po101       Po101
      Eth101/1/13  Down       Po101       Po101
      Eth101/1/14  Down       Po101       Po101
      Eth101/1/15  Down       Po101       Po101
      Eth101/1/16  Down       Po101       Po101
      Eth101/1/17  Down       Po101       Po101
      Eth101/1/18  Down       Po101       Po101
      Eth101/1/19  Down       Po101       Po101
      Eth101/1/20  Down       Po101       Po101
      Eth101/1/21  Down       Po101       Po101
      Eth101/1/22  Down       Po101       Po101
      Eth101/1/23  Down       Po101       Po101
      Eth101/1/24  Down       Po101       Po101
      Eth101/1/25  Down       Po101       Po101
      Eth101/1/26  Down       Po101       Po101
      Eth101/1/27  Down       Po101       Po101
      Eth101/1/28  Down       Po101       Po101
      Eth101/1/29  Down       Po101       Po101
      Eth101/1/30  Down       Po101       Po101
      Eth101/1/31  Down       Po101       Po101
      Eth101/1/32  Down       Po101       Po101
      Eth101/1/33  Down       Po101       Po101
      Eth101/1/34  Down       Po101       Po101
      Eth101/1/35  Down       Po101       Po101
      Eth101/1/36  Down       Po101       Po101
      Eth101/1/37  Down       Po101       Po101
      Eth101/1/38  Down       Po101       Po101
      Eth101/1/39  Down       Po101       Po101
      Eth101/1/40  Down       Po101       Po101
      Eth101/1/41  Down       Po101       Po101
      Eth101/1/42  Down       Po101       Po101
      Eth101/1/43  Down       Po101       Po101
      Eth101/1/44  Down       Po101       Po101
      Eth101/1/45  Down       Po101       Po101
      Eth101/1/46  Down       Po101       Po101
      Eth101/1/47  Down       Po101       Po101
      Eth101/1/48  Down       Po101       Po101
Logs:
09/21/2010 21:14:26.843850: Module register received
09/21/2010 21:14:26.845778: Registration response sent
09/21/2010 21:14:27.663073: Module Online Sequence
09/21/2010 21:14:30.191121: Module Online
 

This example shows how to display the Fabric Extender interfaces pinned to a specific switch interface:

switch# show interface port-channel 101 fex-intf
Fabric           FEX
Interface        Interfaces
---------------------------------------------------
 Po101           Eth101/1/2    Eth101/1/1
 

This example shows how to display the switch interfaces that are connected to a Fabric Extender uplink:

switch# show interface fex-fabric
     Fabric      Fabric       Fex                FEX
Fex  Port      Port State    Uplink    Model         Serial
---------------------------------------------------------------
101    Eth2/1        Active     1    N2K-C2248TP-1GE  JAF1418AARL
101    Eth2/2        Active     2    N2K-C2248TP-1GE  JAF1418AARL
101    Eth4/1        Active     3    N2K-C2248TP-1GE  JAF1418AARL
101    Eth4/2        Active     4    N2K-C2248TP-1GE  JAF1418AARL
 

This example shows how to display the SFP+ transceiver and diagnostic optical monitoring (DOM) information for Fabric Extender uplinks for an SFP+ transceiver that is plugged into the parent switch interface:

switch# show interface ethernet 1/40 transceiver
Ethernet1/40
    sfp is present
    name is CISCO-MOLEX INC
    part number is 74752-9026
    revision is A0
    serial number is MOC13321057
    nominal bitrate is 12000 MBits/sec
    Link length supported for copper is 3 m(s)
    cisco id is --
    cisco extended id number is 4
 

This example shows how to display the SFP+ transceiver and DOM information for Fabric Extender uplinks for an SFP+ transceiver that is plugged into the uplink port on the Fabric Extender:

switch# show interface ethernet 1/40 transceiver fex-fabric
Ethernet1/40
    sfp is present
    name is CISCO-MOLEX INC
    part number is 74752-9026
    revision is A0
    serial number is MOC13321057
    nominal bitrate is 12000 MBits/sec
    Link length supported for 50/125mm fiber is 0 m(s)
    Link length supported for 62.5/125mm fiber is 0 m(s)
    cisco id is --
    cisco extended id number is 4
 

Verifying the Chassis Management Information

Use the following to display configuration information used on the switch supervisor to manage the Fabric Extender.

Command or Action

Purpose

show environment fex {all | FEX-number} [temperature | power | fan]

Displays the environmental sensor status.

show inventory fex FEX-number

Displays inventory information for a Fabric Extender.

show module fex [FEX-number]

Displays module information about a Fabric Extender.

show sprom fex FEX-number {all | backplane | powersupply ps-num} | all

Displays the contents of the serial PROM (SPROM) on the Fabric Extender.

Configuration Examples for Chassis Management

This example shows how to display the module information about all connected Fabric Extender units:

This example shows how to display the inventory information about a specific Fabric Extender:

switch# show inventory fex 101
NAME: "FEX 101 CHASSIS", DESCR: "N2K-C2248TP-1GE  CHASSIS"
PID: N2K-C2248TP-1GE   , VID: V00 , SN: SSI13380FSM

NAME: "FEX 101 Module 1", DESCR: "Fabric Extender Module: 48x1GE, 4x10GE Supervisor"
PID: N2K-C2248TP-1GE   , VID: V00 , SN: JAF1339BDSK

NAME: "FEX 101 Fan 1", DESCR: "Fabric Extender Fan module"
PID: N2K-C2248-FAN     , VID: N/A , SN: N/A

NAME: "FEX 101 Power Supply 2", DESCR: "Fabric Extender AC power supply"
PID: NXK-PAC-400W      , VID:  000, SN:      LIT13370QD6
 

This example shows how to display the environment status for a specific Fabric Extender:

switch# show environment fex 101


Temperature Fex 101:
-----------------------------------------------------------------
Module   Sensor     MajorThresh   MinorThres   CurTemp     Status
                    (Celsius)     (Celsius)    (Celsius)
-----------------------------------------------------------------
1        Outlet-1   60            50           33          ok
1        Outlet-2   60            50           38          ok
1        Inlet-1    50            40           35          ok
1        Die-1      100           90           44          ok


Fan Fex: 101:
------------------------------------------------------
Fan             Model                Hw         Status
------------------------------------------------------
Chassis         N2K-C2148-FAN        --         ok
PS-1            --                   --         absent
PS-2            NXK-PAC-400W         --         ok


Power Supply Fex 101:
---------------------------------------------------------------------------
Voltage: 12 Volts
-----------------------------------------------------
PS  Model                Power       Power     Status
                         (Watts)     (Amp)
-----------------------------------------------------
1   --                        --        --     --
2   NXK-PAC-400W            4.32      0.36     ok


Mod Model                Power     Power       Power     Power       Status
                         Requested Requested   Allocated Allocated
                         (Watts)   (Amp)       (Watts)   (Amp)
--- -------------------  -------   ----------  --------- ----------  ----------
1    N2K-C2248TP-1GE     0.00      0.00        0.00      0.00        powered-up


Power Usage Summary:
--------------------
Power Supply redundancy mode:                 redundant

Total Power Capacity                                4.32 W

Power reserved for Supervisor(s)                    0.00 W
Power currently used by Modules                     0.00 W

                                                -------------
Total Power Available                               4.32 W
                                                -------------
 

This example shows how to display the SPROM for a specific Fabric Extender:

switch# show sprom fex 101 all
DISPLAY FEX 101 SUP sprom contents
Common block:
 Block Signature : 0xabab
 Block Version   : 3
 Block Length    : 160
 Block Checksum  : 0x1a1e
 EEPROM Size     : 65535
 Block Count     : 3
 FRU Major Type  : 0x6002
 FRU Minor Type  : 0x0
 OEM String      : Cisco Systems, Inc.
 Product Number  : N2K-C2248TP-1GE
 Serial Number   : JAF1339BDSK
 Part Number     : 73-12748-01
 Part Revision   : 11
 Mfg Deviation   : 0
 H/W Version     : 0.103
 Mfg Bits        : 0
 Engineer Use    : 0
 snmpOID         : 9.12.3.1.9.78.3.0
 Power Consump   : 1666
 RMA Code        : 0-0-0-0
 CLEI Code       : XXXXXXXXXTBDV00
 VID             : V00
Supervisor Module specific block:
 Block Signature : 0x6002
 Block Version   : 2
 Block Length    : 103
 Block Checksum  : 0x2686
 Feature Bits    : 0x0
 HW Changes Bits : 0x0
 Card Index      : 11016
 MAC Addresses   : 00-00-00-00-00-00
 Number of MACs  : 0
 Number of EPLD  : 0
 Port Type-Num   : 1-48;2-4
 Sensor #1       : 60,50
 Sensor #2       : 60,50
 Sensor #3       : -128,-128
 Sensor #4       : -128,-128
 Sensor #5       : 50,40
 Sensor #6       : -128,-128
 Sensor #7       : -128,-128
 Sensor #8       : -128,-128
 Max Connector Power: 4000
 Cooling Requirement: 65
 Ambient Temperature: 40

DISPLAY FEX 101 backplane sprom contents:
Common block:
 Block Signature : 0xabab
 Block Version   : 3
 Block Length    : 160
 Block Checksum  : 0x1947
 EEPROM Size     : 65535
 Block Count     : 5
 FRU Major Type  : 0x6001
 FRU Minor Type  : 0x0
 OEM String      : Cisco Systems, Inc.
 Product Number  : N2K-C2248TP-1GE
 Serial Number   : SSI13380FSM
 Part Number     : 68-3601-01
 Part Revision   : 03
 Mfg Deviation   : 0
 H/W Version     : 1.0
 Mfg Bits        : 0
 Engineer Use    : 0
 snmpOID         : 9.12.3.1.3.914.0.0
 Power Consump   : 0
 RMA Code        : 0-0-0-0
 CLEI Code       : XXXXXXXXXTDBV00
 VID             : V00
Chassis specific block:
 Block Signature : 0x6001
 Block Version   : 3
 Block Length    : 39
 Block Checksum  : 0x2cf
 Feature Bits    : 0x0
 HW Changes Bits : 0x0
 Stackmib OID    : 0
 MAC Addresses   : 00-0d-ec-e3-28-00
 Number of MACs  : 64
 OEM Enterprise  : 0
 OEM MIB Offset  : 0
 MAX Connector Power: 0
WWN software-module specific block:
 Block Signature : 0x6005
 Block Version   : 1
 Block Length    : 0
 Block Checksum  : 0x66
wwn usage bits:
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00
 00 00
License software-module specific block:
 Block Signature : 0x6006
 Block Version   : 1
 Block Length    : 16
 Block Checksum  : 0x86f
lic usage bits:
 ff ff ff ff ff ff ff ff

DISPLAY FEX 101 power-supply 2 sprom contents:
Common block:
 Block Signature : 0xabab
 Block Version   : 3
 Block Length    : 160
 Block Checksum  : 0x1673
 EEPROM Size     : 65535
 Block Count     : 2
 FRU Major Type  : 0xab01
 FRU Minor Type  : 0x0
 OEM String      : Cisco Systems Inc   NXK-PAC-400W
 Product Number  : NXK-PAC-400W
 Serial Number   :      LIT13370QD6
 Part Number     :         341
 Part Revision   : -037
 CLEI Code       : 5-01     01  000
 VID             :  000
 snmpOID         : 12336.12336.12336.12336.12336.12336.12374.12336
 H/W Version     : 43777.2
 Current         : 36
 RMA Code        : 200-32-32-32
Power supply specific block:
 Block Signature : 0x0
 Block Version   : 0
 Block Length    : 0
 Block Checksum  : 0x0
 Feature Bits    : 0x0
 Current 110v    : 36
 Current 220v    : 36
 Stackmib OID    : 0
 

Additional References

This section includes additional information that is related to configuring the Cisco Nexus 2000 Series Fabric Extender.

Related Documents

Related Topic

Document Title

Cisco NX-OS Licensing

Cisco NX-OS Licensing Guide

Interface configuration

Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide

Command reference

Cisco Nexus 9000 Series Command References