Configuring the Cisco ASR 1000 Series Modular Ethernet Line Card

This chapter provides information about configuring the Cisco ASR 1000 Series Modular Ethernet Line Card on the Cisco ASR 1000 Series Routers. It includes the following sections:

For more information about the commands used in this chapter, refer to the related Cisco IOS Software Command Reference and Master Index publications, and the publication that corresponds to your Cisco IOS XE software release. For more information about accessing these publications, see the “Related Documentation” section.

For information about managing your system images and configuration files, refer to the Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide, the Cisco IOS Configuration Fundamentals Configuration Guide, and the Cisco IOS Configuration Fundamentals Command Reference publications that correspond to your Cisco IOS software release.

Configuration Tasks

This section describes how to configure the Cisco ASR 1000 Series Modular Ethernet Line Card and includes information about verifying the configuration, and includes the following topics:

Mandatory Configuration Tasks

This section lists the mandatory configuration steps to configure the Cisco ASR 1000 Series Modular Ethernet Line Card. Some of the mandatory configuration commands implement default values that might be appropriate for your network. If the default value is correct for your network, you do not have to configure the command. These commands are indicated by (As Required) in the Purpose column.

To configure the Cisco ASR 1000 Series Modular Ethernet Line Card, complete the following steps:

SUMMARY STEPS

  1. configure terminal
  2. Do one of the following:
    • interface HundredGigE slot /subslot /port
  3. ip address ip-address mask [secondary] | dhcp {client-id interface-name }{hostname host-name }}
  4. mtu bytes
  5. no shutdown

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:


Router# configure terminal

Enters global configuration mode.

Step 2

Do one of the following:

  • interface HundredGigE slot /subslot /port

Example:


Router(config)# interface  HundredGigE  1
/0
/0

Example:


interface  tenGigabitethernet  slot
/subslot
/port

Example:


Router(config)# interface tengigabitethernet  1
/0
/0

Configures the 100 Gigabit Ethernet or the 10 Gigabit Ethernet interface. Here:

Step 3

ip address ip-address mask [secondary] | dhcp {client-id interface-name }{hostname host-name }}

Example:


Router(config-if)# ip address 10.20.30.40 255.255.255.0 

Sets a primary or secondary IP address for an interface that is using IPv4. Here:

  • ip-address —Specifies the IP address for the interface.
  • mask —Specifies the mask for the associated IP subnet.
  • secondary —(Optional) Specifies that the configured address is a secondary IP address. If this keyword is omitted, the configured address is the primary IP address.
  • dhcp —Specifies that IP addresses will be assigned dynamically using DHCP.
  • client-id interface-name —Specifies the client identifier. The interface-name sets the client identifier to the hexadecimal MAC address of the named interface.
  • hostname host-name —Specifies the hostname for DHCP purposes. The host-name is the name of the host to be placed in the DHCP option 12 field.

Step 4

mtu bytes

Example:


Router(config-if)# mtu  1523 

(As required) Specifies the maximum packet size for an interface. Here:

  • bytes— Specifies the maximum number of bytes for a packet.

The default is 1500 bytes; the range is 1500 to 9216 bytes.

Step 5

no shutdown

Example:


Router(config-if)# no shutdown 

Enables the interface.

Specifying the Interface Address on an Ethernet Line Card

To configure or monitor Ethernet Line Card interfaces, specify the physical location of the Ethernet Line Card, and interface in the CLI. The interface address format is slot/subslot/port. Here:

  • slot—Specifies the chassis slot number in the Cisco ASR 1000 Series Routers on which the Ethernet Line Card is installed.
  • subslot—Specifies the secondary slot number in the Cisco ASR 1000 Series Routers on which the Ethernet Line Card is installed.
  • port—Specifies the number of the individual interface port on an Ethernet Line Card.

The following example shows how to specify the first interface (Port 0) on an Ethernet Line Card that is installed with EPA-1X100GE in chassis slot 0 and subslot 1:


Router(config)# show run interface HundredGigE 0/1/0
interface HundredGigE 0/1/0
no ip address
shutdown
Router# show interfaces HundredGigE 0/1/0
HundredGigE0/1/0 is administratively down, line protocol is down 
  Hardware is EPA-1X100GE, address is e804.6227.a720 (bia e804.6227.a720)
  MTU 1500 bytes, BW 100000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported 
  Full Duplex, 100000Mbps, link type is force-up, media type is unknown media type
  output flow-control is unsupported, input flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
  Queuing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

The following example shows how to specify the first interface (Port 0) on an Ethernet Line Card that is installed with EPA-10X10GE in chassis slot 0 and subslot 1:


Router(config)# show run interface TenGigabitEthernet 
0/1/0
interface TenGigabitEthernet0/1/0
no ip address
shutdown
Router# show interfaces TenGigabitEthernet
 0/1/0
TenGigabitEthernet0/1/0 is administratively down, line protocol is down
  Hardware is EPA-10X10GE, address is 74a0.2ff9.b8a0 (bia 74a0.2ff9.b8a0)
  MTU 9216 bytes, BW 10000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 7/255, rxload 7/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  Full Duplex, 10000Mbps, link type is force-up, media type is SFP-SR
  output flow-control is off, input flow-control is off
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 02:34:52, output hang never
  Last clearing of "show interface" counters 00:00:08
 Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/40 (size/max)
  30 second input rate 303232000 bits/sec, 37159 packets/sec
  30 second output rate 304195000 bits/sec, 37132 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Modifying the MAC Address on an Interface

The Cisco ASR 1000 Series Modular Ethernet Line Card use a default MAC address for each port that is derived from the base address that is stored in the EEPROM on the backplane of the Cisco ASR 1000 Series Routers.

To modify the default MAC address of an interface to a user-defined address, use the following command in the interface configuration mode:

Command

Purpose

mac-address  ieee-address


Router(config-if)# mac-address  000a.f330.2e40

Modifies the default MAC address of an interface to a user-defined address. Here:

  • ieee-address— Specifies the 48-bit IEEE MAC address written as a dotted triple of four-digit hexadecimal numbers (xxxx.yyyy.zzzz ).

To return to the default MAC address on the interface, use the no form of this command.

Verifying a MAC Address

To verify the MAC address of an interface, use the show interfaces HundredGigE command in the privileged EXEC mode and observe the value shown in the address field.

The following example shows that the MAC address is 74a0.2ff9.bca0 for interface 0 on the Ethernet Line Card installed in slot 1 and subslot 1 of a Cisco ASR 1000 Series Router:


Router# show interfaces HundredGigE 1/1/0
HundredGigE1/1/0 is up, line protocol is up
  Hardware is EPA-1X100GE, address is 74a0.2ff9.bca0 (bia 74a0.2ff9.bca0)
  Internet address is 30.1.1.1/24
  MTU 9216 bytes, BW 100000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  Full Duplex, 100000Mbps, link type is force-up, media type is CPAK-100G-SR10
  output flow-control is on, input flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 02:52:14, output 02:52:14, output hang never
  Last clearing of "show interface" counters 1d04h
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 195348866
  Queuing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     26409774875 packets input, 8066165461480 bytes, 0 no buffer
     Received 1 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     26214425623 packets output, 8159302208852 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Configuring MAC Address Accounting Statistics

The ip accounting mac-address [input | output ] command enables the MAC address accounting on an interface.

The following example shows how to configure the MAC address accounting on an interface:


Router# interface TenGigabitEthernet5/1/0
 ip address 1.1.1.1 255.255.255.0
 ip accounting mac-address input
 ip accounting mac-address output
end

Displaying MAC Address Accounting Statistics

After enabling MAC address accounting, MAC address statistics can be displayed by entering the show interfaces mac-accounting command.

The following example shows that the MAC accounting statistics for interface 0 on the Ethernet Line Card is installed in slot 1 and subslot 0 of a Cisco ASR 1000 Series Router:


Router# show interfaces HundredGigE1/0/0 mac-accounting
HundredGigE1/0/0 
Input(494 free)
0000.0c5d.92f9(58): 1 packets, 106 bytes, last: 4038ms ago
0004.c059.c060(61): 0 packets, 0 bytes, last: 2493135ms ago
00b0.64bc.4860(64): 1 packets, 106 bytes, last: 20165ms ago
0090.f2c9.cc00(103): 12 packets, 720 bytes, last: 3117ms ago 
Total: 14 packets, 932 bytes 
Output (511 free)
0090.f2c9.cc00(103): 8 packets, 504 bytes, last: 4311ms ago 
Total: 8 packets, 504 bytes

Configuring the Hot Standby Router Protocol

The Hot Standby Router Protocol (HSRP) provides high network availability because it routes IP traffic from hosts without relying on the availability of any single router. HSRP is used in a group of routers for selecting an active router and a standby router. (An active router is the router of choice for routing packets; a standby router is a router that takes over the routing duties when an active router fails, or when preset conditions are met).

Enable HSRP on an interface by entering the standby [group-number ] ip [ip-address [secondary ]] command. You can also use the standby command to configure various HSRP elements. This document does not discuss complex HSRP configurations. For additional information on configuring HSRP, refer to the HSRP section of the Cisco IP Configuration Guide publication that corresponds to your Cisco IOS XE software release. In the following HSRP configuration, standby group 2 on Gigabit Ethernet port 2/0/0 is configured with a priority of 110 and to have a preemptive delay for a switchover to occur:


Router(config)# 
interface HundredGigE 2/0/0
Router(config-if)# 
standby 2 ip 120.12.1.200
Router(config-if)# 
standby 2 priority 110
Router(config-if)# 
standby 2 preempt

Verifying HSRP

To verify HSRP information, use the show standby command in EXEC mode:


Router# show standby
HundredGigE1/0/0 - Group 2
  State is Active
    2 state changes, last state change 00:00:06
  Virtual IP address is 120.12.1.200
  Active virtual MAC address is 0000.0c07.ac02 (MAC In Use)
    Local virtual MAC address is 0000.0c07.ac02 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.160 secs
  Preemption enabled
  Active router is local
  Standby router is unknown
  Priority 110 (configured 110)
  Group name is "hsrp-Hu1/0/0-2" (default)

Modifying the Interface MTU Size

Cisco IOS software supports three different types of configurable maximum transmission unit (MTU) options at different levels of the protocol stack:

  • Interface MTU—Checked by the Ethernet Line Card on the traffic coming in from the network. Different interface types support different interface MTU sizes and defaults. The interface MTU defines the maximum packet size allowable (in bytes) for an interface before drops occur. If the frame is smaller than the interface MTU size, but is not smaller than the minimum frame size for the interface type (such as 64 bytes for Ethernet), the frame continues to process.
  • IP MTU—Can be configured on an interface or subinterface. If an IP packet exceeds the IP MTU size, the packet is fragmented.
  • Tag or Multiprotocol Label Switching (MPLS) MTU—Can be configured on an interface or subinterface and allows up to six different labels or tag headers to be attached to a packet. The maximum number of labels is dependent on your Cisco IOS software release.

Different encapsulation methods and the number of MPLS MTU labels add additional overhead to a packet. For example, Subnetwork Access Protocol (SNAP) encapsulation adds an 8-byte header, dot1q encapsulation adds a 4-byte header, and each MPLS label adds a 4-byte header (n labels x 4 bytes).

For Cisco ASR 1000 Series Modular Ethernet Line Card on the Cisco ASR 1000 Series Routers, the default MTU size is 1500 bytes. The maximum configurable MTU is 9216 bytes. The Ethernet Line Card automatically adds an additional 22 bytes to the configured MTU size to accommodate some of the additional overhead.


Note


You cannot set the MTU option at the subinterface level.

Interface MTU Configuration Guidelines

When configuring the interface MTU size of a Cisco ASR 1000 Series Modular Ethernet Line Card on the Cisco ASR 1000 Series Routers, consider the following guidelines:

  • The default interface MTU size accommodates a 1500-byte packet, plus 22 additional bytes to cover the following additional overhead:
    • Layer 2 header—14 bytes
    • Dot1q header—4 bytes
    • CRC—4 bytes
  • If you are using MPLS, be sure that the mpls mtu command is configured for a value less than or equal to the interface MTU.
  • If you are using MPLS labels, you should increase the default interface MTU size to accommodate the number of MPLS labels. Each MPLS label adds 4 bytes of overhead to a packet.

Interface MTU Configuration Task

To modify the MTU size on an interface, use the following command in the interface configuration mode:

Command

Purpose

mtu  bytes 

Router(config-if)# mtu 1523

Configures the maximum packet size for an interface. Here:

  • bytes— Specifies the maximum number of bytes for a packet.

The default is 1500 bytes and the maximum configurable MTU is 9216 bytes.

To return to the default MTU size, use the no form of this command.

Verifying the MTU Size

To verify the MTU size for an interface, use the show interfaces HundredGigE command in the privileged EXEC command and observe the value shown in the MTU field.

The following example shows an MTU size of 1500 bytes for interface port 0 (the second port) on the Cisco ASR 1000 Series Modular Ethernet Line Card installed in slot 1 and Bay 1 of a Cisco ASR 1000 Series Routers:


Router# show interfaces HundredGigE 1/1/0
HundredGigE1/1/0 is up, line protocol is up
  Hardware is EPA-1X100GE, address is 74a0.2ff9.bca0 (bia 74a0.2ff9.bca0)
  Internet address is 30.1.1.1/24
  MTU 1500 bytes, BW 100000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  Full Duplex, 100000Mbps, link type is force-up, media type is CPAK-100G-SR10
  output flow-control is on, input flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 02:52:14, output 02:52:14, output hang never
  Last clearing of "show interface" counters 1d04h
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 195348866
  Queuing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     26409774875 packets input, 8066165461480 bytes, 0 no buffer
     Received 1 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     26214425623 packets output, 8159302208852 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Ingress QoS Classification

The physical level interface module (PLIM) is the hardware component in the data path between the media interface and the forwarding engine.

Use the following commands in the interface configuration mode to configure QoS:

Command

Purpose


plim qos input map ip {precedence-based | precedence precedence-value  queue {strict-priority | 0 }}


Router(config-if)# plim qos input map ip precedence-based


Router(config-if)# plim qos input map ip precedence 5 queue strict-priority

Classifies incoming IP traffic according to the value of the IP precedence bits, and places the traffic into the appropriate queue.

  • precedence-value —Specifies the value of the IP precedence bits (0 to 7). You can specify a range of values separated by a dash or a list of values. By default, the Cisco ASR 1000 Series Modular Ethernet Line Card classifies IP precedence range 6-7 as high priority.
  • strict-priority —Specifies the high-priority queue. Enter 0 for low priority.

Use the no form of this command to remove the configured values.


plim qos input map ipv6 all queue {strict-priority  | 0} 


Router(config-if)# plim qos input map ipv6 all queue strict-priority 

Classifies all the IPv6 packets as high priority or low priority.

  • strict-priority —Specifies high-priority traffic. Enter 0 for low-priority.

The no form of this command disables all IPv6 classification. By default, this command is disabled.


plim qos input map ipv6 tc {tc-value  | tc-range } queue {strict-priority  | 0} 


Router(config-if)# plim qos input map ipv6 tc ef queue 0 

Classifies ingress IPv6 traffic based on the value of the traffic-class bits and places the traffic into the appropriate queue.

  • tc-value | tc-range —Specifies the value of the traffic class bits. You can specify a range of values separated by a dash or a list of values.
  • strict-priority —Specifies the high-priority queue. Enter 0 for the low priority queue.

The no form of this command sets the classification according to default DSCP EF.

By default, IPv6 traffic with a traffic-class value equal to EF uses the high-priority queue and all other traffic uses the low-priority queue. Only the most significant six bits of the traffic-class octet is used for the classification.


plim qos input map mpls all queue {strict-priority  | 0} 


Router(config-if)# plim qos input map mpls all queue strict-priority 

Classifies all MPLS packets as high priority or low priority.

  • strict-priority —Specifies high-priority packets. Enter 0 for low-priority packets.

The no form of this command disables MPLS classification. By default, this command is disabled.


plim qos input map mpls exp {exp-value  | exp-range}  queue {strict-priority  | 0} 


Router(config-if)# plim qos input map mpls exp 5 queue strict-priority 

Classifies incoming MPLS traffic according to the value of the exp bits and places the traffic into the appropriate queue.

  • exp-value | exp-range —Specifies which MPLS exp value or range to use.
  • strict-priority —Specifies high-priority MPLS traffic. Enter 0 for low-priority.

By default, the Cisco ASR 1000 Series Modular Ethernet Line Card classifies MPLS EXP range 6-7 as high-priority.

The no form of this command sets the classification according to default exp range 6-7.


plim qos input queue {strict-priority  | 0}  pause enable | threshold percent]


Router(config-if)# plim qos input queue strict-priority pause enable 

Enables Ethernet pause frame generation due to flow control status.

  • strict-priority —Specifies high-priority queue. Enter 0 for a low-priority queue.
  • pause —Sets up the queue threshold to send a pause frame, which is a percentage of queue limit for packet drop.
  • threshold—Specifies the amount of traffic required to generate the pause frame. The default threshold is 100 percent. This feature is not supported.

By default, pause frame generation is enabled for a strict-priority queue.

The no form of this command disables pause generation for a queue.


plim qos input map ip all queue {strict-priority  | 0} 


Router(config-if)# plim qos input map ip all queue 0 

Allows user to specify all IPv4 packets as high priority or low priority.

  • strict-priority —Specifies high-priority packets. Enter 0 for a low-priority packets

The no form of this command disables all IPv4 classification. By default, this command is disabled.


plim qos input map ip dscp-based


Router(config-if)# plim qos input map ip dscp-based

Enables IP DSCP-based classification.

By default, the Cisco ASR 1000 Series Modular Ethernet Line Card enables IP precedence-based classification for the Cisco ASR 1000 Series Aggregation Services Routers.

The no form of this command totally disables the IP DSCP-based classification.


plim qos input map ip dscp {dscp-value  | dscp-range}  queue {strict-priority  | 0} 


Router(config-if)# plim qos input map ip dscp af11 queue strict-priority 

Allows the user to specify an IP DSCP value or range.

  • strict-priority —Specifies high-priority IP DSCP value. Enter 0 for low-priority.

By default, the Cisco ASR 1000 Series Modular Ethernet Line Card classifies DSCP EF as high priority.

The no form of this command removes the IP DSCP value or range.

Configuring the Encapsulation Type

By default, the interfaces on the Cisco ASR 1000 Series Modular Ethernet Line Card support Advanced Research Projects Agency (ARPA) encapsulation. They do not support configuration of service access point or SNAP encapsulation for transmission of frames; however, the interfaces will properly receive frames that use service access point and SNAP encapsulation.

The only other encapsulation supported by the Ethernet Line Card interfaces is IEEE 802.1Q encapsulation for virtual LANs (VLANs).

Configuring a Subinterface and VLAN

You can configure subinterfaces on the Cisco ASR 1000 Series Modular Ethernet Line Card interfaces on a VLAN using IEEE 802.1Q encapsulation. Cisco Discovery Protocol is disabled by default on the Cisco ASR 1000 Series Modular Ethernet Line Card interfaces and subinterfaces.

To configure an Ethernet Line Card subinterface on a VLAN, use the following commands in the global configuration mode:

SUMMARY STEPS

  1. hw-module subslot slot/subslot ethernet vlan unlimited
  2. Do one of the following:
    • interface HundredGigE slot /subslot /port [. subinterface-number]
  3. encapsulation dot1q vlan-id
  4. ip address ip-address mask [secondary] }

DETAILED STEPS

  Command or Action Purpose

Step 1

hw-module subslot slot/subslot ethernet vlan unlimited

Example:


Router(config)# hw-module subslot slot/subslot ethernet vlan unlimited

(Optional) Enables configuration of up to 4094 dot1q VLANs per port per Cisco ASR 1000 Series Modular Ethernet Line Card. Here:

  • slot —Specifies the slot number of the chassis in which the Ethernet Line Card is installed.
  • subslot —Specifies the slot number of the Ethernet Line Card in which the Ethernet Line Card is installed.

This feature is supported from Cisco IOS XE Release 3.11S onwards.

Step 2

Do one of the following:

  • interface HundredGigE slot /subslot /port [. subinterface-number]

Example:


Router(config)# interface  HundredGigE 2
/0
/0.20

Example:


Example:

Example:


Router(config)# interface tengigabitethernet  1
/0
/20.43

Example:


Specifies the hundred Gigabit Ethernet interface or ten Gigabit Ethernet interface to configure. Here:

Step 3

encapsulation dot1q vlan-id

Example:


Router(config-subif)# encapsulation dot1q  25 

Defines the encapsulation format as IEEE 802.1Q (dot1q), where vlan-id is the number of the VLAN. The valid value range is 1–4094.

Step 4

ip address ip-address mask [secondary] }

Example:


Router(config-subif)# ip address 10.20.30.40 255.255.255.0 

Example:


Sets a primary or secondary IP address for an interface. Here:

  • ip-address —Specifies the IP address for the interface.
  • mask —Specifies the mask for the associated IP subnet.
  • secondary —(Optional) Specifies that the configured address is a secondary IP address. If this keyword is omitted, the configured address is the primary IP address.

VLAN COS-Based Ingress Classification

This section describes how to configure the COS-based classification rules at VLAN sub-interface level and L3 classification rules at main-interface level.


Note


When the hardware-module subslot ethernet vlan unlimited command is configured, the default classification of COS bits 6 and 7 as high priority is supported. However, other user-defined COS values for high-priority and low-priority classification using the plim qos input map cos queue command are not supported.

When the VLAN scale configuration is enabled using the hw-module subslot slot/subslot ethernet vlan unlimited command, the VLAN COS bits classification will be lost.

The following is a sample output of the hw-module subslot slot/subslot ethernet vlan unlimited command displaying a warning message.


Router(config)# hw-module subslot 1/0 ethernet vlan unlimited
 
%VLAN input classification in subslot 1/0 will not be available

To specify VLAN classification, use the following commands in the subinterface configuration mode:

Command

Purpose


plim qos input map cos enable


Router(config-subif)# plim qos input map cos enable

Enables packet classification based on 802.1q VLAN COS bits.

By default, this command is enabled on the Cisco ASR 1000 Series Modular Ethernet Line Card.

The no form of this command totally disables the COS classification.

The command is used in the dot1q subinterface configuration mode, which can be either under the main physical interface or the Gigabit EtherChannel link bundle.


plim qos input map cos {cos-value  | cos-range}  queue {strict-priority  | 0} 


Router(config-subif)# plim qos input map cos 3 queue strict-priority 

Allows a user to specify a COS value or a COS range.

By default, without this command, COS bits value 6 and 7 is classified as high priority. Only the default behavior is supported when the hw-module subslot ethernet vlan unlimited command is configured.

The no form of this command sets the classification according to the default value (COS priority value 6 and 7).

This command is in the VLAN subinterface configuration mode under either the main physical interface or the Gigabit EtherChannel link bundle.

Classification Based on Inner and Outer VLAN COS Values

To enable packet classification based on VLAN COS values for Inner and Outer VLAN of a 802.1Q subinterface or QinQ subinterface, execute the following set of commands from the QinQ subinterface configuration mode:

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. Do one of the following:
    • interface HundredGigE 0/0/0.1
  4. plim qos input map cos inner-based
  5. plim qos input map cos inner { cos-value | cos-range} queue {strict-priority | 0}
  6. plim qos input map cos outer-based
  7. plim qos input map cos outer { cos-value | cos-range} queue {strict-priority | 0}

DETAILED STEPS

  Command or Action Purpose

Step 1

enable

Example:

Router> enable

Enables privileged EXEC mode. Enter your password when prompted.

Step 2

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3

Do one of the following:

  • interface HundredGigE 0/0/0.1
Example:

Router(config)# interface HundredGigE 0/0/0.1
Example:
Example:
interface TengigabitEthernet0/0/0.1 
Example:

Router(config)# interface TengigabitEthernet0/0/0.1

Enters subinterface mode for the hundred Gigabit Ethernet 0/0/0.1 or for the ten Gigabit Ethernet 0/0/0.1.

Step 4

plim qos input map cos inner-based

Example:

Router(config-subif)# plim qos input map cos inner-based

Enables and allows configuration for inner VLAN COS values.

Note

 
The VLAN COS values can be enabled by default by executing the plim qos input map enable command.

Step 5

plim qos input map cos inner { cos-value | cos-range} queue {strict-priority | 0}

Example:

Router(config-subif)# plim qos input map cos inner 5 queue strict-priority

Configures the COS values or the COS range of the inner VLAN of a QinQ subinterface to high priority.

Step 6

plim qos input map cos outer-based

Example:

Router(config-subif)# plim qos input map cos outer-based

Enables configuration for outer VLAN COS values.

Note

 
The VLAN COS values can be enabled by default by executing the plim qos input map enable command.

Step 7

plim qos input map cos outer { cos-value | cos-range} queue {strict-priority | 0}

Example:

Router(config-subif)# plim qos input map cos outer 4 queue strict-priority

Configures the COS values or range for outer VLAN of a QinQ subinterface to high priority.

Verifying a Subinterface Configuration on a VLAN

To verify the configuration of a subinterface and its status on the VLAN, use the show interfaces HundredGigE 0/0/0.1 privileged EXEC command.

The following example shows the status of subinterface number 2 on port 0 on the Ethernet Line Card in Slot 3 and Bay 1 in VLAN number 200:


Router# show interfaces HundredGigE 3/1/0.2
HundredGigE3/1/0.2 is administratively down, line protocol is down
  Hardware is EPA-1X100GE, address is badb.adbb.79e0 (bia badb.adbb.79e0)
  MTU 7500 bytes, BW 100000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  200.
  ARP type: ARPA, ARP Timeout 04:00:00
  Keepalive not supported
  Last clearing of "show interface" counters never

Saving a Configuration

To save your running configuration to NVRAM, use the following command in privileged EXEC configuration mode:

Command

Purpose


copy running-config startup-config 


Router# copy running-config startup-config 

Writes the new configuration to NVRAM.

For information about managing your system image and configuration files, refer to the Cisco IOS Configuration Fundamentals Configuration Guide and Cisco IOS Configuration Fundamentals Command Reference publications that correspond to your Cisco IOS software release.

Shutting Down and Restarting an Interface on an Ethernet Line Card

You can shut down and restart any of the interface ports on a Cisco ASR 1000 Series Modular Ethernet Line Card independent of each other. Shutting down an interface stops traffic and moves the interface into an administratively down state.

There are no restrictions for online insertion and removal (OIR) on the Cisco ASR 1000 Series Modular Ethernet Line Card.

If you are preparing for an OIR of an Ethernet line card, it is not necessary to independently shut down each of the interfaces prior to the deactivation of the Ethernet Line Card. The hw-module slot <1> stop command automatically stops traffic on the interfaces and deactivates them along with the Ethernet Line Card in preparation for OIR.

To shut down an interface on an Ethernet Line Card, use the following command in the interface configuration mode:

Command

Purpose


shutdown 


Router(config-if)# shutdown 

Disables an interface.

To restart an interface on an Ethernet Line Card, use the following command in interface configuration mode:

Command

Purpose

no shutdown 


Router(config-if)# no shutdown 

Restarts a disabled interface.

Modifying the Minimum Frame Size on an EPA Interface


Note


This configuration is useful in cases where devices in the network strip the VLAN tag from Ethernet frames but fail to pad the frame to 64 bytes. In such situations, VLAN-tagged packets with a length of 64 bytes will shrink to 60 bytes, causing the receiver to drop them (as Ethernet frames must be at least 64 bytes in size). By setting a minimum frame size of 68 bytes, we ensure that the frame remains 64 bytes in length even after removing the VLAN tag. Similarly, configuring a minimum frame size of 72 bytes becomes useful in scenarios where frames have two VLAN tags (known as Q-in-Q).


You can modify the minimum frame size of data that is transmitted on an interface from 64 bytes to 68 or 72 bytes.


Note


The minimum frame length of 72 bytes can be enabled on the consolidated platforms ASR 1001-HX and ASR 1002-HX, as well as through the Modular Interface Processor 100 (MIP100) module on modular ASR platforms such as ASR 1006-X and 1009-X.


Restrictions

The following is the restriction for modifying the minimum frame size on an interface:

  • This modification is specific to the interface level, and configuration changes are applied to all packets with sizes less than the configured minimum frame size.

Modifying the Minimum Frame Size to 68 or 72 Bytes

To configure the minimum frame size to 68 or 72 bytes, use the following command in privileged EXEC configuration mode:

Command

Purpose

For 68 bytes:


plim min-frame-length 68byte 

Example:


Router(config-if)# plim min-frame-length 68byte

Configures the minimum frame size to 68 bytes.

For 72 bytes:


plim min-frame-length 72byte 

Example:


Router(config-if)# plim min-frame-length 72byte

Configures the minimum frame size to 72 bytes.

To disable the minimum frame size configuration, use the following command in privileged EXEC configuration mode:

Command

Purpose

For 68 bytes:


no plim min-frame-length 68byte 

Example:


Router(config-if)# no plim min-frame-length 68byte 

Disables the 68-byte minimum frame size configuration.

For 72 bytes:


no plim min-frame-length 72byte 

Example:


Router(config-if)# no plim min-frame-length 72byte 

Disables the 72-byte minimum frame size configuration.

Examples

The following example shows how to enable minimum frame length:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#plim min-frame-length ?
68byte 68 byte - Default:64 byte
72byte Set minimum frame length as 72 bytes

The following example shows how to disable minimum frame length:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#no plim min-frame-length ?
68byte 68 byte - Default:64 byte
72byte Set minimum frame length as 72 bytes

The following example shows how to enable minimum frame length of 68 bytes:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#plim min-frame-length 68byte
Router(config-if)#end
Router#

The following example shows how to disable minimum frame length of 68 bytes:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#no plim min-frame-length 68byte
Router(config-if)#end
Router#

The following example shows how to enable minimum frame length of 72 bytes:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#plim min-frame-length 72byte
Router(config-if)#end
Router#

The following example shows how to disable minimum frame length of 72 bytes:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface GigabitEthernet 0/0/0
Router(config-if)#no plim min-frame-length 72byte
Router(config-if)#end
Router#

Verifying an Interface Configuration

Besides using the show running-configuration command to display your Cisco ASR 1000 Series Routers configuration settings, you can use the show interfaces HundredGigE | tengigabitethernet command to get detailed information on a per-port basis for your Cisco ASR 1000 Series Modular Ethernet Line Card.

Verifying Per-Port Interface Status

To find detailed interface information on a per-port basis for the Cisco ASR 1000 Series Modular Ethernet Line Card, use the show interfaces HundredGigE command.

The following example provides a sample output for interface port 0 on the Ethernet Line Card that is installed in slot 2 and subslot 0 of a Cisco ASR 1000 Series Router:


Router# show interfaces HundredGigE 2/0/0
HundredGigE2/0/0 is administratively down, line protocol is down
  Hardware is EPA-1X100GE, address is badb.adbb.79e0 (bia badb.adbb.79e0)
  MTU 7500 bytes, BW 100000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1, loopback not set
Keepalive not supported 
Full Duplex, 1000Mbps, link type is auto, media type is SX
output flow-control is off, input flow-control is off
ARP type: ARPA, ARP Timeout 04:00:00
Last input 02:20:41, output 00:03:36, output hang never
Last clearing of "show interfaces" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
595 packets input, 45373 bytes, 0 no buffer
Received 3 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles 
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 569 multicast, 0 pause input
593 packets output, 47591 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

Using show Commands to Check CPAK Module and SFP+ Module Status

You can use various show commands to view information specific to 10-G SFP+ and 100-G CPAK optical transceiver modules.

To check or verify the status of an CPAK module or SFP+ module, use the following show commands:

  • show hw-module slot/subslot transceiver port idprom detail
  • show hw-module slot/subslot transceiver port idprom brief
  • show hw-module slot/subslot transceiver port idprom dump
  • show hw-module slot/subslot transceiver port idprom status

The following is a list of sample output of several show commands for CPAK modules and SFP+ modules.

The following show hw-module subslot command sample output is for SFP+ 10GBASE:


Router# show hw-module subslot 0/0 transceiver 0 idprom
IDPROM for transceiver TenGigabitEthernet0/0/0:
  Description                               =  optics (type 130)
  Transceiver Type:                         = SFP+ 10GBASE-SR (273)
  Product Identifier (PID)                  = SFP-10G-SR         
  Vendor Revision                           = G4
  Serial Number (SN)                        = AVD1828AAX9    
  Vendor Name                               = CISCO-AVAGO    
  Vendor OUI (IEEE company ID)              = 00.17.6A (5994)
  CLEI code                                 = COUIA8NCAA
  Cisco part number                         = 10-2415-03
  Device State                              = Enabled.
  Date code (yy/mm/dd)                      = 14/07/12
  Connector type                            = LC.
  Encoding                                  = 64B66B
  Nominal bitrate                           = 10GE (10300 Mbits/s)
  Minimum bit rate as % of nominal bit rate = not specified
  Maximum bit rate as % of nominal bit rate = not specified

The following show hw-module subslot command sample output is for CPAK-100G-SR10:


Router# show hw-module subslot 0/1 transceiver 0 idprom
IDPROM for transceiver HundredGigE0/1/0:
  Description                               = CPAK optics (type 131)
  Transceiver Type:                         = CPAK 100GE SR10 (310)
  Product Identifier (PID)                  = CPAK-100G-SR10 
  Vendor Revision                           = VES1
  Serial Number (SN)                        = FBN182620471   
  Vendor Name                               = CISCO          
  Vendor OUI (IEEE company ID)              = 00.00.0C (12)
  CLEI code                                 = WOTRC5PBAA
  Cisco part number                         = 800-41495-
  Device State                              = Enabled.
  Date code (yyyy/mm/dd)                    = 2014/06/23
  Connector type                            = MPO.
  Encoding                                  = NRZ, Non-PSK.
  Bit Rate                                  = 111.8 Gbps
  Maximum Bit Rate Network Lane             = 11.2 Gbits/s
  Maximum Bit Rate Host Lane               = 11.2 Gbits/s
 
 
Router# show hw-module subslot 0/1 transceiver 0 idprom
IDPROM for transceiver HundredGigE0/1/0:
  Description                               = CPAK optics (type 131)
  Transceiver Type:                         = CPAK 100GE SR10 (310)
  Product Identifier (PID)                  = CPAK-100G-SR10 
  Vendor Revision                           = VES1
  Serial Number (SN)                        = FBN182620471   
  Vendor Name                               = CISCO          
  Vendor OUI (IEEE company ID)              = 00.00.0C (12)
  CLEI code                                 = WOTRC5PBAA
  Cisco part number                         = 800-41495-
  Device State                              = Enabled.
  Date code (yyyy/mm/dd)                    = 2014/06/23
  Connector type                            = MPO.
  Encoding                                  = NRZ, Non-PSK.
  Bit Rate                                  = 111.8 Gbps
  Maximum Bit Rate Network Lane             = 11.2 Gbits/s
  Maximum Bit Rate  Host Lane               = 11.2 Gbits/s
Router #show hw-module subslot 0/1 transceiver 0 idprom dump
IDPROM for transceiver HundredGigE0/1/0:
  Description                               = CPAK optics (type 131)
  Transceiver Type:                         = CPAK 100GE SR10 (310)
  Product Identifier (PID)                  = CPAK-100G-SR10 
  Vendor Revision                           = VES1
  Serial Number (SN)                        = FBN182620471   
  Vendor Name                               = CISCO          
  Vendor OUI (IEEE company ID)              = 00.00.0C (12)
  CLEI code                                 = WOTRC5PBAA
  Cisco part number                         = 800-41495-
  Device State                              = Enabled.
 
Idprom Contents (hex)
(CPAK NVR1 Table - addr 0x8000-0x807F)
        000:        01 21 09 03 00 00 00 00 1E AA
        010:        4A 38 38 00 0A 00 0A 01 83 40
        020:        86 60 00 00 00 04 40 50 26 17
        030:        14 46 00 43 49 53 43 4F 20 20
        040:        20 20 20 20 20 20 20 20 20 00
        050:        00 0C 38 30 30 2D 34 31 34 39
        060:        35 2D 30 31 20 20 20 20 46 42
        070:        4E 31 38 32 36 32 30 34 37 31
        080:        20 20 20 20 32 30 31 34 30 36
        090:        32 33 00 00 57 4F 54 52 43 35
        100:        50 42 41 41 6E 5A 00 05 02 03
        110:        0C 03 0F 20 01 01 08 00 FE 01
        120:        00 00 00 02 03 00 00 FD
 
Threshold Data (hex)
CPAK NVR2 Table - address 0x8080-0x80FF
        000:        4B 00 46 00 00 00 FB 00 8A 00
        010:        87 5A 7A 76 77 E2 00 00 00 00
        020:        00 00 00 00 00 00 00 00 00 00
        030:        00 00 00 00 00 00 00 00 00 00
        040:        13 88 11 94 05 DC 03 E8 45 76
        050:        22 D0 06 C9 03 66 5A 00 55 00
        060:        00 00 FB 00 88 71 43 E2 04 62
        070:        02 32 00 00 00 00 00 00 00 00
        080:        00 00 00 00 00 00 00 00 00 00
        090:        00 00 00 00 00 00 00 00 00 00
        100:        00 00 00 00 00 00 00 00 00 00
        110:        00 00 00 00 00 00 00 00 00 00
        120:        00 00 00 00 00 00 00 93
 
Vendor Idprom Contents (hex)
Vendor Cisco NVR1 Table - address 0x8400-0x847F
        000:        02 00 00 00 00 00 00 00 00 00
        010:        00 00 00 00 00 00 43 49 53 43
        020:        4F 20 20 20 20 20 20 20 20 20
        030:        20 20 43 50 41 4B 2D 31 30 30
        040:        47 2D 53 52 31 30 20 20 56 45
        050:        53 31 07 46 42 4E 31 38 32 36
        060:        32 30 34 37 38 30 30 2D 34 31
        070:        34 39 35 2D 30 31 30 31 20 20
        080:        00 00 00 00 00 00 00 00 00 00
        090:        00 32 38 2D 31 31 30 32 30 2D
        100:        30 34 00 00 00 00 00 00 00 00
        110:        00 00 00 00 00 00 00 00 00 00
        120:        00 00 00 00 00 00 00 1B
 
Vendor Idprom Contents 2 (hex)
Vendor CISCO NVR2 Table - address 0x8480-0x84FF
        000:        00 00 00 00 00 00 00 00 00 00
        010:        00 00 00 00 00 00 00 00 00 00
        020:        00 00 00 00 00 00 00 00 00 00
        030:        00 00 41 46 45 31 37 30 31 50
        040:        20 20 20 20 20 20 20 20 41 46
        050:        45 31 33 42 57 33 20 20 20 20
        060:        20 20 20 20 00 00 00 00 00 00
        070:        00 00 00 00 00 00 00 00 00 00
        080:        53 52 32 36 34 30 31 30 37 34
        090:        2D 30 31 20 20 20 00 00 00 00
        100:        00 00 00 00 00 00 00 00 00 00
        110:        00 00 00 00 00 00 00 00 00 00
        120:        00 00 00 00 00 00 00 0C

Configuration Examples

This section includes the following configuration examples:

Basic Interface Configuration

The following example shows how to enter the global configuration mode to specify the interface that you want to configure, configure an IP address for the interface, and save the configuration.

The following example shows how to configure interface port 1 on the Ethernet Line Card that is located in subslot 0 of the Ethernet Line Card that is installed in slot 0 of a Cisco ASR 1000 Series Router.


! Enter global configuration mode.

!

Router# configure terminal 

! Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address.

!

Router(config)# interface HundredgigE 0/0/1 

!

! Configure an IP address.

!

Router(config-if)# ip address 192.168.50.1 255.255.255.0 

!

! Start the interface.

!

Router(config-if)# no shut 

!

! Save the configuration to NVRAM.

!

Router(config-if)# exit 

Router# copy running-config startup-config 

MAC Address Configuration

The following example shows how to change the default MAC address on the interface to 1111.2222.3333:


! Enter global configuration mode.

!

Router# configure terminal 

! Enter configuration commands, one per line. End with CNTL/Z.

! 

! Specify the interface address

!

Router(config)# interface HundredgigE 0/0/0 

!

! Modify the MAC address.

!

Router(config-if)# mac-address 1111.2222.3333 

MAC Address Accounting Configuration

The following example shows how to enable MAC address accounting:


! Enter global configuration mode.

!

Router# configure terminal 

! Enter configuration commands, one per line. End with CNTL/Z.

! 

! Enable MAC address accounting

Router(config)# interface { HundredGigE | Tengigethernet }  slot/subslot/port 

Router(config-if)# ip accounting mac-address {input | output} 

Router(config)# interface HundredGigE  0/0/0 


Router(config-if)# ip accounting ? 

access-violations Account for IP packets violating access lists on this interface

mac-address Account for MAC addresses seen on this interface

output-packets Account for IP packets output on this interface

precedence Count packets by IP precedence on this interface

<cr> 

Router(config-if)# ip accounting mac-address ? 

input Source MAC address on received packets

output Destination MAC address on transmitted packets

Router(config-if)# ip accounting mac-address input ? 

<cr>

! Specify MAC address accounting for traffic entering the interface.

!

Router(config-if)# ip accounting mac-address input 

! Specify MAC address accounting for traffic leaving the interface.

!

Router(config-if)# ip accounting mac-address output 

Router(config-if)# end 

! Verify the MAC Address on the interface.

!

Router# show interfaces HundredGigE 0/0/0 mac-accounting 

HundredGigE 0/0/0

Input (511 free)

000f.f7b0.5200(26): 124174 packets, 7450440 bytes, last: 1884ms ago

Total: 124174 packets, 7450440 bytes

Output (511 free)

000f.f7b0.5200(26): 135157 packets, 8109420 bytes, last: 1884ms ago

Total: 135157 packets, 8109420 bytes

MTU Configuration

The following example shows how to set the MTU interface to 9216 bytes:


! Enter global configuration mode.

!

Router# configure terminal 

! Enter configuration commands, one per line. End with CNTL/Z.

! 

! Specify the interface address

!

Router(config)# interface HundredgigE 0/0/0 

!

! Configure the interface MTU.

!

Router(config-if)# mtu 9216 

VLAN Configuration

The following example shows how to create the subinterface number 268 on Ethernet Line Card interface port 2 (the third port), and configure the subinterface on the VLAN with the ID number 268, using IEEE 802.1Q encapsulation:


! Enter global configuration mode.

!

Router# configure terminal 

! Enter configuration commands, one per line. End with CNTL/Z.

! 

! Specify the interface address

!

Router(config)# interface HundredgigE 2/0/0.268 

!

! Configure dot1q encapsulation and specify the VLAN ID.

!

Router(config-subif)# encapsulation dot1q 268