Contents

Access Node Control Protocol

The Access Node Control Protocol (ANCP) feature enhances communication between Digital Subscriber Line Access Multiplexers (DSLAMs) and a broadband remote access server (BRAS), enabling the exchange of events, actions, and information requests between the multiplexer end and the server end. As a result, either end can implement appropriate actions.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Access Node Control Protocol

To run ANCP over Transmission Control Protocol (TCP), IP must be enabled on broadband remote access servers (BRAS). Interactions from RADIUS to the BRAS are not required for ANCP and are dependent on the RADIUS server.

For information about release and platform support, see the Feature Information for Access Node Control Protocol.

Restrictions for Access Node Control Protocol

Cisco IOS XE Release 2.4 supports interactions with the RADIUS server from the broadband remote access server (BRAS). Interactions from RADIUS to the BRAS are not required for ANCP and are dependent on the RADIUS server.

Information About Access Node Control Protocol

ANCP is used to aggregate traffic from multiple subscribers and deliver information for any application, while remaining independent from the application. ANCP is currently used in the application between DSLAMs and the broadband remote access server in a digital subscriber line (DSL) broadband environment.

The ANCP feature enables close communication between DSL aggregation multiplexers (DSLAMs) and network edge devices. Using ANCP between DSLAMs and a BRAS enables exchange of events, actions, and information requests so that the appropriate actions occur at the DSLAM and BRAS.

The ANCP architecture supports the following uses of ANCP:

Rate Adaptive Mode

Rate adaptive mode helps to maximize the line bit rate for a given line, and the rate is dependent on the quality of the signal achieved on the line. Rate adaptive mode conveys DSL modem line rate from a DSLAM to a broadband remote access server.

A BRAS running ANCP listens for TCP requests from its ANCP neighbors (DSLAMs).

  • After a TCP session is established--ANCP begins exchanging messages to establish adjacency between the BRAS and its neighbors.

  • After adjacency is established--ANCP event messages can be sent from the DSLAM to the BRAS.

Rate adaptive DSL uses signal quality to adjust line speeds. A BRAS typically sets the subscriber interfaces to the maximum bandwidth agreed to in the service license agreement (SLA).

When customer premises equipment (CPE) is synchronized to a data rate that is lower than the line speed, cell or packet loss occurs on the DSLAM. To prevent this, the DSLAM can use ANCP to notify the BRAS of newly adjusted circuit rates.

When a customer-facing port:

  • Activates -- The DSLAM sends a Port Up message to the BRAS. The appropriate quality of service (QoS) takes effect in accordance with the ANCP-delivered information.

  • Deactivates -- The DSLAM sends a Port Down message to the BRAS. ANCP reports the DSL state sent by the DSLAM, which is typically Silent or Idle. If the broadband remote access server receives another Port Up message, the subscriber sessions either time out or are renewed with a new shaping rate. The shaping rate on the interface does not change until the router receives a new Port Up message.

RADIUS Interaction

Interactions between the broadband remote access server and the RADIUS server are from the router to RADIUS.

The BRAS sends the following attributes and attribute-value pairs (AVPs) to the RADIUS server:

ANCP Line Rates

Upstream Data Rate

Downstream Data Rate

Output Policy Name

VSA 39

Attribute 197, Ascend-Data-Rate

Attribute 255, Ascend-Xmit-Rate

Attribute 77, Connect-Speed-Info

Attribute Type 38, Rx Connect Speed AVP

Attribute Type 24, Tx Connect Speed AVP

The BRAS uses Point-to-Point Protocol (PPPoE) to interact with the authentication, authorization, and accounting (AAA) module. RADIUS processes the information and then takes appropriate action.

Port Mapping

Port mapping associates customer premises equipment (CPE) clients of a DSLAM with VLAN subinterfaces on the BRAS. The VLANs include 802.1Q or queue-in-queue (Q-in-Q) hierarchical VLANs. Port mapping is configured in global configuration mode on the BRAS by grouping CPE client IDs with a specific DSLAM neighbor.

There are two methods you can use to map ports: configure all VLAN subinterfaces first, and the ANCP neighbor mappings next. Or, you can configure the mappings directly under the interface.

For example, the following commands configure port mapping for Q-in-Q VLAN subinterfaces:

ancp neighbor name 
dslam-name 
id 
dslam-id
dot1q
 
outer-vlanid
 second-dot1q
 
inner-vlanid
 [interface
 
type number
] client-id
 "
client-id
"

or

ancp neighbor name 
dslam-name 
id
 dslam-id
dot1q
 
outer-vlanid
 client-id
 "
client-id
"

The client-idis a unique access-loop-circuit-id that the DSLAM sends to the BRAS for each unique port. The DSLAM sends this ID in the ANCP Port Up event message. The access-loop-circuit-id uses a defined format consisting of an access node identifier and digital subscriber line (DSL) information as mentioned below:

ATM/DSL

" access-node-identifier atm slot/module/port . subinterface : vpi . vci "

Ethernet/DSL

" access-node-identifier ethernet slot / module / port . subinterface [: vlan-id]"

The BRAS sets the default state as Down, on all ports of the router, until the DSLAM sends a Port Up message.

Noninteractive Operation Administration and Maintenance

ANCP provides an out-of-band control channel for performing noninteractive operation, administration, and maintenance (OAM) operations from the broadband remote access server. This channel enables router operators to view the ANCP port state of specific DSLAM ports. ANCP port state information is stored in the ANCP dynamic database on the BRAS.

Interactive OAM

The Interactive OAM and Scaling Improvements feature adds on-demand ping capability to ANCP for operations and troubleshooting.


Note


This feature is enabled by default and requires no configuration.


General Switch Management Protocol and ANCP

ANCP is an extension of the General Switch Management Protocol (GSMP). GSMP defines a master-slave neighbor relationship in which the master initiates a connection to a slave. In ANCP, this master-slave relationship is reversed--the BRAS (master) listens and accepts incoming ANCP connections from the DSLAM (slave). The DSLAM uses event messages to communicate asynchronous events to the BRAS, such as topology changes and Port Down or Port Up events.

GSMP connectivity between the BRAS and the DSLAM occurs over TCP/IP (RFC 3293). The DSLAM initiates the connection to the router and the router accepts the connection if the appropriate interface is ANCP enabled.

The GSMP Adjacency Protocol establishes GSMP neighbor relationships.

  1. During the adjacency-building:
    1. The DSLAM and router negotiate their capabilities and determine the synchronization state between the two ends.
    2. GSMP detects whether the router and the DSLAM have retained a local information database state in case of a transport failure, or whether both devices require a state update.
    3. If GSMP determines that it must resynchronize the adjacency, it restarts the adjacency synchronization process, which includes the capability negotiation defined in the ANCP extension draft available at:

http://tools.ietf.org/id/draft-wadhwa-gsmp-l2control-configuration-02.txt

  1. In an ANCP, if a neighbor (neighbor1) contains capabilities that its neighbor (neighbor2) does not support, neighbor1 turns off the capabilities and recommunicates the packets to neighbor2 with the same set of capabilities as neighbor2.

  2. After both the neighbors agree to the same set of capabilities, adjacency is established.

How to Configure Access Node Control Protocol

To configure ANCP, perform the following global or interface configuration tasks:

Enabling ANCP on an Ethernet Interface

Perform this task to enable ANCP on an Ethernet interface.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ancp adjacency timer interval

    4.    interface type number

    5.    ip address address mask

    6.    ancp enable

    7.    interface type number . subinterface

    8.    encapsulation dot1q vlanid [second-dot1q second-vlanid]

    9.    exit


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ancp adjacency timer interval


    Example:
    Router(config)# ancp adjacency timer 100
     

    Sets the ANCP adjacency timer interval, which specifies the amount of time to wait before sending an ANCP hello packet to the DSLAM.

     
    Step 4 interface type number


    Example:
    Router(config)# interface FastEthernet1/0/0
     

    Enters interface configuration mode to define an interface.

     
    Step 5 ip address address mask


    Example:
    Router(config-if)# ip address 10.16.1.2 255.255.0.0
     

    Assigns an IP address and subnet mask to the interface.

     
    Step 6 ancp enable


    Example:
    Router(config-if)# ancp enable
     

    Enables ANCP on the interface where IP is configured.

     
    Step 7 interface type number . subinterface


    Example:
    Router(config-if)# interface FastEthernet1/0/0.1
     

    Enters subinterface configuration mode to define a subinterface.

     
    Step 8 encapsulation dot1q vlanid [second-dot1q second-vlanid]


    Example:
    Router(config-subif)# encapsulation dot1q 100 second-dot1q 200
     

    Enables dot1q VLAN encapsulation on the subinterface for a single-queue 802.1Q VLAN or for Q-in-Q hierarchical VLANs.

     
    Step 9 exit


    Example:
    Router(config-subif)# exit
     

    Exits subinterface configuration mode.

     

    Enabling ANCP on an ATM Interface

    The ancp enable command should be configured only for the control VCs on which the ANCP message is sent from the DSLAM. Perform this task to enable ANCP on ATM interfaces.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    ancp adjacency timer interval

      4.    interface atm slot / subslot / port . subinterface

      5.    ip address ip-address mask

      6.    pvc vpi / vci

      7.    ancp enable

      8.    exit


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 ancp adjacency timer interval


      Example:
      Router(config)# ancp adjacency timer 100
       

      Sets the ANCP adjacency timer interval, which specifies the amount of time to wait before sending an ANCP hello packet to the DSLAM.

       
      Step 4 interface atm slot / subslot / port . subinterface


      Example:
      Router(config)# interface atm 2/0/1.1
       

      Enters subinterface configuration mode to define a subinterface.

       
      Step 5 ip address ip-address mask


      Example:
      Router(config-subif)# ip address 10.16.1.2 255.255.0.0
       

      Assigns an IP address and subnet mask to the subinterface.

       
      Step 6 pvc vpi / vci


      Example:
      Router(config-subif)# pvc 2/100
       

      Enters ATM virtual circuit configuration mode to enable an ANCP connection over ATM PVC.

       
      Step 7 ancp enable


      Example:
      Router(config-if-atm-vc)# ancp enable
       

      Enables ANCP on the interface where IP is configured.

       
      Step 8 exit


      Example:
      Router(config-if-atm-vc)# exit
       

      Exits ATM virtual circuit configuration mode.

       

      Mapping DSLAM Ports to VLAN Interfaces on Broadband Remote Access Servers

      Perform this task to map DSLAM ports to VLAN interfaces on the BRAS.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    ancp atm shaper percent-factor factor

        4.    interface type number.subinterface

        5.    encapsulation dot1q vlan-id

        6.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

        7.    exit


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.

         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 ancp atm shaper percent-factor factor


        Example:
        Router(config)# ancp shaper percent-factor 95
         

        Enables ANCP cell tax accounting for ATM U-interface connections

         
        Step 4 interface type number.subinterface


        Example:
        Router(config)# interface FastEthernet0/0.1
         

        Enters interface configuration mode for the specified subinterface.

         
        Step 5 encapsulation dot1q vlan-id


        Example:
        Router(config-subif)# encapsulation dot1q 411
         

        Enables IEEE 802.1Q encapsulation of traffic on a specified VLAN.

         
        Step 6 ancp neighbor name dslam-name [id dslam-id] client-id client-id


        Example:
        Router(config-subif)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. eth 0/0.1"
         

        Specifies the ANCP access DSLAM to which VLAN subinterfaces are mapped.

         
        Step 7 exit


        Example:
        Router(config-subif)# exit
         

        Exits subinterface configuration mode.

         

        Mapping DSLAM Ports to PVC Interfaces on Broadband Remote Access Servers

        The ancp neighbor name command is available under pvc and pvc-in-range command modes. This command creates a one-to-one mapping between a PVC and a DSLAM port. Perform this task to map DSLAM ports to PVC interfaces on the BRAS.

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    ancp atm shaper percent-factor factor

          4.    interface atm slot / subslot / port . subinterface

          5.    Do one of the following:

          • pvc vpi / vci
          • range pvc start-vpi / start-vci end-vpi / end-vci

          6.    pvc-in-range vpi / vci

          7.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

          8.    end


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.

           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 ancp atm shaper percent-factor factor


          Example:
          Router(config)# ancp shaper percent-factor 95
           

          Enables ANCP cell tax accounting for ATM U-interface connections.

           
          Step 4 interface atm slot / subslot / port . subinterface


          Example:
          Router(config)# interface atm 2/0/1.1
           

          Enters interface configuration mode for the specified ATM subinterface.

           
          Step 5Do one of the following:
          • pvc vpi / vci
          • range pvc start-vpi / start-vci end-vpi / end-vci


          Example:
          Router(config-subif)# pvc 1/101


          Example:
                    


          Example:
          Router(config-subif)# range pvc 9/100 9/102
           

          Creates a one-to-one mapping between a PVC and DSLAM port and enters ATM virtual circuit configuration mode.

          or

          Defines a range of ATM PVCs and enters PVC range configuration mode.

          • If a range of ATM PVCs are defined, use the pvc-in-range command to configure an individual PVC.

           
          Step 6 pvc-in-range vpi / vci


          Example:
          Router(config-if-atm-range-pvc)# pvc-in-range 9/100
           

          (Optional) Configures an individual PVC within a range in PVC range configuration mode.

           
          Step 7 ancp neighbor name dslam-name [id dslam-id] client-id client-id


          Example:
          Router(config-if-atm-range-pvc)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. atm0/0.1"
           

          Specifies the ANCP access DSLAM to which PVC subinterfaces are mapped.

          • This command is available under PVC range and ATM virtual circuit configuration modes.

           
          Step 8 end


          Example:
          Router(config-if-atm-range-pvc)# end
           

          Exits PVC range configuration mode.

           

          Configuration Examples for Access Node Control Protocol

          Enabling Access Node Control Protocol on Ethernet Interfaces Example

          The following example shows how to enable ANCP on Ethernet subinterface 2/0/1.

          interface GigabitEthernet 2/0/1
           ip address 192.168.64.16 255.255.255.0
           ancp enable
          !
          interface GigabitEthernet 2/0/1.1
           encapsulation dot1q 100 second-dot1q 200
          !
          ancp adjacency timer 100

          Enabling Access Node Control Protocol on ATM Interfaces Example

          The following example shows how to enable ANCP on ATM subinterface 2/0/1.1.

          interface ATM2/0/0.1 point-to-point
           description ANCP Link to one DSLAM
           no ip mroute-cache
           ip address 192.168.0.2 255.255.255.252
           pvc 254/32
             protocol ip 192.168.0.1
             ancp enable
             no snmp trap link-status

          Mapping DSLAM Ports to VLAN Interfaces on the BRAS Example

          The following example shows how to map the CPE client ports of a DSLAM to Q-in-Q VLAN subinterfaces on the BRAS. In the example, the DSLAM neighbor named dslam1 with an IP address of 192.68.10.5 has a CPE client port mapped to Q-in-Q VLANs 100 and 200 configured on Ethernet interface 1/0/0.2. Another CPE client port is mapped to Q-in-Q VLANs 100 and 100 configured on Ethernet interface 1/0/0.1.

          interface GigabitEthernet1/0/0.1
           encapsulation dot1q 100 second-dot1q 100 
           ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.2"
          !
          interface GigabitEthernet1/0/0.2
           encapsulation dot1q 100 second-dot1q 200
           ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.1"
          !
          ancp atm shaper percent-factor 95
          !

          The example shown above maps the ports directly at the subinterface level. You can also configure all VLAN subinterfaces first, and perform the mappings under ANCP neighbor next, as shown in the following example:

          interface GigabitEthernet1/0/0.1
           encapsulation dot1q 100 second-dot1q 100
          !
          interface GigabitEthernet1/0/0.2
           encapsulation dot1q 100 second-dot1q 200
          !
          ancp atm shaper percent-factor 95
          !
          ancp neighbor name dslam1 id 192.168.10.5
           dot1q 100 second-dot1q 100 interface GigabitEthernet1/0/0.1 client-id "192.168.10.5  ethernet1/0/0.2"
          !
          ancp neighbor name dslam1 id 192.168.10.5
           dot1q 100 second-dot1q 200 interface GigabitEthernet1/0/0.2 client-id "192.168.10.5 ethernet1/0/0.2"

          Mapping DSLAM Ports to PVC Interfaces on the BRAS Example

          The ancp neighbor name command maps the CPE client ports of a DSLAM to PVC interfaces on the BRAS. This command can be configured either globally or under PVC/PVC-in-Range mode.

          In PVC or PVC-in-Range Configuration Mode

          In this example, the router interfaces with one DSLAM which has two ports or clients.

          interface ATM2/0/0.1 point-to-point
            description ANCP Link to one DSLAM
            no ip mroute-cache
            ip address 192.168.0.2 255.255.255.252      
            pvc 254/32
               protocol ip 192.168.0.1 255.255.255.252
               ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                  no snmp trap link-status
                !
          interface ATM1/0/0.1 multipoint
            description TDSL clients - default TDSL 1024
            class-int speed:ubr:1184:160:10
            range pvc 10/41 10/160
              service-policy input SET-PRECEDENCE-0
              service-policy output premium-plus:l2c:25088
              pvc-in-range 10/103
                description TDSL client 16 Mbps with ANCP
                class-vc speed:ubr:17696:1184:05
                ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                 !
            range pvc 11/41 11/160
              service-policy input SET-PRECEDENCE-0
              service-policy output premium-plus:l2c:25088
              pvc-in-range 11/108
                description TDSL client 16 Mbps with ANCP
                class-vc speed:ubr:17696:1184:05
                ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-y-identifier"
                  !

          In Global Configuration Mode

          When the ancp neighbor command is configured globally, the PVC information for the ATM interface must also be specified, as shown in the following example:

          interface ATM1/0/0.1 multipoint
           description TDSL clients - default TDSL 1024
           class-int speed:ubr:1184:160:10
           range pvc 10/41 10/160
             service-policy input SET-PRECEDENCE-0
             service-policy output premium-plus:l2c:25088
             pvc-in-range 10/103
               description TDSL client 16 Mbps with ANCP
               class-vc speed:ubr:17696:1184:05
          !
           range pvc 11/41 11/160
             service-policy input SET-PRECEDENCE-0
             service-policy output premium-plus:l2c:25088
             pvc-in-range 11/108
               description TDSL client 16 Mbps with ANCP
               class-vc speed:ubr:17696:1184:05
          !
          ancp neighbor name dslam1 id 192.168.10.5
           atm 10/103 interface ATM1/0/0.1 client-id "dslam-port-x-identifier"
           atm 11/108 interface ATM1/0/0.1 client-id "dslam-port-y-identifier"

          Additional References

          Related Documents

          Related Topic

          Document Title

          Cisco IOS commands

          Cisco IOS Master Commands List, All Releases

          ANCP Commands

          Cisco IOS Access Node Control Protocol Command Reference

          IEEE 802.1Q VLAN

          Configuring Routing Between VLANs with IEEE 802.1Q Encapsulation

          Queue-in-Queue VLAN Tags

          IEEE 802.1Q-in-Q VLAN Tag Termination

          RFCs

          RFC

          Title

          ANCP extension draft

          http:/​/​tools.ietf.org/​id/​draft-wadhwa-gsmp-l2control-configuration-02.txt GSMP Extensions for Access Node Control Mechanism, Internet draft

          RFC 3292

          General Switch Management Protocol (GSMP) V3

          RFC 3293

          General Switch Management Protocol (GSMP), Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

          Technical Assistance

          Description

          Link

          The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          Feature Information for Access Node Control Protocol

          The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

          Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to . An account on Cisco.com is not required.
          Table 1 Feature Information for Access Node Control Protocol

          Feature Name

          Releases

          Feature Information

          Access Node Control Protocol

          Cisco IOS XE Release 2.4

          In Cisco IOS XE Release 2.4, this feature was introduced on the Cisco ASR 1000.

          The following command was introduced: ancp vdsl ethernet shaper.

          Interactive OAM and Scaling Improvements

          Cisco IOS XE Release 2.4

          The Interactive OAM and Scaling Improvements feature adds on demand ping capability to ANCP for operations and troubleshooting.

          In Cisco IOS XE Release 2.4, this feature was introduced on the Cisco ASR 1000.

          The following commands were introduced or modified: ping ancp, show ancp neighbor port, show ancp port, show ancp session, show ancp session adjacency, show ancp session event, and show ancp statistics.


          Access Node Control Protocol

          Contents

          Access Node Control Protocol

          The Access Node Control Protocol (ANCP) feature enhances communication between Digital Subscriber Line Access Multiplexers (DSLAMs) and a broadband remote access server (BRAS), enabling the exchange of events, actions, and information requests between the multiplexer end and the server end. As a result, either end can implement appropriate actions.

          Finding Feature Information

          Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

          Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

          Prerequisites for Access Node Control Protocol

          To run ANCP over Transmission Control Protocol (TCP), IP must be enabled on broadband remote access servers (BRAS). Interactions from RADIUS to the BRAS are not required for ANCP and are dependent on the RADIUS server.

          For information about release and platform support, see the Feature Information for Access Node Control Protocol.

          Restrictions for Access Node Control Protocol

          Cisco IOS XE Release 2.4 supports interactions with the RADIUS server from the broadband remote access server (BRAS). Interactions from RADIUS to the BRAS are not required for ANCP and are dependent on the RADIUS server.

          Information About Access Node Control Protocol

          ANCP is used to aggregate traffic from multiple subscribers and deliver information for any application, while remaining independent from the application. ANCP is currently used in the application between DSLAMs and the broadband remote access server in a digital subscriber line (DSL) broadband environment.

          The ANCP feature enables close communication between DSL aggregation multiplexers (DSLAMs) and network edge devices. Using ANCP between DSLAMs and a BRAS enables exchange of events, actions, and information requests so that the appropriate actions occur at the DSLAM and BRAS.

          The ANCP architecture supports the following uses of ANCP:

          Rate Adaptive Mode

          Rate adaptive mode helps to maximize the line bit rate for a given line, and the rate is dependent on the quality of the signal achieved on the line. Rate adaptive mode conveys DSL modem line rate from a DSLAM to a broadband remote access server.

          A BRAS running ANCP listens for TCP requests from its ANCP neighbors (DSLAMs).

          • After a TCP session is established--ANCP begins exchanging messages to establish adjacency between the BRAS and its neighbors.

          • After adjacency is established--ANCP event messages can be sent from the DSLAM to the BRAS.

          Rate adaptive DSL uses signal quality to adjust line speeds. A BRAS typically sets the subscriber interfaces to the maximum bandwidth agreed to in the service license agreement (SLA).

          When customer premises equipment (CPE) is synchronized to a data rate that is lower than the line speed, cell or packet loss occurs on the DSLAM. To prevent this, the DSLAM can use ANCP to notify the BRAS of newly adjusted circuit rates.

          When a customer-facing port:

          • Activates -- The DSLAM sends a Port Up message to the BRAS. The appropriate quality of service (QoS) takes effect in accordance with the ANCP-delivered information.

          • Deactivates -- The DSLAM sends a Port Down message to the BRAS. ANCP reports the DSL state sent by the DSLAM, which is typically Silent or Idle. If the broadband remote access server receives another Port Up message, the subscriber sessions either time out or are renewed with a new shaping rate. The shaping rate on the interface does not change until the router receives a new Port Up message.

          RADIUS Interaction

          Interactions between the broadband remote access server and the RADIUS server are from the router to RADIUS.

          The BRAS sends the following attributes and attribute-value pairs (AVPs) to the RADIUS server:

          ANCP Line Rates

          Upstream Data Rate

          Downstream Data Rate

          Output Policy Name

          VSA 39

          Attribute 197, Ascend-Data-Rate

          Attribute 255, Ascend-Xmit-Rate

          Attribute 77, Connect-Speed-Info

          Attribute Type 38, Rx Connect Speed AVP

          Attribute Type 24, Tx Connect Speed AVP

          The BRAS uses Point-to-Point Protocol (PPPoE) to interact with the authentication, authorization, and accounting (AAA) module. RADIUS processes the information and then takes appropriate action.

          Port Mapping

          Port mapping associates customer premises equipment (CPE) clients of a DSLAM with VLAN subinterfaces on the BRAS. The VLANs include 802.1Q or queue-in-queue (Q-in-Q) hierarchical VLANs. Port mapping is configured in global configuration mode on the BRAS by grouping CPE client IDs with a specific DSLAM neighbor.

          There are two methods you can use to map ports: configure all VLAN subinterfaces first, and the ANCP neighbor mappings next. Or, you can configure the mappings directly under the interface.

          For example, the following commands configure port mapping for Q-in-Q VLAN subinterfaces:

          ancp neighbor name 
          dslam-name 
          id 
          dslam-id
          dot1q
           
          outer-vlanid
           second-dot1q
           
          inner-vlanid
           [interface
           
          type number
          ] client-id
           "
          client-id
          "
          

          or

          ancp neighbor name 
          dslam-name 
          id
           dslam-id
          dot1q
           
          outer-vlanid
           client-id
           "
          client-id
          "
          

          The client-idis a unique access-loop-circuit-id that the DSLAM sends to the BRAS for each unique port. The DSLAM sends this ID in the ANCP Port Up event message. The access-loop-circuit-id uses a defined format consisting of an access node identifier and digital subscriber line (DSL) information as mentioned below:

          ATM/DSL

          " access-node-identifier atm slot/module/port . subinterface : vpi . vci "

          Ethernet/DSL

          " access-node-identifier ethernet slot / module / port . subinterface [: vlan-id]"

          The BRAS sets the default state as Down, on all ports of the router, until the DSLAM sends a Port Up message.

          Noninteractive Operation Administration and Maintenance

          ANCP provides an out-of-band control channel for performing noninteractive operation, administration, and maintenance (OAM) operations from the broadband remote access server. This channel enables router operators to view the ANCP port state of specific DSLAM ports. ANCP port state information is stored in the ANCP dynamic database on the BRAS.

          Interactive OAM

          The Interactive OAM and Scaling Improvements feature adds on-demand ping capability to ANCP for operations and troubleshooting.


          Note


          This feature is enabled by default and requires no configuration.


          General Switch Management Protocol and ANCP

          ANCP is an extension of the General Switch Management Protocol (GSMP). GSMP defines a master-slave neighbor relationship in which the master initiates a connection to a slave. In ANCP, this master-slave relationship is reversed--the BRAS (master) listens and accepts incoming ANCP connections from the DSLAM (slave). The DSLAM uses event messages to communicate asynchronous events to the BRAS, such as topology changes and Port Down or Port Up events.

          GSMP connectivity between the BRAS and the DSLAM occurs over TCP/IP (RFC 3293). The DSLAM initiates the connection to the router and the router accepts the connection if the appropriate interface is ANCP enabled.

          The GSMP Adjacency Protocol establishes GSMP neighbor relationships.

          1. During the adjacency-building:
            1. The DSLAM and router negotiate their capabilities and determine the synchronization state between the two ends.
            2. GSMP detects whether the router and the DSLAM have retained a local information database state in case of a transport failure, or whether both devices require a state update.
            3. If GSMP determines that it must resynchronize the adjacency, it restarts the adjacency synchronization process, which includes the capability negotiation defined in the ANCP extension draft available at:

          http://tools.ietf.org/id/draft-wadhwa-gsmp-l2control-configuration-02.txt

          1. In an ANCP, if a neighbor (neighbor1) contains capabilities that its neighbor (neighbor2) does not support, neighbor1 turns off the capabilities and recommunicates the packets to neighbor2 with the same set of capabilities as neighbor2.

          2. After both the neighbors agree to the same set of capabilities, adjacency is established.

          How to Configure Access Node Control Protocol

          To configure ANCP, perform the following global or interface configuration tasks:

          Enabling ANCP on an Ethernet Interface

          Perform this task to enable ANCP on an Ethernet interface.

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    ancp adjacency timer interval

            4.    interface type number

            5.    ip address address mask

            6.    ancp enable

            7.    interface type number . subinterface

            8.    encapsulation dot1q vlanid [second-dot1q second-vlanid]

            9.    exit


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 enable


            Example:
            Router> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.

             
            Step 2 configure terminal


            Example:
            Router# configure terminal
             

            Enters global configuration mode.

             
            Step 3 ancp adjacency timer interval


            Example:
            Router(config)# ancp adjacency timer 100
             

            Sets the ANCP adjacency timer interval, which specifies the amount of time to wait before sending an ANCP hello packet to the DSLAM.

             
            Step 4 interface type number


            Example:
            Router(config)# interface FastEthernet1/0/0
             

            Enters interface configuration mode to define an interface.

             
            Step 5 ip address address mask


            Example:
            Router(config-if)# ip address 10.16.1.2 255.255.0.0
             

            Assigns an IP address and subnet mask to the interface.

             
            Step 6 ancp enable


            Example:
            Router(config-if)# ancp enable
             

            Enables ANCP on the interface where IP is configured.

             
            Step 7 interface type number . subinterface


            Example:
            Router(config-if)# interface FastEthernet1/0/0.1
             

            Enters subinterface configuration mode to define a subinterface.

             
            Step 8 encapsulation dot1q vlanid [second-dot1q second-vlanid]


            Example:
            Router(config-subif)# encapsulation dot1q 100 second-dot1q 200
             

            Enables dot1q VLAN encapsulation on the subinterface for a single-queue 802.1Q VLAN or for Q-in-Q hierarchical VLANs.

             
            Step 9 exit


            Example:
            Router(config-subif)# exit
             

            Exits subinterface configuration mode.

             

            Enabling ANCP on an ATM Interface

            The ancp enable command should be configured only for the control VCs on which the ANCP message is sent from the DSLAM. Perform this task to enable ANCP on ATM interfaces.

            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    ancp adjacency timer interval

              4.    interface atm slot / subslot / port . subinterface

              5.    ip address ip-address mask

              6.    pvc vpi / vci

              7.    ancp enable

              8.    exit


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 enable


              Example:
              Router> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.

               
              Step 2 configure terminal


              Example:
              Router# configure terminal
               

              Enters global configuration mode.

               
              Step 3 ancp adjacency timer interval


              Example:
              Router(config)# ancp adjacency timer 100
               

              Sets the ANCP adjacency timer interval, which specifies the amount of time to wait before sending an ANCP hello packet to the DSLAM.

               
              Step 4 interface atm slot / subslot / port . subinterface


              Example:
              Router(config)# interface atm 2/0/1.1
               

              Enters subinterface configuration mode to define a subinterface.

               
              Step 5 ip address ip-address mask


              Example:
              Router(config-subif)# ip address 10.16.1.2 255.255.0.0
               

              Assigns an IP address and subnet mask to the subinterface.

               
              Step 6 pvc vpi / vci


              Example:
              Router(config-subif)# pvc 2/100
               

              Enters ATM virtual circuit configuration mode to enable an ANCP connection over ATM PVC.

               
              Step 7 ancp enable


              Example:
              Router(config-if-atm-vc)# ancp enable
               

              Enables ANCP on the interface where IP is configured.

               
              Step 8 exit


              Example:
              Router(config-if-atm-vc)# exit
               

              Exits ATM virtual circuit configuration mode.

               

              Mapping DSLAM Ports to VLAN Interfaces on Broadband Remote Access Servers

              Perform this task to map DSLAM ports to VLAN interfaces on the BRAS.

              SUMMARY STEPS

                1.    enable

                2.    configure terminal

                3.    ancp atm shaper percent-factor factor

                4.    interface type number.subinterface

                5.    encapsulation dot1q vlan-id

                6.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

                7.    exit


              DETAILED STEPS
                 Command or ActionPurpose
                Step 1 enable


                Example:
                Router> enable
                 

                Enables privileged EXEC mode.

                • Enter your password if prompted.

                 
                Step 2 configure terminal


                Example:
                Router# configure terminal
                 

                Enters global configuration mode.

                 
                Step 3 ancp atm shaper percent-factor factor


                Example:
                Router(config)# ancp shaper percent-factor 95
                 

                Enables ANCP cell tax accounting for ATM U-interface connections

                 
                Step 4 interface type number.subinterface


                Example:
                Router(config)# interface FastEthernet0/0.1
                 

                Enters interface configuration mode for the specified subinterface.

                 
                Step 5 encapsulation dot1q vlan-id


                Example:
                Router(config-subif)# encapsulation dot1q 411
                 

                Enables IEEE 802.1Q encapsulation of traffic on a specified VLAN.

                 
                Step 6 ancp neighbor name dslam-name [id dslam-id] client-id client-id


                Example:
                Router(config-subif)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. eth 0/0.1"
                 

                Specifies the ANCP access DSLAM to which VLAN subinterfaces are mapped.

                 
                Step 7 exit


                Example:
                Router(config-subif)# exit
                 

                Exits subinterface configuration mode.

                 

                Mapping DSLAM Ports to PVC Interfaces on Broadband Remote Access Servers

                The ancp neighbor name command is available under pvc and pvc-in-range command modes. This command creates a one-to-one mapping between a PVC and a DSLAM port. Perform this task to map DSLAM ports to PVC interfaces on the BRAS.

                SUMMARY STEPS

                  1.    enable

                  2.    configure terminal

                  3.    ancp atm shaper percent-factor factor

                  4.    interface atm slot / subslot / port . subinterface

                  5.    Do one of the following:

                  • pvc vpi / vci
                  • range pvc start-vpi / start-vci end-vpi / end-vci

                  6.    pvc-in-range vpi / vci

                  7.    ancp neighbor name dslam-name [id dslam-id] client-id client-id

                  8.    end


                DETAILED STEPS
                   Command or ActionPurpose
                  Step 1 enable


                  Example:
                  Router> enable
                   

                  Enables privileged EXEC mode.

                  • Enter your password if prompted.

                   
                  Step 2 configure terminal


                  Example:
                  Router# configure terminal
                   

                  Enters global configuration mode.

                   
                  Step 3 ancp atm shaper percent-factor factor


                  Example:
                  Router(config)# ancp shaper percent-factor 95
                   

                  Enables ANCP cell tax accounting for ATM U-interface connections.

                   
                  Step 4 interface atm slot / subslot / port . subinterface


                  Example:
                  Router(config)# interface atm 2/0/1.1
                   

                  Enters interface configuration mode for the specified ATM subinterface.

                   
                  Step 5Do one of the following:
                  • pvc vpi / vci
                  • range pvc start-vpi / start-vci end-vpi / end-vci


                  Example:
                  Router(config-subif)# pvc 1/101


                  Example:
                            


                  Example:
                  Router(config-subif)# range pvc 9/100 9/102
                   

                  Creates a one-to-one mapping between a PVC and DSLAM port and enters ATM virtual circuit configuration mode.

                  or

                  Defines a range of ATM PVCs and enters PVC range configuration mode.

                  • If a range of ATM PVCs are defined, use the pvc-in-range command to configure an individual PVC.

                   
                  Step 6 pvc-in-range vpi / vci


                  Example:
                  Router(config-if-atm-range-pvc)# pvc-in-range 9/100
                   

                  (Optional) Configures an individual PVC within a range in PVC range configuration mode.

                   
                  Step 7 ancp neighbor name dslam-name [id dslam-id] client-id client-id


                  Example:
                  Router(config-if-atm-range-pvc)# ancp neighbor name dslam1 id 1.2.3.4 client-id "1.2.3.4. atm0/0.1"
                   

                  Specifies the ANCP access DSLAM to which PVC subinterfaces are mapped.

                  • This command is available under PVC range and ATM virtual circuit configuration modes.

                   
                  Step 8 end


                  Example:
                  Router(config-if-atm-range-pvc)# end
                   

                  Exits PVC range configuration mode.

                   

                  Configuration Examples for Access Node Control Protocol

                  Enabling Access Node Control Protocol on Ethernet Interfaces Example

                  The following example shows how to enable ANCP on Ethernet subinterface 2/0/1.

                  interface GigabitEthernet 2/0/1
                   ip address 192.168.64.16 255.255.255.0
                   ancp enable
                  !
                  interface GigabitEthernet 2/0/1.1
                   encapsulation dot1q 100 second-dot1q 200
                  !
                  ancp adjacency timer 100

                  Enabling Access Node Control Protocol on ATM Interfaces Example

                  The following example shows how to enable ANCP on ATM subinterface 2/0/1.1.

                  interface ATM2/0/0.1 point-to-point
                   description ANCP Link to one DSLAM
                   no ip mroute-cache
                   ip address 192.168.0.2 255.255.255.252
                   pvc 254/32
                     protocol ip 192.168.0.1
                     ancp enable
                     no snmp trap link-status

                  Mapping DSLAM Ports to VLAN Interfaces on the BRAS Example

                  The following example shows how to map the CPE client ports of a DSLAM to Q-in-Q VLAN subinterfaces on the BRAS. In the example, the DSLAM neighbor named dslam1 with an IP address of 192.68.10.5 has a CPE client port mapped to Q-in-Q VLANs 100 and 200 configured on Ethernet interface 1/0/0.2. Another CPE client port is mapped to Q-in-Q VLANs 100 and 100 configured on Ethernet interface 1/0/0.1.

                  interface GigabitEthernet1/0/0.1
                   encapsulation dot1q 100 second-dot1q 100 
                   ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.2"
                  !
                  interface GigabitEthernet1/0/0.2
                   encapsulation dot1q 100 second-dot1q 200
                   ancp neighbor name dslam1 id 192.168.10.5 client-id "192.168.10.5 ethernet1/0/0.1"
                  !
                  ancp atm shaper percent-factor 95
                  !

                  The example shown above maps the ports directly at the subinterface level. You can also configure all VLAN subinterfaces first, and perform the mappings under ANCP neighbor next, as shown in the following example:

                  interface GigabitEthernet1/0/0.1
                   encapsulation dot1q 100 second-dot1q 100
                  !
                  interface GigabitEthernet1/0/0.2
                   encapsulation dot1q 100 second-dot1q 200
                  !
                  ancp atm shaper percent-factor 95
                  !
                  ancp neighbor name dslam1 id 192.168.10.5
                   dot1q 100 second-dot1q 100 interface GigabitEthernet1/0/0.1 client-id "192.168.10.5  ethernet1/0/0.2"
                  !
                  ancp neighbor name dslam1 id 192.168.10.5
                   dot1q 100 second-dot1q 200 interface GigabitEthernet1/0/0.2 client-id "192.168.10.5 ethernet1/0/0.2"

                  Mapping DSLAM Ports to PVC Interfaces on the BRAS Example

                  The ancp neighbor name command maps the CPE client ports of a DSLAM to PVC interfaces on the BRAS. This command can be configured either globally or under PVC/PVC-in-Range mode.

                  In PVC or PVC-in-Range Configuration Mode

                  In this example, the router interfaces with one DSLAM which has two ports or clients.

                  interface ATM2/0/0.1 point-to-point
                    description ANCP Link to one DSLAM
                    no ip mroute-cache
                    ip address 192.168.0.2 255.255.255.252      
                    pvc 254/32
                       protocol ip 192.168.0.1 255.255.255.252
                       ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                          no snmp trap link-status
                        !
                  interface ATM1/0/0.1 multipoint
                    description TDSL clients - default TDSL 1024
                    class-int speed:ubr:1184:160:10
                    range pvc 10/41 10/160
                      service-policy input SET-PRECEDENCE-0
                      service-policy output premium-plus:l2c:25088
                      pvc-in-range 10/103
                        description TDSL client 16 Mbps with ANCP
                        class-vc speed:ubr:17696:1184:05
                        ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-x-identifier"
                         !
                    range pvc 11/41 11/160
                      service-policy input SET-PRECEDENCE-0
                      service-policy output premium-plus:l2c:25088
                      pvc-in-range 11/108
                        description TDSL client 16 Mbps with ANCP
                        class-vc speed:ubr:17696:1184:05
                        ancp neighbor name dslam1 id 192.168.10.5 client-id "dslam-port-y-identifier"
                          !

                  In Global Configuration Mode

                  When the ancp neighbor command is configured globally, the PVC information for the ATM interface must also be specified, as shown in the following example:

                  interface ATM1/0/0.1 multipoint
                   description TDSL clients - default TDSL 1024
                   class-int speed:ubr:1184:160:10
                   range pvc 10/41 10/160
                     service-policy input SET-PRECEDENCE-0
                     service-policy output premium-plus:l2c:25088
                     pvc-in-range 10/103
                       description TDSL client 16 Mbps with ANCP
                       class-vc speed:ubr:17696:1184:05
                  !
                   range pvc 11/41 11/160
                     service-policy input SET-PRECEDENCE-0
                     service-policy output premium-plus:l2c:25088
                     pvc-in-range 11/108
                       description TDSL client 16 Mbps with ANCP
                       class-vc speed:ubr:17696:1184:05
                  !
                  ancp neighbor name dslam1 id 192.168.10.5
                   atm 10/103 interface ATM1/0/0.1 client-id "dslam-port-x-identifier"
                   atm 11/108 interface ATM1/0/0.1 client-id "dslam-port-y-identifier"

                  Additional References

                  Related Documents

                  Related Topic

                  Document Title

                  Cisco IOS commands

                  Cisco IOS Master Commands List, All Releases

                  ANCP Commands

                  Cisco IOS Access Node Control Protocol Command Reference

                  IEEE 802.1Q VLAN

                  Configuring Routing Between VLANs with IEEE 802.1Q Encapsulation

                  Queue-in-Queue VLAN Tags

                  IEEE 802.1Q-in-Q VLAN Tag Termination

                  RFCs

                  RFC

                  Title

                  ANCP extension draft

                  http:/​/​tools.ietf.org/​id/​draft-wadhwa-gsmp-l2control-configuration-02.txt GSMP Extensions for Access Node Control Mechanism, Internet draft

                  RFC 3292

                  General Switch Management Protocol (GSMP) V3

                  RFC 3293

                  General Switch Management Protocol (GSMP), Packet Encapsulations for Asynchronous Transfer Mode (ATM), Ethernet and Transmission Control Protocol (TCP)

                  Technical Assistance

                  Description

                  Link

                  The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

                  http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

                  Feature Information for Access Node Control Protocol

                  The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

                  Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to . An account on Cisco.com is not required.
                  Table 1 Feature Information for Access Node Control Protocol

                  Feature Name

                  Releases

                  Feature Information

                  Access Node Control Protocol

                  Cisco IOS XE Release 2.4

                  In Cisco IOS XE Release 2.4, this feature was introduced on the Cisco ASR 1000.

                  The following command was introduced: ancp vdsl ethernet shaper.

                  Interactive OAM and Scaling Improvements

                  Cisco IOS XE Release 2.4

                  The Interactive OAM and Scaling Improvements feature adds on demand ping capability to ANCP for operations and troubleshooting.

                  In Cisco IOS XE Release 2.4, this feature was introduced on the Cisco ASR 1000.

                  The following commands were introduced or modified: ping ancp, show ancp neighbor port, show ancp port, show ancp session, show ancp session adjacency, show ancp session event, and show ancp statistics.