Step 1 |
enable
|
Enables privileged EXEC mode.
|
Step 2 |
configure
terminal
Router# configure terminal
|
Enters global configuration mode.
|
Step 3 |
vrf
definition
vrf-name
Router(config)# vrf definition SERVICES
|
Defines a VRF and enters VRF configuration mode.
|
Step 4 |
vnet
tag
number
Router(config-vrf)# vnet tag 100
|
Specifies the global, numeric tag for the VRF.
|
Step 5 |
description
string
Router(config-vrf)# description shared services
|
(Optional) Describes a VRF to help the network administrator looking at the configuration file.
|
Step 6 |
address-family
ipv4
Router(config-vrf)# address-family ipv4
|
Enters address family configuration mode to configure a routing session using standard IPv4 address prefixes.
|
Step 7 |
exit
Router(config-vrf-af)# exit
|
Exits to VRF configuration mode.
|
Step 8 |
exit
|
Exits to global configuration mode.
|
Step 9 |
vrf
definition
vrf-name
Router(config)# vrf definition RED
|
Defines a VRF and enters VRF configuration mode.
|
Step 10 |
vnet
tag
number
Router(config-vrf)# vnet tag 200
|
Specifies the global, numeric tag for the VRF.
|
Step 11 |
description
string
Router(config-vrf)# description user of services
|
(Optional) Describes a VRF to help the network administrator looking at the configuration file.
|
Step 12 |
address-family
ipv4
Router(config-vrf)# address-family ipv4
|
Enters address family configuration mode to configure a routing session using standard IP Version 4 address prefixes.
|
Step 13 |
exit
Router(config-vrf-af)# exit
|
Exits to VRF configuration mode.
|
Step 14 |
exit
|
Exits to global configuration mode.
|
Step 15 |
interface
type
number
Router(config)# interface gigabitethernet 0/0/0
|
Configures an interface type and number and enters interface configuration mode.
|
Step 16 |
vrf
forwarding
vrf-name
Router(config-if)# vrf forwarding SERVICES
|
Associates a VRF instance with an interface.
|
Step 17 |
ip
address
ip-address
mask
Router(config-if)# ip address 192.168.1.3 255.255.255.0
|
Sets a primary IP address for an interface.
|
Step 18 |
no
shutdown
Router(config-if)# no shutdown
|
|
Step 19 |
exit
|
Exits to global configuration mode.
|
Step 20 |
router
ospf
process-id
vrf
vrf-name
Router(config)# router ospf 99 vrf SERVICES
|
Configures an OSPF routing process and enters router configuration mode.
|
Step 21 |
network
ip-address
wildcard-mask
area
area-id
Router(config-router)# network 192.168.1.0 0.0.0.255 area 0
|
Defines the interfaces on which OSPF runs and the area ID for those interfaces.
|
Step 22 |
exit
Router(config-router)# exit
|
Exits to global configuration mode.
|
Step 23 |
router
ospf
process-id [vrf
vrf-name ]
Router(config)# router ospf 98 vrf RED
|
Configures an OSPF routing process and enters router configuration mode.
|
Step 24 |
network
ip-address
wildcard-mask
area
area-id
Router(config-router)# network 192.168.1.0 0.0.0.255 area 0
|
Defines the interfaces on which OSPF runs and the area ID for those interfaces.
|
Step 25 |
exit
Router(config-router)# exit
|
Exits to the global configuration mode.
|
Step 26 |
vrf
definition
vrf-name
Router(config)# vrf definition RED
|
Defines a VRF and enters VRF configuration mode.
|
Step 27 |
address-family
ipv4
Router(config-vrf)# address-family ipv4
|
Enters address family configuration mode to configure a routing session using standard IPv4 address prefixes.
|
Step 28 |
route-replicate
from
[vrf
vrf-name ] {multicast |
unicast } {all |
protocol-name } [route-map
map-tag ]
Router(config-vrf-af)# route replicate from vrf SERVICES unicast all
|
Replicates routes into the base topology within the specified address family.
-
If the
all keyword is specified as a source protocol, only one
route-replicate command is allowed per VRF for a given destination topology.
-
Use the
connected keyword as a source
protocol-name in order to replicate only connected routes.
|
Step 29 |
exit
Router(config-vrf-af)# exit
|
Exits to VRF configuration mode.
|
Step 30 |
exit
|
Exits to global configuration mode.
|
Step 31 |
vrf
definition
vrf-name
Router(config)# vrf definition SERVICES
|
Defines a VRF and enters VRF configuration mode.
|
Step 32 |
address-family
ipv4
Router(config-vrf)# address-family ipv4
|
Enters address family configuration mode to configure a routing session using standard IPv4 address prefixes.
|
Step 33 |
route-replicate
from
[vrf
vrf-name ] {multicast |
unicast } {all |
protocol-name } [route-map
map-tag ]
Router(config-vrf-af)# route replicate from vrf RED unicast all
|
Replicates routes into the base topology within the specified address family.
|
Step 34 |
end
Router(config-vrf-af)# end
|
Exits configuration mode.
|
Step 35 |
show
ip
route
vrf
vrf-name
Router# show ip route vrf RED
|
(Optional) Displays routes, including those replicated, which are indicated by a plus sign (+).
|