LISP Multicast

The LISP Multicast feature introduces support for carrying multicast traffic over a Locator ID Separation Protocol (LISP) overlay. This support currently allows for unicast transport of multicast traffic with head-end replication at the root ingress tunnel router (ITR) site. This allows network operators to use LISP to carry multicast traffic over core networks that do not have native multicast capabilities.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for LISP Multicast

  • You must configure basic LISP services on the device. Basic LISP configurations are covered in "Configuring Basic LISP" section of this configuration guide.

  • You must configure IPv6 multicast and LISP services on the device. The configuration of IPv6 multicast over LISP is covered in "How to Configure LISP Multicast" and "Example: Configuring IPv6 Multicast over LISP" sections of this guide.

Restrictions for LISP Multicast

  • LISP multicast does not support IPv6 endpoint identifiers (EIDs) or IPv6 routing locators (RLOCs). Only IPv4 EIDs and IPv4 RLOCs are supported.

  • LISP multicast does not support Dense Mode or Bidirectional Protocol Independent Multicast (PIM). Only PIM-Sparse Mode (SM) and PIM Source Specific Multicast (SSM) modes are supported.

  • LISP multicast does not support group to Rendezvous Point (RP) mapping distribution mechanisms, Auto-RP and Bootstrap Router (BSR). Only static-RP configuration is supported.

  • LISP multicast does not support LISP Virtual Machine Mobility (VM-Mobility) deployment. That is, LISP multicast cannot be used as a data center interconnect (DCI) mechanism.

  • IPv6 LISP multicast does not support IPv6 routing locators. Additionally, it does not support multicast transport.


Note


IPv6 LISP multicast is supported only from Cisco IOS Release 16.2 onwards, though releases earlier than 16.2 supports only IPv4 LISP multicast


Information About LISP Multicast

The implementation of LISP multicast includes the following features:

  • Mapping of multicast source addresses as LISP endpoint identifiers (EIDs). (Destination group addresses are not topology dependent).

  • Building the multicast distribution tree across LISP overlays.

  • Unicast head-end replication of multicast data packets from sources within a root ingress tunnel router (ITR) site to receiver egress tunnel routers (ETRs).

  • Support for ASM (Any Source Multicast) and SSM (Source Specific Multicast).

  • Support for various combinations of LISP and non-LISP capable source and receiver sites.

  • Support for IPv6 endpoint identifiers (EIDs).


Note


If a LISP xTR is also a PIM First Hop Router (FH) or a Rendezvous Point (RP) and the device is only receiving traffic, ensure that at least one interface on the device is covered by a local LISP database mapping. No additional configuration is required to ensure that proper address is selected.


How to Configure LISP Multicast

Configuring LISP Multicast

Perform this task to enable the LISP multicast functionality on the xTR.

Before You Begin

Ensure that generic multicast functionality has been enabled on the required devices of the LISP site and PIM sparse mode has been enabled on the required interfaces of these devices.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ip multicast-routing [distributed]

    4.    Enter one of the following:

    • ip pim rp-address rp-address
    • ip pim ssm {default | range {access-list-number | access-list-name}}

    5.    interface lisp interface-number

    6.    ipv6 pim lisp transport [ipv4]

    7.    ip pim sparse-mode

    8.    exit

    9.    interface interface-type interface-number

    10.    description string

    11.    ip pim sparse-mode

    12.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ip multicast-routing [distributed]


    Example:
    Device(config)# ip multicast-routing
     

    Enables IP multicast routing.

     
    Step 4Enter one of the following:
    • ip pim rp-address rp-address
    • ip pim ssm {default | range {access-list-number | access-list-name}}


    Example:
    Device(config)# ip pim rp-address 10.1.0.2


    Example:
    Device(config)# ip pim ssm default
     
    • Statically configures the address of a Protocol Independent Multicast (PIM) rendezvous point (RP) for multicast groups.

    • Defines the Source Specific Multicast (SSM) range of IP multicast addresses.

     
    Step 5 interface lisp interface-number


    Example:
    Device(config)# interface LISP0
     

    Selects a LISP interface to configure and enters interface configuration mode.

     
    Step 6 ipv6 pim lisp transport [ipv4]


    Example:
    Device(config-if)# ipv6 pim lisp transport unicast ipv4
     

    Selects a LISP interface to configure and enters interface configuration mode.

     
    Step 7 ip pim sparse-mode


    Example:
    Device(config-if)# ip pim sparse-mode
     

    Enables Protocol Independent Multicast (PIM) on an interface for sparse-mode operation.

     
    Step 8 exit


    Example:
    Device(config-if)# exit
     

    Exits interface configuration mode and enters global configuration mode.

     
    Step 9interface interface-type interface-number


    Example:
    Device(config)# interface GigabitEthernet0/0/0
     

    Configures the LISP interface facing the site and enters interface configuration mode.

     
    Step 10 description string


    Example:
    Device(config-if)# description Link To Site
     

    Configures a description text for the interface.

     
    Step 11 ip pim sparse-mode


    Example:
    Device(config-if)# ip pim sparse-mode
     

    Enables Protocol Independent Multicast (PIM) on an interface for sparse-mode operation.

     
    Step 12 end


    Example:
    Device(config-if)# end
     

    Ends the current configuration session and returns to privileged EXEC mode.

     

    Configuring LISP Multicast in VRFs

    Perform this task to enable the LISP multicast functionality on an xTR with Virtual Routing and Forwarding (VRF) mode configured.

    Before You Begin

    Ensure that generic multicast functionality has been enabled on the required devices of the LISP site and that PIM sparse mode has been enabled on the required interfaces of these devices.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    vrf definition vrf-name

      4.    address-family ipv4

      5.    exit

      6.    exit

      7.    ip multicast-routing vrf vrf-name [distributed]

      8.    Enter one of the following:

      • ip pim vrf vrf-name rp-address ip-address
      • ip pim vrf vrf-name ssm {default | range {access-list-number | access-list-name}}

      9.    interface lisp interface-number

      10.    ip pim sparse-mode

      11.    exit

      12.    interface interface-type interface-number

      13.    vrf forwarding vrf-name

      14.    description string

      15.    ip pim sparse-mode

      16.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3vrf definition vrf-name


      Example:
      Device(config)# vrf definition VRF1
       

      Configures a virtual routing and forwarding (VRF) routing table instance and enters VRF configuration mode.

       
      Step 4address-family ipv4


      Example:
      Device(config-vrf)# address-family ipv4
       

      Configures an address family for the VRF and enters VRF address family configuration mode.

       
      Step 5exit


      Example:
      Device(config-vrf-af)# exit
       

      Exits VRF address family configuration mode and enters VRF configuration mode.

       
      Step 6exit


      Example:
      Device(config-vrf)# exit
       

      Exits VRF configuration mode and enters global configuration mode.

       
      Step 7 ip multicast-routing vrf vrf-name [distributed]


      Example:
      Device(config)# ip multicast-routing vrf VRF1 distributed
       

      Enables IP multicast routing.

       
      Step 8Enter one of the following:
      • ip pim vrf vrf-name rp-address ip-address
      • ip pim vrf vrf-name ssm {default | range {access-list-number | access-list-name}}


      Example:
      Device(config)# ip pim vrf VRF1 rp-address 10.1.0.2


      Example:
      Device(config)# ip pim vrf VRF1 ssm default
       
      • Statically configures the address of a Protocol Independent Multicast (PIM) rendezvous point (RP) for multicast groups.

      • Defines the Source Specific Multicast (SSM) range of IP multicast addresses.

       
      Step 9 interface lisp interface-number


      Example:
      Device(config)# interface lisp 22.10
       

      Selects a LISP interface to configure and enters interface configuration mode.

       
      Step 10 ip pim sparse-mode


      Example:
      Device(config-if)# ip pim sparse-mode
       

      Enables Protocol Independent Multicast (PIM) on an interface for sparse-mode operation.

       
      Step 11 exit


      Example:
      Device(config-if)# exit
       

      Exits interface configuration mode and enters global configuration mode.

       
      Step 12interface interface-type interface-number


      Example:
      Device(config)# interface GigabitEthernet0/0/0
       

      Configures the LISP interface facing the site and enters interface configuration mode.

       
      Step 13vrf forwarding vrf-name


      Example:
      Device(config-if)# vrf forwarding VRF1
       

      Enables VRF forwarding on the interface.

       
      Step 14 description string


      Example:
      Device(config-if)# description Link To Site
       

      Configures a description text for the interface.

       
      Step 15 ip pim sparse-mode


      Example:
      Device(config-if)# ip pim sparse-mode.
       

      Enables Protocol Independent Multicast (PIM) on an interface for sparse-mode operation.

       
      Step 16 end


      Example:
      Device(config-if)# end
       

      Ends the current configuration session and returns to privileged EXEC mode.

       

      Verifying LISP Multicast

      Perform this task to verify the configuration of LISP multicast routes on a device.

      SUMMARY STEPS

        1.    show ip mroute multicast-ip-address

        2.    ping multicast-ip-address


      DETAILED STEPS
        Step 1   show ip mroute multicast-ip-address


        Example:

        The following example shows how the IP multicast routing table is displayed using the show ip mroute command:

        Device# show ip mroute 239.4.4.4
        
        IP Multicast Routing Table
        Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
               L - Local, P - Pruned, R - RP-bit set, F - Register flag,
               T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
               X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
               U - URD, I - Received Source Specific Host Report,
               Z - Multicast Tunnel, z - MDT-data group sender,
               Y - Joined MDT-data group, y - Sending to MDT-data group,
               G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
               N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
               Q - Received BGP S-A Route, q - Sent BGP S-A Route,
               V - RD & Vector, v - Vector, p - PIM Joins on route,
               x - VxLAN group
        Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
         Timers: Uptime/Expires
         Interface state: Interface, Next-Hop or VCD, State/Mode
        
        (*, 239.4.4.4), 00:06:25/00:02:39, RP 10.1.0.2, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.1.0.2
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:06:24/00:02:39
        
        (*, 224.0.1.40), 00:06:25/00:02:37, RP 10.1.0.2, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.1.0.2
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:06:24/00:02:37
        
        
        
        
        Step 2   ping multicast-ip-address


        Example:

        The following example shows how to verify basic multicast network connectivity by pinging the multicast address:

        Device# ping 239.4.4.4
        
        Type escape sequence to abort.
        Sending 1, 100-byte ICMP Echos to 239.4.4.4, timeout is 2 seconds:
        
        Reply to request 0 from 192.168.0.1, 15 ms
        Reply to request 0 from 10.1.0.2, 58 ms
        Reply to request 0 from 10.1.0.2, 58 ms
        Reply to request 0 from 10.1.0.1, 35 ms
        Reply to request 0 from 10.1.0.2, 34 ms
        Reply to request 0 from 10.1.0.1, 15 ms
        
        
        
        
        

        Configuration Examples for LISP Multicast

        Example: Configuring LISP Multicast

        Router 1

        The following example shows how to configure LISP Multicast in the topology given below:

        Figure 1. LISP Multicast Topology



        The following example shows how to configure LISP multicast in Router 1:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface Loopback1
         ip address 192.168.0.1 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Loopback2
         ip address 192.168.0.2 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Loopback3
         ip address 192.168.0.3 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Serial0/0
         ip address 10.1.0.1 255.255.255.0
         ip pim sparse-mode
         serial restart-delay 0
        !
        router rip
         version 2
         network 10.0.0.0
         network 192.168.0.0
         default-information originate
        !
        ip forward-protocol nd
        !
        ip pim rp-address 10.1.0.2
        !
        !
        End
        
        
        
        

        The following example shows how to verify the configuration of LISP multicast routes in Router 1:

        Device# show ip mroute
        
        
        IP Multicast Routing Table
        Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
               L - Local, P - Pruned, R - RP-bit set, F - Register flag,
               T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
               X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
               U - URD, I - Received Source Specific Host Report,
               Z - Multicast Tunnel, z - MDT-data group sender,
               Y - Joined MDT-data group, y - Sending to MDT-data group,
               G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
               N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
               Q - Received BGP S-A Route, q - Sent BGP S-A Route,
               V - RD & Vector, v - Vector, p - PIM Joins on route,
               x - VxLAN group
        Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
         Timers: Uptime/Expires
         Interface state: Interface, Next-Hop or VCD, State/Mode
        
        (*, 239.4.4.4), 00:00:49/00:02:16, RP 10.1.0.2, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.1.0.2
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:00:48/00:02:12
        
        (*, 224.0.1.40), 00:00:49/00:02:11, RP 10.1.0.2, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.1.0.2
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:00:48/00:02:11
        
        
        
        

        The following example shows how to verify basic multicast network connectivity from Router 1 by pinging the multicast address:

        Device# ping 239.4.4.4
        
        
        Type escape sequence to abort.
        Sending 1, 100-byte ICMP Echos to 239.4.4.4, timeout is 2 seconds:
        
        Reply to request 0 from 192.168.0.1, 9 ms
        Reply to request 0 from 10.1.0.2, 48 ms
        Reply to request 0 from 192.168.0.2, 16 ms
        Reply to request 0 from 192.168.0.3, 16 ms
        Reply to request 0 from 10.1.0.1, 38 ms
        Reply to request 0 from 10.1.0.2, 38 ms
        Reply to request 0 from 10.1.0.2, 29 ms
        Reply to request 0 from 10.1.0.1, 9 ms
        
        
        
        

        The following example shows how to configure LISP multicast in xTR1:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface LISP0
         ip pim sparse-mode
        !
        interface Serial1/0
         ip address 10.1.0.2 255.255.255.0
         ip pim sparse-mode
         serial restart-delay 0
        !
        interface Serial2/0
         ip address 10.2.0.1 255.255.255.0
         serial restart-delay 0
        !
        router lisp
         database-mapping 192.168.0.0/24 10.2.0.1 priority 1 weight 100
         ipv4 itr map-resolver 10.14.0.14
         ipv4 itr
         ipv4 etr map-server 10.14.0.14 key password123
         ipv4 etr
         exit
        !
        !
        router rip
         version 2
         network 10.0.0.0
         default-information originate
        !
        ip pim rp-address 10.1.0.2
        ip route 0.0.0.0 0.0.0.0 10.2.0.2
        !
        
        
        
        

        The following example shows how to configure LISP multicast in Router 2:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface Loopback1
         ip address 192.168.1.1 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Loopback2
         ip address 192.168.1.2 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Loopback3
         ip address 192.168.1.3 255.255.255.255
         ip pim sparse-mode
         ip igmp join-group 239.4.4.4
         serial restart-delay 0
        !
        interface Serial0/0
         ip address 10.4.0.2 255.255.255.0
         ip pim sparse-mode
         serial restart-delay 0
        !
        !
        router rip
         version 2
         network 10.0.0.0
         network 192.168.1.0
         default-information originate
        !
        ip forward-protocol nd
        !
        !
        ip pim rp-address 10.1.0.2
        !
        !
        End
        
        
        
        

        The following example shows how to verify the configuration of LISP multicast routes in Router 2:

        Device# show ip mroute
        
        
        IP Multicast Routing Table
        Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
               L - Local, P - Pruned, R - RP-bit set, F - Register flag,
               T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
               X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
               U - URD, I - Received Source Specific Host Report,
               Z - Multicast Tunnel, z - MDT-data group sender,
               Y - Joined MDT-data group, y - Sending to MDT-data group,
               G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
               N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
               Q - Received BGP S-A Route, q - Sent BGP S-A Route,
               V - RD & Vector, v - Vector, p - PIM Joins on route,
               x - VxLAN group
        Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
         Timers: Uptime/Expires
         Interface state: Interface, Next-Hop or VCD, State/Mode
        
        (*, 239.4.4.4), 00:12:59/00:02:01, RP 10.4.0.1, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.4.0.1
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:12:58/00:02:01
        
        (*, 224.0.1.40), 00:12:59/00:02:03, RP 10.4.0.1, flags: SJCL
          Incoming interface: Serial0/0, RPF nbr 10.4.0.1
          Outgoing interface list:
            Loopback2, Forward/Sparse, 00:12:58/00:02:03
        
        
        
        

        The following example shows how to verify basic multicast network connectivity from Router 2 by pinging the multicast address:

        Device# ping 239.4.4.4
        
        
        Type escape sequence to abort.
        Sending 1, 100-byte ICMP Echos to 239.4.4.4, timeout is 2 seconds:
        
        Reply to request 0 from 192.168.1.1, 2 ms
        Reply to request 0 from 10.3.0.2, 26 ms
        Reply to request 0 from 10.4.0.1, 26 ms
        Reply to request 0 from 192.168.1.2, 2 ms
        Reply to request 0 from 192.168.1.3, 8 ms
        Reply to request 0 from 10.4.0.1, 16 ms
        Reply to request 0 from 10.4.0.1, 16 ms
        Reply to request 0 from 10.4.0.2, 2 ms
        
        
        
        

        The following example shows how to configure LISP multicast in xTR2:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface LISP0
         ip pim sparse-mode
        !
        !
        interface Serial1/0
         ip address 10.3.0.2 255.255.255.0
         serial restart-delay 0
        !
        interface Serial2/0
         ip address 10.4.0.1 255.255.255.0
         ip pim sparse-mode
         serial restart-delay 0
        !
        !
        router lisp
         database-mapping 192.168.1.0/24 10.3.0.2 priority 1 weight 100
         ipv4 itr map-resolver 10.14.0.14
         ipv4 itr
         ipv4 etr map-server 10.14.0.14 key Amel
         ipv4 etr
         exit
        !
        router rip
         version 2
         network 10.0.0.0
         default-information originate
        !
        ip pim rp-address 10.1.0.2
        ip route 0.0.0.0 0.0.0.0 10.3.0.1
        !
        
        
        
        

        The following example shows how to configure LISP multicast in MS/MR:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface Serial3/0
         ip address 10.14.0.14 255.255.255.0
         serial restart-delay 0
        !
        !
        router lisp
         site Site-A
          authentication-key password123
          eid-prefix 192.168.0.0/24
          exit
         !
         site Site-B
          authentication-key Amel
          eid-prefix 192.168.1.0/24
          exit
         !
         ipv4 map-server
         ipv4 map-resolver
         exit
        !
        ip route 0.0.0.0 0.0.0.0 10.14.0.1
        !
        
        
        
        

        The following example shows how to configure LISP multicast in the Core router:

        Device# show startup-config
        
        
        !
        ip multicast-routing
        !
        interface Ethernet0/0
         ip address 10.14.0.1 255.255.255.0
         serial restart-delay 0
        !
        interface Serial1/0
         ip address 10.2.0.2 255.255.255.0
         serial restart-delay 0
        !
        interface Serial2/0
         ip address 10.3.0.1 255.255.255.0
         serial restart-delay 0
        !
        
        
        
        

        Example: Configuring LISP Multicast in VRFs

        The following example shows how to enable and configure a simple LISP site with one IPv4 Routing locator (RLOC) and one IPv4 Endpoint identifier (EID) using xTR, a device which functions both as an Ingress tunnel router (ITR) and an Egress tunnel router (ETR), functionality and using a LISP map server and map resolver for mapping services:

        Device> enable
        Device# configure terminal
        Device(config)# vrf definition VRF1
        Device(config-vrf)# address-family ipv4
        Device(config-vrf-af)# exit
        Device(config-vrf)# exit
        Device(config)# ip multicast-routing vrf VRF1 [distributed]
        Device(config)# ip pim vrf VRF1 ssm range LIST1
        Device(config)# router lisp 22
        Device(config-router-lisp)# eid-table vrf VRF1 instance-id 10
        Device(config-router-lisp-eid-table)# database-mapping 198.51.100.0/24 192.0.2.10 priority 1 weight 100
        Device(config-router-lisp-eid-table)# exit
        Device(config-router-lisp)# ipv4 itr
        Device(config-router-lisp)# ipv4 etr
        Device(config-router-lisp)# ipv4 itr map-resolver 192.0.2.10
        Device(config-router-lisp)# ipv4 etr map-server 192.0.2.10 key 0 some-key
        Device(config-router-lisp)# exit
        Device(config)# interface lisp 22.10
        Device(config-if)# ip pim sparse-mode
        Device(config-if)# exit
        Device(config)# ip route 0.0.0.0 0.0.0.0 192.0.2.20
        Device(config)# end

        Additional References for LISP Multicast

        The following sections provide references related to the Locator ID Separation Protocol.

        Related Documents

        Document Title

        Location

        Cisco IOS commands

        Cisco IOS Master Command List, All Releases

        LISP commands

        Cisco IOS IP Routing: LISP Command Reference

        Standards

        Standard

        Title

        Address family numbers

        IANA Address Family Numbers

        MIBs

        MIB

        MIBs Link

        None

        To locate and download MIBs for selected platforms, Cisco IOS software releases, and feature sets, use Cisco MIB Locator found at the following URL: http:/​/​www.cisco.com/​go/​mibs

        RFCs

        RFC

        Title

        RFC 6830

        Locator/ID Separation Protocol (LISP) http:/​/​tools.ietf.org/​html/​

        RFC 6831

        LISP Multicast http:/​/​tools.ietf.org/​html/​rfc6831

        RFC 6832

        Interworking LISP and Non-LISP Sites http:/​/​tools.ietf.org/​html/​rfc6832

        RFC 6833

        LISP Map Server Interface http:/​/​tools.ietf.org/​html/​rfc6833

        RFC 6834

        LISP Map-Versioning http:/​/​tools.ietf.org/​html/​rfc6834

        RFC 6835

        LISP Internet Groper http:/​/​tools.ietf.org/​html/​rfc6835

        RFC 6836

        LISP Alternative Topology (LISP+ALT) http:/​/​tools.ietf.org/​html/​rfc6836

        Technical Assistance

        Description

        Link

        The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

        To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

        Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        Feature Information for LISP Multicast

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.
        Table 1 Feature Information for LISP Multicast

        Feature Name

        Releases

        Feature Information

        LISP Multicast

        Cisco IOS XE Release 3.13S

        The LISP Multicast feature introduces support for carrying multicast traffic over a Locator ID Separation Protocol (LISP) overlay and allows source multicast sites and receiver multicast sites to send and receive multicast packets over a unicast RLOC core.