IPv6: RIPng VRF-Aware Support

The IPv6: RIPng VRF-Aware Support feature uses separate routing tables for every provider edge-customer edge (PE-CE) scenario, thus allowing improved route protection, modularity, and a potential reduction in the size of the routing table.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/. An account on Cisco.com is not required.

Information About IPv6: RIPng VRF-Aware Support

IPv6 Routing: RIP for IPv6

IPv6 Routing Information Protocol (RIP) functions the same and offers the same benefits as IPv4 RIP. RIP enhancements for IPv6, detailed in RFC 2080, include support for IPv6 addresses and prefixes and the use of the all-RIP-devices multicast group address, FF02::9, as the destination address for RIP update messages.

IPv6: RIPng VRF-Aware Support

When not in Virtual Routing and Forwarding (VRF) mode, every IPv6 Routing Information Protocol (RIP)—also know as RIP Next Generation (RIPng)—process and the configuration associated with it, keeps all the routes in the same routing table. In other routing protocols, it is often required to keep the protocol-related routes stored in separate routing tables.

The IPv6: RIPng VRF-Aware Support feature enables isolation, modularity, and potential performance improvement by reducing the number of routes stored in a single routing table. It also allows a network administrator to create different RIP routing tables and share the same protocol configuration stored in a single RIP protocol configuration block.

How to Configure IPv6: RIPng VRF-Aware Support

Configuring IPv6: RIPng VRF-Aware Support

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. ipv6 unicast-routing
  4. vrf definition vrf-name
  5. address-family ipv6
  6. exit
  7. exit
  8. ipv6 rip vrf-mode enable
  9. ipv6 router rip rip-process-name
  10. exit
  11. interface type number
  12. vrf forwarding vrf-name
  13. ipv6 enable
  14. ipv6 rip rip-process-name enable
  15. end
  16. debug ipv6 rip vrf vrf-name
  17. show ipv6 rip vrf vrf-name next-hops
  18. show ipv6 rip vrf vrf-name database

DETAILED STEPS

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:

Device # configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing

Example:

Device (config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

Step 4

vrf definition vrf-name

Example:

Device(config)# vrf definition vrf1

Configures a virtual routing and forwarding (VRF) routing table instance and enters VRF configuration mode.

Step 5

address-family ipv6

Example:

Device(config-vrf)# address-family ipv6

Enters VRF address family configuration mode and enables IPv6 address prefixes.

Step 6

exit

Example:

Device(config-vrf-af)# exit

Exits VRF address family configuration mode and returns to VRF configuration mode.

Step 7

exit

Example:

Device(config-vrf)# exit

Exits VRF configuration mode and returns to global configuration mode.

Step 8

ipv6 rip vrf-mode enable

Example:

Device (config)# ipv6 rip vrf-mode enable

Enables VRF support for IPv6 RIP routing and enters RTR entry configuration mode.

Step 9

ipv6 router rip rip-process-name

Example:

Device (config)# ipv6 router rip myrip

Creates an IPv6 Routing Information Protocol (RIP) routing process instance.

Step 10

exit

Example:

Device (config-rtr)# exit

Exits RTR entry configuration mode and returns to global configuration mode.

Step 11

interface type number

Example:

Device (config)# interface Ethernet 0/0

Specifies the interface type and number and enters interface configuration mode.

Step 12

vrf forwarding vrf-name

Example:

Device(config-if)# vrf forwarding vrf1

Binds the interface to the specified VRF routing instance table and removes all the Layer 3 interface configuration that is available when the command is entered.

Step 13

ipv6 enable

Example:

Device(config-if)# ipv6 enable

Enables IPv6 on the interface.

Step 14

ipv6 rip rip-process-name enable

Example:

Device(config-if)# ipv6 rip myrip enable

Enables an IPv6 RIP routing process on the interface.

Step 15

end

Example:

Device (config-if)# end

Exits interface configuration mode and returns to privileged EXEC mode.

Step 16

debug ipv6 rip vrf vrf-name

Example:

Device# debug ipv6 rip vrf vrf1

Displays debugging information related to VRF support for the specified IPv6 RIP VRF routing table instance.

Step 17

show ipv6 rip vrf vrf-name next-hops

Example:

Device# show ipv6 rip vrf vrf1 next-hops

Displays the next hops in the specified VRF RIPng routing table.

Step 18

show ipv6 rip vrf vrf-name database

Example:

Device# show ipv6 rip vrf vrf1 database

Displays the associated RIP local routing information base (RIB).

Configuration Examples for IPv6: RIPng VRF-Aware Support

Example: Configuring IPv6: RIPng VRF-Aware Support


Device> enable
Device# configure terminal 
Device(config)# ipv6 unicast-routing
Device(config)# vrf definition vrf1 
Device(config-vrf)# address-family ipv6
Device(config-vrf-af)# exit
Device(config-vrf)# exit
Device(config)# ipv6 rip vrf-mode enable 
Device(config)# ipv6 router rip myrip
Device(config-rtr)# exit
Device(config)# interface Ethernet 0/0
Device(config-if)# vrf forwarding vrf1
Device(config-if)# ipv6 enable
Device(config-if)# ipv6 rip myrip enable 
Device(config-if)# end

Example: Verifying IPv6: RIPng VRF-Aware Support


Device> debug ipv6 rip vrf vrf1

RIP Routing Protocol debugging is on for vrf vrf1
Sending:
*Mar 15 11:23:08.508: RIPng: Sending multicast update on Ethernet0/0 for vrf for vrf vrf1
*Mar 15 11:23:08.508: src=2001:DB8:0:1:FFFF:1234::5
*Mar 15 11:23:08.508: dst=2001:DB8:0:1::1 (Ethernet0/0)
*Mar 15 11:23:08.508: sport=521, dport=521, length=52
*Mar 15 11:23:08.508: command=2, version=1, mbz=0, #rte=2
*Mar 15 11:23:08.508: tag=0, metric=1, prefix=6000::/64
*Mar 15 11:23:08.508: tag=0, metric=1, prefix=2000::/64
*Mar 15 11:23:08.508: RIPng: Packet waiting
*Mar 15 11:23:08.508: RIPng: Process vrf received own response on Loopback1
Receiving
*Mar 15 11:23:20.316: RIPng: Packet waiting
*Mar 15 11:23:20.316: RIPng: response received from FE80::A8BB:CCFF:FE00:7C00 on Ethernet0/0
for vrf
*Mar 15 11:23:20.316: src=2001:DB8:0:1:FFFF:1234::4 (Ethernet0/0)
*Mar 15 11:23:20.316: dst=2001:DB8::1
*Mar 15 11:23:20.316: sport=521, dport=521, length=32
*Mar 15 11:23:20.316: command=2, version=1, mbz=0, #rte=1
*Mar 15 11:23:20.316: tag=0, metric=1, prefix=AAAA::/64

Device> show ipv6 rip vrf vrf1	database

RIP VRF "vrf1", local RIB
FE80::A8BB:CCFF:FE00:7C00/Ethernet0/0 [1 paths]


Device> show ipv6 rip vrf vrf1 next-hops

RIP VRF "vrf1", Next Hops
 AAAA::/64, metric 2, installed
Ethernet0/0/FE80::A8BB:CCFF:FE00:7C00, expires in 177 secs

Additional References for IPv6: RIPng VRF-Aware Support

Related Documents

Related Topic Document Title

IP Routing: RIP commands

Cisco IOS IP Routing: RIP Command Reference

IPv6 Routing: RIP for IPv6

Cisco IOS IP Routing: RIP Configuration Guide

Standards and RFCs

Standard/RFC Title

RFC 2080

RIPng for IPv6

Technical Assistance

Description Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/support

Feature Information for IPv6: RIPng VRF-Aware Support

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1. IPv6: RIPng VRF-Aware Support

Feature Name

Releases

Feature Information

IPv6: RIPng VRF-Aware Support

15.3(3)M

15.2(1)SY

When not virtual routing and forwarding (VRF) aware, IPv6 Routing Information Protocol (RIP), also known as RIP Next Generation (RIPng), works only with routes that are available in the default global routing table. When operating in VRF mode, RIPng, creates a separate routing table for each VRF instance. The IPv6: RIPng VRF-Aware Support feature enables the availability of separate routing tables for every provider edge-customer edge (PE-CE) scenario, thus allowing improved route protection, modularity, and a potential reduction in the size of the routing table.

The following commands were introduced or modified: clear ipv6 rip, debug ipv6 rip , ipv6 rip vrf-mode enable, and show ipv6 rip.