Configuring Routed Pseudowire and VPLS

Routed Pseudowire and VPLS feature routes Layer 3 traffic and Layer 2 frames for pseudowire connections between provider edge (PE) devices using Virtual Private LAN Services (VPLS) multipoint PE.

Prerequisites for Routed Pseudowire and VPLS

  • MTU must be manually configured for MPLS enabled interfaces.

Restrictions for Routed Pseudowire and VPLS

  • MPLS is not supported over routed VPLS in releases prior to Cisco IOS XE 16.6.1

  • Maximum number of routed VPLS supported per system is 128.

  • Maximum number of pseudowires supported per bridge domain is 62.

  • Layer 2 and Layer 3 multicast are not supported.

  • ACL on the core network is not supported.

  • PBR is not supported.

  • MTU check is not supported. MTU must be manually configured for MPLS enabled interfaces.

Restrictions on RSP3 Module

  • VRRP and HSRP over VPLS BDI is not supported.

  • Throughput is impacted as the packet is subjected to one extra pass for processing in both the imposition and the disposition flow.

  • Multicast over routed pseudowire is not supported.

  • Routed EoMPLS is not supported.

  • FRR over routed pseudowire is not supported.

  • BFD over routed pseudowire is not supported.

  • MTU check is not performed on core facing interface. Same MTU has to be configured manually on all MPLS enabled interfaces in the network.

  • IPv6 traffic is not supported over routed pseudowire.

Information About Routed Pseudowire and VPLS

Routed Pseudowire and VPLS

Routed Pseudowire and VPLS configuration can route Layer 3 traffic as well as Layer 2 frames for pseudowire connections between provider edge (PE) devices using Virtual Private LAN Services (VPLS) multipoint PE. The ability to route frames to and from these interfaces supports termination of pseudowires into the Layer 3 network (VPN or global) on the same switch, or to the tunnel Layer 3 frames over a Layer 2 tunnel (VPLS).

To configure routing support for a pseudowire, configure the IP address and other Layer 3 features for the Layer 3 domain in interface configuration mode.


Note

BFD over BDI is supported with routed VPLS configuration.


Routed Psuedowire and VPLS on the RSP3 Module

Starting Cisco IOS Release 16.6.1, Routed pseudowire and VPLS is supported on the RSP3 module.

Routed VPLS is the ability to route and bridge frames to and from the pseudowires. Routed VPLS is configured by assigning the IP address under the bridge domain interface (BDI), and then associating that BDI with l2 vfi mode for VPLS. This feature combines the traditional Layer2 functionality with Layer3 routing functions.

Some of the benefits of Routed VPLS are:

  • Offers new service opportunities such as virtual leased-line service and PVC-like layer-based service.

  • Reduces cost by consolidating multiple core technologies into a single packet-based network infrastructure.

  • Provides simplified services such as Layer2 transport options for service providers who need to provide L2 connectivity and maintain customer autonomy.

  • Protects existing investments when networks extend their customer access to existing Layer2 networks without deploying a new separate infrastructure.

How to Configure Routed Pseudowire and VPLS

Configuring Routed Psuedowire andVPLS on the RSP3 Module

PE (RSP3) configuration

l2 vfi 102 manual
vpn id 102
bridge-domain 102
neighbor 3.3.3.3 encapsulation mpls


Access side interface

interface GigabitEthernet0/0/0
 no ip address
 load-interval 30
 negotiation auto
 service instance 1 ethernet
  encapsulation untagged
  bridge-domain 175

 service instance 2 ethernet
  encapsulation dot1q 102
  rewrite ingress tag pop 1 symmetric
  bridge-domain 102


interface BDI102
 ip address 188.0.0.1 255.255.0.0

interface BDI175
 ip address 175.0.0.1 255.255.0.0

Assigning IP Addresses For Bridge Domain (BDI)

Procedure

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

interface bdi bdi-number

Example:

Router(config)# interface bdi 3000

Configures the bridge domain interface.

Step 4

ip address ip address subnet mask

Example:

Router(config-if)# ip address 24.24.24.24 255.255.255.0

Specifies the IP address for the bridge domain.

Step 5

no shut

Example:

Router(config-if)# no shutdown

Enables the bridge domain interface.

Step 6

end

Example:

Router(config-if)# end

Exits interface configuration mode.

Configuring a VFI on a PE Device

The virtual forwarding interface (VFI) specifies the VPN ID of a Virtual Private LAN Services (VPLS) domain, the addresses of other provider edge (PE) devices in the domain, and the type of tunnel signaling and encapsulation mechanism for each peer.


Note

Only Multiprotocol Label Switching (MPLS) encapsulation is supported.



Note

You must configure BDI on the bridge domain that has the association with the VFI.


Procedure

  Command or Action Purpose
Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

l2 vfi name manual

Example:


Device(config)# l2 vfi vfi110 manual

Establishes a Layer 2 VPN (L2VPN) virtual forwarding interface (VFI) between two or more separate networks and enters VFI configuration mode.

Step 4

vpn id vpn-id

Example:


Device(config-vfi)# vpn id 110

Configures a VPN ID for a VPLS domain.

  • The emulated VCs bound to this Layer 2 virtual routing and forwarding (VRF) instance use this VPN ID for signaling.

Step 5

neighbor remote-router-id vc-id {encapsulation encapsulation-type | pw-class pw-name } [no-split-horizon ]

Example:


Device(config-vfi)# neighbor 172.16.10.2 4 encapsulation mpls

Specifies the type of tunnel signaling and encapsulation mechanism for each VPLS peer.

Note 

Split horizon is the default configuration to avoid broadcast packet looping and to isolate Layer 2 traffic. Use the no-split-horizon keyword to disable split horizon and to configure multiple VCs per spoke into the same VFI.

Step 6

bridge-domain bd-id

Example:


Device(config-vfi)# bridge-domain 100

Specifies a bridge domain.

Step 7

end

Example:


Device(config-vfi)# end

Exits VFI configuration mode and returns to privileged EXEC mode.

Configuration Examples: Routed Pseudowire and VPLS

Example: Configuring Routed Pseudowire and VPLS

The example configures the IP address on a BDI interface and associates the interface to a VFI.


!
interface GigabitEthernet0/0/0
 service instance 3 ethernet
  encapsulation dot1q 3000
  rewrite ingress tag pop 1 symmetric
  bridge-domain 100
!
interface BDI100
 ip address 24.24.24.24 255.255.255.0
 no shut
!
l2 vfi TEST manual 
 vpn id 100
 bridge-domain 100
 neighbor 9.9.9.9 encapsulation mpls
!

Verifying the Configuration on the RSP3 Module

Use the follwing show commands to verify routed pseudowire and VPLS configurations on the RSP3.

  • show l2vpn vfi d

  • show mpls ldp bindings local-label

  • show mpls forwarding-table

  • show ip cef

  • show platform ha pp act pw vpls

show mpls l2transport vc

Router# show mpls l2transport vc 100        

Local intf     Local circuit              Dest address    VC ID      Status    
-------------  --------------------------     ---------------      ----------   ----------
Gi0/2          Eth VLAN 100               192.168.1.7         100          UP        
ASR900#

show mpls l2transport summary

Router# show mpls l2transport summary 
Destination address: 110.0.0.3, total number of vc: 226
  0 unknown, 0 up, 125 down, 101 admin down, 0 recovering, 0 standby, 0 hotstandby
  99 active vc on MPLS interface Gi0/16