Step 1
|
enable
|
Enables
privileged EXEC mode.
|
Step 2
|
configure
terminal
Device# configure terminal
|
Enters global
configuration mode.
|
Step 3
|
crypto
IPsec
profile
profile-name
Device(config)# crypto IPsec profile TUNNEL-PROFILE-SITE
|
Defines the
IPsec parameters that are to be used for IPsec encryption between two IPsec
devices, and enters IPsec profile configuration mode.
|
Step 4
|
set
transform-set
transform-set-name [transform-set-name2...transform-set-name6]
Device(config-ipsec-profile)# set transform-set tset1
|
Specifies which
transform sets can be used
.
|
Step 5
|
set
ikev2 profile ikev2 profile-name
Device(config-ipsec-profile)# set ikev2-profile ikev2profile
|
Specifies which transform sets can be used .
|
Step 6
|
crypto
ikev2
dpd
interval retry-interval {on-demand | periodic}
Device(config-ikev2-profile)# crypto ikev2 dpd 10 2 periodic
|
This step is optional. Configures Dead Peer Detection (DPD) globally for peers matching the profile. By default, the Dead
Peer Detection (DPD) is disabled.
|
Step 7
|
exit
Device(ipsec-profile)# exit
|
Exits IPsec
profile configuration mode, and enters global configuration mode.
|
Step 8
|
interface
type
number
Device(config)# interface tunnel 10
|
Specifies the
interface on which the tunnel will be configured and enters interface
configuration mode.
|
Step 9
|
ip
address
address
mask
Device(config-if)# ip address 10.10.10.1 255.255.255.0
|
Specifies the
IP address and mask.
|
Step 10
|
tunnel
source
ip address
Device(config-if)# tunnel source 2.2.2.1
|
Specifies the tunnel source address. For IPsec HA, this tunnel source address should point to the HSRP VIP (Virtual IP) address
of the physical interface terminating the tunnel.
|
Step 11
|
tunnel mode ipsec
ipv4
Device(config-if)# tunnel mode ipsec ipv4
|
Defines the mode for the tunnel.
|
Step 12
|
tunnel
destination
ip-address
Device(config-if)# tunnel destination 3.3.3.5
|
Identifies
the IP address of the tunnel destination.
|
Step 13
|
tunnel
protection
IPsec
profile
profile-name
Device(config-if)# tunnel protection IPsec profile TUNNEL-PROFILE-SITE
|
Associates a tunnel interface with an IPsec profile.
|
Step 14
|
exit
|
Exits interface configuration mode and returns to privileged EXEC mode.
|
Step 15
|
interface
type slot/port
number
Device(config)# interface GigabitEthernet0/0/0
|
Specifies a gigabit ethernet interface and enters interface configuration mode.
|
Step 16
|
ip
address
address
mask
Device(config-if)# ip address 2.2.2.2 255.255.255.0
|
Specifies the IP address and mask.
|
Step 17
|
standbygroup-number
ip [IP [secondary]]
Device(config-if)# standby 1 ip 2.2.2.1
|
Speicifies the standby IP address to activate the Hot Standby Router Protocol (HSRP).
|
Step 18
|
standbygroup-number
priority
priority name
Device(config-if)# standby 1 priority 105
|
Speicifies the standby priority to activate the Hot Standby Router Protocol (HSRP).
|
Step 19
|
standbygroup-number
preempt
Device(config-if)# standby 1 preempt
|
Speicifies the standby preempt to activate the Hot Standby Router Protocol (HSRP).
|
Step 20
|
standbygroup-number
name
name
Device(config-if)# standby 1 name IPSEC-VTI-HA
|
Speicifies the standby name to activate the Hot Standby Router Protocol (HSRP).
|
Step 21
|
standbygroup-number
track
type [interface-priority]
Device(config-if)# standby 1 track 200 decrement 10
|
Specifies the interface to track other interfaces, so that if one of the other interfaces goes down, the device's Hot Standby
priority is lowered.
|
Step 22
|
negotiate auto
Device(config-if)# negotiation auto
|
Enables the autonegotiation protocol to configure the speed, duplex, and automatic flow-control of the Gigabit Ethernet interface.
|
Step 23
|
exit
|
Exits interface configuration mode and returns to privileged EXEC mode.
|
Step 24
|
interface
type slot/port
number
Device(config)# interface GigabitEthernet0/0/1
|
Specifies a gigabit ethernet interface and enters interface configuration mode.
|
Step 25
|
ip
address
address
mask
Device(config-if)# ip address 1.1.1.2 255.255.255.0
|
Specifies the IP address and mask.
|
Step 26
|
standbygroup-number
ip [IP [secondary]]
Device(config-if)# standby 2 ip 1.1.1.1
|
Speicifies the standby IP address to activate the Hot Standby Router Protocol (HSRP).
|
Step 27
|
standbygroup-number
priority
priority name
Device(config-if)# standby 2 priority 105
|
Speicifies the standby priority to activate the Hot Standby Router Protocol (HSRP).
|
Step 28
|
standbygroup-number
preempt
Device(config-if)# standby 2 preempt
|
Speicifies the standby preempt to activate the Hot Standby Router Protocol (HSRP).
|
Step 29
|
standbygroup-number
track
type [interface-priority]
Device(config-if)# standby 2 track 100 decrement 10
|
Specifies the interface to track other interfaces, so that if one of the other interfaces goes down, the device's Hot Standby
priority is lowered.
|
Step 30
|
negotiate auto
Device(config-if)# negotiation auto
|
Enables the autonegotiation protocol to configure the speed, duplex, and automatic flow-control of the Gigabit Ethernet interface.
|
Step 31
|
exit
|
Exits interface configuration mode and returns to privileged EXEC mode.
|
Step 32
|
Repeat the same steps and configure the device B.
|
|