BGP - SR: BGP Prefix SID Redistribution

The BGP - SR: BGP Prefix SID Redistribution feature provides support for BGP Prefix-SID in IPv4 prefixes in segment routing—BGP networks.

Prerequisites for BGP - SR: BGP Prefix SID Redistribution

  • Mulitprotocol Label Switching (MPLS) must be configured.

Information About BGP - SR: BGP Prefix SID Redistribution

Segment Routing and BGP

Segment Routing uses Multiprotocol Label Switching (MPLS) labels to create a path to guide a packet in a network. Using segment routing, an MPLS label range is reserved with MPLS Forwarding Infrastructure (MFI). This label range is called Segment Routing Global Block (SRGB). A prefix SID assigned to a prefix is an extension of SRGB.

To support segment routing, Border Gateway Protocol (BGP) requires the ability to advertise a segment identifier (SID) for a BGP prefix. A BGP-Prefix-SID is the segment identifier of the BGP prefix segment in an segment routing with BGP network. A BGP-Prefix-SID is also an instruction to forward the packet over an ECMP-aware best-path computed by BGP to a related prefix. When BGP nodes communicate with neighbor nodes in a network, the BGP Update, message sent to neighbor nodes, includes the Prefix-SID Label in Labeled Unicast NLRI and a prefix SID index in a new attribute called Prefix SID attribute.

To support forwarding paths for traffic engineering, the forwarding path may need to be different from the optimal path. Hence, each BGP node assigns a local label to the neighbors and advertises the local label as adjacency SID through BGP--link state updates.

The BGP - SR: BGP Prefix SID Redistribution feature can be enabled by using the connected-prefix-sid-map command in the segment routing MPLS configuration mode. Additionally, you also need to enable the segment-routing mpls command in the router configuration mode for each address family.


Note

In Cisco IOS XE Everest 16.6.1, IPv4 prefixes only are supported.


Segment Routing for Locally Sourced Routes

Interface host routes configured on local nodes are known as locally sourced routes. If segment routing is enabled, a BGP node includes the explicit or implicit null as prefix SID label and prefix SID attribute and advertises the prefix to a neighbor node.

If explicit-null is not configured on a neighbor, the MPLS Implicit Null label (3) is advertised to a neighbor node. If explicit-null is configured on a neighbor, the MPLS Explicit Null label corresponding to the address family of the prefix is advertised (0 for IPv4) to a neighbor node.

Segment Routing for Received Prefixes

BGP nodes that receive prefix SID attribute from a neighbor node via communication, add the label in the outgoing label as the prefix when a route is added to the RIB. The local label and prefix SID index is included in the RIB.

Segment Routing for Redistributed Routes

A source protocol on a BGP node allocates local label depending on the received prefix SID index and SRGB available on a local node. A source protocol provides the prefix SID index and the derived local label to RIB. BGP uses the local label from RIB as a label in the Labeled Unicast update sent to neighbors nodes.

BGP--MFI Interaction

BGP registers with MFI as a client and binds the label derived from SID index and SRGB as local label (with which traffic is expected to arrive) for the prefix.

How to Enable BGP - SR: BGP Prefix SID Redistribution

Enabling BGP-Prefix-SID

segment-routing mpls
 connected-prefix-sid-map */--------> Configures Prefix to SIDIndex Map that can be queried by BGP/IGP /*
 address-family ipv4
 10.0.0.1/255.0.0.0 index 10 range 11.0.0.1

Enabling BGP for Segment Routing

router bgp 2
 address-family-ipv4 
  segment-routing mpls

Verifying BGP - SR: BGP Prefix SID Redistribution

This section shows how to verify the BGP - SR: BGP Prefix SID Redistribution feature with the help of an example network, in which, a device configured with segment routing is connected to two devices configured with Border Gateway Protocol (BGP). In each device, the show segment-routing mpls command is used to view the configuration.

The following is configuration on the device configured with segment routing.

segment-routing mpls
global-block 10000 13000
!
connected-prefix-sid-map
  address-family ipv4
   12.1.1.1/32 index 3 range 1 
  exit-address-family
!
  segment-routing mpls


interface Loopback0
ip address 12.1.1.1 255.255.255.255

router bgp 1
neighbor 10.1.1.2 remote-as 2
!
address-family ipv4
  redistribute connected
  segment-routing mpls
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-label
exit-address-family

The following is the configuration on the first device configured with BGP.

segment-routing mpls

router bgp 2
neighbor 10.1.1.1 remote-as 1
neighbor 11.1.1.2 remote-as 3
!
address-family ipv4
  redistribute connected
  neighbor 10.1.1.1 activate
  neighbor 10.1.1.1 send-label
  neighbor 11.1.1.2 activate
  neighbor 11.1.1.2 send-label
exit-address-family

The following is the configuration on the second device configured with BGP.

segment-routing mpls

router bgp 3
neighbor 11.1.1.1 remote-as 2
!
address-family ipv4
  redistribute connected
  neighbor 11.1.1.1 activate
  neighbor 11.1.1.1 send-label
exit-address-family

Additional References for BGP - SR: BGP Prefix SID Redistribution

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Command List, All Releases

Standards and RFCs

Standard/RFC

Title

RFC3107

Carrying Label Information in BGP-4

Feature Information for BGP - SR: BGP Prefix SID Redistribution

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Table 1. Feature Information for BGP - SR: BGP Prefix SID Redistribution

Feature Name

Releases

Feature Information

BGP - SR: BGP Prefix SID Redistribution

Cisco IOS XE Everest 16.6.1

The BGP - SR: BGP Prefix SID Redistribution feature provides support for BGP Prefix-SID in IPv4 prefixes in segment routing—BGP networks.

The following commands were introduced or modified: connected-prefix-sid-map, segment-routing.