- log-adjacency-changes
- lsp-full suppress
- lsp-gen-interval (IPX)
- lsp-gen-interval (IS-IS)
- lsp-refresh-interval (IS-IS)
- max-area-addresses
- metric
- metric-style wide
- net
- partition avoidance
- prc-interval
- protocol shutdown
- redistribute isis
- router isis
- set-attached-bit
- set-overload-bit
- show clns interface
- show clns is-neighbors
- show clns traffic
- show isis database
- show isis database verbose
- show isis fast-reroute
- show isis hostname
- show isis lsp-log
- show isis neighbors
- show isis nsf
- show isis rib
- show isis rib redistribution
- show isis spf-log
- show isis topology
- snmp-server enable traps isis
- spf-interval
- srlg
- summary-address (IS-IS)
- vrf (router configuration)
log-adjacency-changes
To configure the router to send a syslog message when an Open Shortest Path First (OSPF) neighbor goes up or down, use the log-adjacency-changes command in router configuration mode. To turn off this function, use the no form of this command.
log-adjacency-changes [detail]
no log-adjacency-changes [detail]
Syntax Description
detail |
(Optional) Sends a syslog message for each state change, not just when a neighbor goes up or down. |
Command Default
Enabled
Command Modes
Router configuration
Command History
Usage Guidelines
This command allows you to know about OSPF neighbors going up or down without turning on the debug ip ospf packet command or the debug ipv6 ospf adjacency command. The log-adjacency-changes command provides a higher level view of those changes of the peer relationship with less output than the debug command provides. The log-adjacency-changes command is on by default but only up/down (full/down) events are reported, unless the detail keyword is also used.
Examples
The following example configures the router to send a syslog message when an OSPF neighbor state changes:
log-adjacency-changes detail
Related Commands
|
|
---|---|
debug ip ospf packet |
Displays information about each OSPF packet received for IPv4. |
debug ipv6 ospf |
Displays debugging information for OSPF for IPv6. |
lsp-full suppress
To control which routes are suppressed when the link-state protocol data unit (PDU) becomes full, use the lsp-full suppress command in router configuration mode. To stop suppression of redistributed routes, specify the none keyword or use the no form of this command.
lsp-full suppress {external [interlevel] | interlevel [external] | none}
no lsp-full suppress
Syntax Description
Command Default
Redistributed routes are suppressed.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
In networks where there is no limit placed on the number of redistributed routes into IS-IS (that is, the redistribute maximum-prefix command was not configured), it is possible that the link-state PDU (LSP) could become full and routes will be dropped. Use the lsp-full suppress command to define in advance which routes are suppressed in the event that the LSP becomes full.
The external and interlevel keywords can be specified together or separately.
Use the clear isis lsp-full command to clear the LSPFULL state.
Examples
The following example shows how to specify that if the LSP becomes full, both redistributed routes and routes from another level will be suppressed from the LSP:
router isis
lsp-full suppress interlevel external
Related Commands
lsp-gen-interval (IPX)
To set the minimum interval at which link-state packets (LSPs) are generated, use the lsp-gen-interval command in router configuration mode. To restore the default interval, use the no form of this command.
lsp-gen-interval seconds
no lsp-gen-interval seconds
Syntax Description
seconds |
Minimum interval, in seconds. It can be a number in the range 0 to 120. The default is 5 seconds. |
Defaults
5 seconds
Command Modes
Router configuration
Command History
Usage Guidelines
The lsp-gen-interval command controls the rate at which LSPs are generated on a per-LSP basis. For instance, if a link is changing state at a high rate, the default value of the LSP generation interval limits the signaling of this change to once every 5 seconds. Because the generation of an LSP may cause all routers in the area to perform the SPF calculation, controlling this interval may have area-wide impact. Raising this interval can reduce the load on the network imposed by a rapidly changing link.
Examples
The following example sets the minimum interval at which LSPs are generated to 10 seconds:
lsp-gen-interval 10
Related Commands
|
|
---|---|
ipx router |
Specifies the routing protocol to use. |
spf-interval |
Controls how often Cisco IOS software performs the SPF calculation. |
lsp-gen-interval (IS-IS)
To customize IS-IS throttling of LSP generation, use the lsp-gen-interval command in router configuration mode. To restore default values, use the no form of this command.
lsp-gen-interval [level-1 | level-2] lsp-max-wait [lsp-initial-wait lsp-second-wait]
no lsp-gen-interval
Syntax Description
Defaults
lsp-max-wait: 5 seconds
lsp-initial-wait: 50 milliseconds
lsp-second-wait: 5000 milliseconds
Command Modes
Router configuration
Command History
Usage Guidelines
The following description will help you determine whether to change the default values of this command:
•The lsp-initial-wait argument indicates the initial wait time (in milliseconds) before generating the first LSP.
•The third argument indicates the amount of time to wait (in milliseconds) between the first and second LSP generation.
•Each subsequent wait interval is twice as long as the previous one until the wait interval reaches the lsp-max-wait interval specified, so this value causes the throttling or slowing down of the LSP generation after the initial and second intervals. Once this interval is reached, the wait interval continues at this interval until the network calms down.
•After the network calms down and there are no triggers for 2 times the lsp-max-wait interval, fast behavior is restored (the initial wait time).
Notice that the lsp-gen-interval command controls the delay between LSPs being generated, as opposed to the following related commands:
•The isis lsp-interval command sets the delay (in milliseconds) between successive LSPs being transmitted (including LSPs generated by another system and forwarded by the local system).
•The isis retransmit-interval command sets the amount of time (in seconds) between retransmissions of the same LSP on a point-to-point link.
•The isis retransmit-throttle-interval command sets the minimum delay (in milliseconds) between retransmitted LSPs on a point-to-point interface.
These commands can be used in combination to control the rate of LSP packets being generated, transmitted, and retransmitted.
Examples
The following example configures intervals for SPF calculations, PRC, and LSP generation:
router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100
Related Commands
lsp-refresh-interval (IS-IS)
To set the link-state packet (LSP) refresh interval, use the lsp-refresh-interval command in router configuration mode. To restore the default refresh interval, use the no form of this command.
lsp-refresh-interval seconds
no lsp-refresh-interval
Syntax Description
seconds |
Interval (in seconds) at which LSPs are refreshed.The range is 1 to 65535 seconds. The default value is 900 seconds (15 minutes). |
Defaults
900 seconds (15 minutes)
Command Modes
Router configuration
Command History
Usage Guidelines
The refresh interval determines the rate at which Cisco IOS software periodically transmits in LSPs the route topology information that it originates. This is done to keep the database information from becoming too old.
LSPs must be periodically refreshed before their lifetimes expire. The value set for the lsp-refresh-interval command should be less than the value set for the max-lsp-lifetime command; otherwise, LSPs will time out before they are refreshed. If you misconfigure the LSP lifetime to be too low compared to the LSP refresh interval, the software will reduce the LSP refresh interval to prevent the LSPs from timing out.
Reducing the refresh interval reduces the amount of time that undetected link state database corruption can persist at the cost of increased link utilization. (This is an extremely unlikely event, however, because there are other safeguards against corruption.) Increasing the interval reduces the link utilization caused by the flooding of refreshed packets (although this utilization is very small).
Examples
The following example configures the IS-IS LSP refresh interval to be 1080 seconds (18 minutes):
router isis
lsp-refresh-interval 1080
Related Commands
|
|
---|---|
max-lsp-lifetime (IS-IS) |
Sets the maximum time that link-state packets (LSPs) can remain in a router's database without being refreshed. |
max-area-addresses
To configure additional manual addresses for an IS-IS area, use the max-area-addresses command in router configuration mode. To disable the manual addresses, use the no form of this command.
max-area-addresses number
no max-area-addresses number
Syntax Description
number |
Number of manual addresses to add. The range is from 3 to 234. There is no default value. |
Command Default
No manual addresses are configured for an IS-IS area.
Command Modes
Router configuration
Command History
Usage Guidelines
The max-area-addresses command allows you to maximize the size of an IS-IS area by configuring additional manual addresses. You specify the number of manual addresses that you want to add by entering the max-area-addresses command, and you assign a NET address to create each manual address by entering the net command.
Examples
The following example configures three manual addresses as follows:
router isis
max-area-addresses 3
net 50.3131.3131.3131.00
net 51.3131.3131.3131.00
net 52.3131.3131.3131.00
In the following example, an error message appears because the user has exceeded the maximum number of manual addresses that were configured with the max-area-addresses command:
router isis
max-area-addresses 2
net 50.3131.3131.3131.00
net 51.3131.3131.3131.00
net 52.3131.3131.3131.00
%The maximum allowed addresses already configured
Related Commands
|
|
---|---|
net |
Assigns a NET address to an IS-IS router. |
metric
To globally change the metric value for all Intermediate System-to-Intermediate System (IS-IS) interfaces, use the metric command in interface configuration mode or address family configuration mode. To disable the metric value and reinstate the default metric value of 10, use the no form of this command.
metric default-value [level-1 | level-2]
no metric default-value [level-1 | level-2]
Syntax Description
Defaults
The default value for active IS-IS interfaces is 10; the default value for inactive IS-IS interfaces is 0. If the level-1 or level-2 keyword is not entered, the metric will be applied to both Level 1 and Level 2 IS-IS interfaces.
Command Modes
Interface configuration
Address family configuration
Command History
Usage Guidelines
When you need to change the default metric value for all IS-IS interfaces, it is recommended to use the metric command in order to configure all interfaces globally. Globally configuring the metric values prevents user errors, such as unintentionally removing a set metric from an interface without configuring a new value and unintentionally allowing the interface to revert to the default metric of 10, thereby becoming a highly preferred interface in the network.
For networks running IPv4, enter the metric command in interface configuration mode. For networks running IPv6, enter the metric command in address family configuration mode.
Once you enter the metric command to change the default IS-IS interface metric value, an enabled interface will use the new value instead of the default value of 10. Passive interfaces will continue to use the metric value of 0.
Note The metric value that is directly configured for a specific interface with either the isis metric command or the isis ipv6 metric command will always take precedence over the metric value that you configure with the metric command.
Examples
The following example configures the IS-IS interfaces with a global default value of 111 for an IS-IS IPv4 network:
interface Ethernet3/1
ip address 10.10.10.2 255.255.0.0
ip router isis area1
no ip route-cache
duplex half
!
interface Ethernet3/2
ip address 10.10.10.130 255.255.255.0
ip router isis area1
no ip route-cache
duplex half
!
router isis area1
net 01.0000.0309.1234.00
metric-style wide
metric 111
Entering the show clns interface command returns the following information:
Router# show clns interface
Ethernet3/1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 39 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 922 milliseconds
Next IS-IS LAN Level-2 Hello in 1 seconds
Ethernet3/2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 20 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 1 seconds
The following example configures IPv6 for IS-IS and a global default value of 222 IPv6 metric for the IS-IS interfaces. The metric of 10 that was entered using the isis metric command will take precedence.
interface Ethernet3/1
ip address 10.10.10.2 255.255.0.0
ip router isis area1
no ip route-cache
duplex half
isis metric 10
!
interface Ethernet3/2
ip address 10.10.10.10 255.255.255.0
ip router isis area1
no ip route-cache
duplex half
router isis area1
net 01.0000.0309.1234.00
metric-style wide
metric 111
!
address-family ipv6
metric 222
exit-address-family
Enter the show clns interface command to verify that the global default metric for IS-IS IPv6 interfaces for IPv6 network is 222:
Router# show clns interface
Ethernet3/1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 51 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: mekong.01
Level-1 IPv6 Metric: 222
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: mekong.01
Level-2 IPv6 Metric: 222
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 2 seconds
Ethernet3/2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 17 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-1 IPv6 Metric: 222
Number of active level-1 adjacencies: 1
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-2 IPv6 Metric: 222
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 1 seconds
Next IS-IS LAN Level-2 Hello in 89 milliseconds
Related Commands
|
|
---|---|
isis ipv6 metric |
Configures the value of an IS-IS IPv6 metric. |
isis metric |
Configures the metric for an interface. |
metric-style wide
To configure a router running Intermediate System-to-Intermediate System (IS-IS) so that it generates and accepts only new-style type, length, value objects (TLVs), use the metric-style wide command in router configuration mode. To disable this function, use the no form of this command.
metric-style wide [transition] [level-1 | level-2 | level-1-2]
no metric-style wide [transition] [level-1 | level-2 | level-1-2]
Syntax Description
Command Default
The Multiprotocol Label Switching (MPLS) traffic engineering image generates only old-style TLVs. To do MPLS traffic engineering, new-style TLVs that have wider metric fields must be generated.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
If you enter the metric-style wide command, a router generates and accepts only new-style TLVs. Therefore, the router uses less memory and other resources than it would if it generated both old-style and new-style TLVs.
This style is appropriate for enabling MPLS traffic engineering across an entire network.
Note This discussion of metric styles and transition strategies is oriented toward traffic engineering deployment. Other commands and models could be appropriate if the new-style TLVs are desired for other reasons. For example, a network might require wider metrics, but might not use traffic engineering.
Examples
The following example shows how to configure a router to generate and accept only new-style TLVs on level 1:
Router(config-router)# metric-style wide level-1
Related Commands
net
To configure an Intermediate System-to-Intermediate System (IS-IS) network entity title (NET) for the routing process, use the net command in global configuration mode. To remove a NET, use the no form of this command.
net net1 alt net2
no net net
Syntax Description
Defaults
The defaults are as follows:
•No NET is configured.
•The IS-IS process is disabled.
Command Modes
Global configuration
Command History
Usage Guidelines
An IS (Intermediate system) is identified by an address known as a network access point (NASAP). The NSAP is divided up into three parts as specified by ISO/AI 10589:
Area address—This field is of variable length, composed of high order octets, and it excludes the System ID and N-selector (NSEL) fields. This area address is associated wit a single area within the routing domain.
System ID—This field is 6 octets long and should be set to a unique value with Level 1 and Level 2. The system IS defines an end system (ES) or an IS in an area. You configure the area address and the system ID with the NET command. You can display the system ID with the show isis topology command.
NSEL—This field is called the N-selector, also referred to as the NSAP, and it specifies the upper-layer protocol. The NSEL is the last byte of the NSAP and identifies a network service user. A network service user is a transport entity or the IS network entity itself. When the N-selector is set to zero, the entire NSAP is called a network entity title (NET).
A NET is an NSAP where the last byte is always the n-selector and is always zero. A NET can be from 8 to 20 bytes in length.
Under most circumstances, you should configure one NET only. It is possible to configure two or three NETs, but you should not configure more than one NET except for the following unusual circumstances:
•A network configuration has multiple areas that are merged.
•One area in the IS-IS process is being split into multiple areas.
Configuring multiple NETs in these two circumstances can be temporarily useful because multiple area addresses enable you to renumber an area individually as needed.
When entering the value for the net argument, use these guidelines:
•In a 3-slot chassis, slot 1 is the primary slot and slot 2 is the alternate slot.
•In a 6-slot chassis, slot 5 is the primary slot and slot 6 is the alternate slot.
•In a 9-slot chassis, slot 5 is the primary slot and slot 6 is the alternate slot.
•In a 13-slot chassis, slot 7 is the primary slot and slot 8 is the alternate slot.
If you are using IS-IS to perform IP routing only (no connectionless network service routing is enabled), you must configure a NET to define the router ID and area ID.
Examples
The following example shows how to configure a router with a NET which consists of the system ID 0000.0c11.1110 and area address 47.0004.004d.0001:
router isis firstcompany
net 47.0004.004d.0001.0001.0c11.1111.00
The following example shows three IS-IS routing processes with three areas that are configured. Each area has a unique identifier, but the system ID is the same for all areas.
clns routing
.
.
.
interface Tunnel529
ip address 10.0.0.5 255.255.255.0
ip router isis BB
clns router isis BB
interface Ethernet1
ip address 10.1.1.5 255.255.255.0
ip router isis A3253-01
clns router isis A3253-01
!
interface Ethernet2
ip address 10.2.2.5 255.255.255.0
ip router isis A3253-02
clns router isis A3253-02
.
.
.
router isis BB ! Defaults to "is-type level-1-2"
net 49.2222.0000.0000.0005.00
!
router isis A3253-01
net 49.0553.0001.0000.0000.0005.00
is-type level-1
!
router isis A3253-02
net 49.0553.0002.0000.0000.0005.00
is-type level-1
Related Commands
partition avoidance
To cause an Intermediate System-to-Intermediate System (IS-IS) Level 1-2 border router to stop advertising the Level 1 area prefix into the Level 2 backbone when full connectivity is lost between the border router, all adjacent Level 1 routers, and end hosts, use the partition avoidance command in router configuration mode. To disable this output format, use the no form of the command.
partition avoidance area-tag
no partition avoidance area-tag
Syntax Description
Defaults
This command is disabled by default.
Command Modes
Router configuration
Command History
Usage Guidelines
When the partition avoidance command is enabled, a multiarea router withdraws a Level 1 area prefix from the Level 2 backbone when it no longer has any active adjacencies to that Level 1 area. This withdrawal prevents the Level 1 area from appearing to be partitioned within the Level 2 backbone.
In International Organization for Standardization (ISO) CLNS networks using a redundant topology, it is possible for an area to become "partitioned" when full connectivity is lost between a Level 1-2 border router, all adjacent Level 1 routers, and end hosts. In such a case, multiple Level 1-2 border routers advertise the Level 1 area prefix into the backbone area, even though any one router can reach only a subset of the end hosts in the Level 1 area.
When enabled, the partition avoidance command prevents this partitioning by causing the border router to stop advertising the Level 1 area prefix into the Level 2 backbone. This command displays the output from different areas as a string or additional white space.
Other cases of connectivity loss within the Level 1 area itself are not detected or corrected by the border router, and this command will have no effect.
Examples
The following example causes the routing process named Finance to stop advertising the prefix for the area named area1 when the router no longer has any active adjacencies to area1:
router isis Finance
partition avoidance area1
Related Commands
|
|
---|---|
is-type |
Configures the routing level for an instance of the IS-IS routing process. |
router isis |
Enables the IS-IS routing protocol and specifies an IS-IS process. |
prc-interval
To customize Intermediate System-to-Intermediate System (IS-IS) throttling of partial route calculations (PRC), use the prc-interval command in router configuration mode. To restore default values, use the no form of this command.
prc-interval prc-max-wait [prc-initial-wait prc-second-wait]
no prc-interval
Syntax Description
Defaults
prc-max-wait: 5 seconds
prc-initial-wait: 2000 milliseconds
prc-second-wait: 5000 milliseconds
Command Modes
Router configuration
Command History
Usage Guidelines
PRC is the software's process of calculating routes without performing an shortest path first (SPF) calculation. This is possible when the topology of the routing system itself has not changed, but a change is detected in the information announced by a particular IS or when it is necessary to attempt to reinstall such routes in the Routing Information Base (RIB).
The following description will help you determine whether to change the default values of this command:
•The prc-initial-wait argument indicates the initial wait time (in milliseconds) before generating the first link-state packet (LSP).
•The prc-second-wait argument indicates the amount of time to wait (in milliseconds) between the first and second LSP generation.
•Each subsequent wait interval is twice as long as the previous one until the wait interval reaches the prc-max-wait interval specified, so this value causes the throttling or slowing down of the PRC calculation after the initial and second intervals. Once this interval is reached, the wait interval continues at this interval until the network calms down.
•After the network calms down and there are no triggers for 2 times the prc-max-wait interval, fast behavior is restored (the initial wait time).
Examples
The following example configures intervals for SPF calculations, PRC, and LSP generation:
router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100
protocol shutdown
To disable the Intermediate System-to-Intermediate System (IS-IS) protocol so that it cannot form any adjacency on any interface and will clear the IS-IS link-state packet (LSP) database, use the protocol shutdown command in router configuration mode. To reenable the IS-IS protocol, use the no form of this command.
protocol shutdown
no protocol shutdown
Syntax Description
This command has no arguments or keywords.
Defaults
No default behavior or values
Command Modes
Router configuration
Command History
Usage Guidelines
The protocol shutdown command allows you to disable the IS-IS protocol for a specific routing instance without removing any existing IS-IS configurations parameters. When you enter the protocol shutdown command, the IS-IS protocol will continue to run on the router, and you can use the current IS-IS configuration, but IS-IS will not form any adjacencies on any interface, and it will also clear the IS-IS LSP database.
If you want to disable the IS-IS protocol for a specific interface, use the isis protocol shutdown command.
Examples
The following example disables the IS-IS protocol for a specific routing instance:
Router(config)# router isis area1
Router(config-router)# protocol shutdown
Related Commands
redistribute isis
To redistribute Intermediate System-to-Intermediate System (IS-IS) routes specifically from Level 1 into Level 2 or from Level 2 into Level 1, use the redistribute isis command in router configuration mode. To disable the redistribution, use the no form of this command.
redistribute isis ip {level-1 | level-2} into {level-2 | level-1} [[distribute-list list-number] | [route-map map-tag]]
no redistribute isis ip {level-1 | level-2} into {level-2 | level-1}{[distribute-list list-number] | [route-map map-tag]}
Syntax Description
Defaults
There are no default values for this command.
Command Modes
Router configuration
Command History
Usage Guidelines
Specify either level-l into level-2 or level-2 into level-1. You may optionally specify either a distribute list or a route map, but not both. You must also specify the metric-style wide command in order for the redistribute isis command to work.
In IS-IS, all areas are stub areas, which means that no routing information is leaked from the backbone (Level 2) into areas (Level 1). Level 1-only routers use default routing to the closest Level 1-Level 2 router in their area. This command enables you to redistribute Level 2 IP routes into Level 1 areas. This redistribution enables Level 1-only routers to pick the best path for an IP prefix to get out of the area. This is an IP-only feature, CLNS routing is still stub routing.
For more control and scalability, a distribute list or a route map can control which Level 2 IP routes can be redistributed into Level 1. This command allows large IS-IS-IP networks to use areas for better scalability.
Examples
In the following example, access list 100 controls the redistribution of IS-IS from Level 1 into Level 2:
router isis
net 49.0000.0000.0001.00
metric-style wide
redistribute isis ip level-1 into level-2 distribute-list 100
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
In the following example, the route map named "match-tag" controls the redistribution of IS-IS from Level 1 into Level 2 so that only routes tagged with 110 are redistributed:
router isis
net 49.0000.0000.0001.00
metric-style wide
redistribute isis ip level-1 into level-2 route-map match-tag
route-map match-tag permit 10
match tag 110
Related Commands
|
|
---|---|
metric-style wide |
Configures a router running IS-IS so that it generates and accepts only new-style TLVs. |
router isis
To enable the Intermediate System-to-Intermediate System (IS-IS) routing protocol and to specify an IS-IS process, use the router isis command in global configuration mode. To disable IS-IS routing, use the no form of this command.
router isis [area-tag]
no router isis [area-tag]
Syntax Description
Command Default
This command is disabled by default.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
This command is used to enable routing for an area. An appropriate network entity title (NET) must be configured to specify the area address of the area and system ID of the router. Routing must be enabled on one or more interfaces before adjacencies may be established and dynamic routing is possible.
If you have IS-IS running and at least one International Standards Organization Interior Gateway Routing Protocol (ISO-IGRP) process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-IGRP at the same time. However, each area in an IS-IS multiarea configuration should have a nonnull area tag to facilitate identification of the area.
You can configure only one IS-IS routing process to perform Level 2 (interarea) routing. You can configure this process to perform Level 1 (intra-area) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1.
An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media such as WAN media where subinterfaces are supported, different subinterfaces could be configured for different areas.
If Level 2 routing is not desired for a given area, use the is-type command to remove Level 2. Level 2 routing can then be enabled on some other router instance.
Explicit redistribution between IS-IS instances is prohibited (prevented by the parser). In other words, you cannot issue a redistribute isis area-tag command in the context of another IS-IS router instance (router isis area-tag). Redistribution from any other routing protocol into a particular area is possible, and is configured per router instance, as in Cisco IOS Release 12.0, using the redistribute and route map commands. By default, redistribution is into Level 2.
If multiple Level 1 areas are defined, the Target Address Resolution Protocol (TARP) behaves in the following way:
•The locally assigned target identifier gets the network service access point (NSAP) of the Level 2 area, if present.
•If only Level 1 areas are configured, the router uses the NSAP of the first active Level 1 area as shown in the configuration at the time of TARP configuration ("tarp run"). (Level 1 areas are sorted alphanumerically by tag name, with capital letters coming before lowercase letters. For example, AREA-1 precedes AREA-2, which precedes area-1.) Note that the target identifier NSAP could change following a reload if a new Level 1 area is added to the configuration after TARP is running.
•The router continues to process all Type 1 and 2 protocol data units (PDUs) that are for this router. Type 1 PDUs are processed locally if the specified target identifier is in the local target identifier cache. If not, they are "propagated" (routed) to all interfaces in the same Level 1 area. (The same area is defined as the area configured on the input interface.)
•Type 2 PDUs are processed locally if the specified target identifier is in the local target identifier cache. If not, they are propagated via all interfaces (all Level 1 or Level 2 areas) with TARP enabled. If the source of the PDU is from a different area, the information is also added to the local target identifier cache. Type 2 PDUs are propagated via all static adjacencies.
•Type 4 PDUs (for changes originated locally) are propagated to all Level 1 and Level 2 areas (because internally they are treated as "Level 1-2").
•Type 3 and 5 PDUs continue to be routed.
•Type 1 PDUs are propagated only via Level 1 static adjacencies if the static NSAP is in one of the Level 1 areas in this router.
After you enter the router isis command, you can enter the maximum number of paths. There can be from 1 to 32 paths.
Examples
The following example shows how to configure IS-IS for IP routing, with system ID 0000.0000.0002 and area ID 01.0001, and enable IS-IS to form adjacencies on Ethernet interface 0 and serial interface 0. The IP prefix assigned to Ethernet interface 0 will be advertised to other IS-IS routers.
router isis tag1
net 01.0001.0000.0000.0002
is-type level-1
!
interface ethernet 0
ip address 10.1.1.1 255.255.255.0
ip router isis
!
interface serial 0
ip unnumbered ethernet0
ip router isis
The following example shows how to start IS-IS routing with the optional area-tag argument, where "example" is the value for the area-tag argument:
router isis example
The following example shows how to specify IS-IS as an IP routing protocol for a process named Finance, and specify that the Finance process will be routed on Ethernet interface 0 and serial interface 0:
router isis Finance
net 49.0001.aaaa.aaaa.aaaa.00
interface Ethernet 0
ip router isis Finance
interface serial 0
ip router isis Finance
The following example shows usage of the maximum-paths option:
router isis
maximum-paths?
20
Related Commands
set-attached-bit
To specify constraints for when a Level 1 - Level 2 (L1L2) router should set its attached-bit, use the set-attached-bit command in router configuration mode. To disable this function, use the no form of this command.
set-attached-bit route-map map-tag
no set-attached-bit route-map map-tag
Syntax Description
route-map map-tag |
Identifier of a configured route map. If the specified route map is matched, the router continues to set its attached-bit. |
Defaults
This command is disabled by default.
Command Modes
Router configuration
Command History
Usage Guidelines
In the current IS-IS implementation, as specified in ISO 10589, L1L2 routers set their Level 1 (L1) link-state packet (LSP) attached-bit when they see other areas in their own domain, or see other domains. However, in some network topologies, adjacent L1L2 routers in different areas may lose connectivity to the Level 2 (L2) backbone. Level 1 (L1) routers may then send traffic destined outside of the area or domain to L1L2 routers that may not have such connectivity.
To allow more control over the attached-bit setting for L1L2 routers, enter the set-attached-bit command in router configuration mode. The route map can specify one or more CLNS routes. If at least one of the match address route-map clauses matches a route in the L2 CLNS routing table, and if all other requirements for setting the attached-bit are met, the L1L2 router will continue to set the attached-bit in its L1 LSP. If the requirements are not met or no match address route-map clauses match a route in the L2 CLNS routing table, the attached-bit will not be set.
Note Wildcarded matches are not supported. For each route-map statement, an exact route lookup of the specified route will be performed. The first matched route will have other match statements applied.
Examples
In the following example, the attached-bit will stay set when the router matches 49.00aa in the L2 CLNS routing table.
router isis
clns filter-set L2_backbone_connectivity permit 49.00aa
route-map check-for-L2_backbone_connectivity
match clns address L2_backbone_connectivity
router isis
set-attached-bit route-map check-for-L2_backbone_connectivity
end
show clns route 49.00aa
Known via "isis", distance 110, metric 30, Dynamic Entry
Routing Descriptor Blocks:
via tr2, Serial0
isis, route metric is 30, route version is 58
Related Commands
set-overload-bit
To configure the router to signal other routers not to use it as an intermediate hop in their shortest path first (SPF) calculations, use the set-overload-bit command in router configuration mode. To remove the designation, use the no form of this command.
set-overload-bit [on-startup {seconds | wait-for-bgp}] [suppress [[interlevel] [external]]]
no set-overload-bit
Syntax Description
Defaults
The overload bit is not set.
Command Modes
Router configuration
Command History
Usage Guidelines
This command forces the router to set the overload bit (also known as the hippity bit) in its nonpseudonode link-state packets (LSPs). Normally, the setting of the overload bit is allowed only when a router runs into problems. For example, when a router is experiencing a memory shortage, it might be that the link-state database is not complete, resulting in an incomplete or inaccurate routing table. By setting the overload bit in its LSPs, other routers can ignore the unreliable router in their SPF calculations until the router has recovered from its problems.
The result will be that no paths through this router are seen by other routers in the IS-IS area. However, IP and Connectionless Network Service (CLNS) prefixes directly connected to this router will still be reachable.
This command can be useful when you want to connect a router to an IS-IS network but do not want real traffic flowing through it under any circumstances. Examples situations are as follows:
•A test router in the lab, connected to a production network.
•A router configured as an LSP flooding server, for example, on a nonbroadcast multiaccess (NBMA) network, in combination with the mesh group feature.
•A router that is aggregating virtual circuits (VCs) used only for network management. In this case, the network management stations must be on a network directly connected to the router with the set-overload-bit command configured.
Unless you specify the on-startup keyword, this command sets the overload bit immediately.
In addition to setting the overload bit, you might want to suppress certain types of IP prefix advertisements from LSPs. For example, allowing IP prefix propagation between Level 1 and Level 2 effectively makes a node a transit node for IP traffic, which might be undesirable. The suppress keyword used with the interlevel or external keyword (or both) accomplishes that suppression while the overload bit is set.
Examples
The following example sets the overload bit upon startup and until BGP has converged, and suppresses redistribution between IS-IS levels and suppresses redistribution from external routing protocols while the overload bit is set:
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
ip router isis
router isis
net 49.0001.0000.0000.0001.00
set-overload-bit on-startup wait-for-bgp suppress interlevel external
router bgp 100
show clns interface
To list the CLNS-specific information about each interface, use the show clns interface command in privileged EXEC mode.
show clns interface [type number]
Syntax Description
type |
(Optional) Interface type. |
number |
(Optional) Interface number. |
Command Modes
Privileged EXEC
Command History
Examples
The following is sample output from the show clns interface command that includes information for Token Ring and serial interfaces:
Router# show clns interface
TokenRing 0 is administratively down, line protocol is down
CLNS protocol processing disabled
TokenRing 1 is up, line protocol is up
Checksums enabled, MTU 4461, Encapsulation SNAP
ERPDUs enabled, min. interval 10 msec.
RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
Congestion Experienced bit set at 4 packets
CLNS fast switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 18 seconds
Routing Protocol: ISO IGRP
Routing Domain/Area: <39.0003> <0020>
Serial 2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
Congestion Experienced bit set at 4 packets
CLNS fast switching enabled
DEC compatibility mode OFF for this interface
CLNS cluster alias enabled on this interface
Next ESH/ISH in 48 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Level-1 Metric: 10, Priority: 64, Circuit ID: 0000.0C00.2D55.0A
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: 0000.0000.0000.00
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 hello in 3 seconds
Next IS-IS LAN Level-2 hello in 3 seconds
Cisco IOS Release 12.2(18)SXE, 12.0(31)S, and 12.4(4)T
The following is sample output from the show clns interface command that verifies that the BFD feature has been enabled on Ethernet interface 3/0. The relevant command output is shown in bold in the output.
Router# show clns interface ethernet 3/0
Ethernet3/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 42 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: RouterA.02
DR ID: 0000.0000.0000.00
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: RouterA.02
DR ID: 0000.0000.0000.00
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 3 seconds
Next IS-IS LAN Level-2 Hello in 5 seconds
BFD enabled
Table 8 describes the significant fields shown in the display.
show clns is-neighbors
To display Intermediate System-to-Intermediate System (IS-IS) related information for IS-IS router adjacencies, use the show clns is-neighbors command in EXEC mode. Neighbor entries are sorted according to the area in which they are located.
show clns area-tag is-neighbors [type number] [detail]
Syntax Description
Command Modes
EXEC
Command History
|
|
---|---|
10.0 |
This command was introduced. |
12.2(33)SRA |
This command was integrated into Cisco IOS Release 12.2(33)SRA. |
Examples
The following is sample output from the show clns is-neighbors command:
Router# show clns is-neighbors
System Id Interface State Type Priority Circuit Id Format
0000.0C00.0C35 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
0800.2B16.24EA Ethernet0 Up L1L2 64/64 0800.2B16.24EA.01 Phase V
0000.0C00.3E51 Serial1 Up L2 0 04 Phase V
0000.0C00.62E6 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
Table 9 describes significant fields shown in the display.
The following is sample output from the show clns is-neighbors detail command:
Router# show clns is-neighbors detail
System Id Interface State Type Priority Circuit Id Format
0000.0C00.0C35 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
Area Address(es): 47.0004.004D.0001 39.0001
Uptime: 0:03:35
0800.2B16.24EA Ethernet0 Up L1L2 64/64 0800.2B16.24EA.01 Phase V
Area Address(es): 47.0004.004D.0001
Uptime: 0:03:35
0000.0C00.3E51 Serial1 Up L2 0 04 Phase V
Area Address(es): 39.0004
Uptime: 0:03:35
000.0C00.62E6 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
Area Address(es): 47.0004.004D.0001
Uptime: 0:03:35
Notice that the information displayed in show clns is-neighbors detail output includes everything shown in show clns is-neighbors output, but it also includes the area addresses associated with the IS neighbors (intermediate-system adjacencies) and how long (uptime) the adjacency has existed.
Related Commands
show clns traffic
To list the CLNS packets that this router has seen, use the show clns traffic command in user EXEC or privileged EXEC mode.
show clns area-tag traffic
Syntax Description
Command Modes
User EXEC
Privileged EXEC
Command History
|
|
---|---|
10.0 |
This command was introduced. |
12.2(33)SRA |
This command was integrated into Cisco IOS Release 12.2(33)SRA. |
Examples
The following is sample output from the show clns traffic command:
Router# show clns traffic
CLNS & ESIS Output: 139885, Input: 90406
CLNS Local: 0, Forward: 0
CLNS Discards:
Hdr Syntax: 150, Checksum: 0, Lifetime: 0, Output cngstn: 0
No Route: 0, Dst Unreachable 0, Encaps. Failed: 0
NLP Unknown: 0, Not an IS: 0
CLNS Options: Packets 19, total 19, bad 0, GQOS 0, cngstn exprncd 0
CLNS Segments: Segmented: 0, Failed: 0
CLNS Broadcasts: sent: 0, rcvd: 0
Echos: Rcvd 0 requests, 69679 replies
Sent 69701 requests, 0 replies
ESIS(sent/rcvd): ESHs: 0/34, ISHs: 483/1839, RDs: 0/0, QCF: 0/0
ISO IGRP: Querys (sent/rcvd): 0/0 Updates (sent/rcvd): 1279/1402
ISO IGRP: Router Hellos: (sent/rcvd): 1673/1848
ISO IGRP Syntax Errors: 0
IS-IS: Level-1 Hellos (sent/rcvd): 0/0
IS-IS: Level-2 Hellos (sent/rcvd): 0/0
IS-IS: PTP Hellos (sent/rcvd): 0/0
IS-IS: Level-1 LSPs (sent/rcvd): 0/0
IS-IS: Level-2 LSPs (sent/rcvd): 0/0
IS-IS: Level-1 CSNPs (sent/rcvd): 0/0
IS-IS: Level-2 CSNPs (sent/rcvd): 0/0
IS-IS: Level-1 PSNPs (sent/rcvd): 0/0
IS-IS: Level-2 PSNPs (sent/rcvd): 0/0
IS-IS: Level-1 DR Elections: 0
IS-IS: Level-2 DR Elections: 0
IS-IS: Level-1 SPF Calculations: 0
IS-IS: Level-2 SPF Calculations: 0
Table 10 describes significant fields shown in the display.
show isis database
To display the Intermediate System-to-Intermediate System (IS-IS) link-state database, use the show isis database command in user EXEC or privileged EXEC mode.
show isis [process-tag] database [level-1 | l1] [level-2 | l2][detail] [lspid]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
The order of the optional argument and keywords is not important when this command is entered. For example, the following are both valid command specifications and provide the same output: show isis database detail l2 and show isis database l2 detail.
Examples
The following is sample output from the show isis database command:
Router# show isis database
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.00-00 0x0000000C 0x5696 792 0/0/0
0000.0C00.40AF.00-00* 0x00000009 0x8452 1077 1/0/0
0000.0C00.62E6.00-00 0x0000000A 0x38E7 383 0/0/0
0000.0C00.62E6.03-00 0x00000006 0x82BC 384 0/0/0
0800.2B16.24EA.00-00 0x00001D9F 0x8864 1188 1/0/0
0800.2B16.24EA.01-00 0x00001E36 0x0935 1198 1/0/0
IS-IS Level-2 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.03-00 0x00000005 0x04C8 792 0/0/0
0000.0C00.3E51.00-00 0x00000007 0xAF96 758 0/0/0
0000.0C00.40AF.00-00* 0x0000000A 0x3AA9 1077 0/0/0
The following is sample output from the show isis database command using the process-tag argument to display information about a VPN routing and forwarding instance (VRF)-aware IS-IS instance tagFirst:
Router# show isis tagFirst database level-2
Tag tagFirst:
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
igp-01.00-00 0x0000000A 0x5E73 914 0/0/0
igp-01.03-00 0x00000001 0x8E41 894 0/0/0
igp-01.04-00 0x00000001 0x8747 894 0/0/0
igp-03.00-00 * 0x00000005 0x55AD 727 0/0/0
igp-03.02-00 * 0x00000001 0x3B97 727 0/0/0
igp-02.00-0 0x00000004 0xC1FB 993 0/0/0
igp-02.01-00 0x00000001 0x448D 814 0/0/0
igp-04.00-00 0x00000004 0x76D0 892 0/0/0
Table 11 describes the significant fields shown in the display.
.
The following is sample output from the show isis database detail command:
Router# show isis database detail
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.00-00 0x0000000C 0x5696 325 0/0/0
Area Address: 47.0004.004D.0001
Area Address: 39.0001
Metric: 10 IS 0000.0C00.62E6.03
Metric: 0 ES 0000.0C00.0C35
0000.0C00.40AF.00-00* 0x00000009 0x8452 608 1/0/0
Area Address: 47.0004.004D.0001
Topology: IPv4 (0x0) IPv6 (0x2)
NLPID: 0xCC 0x8E
IP Address: 172.16.21.49
Metric: 10 IS 0800.2B16.24EA.01
Metric: 10 IS 0000.0C00.62E6.03
Metric: 0 ES 0000.0C00.40AF
IPv6 Address: 2001:0DB8::/32
Metric: 10 IPv6 (MT-IPv6) 2001:0DB8::/64
Metric: 5 IS-Extended cisco.03
Metric: 10 IS-Extended cisco1.03
Metric: 10 IS (MT-IPv6) cisco.03
As the output shows, in addition to the information displayed with the show isis database command, the show isis database detail command displays the contents of each LSP.
Table 12 describes the significant fields shown in the display.
.
The following is additional sample output from the show isis database detail command. This LSP is a Level 2 LSP. The area address 39.0001 is the address of the area in which the router resides.
Router# show isis database 12 detail
IS-IS Level-2 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.1111.00-00* 0x00000006 0x4DB3 1194 0/0/0
Area Address: 39.0001
NLPID: 0x81 0xCC
IP Address: 172.16.64.17
Metric: 10 IS 0000.0C00.1111.09
Metric: 10 IS 0000.0C00.1111.08
Metric: 10 IP 172.16.65.0 255.255.255.0
show isis database verbose
To display additional information about the Intermediate System-to-Intermediate System (IS-IS) database, use the show isis database verbose command in user EXEC or privileged EXEC mode.
show isis database verbose
Syntax Description
This command has no arguments or keywords.
Command Modes
User EXEC
Privileged EXEC
Command History
Examples
The following is sample output from the show isis database verbose command:
Router# show isis database verbose
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
dtp-5.00-00 * 0x000000E6 0xC9BB 1042 0/0/0
Area Address:49.0001
NLPID: 0xCC
Hostname:dtp-5
Router ID: 10.5.5.5
IP Address: 172.16.39.5
Metric:10 IP 172.16.39.0/24
dtp-5.00-01 * 0x000000E7 0xAB36 1065 0/0/0
Metric:10 IS-Extended dtp-5.01
Affinity:0x00000000
Interface IP Address:172.21.39.5
Physical BW:10000000 bits/sec
Reservable BW:1166000 bits/sec
BW Unreserved[0]: 1166000 bits/sec, BW Unreserved[1]: 1166000 bits/sec
BW Unreserved[2]: 1166000 bits/sec, BW Unreserved[3]: 1166000 bits/sec
BW Unreserved[4]: 1166000 bits/sec, BW Unreserved[5]: 1166000 bits/sec
BW Unreserved[6]: 1166000 bits/sec, BW Unreserved[7]: 1153000 bits/sec
Metric:0 ES dtp-5
Table 13 describes the significant fields shown in the display.
The following example includes a route tag:
Router# show isis database verbose
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
dasher.00-00 0x000000F8 0xE57B 518 1/0/0
Area Address: 49.0002
NSPID: 0xCC
Hostname: dasher
IP Address: 10.3.0.1
Metric: 10 IP 172.16.170.0/24
Metric: 10 IP 10.0.3.0/24
Metric: 10 IP 10.0.3.3/30
Metric: 10 IS-Extended dasher.02172.19.170.0/24
Metric: 20 IP-Interarea 10.1.1.1/32
Route Admin Tag: 60
Metric: 20 IP-Interarea 192.168.0.6/32
Route Admin Tag: 50
Related Commands
show isis fast-reroute
To display information about Intermediate System-to-Intermediate System (IS-IS) Fast Reroute (FRR) configurations, use the show isis fast-reroute command in user EXEC or privileged EXEC mode.
show isis fast-reroute {interfaces [type number] | summary}
Syntax Description
Command Default
This command has no default settings.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
15.1(2)S |
This command was introduced. |
Usage Guidelines
The show isis fast-reroute interfaces command displays whether or not an interface is supported by a platform.
Examples
The following is sample output from the show isis fast-reroute interfaces command:
Router# show isis fast-reroute interfaces
Tag Null - Fast-Reroute Platform Support Information:
Serial6/3: Protectable: Yes. Usable for repair: Yes
Serial6/2: Protectable: Yes. Usable for repair: Yes
Loopback16: Protectable: No. Usable for repair: No
Table 14 describes the significant fields shown in the display.
The following is sample output from the show isis fast-reroute summary command:
Router# show isis fast-reroute summary
Prefix Counts: Total Protected Coverage
High priority: 17 17 100%
Normal priority: 0 0 0%
Table 15 describes the significant fields shown in the display.
Related Commands
show isis hostname
To display the router-name-to-system-ID mapping table entries for an Intermediate System-to-Intermediate System (IS-IS) router, use the show isis hostname command in privileged EXEC mode.
show isis hostname
Syntax Description
This command has no arguments or keywords.
Command Modes
Privileged EXEC
Command History
|
|
---|---|
12.0 |
This command was introduced. |
12.0S |
This command was integrated into Cisco IOS Release 12.0(S). |
Usage Guidelines
In the IS-IS routing domain, the system ID is used to represent each router. The system ID is part of the network entity title (NET) that is configured for each IS-IS router. For example, a router with a configured NET of 49.0001.0023.0003.000a.00 has a system ID of 0023.0003.000a. Router-name-to-system-ID mapping is difficult for network administrators to remember during maintenance and troubleshooting on the routers. Entering the show isis hostname command displays the entries in the router-name-to-system-ID mapping table.
If the dynamic hostname feature has not been disabled by entering the no hostname dynamic command, the mapping will consist of a dynamic host mapping table. However, if the clns host command has been entered to create a mapping between the router name and the system ID, this locally defined mapping will take precedence over the dynamically learned one from the dynamic hostname feature.
Examples
The following example changes the hostname to RouterA and assigns the NET 49.0001.0000.0000.000b.00 to RouterA.
Router> enable
Router# configure terminal
Router(config)# hostname RouterA
RouterA(config)# router isis CompanyA
RouterA(config-router)# net 49.0001.0000.0000.000b.00
RouterA(config-router)# hostname dynamic
RouterA(config-router)# end
Entering the show isis hostname command displays the dynamic host mapping table. The dynamic host mapping table displays the router-name-to-system-ID mapping table entries for Router-b, Router-c and for the local router named Router-a. The command output shows that the local router is running the IS-IS process named CompanyA. The table also shows that the neighbor router Router-b is a Level-1 router, and its hostname is advertised by the Level-1 (L1) link-state protocol (LSP). Router-b is a Level-2 router and its hostname is advertised by the L2 LSP. The * symbol that appears under Level for the local router Router-a signifies that this is the router-name-to-system-ID mapping information for the local router.
Router-a# show isis hostname
Level System ID Dynamic Hostname (CompanyA)
1 3333.3333.333b Router-b
2 3131.3131.313b Router-c
* 3232.3232.323b Router-a
Related Commands
show isis lsp-log
To display the Level 1 and Level 2 Intermediate System-to-Intermediate System (IS-IS) link-state packet (LSP) log of the interfaces that triggered the new LSP, use the show isis lsp-log command in EXEC mode.
show isis lsp-log
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Examples
The following is sample output from the show isis lsp-log command:
Router# show isis lsp-log
Level 1 LSP log
When Count Interface Triggers
07:05:18 3 CONFIG NEWADJ DIS
07:05:13 2 Ethernet0 NEWADJ DIS
07:04:43 1 ATTACHFLAG
07:01:38 2 Ethernet0 IPUP
07:01:33 2 Loopback0 CONFIG
07:01:24 1 Ethernet0 DELADJ
07:01:17 2 Ethernet0 DIS ES
07:01:02 1 Ethernet0 NEWADJ
07:00:57 2 Ethernet0 NEWADJ DIS
Level 2 LSP log
When Count Interface Triggers
07:05:24 2 CONFIG NEWADJ
07:05:23 1 Ethernet0 NEWADJ
07:05:18 1 Ethernet0 DIS
07:05:00 1 Serial0 NEWADJ
07:01:44 2 Ethernet0 IPUP
07:01:39 3 Loopback0 CONFIG DELADJ
07:01:30 1 Ethernet0 DELADJ
07:01:25 1 Serial0 NEWADJ
07:00:56 1 IPIA
07:00:47 2 AREASET IPIA
Table 16 describes the fields shown in the display.
show isis neighbors
To display information about Intermediate System-to-Intermediate System (IS-IS) neighbors, use the show isis neighbors command in privileged EXEC mode.
show isis neighbors [detail]
Syntax Description
detail |
(Optional) Displays more detailed information for IS-IS neighbors. |
Command Default
Brief information for IS-IS neighbors is displayed.
Command Modes
Privileged EXEC
Command History
Usage Guidelines
The show isis neighbors command is used to display brief information about connected IS-IS routers. Enter the detail keyword to display more detailed information.
Examples
Release 12.0(29)S
The show isis neighbors command is entered to display information about the IS-IS neighbor Router1.
Router5# show isis neighbors
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 28 R5.02
Thee show isis neighbors detail command is entered to display more detailed information about the IS-IS neighbor Router1.
Router5# show isis neighbors detail
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 22 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V
Release 12.2(33)SRB
The show isis neighbors detail command is entered to verify the status of the IS-IS neighbor Router1 for a network that has MTR configured. For each of the topologies - unicast, DATA and VOICE, the interface information is displayed.
Router5# show isis neighbors detail
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0005 L2 Et0/0 192.168.128.2 UP 28 R5.01
Area Address(es): 33
SNPA: aabb.cc00.1f00
State Changed: 00:07:05
LAN Priority: 64
Format: Phase V
Remote TID: 100, 200
Local TID: 100, 200
Table 17 describes the significant fields shown in the display.
show isis nsf
To display current state information regarding Intermediate System-to-Intermediate System (IS-IS) Cisco nonstop forwarding (NSF), use the show isis nsf command in user EXEC mode.
show isis nsf
Syntax Description
This command has no arguments or keywords.
Command Modes
User EXEC
Command History
Usage Guidelines
The show isis nsf command can be used with both Cisco proprietary IS-IS NSF and Internet Engineering Task Force (IETF) IS-IS NSF. The information displayed when this command is entered depends on which protocol has been configured. To configure nsf for a specific routing protocol, use the router bgp, router ospf, or router isis commands in global configuration mode.
Examples
The following example shows state information for an active RP that is configured to use Cisco proprietary IS-IS NSF:
Router# show isis nsf
NSF enabled, mode 'cisco'
RP is ACTIVE, standby ready, bulk sync complete
NSF interval timer expired (NSF restart enabled)
Checkpointing enabled, no errors
Local state:ACTIVE, Peer state:STANDBY HOT, Mode:SSO
The following example shows state information for a standby RP that is configured to use Cisco proprietary IS-IS NSF:
Router# show isis nsf
NSF enabled, mode 'cisco'
RP is STANDBY, chkpt msg receive count:ADJ 2, LSP 314
NSF interval timer notification received (NSF restart enabled)
Checkpointing enabled, no errors
Local state:STANDBY HOT, Peer state:ACTIVE, Mode:SSO
The following example shows state information when the networking device is configured to use IETF IS-IS NSF:
Router# show isis nsf
NSF is ENABLED, mode IETF
NSF pdb state:Inactive
NSF L1 active interfaces:0
NSF L1 active LSPs:0
NSF interfaces awaiting L1 CSNP:0
Awaiting L1 LSPs:
NSF L2 active interfaces:0
NSF L2 active LSPs:0
NSF interfaces awaiting L2 CSNP:0
Awaiting L2 LSPs:
Interface:Serial3/0/2
NSF L1 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
Interface:GigabitEthernet2/0/0
NSF L1 Restart state:Running
NSF L1 Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF L2 Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
L2 NSF CSNP requested:FALSE
Related Commands
show isis rib
To display paths for a specific route or for all routes under a major network that are stored in the IP local Routing Information Base (RIB), use the show isis rib command in privileged EXEC mode.
show isis rib [ip-address | ip-address-mask]
Syntax Description
ip-address |
(Optional) Displays paths for a specific route. |
ip-address-mask |
(Optional) Displays paths for all routes under a major network. |
Command Default
If no ip-address or ip-address-mask argument is specified, all routes in the Integrated Intermediate System-to-Intermediate System (IS-IS) local RIB will be displayed.
Command Modes
Privileged EXEC
Command History
Usage Guidelines
To verify that an IP prefix update that exists in the IP global RIB also has been updated in the IS-IS local RIB, enter the show isis rib command.
Examples
The following is sample output from the show isis rib command to show all routes under the major network with the IP address mask 10.2.2.0 255.255.255.0 that are stored within the IS-IS local RIB:
Router# show isis rib 10.2.2.0 255.255.255.0
IPv4 local RIB for IS-IS process
10.2.2.0/24
[115/L2/20} via 10.2.2.2(Ethernet2), from 10.22.22.22, tag 0, LSP[10/10]
Table 18 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
debug isis rib |
Displays debug information for IP Version 4 routes within the global or IS-IS local RIB. |
ip route priority high |
Assigns a high priority to an IS-IS IP prefix. |
show isis rib redistribution
To display the prefixes in the local redistribution cache, use the show isis rib redistribution command in user EXEC or privileged EXEC mode.
show isis rib redistribution [level-1 | level-2] [network-prefix]
Syntax Description
Command Modes
User EXEC
Privileged EXEC
Command History
Usage Guidelines
You can use the show isis rib redistribution command to verify that desired routes have been redistributed into Intermediate System-to-Intermediate System (IS-IS). The command output will show the network prefixes in the local redistribution cache.
Examples
In the following example, the output from the show isis rib redistribution command verifies that Internet Protocol version 4 (IPv4) routes have been redistributed into IS-IS. The output is self-explanatory.
Router# show isis rib redistribution
IPv4 redistribution RIB for IS-IS process
====== Level 1 ======
10.3.3.0/24
[Connected/0] external
10.0.18.48/28
[Connected/0] external
====== Level 2 ======
The following lines indicate that the prefix 10.3.3.0 with a mask 24 was redistributed from the connected routing protocol into IS-IS as a level 1 route, cost 0, with a metric type external:
10.3.3.0/24
[Connected/0] external
The following lines show that the connected routing protocol owns the prefix 10.0.18.48 and that the metric for the route is 28:
10.0.18.48/28
[Connected/0] external
Related Commands
|
|
---|---|
clear isis rib redistribution |
Clears some or all prefixes in the local redistribution cache. |
debug isis rib redistribution |
Debugs the local redistribution cache event. |
show isis spf-log
To display how often and why the router has run a full shortest path first (SPF) calculation, use the show isis spf-log user command in user EXEC or privileged EXEC mode.
show isis [area-tag] [ipv6 | *] spf-log
Syntax Description
Command Modes
User EXEC
Privileged EXEC
Command History
Examples
The following is sample output from the show isis spf-log command with the optional ipv6 keyword:
Router# show isis ipv6 spf-log
IPv6 Level 1 SPF log
When Duration Nodes Count Last trigger LSP Triggers
00:15:46 3124 40 1 milles.00-00 TLVCODE
00:15:24 3216 41 5 milles.00-00 TLVCODE NEWLSP
00:15:19 3096 41 1 deurze.00-00 TLVCODE
00:14:54 3004 41 2 milles.00-00 ATTACHFLAG LSPHEADER
00:14:49 3384 41 1 milles.00-01 TLVCODE
00:14:23 2932 41 3 milles.00-00 TLVCODE
00:05:18 3140 41 1 PERIODIC
00:03:54 3144 41 1 milles.01-00 TLVCODE
00:03:49 2908 41 1 milles.01-00 TLVCODE
00:03:28 3148 41 3 bakel.00-00 TLVCODE TLVCONTENT
00:03:15 3054 41 1 milles.00-00 TLVCODE
00:02:53 2958 41 1 mortel.00-00 TLVCODE
00:02:48 3632 41 2 milles.00-00 NEWADJ TLVCODE
00:02:23 2988 41 1 milles.00-01 TLVCODE
00:02:18 3016 41 1 gemert.00-00 TLVCODE
00:02:14 2932 41 1 bakel.00-00 TLVCONTENT
00:02:09 2988 41 2 bakel.00-00 TLVCONTENT
00:01:54 3228 41 1 milles.00-00 TLVCODE
00:01:38 3120 41 3 rips.03-00 TLVCONTENT
Table 19 describes the significant fields shown in the display.
Table 20 lists possible triggers of a full SPF calculation.
show isis topology
To display a list of all connected routers in all areas, use the show isis topology command in user EXEC or privileged EXEC mode.
show isis [process-tag] [ipv6 | *] topology
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show isis topology EXEC command to verify the presence and connectivity between all routers in all areas.
Examples
The following example shows output from the show isis topology command using the optional ipv6 keyword. The command shown is used in a dual CLNS-IP network:
Router# show isis ipv6 topology
Tag L2BB:
IS-IS IPv6 paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0005 --
0000.0000.0009 10 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0017 20 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0053 30 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0068 20 0000.0000.0009 Tu529 *Tunnel*
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0005 --
0000.0000.0009 10 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0017 20 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0053 30 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0068 20 0000.0000.0009 Tu529 *Tunnel*
Tag A3253-01:
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0003 10 0000.0000.0003 Et1 0000.0c03.6944
0000.0000.0005 --
0000.0000.0053 10 0000.0000.0053 Et1 0060.3e58.ccdb
Tag A3253-02:
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0002 10 0000.0000.0002 Et2 0000.0c03.6bc5
0000.0000.0005 --
0000.0000.0053 10 0000.0000.0053 Et2 0060.3e58.ccde
Table 21 describes the significant fields shown in the display.
snmp-server enable traps isis
To enable Simple Network Management Protocol (SNMP) notifications for Intermediate System-to-Intermediate System (IS-IS) errors and transition state changes, use the snmp-server enable traps isis command in global configuration mode. To disable all or some of the IS-IS SNMP notifications, use the no form of this command.
snmp-server enable traps isis [errors [error-type]] [state-change [state-change-type]]
no snmp-server enable traps isis [errors [error-type]] [state-change [state-change-type]]
Syntax Description
Command Default
This command is disabled by default. If you enter this command with no keywords, the default is to enable all SNMP notifications.
Command Modes
Global configuration
Command History
Usage Guidelines
To globally enable all IS-IS MIB traps, enter the snmp-server enable traps isis command in global configuration mode. If you want to disable one or more traps, you can enter the no snmp-server enable traps isis errors command or the no snmp-server enable traps isis state-change command followed by the keywords that represent the traps that you want to disable. Entering the no snmp-server enable traps isis errors command without any keywords will disable all IS-IS error traps. Entering the no snmp-server enable traps isis state-change command without any keywords will disable all IS-IS state-change traps.
Examples
The following example shows how to enable the router to send IS-IS SNMP notifications only for IS-IS errors involving authentication to the host at the address myhost.cisco.com using the community string defined as public:
Router(config)# snmp-server enable traps isis errors authentication
Router(config)# snmp-server host myhost.cisco.com version 2c public
The following example shows how to enable the router to send IS-IS SNMP notifications for state changes involving adjacencies between Intermediate Systems (ISs) to the host at the address myhost.cisco.com using the community string defined as public:
Router(config)# snmp-server enable traps isis state-change adjacency
Router(config)# snmp-server host myhost.cisco.com version 2c public
Related Commands
|
|
---|---|
snmp-server host |
Specifies the recipient of an SNMP notification operation. |
spf-interval
To customize Intermediate System-to-Intermediate System (IS-IS) throttling of shortest path first (SPF) calculations, use the spf-interval command in router configuration mode. To restore default values, use the no form of this command.
spf-interval [level-1 | level-2] spf-max-wait [spf-initial-wait spf-second-wait]
no spf-interval
Syntax Description
Defaults
spf-max-wait: 10 seconds
spf-initial-wait: 5500 milliseconds
spf-second-wait: 5500 milliseconds
Command Modes
Router configuration
Command History
Usage Guidelines
SPF calculations are performed only when the topology changes. They are not performed when external routes change.
The spf-interval command controls how often Cisco IOS software performs the SPF calculation. The SPF calculation is processor-intensive. Therefore, it may be useful to limit how often this is done, especially when the area is large and the topology changes often. Increasing the SPF interval reduces the processor load of the router, but potentially slows down the rate of convergence.
The following description will help you determine whether to change the default values of this command:
•The spf-initial-wait argument indicates the initial wait time (in milliseconds) after a topology change before the first SPF calculation.
•The spf-second-wait argument indicates the interval (in milliseconds) between the first and second SPF calculation.
•Each subsequent wait interval is twice as long as the previous one until the wait interval reaches the spf-max-wait interval specified; the SPF calculations are throttled or slowed down after the initial and second intervals. Once the spf-max-wait interval is reached, the wait interval continues at this interval until the network calms down.
•After the network calms down and there are no triggers for 2 times the spf-max-wait interval, fast behavior is restored (the initial wait time).
SPF throttling is not a dampening mechanism; that is, SPF throttling does not prevent SPF calculations or mark any route, interface, or router as down. SPF throttling simply increases the intervals between SPF calculations.
Examples
The following example configures intervals for SPF calculations, partial route calculation (PRC), and link-state packet (LSP) generation:
router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100
srlg
To assign an interface to a Shared Risk Link Group (SRLG) and to configure interface-specific SRLG, use the srlg command in interface configuration mode. To disable the configuration, use the no form of this command.
srlg gid srlg-id
no srlg gid srlg-id
Syntax Description
gid |
Specifies the SRLG group ID. |
srlg-id |
SRLG ID. Valid values are from 1 to 8192. |
Command Default
No interfaces are assigned to an SRLG.
Command Modes
Interface configuration (config-if)
Command History
|
|
---|---|
15.1(2)S |
This command was introduced. |
Usage Guidelines
The SRLG configuration assigns an interface to one or more risk groups. When an interface assigned to one group fails, the other interfaces that are part of the group also fail.
Examples
The following example shows how to assign an SRLG group ID to a Gigabit Ethernet interface:
Router(config)# interface gigabitethernet 0/0
Router(config-if)# srlg gid 900
Router(config-if)# end
Related Commands
|
|
---|---|
interface |
Configures an interface and enters interface configuration mode. |
summary-address (IS-IS)
To create aggregate addresses for Intermediate System-to-Intermediate System (IS-IS), use the summary-address command in router configuration mode. To restore the default, use the no form of this command.
summary-address address mask [level-1 | level-1-2 | level-2] [tag tag-number] [metric metric-value]
no summary-address address mask [level-1 | level-1-2 | level-2[[tag tag-number] [metric metric-value]
Syntax Description
Command Default
All routes are advertised individually.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
Multiple groups of addresses can be summarized for a given level. Routes learned from other routing protocols can also be summarized. The metric used to advertise the summary is the smallest metric of all the more specific routes. This command helps reduce the size of the routing table.
This command also reduces the size of the link-state packets (LSPs) and thus the link-state database (LSDB). It also helps network stability because a summary advertisement is depending on many more specific routes. A single route flap does not cause the summary advertisement to flap in most cases.
The drawback of summary addresses is that other routes might have less information to calculate the most optimal routing table for all individual destinations.
Examples
The following example redistributes Routing Information Protocol (RIP) routes into IS-IS. In a RIP network, there are IP routes for 10.1.1, 10.1.2, 10.1.3, 10.1.4, and so on. This example advertises only 10.1.0.0 into the IS-IS Level 1 link-state protocol data unit (PDU). The summary address is tagged with 100 and given a metric value of 110.
router isis
net 01.0000.0000.0001.00
redistribute rip level-1 metric 40
summary-address 10.1.0.0 255.255.0.0 tag 100 metric 110
vrf (router configuration)
To associate an Intermediate System-to-Intermediate System (IS-IS) instance with a VPN routing and forwarding instance (VRF), use the vrf command in router configuration mode. To remove the VRF, use the no form of this command.
vrf vrf-name
no vrf vrf-name
Syntax Description
vrf-name |
Name of the VRF to which you want to associate an IS-IS instance. |
Command Default
An ISIS instance is not associated with a VRF.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
You must already have created the VRF before you can associate it with an IS-IS instance. The following restrictions should be noted:
•IS-IS instances running Connectionless Network Services (CLNS) must have the same system ID.
•An IS-IS instance that is running CLNS or IPv6 cannot be associated with a VRF.
•You can configure only one IS-IS instance to run both CLNS and IP.
•IS-IS instances within the same VRF must have unique system IDs, although IS-IS instances located in separate VRFs can have the same system ID.
•You can associate an IS-IS instance with only one VRF.
•You can configure the passive-interface default command only on one IS-IS instance per VRF.
•Redistribution is allowed only within the same VRF.
•You can enable only one IS-IS instance per interface.
•An interface can belong to an IS-IS instance only if they are associated with the same VRF.
For more information about configuring VRF-aware IS-IS instances, see the IS-IS Support for Multiple Instances (IP only) Each Mapped to a VRF feature.
Examples
The following example shows the creation of an IS-IS instance that gets associated with a VRF called First:
Router(config)# router isis tagFirst
Router(config-router)# vrf First