- clear clns cache
- clear clns es-neighbors
- clear clns is-neighbors
- clear clns neighbors
- clear clns route
- clear clns traffic
- clear tarp counters
- clear tarp ldb-table
- clear tarp tid-table
- clns access-group
- clns adjacency-filter
- clns cache-invalidate-delay
- clns checksum
- clns cluster-alias
- clns configuration-time
- clns congestion-threshold
- clns dec-compatible
- clns enable
- clns erpdu-interval
- clns esct-time
- clns es-neighbor
- clns filter-expr
- clns filter-set
- clns holding-time
- clns host
- clns is-neighbor
- clns mtu
- clns net (global)
- clns packet-lifetime
- clns rdpdu-interval
- clns route (create)
- clns route (enter)
- clns route default discard
- clns route default
- clns route discard
- clns route-cache
- clns router isis
- clns router iso-igrp
- clns routing
- clns security pass-through
- clns send-erpdu
- clns send-rdpdu
- clns split-horizon
- clns template-alias
- clns want-erpdu
- ctunnel destination
- ctunnel mode
- distance (ISO CLNS)
- ignore-lsp-errors
- interface ctunnel
- ip domain-lookup nsap
- isis adjacency-filter
- iso-igrp adjacency-filter
- lsp-mtu (ISO CLNS)
Cisco IOS ISO Connectionless Network Service Commands
The International Organization for Standardization (ISO) Connectionless Network Service (CLNS) protocol is a standard for the network layer of the OSI model.
Use the commands in this book to configure and monitor ISO CLNS networks. For ISO CLNS protocol configuration information and examples, see the Cisco IOS Apollo Domain, Banyan VINES, DECnet, ISO CLNS, and XNS Configuration Guide, Release 12.2.
clear clns cache
To clear and reinitialize the CLNS routing cache, use the clear clns cache command in EXEC mode.
clear clns cache
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Examples
The following example clears the CLNS routing cache:
clear clns cache
Related Commands
|
|
---|---|
show clns cache |
Displays the CLNS routing cache. |
clear clns es-neighbors
To remove end system (ES) neighbor information from the adjacency database, use the clear clns es-neighbors command in EXEC mode.
clear clns [tag] es-neighbors
Syntax Description
Command Modes
EXEC
Command History
Usage Guidelines
When you enter the clear clns es-neighbors command to clear dynamically discovered neighbors that are learned through ES-IS or IS-IS protocols, keep in mind that these adjacencies may have reappeared by the time you enter the show clns neighbors command. These dynamic adjacencies can be quickly reformed if the neighbors exchange hello messages.
Examples
The following example removes the ES neighbor information from the adjacency database:
clear clns es-neighbors
Related Commands
clear clns is-neighbors
To remove intermediate system (IS) neighbor information from the adjacency database, use the clear clns is-neighbors command in EXEC mode.
clear clns [tag] is-neighbors
Syntax Description
Command Modes
EXEC
Command History
Usage Guidelines
When you enter the clear clns is-neighbors command to clear dynamically discovered neighbors that are learned through ES-IS or IS-IS protocols, keep in mind that these adjacencies may have reappeared by the time you enter the show clns neighbors command. These dynamic adjacencies can be quickly reformed if the neighbors exchange hello messages.
Examples
The following example removes the IS neighbor information from the adjacency database:
clear clns is-neighbors
Related Commands
clear clns neighbors
To remove CLNS neighbor information from the adjacency database, use the clear clns neighbors command in EXEC mode.
clear clns [tag] neighbors
Syntax Description
Command Modes
EXEC
Command History
Usage Guidelines
When you enter the clear clns neighbors command to clear dynamically discovered neighbors that are learned through ES-IS or IS-IS protocols, keep in mind that these adjacencies may have reappeared by the time you enter the show clns neighbors command. These dynamic adjacencies can be quickly reformed if the neighbors exchange hello messages.
Examples
The following example removes the CLNS neighbor information from the adjacency database:
clear clns neighbors
Related Commands
clear clns route
To remove all of the dynamically derived CLNS routing information, use the clear clns route command in EXEC mode.
clear clns route
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Examples
The following example removes all of the dynamically derived CLNS routing information:
clear clns route
Related Commands
|
|
---|---|
show clns route |
Displays all of the destinations to which this router knows how to route packets. |
clear clns traffic
To clear all ISO CLNS statistics that are displayed when you use the show clns traffic command, use the clear clns traffic command in EXEC mode.
clear clns [tag] traffic
Syntax Description
Command Modes
EXEC
Command History
Examples
The following example removes the ISO CLNS statistics:
clear clns traffic
Related Commands
|
|
---|---|
show clns traffic |
Lists the CLNS packets that this router has seen. |
clear tarp counters
To clear all Target Identifier Address Resolution Protocol (TARP) counters that are shown with the show tarp traffic command, use the clear tarp counters command in EXEC mode.
clear tarp counters
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Usage Guidelines
Clearing the counters can assist you with troubleshooting. For example, you may want to clear the counter and then check to see how many PDUs the router is originating.
Examples
The following example clears the TARP counters:
clear tarp counters
Related Commands
|
|
---|---|
show tarp traffic |
Displays statistics about TARP PDUs since the last time the counters were cleared. |
clear tarp ldb-table
To clear the system ID-to-sequence number mapping entries stored in the TARP loop-detection buffer table, use the clear tarp ldb-table command in EXEC mode.
clear tarp ldb-table
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Usage Guidelines
The loop-detection buffer table prevents TARP packets from looping.
Clearing the mapping entries assists you with troubleshooting. For example, clear the loop-detection buffer table and assign a new sequence number (using the tarp sequence-number command) to ensure that other hosts update their entries.
Examples
The following example clears the TARP loop-detection buffer table:
clear tarp ldb-table
Related Commands
clear tarp tid-table
To clear the dynamically created TARP target identifier (TID)-to-NSAP address mapping entries stored in TID cache, use the clear tarp tid-table command in EXEC mode.
clear tarp tid-table
Syntax Description
This command has no arguments or keywords.
Command Modes
EXEC
Command History
Usage Guidelines
Clearing the TID cache is one method to remove old entries. Another method is to set the length of time a dynamically created TARP entry remains in the TID cache using the tarp cache-timer command.
The clear tarp tid-table command does not delete the cache entry for its own TID or the cache entries explicitly configured with the tarp map command.
Examples
The following example clears the TARP TID table:
clear tarp tid-table
Related Commands
clns access-group
To filter transit CLNS traffic going either into or out of the router or both on a per-interface basis, use the clns access-group command in interface configuration mode. To disable filtering of transit CLNS packets, use the no form of this command.
clns access-group name [in | out]
no clns access-group name [in | out]
Syntax Description
Defaults
Disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
This command has no effect on any CLNS packets sourced by Cisco IOS software. It applies only to packets forwarded by the software. Fast switching is still supported with access groups in place, but its performance will be impacted based on the complexity of the filters.
For descriptions of filter sets and expressions, refer to the clns filter-expr, clns filter-set, and clns template-alias global configuration commands.
Examples
The following example enables forwarding of frames received on Ethernet 0 that had a source address of anything other than 38.840F, and a destination address that started with 47.0005 or 47.0023, but nothing else:
clns filter-set US-OR-NORDUNET permit 47.0005...
clns filter-set US-OR-NORDUNET permit 47.0023...
clns filter-set NO-ANSI deny 38.840F...
clns filter-set NO-ANSI permit default
clns filter-expr STRANGE source NO-ANSI and destination US-OR-NORDUNET
interface ethernet 0
clns access-group STRANGE in
Related Commands
clns adjacency-filter
To filter the establishment of ES-IS adjacencies, use the clns adjacency-filter command in interface configuration mode. To disable this filtering, use the no form of this command.
clns adjacency-filter {es | is} name
no clns adjacency-filter {es | is} name
Syntax Description
es |
ES adjacencies are to be filtered. |
is |
IS adjacencies are to be filtered. |
name |
Name of the filter set or expression to apply. |
Defaults
Disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
Filtering is performed on full NSAP addresses. If filtering should only be performed on system IDs or any other substring of the full NSAP address, the wildcard-matching capabilities of filter sets should be used to ignore the insignificant portions of the NSAP addresses.
Note When you enter the clns adjacency-filter command, only the adjacencies that were formed using ES-IS will be filtered out. In order to remove adjacencies that were formed using IS-IS and ISO-IGRP, use the isis adjacency-filter and iso-igrp adjacency-filter commands, respectively.
For descriptions of filter sets and expressions, refer to the clns filter-expr, clns filter-set, and clns template-alias global configuration commands.
Examples
The following example builds a filter that accepts end system adjacencies with only two systems, based only on their system IDs:
clns filter-set ourfriends ...0000.0c00.1234.**
clns filter-set ourfriends ...0000.0c00.125a.**
interface ethernet 0
clns adjacency-filter es ourfriends
Related Commands
clns cache-invalidate-delay
To control the invalidation rate of the CLNS route cache, use the clns cache-invalidate-delay command in global configuration mode. To allow the CLNS route cache to be immediately invalidated, use the no form of this command.
clns cache-invalidate-delay [minimum maximum quiet threshold]
no clns cache-invalidate-delay
Syntax Description
Defaults
minimum: 2 seconds
maximum: 5 seconds
quiet: 3 seconds
threshold: 0 invalidations
Command Modes
Global configuration
Command History
Usage Guidelines
All cache invalidation requests are honored immediately.
This command should typically not be used except under the guidance of technical support personnel. Incorrect settings can seriously degrade network performance.
In an environment with heavy traffic, the CLNS cache can get invalidated (purged) too frequently. Frequent cache invalidations will cause the CPU to spend too much time purging and repopulating the cache.
The clns cache-invalidate-delay command controls how the CLNS route cache is purged. The intent is to delay invalidation of the cache until after routing has settled down. Because the routing table changes tend to be clustered in a short period of time, and the cache may be purged repeatedly, a high CPU load might be placed on the router.
When this feature is enabled, and the system requests that the route cache be purged, the request is held for at least the minimum seconds. Then the system determines whether the cache has been "quiet" (that is, less than threshold invalidation requests in the last quiet seconds). If the cache has been quiet, the cache is then purged. If the cache does not become quiet within maximum seconds after the first request, it is purged unconditionally.
Manipulation of these parameters trades off CPU utilization versus route convergence time. The timing of routing protocols is not affected, but the removal of stale cache entries is affected.
Examples
The following example sets a minimum delay of 5 seconds, a maximum delay of 30 seconds, and a quiet threshold of no more than 5 invalidation requests in the previous 10 seconds:
clns cache-invalidate-delay 5 30 10 5
Related Commands
|
|
---|---|
clns route-cache |
Allows fast switching through the cache. |
show clns cache |
Displays the CLNS route cache. |
clns checksum
To enable checksum generation when ISO CLNS routing software sources a CLNS packet, use the clns checksum command in interface configuration mode. To disable checksum generation, use the no form of this command.
clns checksum
no clns checksum
Syntax Description
This command has no arguments or keywords.
Defaults
Enabled
Command Modes
Interface configuration
Command History
Usage Guidelines
This command has no effect on routing packets, such as ES-IS, ISO-Interior Gateway Routing Protocol (IGRP) and IS-IS, sourced by the system. It applies to pings and trace route packets.
Examples
The following example enables checksum generation:
interface ethernet 0
clns checksum
clns cluster-alias
To allow multiple end systems to advertise the same NSAP address but with different system IDs in ES hello messages, use the clns cluster-alias command in interface configuration mode. To disable cluster aliasing, use the no form of this command.
clns cluster-alias
no clns cluster-alias
Syntax Description
This command has no arguments or keywords.
Defaults
Disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
This feature caches multiple ES adjacencies with the same NSAP, but with different subnetwork point of attachment (SNPA) addresses. When a packet is destined to the common NSAP address, Cisco IOS software load-splits the packets among the different SNPA addresses. A router that supports this capability forwards traffic to each system.
If DECnet Phase V cluster aliases are disabled on an interface, ES hello packet information is used to replace any existing adjacency information for the NSAP. Otherwise, an additional adjacency (with a different SNPA) is created for the same NSAP.
Examples
The following example enables cluster aliasing on specified interfaces:
clns nsap 47.0004.004d.0001.0000.0c00.1111.00
clns routing
interface ethernet 0
clns cluster-alias
interface ethernet 1
clns cluster-alias
clns configuration-time
To specify the rate at which ES hellos and IS hellos are sent, use the clns configuration-time command in global configuration mode. To restore the default value, use the no form of this command.
clns configuration-time seconds
no clns configuration-time
Syntax Description
seconds |
Rate, in seconds, at which ES and IS hello packets are sent. |
Defaults
60 seconds
Command Modes
Global configuration
Command History
Usage Guidelines
The clns configuration-time command controls how frequently a router will send hello messages to its adjacent routers. A hello message sent by the router contains the clns-holding time that tells the receiver for how long it should consider the hello message valid. By default, the clns configuration-time is 60 seconds and the clns holding-time is 300 seconds.
Examples
The following example specifies that ES hellos and IS hellos are to be sent every 100 seconds:
clns configuration-time 100
Related Commands
clns congestion-threshold
To set the congestion experienced bit if the output queue has more than the specified number of packets in it, use the clns congestion-threshold command in interface configuration mode. A number value of zero or the no form of this command prevents this bit from being set. To remove the parameter setting and set it to 0, use the no form of this command.
clns congestion-threshold number
no clns congestion-threshold
Syntax Description
number |
Number of packets that are allowed in the output queue before the system sets the congestion-experienced bit. The value zero (0) prevents this bit from being set. |
Defaults
4 packets
Command Modes
Interface configuration
Command History
Usage Guidelines
If a router configured for CLNS experiences congestion, it sets the congestion experienced bit. The congestion threshold is a per-interface parameter set by this interface configuration command. An error PDU (ERPDU) is sent to the sending router and the packet is dropped if the number of packets exceeds the threshold.
Examples
The following example sets the congestion threshold to 10:
interface ethernet 0
clns congestion-threshold 10
clns dec-compatible
To allow IS hellos sent and received to ignore the N-selector byte, use the clns dec-compatible command in interface configuration mode. To disable this feature, use the no form of this command.
clns dec-compatible
no clns dec-compatible
Syntax Description
This command has no arguments or keywords.
Defaults
Disabled
Command Modes
Interface configuration
Command History
Examples
The following example enables DEC-compatible mode:
interface ethernet 0
clns dec-compatible
clns enable
If you do not intend to perform any dynamic routing on an interface, but intend to pass ISO CLNS packet traffic to end systems, use the clns enable command in interface configuration mode. To disable ISO CLNS on a particular interface, use the no form of this command.
clns enable
no clns enable
Syntax Description
This command has no arguments or keywords.
Defaults
Disabled
Command Modes
Interface configuration
Command History
Examples
The following example enables ISO CLNS on Ethernet interface 0:
interface ethernet 0
clns enable
clns erpdu-interval
To determine the minimum interval time, in milliseconds, between error ERPDUs, use the clns erpdu-interval command in interface configuration mode. To turn off the interval rate and effectively set no limit between ERPDUs, use the no form of this command or a milliseconds value of zero.
clns erpdu-interval milliseconds
no clns erpdu-interval milliseconds
Syntax Description
milliseconds |
Minimum interval time (in milliseconds) between ERPDUs. |
Defaults
10 ms
Command Modes
Interface configuration
Command History
Usage Guidelines
This command prevents the router from sending ERPDUs more frequently than 1 per interface per 10 ms. It is wise not to send an ERPDU frequently if bandwidth is precious (such as over slow serial lines).
Examples
The following example sets the ERPDU interval to 30 ms:
interface ethernet 0
clns erpdu-interval 30
Related Commands
|
|
---|---|
clns send-erpdu |
Allows CLNS to send an error PDU when the routing software detects an error in a data PDU. |
clns esct-time
To supply an ES configuration timer option in a transmitted IS hello packet that tells the ES how often it should transmit ES hello packet PDUs, use the clns esct-time command in interface configuration mode. To restore the default value and disable this function, use the no form of this command.
clns esct-time seconds
no clns esct-time seconds
Syntax Description
seconds |
Time, in seconds, between ES hello PDUs. Range is from 0 to 65,535. |
Defaults
0 seconds (disabled)
Command Modes
Interface configuration
Command History
Examples
The following example sets the ES configuration time to 10 seconds:
interface ethernet 0
clns esct-time 10
Related Commands
clns es-neighbor
To manually define adjacencies for end systems that do not support the ES-IS routing protocol, use the clns es-neighbor command in interface configuration mode. To delete the ES neighbor, use the no form of this command.
clns es-neighbor nsap snpa
no clns es-neighbor nsap
Syntax Description
nsap |
Specific NSAP to map to a specific data link address. |
snpa |
Data link address. |
Defaults
No end systems are listed.
Command Modes
Interface configuration
Command History
Usage Guidelines
When you do use the clns es-neighbor command, you will have to manually specify the NSAP-to-SNPA mapping for the adjacencies. The subnetwork point of attachment (SNPA) of the end system will depend upon what type of interface is being used to provide connectively. On LANs, the SNPA will be a MAC address.
If you have configured either the clns router iso-igrp or clns router isis interface configuration commands for a particular interface, the ES-IS routing software automatically turns ES-IS on for that interface.
It is only necessary to use static mapping for those end systems that do not support ES-IS. The Cisco IOS software will continue to discover dynamically those end systems that do support ES-IS.
Examples
The following example defines an ES neighbor on Ethernet interface 0:
interface ethernet 0
clns es-neighbor 47.0004.004D.0055.0000.0C00.A45B.00 0000.0C00.A45B
In this case, the end system with the following NSAP, or network entity title (NET), is configured with an Ethernet MAC address of 0000.0C00.A45B:
47.0004.004D.0055.0000.0C00.A45B.00
Related Commands
clns filter-expr
To combine CLNS filter sets and CLNS address templates to create complex logical NSAP pattern-matching expressions, use one or more clns filter-expr commands in global configuration mode. To delete the expression, use the no form of this command.
clns filter-expr ename [term | not term | term {and | or | xor} term]
no clns filter-expr ename
Syntax Description
Defaults
No filter expression is defined.
Command Modes
Global configuration
Command History
Usage Guidelines
Filter expressions can reference previously defined filter expressions, so you can build arbitrarily complex expressions.
If none of the optional keywords is used, then the command defines a simple filter expression that is pattern matched only if the pattern given by term is matched.
Use this command to define complex filter expressions. See the description of the clns filter-set global configuration command to learn how to define filter sets.
Examples
The following example defines a filter expression that matches addresses with a source address of anything besides 39.840F, and a destination address that started with 47.0005 or 47.0023, but nothing else:
clns filter-set US-OR-NORDUNET permit 47.0005...
clns filter-set US-OR-NORDUNET permit 47.0023
clns filter-set NO-ANSI deny 38.840F...
clns filter-set NO-ANSI permit default
!
clns filter-expr STRANGE source NO-ANSI and destination US-OR-NORDUNET
Related Commands
clns filter-set
To build a list of CLNS address templates with associated permit and deny conditions for use in CLNS filter expressions, use the clns filter-set command in global configuration mode. CLNS filter expressions are used in the creation and use of CLNS access lists. To delete the entire filter set, use the no form of this command.
clns filter-set name [permit | deny] template
no clns filter-set name
Syntax Description
Defaults
No address templates are defined.
Command Modes
Global configuration
Command History
Usage Guidelines
Use this command to define a list of pattern matches and permit/deny conditions for use in CLNS filter expressions. Filter expressions are used in the creation and use of CLNS access lists. See the description of the clns filter-expr global configuration command to learn how to define filter expressions and the clns template-alias global configuration command to learn how to define address templates and address template aliases.
Each address that must be matched against a filter set is first compared against all the entries in the filter set, in order, for an exact match with the address. If the exact match search fails to find a match, then the entries in the filter set containing wildcard matches are scanned for a match, again, in order. The first template that matches is used. If an address does not match any of the filter set entries, an implicit "deny" is returned as the permit/deny action of the filter set.
Examples
The following example returns a permit action if an address starts with either 47.0005 or 47.0023. It returns an implicit deny action on any other address.
clns filter-set US-OR-NORDUNET permit 47.0005...
clns filter-set US-OR-NORDUNET permit 47.0023...
The following example returns a deny action if an address starts with 39.840F, but returns a permit action for any other address:
clns filter-set NO-ANSI deny 38.840F...
clns filter-set NO-ANSI permit default
Related Commands
clns holding-time
To allow the sender of an ES hello or IS hello to specify the length of time for which you consider the information in the hello packets to be valid, use the clns holding-time command in global configuration mode. To restore the default value (300 seconds, or 5 minutes), use the no form of this command.
clns holding-time seconds
no clns holding-time
Syntax Description
seconds |
Length of time, in seconds, during which the information in the hello packets is considered valid. |
Defaults
300 seconds (5 minutes)
Command Modes
Global configuration
Command History
Usage Guidelines
Setting this value too high puts extra traffic on a line and adds time to process hellos. However, you want to avoid setting it too low if your topology changes more often than Cisco IOS software sends updates.
Examples
The following example sets the holding time at 150 seconds:
clns holding-time 150
Related Commands
clns host
To define a name-to-NSAP mapping that can then be used with commands that require NSAPs, use the clns host command in global configuration mode.
clns host name nsap
Syntax Description
name |
Desired name for the NSAP. The first character can be either a letter or a number, but if you use a number, the operations you can perform are limited. |
nsap |
NSAP to which that the name maps. |
Defaults
No mapping is defined.
Command Modes
Global configuration
Command History
Usage Guidelines
The assigned NSAP name is displayed, where applicable, in show and debug EXEC commands. There are some effects and requirements associated with using names to represent network entity titles (NETs) and NSAPs, however. Although using names as proxies for addresses is allowed with CLNS commands, they are never written out to nonvolatile random-access memory (NVRAM).
The first character can be either a letter or a number, but if you use a number, the operations you can perform (such as ping) are limited.
The clns host command is generated after all other CLNS commands when the configuration file is parsed. As a result, the NVRAM version of the configuration cannot be edited to specifically change the address defined in the original clns host command. You must specifically change any commands that refer to the original address. This affects all commands that accept names.
The commands that are affected by these requirements include the following:
•net (router configuration command)
•clns is-neighbor (interface configuration command)
•clns es-neighbor (interface configuration command)
•clns route (global configuration command)
Examples
The following example defines names to NSAPs:
clns host cisco1 39.0001.0000.0c00.1111.00
clns host cisco2 39.0002.0000.0c00.1111.00
router iso-igrp
net cisco1
!
interface ethernet 0
clns net cisco2
Related Commands
clns is-neighbor
To manually define adjacencies for intermediate systems, use the clns is-neighbor command in interface configuration mode. To delete the specified IS neighbor, use the no form of this command.
clns is-neighbor nsap snpa
no clns is-neighbor nsap
Syntax Description
nsap |
NSAP of a specific intermediate system to enter as neighbor to a specific data link address. |
snpa |
Data link address. |
Defaults
No intermediate systems are listed.
Command Modes
Interface configuration
Command History
Usage Guidelines
When you do use the clns is-neighbor command, you will have to manually specify the NSAP-to-SNPA mapping for the adjacencies. The subnetwork point of attachments (SNPAs) are the MAC addresses. The SNPA of the end system will depend upon what type of interface is being used to provide connectively. On LANs, the SNPA will be a MAC address.
It is sometimes preferable for a router to have a neighbor entry statically configured rather than learned through ES-IS, ISO IGRP, or IS-IS. This interface configuration command enters an IS neighbor.
Examples
The following example defines an IS neighbor on Ethernet interface 0:
interface ethernet 0
clns is-neighbor 47.0004.004D.0055.0000.0C00.A45B.00 0000.0C00.A45B
Related Commands
clns mtu
To set the maximum transmission unit (MTU) packet size for the interface, use the clns mtu command in interface configuration mode. To restore the default and maximum packet size, use the no form of this command.
clns mtu bytes
no clns mtu
Syntax Description
bytes |
Maximum packet size in bytes. The minimum value is 512; the default and maximum packet size depend on the interface type. |
Defaults
Depends on interface type
Command Modes
Interface configuration
Command History
Usage Guidelines
All interfaces have a default maximum packet size. You can set the MTU size of the packets sent on the interface with the mtu interface configuration command.
All routers on a physical medium must have the same protocol MTU in order to operate.
The CTR card does not support the switching of frames larger than 4472 bytes. Interoperability problems can occur if CTR cards are intermixed with other Token Ring cards on the same network. These problems can be minimized by lowering the CLNS MTUs to be the same on all routers on the network with the clns mtu command.
Note Changing the MTU value with the mtu interface configuration command can affect the CLNS MTU value. If the CLNS MTU is at its maximum given the interface MTU, the CLNS MTU will change with the interface MTU. However, the reverse is not true; changing the CLNS MTU value has no effect on the value for the mtu interface configuration command.
Examples
The following example sets the MTU packet size to 1000 bytes:
interface ethernet 0
clns mtu 1000
Related Commands
|
|
---|---|
mtu |
Adjusts the maximum packet size or MTU size. |
clns net (global)
To assign a static address for a router, use the clns net command in global configuration mode. If the Cisco IOS software is configured to support ISO CLNS, but is not configured to dynamically route CLNS packets using ISO IGRP or IS-IS, use this command to assign an address to the router. To remove any previously configured NET or NSAP address, use the no form of this command.
clns net {net-address | name}
no clns net {net-address | name}
Syntax Description
net-address |
NET address. Refer to the "Usage Guidelines" section. |
name |
CLNS host name to be associated with this interface. |
Defaults
No static address is assigned.
Command Modes
Global configuration
Command History
Usage Guidelines
A CLNS packet sent to any of the defined NSAPs or NETs will be received by the router. The Cisco IOS software chooses the NET to use when it sends a packet with the following algorithm:
•If no dynamic routing protocol is running, use the NET defined for the outgoing interface if it exists; otherwise, use the NET defined for the router.
•If ISO IGRP is running, use the NET of the routing process that is running on this interface.
•If IS-IS is running, use the NET of the IS-IS routing process that is running on this interface.
Examples
The following example assigns a static address:
clns net 49.0001.aa00.0400.9105.00
clns packet-lifetime
To specify the initial lifetime for locally generated packets, use the clns packet-lifetime command in global configuration mode. To remove the parameter's settings, use the no form of this command.
clns packet-lifetime seconds
no clns packet-lifetime
Syntax Description
seconds |
Packet lifetime in seconds. |
Defaults
32 seconds
Command Modes
Global configuration
Command History
Examples
The following example sets a packet lifetime of 120 seconds:
clns packet-lifetime 120
Related Commands
|
|
---|---|
clns want-erpdu |
Specifies whether to request ERPDUs on packets sourced by the router. |
clns rdpdu-interval
To determine the minimum interval time between redirect PDUs (RDPDUs), use the clns rdpdu-interval command in interface configuration mode. To turn off the interval rate and effectively set no limit between RDPDUs, use the no form of this command or a milliseconds value of zero.
clns rdpdu-interval milliseconds
no clns rdpdu-interval milliseconds
Syntax Description
milliseconds |
Minimum interval time in milliseconds between RDPDUs. |
Defaults
100 ms
Command Modes
Interface configuration
Command History
Usage Guidelines
RDPDUs are rate-limited and are not sent more frequently than one per interface per 100 ms. There is no need to change the default. This setting will work fine for most networks.
Examples
The following example sets an interval of 50 ms:
interface ethernet 0
clns rdpdu-interval 50
Related Commands
|
|
---|---|
clns send-rdpdu |
Allows CLNS to send RPDUs when a better route for a given host is known. |
clns route (create)
To create an interface static route, use this form of the clns route command in global configuration mode. To remove this route, use the no form of this command.
clns route nsap-prefix type number [snpa-address]
no clns route nsap-prefix
Syntax Description
Defaults
No interface static routes are created.
Command Modes
Global configuration
Command History
Usage Guidelines
CLNS static routes will not be used to route traffic to a destination for which there is a dynamic route, if that destination is within the domain (ISO-IGRP) or area (IS-IS) of the router.
Note If you do not specify an SNPA address when you have a multiaccess network, you will receive an error message indicating a bad SNPA.
Examples
The following example creates a static route for an Ethernet interface:
clns route 39.0002 ethernet 3 aa00.0400.1111
The following example creates a static route for a serial interface:
clns route 39.0002 serial 0
Related Commands
clns route (enter)
To enter a specific static route, use this form of the clns route command in global configuration mode. NSAPs that start with nsap-prefix are forwarded to next-hop-net or the name of the next hop. To remove this route, use the no form of this command.
clns route nsap-prefix {next-hop-net | name}
no clns route nsap-prefix
Syntax Description
Defaults
No static route is entered.
Command Modes
Global configuration
Command History
Usage Guidelines
CLNS static routes will not be used to route traffic to a destination for which there is a dynamic route, if that destination is within the domain (ISO-IGRP) or area (IS-IS) of the router.
Examples
The following example forwards all packets toward the specified route:
clns route 39.840F 47.0005.80FF.FF00.0123.4567.89AB.00
Related Commands
clns route default discard
To assign a default discard route and automatically discard packets with NSAP addresses that do not match any existing routes, use the clns route default discard command in global configuration mode. To remove the default discard route, use the no form of this command.
clns route default discard
no clns route default discard
Syntax Description
This command has no arguments or keywords.
Defaults
Disabled
Command Modes
Global configuration
Command History
Usage Guidelines
The only time you would use this command is if you are using static routing and ES-IS and you wish disable ES-IS and therefore reduce the router to using purely static routing. Using this command will reduce the functionality of the router by forcing ISO CLNS to ignore all nodes that were learned through ES-IS.
Note This command will have little or no affect if you are using a dynamic routing process such as IS-IS or ISO-IGRP, as the router will discard any packets for which it does not have a route, even if this command has not been entered.
Examples
The following example assigns a default discard route:
clns route default discard
When you enter the enter the show clns route command, you will see the following default discard route information:
Router# show clns route
Codes: C - connected, S - static, d - DecnetIV
I - ISO-IGRP, i - IS-IS, e - ES-IS
S Default Prefix [10/0], Discard Entry
Related Commands
clns route default
To configure a default zero-length prefix rather than type an NSAP prefix, use the clns route default command in global configuration mode. To remove this route, use the no form of this command.
clns route default type number
no clns route default
Syntax Description
type |
Interface type. Specify the interface type immediately followed by the interface number; there is no space between the two. |
number |
Interface number. |
Defaults
No default prefix is configured.
Command Modes
Global configuration
Command History
Examples
The following example configures a default zero-length prefix:
clns route default ethernet0
Related Commands
clns route discard
To explicitly tell a router to discard packets with NSAP addresses that match the specified nsap-prefix, use the clns route discard command in global configuration mode. To remove this route, use the no form of this command.
clns route nsap-prefix discard
no clns route nsap-prefix
Syntax Description
Defaults
No NSAP addresses are identified.
Command Modes
Global configuration
Command History
Usage Guidelines
The decnet advertise command and the clns route discard command work together when DECnet Phase IV/V conversion is enabled. Any packet with the specified CLNS NSAP prefix causes CLNS to behave as if no route were found. Because DECnet Phase IV/V conversion is enabled, the route is then looked up in the Phase IV routing table. The router that is advertising the DECnet Phase IV route converts the packet to OSI and sends it to the router that is advertising the CLNS discard static route. Once it gets there, the packet is converted back to Phase IV.
CLNS discard routes cannot be used to discard packets that are addressed to a destination for which there is a dynamic route, if that destination is within the domain (ISO IGRP) or area (IS-IS) of the router.
Examples
The following example discards packets with a destination NSAP address that matches the prefix 47.0005:
clns route 47.0005 discard
Related Commands
clns route-cache
To allow fast switching through the cache, use the clns route-cache command in interface configuration mode. To disable fast switching, use the no form of this command.
clns route-cache
no clns route-cache
Syntax Description
This command has no arguments or keywords.
Defaults
Enabled
Command Modes
Interface configuration
Command History
Usage Guidelines
The cache still exists and is used after the no clns route-cache command is used; the software just does not do fast switching through the cache.
Examples
The following example allows fast switching through the cache:
interface ethernet 0
clns route-cache
clns router isis
To configure an Intermediate System-to-Intermediate System (IS-IS) routing process for ISO Connectionless Network Service Protocol (CLNS) on a specified interface and to attach an area designator to the routing process, use the clns router isis command in interface configuration mode. To disable IS-IS for ISO CLNS, use the no form of the command.
clns router isis area-tag
no clns router isis area-tag
Syntax Description
Defaults
No routing processes are specified.
Command Modes
Interface configuration
Command History
Usage Guidelines
Before the IS-IS router process is useful, a network entity title (NET) must be assigned with the net command and some interfaces must be enabled with IS-IS.
If you have IS-IS running and at least one ISO-IGRP process, the IS-IS process and the ISO-IGRP process cannot both be configured without an area tag. The null tag can be used by only one process. If you run ISO-IGRP and IS-IS, a null tag can be used for IS-IS, but not for ISO-Interior Gateway Routing Protocol (IGRP) at the same time. However, each area in an IS-IS multiarea configuration should have a non-null area tag to facilitate identification of the area.
Note The IS-IS multiarea feature is not supported for IP.
You can configure only one process to perform Level 2 (interarea) routing. If Level 2 routing is configured on any process, all additional processes are automatically configured as Level 1. You can configure this process to perform intra-area (Level 1) routing at the same time. You can configure up to 29 additional processes as Level 1-only processes. Use the is-type command to remove Level 2 routing from a router instance. You can then use the is-type command to enable Level 2 routing on some other IS-IS router instance.
Note The CPU memory required to run 29 Level 1 ISIS processes will probably not be present in low-end platforms unless the routing information and area topology are limited.
An interface cannot be part of more than one area, except in the case where the associated routing process is performing both Level 1 and Level 2 routing. On media (such as WAN media, for example) where subinterfaces are supported, different subinterfaces could be configured for different areas.
Examples
The following example enables IS-IS routing for ISO CLNS on Ethernet interface 0:
router isis cisco
net 39.0001.0000.0c00.1111.00
interface ethernet 0
clns router isis cisco
The following example shows an IS-IS configuration with two Level 1 areas and one Level 1-2 area:
clns routing
...
interface Tunnel529
clns router isis BB
interface Ethernet1
clns router isis A3253-01
!
interface Ethernet2
clns router isis A3253-02
...
router isis BB ! Defaults to "is-type level-1-2"
net 49.2222.0000.0000.0005.00
!
router isis A3253-01
net 49.0553.0001.0000.0000.0005.00
is-type level-1
!
router isis A3253-02
net 49.0553.0002.0000.0000.0005.00
is-type level-1
Related Commands
|
|
---|---|
router isis |
Enables the IS-IS routing protocol and specifies an IS-IS process for IP. |
clns router iso-igrp
To specify ISO IGRP routing on a specified interface, use the clns router iso-igrp command in interface configuration mode. To disable ISO IGRP routing for the system, use the no form of the global configuration command with the appropriate tag.
clns router iso-igrp tag [level 2]
no clns router iso-igrp tag
Syntax Description
Defaults
ISO IGRP routing is not specified on any interface.
Command Modes
Interface configuration
Global configuration
Command History
Usage Guidelines
If you want this interface to advertise Level 2 information only, use the level 2 keyword. This option reduces the amount of router-to-router traffic by telling Cisco IOS software to send out only Level 2 routing updates on certain interfaces. Level 1 information is not passed on the interfaces for which the Level 2 option is set.
Examples
In the following example, the interface advertises Level 2 information only on serial interface 0:
router iso-igrp marketing
net 49.0001.0000.0c00.1111.00
interface serial 0
clns router iso-igrp marketing level 2
Related Commands
|
|
---|---|
router iso-igrp |
Identifies the area the router will work in and informs it that it will route dynamically using the ISO IGRP protocol. |
clns routing
To enable routing of CLNS packets, use the clns routing command in global configuration mode. To disable CLNS routing, use the no form of this command.
clns routing
no clns routing
Syntax Description
This command has no arguments or keywords.
Defaults
Disabled
Command Modes
Global configuration
Command History
Examples
The following example enables routing of CLNS packets:
clns routing
Related Commands
|
|
---|---|
clns security pass-through |
Allows Cisco IOS software to pass packets that have security options set. |
clns security pass-through
To allow Cisco IOS software to pass packets that have security options set, use the clns security pass-through command in global configuration mode. To disable this function, use the no form of this command.
clns security pass-through
no clns security pass-through
Syntax Description
This command has no arguments or keywords.
Defaults
The software discards any packets it sees as set with security options.
Command Modes
Global configuration
Command History
Examples
The following example allows Cisco IOS software to pass packets that have security options set:
clns routing
router iso-igrp
net 47.0004.004d.0001.0000.0c11.1111.00
clns security pass-through
Related Commands
|
|
---|---|
clns routing |
Enables routing of CLNS packets. |
clns send-erpdu
To allow CLNS to send an error PDU when the routing software detects an error in a data PDU, use the clns send-erpdu command in interface configuration mode. To disable this function, use the no form of this command.
clns send-erpdu
no clns send-erpdu
Syntax Description
This command has no arguments or keywords.
Defaults
Enabled
Command Modes
Interface configuration
Command History
Usage Guidelines
When a CLNS packet comes in, the routing software looks in the routing table for the next hop. If it does not find the next hop, the packet is discarded and an ERPDU can be sent to the original source/sender of the packet that was discarded.
Examples
The following example allows CLNS to send an error PDU when it detects an error in a data PDU:
interface ethernet 0
clns send-erpdu
Related Commands
|
|
---|---|
clns erpdu-interval |
Determines the minimum interval time, in milliseconds, between error ERPDUs. |
clns send-rdpdu
To allow CLNS to redirect PDUs (RDPDUs) when a better route for a given host is known, use the clns send-rdpdu command in interface configuration mode. To disable this function, use the no form of this command.
clns send-rdpdu
no clns send-rdpdu
Syntax Description
This command has no arguments or keywords.
Defaults
Enabled
Command Modes
Interface configuration
Command History
Usage Guidelines
If a packet is sent out on the same interface it came in on, an RDPDU can also be sent to the sender of the packet.
Examples
The following example allows CLNS to send RDPDUs:
interface ethernet 0
clns send-rdpdu
Related Commands
|
|
---|---|
clns erpdu-interval |
Determines the minimum interval time (in milliseconds) between RDPDUs. |
clns split-horizon
To implement split horizon for ISO IGRP updates, use the clns split-horizon command in interface configuration mode. To disable this function, use the no form of this command.
clns split-horizon
no clns split-horizon
Syntax Description
This command has no arguments or keywords.
Defaults
For all LAN interfaces—enabled
For WAN interfaces on X.25, Frame Relay, or SMDS networks—disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
Normally, routers that are connected to broadcast-type OSI networks and that use distance vector routing protocols employ the split-horizon mechanism to prevent routing loops. Split-horizon blocks information about routes from being advertised by a router out any interface from which that information originated. This behavior usually optimizes communications among multiple routers, particularly when links are broken. However, with nonbroadcast networks, such as Frame Relay and SMDS, situations can arise for which this behavior is less than ideal. For all interfaces except those for which either Frame Relay or SMDS encapsulation is enabled, the default condition for this command is for split horizon to be enabled.
If your configuration includes either the encapsulation frame-relay or encapsulation smds interface configuration commands, the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.
For networks that include links over X.25 PSNs, the neighbor interface configuration command can be used to defeat the split horizon feature. You can as an alternative explicitly specify the no clns split-horizon command in your configuration. However, if you do so, you must similarly disable split horizon for all routers in any relevant multicast groups on that network.
Split horizon for ISO IGRP defaults to off for X.25, SMDS, and Frame Relay. Thereby, destinations are advertised out the interface for which the router has a destination.
In general, changing the state of the default for this interface configuration command is not recommended, unless you are certain that your application requires making a change in order to properly advertise routes. Remember that if split horizon is disabled on a serial interface (and that interface is attached to a packet-switched network), you must disable split horizon for all routers in any relevant multicast groups on that network.
Examples
The following example disables split horizon on a serial link connected to an X.25 network:
interface serial 0
encapsulation x25
no clns split-horizon
clns template-alias
To build a list of alphanumeric aliases of CLNS address templates for use in the definition of CLNS filter sets, use one or more clns template-alias commands in global configuration mode. To delete the alias, use the no form of this command.
clns template-alias name template
no clns template-alias name
Syntax Description
name |
Alphanumeric name to apply as an alias for the template. |
template |
Address template, as defined in the "Usage Guidelines" section. |
Defaults
No alias list is defined.
Command Modes
Global configuration
Command History
Usage Guidelines
Address templates are "pattern forms" that match one or more CLNS addresses. They can be simple single CLNS addresses, which match just themselves, or contain wildcards, prefixes, and suffixes, allowing a single template to match many addresses.
The simplest address template matches just a single address, as shown in this example:
47.0005.1234.5678.9abc.def0.00
Wildcard digits, which can match any value, are indicated with asterisks (*). The following template matches the above address and any other 12-byte long address that starts with 47.0005.1234.5678:
47.0005.1234.5678.****.****.**
Because OSI addresses are variable in length, it is often useful to build templates that match addresses that share a common prefix. The following template matches any address of any length that begins with the prefix 47.0005.1234.5678:
47.0005.1234.5678...
In other instances, matching a suffix of the address is also important, such as when matching system IDs. The following template matches any address that ends with the suffix 0000.0c01.2345.00:
...0000.0c01.2345.00
In other cases, you might want to match addresses on a single-bit granularity, rather than half-byte (four-bit, or nibble) granularity. This pattern matching is supported by allowing the hex digits that represent four bits to be replaced by groups of four binary bits, represented by 0s and 1s. These four binary digits are enclosed within parentheses. The following template matches any address that starts with 47.0005 followed by the binary bits 10. The final two binary bits in the nibble can be either 0 or 1, and are represented with asterisks.
47.0005.(10**)...
Use this command to define aliases for commonly referenced address templates. The use of these aliases reduces the chances for typographical error in the creation of CLNS filter sets.
Examples
The following command defines a filter set called COMPLEX-PREFIX for the last example given in the "Usage Guidelines" section:
clns template-alias COMPLEX-PREFIX 47.0005.(10**)...
Related Commands
clns want-erpdu
To specify whether to request ERPDUs on packets sourced by the router, use the clns want-erpdu command in global configuration mode. To remove the parameter's settings, use the no form of this command.
clns want-erpdu
no clns want-erpdu
Syntax Description
This command has no arguments or keywords.
Defaults
To request ERPDUs
Command Modes
Global configuration
Command History
Usage Guidelines
This command has no effect on routing packets (ES-IS, ISO IGRP, and IS-IS) sourced by the system. It applies to pings and trace route packets.
Examples
The following example requests ERPDUs on packets sourced by the router:
clns want-erpdu
Related Commands
|
|
---|---|
clns packet-lifetime |
Specifies the initial lifetime for locally generated packets. |
ctunnel destination
To configure the destination parameter for an IP over CLNS tunnel (CTunnel), use the ctunnel destination command in interface configuration mode. To remove the destination parameter, use the no form of this command.
ctunnel destination nsap-address
no ctunnel destination nsap-address
Syntax Description
nsap-address |
NSAP address for the CTunnel destination. |
Defaults
No default behavior or values.
Command Modes
Interface configuration
Command History
Usage Guidelines
When creating an IP over CLNS tunnel, you must first create the virtual interface by using the interface ctunnel command. Once you have created the virtual interface, the order in which you configure the destination parameter by using the ctunnel destination command and set the IP address for that destination parameter by using the ip address command does not matter.
Addresses in the ISO network architecture are referred to as network service access point (NSAP) addresses and network entity titles (NETs). Each node in an OSI network has one or more NETs. In addition, each node has many NSAP addresses. Each NSAP address differs from one of the NETs for that node in only the last byte. This byte is called the N-selector. Its function is similar to the port number in other protocol suites.
When a CTunnel interface is being configured, the N-selector of the destination NSAP address is set automatically by the router. Regardless of the value you enter for the N-selector byte, the router will select the appropriate value. You will see the value that was chosen by the router when you enter the show interfaces ctunnel command.
Examples
The following example configures a CTunnel from one router to another and shows the CTunnel destination set to 49.0001.1111.1111.1111.00.
interface ctunnel 301
ip address 10.0.0.3 255.255.255.0
ctunnel destination 49.0001.1111.1111.1111.00
Related Commands
ctunnel mode
To transport IPv4 and IPv6 packets over Connectionless Network Service (CLNS) tunnel (CTunnel), use the ctunnel mode command in interface configuration mode. To return the ctunnel to the default cisco mode, use the no form of this command.
ctunnel mode [gre | cisco]
no ctunnel mode
Syntax Description
gre |
(Optional) Sets the ctunnel mode to Generic Routing Encapsulation (GRE) for transporting IPv6 packets over the CLNS network. |
cisco |
(Optional) Returns the ctunnel mode to the default cisco. |
Command Default
Cisco encapsulation
Command Modes
Interface configuration
Command History
Usage Guidelines
GRE tunneling of IPv4 and IPv6 packets through CLNS-only networks enables Cisco ctunnels to interoperate with networking equipment from other vendors. This feature provides compliance with RFC 3147, Generic Routing Encapsulation over CLNS Networks, which should allow interoperation between Cisco equipment and that of other vendors. in which the same standard is implemented.
RFC 3147 specifies the use of GRE when tunneling packets. The implementation of this feature does not include support for GRE header fields such as those used to specify checksums, keys, or sequencing. Any packets received which specify the use of these features will be dropped.
The default ctunnel mode continues to use the standard Cisco encapsulation. Both ends of the tunnel must be configured with the same mode for it to work. If you want to tunnel ipv6 packets you must use the new gre mode.
Examples
The following example configures a CTunnel from one router to another and shows the CTunnel destination set to 49.0001.1111.1111.1111.00. The ctunnel mode is set to gre to transport IPv6 packets.
interface ctunnel 301
ipv6 address 2001:0DB8:1111:2222::2/64
ctunnel destination 49.0001.1111.1111.1111.00
ctunnel mode gre
Related Commands
distance (ISO CLNS)
To configure the administrative distance for CLNS routes learned, use the distance command in router configuration mode. To restore the administrative distance to the default, use the no form of this command.
distance value [clns]
no distance value [clns]
Syntax Description
Defaults
Static routes—10
ISO IGRP routes—100
IS-IS routes—110
Command Modes
Router configuration
Command History
Usage Guidelines
When multiple routing processes are running in the same router for CLNS, it is possible for the same route to be advertised by more than one routing process.
If the router is forwarding packets, dynamic routes will always take priority over static routes, unless the router is routing to a destination outside of its domain and area. The router first will look for an ISO IGRP route within its own area, then for an ISO IGRP route within its own domain, and finally for an IS-IS route within its own area, until it finds a matching route. If a matching route still has not been found, the router will check its prefix table, which contains static routes and routes to destinations outside the area (ISO IGRP), domain (ISO IGRP), and area (IS-IS) routes for that router. When the router is using its prefix table, it will choose the route that has the lowest administrative distance.
Note The administrative distance for CLNS routes that you have configured by entering the distance command will take effect only when routes are entered into the routing prefix table.
If you want an ISO IGRP prefix route to override a static route, you must set the administrative distance for the routing process to be lower than 10 (assigned administrative distance for static routes). You cannot change the assigned administrative distance for static routes.
The show clns protocol EXEC command displays the default administrative distance for a specified routing process.
Examples
In the following example, the distance value for CLNS routes learned is 90. Preference is given to these CLNS routes rather than routes with the default administrative distance value of 110.
router isis
distance 90 clns
ignore-lsp-errors
To allow the router to ignore Intermediate System-to-Intermediate System (IS-IS) link-state packets that are received with internal checksum errors rather than purging the link-state packets, use the ignore-lsp-errors command in router configuration mode. To disable this function, use the no form of this command.
ignore-lsp-errors
no ignore-lsp-errors
Syntax Description
This command has no arguments or keywords.
Defaults
This command is enabled by default; that is, corrupted LSPs are dropped instead of purged for network stability.
Command Modes
Router configuration
Command History
Usage Guidelines
The IS-IS protocol definition requires that a received link-state packet with an incorrect data-link checksum be purged by the receiver, which causes the initiator of the packet to regenerate it. However, if a network has a link that causes data corruption while still delivering link-state packets with correct data link checksums, a continuous cycle of purging and regenerating large numbers of packets can occur. Because this could render the network nonfunctional, use the ignore-lsp-errors command to ignore these link-state packets rather than purge the packets.
Link-state packets are used by the receiving routers to maintain their routing tables.
If you want to explicitly purge the corrupted LSPs, issue the no ignore-lsp-errors command.
Examples
The following example instructs the router to ignore link-state packets that have internal checksum errors:
router isis
ignore-lsp-errors
interface ctunnel
To create a virtual interface to transport IP over a CLNS tunnel (CTunnel), use the interface ctunnel command in global configuration mode. To remove the virtual interface, use the no form of this command.
interface ctunnel interface-number
no interface ctunnel interface-number
Syntax Description
interface-number |
CTunnel interface number (a number from 0 through 2,147,483,647). |
Defaults
No default behavior or values.
Command Modes
Global configuration
Command History
Usage Guidelines
When configuring an IP over CLNS tunnel, you must first create a virtual interface. In the following example, the interface ctunnel command is used to create the virtual interface.
Examples
The following example configures a CTunnel from one router to another and shows the CTunnel destination set to 49.0001.1111.1111.1111.00:
interface ctunnel 301
ip address 10.0.0.3 255.255.255.0
ctunnel destination 49.0001.1111.1111.1111.00
Related Commands
ip domain-lookup nsap
To allow Domain Name System (DNS) queries for CLNS addresses, use the ip domain-lookup nsap command in global configuration mode. To disable this function, use the no form of this command.
ip domain-lookup nsap
no ip domain-lookup nsap
Syntax Description
This command has no arguments or keywords.
Defaults
Enabled
Command Modes
Global configuration
Command History
Usage Guidelines
With both IP and ISO CLNS enabled on a router, this feature allows you to discover a CLNS address without having to specify a full CLNS address given a host name. This feature is useful for the ISO CLNS ping EXEC command and when making CLNS Telnet connections.
Examples
The following example disables DNS queries of CLNS addresses:
no ip domain-lookup nsap
Related Commands
isis adjacency-filter
To filter the establishment of Intermediate System-to-Intermediate System (IS-IS) adjacencies, use the isis adjacency-filter command in interface configuration mode. To disable filtering of the establishment of IS-IS adjacencies, use the no form of this command.
isis adjacency-filter name [match-all]
no isis adjacency-filter name [match-all]
Syntax Description
Defaults
Disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
Filtering is performed by building NSAP addresses out of incoming IS-IS hello packets by combining each area address in the hello with the system ID. Each of these NSAP addresses is then passed through the filter. If any one NSAP matches, the filter is considered "passed," unless the match-all keyword was specified, in which case all addresses must pass. The functionality of the match-all keyword is useful in performing "negative tests," such as accepting an adjacency only if a particular address is not present.
Filtering is performed on full NSAP addresses. If filtering should only be performed on system IDs, or any other substring of the full NSAP address, the wildcard matching capabilities of filter sets should be used to ignore the insignificant portions of the NSAP addresses.
Filter sets and expressions are described in this manual in the descriptions for the clns filter-expr, clns filter-set, and clns template-alias global configuration commands.
Examples
The following example builds a filter that accepts adjacencies with only two systems, based only on their system IDs:
clns filter-set ourfriends ...0000.0c00.1234.**
clns filter-set ourfriends ...0000.0c00.125a.**
!
interface ethernet 0
isis adjacency-filter ourfriends
Related Commands
iso-igrp adjacency-filter
To filter the establishment of ISO IGRP adjacencies, use the iso-igrp adjacency-filter command in interface configuration mode. To disable filtering of the establishment of ISO IGRP adjacencies, use the no form of this command.
iso-igrp adjacency-filter name
no iso-igrp adjacency-filter name
Syntax Description
name |
Name of the filter set or expression to apply. |
Defaults
Disabled
Command Modes
Interface configuration
Command History
Usage Guidelines
Filtering is performed on full NSAP addresses. If filtering should only be performed on system IDs, or any other substring of the full NSAP address, the wildcard matching capabilities of filter sets should be used to ignore the insignificant portions of the NSAP addresses.
For descriptions of filter sets and expressions, refer to the clns filter-expr, clns filter-set, and clns template-alias global configuration commands.
Examples
The following example builds a filter that accepts adjacencies with only two systems, based only on their system IDs:
clns filter-set ourfriends ...0000.0c00.1234.**
clns filter-set ourfriends ...0000.0c00.125a.**
!
interface ethernet 0
iso-igrp adjacency-filter ourfriends
Related Commands
lsp-mtu (ISO CLNS)
To set the maximum transmission unit (MTU) size of Intermediate System-to-Intermediate System (IS-IS) link-state packets (LSPs), use the lsp-mtu command in router configuration mode. To disable this function, use the no form of this command.
lsp-mtu size
no lsp-mtu
Syntax Description
size |
Maximum packet size in bytes. The size must be less than or equal to the smallest MTU of any link in the network. The default size is 1497 bytes. |
Defaults
1497 bytes
Command Modes
Router configuration
Command History
Usage Guidelines
Under normal conditions, the default MTU size should be sufficient. However, if the MTU of a link is below 1500 bytes, the link-state packet MTU must be lowered accordingly on each router in the network. If this is not done, routing becomes unpredictable.
Note This rule applies for all routers in a network. If any link in the network has a reduced MTU, all routers must be changed, not just the routers directly connected to the link.
Examples
The following example sets the MTU size to 1300 bytes:
router isis
lsp-mtu 1300
Related Commands
|
|
---|---|
clns mtu |
Sets the MTU packet size for the interface. |
mtu |
Adjusts the maximum packet size or MTU size. |