- scope
- select-topology
- service-policy type class-routing
- show ip bgp topology
- show ip eigrp topology
- show ip interface (MTR)
- show ip ospf interface
- show ip ospf topology-info
- show ip protocols topology
- show ip route multicast
- show ip route topology
- show ip static route
- show ip static route summary
- show ip traffic (MTR)
- show isis neighbors
- show mtm table
- show policy-map type class-routing ipv4 unicast
- show snmp context mapping
- show topology
- shutdown (MTR)
- snmp context
- topology (BGP)
- topology (EIGRP)
- topology (global)
- topology (interface)
- topology (IS-IS)
- topology (OSPF)
- topology-accounting
- traceroute
- use-topology
scope
To define the scope for a Border Gateway Protocol (BGP) routing session and to enter router scope configuration mode, use the scope command in router configuration mode. To remove the scope configuration, use the no form of this command.
scope {global | vrf vrf-name}
no scope {global | vrf vrf-name}
Syntax Description
global |
Configures BGP to use the global routing table or a specific topology table. |
vrf |
Configures BGP to use a specific VRF routing table. |
vrf-name |
Name of an existing VRF. |
Command Default
No scope is defined for a BGP routing session.
Command Modes
Router configuration
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Usage Guidelines
A new configuration hierarchy, named scope, has been introduced into the BGP protocol. To implement Multi-Topology Routing (MTR) support for BGP, the scope hierarchy is required, but the scope hierarchy is not limited to MTR use. The scope hierarchy introduces some new configuration modes such as router scope configuration mode. Router scope configuration mode is entered by configuring the scope command in router configuration mode, and a collection of routing tables is created when this command is entered. The scope is configured to isolate routing calculation for a single network (globally) or on a per-VRF basis, and BGP commands configured in routing scope configuration mode are referred to as scoped commands. The scope hierarchy can contain one or more address families.
The BGP command-line interface (CLI) has been modified to provide backwards compatibility for pre-MTR BGP configuration and to provide a hierarchal implementation of MTR. From router scope configuration mode, MTR is configured first by entering the address-family command to enter the desired address family and then by entering the topology command to define the topology
Note Configuring a scope for a BGP routing process removes CLI support for pre-MTR-based configuration.
Examples
The following example defines a global scope that includes both unicast and multicast topology configurations. Another scope is specifically defined only for the VRF named DATA.
Router(config)# router bgp 45000
Router(config-router)# scope global
Router(config-router-scope)# bgp default ipv4-unicast
Router(config-router-scope)# neighbor 172.16.1.2 remote-as 45000
Router(config-router-scope)# neighbor 192.168.3.2 remote-as 50000
Router(config-router-scope)# address-family ipv4 unicast
Router(config-router-scope-af)# topology VOICE
Router(config-router-scope-af)# bgp tid 100
Router(config-router-scope-af)# neighbor 172.16.1.2 activate
Router(config-router-scope-af)# exit
Router(config-router-scope)# address-family ipv4 multicast
Router(config-router-scope-af)# topology base
Router(config-router-scope-af-topo)# neighbor 192.168.3.2 activate
Router(config-router-scope-af-topo)# exit
Router(config-router-scope-af)# exit
Router(config-router-scope)# exit
Router(config-router)# scope vrf DATA
Router(config-router-scope)# neighbor 192.168.1.2 remote-as 40000
Router(config-router-scope)# address-family ipv4
Router(config-router-scope-af)# neighbor 192.168.1.2 activate
Router(config-router-scope-af)# end
Related Commands
|
|
---|---|
bgp tid |
Configures BGP to accept routes with a specified topology ID. |
topology (BGP) |
Configures a process to route IP traffic under the specified topology instance. |
select-topology
To attach the policy map to the topology, use the select-topology command in policy map class configuration mode. To remove the association of the policy map with the topology, use the no form of this command.
select-topology topology-name
no select-topology topology-name
Syntax Description
topology-name |
Name of the topology. |
Command Default
No policy map is attached to the topology.
Command Modes
Policy map class configuration (config-pmap-c)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Examples
In the following example, the topology VOICE is configured to be attached to the policy map BLUE:
Router(config)# global-address-family ipv4
Router(config-af)# topology VOICE
Router(config-af-topology)# all-interfaces
Router(config-af-topology)# exit
Router(config-af)# exit
Router(config)# class-map match-any DATA
Router(config-cmap)# match ip dscp 9
Router(config-cmap)# exit
Router(config)# policy-map type class-routing ipv4 unicast BLUE
Router(config-pmap)# class DATA
Router(config-pmap-c)# select-topology VOICE
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# global-address-family ipv4
Router(config-af)# service-policy type class-routing BLUE
Router(config-af)# end
service-policy type class-routing
To attach the service policy to the policy map for Multi-Topology Routing (MTR) traffic classification and to activate MTR, use the service-policy type class-routing command in global address family configuration mode. To detach the service policy from the policy map, use the no form of this command.
service-policy type class-routing policy-map-name
no service-policy type class-routing policy-map-name
Syntax Description
policy-map-name |
Policy map name. |
Command Default
The service policy is not attached.
Command Modes
Global address family configuration (config-af)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The service-policy type class-routing command is used to attach a service policy to a policy map for MTR traffic classification. MTR traffic classification is used to configure topology-specific forwarding behaviors when multiple topologies are configured on the same router. Class-specific packets are associated with the corresponding topology table forwarding entries.
After the service-policy type class-routing command is entered, MTR is activated.
Examples
The following example shows how to configure traffic classification for a topology instance named VOICE:
Router(config)# global-address-family ipv4
Router(config-af)# topology VOICE
Router(config-af-topology)# all-interfaces
Router(config-af-topology)# exit
Router(config-af)# exit
Router(config)# class-map match-any DATA
Router(config-cmap)# match ip dscp 9
Router(config-cmap)# exit
Router(config)# policy-map type class-routing ipv4 unicast BLUE
Router(config-pmap)# class DATA
Router(config-pmap-c)# select-topology VOICE
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# global-address-family ipv4
Router(config-af)# service-policy type class-routing BLUE
Router(config-af)# end
Related Commands
show ip bgp topology
To display topology instance information from the Border Gateway Protocol (BGP) table, use the show ip bgp topology command in privileged EXEC mode.
With BGP show Command Argument
show ip bgp topology {* | topology} [bgp-keyword]
With IP Prefix and Mask Length Syntax
show ip bgp topology {* | topology} [ip-prefix/length [bestpath] [longer-prefixes [injected]] [multipaths] [shorter-prefixes [mask-length]] [subnets]]
With Network Address Syntax
show ip bgp topology {* | topology} [network-address [mask | bestpath | multipaths] [bestpath] [longer-prefixes [injected]] [multipaths] [shorter-prefixes [mask-length]] [subnets]]
Syntax Description
* |
Displays all routing topology instances. |
topology |
Name of topology for which information is displayed. |
bgp-keyword |
(Optional) Argument representing a show ip bgp command keyword that can be added to this command. See Table 2. |
ip-prefix/length |
(Optional) The IP prefix address (in dotted decimal format) and the length of the mask (0 to 32). The slash mark must be included. |
bestpath |
(Optional) Displays the bestpath for the specified prefix. |
longer-prefixes |
(Optional) Displays the route and more specific routes. |
injected |
(Optional) Displays more specific routes that were injected because of the specified prefix. |
multipaths |
(Optional) Displays the multipaths for the specified prefix. |
shorter-prefixes |
(Optional) Displays the less specific routes. |
mask-length |
(Optional) The length of the mask as a number in the range from 0 to 32. Prefixes longer than the specified mask length are displayed. |
subnets |
(Optional) Displays the subnet routes for the specified prefix. |
network-address |
(Optional) The IP address of a network in the BGP routing table. |
mask |
(Optional) The mask of the network address, in dotted decimal format. |
Command Modes
Privileged EXEC
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Usage Guidelines
Table 2 displays optional additional show ip bgp command keywords that can be configured with the show ip bgp topology command. Replace the bgp-keyword argument with the appropriate keyword from the table. For more details about each command in its show ip bgp bgp-keyword form, see the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR.
Examples
The following example shows summary output for the show ip bgp topology command. Information is displayed about BGP neighbors configured to use the MTR topology named VIDEO.
Router# show ip bgp topology VIDEO summary
BGP router identifier 192.168.3.1, local AS number 45000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.1.2 4 45000 289 289 1 0 0 04:48:44 0
192.168.3.2 4 50000 3 3 1 0 0 00:00:27 0
Table 3 describes the significant fields shown in the display.
The following is partial output for the show ip bgp topology command when the neighbors keyword is used. Information is displayed for each neighbor that is configured to use the topology named VIDEO, and the output is similar to the output for the show ip bgp neighbors command with the addition of topology-related information.
Router# show ip bgp topology VIDEO neighbors
BGP neighbor is 172.16.1.2, remote AS 45000, internal link
BGP version 4, remote router ID 192.168.2.1
BGP state = Established, up for 04:56:30
Last read 00:00:23, last write 00:00:21, hold time is 180, keepalive interval is 60 seconds
Neighbor sessions:
1 active, is multisession capable
Neighbor capabilities:
Route refresh: advertised and received(new)
Message statistics, state Established:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 296 296
Route Refresh: 0 0
Total: 297 297
Default minimum time between advertisement runs is 0 seconds
For address family: IPv4 Unicast topology VIDEO
Session: 172.16.1.2 session 1
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Topology identifier: 100
.
.
.
Address tracking is enabled, the RIB does have a route to 172.16.1.2
Address tracking requires at least a /24 route to the peer
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Minimum incoming TTL 0, Outgoing TTL 255
Local host: 172.16.1.1, Local port: 11113
Foreign host: 172.16.1.2, Foreign port: 179
.
.
.
BGP neighbor is 192.168.3.2, remote AS 50000, external link
BGP version 4, remote router ID 192.168.3.2
BGP state = Established, up for 00:08:24
Last read 00:00:21, last write 00:00:20, hold time is 180, keepalive interval is 60 seconds
Neighbor sessions:
1 active, is multisession capable
Neighbor capabilities:
Route refresh: advertised and received(new)
Message statistics, state Established:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 10 10
Route Refresh: 0 0
Total: 11 11
Default minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast topology VIDEO
Session: 192.168.3.2 session 1
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 2, Offset 0, Mask 0x4
2 update-group member
Topology identifier: 100
.
.
.
Address tracking is enabled, the RIB does have a route to 192.168.3.2
Address tracking requires at least a /24 route to the peer
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Minimum incoming TTL 0, Outgoing TTL 1
Local host: 192.168.3.1, Local port: 11133
Foreign host: 192.168.3.2, Foreign port: 179
.
.
.
Table 4 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
topology (BGP) |
Configures a BGP routing process to route IP for a specified MTR topology instance. |
show ip eigrp topology
To display entries in the Enhanced Interior Gateway Routing Protocol (EIGRP) topology table, use the show ip eigrp topology command in privileged EXEC mode.
show ip eigrp [vrf {vrf-name | *}] [autonomous-system-number] topology [ip-address [mask]] | [name] [active | all-links | detail-links | pending | summary | zero-successors]
Syntax Description
Command Default
If this command is used without any optional keywords, then only topology entries with feasible successors are displayed and only the feasible paths are shown.
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Us the show ip eigrp topology command to display topology entries, feasible and non-feasible paths, metrics, and states. This command can be used without any keywords or arguments, in which case only topology entries with feasible successors are displayed, and only the feasible paths are shown. The all-links keyword displays all paths, whether feasible successors or not, and the detail-links keyword displays additional detail about these paths.
This command can be used to display information about EIGRP named configurations and EIGRP autonomous-system (AS) configurations.
This command displays the same information as the show eigrp address-family topology command. Cisco recommends using the show eigrp address-family topology command.
Examples
The following is sample output from the show ip eigrp topology command:
Router# show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status, s - sia status
P 10.0.0.0/8, 1 successors, FD is 409600
via 1.1.1.2 (409600/128256), Ethernet0/0
P 172.16.1.0/24, 1 successors, FD is 409600
via 1.1.1.2 (409600/128256), Ethernet0/0
P 10.0.0.0/8, 1 successors, FD is 281600
via Summary (281600/0), Null0
P 10.0.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
The following example displays detailed information for a single prefix. The prefix shown is an EIGRP internal route:
Router# show ip eigrp topology 10.0.0.0/8
EIGRP-IPv4 Topology Entry for AS(1)/ID(10.0.0.1) for 10.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Descriptor Blocks:
10.0.0.2 (Ethernet0/0), from 10.0.1.2, Send flag is 0x0
Composite metric is (409600/128256), route is Internal
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 10.0.1.2
The following example displays detailed information for a single prefix. The prefix shown is an EIGRP external route:
Router# show ip eigrp topology 172.16.1.0/24
EIGRP-IPv4 Topology Entry for AS(1)/ID(10.0.0.1) for 10.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Descriptor Blocks:
10.0.0.2 (Ethernet0/0), from 10.0.1.2, Send flag is 0x0
Composite metric is (409600/128256), route is External
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 10.0.1.2
External data:
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
The following example demonstrates the all-links keyword, which displays all paths, even those that are not feasible:
Router# show ip eigrp topology all-links
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.16.1.0/24, 1 successors, FD is 409600, serno 14
via 10.10.1.2 (409600/128256), Ethernet0/0
via 10.1.04.3 (2586111744/2585599744), Serial3/0, serno 18
The following example demonstrates the detail-links keyword, which displays additional detail about the routes:
Router# show ip eigrp topology detail-links
EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 10.0.0.0/8, 1 successors, FD is 409600, serno 6
via 1.1.1.2 (409600/128256), Ethernet0/0
P 172.16.1.0/24, 1 successors, FD is 409600, serno 14
via 1.1.1.2 (409600/128256), Ethernet0/0
P 10.0.0.0/8, 1 successors, FD is 281600, serno 3
via Summary (281600/0), Null0
P 10.1.1.0/24, 1 successors, FD is 281600, serno 1
via Connected, Ethernet0/0
Table 5 describes the significant fields shown in the displays.
Related Commands
|
|
---|---|
show eigrp address-family topology |
Displays entries in the EIGRP topology table. |
show ip interface (MTR)
To display the usability status of interfaces configured for IP or to display IP traffic statistics for all interfaces or for a particular interface, use the show ip interface command in user EXEC or privileged EXEC mode.
show ip interface [type number] [topology {name | all | base}] [stats]
Syntax Description
Command Default
The Cisco IOS software automatically enters a directly connected route in the routing table if the interface is usable. A usable interface is defined as one that can send and receive packets. If an interface is not usable, the directly connected routing entry is removed from the routing table. Removing the entry allows the software to use dynamic routing protocols to determine backup routes to the network, if any.
If the interface can provide two-way communication, the line protocol is marked "up." If the interface hardware is usable, the interface is marked "up."
If you specify an optional interface type and number, you see information for that specific interface.
If you specify no optional arguments, you see information on all the interfaces.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
Use the show ip interface command to display IP traffic statistics. When the stats keyword is used by itself, this command displays IP traffic statistics without topology awareness (an aggregate of all topologies). When the topology keyword and name argument are used, the statistics are limited to the IP traffic for that specific topology. The topology base keyword is reserved for IPv4 unicast base topology. Use the all keyword to display all topologies.
There are no statistics collected for the interface by default. Statistics collection for Multi-Topology Routing (MTR) is enabled by using the ip topology-accounting command in interface configuration mode.
Examples
The following is sample output from the show ip interface command:
Router# show ip interface FastEthernet 1/10 stats
FastEthernet1/10
5 minutes input rate 0 bits/sec, 0 packet/sec,
5 minutes output rate 0 bits/sec, 0 packet/sec,
201 packets input, 16038 bytes
588 packets output, 25976 bytes
Table 6 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
ip topology-accounting |
Enables topology accounting for all IPv4 unicast topologies in the VRF associated with a particular interface. |
show ip ospf interface
To display interface information related to Open Shortest Path First (OSPF), use the show ip ospf interface command in user EXEC or privileged EXEC mode.
show ip ospf [process-id] interface [type number] [brief] [multicast] [topology {topology-name | base}]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Examples
The following is sample output from the show ip ospf interface command when Ethernet interface 0/0 is specified:
Router# show ip ospf interface ethernet 0/0
Ethernet0/0 is up, line protocol is up
Internet Address 192.168.254.202/24, Area 0
Process ID 1, Router ID 192.168.99.1, Network Type BROADCAST, Cost: 10
Topology-MTID Cost Disabled Shutdown Topology Name
0 10 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.99.1, Interface address 192.168.254.202
Backup Designated router (ID) 192.168.254.10, Interface address 192.168.254.10
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.254.10 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Cisco IOS Release 12.2(33)SRB
The following sample output from the show ip ospf interface brief topology VOICE command shows a summary of information, including a confirmation that the Multitopology Routing (MTR) VOICE topology is configured in the interface configuration:
Router# show ip ospf interface brief topology VOICE
VOICE Topology (MTID 10)
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 1 0 10.0.0.2/32 1 LOOP 0/0
Se2/0 1 0 10.1.0.2/30 10 P2P 1/1
The following sample output from the show ip ospf interface topology VOICE command displays details of the MTR VOICE topology for the interface. When the command is entered without the brief keyword, more information is displayed.
Router# show ip ospf interface topology VOICE
VOICE Topology (MTID 10)
Loopback0 is up, line protocol is up
Internet Address 10.0.0.2/32, Area 0
Process ID 1, Router ID 10.0.0.2, Network Type LOOPBACK
Topology-MTID Cost Disabled Shutdown Topology Name
10 1 no no VOICE
Loopback interface is treated as a stub Host Serial2/0 is up, line protocol is up
Internet Address 10.1.0.2/30, Area 0
Process ID 1, Router ID 10.0.0.2, Network Type POINT_TO_POINT
Topology-MTID Cost Disabled Shutdown Topology Name
10 10 no no VOICE
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.0.0.1
Suppress hello for 0 neighbor(s)
Cisco IOS Release 12.2(33)SRC
The following sample output from the show ip ospf interface command displays details about the configured Time-to-Live (TTL) limits:
Router# show ip ospf interface ethernet 0
.
.
.
Strict TTL checking enabled
! or a message similar to the following is displayed
Strict TTL checking enabled, up to 4 hops allowed
.
.
.
Table 7 describes the significant fields shown in the displays.
show ip ospf topology-info
To display Open Shortest Path First (OSPF) details about the topologies configured under the OSPF protocol instance, use the show ip ospf topology-info command in privileged EXEC mode.
show ip ospf [process-id] topology-info [multicast] [topology {topology-name | base}]
Syntax Description
Command Modes
Privileged EXEC
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Examples
The following example shows information about an OSPF routing process under the VOICE topology:
Router# show ip ospf topology-info topology VOICE
OSPF Router with ID (10.0.0.2) (Process ID 1)
VOICE Topology (MTID 10)
Topology priority is 120
Number of areas transit capable is 0
Initial SPF schedule delay 10 msecs
Minimum hold time between two consecutive SPFs 20 msecs
Maximum wait time between two consecutive SPFs 20000 msecs
Area BACKBONE(0)
SPF algorithm last executed 15:05:41.808 ago
SPF algorithm executed 9 times
Area ranges are
Table 8 describes the significant fields shown in the display.
show ip protocols topology
To display the configuration and state of active routing protocol processes under a topology instance, use the show ip protocols topology command in user EXEC or privileged EXEC mode.
show ip protocols topology topology-name [summary]
Syntax Description
topology-name |
Name of the topology. |
summary |
(Optional) Displays summary information. |
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The show ip protocols topology command is used to display general routing information and routing protocol status under a topology instance. The topology name must be specified when entering this command.
Examples
The following example shows information about an OSPF routing process under the DATA topology:
Router# show ip protocols topology DATA
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 10.1.1.253
It is an autonomous system boundary router
Redistributing External Routes from,
Number of areas in this router is 3. 3 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)
Table 9 describes the significant fields shown in the display.
The following example displays summary information about the topology DATA:
Router# show ip protocols topology DATA summary
Index Process Name
0 connected
1 static
2 ospf 1
*** IP Routing is NSF aware ***
Table 10 describes the significant fields shown in the display.
Table 10 show ip protocols topology summary Field Descriptions
|
|
---|---|
Index Process Name |
Displays route source type and number of associated routes. |
IP Routing is NSF aware |
Indicates that the Cisco IOS software image is NSF aware. |
Related Commands
show ip route multicast
To display multicast routes in the routing table, use the show ip route multicast command in user EXEC or privileged EXEC mode.
show ip route multicast [vrf vrf-name] [host-name | ip-address [mask] [longer-prefixes]] [connected | protocol | static | summary | supernets-only | track-table]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show ip route multicast command to display multicast routes in the routing table.
Examples
The following example shows how to display a summary of multicast routes:
Router# show ip route multicast summary
IP routing table name is multicast (0x8000)
IP routing table maximum-paths is 32
Route Source Networks Subnets Replicates Overhead Memory (bytes)
connected 0 0 0 0 0
static 0 0 0 0 0
internal 0 20
Total 0 0 0 0 20
Table 11 describes the significant fields shown in the display.
Table 11 show ip route multicast summary Field Descriptions
show ip route topology
To display entries in a topology routing table, use the show ip route topology command in user EXEC or privileged EXEC mode.
show ip route topology topology-name [hostname | ip-address [mask] [longer-prefixes]] [connected | protocol | static | summary | supernets-only | track-table]
Syntax Description
Command Default
No default behavior or values
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The show ip route topology command is used to display routes installed in a topology routing table. The topology name must be specified when you enter this command.
Examples
The following example displays information for the 10.2.1.1 route under the DATA topology:
Router# show ip route topology DATA 10.2.1.1
Routing entry for 10.2.1.1/32
Known via "connected", distance 0, metric 0 (connected)
Routing Descriptor Blocks:
* directly connected, via Ethernet1/0
Route metric is 0, traffic share count is 1
Table 12 describes the significant fields shown in the display.
The following examples show the routing table of the DATA topology:
Router# show ip route topology DATA
Routing Table: DATA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
10.3.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.3.2.0/24 is directly connected, Ethernet2/0
L 10.3.2.1/32 is directly connected, Ethernet2/0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.1.1.0/25 is directly connected, Ethernet0/0
L 10.1.1.1/32 is directly connected, Ethernet0/0
C 10.1.1.128/25 is directly connected, Loopback0
L 10.1.1.253/32 is directly connected, Loopback0
C 10.2.1.0/25 is directly connected, Ethernet1/0
L 10.2.1.1/32 is directly connected, Ethernet1/0
Table 13 describes the significant fields shown in the display.
Related Commands
show ip static route
To display the static process local Routing Information Base (RIB) information, use the show ip static route command in user EXEC or privileged EXEC mode.
show ip static route [bfd] [vrf vrf-name] [topology topology-name] [ip-address [mask]] [multicast] [summary]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Examples
The following is sample output from the show ip static route command:
Router# show ip static route
Codes: M - Manual static, A - AAA download, N - IP NAT, D - DHCP,
G - GPRS, V - Crypto VPN, C - CASA, P - Channel interface processor,
B - BootP, S - Service selection gateway
DN - Default Network, T - Tracking object
L - TL1, E - OER
Codes in []: A - active, N - non-active, P - permanent
Cisco IOS Release 12.2(33)SRC
The following is sample output for the show ip static route command:
Router# show ip static route
Codes: M - Manual static, A - AAA download, N - IP NAT, D - DHCP,
G - GPRS, V - Crypto VPN, C - CASA, P - Channel interface processor,
B - BootP, S - Service selection gateway
DN - Default Network, T - Tracking object
L - TL1, E - OER
Codes in []: A - active, N - non-active, B - BFD-tracked, P - permanent
Static local RIB for default
M 10.2.2.2/32 [1/0] via Serial2/0 192.168.201.2 [N B]
M 10.0.0.0/8 [1/0] via Serial2/0 192.168.202.2 [N B]
M 10.2.0.0/8 [1/0] via Loopback0 [A]
Table 14 describes the significant fields shown in the display.
show ip static route summary
To display a global summary of the static process local Routing Information Base (RIB), use the show ip static route summary command in user EXEC or privileged EXEC configuration mode.
show ip static route summary
Syntax Description
This command has no arguments or keywords.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Examples
The following example shows a global summary of the static routes:
Router# show ip static route summary
Allow inter-vrf: yes
Number of download routes: 0
Number of static routes: 20
Number of per user routes: 5
Download route version: 0
Table 15 describes the significant fields shown in the display.
show ip traffic (MTR)
To display statistics about IP traffic, use the show ip traffic command in privileged EXEC mode.
show ip traffic [topology {name | all | base}]
Syntax Description
Command Default
Statistics for all topologies are displayed.
Command Modes
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
Use the show ip traffic command to display global IP traffic statistics (an aggregation of all the topologies when Multi-Topology Routing [MTR] is enabled) or statistics related to a particular topology. The base keyword is reserved for the IPv4 unicast base topology. The all keyword displays all topologies.
Examples
The following is sample output from the show ip traffic command for the VOICE topology:
Router# show ip traffic topology VOICE
Topology: VOICE
5 minute input rate 0 bits/sec, 0 packet/sec,
5 minute output rate 0 bits/sec, 0 packet/sec,
100 packets input, 6038 bytes,
88 packets output, 5976 bytes.
Table 16 describes the significant fields shown in the display.
show isis neighbors
To display information about Intermediate System-to-Intermediate System (IS-IS) neighbors, use the show isis neighbors command in privileged EXEC mode.
show isis neighbors [detail]
Syntax Description
detail |
(Optional) Displays more detailed information for IS-IS neighbors. |
Command Default
Brief information for IS-IS neighbors is displayed.
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
The show isis neighbors command is used to display brief information about connected IS-IS routers. Enter the detail keyword to display more detailed information.
Examples
Release 12.0(29)S
The show isis neighbors command is entered to display information about the IS-IS neighbor Router1.
Router5# show isis neighbors
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 28 R5.02
Thee show isis neighbors detail command is entered to display more detailed information about the IS-IS neighbor Router1.
Router5# show isis neighbors detail
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 22 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V
Release 12.2(33)SRB
The show isis neighbors detail command is entered to verify the status of the IS-IS neighbor Router1 for a network that has MTR configured. For each of the topologies - unicast, DATA and VOICE, the interface information is displayed.
Router5# show isis neighbors detail
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0005 L2 Et0/0 192.168.128.2 UP 28 R5.01
Area Address(es): 33
SNPA: aabb.cc00.1f00
State Changed: 00:07:05
LAN Priority: 64
Format: Phase V
Remote TID: 100, 200
Local TID: 100, 200
Table 17 describes the significant fields shown in the display.
show mtm table
To display information about the classifier values and the DiffServ Code Point (DSCP) values assigned to each topology, use the show mtm table command in user EXEC or privileged EXEC mode.
show mtm table
Syntax Description
This command has no arguments or keywords.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The show mtm table command shows the DSCP bits and classifier values that are mapped to the topologies for Multi-Topology Routing (MTR). The DSCP bits are used to mark the packet and assign traffic to a topology.
Examples
The following example displays the classifier and DSCP values for the VOICE and VIDEO topologies:
Router# show mtm table
MTM Table for VRF: default, ID:0
Topology Address Family Associated VRF Topo-ID
base ipv4 default 0
VOICE ipv4 default 2051
Classifier: ClassID:3
DSCP: cs1
DSCP: 9
VIDEO ipv4 default 2054
Classifier: ClassID:4
DSCP: af11
Table 18 describes the significant fields shown in the display.
show policy-map type class-routing ipv4 unicast
To display class-routing policy map information for Multi-Topology Routing (MTR), use the show policy-map type class-routing ipv4 unicast command in privileged EXEC mode.
show policy-map type class-routing ipv4 unicast [interface [interface-type interface-number]]
Syntax Description
interface |
(Optional) Displays statistics on all interfaces under the global space. |
interface-type interface-number |
(Optional) Displays statistics on a specific interface. |
Command Modes
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Examples
The following example shows that the policy map MTR is attached to the voice and video topologies:
Router# show policy-map type class-routing ipv4 unicast
Policy Map type class-routing ipv4 unicast MTR
Class VOICE-CLASS
select-topology voice
Class VIDEO-CLASS
select-topology video
The following example shows statistics about the policy map named MTR and the voice and video topologies. The number of packets and total bytes on a per-class and per-interface basis are shown. There is also further granularity in the display output by showing per match statement statistics:
Router# show policy-map type class-routing ipv4 unicast interface ethernet 0/0
Service-policy: MTR
Class-map: VOICE-CLASS (match-any)
10 packets, 600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp cs1 (8)
10 packets, 600 bytes
5 minute rate 0 bps
select-topology voice
Class-map: VIDEO-CLASS (match-any)
15 packets, 900 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp af43
15 packets, 900 bytes
5 minute rate 0 bps
select-topology video
Table 19 describes the significant fields shown in the display.
show snmp context mapping
To display information about Simple Network Management Protocol (SNMP) context mappings for Multi-Topology Routing (MTR), use the show snmp context mapping command in privileged EXEC mode.
show snmp context mapping
Syntax Description
This command has no arguments or keywords.
Command Default
No default behavior or values.
Command Modes
Privileged EXEC
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Usage Guidelines
The SNMP agent software component on the router can be configured to pass a context string to existing MIB access functions by using the snmp context command. Network management applications can provide these context strings in SNMP transactions to direct those transactions to a specific virtual private network (VPN) routing and forwarding (VRF) instance, a specific topology, and/or routing protocol instance. The show snmp context mapping command displays information about the mapping of the context to the VRF, address family, topology, and protocol.
Examples
The following example displays the mapping of the context to the topology and protocol instance:
Router# show snmp context mapping
Context: ospf-voice
VRF Name:
Address Family Name: ipv4
Topology Name: voice
Protocol Instance: OSPF-3 Router
Context: context-ospf
VRF Name:
Address Family Name:
Topology Name:
Protocol Instance: OSPF-3 Router
Context: context-vrfA
VRF Name: vrfA
Address Family Name:
Topology Name:
Protocol Instance:
Context: context-voice
VRF Name:
Address Family Name: ipv4
Topology Name: voice
Protocol Instance:
Table 20 describes the significant fields shown in the display.
Related Commands
|
|
---|---|
snmp context |
Creates an SNMP context for MTR. |
show topology
To display status and configuration information for topologies configured with Multi-Topology Routing (MTR), use the show topology command in privileged EXEC mode.
show topology [cache [topology-id] | ha | [detail | interface | lock | router] [all | ipv4 | ipv6 | vrf vpn-instance]]}
Syntax Description
Command Default
Information about all topologies is displayed.
Command Modes
Privileged EXEC (#)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The show topology command is used to display configuration information for MTR. The output displays global mode, interface mode, and router mode configurations. The output can be filtered to display information for only specific address families and subaddress families or specific topologies.
Examples
The following example shows the topology name and status of base and class-specific topologies:
Router# show topology
Topology Address Family Associated VRF State
base ipv4 default UP
VOICE ipv4 default UP
base default UP
Table 21 describes the significant fields shown in the display.
The following example shows detailed information about base and class-specific topologies:
Router# show topology detail
Topology: base
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet1/0, operation state: DOWN
Serial2/0, operation state: DOWN
Serial3/0, operation state: UP
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
Topology: base
Address-family:
Associated VPN VRF is default
Topology state is UP
Route Replication Enabled:
from unicast all
Associated interfaces:
Ethernet0/0, operation state: UP
Table 22 describes the significant fields shown in the display.
The following example shows information about the status of topologies on a route. The additional fields here show which IP routing protocols are configured for each topology.
Router# show topology router
Topology: base
Address-family: ipv4
Associated VPN VRF is default
OSPF 2 Area 0
IS-IS [name] Level-1
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
OSPF 2 Area 0
IS-IS [name] Level-1
Topology: base
Address-family: IPv4 multicast
Associated VPN VRF is default
OSPF 2 Area 0
IS-IS [name] Level-1
The following example shows information about the status of each interface that is associated with a topology:
Router# show topology interface
Topology: base
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
OSPF 2 metric: 10 state: UP
IS-IS [name] metric (10,10) state: UP
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
OSPF 2 metric: 10 state: UP
IS-IS [name] metric (10,10) state: UP
Topology: base
Address-family: IPv4 multicast
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
OSPF 2 metric: 10 state: UP
IS-IS [name] metric (10,10) state: UP
Related Commands
shutdown (MTR)
To temporarily disable a topology instance without removing the topology configuration, use the shutdown command in address family topology configuration mode. To restart the topology instance, use the no form of this command.
shutdown
no shutdown
Syntax Description
This command has no arguments or keywords.
Command Default
The default state is enabled.
Command Modes
Address family topology configuration (config-af-topology)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The shutdown (MTR) command is used to temporarily disable a topology without removing the topology configuration from the router. This command is useful for initial topology configuration. The topology can be placed in a shutdown state until the configuration is complete and the topology is ready to be deployed.
A topology is operationally disabled when it is shut down. No routing or forwarding occurs, and routing and forwarding tables are either empty or nonexistent when a topology is in a shutdown state.
Note A topology cannot be placed in the shutdown state if referenced by any active policy map.
Examples
The following example configures the router to temporarily place the VOICE topology in a shutdown state:
Router(config)# global-address-family ipv4
Router(config-af)# topology VOICE
Router(config-af-topology)# all-interfaces
Router(config-af-topology)# forward-base
Router(config-af-topology)# shutdown
Router(config-af-topology)# end
Related Commands
snmp context
To create a Simple Network Management Protocol (SNMP) context for Multi-Topology Routing (MTR) or for virtual networking, use the snmp context command in the appropriate command mode. To delete an SNMP context, use the no form of this command.
For SNMP V1 or V2c
snmp context context-name [community community-name [ro | rw]]
For SNMP V3
snmp context context-name [user username [credential | [encrypted] [auth {md5 password | sha password}] [access {access-list-number| access-list-name | ipv6 access-list-name}]]]
no snmp context context-name
Syntax Description
Command Default
No SNMP contexts are configured.
Command Modes
Address family configuration (config-router-af)
Router address family topology configuration (config-router-af-topology)
Router configuration (config-router)
VRF address family configuration (config-vrf-af)
VRF configuration (config-vrf)
Command History
Usage Guidelines
When you use the no snmp context command, all SNMP instances in that context are deleted.
Examples
The following example shows how to create an SNMP context to be associated with VPN companyA:
Router(config)# ip vrf companyA
Router(config-vrf)# snmp context contextA
The following example shows how to create an SNMP context in VRF address family configuration mode to be associated with VPN companyA:
Router(config)# vrf definition companyA
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# snmp context contextA
Related Commands
topology (BGP)
To configure a Border Gateway Protocol (BGP) routing process to route IP traffic for the specified topology instance and to enter router scope address family topology configuration mode, use the topology command in router scope address family configuration mode. To disassociate the BGP routing process from the topology instance, use the no form of this command.
topology {topology-name | base}
no topology {topology-name | base}
Syntax Description
topology-name |
Name of a class-specific topology. The topology-name argument is case-sensitive. |
base |
Specifies the base topology. |
Command Default
No default behavior or values
Command Modes
Router scope address family configuration
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Usage Guidelines
The topology (BGP) command is used in a Multi-Topology Routing (MTR) configuration to enable a specific topology inside a BGP address family session. Command configurations after the topology command is entered apply only to the topology instance. The topology must first be defined globally using the global-address-family command in global configuration mode before the topology can be configured under the BGP routing session. The topology (BGP) command is entered under a BGP router scope hierarchy that includes an address family configuration.
Examples
The following example configures a BGP peering session with the 192.168.3.2 neighbor under the VOICE topology:
Router(config)# global-address-family ipv4
Router(config-af)# topology VOICE
Router(config-af-topology)# all-interfaces
Router(config-af-topology)# exit
Router(config-af)# exit
Router(config)# router bgp 45000
Router(config-router)# scope global
Router(config-router-scope)# bgp default ipv4-unicast
Router(config-router-scope)# neighbor 192.168.3.2 remote-as 50000
Router(config-router-scope)# address-family ipv4 unicast
Router(config-router-scope-af)# topology VOICE
Router(config-router-scope-af-topo)# bgp tid 100
Router(config-router-scope-af-topo)# neighbor 192.168.3.2 activate
Router(config-router-scope-af-topo)# end
Related Commands
topology (EIGRP)
To configure an Enhanced Interior Gateway Routing Protocol (EIGRP) process to route IP traffic under the specified topology instance and to enter address-family topology configuration mode, use the topology command in address-family configuration mode. To disassociate the EIGRP routing process from the topology instance, use the no form of this command.
topology {base | topology-name tid number}
no topology topology-name
Syntax Description
Command Default
EIGRP routing processes are not configured to route IP traffic under a topology instance.
Command Modes
Address-family configuration (config-router-af)
Command History
Usage Guidelines
The topology command is used in a Multi-Topology Routing (MTR) configuration to enable an EIGRP process under the specified topology. The topology command is entered under address-family configuration mode. Command configurations are applied only to the topology instance. The topology must be defined globally with the global-address-family command in global address-family configuration mode before the topology can be configured under the EIGRP process.
The tid keyword associates an ID with the topology instance. Each topology must be configured with a unique topology ID. The topology ID is used to identify and group Network Layer Reachability Information (NLRI) for each topology in EIGRP updates.
The topology ID must be consistent across routers so that EIGRP can correctly associate topologies.
Examples
The following example configures EIGRP process 1 to route traffic for the 192.168.0.0/16 network under the VOICE topology instance:
Router(config)# router eigrp 1
Router(config-router)# address-family ipv4 unicast autonomous-system 3
Router(config-router-af)# topology VOICE tid 100
Router(config-router-af-topology)# no auto-summary
Router(config-router-af-topology)# network 192.168.0.0 0.0.255.255
Router(config-router-af-topology)# end
Related Commands
topology (global)
To configure a global topology instance and enter routing topology configuration mode, use the topology command in global address family configuration mode. To disable the topology instance and remove from the router configuration, use the no form of this command.
topology {base | topology-name}
no topology {base | topology-name}
Syntax Description
Command Default
No global topology instances are configured.
Command Modes
Global address family configuration (config-af)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The topology (global) command is used to configure a topology instance and enter routing topology configuration mode. Up to 32 unicast and a single multicast topology can be configured on a router. In routing topology configuration mode, the following global topology configuration parameters are applied:
•Global interface configuration—The topology is configured on all interfaces by entering the all-interfaces command. All interfaces are removed from the topology by entering the no form of this command, which is the default.
•Forwarding mode—The method that the router uses to look up forwarding entries in the FIB is configured by entering the forward-base command. Entering this command enables "incremental" forwarding mode. Entering the no form enables "strict" forwarding mode, which is the default. In strict mode, the router will look for a forwarding entry only within the class-specific topology FIB. If an entry is not found, the packet is dropped. In incremental mode, the router will first look in the class-specific topology FIB. If a covering forwarding entry is not found, the router will then look in the base topology FIB.
•Maximum route limit—A limit for the number of routes that will be permitted in the topology and installed to the topology RIB is configured by entering the maximum routes (MTR) command. This functionality is similar to routing and VPN maximum route features. No limit is the default.
Note Per-interface topology configuration parameters override configurations applied in global address family topology configuration and routing topology configuration mode.
Examples
The following example creates a topology instance named VOICE. The router is configured to use incremental forwarding mode and to generate warning messages when 1000 routes have been accepted/installed in the VOICE topology RIB:
Router(config)# global-address-family ipv4
Router(config-af)# topology VOICE
Router(config-af-topology)# forward-base
Router(config-af-topology)# maximum routes 1000 warn-only
Related Commands
topology (interface)
To configure a Multi-Topology routing (MTR) topology instance on an interface, use the topology command in interface configuration mode. To disable the topology interface configuration and configure the router to use global defaults, use the no form of this command.
topology ipv4 [multicast | unicast] {topology-name [disable] | base}
no topology ipv4 [multicast | unicast] {topology-name [disable] | base}
Syntax Description
Command Default
Unicast subaddress family configuration mode is entered when no subaddress family is specified.
No interfaces are included in class-specific topologies unless explicitly configured.
Configuration applied with the all-interfaces command in routing topology configuration does not override individual interface configuration applied in interface topology configuration mode.
Command Modes
Interface configuration (config-if)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The topology command is used to apply specific topology configuration at the interface level. The address family must be specified when this command is entered. The subaddress family can be optionally specified. Entering this command in Interface configuration mode places the router in interface topology configuration mode. In this mode, Enhanced Interior Gateway Routing Protocol (EIGRP), Intermediate System-to-Intermediate System, and Open Shortest Path First (OSPF) interface-specific configuration can be applied.
Disabling a Topology Under an Interface
An interface topology configuration can be disabled or an interface can be excluded from global topology configuration by entering this command with the disable keyword. Entering the disable keyword for a base topology removes only specific base topology configuration that applies to a class-specific topology.
Examples
The following example applies an OSPF cost of 10 to routes learned through the topology VOICE. This configuration also disables the multicast topology VIDEO.
Router(config)# interface Ethernet 0/0
Router(config-if)# topology ipv4 VOICE
Router(config-if-topology)# ip ospf cost 10
Router(config-if-topology)# exit
Router(config-if)# topology ipv4 multicast VIDEO disable
Router (config-if)#
end
Related Commands
topology (IS-IS)
To configure Intermediate System-to-Intermediate System (IS-IS) Multi-Topology Routing (MTR) support for a non-base topology or to enter a configuration sub-mode specific to an IPv4 multicast base topology, use the topology command in router address family configuration mode.
MTR Unicast for IPv4 or IPv6
topology topology-name tid number
MTR Multicast for IPv4
topology base
Syntax Description
Command Default
No default behavior or values
Command Modes
Router address family configuration
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
The topology command is used in an MT configuration to enable an IS-IS instance under the base topology for IPv4 multicast, or to configure IS-IS support for a non-base topology. The topology command is entered under an address family configuration. Command configurations are applied to only the topology instance. The topology must be defined globally with the global-address-family command in global configuration mode before the topology can be configured under the IS-IS instance.
The tid keyword associates an ID with the topology instance. Each topology must be configured with a unique topology ID. The topology ID is used to identify and group Network Layer Reachability Information (NLRI) for each topology in IS-IS updates.
Examples
The following example configures the IS-IS DATA topology with a TID value of 200 for IPv4 unicast:
router isis
net 33.3333.3333.3333.00
metric-style wide
address-family ipv4 unicast
topology DATA tid 200
end
The topology command is entered with the base keyword to specify the base topology for IPv4 multicast base topology:
router isis
net 33.3333.3333.3333.00
metric-style wide
address-family ipv4 multicast
topology base
Related Commands
|
|
---|---|
address-family (IS-IS) |
Configures the exchange of address family and subaddress family prefixes. |
topology (interface) |
Configures an MTR topology instance on an interface. |
topology (OSPF)
To configure an Open Shortest Path First (OSPF) process to route IP traffic under the specified topology instance, use the topology command in address family configuration mode. To remove the OSPF routing process from the topology instance, use the no form of this command.
topology {base | topology-name tid number}
no topology {base | topology-name tid number}
Syntax Description
Command Default
OSPF assigns the ID number 0 to the base unicast topology and the number 1 to the base multicast topology.
Command Modes
Address family configuration
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
Usage Guidelines
The topology command is used in Multi-Topology Routing (MTR) configuration to enable an OSPF process under the specified topology. The topology command is entered under router address family configuration. Entering the topology command places the router in router address family topology configuration mode. Subsequent commands that are configured are applied to only the specified topology instance. The topology must be defined globally with the global-address-family command in global configuration mode before the topology can be configured under the OSPF process.
Multicast Base Topology
The base keyword is used to enter the base topology when a multicast subaddress family configuration is created. Entering the no form of this command for a multicast configuration does not remove the base topology, only the command configurations that were entered in this mode.
Note The base keyword is accepted for only IPv4 multicast. The tid keyword is accepted for only IPv4 and IPv6 unicast.
Topology ID
The topology ID must be specified with the tid keyword when this command is first entered. This keyword is optional for subsequent configuration. The topology ID cannot be changed after a topology instance is configured. You must first remove the topology instance from the router configuration and then reconfigure the topology instance with a new topology ID.
Examples
The following example creates the VOICE topology instance and configures the topology ID 100:
Router(config)# router ospf 1
Router(config-router)# address-family ipv4
Router(config-router-af)# topology VOICE tid 100
Router(config-router-af-topology)# end
Related Commands
|
|
---|---|
address-family (OSPF) |
Configures address family and subaddress family IP prefix exchange. |
topology-accounting
To enable topology accounting on all of the interfaces in the global address family for the default VRF instance, use the topology-accounting command in global address family configuration mode. To disable statistics collection from all interfaces that are part of default VRF, use the no form of this command.
topology-accounting
no topology-accounting
Syntax Description
This command has no arguments or keywords.
Command Default
No topology accounting statistics are collected.
Command Modes
Global address family configuration (config-af)
Command History
|
|
---|---|
12.2(33)SRB |
This command was introduced. |
12.2(33)SRE |
This command was integrated into Cisco IOS Release 12.2(33)SRE. |
Usage Guidelines
Use this command to enable topology accounting on all of the interfaces in the global address family for all IPv4 unicast topologies in the default VRF instance. Enabling this command does not impact interfaces in other VRF instances. Statistic collection is enabled and information is collected and accumulated from interfaces that belong in the default VRF and are participating in one or more IPv4 topologies.
The no form of this command disables statistics collection from all interfaces that are part of the default VRF instance. The no form of this command does not disable statistics collection from interfaces on which the ip topology-accounting command has been configured.
Examples
The following example shows how to enable topology accounting on all interfaces in the global address family for all IPv4 unicast topologies in the default VRF instance:
Router(config)# global-address-family ipv4
Router(config-af)# topology-accounting
Related Commands
|
|
---|---|
ip topology-accounting |
Enables topology accounting for all IPv4 unicast topologies in the VRF associated with a particular interface. |
traceroute
To discover the routes that packets will actually take when traveling to their destination address, use the traceroute command in user EXEC or privileged EXEC mode.
traceroute [vrf vrf-name | topology topology-name] [protocol] destination
Syntax Description
Command Default
When not specified, the protocol argument is determined by the software examining the format of the destination argument. For example, if the software finds a destination argument in IP format, the protocol value defaults to IP.
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
The traceroute command works by taking advantage of the error messages generated by routers when a datagram exceeds its hop limit value.
The traceroute command starts by sending probe datagrams with a hop limit of 1. Including a hop limit of 1 with a probe datagram causes the neighboring routers to discard the probe datagram and send back an error message. The traceroute command sends several probes with increasing hop limits and displays the round-trip time for each.
The traceroute command sends out one probe at a time. Each outgoing packet might result in one or more error messages. A time-exceeded error message indicates that an intermediate router has seen and discarded the probe. A destination unreachable error message indicates that the destination node has received and discarded the probe because the hop limit of the packet reached a value of 0. If the timer goes off before a response comes in, the traceroute command prints an asterisk (*).
The traceroute command terminates when the destination responds, when the hop limit is exceeded, or when the user interrupts the trace with the escape sequence. By default, to invoke the escape sequence, type Ctrl-^ X—by simultaneously pressing and releasing the Ctrl, Shift, and 6 keys, and then pressing the X key.
To use nondefault parameters and invoke an extended traceroute test, enter the command without a protocol or destination argument in privileged EXEC mode. You are stepped through a dialog to select the desired parameters. Extended traceroute tests are not supported in user EXEC mode. The user-level traceroute feature provides a basic trace facility for users who do not have system privileges. The destination argument is required in user EXEC mode.
If the system cannot map an address for a hostname, it returns a "%No valid source address for destination" message.
If the vrf vrf-name keyword and argument are used, the topology option is not displayed because only the default VRF is supported. The topology topology-name keyword and argument and the DiffServ Code Point (DSCP) option in the extended traceroute system dialog are displayed only if a topology is configured on the router.
In Cisco IOS XE Release 3.2S, output of the traceroute command with the vrf keyword was enhanced to make troubleshooting easier by displaying the incoming VRF name/tag and the outgoing VRF name/tag.
Examples
After you enter the traceroute command in privileged EXEC mode, the system prompts you for a protocol. The default protocol is IP.
If you enter a hostname or address on the same line as the traceroute command, the default action is taken as appropriate for the protocol type of that name or address.
The following example is sample dialog from the traceroute command using default values. The specific dialog varies somewhat from protocol to protocol.
Router# traceroute
Protocol [ip]:
Target IP address:
Source address:
DSCP Value [0]: ! Only displayed if a topology is configured on the router.
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose [none]:
The following example displays output available in Cisco IOS XE Release 3.2S and later. Output of the traceroute command with the vrf keyword includes the incoming VRF name/tag and the outgoing VRF name/tag.
Router# traceroute vrf red 10.0.10.12
Type escape sequence to abort.
Tracing the route to 10.0.10.12
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.13.15 (red/13,red/13) 0 msec
10.1.16.16 (red/13,red/13) 0 msec
10.1.13.15 (red/13,red/13) 1 msec
2 10.1.8.13 (red/13,red/13) 0 msec
10.1.7.13 (red/13,red/13) 0 msec
10.1.8.13 (red/13,red/13) 0 msec
3 10.1.2.11 (red/13,blue/10) 1 msec 0 msec 0 msec
4 * * *
Related Commands
|
|
ping (MTR) |
Pings a destination within a specific topology. |
use-topology
To configure a multicast topology to perform Reverse Path Forwarding (RPF) computations using a unicast topology Routing Information Base (RIB), use the use-topology command in address family topology configuration mode. To disable RPF computations using a unicast topology RIB, use the no form of this command.
use-topology unicast {base | topology-name}
no use-topology unicast {base | topology-name}
Syntax Description
unicast |
Specifies a unicast sub-address family. |
base |
Specifies a base topology. |
topology-name |
A class-specific unicast topology. |
Command Default
No default behavior or values.
Command Modes
Address family topology configuration (config-af-topology)
Command History
Usage Guidelines
When this command is configured, the multicast topology uses routes in the specified unicast topology table to build multicast distribution trees.
This multicast RIB is not used when this command is enabled, even if the multicast RIB is populated and supported by a routing protocol.
Examples
The following example shows how to configure a multicast topology to perform RPF computations using a unicast topology RIB:
Router(config)# ip multicast-routing
Router(config)# ip multicast rpf multitopology
Router(config)# global-address-family ipv4 multicast
Router(config-af)# topology base
Router(config-af-topology)# use-topology unicast base