- send-lifetime
- service-family
- service-family external-client listen
- sf-interface
- show eigrp plugins
- show eigrp protocols
- show eigrp service-family
- show eigrp service-family external-client
- show eigrp service-family ipv4 topology
- show eigrp service-family ipv6 topology
- show eigrp tech-support
- shutdown (service-family)
- split-horizon (EIGRP)
- timers graceful-restart purge-time
- topology
- username (SAF)
send-lifetime
To set the time period during which an authentication key on a key chain is valid to be sent, use the send-lifetime command in key chain key configuration mode. To revert to the default value, use the no form of this command.
send-lifetime start-time {infinite | end-time | duration seconds}
no send-lifetime [start-time {infinite | end-time | duration seconds}]
Syntax Description
Command Default
Forever (the starting time is January 1, 1993, and the ending time is infinite)
Command Modes
Key chain key configuration (config-keychain-key)
Command History
|
|
---|---|
11.1 |
This command was introduced. |
12.4(6)T |
Support for IPv6 was added. |
Usage Guidelines
Specify a start-time value and one of the following values: infinite, end-time, or duration seconds.
We recommend running Network Time Protocol (NTP) or some other time synchronization method if you intend to set lifetimes on keys.
If the last key expires, authentication will continue and an error message will be generated. To disable authentication, you must manually delete the last valid key.
Examples
The following example configures a key chain named chain1. The key named key1 will be accepted from 1:30 p.m. to 3:30 p.m. and be sent from 2:00 p.m. to 3:00 p.m. The key named key2 will be accepted from 2:30 p.m. to 4:30 p.m. and be sent from 3:00 p.m. to 4:00 p.m. The overlap allows for migration of keys or a discrepancy in the set time of the router. There is a 30-minute leeway on each side to handle time differences.
Router(config)# interface ethernet 0
Router(config-if)# ip rip authentication key-chain chain1
Router(config-if)# ip rip authentication mode md5
!
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
!
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600
The following example configures a key chain named chain1 for EIGRP address-family. The key named key1 will be accepted from 1:30 p.m. to 3:30 p.m. and be sent from 2:00 p.m. to 3:00 p.m. The key named key2 will be accepted from 2:30 p.m. to 4:30 p.m. and be sent from 3:00 p.m. to 4:00 p.m. The overlap allows for migration of keys or a discrepancy in the set time of the router. There is a 30-minute leeway on each side to handle time differences.
Router(config)# eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain trees
Router(config-router-af-interface)# authentication mode md5
Router(config-router-af-interface)# exit
Router(config-router-af)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600
The following named configuration example configures a key chain named chain1 for a Cisco SAF service family. The key named key1 will be accepted from 1:30 p.m. to 3:30 p.m. and be sent from 2:00 p.m. to 3:00 p.m. The key named key2 will be accepted from 2:30 p.m. to 4:30 p.m. and be sent from 3:00 p.m. to 4:00 p.m. The overlap allows for migration of keys or a discrepancy in the set time of the router. There is a 30-minute leeway on each side to handle time differences.
Router(config)# eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# network 10.0.0.0
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain trees
Router(config-router-sf-interface)# authentication mode md5
Router(config-router-sf-interface)# exit
Router(config-router-sf)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600
Related Commands
service-family
To configure virtual routing and forwarding (VRF) metrics for a Cisco SAF service-family, use the service-family ipv4 command in router configuration mode. To disable the service-family configuration, use the no form on this command.
service-family {ipv4 | ipv6} [vrf vrf-name] autonomous-system autonomous-system-number
no service-family {ipv4 | ipv6} [vrf vrf-name] autonomous-system autonomous-system-number
Syntax Description
Command Default
No service family configurations exist.
Command Modes
Router configuration (config-router)
Command History
Usage Guidelines
Use the service-family command to enter service-family configuration mode.
Note Using the service-family ipv6 commands requires an IPv6-enabled SAF client, which currently does not exist.
Examples
The following example configures a service-family autonomous-system number 4533:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Related Commands
|
|
---|---|
exit-service-family |
Exits service-family configuration mode. |
router eigrp |
Configures the EIGRP process. |
service-family external-client listen
To configure a Cisco SAF External-Client TCP port, use the service-family external-client listen command in global configuration mode. To remove the associated external-client configuration, use the no form on this command.
service-family external-client listen {ipv4 | ipv6} tcp-port-number vrf-name
no service-family external-client listen
Syntax Description
Command Default
No external-client configurations exist.
Command Modes
Global configuration (config)
Command History
Usage Guidelines
Use the service-family external-client listen command to configure a TCP port on which the Cisco SAF Forwarder is to listen. The no form of this command removes all clients from the Cisco SAF network, the External-Client database, tears down all sockets, and removes the TCP listen socket.
Note Using the service-family external-client listen ipv6 commands requires an IPv6-enabled SAF client, which currently does not exist.
Use the show eigrp service-family external-client command to verify information on EIGRP external clients.
Examples
The following example configures an external-client TCP port number 4355 for the Cisco SAF Forwarder to listen on:
Router(config)# service-family external-client listen ipv4 4355
Related Commands
|
|
---|---|
show eigrp service-family external-client |
Displays information on Cisco SAF External Clients. |
sf-interface
To configure interface-specific commands for a Cisco SAF service family, use the sf-interface command in service-family configuration mode. To disable the service-family mode, use the no form on this command.
sf-interface {interface-type interface-number | default}
no sf-interface {interface-type interface-number | default}
Syntax Description
interface-type |
Specifies the interface type. |
interface-number |
Specifies the interface number. |
default |
Specifies the service-family default interface configuration. |
Command Modes
Service-family configuration (config-router-sf)
Command History
Usage Guidelines
Use the sf-interface default command to set the Cisco SAF default configuration for all interfaces on the router.
Use the sf-interface interface-type interface-number command to apply a Cisco SAF configuration to a specific interface. Any configuration using this command overrides the default configuration.
Examples
The following example places a router in service-family configuration mode and enables Ethernet interface 0/0, while disabling all other interfaces:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface default
Router(config-router-sf-interface)# shutdown
Router(config-router-sf-interface)# Ethernet 0/0
Router(config-router-sf-interface)# no shutdown
Related Commands
show eigrp plugins
To display general information including the versions of the Enhanced Interior Gateway Routing Protocol (EIGRP) protocol features that are currently running, use the show eigrp plugins command in user EXEC or privileged EXEC mode.
show eigrp [vrf-name] [as-number] plugins [plugin-name] [detailed]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp plugins command in user EXEC or privileged EXEC mode to determine if a particular EIGRP feature is available in your Cisco IOS image. This command displays a summary of information about EIGRP service families and address families.
This command is useful when contacting Cisco technical support.
Examples
The following example shows how to display EIGRP plugin information:
Router# show eigrp plugins
EIGRP feature plugins:::
eigrp-release : 5.00.00 : Portable EIGRP Release
: 19.00.00 : Source Component Release(rel5)
igrp2 : 3.00.00 : Reliable Transport/Dual Database
bfd : 1.01.00 : BFD Platform Support
mtr : 1.00.01 : Multi-Topology Routing(MTR)
eigrp-pfr : 1.00.01 : Performance Routing Support
ipv4-af : 2.01.01 : Routing Protocol Support
ipv4-sf : 1.01.00 : Service Distribution Support
external-client : 1.02.00 : Service Distribution Client Support
ipv6-af : 2.01.01 : Routing Protocol Support
ipv6-sf : 1.01.00 : Service Distribution Support
snmp-agent : 1.01.01 : SNMP/SNMPv2 Agent Support
Table 2 describes the significant fields shown in the display.
Related Commands
show eigrp protocols
To display general information about Enhanced Interior Gateway Routing Protocol (EIGRP) protocols that are currently running, use the show eigrp protocols command in user EXEC or privileged EXEC mode.
show eigrp protocols [vrf vrf-name]
Syntax Description
vrf vrf-name |
(Optional) Displays information about the specified VRF. |
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp protocols command in user EXEC or privileged EXEC mode to see a summary of information on EIGRP IPv4 service families or address families.
Examples
The following example shows how to display general EIGRP information:
Router# show eigrp protocols
EIGRP-IPv4 Protocol for AS(10)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
EIGRP-IPv4 Protocol for AS(5) VRF(red)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 0
Total Redist Count: 0
The following example shows how to display general EIGRP information for VRF1:
Router# show eigrp protocols vrf vrf1
EIGRP-IPv4 Protocol for AS(5) VRF(vrf1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 1.1.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 0
Total Redist Count: 0
Table 3 describes the significant fields shown in the display.
Related Commands
show eigrp service-family
To display information for an Enhanced Interior Gateway Routing Protocol (EIGRP) IPv4 or IPv6 service family, use the show eigrp service-family command in user EXEC or privileged EXEC mode.
show eigrp service-family {ipv4 | ipv6} [vrf vrf-name] autonomous-system-number
{accounting |
clients [detail] |
events [starting-event-number ending-event-number] | [errmsg starting-event-number ending-event-number] | [type] |
interfaces [interface-type interface-number] | detail interface-type interface-number] |
neighbors [detail | interface-type interface-number] |
sia-event [starting-event-number ending-event-number] |
sia-statistics [ip-address] |
subscriptions [detail] |
timers |
traffic}
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Using show eigrp service-family ipv4 command in user EXEC or privileged EXEC mode to see a summary of information on EIGRP IPv4 service families.
Note Using the show eigrp service-family ipv6 commands requires an IPv6-enabled SAF client, which currently does not exist.
Examples
The following is sample output from the show eigrp service-family ipv4 accounting command:
Router> enable
Router# show eigrp service-family ipv4 4453 accounting
EIGRP-SFv4 VR(saf) Accounting for AS(22)/ID(10.0.0.1)
Total Prefix Count: 3 States: A-Adjacency, P-Pending, D-Down
State Address/Source Interface Prefix Restart Restart/ Count Reset(s)
A 10.0.0.2 Et0/0 2 0 0
Table 4 describes the significant fields shown in the show eigrp service-family ipv4 accounting command output.
The following is sample output from the show eigrp service-family ipv4 clients command:
Router> enable
Router# show eigrp service-family ipv4 autonomous-system 1 clients
EIGRP-SFv4 VR(saf) Clients for AS(1)ID(10.0.0.1)
Client Callback
Handle Name Context/pid/Registered (Y/N)
1 example 0x00000000/ 3/N
2 CME 0x00000000/ 3/N
The following is sample output from the show eigrp service-family ipv4 clients detail command:
Router> enable
Router# show eigrp service-family ipv4 autonomous-system 1 clients detail
EIGRP-SFv4 VR(saf) Clients for AS(1)ID(10.0.0.1)
Client Callback
Handle Name Context/pid/Registered (Y/N)
1 Test 0x00000000/ 3/N
Subscribed Services/Notifications: 0/0
Published Services/Size(kB): 0/0
Sequence Number Updated: 0
2 CME 0x00000000/ 3/N
Subscribed Services/Notifications: 1/1
Published Services/Size(kB): 1/2
Sequence Number Updated: 2
Table 5 describes the significant fields shown in the show eigrp service-family ipv4 clients command output.
The following is sample output from the show eigrp service-family ipv4 interfaces command:
Router> enable
Router# show eigrp service-family ipv4 4453 interfaces
EIGRP service-family neighbors for process 4453
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Services
Se0 1 0/0 28 0/15 127 0
Se1 1 0/0 44 0/15 211 0
The following is sample output from the show eigrp service-family ipv4 interfaces detail command:
Router> enable
Router# show eigrp service-family ipv4 4453 interfaces detail Loopback 1
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Services
Lo1 166 0/0 48 0/1 258 0
Hello-interval is 5, Hold-time is 15
Split-horizon is enabled
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 10148/67233
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 8719
Retransmissions sent: 2696 Out-of-sequence rcvd: 594
Interface has all stub peers
Topology-ids on interface - 0
Authentication mode is not set[GFM1]EIGRP service-family neighbors for process 4453
Table 6 describes the significant fields shown in the show eigrp service-family ipv4 interfaces command output.
The following is sample output from the show eigrp service-family ipv4 neighbors command:
Router> enable
Router# show eigrp service-family ipv4 4453 neighbors
EIGRP SFv4 VR(test) Service-Family Neighbors for AS(4453)
Address Interfaces Hold Uptime SRTT RTO Q Seq
(sec) ((sec) (msec) Cnt Num
10.1.1.1 Ethernet0/0 13 00:00:41 30 1014 0 16
10.1.2.1 Ethernet0/0 14 00:02:02 20 200 0 10
The following is sample output from the show eigrp service-family ipv4 neighbors detail command:
Router> enable
Router# show eigrp service-family ipv4 4453 neighbors detail
EIGRP SFv4 VR(test) Service-Family Neighbors for AS(4453)
Address Interfaces Hold Uptime SRTT RTO Q Seq
(sec) ((sec) (msec) Cnt Num
10.1.1.1 Ethernet0/0 14 00:00:41 1 3000 0 80
Version 5.0/3.0, Retrans: 1, Retries: 0
Topology-ids from peer - 0
Receive-Only Peer Advertising (No) Routes
Suppressing queries
10.1.2.1 Ethernet0/1 13 00:02:02 28 200 0 883
Version 5.0/3.0, Retrans: 1, Retries: 0, Prefixes: 1
Topology-ids from peer - 0
Stub Peer Advertising (CONNECYTED) Routes
Table 7 describes the significant fields shown in the show eigrp service-family ipv4 neighbors command output.
The following is sample output from the show eigrp service-family ipv4 traffic command:
Router> enable
Router# show eigrp service-family ipv4 4453 traffic
EIGRP service-family Traffic Statistics for process 4453
Hello sent/received: 218/205
Updates sent/received: 7/23
Queries sent/received: 2/0
Replies sent/received: 0/2
Acks sent/received: 21/14
SIA-Queries sent/received: 0/0
SIA-Replies sent/received 0/0
Hello Process ID: 121
PDM Process ID: 120
Socket Queue: 0/2000/2/0
(current/max/highest/drops)
Input Queue: 0/2000/2/0
(current/max/highest/drops)
Table 8 describes the significant fields shown in the show eigrp service-family ipv4 traffic command output.
Related Commands
show eigrp service-family external-client
To display information about Cisco Service Advertisement Framework (Cisco SAF) external clients, use the show eigrp service-family external-client command in user EXEC or privileged EXEC mode.
show eigrp service-family external-client [client-label]
Syntax Description
client-label |
(Optional) Displays detailed client information for the specified client label. |
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp service-family external-client command in user or privileged EXEC mode to see a summary of the information about Cisco SAF external clients that are currently registered with the Cisco SAF system.
Examples
The following is sample output from the show eigrp service-family external-client command if any clients are registered:
Router# show eigrp service-family external-client
SAF External Clients
example-using-basename (basename)
Client Socket Keep Address Port Tag
Handle FD (ms)
1 1 3268319 10.1.1.1 47519 @12
2 2 3268347 192.168.100.101 36997 @1
example-configured-but-no-clients-connected
No connected clients
example-client-without-basename
Client Socket Keep Address Port Tag
Handle FD (ms)
3 3 208373 10.1.1.2 51294 --
Table 9 describes the significant fields shown in the display.
The following is sample output from the show eigrp service-family external-client client-label command if the specified client is registered:
Router# show eigrp service-family external-client example-using-basename@12
SAF External Client "example-using-basename" (basename)
Listening on port 1024, keepalive time 3600000 ms
VR(saf) SFv4 AS(1) Topology(base)
Client Socket Keep Address Port Tag
Handle FD (ms)
1 1 3322871 10.1.1.1 47519 @12
Client name "thisistheclientnameweprovided"
Page size 1, currently allowed to send 1
Protocol version 1.0
2 subscriptions
Table 10 describes the significant fields shown in the display.
Related Commands
show eigrp service-family ipv4 topology
To display topology information for an Enhanced Interior Gateway Routing Protocol (EIGRP) IPv4 service family, use the show eigrp service-family ipv4 topology command in user EXEC or privileged EXEC mode.
show eigrp service-family ipv4 [vrf vrf-name] autonomous-system-number topology [service-instance-number |
active |
all-links |
detail-links |
pending
service-type [connected | external | internal | local | redistributed | summary] |
summary |
zero-successors]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp service-family ipv4 topology command in user EXEC or privileged EXEC mode to see a summary of information on EIGRP IPv4 service-families services.
Examples
The following is sample output from the show eigrp service-family ipv4 topology command:
Router> enable
Router# show eigrp service-family ipv4 4453 topology
EIGRP-SFv4 Topology Table for process 4453
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - Reply status
P 1:2:0.0.0.3, 2 successors, FD is 0
via 10.16.80.28 (46251776/46226176), Ethernet0
via 10.16.81.28 (46251776/46226176), Ethernet1
via 10.16.80.31 (46277376/46251776), Serial0
P 4:5:0.0.0.6, 1 successors, FD is 37200
via Connected, Ethernet1
via 10.16.81.28 (307200/281600), Ethernet1S
via 10.16.80.28 (307200/281600), Ethernet0
via 10.16.80.31 (332800/307200), Serial0
The following is sample output from the show eigrp service-family ipv4 topology command for a specified service:
Router> enable
Router# show eigrp service-family ipv4 4453 topology 1:2:0.0.0.3
EIGRP-SFv4 VR(example) Topology Table entry for AS(4453)/ID(10.1.1.1)1:2:0.0.0.3
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Service Description Blocks:
1:2:3.0.0.0.3 (Ethernet0/0), from 10.2.1.1, Send flag is 0x0
Composite metric is (409600/128256), Route is External
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 10.89.245.1
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - Reply status
P 1:2:0.0.0.3, 2 successors, FD is 0
via 10.16.80.28 (46251776/46226176), Ethernet0
via 10.16.81.28 (46251776/46226176), Ethernet1
via 10.16.80.31 (46277376/46251776), Serial0
P 4:5:0.0.0.6, 1 successors, FD is 37200
via Connected, Ethernet1
via 10.16.81.28 (307200/281600), Ethernet1S
via 10.16.80.28 (307200/281600), Ethernet0
via 10.16.80.31 (332800/307200), Serial0
Table 11 describes the significant fields shown in the show eigrp service-family ipv4 topology command output.
Related Commands
show eigrp service-family ipv6 topology
To display topology information for an Enhanced Interior Gateway Routing Protocol (EIGRP) IPv6 service family, use the show eigrp service-family ipv6 topology command in user EXEC or privileged EXEC mode.
show eigrp service-family ipv6 [vrf vrf-name] autonomous-system-number topology [service-instance-number |
active |
all-links |
detail-links |
pending
service-type [connected | external | internal | local | redistributed | summary] |
summary |
zero-successors]
Syntax Description
Command Modes
User EXEC (>)
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp service-family ipv6 topology command in user EXEC or privileged EXEC mode to see a summary of information on EIGRP IPv6 service-family topology services.
Note Using the show eigrp service-family ipv6 topology commands requires an IPv6-enabled SAF client, which currently does not exist.
Examples
The following is sample output from the show eigrp service-family ipv6 topology command:
Router> enable
Router# show eigrp service-family ipv6 4453 topology
EIGRP-SFv4 Topology Table for process 4453
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - Reply status
P 1:2:0.0.0.3, 2 successors, FD is 0
via 10.16.80.28 (46251776/46226176), Ethernet0
via 10.16.81.28 (46251776/46226176), Ethernet1
via 10.16.80.31 (46277376/46251776), Serial0
P 4:5:0.0.0.6, 1 successors, FD is 37200
via Connected, Ethernet1
via 10.16.81.28 (307200/281600), Ethernet1S
via 10.16.80.28 (307200/281600), Ethernet0
via 10.16.80.31 (332800/307200), Serial0
The following is sample output from the show eigrp service-family ipv6 topology command for a specified service:
Router> enable
Router# show eigrp service-family ipv6 4453 topology 1:2:0.0.0.3
EIGRP-SFv4 VR(example) Topology Table entry for AS(4453)
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Service Description Blocks:
1:2:3.0.0.0.3 (Ethernet0/0), from 10.2.1.1, Send flag is 0x0
Composite metric is (409600/128256), Route is External
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 10.89.245.1
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply, r - Reply status
P 1:2:0.0.0.3, 2 successors, FD is 0
via 10.16.80.28 (46251776/46226176), Ethernet0
via 10.16.81.28 (46251776/46226176), Ethernet1
via 10.16.80.31 (46277376/46251776), Serial0
P 4:5:0.0.0.6, 1 successors, FD is 37200
via Connected, Ethernet1
via 10.16.81.28 (307200/281600), Ethernet1S
via 10.16.80.28 (307200/281600), Ethernet0
via 10.16.80.31 (332800/307200), Serial0
Table 12 describes the significant fields shown in the show eigrp service-family ipv6 topology command output.
Related Commands
show eigrp tech-support
To generate a report of Enhanced Interior Gateway Routing Protocol (EIGRP) internal state information, use the show eigrp tech-support command in privileged EXEC mode.
show eigrp tech-support [detailed]
Syntax Description
detailed |
(Optional) Displays additional detail not shown with the basic command. |
Command Modes
Privileged EXEC (#)
Command History
Usage Guidelines
Use the show eigrp tech-support command in privileged EXEC mode to display various internal EIGRP states.
Note This command is useful for debugging and troubleshooting by Cisco technical support, but it is not intended for normal EIGRP administration tasks. This command should not be used without guidance from Cisco technical support.
Examples
The following is sample output from the show eigrp tech-support detailed command:
Router# show eigrp tech-support detailed
EIGRP Internal Process States
procinfoQ:
1: 0x54ABD10 vrid:2 afi:1 as:2 tableid:0 vrfid:0 tid:0 name:
topo_ddbQ(1) 0x55243E8 tableid:0 name:base
topo_ddbQ.count: 1
procinfoQ.count: 1
deadQ:
ddbQ:
1: 0x55243E8 name:base
ddbQ.count: 1
---------------------------------------------------------
EIGRP-IPv4 Protocol for AS(2)
{vrid:2 afi:1 as:2 tableid:0 vrfid:0 tid:0 name: }
PIDs: Hello: 204 PDM: 203
Router-ID: 6.6.6.6
Threads: procinfo: 0x4A3EC70 ddb: 0x4A3EE50
workQ:
iidbQ: Se2/0 Se2/1 Se3/0 Et0/1
count: 4
temp_iidbQ:
passive_iidbQ: Et0/0
count: 1
peerQ:
static_peerQ:
suspendQ:
networkQ: 1.0.0.0
2.0.0.0
count: 2
summaryQ: 2.0.0.0/16 - Et0/1 (intf: 1)
1.0.0.0/8 - Et0/1 (intf: 1)
count: 2
Socket Queue: 0/2000/2/0 (current/max/highest/drops)
Input Queue: 0/2000/2/0 (current/max/highest/drops)
GRS/NSF: enabled hold-timer: 240
Active Timer: 3 min
Distance: internal 90 external 170
Max Path: 4
Max Hopcount: 100
Variance: 1
---------------------------------------------------------
Related Commands
|
|
---|---|
show eigrp plugins |
Displays general information including the versions of the EIGRP protocol features currently running. |
shutdown (service-family)
To disable an Enhanced Interior Gateway Routing Protocol (EIGRP) service family, or all service families and address families configured for a router preventing neighbor discovery and establishment and remove all services and registered clients, use the shutdown command in router configuration, service-family configuration mode, or service-family interface configuration mode.
To disable neighbor discovery and establishment on an interface, use the shutdown command in service-family interface configuration mode. This configuration does not affect clients or any locally published (connected) services.
To reenable the service-family protocol, use the no form of this command.
shutdown
no shutdown
Syntax Description
This command has no arguments or keywords.
Command Default
Service-family protocol is enabled.
Command Modes
Router configuration (config-router)
Service-family configuration (config-router-sf)
Service-family interface configuration (config-router-sf-interface)
Command History
Usage Guidelines
Use the shutdown command to disable the service-family protocol for a specific routing instance. The service-family protocol continues to run and the current service-family configurations are available; however the service-family protocol will not create any adjacencies on any interface and will clear the service-family topology database.
Examples
The following example shows the placement of the shutdown command for each configuration level:
Router(config-router)# shutdown
Router(config-router-sf)# shutdown
Router(config-router-sf-interface)# shutdown
Related Commands
|
|
---|---|
router eigrp |
Configures the EIGRP process. |
sf-interface |
Configures interface-specific commands under the service-family interface configuration mode. |
split-horizon (EIGRP)
To enable Enhanced Interior Gateway Routing Protocol (EIGRP) split-horizon, use the split-horizon command in address-family interface configuration mode or service-family interface configuration mode. To disable EIGRP split-horizon, use the no form of this command.
split-horizon
no split-horizon
Syntax Description
This command has no arguments or keywords.
Command Default
EIGRP split-horizon is enabled by default. However, for ATM interfaces and subinterfaces split-horizon is disabled by default.
Command Modes
Address-family interface configuration (config-router-af-interface)
Service-family interface configuration (config-router-sf-interface)
Command History
Usage Guidelines
The split-horizon rule prohibits a router from advertising a route through an interface that the router itself uses to reach the destination. The following are general rules for EIGRP split-horizon:
•Split-horizon behavior is turned on by default.
•When you change the EIGRP split-horizon setting on an interface, all adjacencies with EIGRP neighbors reachable over that interface are reset.
•Split-horizon should typically be disabled only on non-broadcast multi-access interfaces.
•The EIGRP split-horizon behavior is not controlled or influenced by the ip split-horizon command.
To configure split-horizon for an EIGRP address family, use the split-horizon command in address-family interface configuration mode.
To configure split-horizon for an EIGRP service family, use the split-horizon command in service-family interface configuration mode.
Examples
The following example disables EIGRP split-horizon for serial interface 3/0 in address-family 5400:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface serial3/0
Router(config-router-af-interface)# no split-horizon
The following example disables EIGRP split-horizon for serial interface 3/0 in service-family 5400:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 5400
Router(config-router-sf)# sf-interface serial3/0
Router(config-router-sf-interface)# no split-horizon
Related Commands
timers graceful-restart purge-time
To set the route-hold timer to determine how long a nonstop forwarding (NSF)-aware router that is running Enhanced Interior Gateway Routing Protocol (EIGRP) will hold routes for an inactive peer, use the timers graceful-restart purge-time command in router configuration, address-family, or service-family configuration mode. To return the route-hold timer to the default value, use the no form of this command.
timers graceful-restart purge-time seconds
no timers graceful-restart purge-time
Syntax Description
seconds |
Time, in seconds, for which EIGRP will hold routes for an inactive peer. The configurable time range is from 20 to 300 seconds. The default is 240 seconds. |
Command Default
EIGRP NSF awareness is enabled by default. The default value for the route-hold timer is 240 seconds.
Command Modes
Router configuration (config-router)
Address-family configuration (config-router-af)
Service-family configuration (config-router-sf)
Command History
Usage Guidelines
The route-hold timer sets the maximum period of time for which the NSF-aware router will hold known routes for an NSF-capable neighbor during a switchover operation or a well-known failure condition. The route-hold timer is configurable so that you can tune network performance and avoid undesired effects, such as "black holing" routes if the switchover operation takes too much time. When this timer expires, the NSF-aware router scans the topology table and discards any stale routes, allowing EIGRP peers to find alternate routes instead of waiting during a long switchover operation.
Examples
The following configuration example sets the route-hold timer value for an NSF-aware address family. In the example, the route-hold timer is set to 1 minute:
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# timers graceful-restart purge-time 60
The following configuration example sets the route-hold timer value for an NSF-aware service-family. In this example, the route-hold timer is set to 300 seconds:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# timers graceful-restart purge-time 300
Related Commands
topology
To configure topology-specific commands for an Enhanced Interior Gateway Routing Protocol (EIGRP) service family, use the topology command in service-family interface configuration mode. To disable the service-family topology configuration mode, use the no form of this command.
topology {base}
no topology {base}
Syntax Description
base |
Configures the base topology. |
Command Modes
Service-family configuration (config-router-sf)
Command History
Usage Guidelines
Use the topology command to configure Cisco SAF for multitopology networks.
Note In Cisco IOS Release 15.0(1)M, only the base topology is supported.
Use the show eigrp service-family ipv4 topology command to verify the topology base configuration.
Examples
The following example configures the base topology:
Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface default
Router(config-router-sf-interface)# no shutdown
Router(config-router-sf-interface)# exit-sf-interface
Router(config-router-sf)# topology base
Related Commands
username (SAF)
To configure username for a Cisco SAF External-Client, use the username command in external-client label configuration mode. To negate the username, use the no form of this command.
username name
no username name
Syntax Description
name |
Specifies the name for the external client between 1 and 64 characters. |
Command Modes
External-client label configuration (config-external-client-mode)
Command History
Usage Guidelines
Use the username command to configure Cisco SAF External Clients. Entering a new username value overwrites the old value, but the new value will only take affect after the Cisco SAF External Client re-registers.
Use the show eigrp service-family ipv4 external-client command to verify the Cisco SAF External Client configuration.
Examples
The following example configures a Cisco SAF External Client named example:
Router(config)# service-family external-client listen ipv4 2444
Router(config-external-client)# external-client example
Router(config-external-client-mode)# username example