Configuring DSL
Cisco 900 Series Integrated Services Routers (ISRs) support asymmetric digital subscriber line (ADSL) 2/2+ and very high speed digital subscriber line 2 (VDSL2) transmission modes, also called multimode.
DSL Configuration Restrictions
- Cisco 900 Series Router supports only Pair 0.
- VDSL mode bonding is not supported. 30a profile is not supported.
Configuring ADSL Mode
Perform the following tasks to configure ADSL mode:
Configuring ADSL Auto Mode
Note Configure the DSLAM in ADSL mode prior to configuring the router.
This example shows how to configure the ADSL controller to auto mode:
Router# configure terminal
Router(config)# controller vdsl 0
Router(config-controller)# operating mode auto
Router(config-controller)# end
Configuring CPE and Peer for ADSL Mode
When configuring for ADSL, the ATM main interface or ATM sub-interface must be configured with a PVC and an IP address, perform a no shutdown command on the interface if needed.
Configuring the ATM CPE side
This example shows how to configure the ATM CPE side:
Router# configure terminal
Router(config)# interface atm0
Router(config-if)# no shutdown
Router(config-if)# interface ATM0.1 point-to-point
Router(config-subif)# ip address 30.0.0.1 255.255.255.0
Router(config-subif)# pvc 13/32
Router(config-if-atm-vc)# protocol ip 30.0.0.2 broadcast
Router(config-if-atm-vc)# end
Configuring the ATM Peer side
This example shows how to configure the ATM peer side:
Router# configure terminal
Router(config)# interface atm0
Router(config-if)# no shutdown
Router(config-if)# interface ATM0.1 point-to-point
Router(config-subif)# ip address 30.0.0.2 255.255.255.0
Router(config-subif)# pvc 13/32
Router(config-if-atm-vc)# protocol ip 30.0.0.1 broadcast
Router(config-if-atm-vc)# end
Router#
ADSL Configuration Example
This example shows a typical ADSL2+ configuration set to auto mode.
Building configuration...
Current configuration : 1519 bytes
! Last configuration change at 08:46:20 UTC Fri Jan 11 2019
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot system flash:c900-universalk9-mz.SPA.158-3.M1
multilink bundle-name authenticated
license udi pid C927-4P sn FGL22511283
interface ATM0.1 point-to-point
ip address 30.0.0.1 255.255.255.0
protocol ip 30.0.0.2 broadcast
interface GigabitEthernet0
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
ip address 9.6.9.29 255.255.0.0
ip tftp source-interface GigabitEthernet4
ip route 0.0.0.0 0.0.0.0 9.6.0.1
ip route 202.153.144.25 255.255.255.255 9.6.0.1
tftp-server flash:/firmware/vadsl_module_img.bin
scheduler allocate 20000 1000
Verifying ADSL Configuration
Verify that the configuration is set properly by using the show controller vdsl 0 command from the privileged EXEC mode.
Router# show controller vdsl 0
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xB11F
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FCH2234TH6R C927-4P 15.8(3)M1
Serial Number Far: eq_nr multiline_cpe software_rev
Modem Version Near: 15.8(3)M1
Modem Version Far: 0xb11f
Modem Status: TC Sync (Showtime!)
Trained Mode: G.992.5 (ADSL2+) Annex A
DELT configuration: disabled
Firmware Source File Name
-------- ------ ----------
VDSL embedded VDSL_LINUX_DEV_01212008
Modem FW Version: 4.14L.04
Modem PHY Version: A2pv6F039x8.d26d
Bit swap: enabled enabled
Line Attenuation: 1.0 dB 2.4 dB
Signal Attenuation: 1.9 dB 2.1 dB
Noise Margin: 10.8 dB 7.3 dB
Attainable Rate: 27564 kbits/s 1283 kbits/s
Actual Power: - 0.4 dBm 12.0 dBm
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 27547 0 1279
SRA Previous Speed: 0 0 0 0
Previous Speed: 0 27547 0 1279
Total Cells: 0 11338923 0 520053
Interleave (ms): 0.00 0.07 0.00 0.49
Actual INP: 0.00 0.00 0.00 0.00
Training Log Filename : flash:vdsllog.bin
Verifying CPE to Peer Connection for ADSL
Ping the peer to confirm that the CPE to peer configuration is set up correctly.
Router# ping 30.0.0.2 rep 20
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 30.0.0.2, timeout is 2 seconds:
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Configuring VDSL Mode
Perform the following tasks to configure VDSL mode:
Configuring VDSL Auto Mode
Note Configure the DSLAM in VDSL mode prior to configuring the router.
This example shows how to configure the VDSL controller to auto mode:
Router# configure terminal
Router(config)# controller vdsl 0
Router(config-controller)# operating mode auto
Router(config-controller)# end
Configuring CPE and Peer for VDSL Mode
When configuring VDSL, configure the ethernet 0 interface and perform a no shutdown command on the interface if needed.
Configuring the VDSL CPE Side
This example shows how to configure the VDSL CPE side:
Router# configure terminal
Router(config)# interface ethernet0
Router(config-if)# ip address 90.0.0.1 255.255.255.0
Router(config-if)# no shutdown
Configuring the VDSL Peer Side
This example shows how to configure the VDSL peer side:
Router# configure terminal
Router(config)# interface ethernet0
Router(config-if)# ip address 90.0.0.2 255.255.255.0
Router(config-if)# no shutdown
VDSL Configuration Example
This example shows a typical output of a VDSL configuration:
Building configuration...
Current configuration : 1456 bytes
! Last configuration change at 08:51:44 UTC Fri Jan 11 2019
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot system flash:c900-universalk9-mz.SPA.158-3.M1
multilink bundle-name authenticated
license udi pid C927-4P sn FGL22511283
interface ATM0.1 point-to-point
ip address 90.0.0.1 255.255.255.0
interface GigabitEthernet0
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
ip address 9.6.9.29 255.255.0.0
ip tftp source-interface GigabitEthernet4
ip route 0.0.0.0 0.0.0.0 9.6.0.1
ip route 202.153.144.25 255.255.255.255 9.6.0.1
tftp-server flash:/firmware/vadsl_module_img.bin
scheduler allocate 20000 1000
Verifying VDSL Configuration
Verify the configuration is set properly by using the show controller vdsl 0 command from privileged EXEC mode.
Router# show controller vdsl 0
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xB11F
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' 'BDCM'
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0xB500
Serial Number Near: FCH2234TH6R C927-4P 15.8(3)M1
Serial Number Far: eq_nr multiline_cpe software_rev
Modem Version Near: 15.8(3)M1
Modem Version Far: 0xb11f
Modem Status: TC Sync (Showtime!)
Trained Mode: G.993.2 (VDSL2) Profile 17a
DELT configuration: disabled
Firmware Source File Name
-------- ------ ----------
VDSL embedded VDSL_LINUX_DEV_01212008
Modem FW Version: 4.14L.04
Modem PHY Version: A2pv6F039x8.d26d
Bit swap: enabled enabled
Line Attenuation: 0.9 dB 0.0 dB
Signal Attenuation: 1.8 dB 0.0 dB
Noise Margin: 18.6 dB 17.6 dB
Attainable Rate: 138139 kbits/s 87957 kbits/s
Actual Power: 14.1 dBm 3.8 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 0.2 0.9 1.7 N/A 0.0 0.0 0.0
Signal Attenuation(dB): 0.2 0.9 1.7 N/A 0.0 0.0 0.0
Noise Margin(dB): 27.7 16.9 10.9 N/A 15.5 16.3 21.3
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 128857 0 60013
SRA Previous Speed: 0 0 0 0
Previous Speed: 0 27451 0 1288
Interleave (ms): 0.00 7.00 0.00 1.00
Actual INP: 0.00 1.00 0.00 0.10
Training Log Filename : flash:vdsllog.bin
Verifying CPE to Peer Connection for VDSL
Ping the peer to confirm that CPE to peer configuration is setup correctly.
Router# ping 90.0.0.2 rep 20
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 90.0.0.2, timeout is 2 seconds:
Success rate is 100 percent (20/20), round-trip min/avg/max = 20/22/28 ms
Configuring VLAN 0 Priority Tagging
The VLAN 0 Priority Tagging feature enables 802.1Q Ethernet frames to be transmitted with the VLAN ID set to zero. These frames are called priority tagged frames. Setting the VLAN ID tag to zero allows the VLAN ID tag to be ignored and the Ethernet frame to be processed according to the priority configured in the 802.1P bits of the 802.1Q Ethernet frame header.
This example shows how to configure VLAN Priority Tagging on the CPE side:
Router# configure terminal
Router(config)# interface GigabitEthernet0
Router(config-if)# encapsulation priority-tagged
Router(config-if)# ip address 2.2.2.1 255.255.255.0
This example shows how to configure VLAN Priority Tagging on the Peer side:
Router# configure terminal
Router(config)# interface GigabitEthernet0
Router(config-if)# encapsulation priority-tagged
Router(config-if)# ip address 2.2.2.2 255.255.255.0
Ping the peer to confirm that CPE to peer configuration is setup correctly. This example shows the ping output:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
isr4221#sh run int gi0/0/0.1
Building configuration...
Current configuration : 105 bytes
interface GigabitEthernet0/0/0.1
encapsulation priority-tagged
ip address 2.2.2.2 255.255.255.0
Enabling ADSL2/2+ Annex M Mode on Over POTS VDSL2/ADSL Multimode Annex A SKUs
This example shows how to enable ADSL2/2+ Annex M mode on Over POTS VDSL2/ADSL Multimode Annex A SKUs:
Router# configure terminal
Router(config)# controller vdsl 0
Router(config-controller)# operating mode adsl2+ annex m
Router(config-controller)# end
Enabling Seamless Rate Adaption
This example shows how to enable SRA mode:
router# configure terminal
router(config)# controller vdsl 0
router(config-controller)# sra
router(config-controller)# end
Note Use the no form of the command to disable SRA. SRA mode is disabled by default.
Configuring UBR+
This example shows how to configure UBR+ PVC on a DSL line:
Router# configure terminal
Router(config)# interface ATM 0/0
Router(config-if)# pvc 4/100
Router(config-if-atm-vc)# ubr+ 2304 2304
This example specifies the output-pcr argument for an ATM PVC to be 100000 kbps and the output-mcr to be 3000 kbps:
Router# configure terminal
Router(config)# interface ATM 0/0
Router(config-if)# pvc 1/32
Router(config-if-atm-vc)# ubr+ 100000 3000
This example specifies the output-pcr, output-mcr, input-pcr, and input-mcr arguments for an ATM SVC to be 10000 kbps, 3000 kbps, 9000 kbps, and 1000 kbps, respectively:
Router# configure terminal
Router(config)# interface ATM 0/0
Router(config-if)# svc lion nsap 47.0091.81.000000.0040.0B0A.2501.ABC1.3333.3333.05
Router(config-if-atm-vc)# ubr+ 10000 3000 9000 1000
Troubleshooting
Use the following show commands to troubleshoot DSL:
- show interface Ethernet0
- show interface ATM0
- show interface summary
- show controller vdsl 0
- show controller vdsl 0 datapath
- show atm pvc
Collecting DSL Training Logs
A training log provides you information about the different events that happened during the ADSL training.
This example shows how to start collecting the DSL training logs:
Router#debug vdsl 0 training log
Training log generation started for VDSL 0.
This example shows how to stop collecting the DSL training logs:
Router#no debug vdsl 0 training log
Training Log file for VDSL 0 written to flash:vdsllog.bin.
Training log also supports the auto-stop options. Use the following commands for auto-stop:
no debug vdsl 0 training log autostop linkdown: Stops the collection when the link goes down.
no debug vdsl 0 training log autostop linkup: Stops the collection when the link reaches the showtime.
By default, training log is stored in flash:vdsllog.bin.
You can modify the filename in which the training logs are stored before starting the training log collection. This example shows how to modify the filename:
Router(config)#controller vdsl 0
Router(config-controller)#training log filename flash:mytraininglog.bin
Router(config-controller)#end
Router#sh controller vdsl 0 | sec Training Log
Training Log Filename : flash:mytraininglog.bin
Upgrading DSL Firmware
To upgrade the firmware on a DSL interface, perform these steps:
Step 1 Download the VDSL2 firmware from the Cisco Software Download Centre at https://software.cisco.com/download/home
Step 2 Copy the firmware to the router.
Step 3 Configure the router to load the new firmware from a designated location.
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#controller vdsl 0
Router(config-controller)#firmware filename ?
archive: Download fw file name
cns: Download fw file name
flash: Download fw file name
ftp: Download fw file name
http: Download fw file name
https: Download fw file name
null: Download fw file name
nvram: Download fw file name
pram: Download fw file name
rcp: Download fw file name
scp: Download fw file name
security: Download fw file name
system: Download fw file name
tar: Download fw file name
tftp: Download fw file name
tmpsys: Download fw file name
Router(config-controller)#firmware filename flash:vdsl_fw.bin_39p1
Step 4 Restart the controller interface for the new firmware to take effect.
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#controller vdsl 0
Router(config-controller)#shut
Router(config-controller)#no shut
Router(config-controller)#end