Labeled BGP Support

This feature module describes how to add label mapping information to the Border Gateway Protocol (BGP) message that is used to distribute the route on the router.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Restrictions for Labeled BGP Support

  • The router supports only the client functionality of RFC 3107 and not its area border router (ABR) functionality.

  • The router does not support two label-pop (Label pop is the process of removing label header).

Overview of Labeled BGP Support

The Labeled BGP Support feature provides the option to use the BGP update message (that is used to distribute the route) to re-distribute Multiprotocol Label Switching (MPLS) label mapped to that route. The label mapping information is added (using send-label option of RFC 3107) to the same BGP message that is used to distribute the route. This process is useful in inter-domain routing, and the message that is used to distribute the route. This process is useful in inter-domain routing, and the router supports this functionality as well as the virtual private network (VPN) and virtual routing and forwarding (VRF) over Labeled BGP functionality.

VPN/VRF over RFC 3107

The VPN/VRF over Labeled BGP is a 3-label imposition process (VRF Label, BGP label, interior gateway protocols [IGP] label). The innermost label is VRF, followed by BGP (for RFC 3107), and IGP. This functionality allows the router to support a VRF over labeled BGP session with an ABR.

Configuring Labeled BGP Support

Procedure

  Command or Action Purpose
Step 1

enable

Example:

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.
Step 2

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3

router bgp as-number

Example:

Router(config)# router bgp 100

Enters router configuration mode.

  • as-number—Number of an autonomous system that identifies the router to other BGP routers and tags the routing information that is passed along. The valid values range from 1 to 65535.
Step 4

address family ipv4

Example:


Router(config-router)# address family ipv4

Configures the address family as IPv4 using standard IPv4 address prefixes.

Step 5

neighbor peer-group-name send-community

Example:

Router(config-router)# neighbor 172.16.70.23 send-community

Specifies that the communities attribute be sent to the neighbor at this IP address.

  • peer-group-name—Name of a BGP peer group.
Step 6

neighbor peer-group-name next-hop-self

Example:


Router(config-router)# neighbor 172.16.70.23 next-hop-self

Configures the router as the next hop for a BGP-speaking neighbor or peer group.

Step 7

neighbor peer-group-name activate

Example:

Router(config-router)# neighbor 172.16.70.23 activate

Enables the exchange of information with a neighboring BGP router.

Configuration Example for Labeled BGP Support

>

The following is a sample configuration of the Labeled BGP Support feature.


!

router bgp 1000

 bgp router-id 100.111.13.23

 neighbor pan peer-group

 neighbor pan remote-as 1000

 neighbor pan update-source Loopback0

 neighbor 100.111.14.3 peer-group pan

 !

 address-family ipv4

  neighbor pan send-community

  neighbor pan next-hop-self

  neighbor pan send-label 

!The send-label option is used to associate a BGP label to the prefix.

  neighbor 100.111.14.3 activate

 exit-address-family

 !

 address-family vpnv4

  neighbor pan send-community extended

  neighbor 100.111.14.3 activate

 exit-address-family

 !

 address-family ipv4 vrf LTE12

  redistribute connected

 exit-address-family

!

Verifying Labeled BGP Support

To verify the Labeled BGP Support, use the show commands given below:

Router# show bgp ipv4 unicast labels

Network          Next Hop      In label/Out label

  1.0.0.0          0.0.0.0         imp-null/nolabel

  10.13.22.2/31    0.0.0.0         imp-null/nolabel

  10.13.23.0/31    0.0.0.0         imp-null/nolabel

  10.70.1.0/30     0.0.0.0         imp-null/nolabel

  100.100.10.1/32  100.111.14.4    nolabel/558

                   100.111.14.3    nolabel/560

  100.100.13.23/32 0.0.0.0         imp-null/nolabel

  100.101.13.23/32 0.0.0.0         imp-null/nolabel

  100.111.13.23/32 0.0.0.0         imp-null/nolabel

  100.111.13.26/32 100.111.14.3    nolabel/534

                   100.111.14.4    nolabel/68

  100.111.15.1/32  100.111.14.3    nolabel/25

Router# show ip bgp labels

   Network          Next Hop      In label/Out label

   1.0.0.0          0.0.0.0         imp-null/nolabel

   10.13.22.2/31    0.0.0.0         imp-null/nolabel

   10.13.23.0/31    0.0.0.0         imp-null/nolabel

   10.70.1.0/30     0.0.0.0         imp-null/nolabel

   100.100.10.1/32  100.111.14.4    nolabel/563

                    100.111.14.3    nolabel/556

   100.100.13.23/32 0.0.0.0         imp-null/nolabel

   100.101.13.23/32 0.0.0.0         imp-null/nolabel

   100.111.13.23/32 0.0.0.0         imp-null/nolabel

   100.111.13.26/32 100.111.14.4    nolabel/561

                    100.111.14.3    nolabel/559

   100.111.15.1/32  100.111.14.4    nolabel/59

                    100.111.14.3    nolabel/57

   100.111.15.2/32  100.111.14.4    nolabel/62

                    100.111.14.3    nolabel/52

   100.112.1.1/32   100.111.14.4    nolabel/nolabel

                    100.111.14.3    nolabel/nolabel

   100.112.1.2/32   100.111.14.4    nolabel/nolabel

                    100.111.14.3    nolabel/nolabel

   100.112.1.3/32   100.111.14.4    nolabel/nolabel

                    100.111.14.3    nolabel/nolabel 

Router# show ip bgp vpnv4 all label

   Network          Next Hop      In label/Out label

Route Distinguisher: 236:236

   154.154.236.4/30 100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

   154.154.236.8/30 100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

   154.154.236.12/30

                    100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

   154.154.236.16/30

                    100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

   154.154.236.20/30

                    100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

   154.154.236.24/30

                    100.154.1.1     nolabel/14002

                    100.154.1.1     nolabel/14002

Router# show ip vrf interface

Interface              IP-Address      VRF                              Protocol

Vl100                  113.23.12.1     LTE12 

Router# show ip bgp vpnv4 vrf LTE12 label

   Network          Next Hop      In label/Out label

Route Distinguisher: 6666:6666 (LTE12)

   113.22.12.0/24   100.111.13.22   nolabel/51

                    100.111.13.22   nolabel/51

   113.23.12.0/24   0.0.0.0         50/nolabel(LTE12)

   113.24.12.0/24   100.111.13.24   nolabel/32

                    100.111.13.24   nolabel/32

   115.1.12.0/24    100.111.15.1    nolabel/16024

                    100.111.15.1    nolabel/16024

   154.154.236.4/30 100.154.1.1     nolabel/14002

   154.154.236.8/30 100.154.1.1     nolabel/14002

   154.154.236.12/30

                    100.154.1.1     nolabel/14002

   154.154.236.16/30

                    100.154.1.1     nolabel/14002

   154.154.236.20/30

                    100.154.1.1     nolabel/14002

   154.154.236.24/30

                    100.154.1.1     nolabel/14002

To verify three Label Support, use the show ip cef vrf command as shown in the following example.

Router# show ip cef vrf LTE12 113.22.12.0 internal

113.22.12.0/24, epoch 0, flags rib defined all labels, RIB[B], refcount 5, per-destination sharing

  sources: RIB

  feature space:

   IPRM: 0x00018000

   LFD: 113.22.12.0/24  0 local labels

        contains path extension list

  ifnums: (none)

  path 13E8A064, path list 13F49DC8, share 1/1, type recursive, for IPv4, flags must-be-labelled, recursive-via-host

    MPLS short path extensions: MOI flags = 0x0 label 51

  recursive via 100.111.13.22[IPv4:Default] label 51, fib 141253D8, 1 terminal fib, v4:Default:100.111.13.22/32

    path 12520C8C, path list 13F49C38, share 1/1, type attached nexthop, for IPv4

   MPLS short path extensions: MOI flags = 0x0 label 17

      nexthop 100.111.14.4 Vlan10 label 17, adjacency IP adj out of Vlan10, addr 10.13.23.1 13734C80

  output chain: label 22 label 51 label 17 TAG adj out of Vlan10, addr 10.13.23.1 143EDCA0

!You can see three labels in the output chain; of which 22 is VRF label, 51 is BGP label !and 17 is LDP label 

Additional References

Related Documents

Related Topic Document Title
Cisco IOS XE Command Reference Cisco IOS IP Routing: BGP Command Reference

Standards and RFCs

Standard/RFC Title
RFC-3107

Carrying Label Information in BGP-4

MIBs

MIB MIBs Link
NA

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

Technical Assistance

Description Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/support