Restrictions for ADSL Support in IPv6
ADSL and dial deployment are available for interfaces with PPP encapsulation enabled, including PPP over ATM (PPPoA), PPP over Ethernet (PPPoE), PPP over async, and PPP over ISDN.
The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
Asymmetric Digital Subscriber Line (ADSL) support in IPv6 provides the extensions that make large-scale access possible for IPv6 environments, including IPv6 RADIUS attributes, stateless address configuration on PPP links, per-user static routes, and ACLs.
ADSL and dial deployment are available for interfaces with PPP encapsulation enabled, including PPP over ATM (PPPoA), PPP over Ethernet (PPPoE), PPP over async, and PPP over ISDN.
A Cisco router configured with IPv6 will advertise its IPv6 prefixes on one or more interfaces, allowing IPv6 clients to automatically configure their addresses. In IPv6, address assignment is performed at the network layer, in contrast to IPv4 where a number of functions are handled in the PPP layer. The only function handled in IPv6 control protocol is the negotiation of a unique interface identifier. Everything else, including Domain Name Server (DNS) server discovery, is done within the IPv6 protocol itself.
Contrary to IPv4 address assignment, an IPv6 user will be assigned a prefix, not a single address. Typically, the ISP assigns a 64- or 48-bit prefix.
In IPv6, ISPs assign long-lived prefixes to users, which has some impact on the routing system. In typical IPv4 environments, each network access server (NAS) has a pool of 24-bit addresses and users get addresses from this pool when dialing in. If a user dials another point of presence (POP) or is connected to another NAS at the same POP, a different IPv4 address is assigned.
Addresses for IPv6 are assigned using two methods:
Assigning addresses using the stateless address autoconfiguration method can be used only to assign 64-bit prefixes. Each user is assigned a 64-bit prefix, which is advertised to the user in a router advertisement (RA). All addresses are automatically configured based on the assigned prefix.
A typical scenario is to assign a separate 64-bit prefix per user; however, users can also be assigned a prefix from a shared pool of addresses. Using the shared pool limits addresses to only one address per user.
This method works best for the cases where the customer provider edge (CPE) router is a single PC or is limited to only one subnet. If the user has multiple subnets, Layer 2 (L2) bridging, multilink subnets or proxy RA can be used. The prefix advertised in the RA can come from an authorization, authentication, and accounting (AAA) server, which also provides the prefix attribute, can be manually configured, or can be allocated from a prefix pool.
The Framed-Interface-Id AAA attribute influences the choice of interface identifier for peers and, in combination with the prefix, the complete IPv6 address can be determined.
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
hostname name Example:
|
Specifies the hostname for the network server. |
Step 4 |
aaa new-model Example:
|
Enables the AAA server. |
Step 5 |
aaa authentication ppp {default | list-name } method1 [method2 ...] Example:
|
Specifies one or more AAA authentication methods for use on serial interfaces that are running PPP. |
Step 6 |
aaa authorization configuration default {radius | tacacs+ Example:
|
Downloads configuration information from the AAA server. |
Step 7 |
show ipv6 route [ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number Example:
|
Shows the routes installed by the previous commands. |
Step 8 |
virtual-profile virtual-template number Example:
|
Enables virtual profiles by virtual interface template. |
Step 9 |
interface serial controller-number : timeslot Example:
|
Specifies a serial interface created on a channelized E1 or channelized T1 controller (for ISDN PRI, channel-associated signaling, or robbed-bit signaling). This command also puts the router into interface configuration mode. |
Step 10 |
encapsulation encapsulation-type Example:
|
Sets the encapsulation method used by the interface. |
Step 11 |
exit Example:
|
Returns to global configuration mode. |
Step 12 |
dialer-group group-number Example:
|
Controls access by configuring an interface to belong to a specific dialing group. |
Step 13 |
ppp authentication protocol1 [protocol2 ...] [if-needed ] [list-name | default ] [callin ] [one-time ] [optional ] Example:
|
Enables Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP) or both and specifies the order in which CHAP and PAP authentication are selected on the interface. |
Step 14 |
interface virtual-template number Example:
|
Creates a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces. |
Step 15 |
ipv6 enable Example:
|
Enables IPv6 processing on an interface that has not been configured with an explicit IPv6 address. |
Step 16 |
dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group } Example:
|
Defines a dial-on-demand routing (DDR) dialer list for dialing by protocol or by a combination of a protocol and a previously defined access list. |
Step 17 |
radius-server host {hostname | ip-address } [test username user-name ] [auth-port port-number ] [ignore-auth-port ] [acct-port port-number ] [ignore-acct-port ] [timeout seconds ] [retransmit retries ] [key string ] [alias {hostname | ip-address }] [idle-time seconds Example:
|
Specifies a RADIUS server host. |
Command or Action | Purpose | |
---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode.
|
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
Step 3 |
hostname name Example:
|
Specifies the hostname for the network server. |
Step 4 |
interface bri number . subinterface-number [multipoint | point-to-point ] Example:
|
Configures a BRI interface. |
Step 5 |
encapsulation encapsulation-type Example:
|
Sets the encapsulation method used by the interface. |
Step 6 |
ipv6 address autoconfig [default Example:
|
Indicates that the IPv6 address will be generated automatically. |
Step 7 |
isdn switch-type switch-type Example:
|
Specifies the central office switch type on the ISDN interface. |
Step 8 |
ppp authentication {protocol1 [protocol2 ...]} [if-needed ] [list-name | default ] [callin ] [one-time ] Example:
|
Enables Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP) or both and specifies the order in which CHAP and PAP authentication are selected on the interface. |
Step 9 |
ppp multilink [bap | required ] Example:
|
Enables Multilink PPP (MLP) on an interface and, optionally, enables Bandwidth Allocation Control Protocol (BACP) and Bandwidth Allocation Protocol (BAP) for dynamic bandwidth allocation. |
Step 10 |
exit Example:
|
Exits interface configuration mode and returns to global configuration mode. |
Step 11 |
dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group } Example:
|
Defines a dial-on-demand routing (DDR) dialer list for dialing by protocol or by a combination of a protocol and a previously defined access list. |
Step 12 |
ipv6 route ipv6-prefix / prefix-length {ipv6-address | interface-type interface-number ipv6-address ]} [administrative-distance ] [administrative-multicast-distance | unicast | multicast ] [tag tag Example:
|
Establishes static IPv6 routes.
|
This configuration for the ISP NAS shows the configuration that supports access from the remote CE router.
hostname cust1-53a
aaa new-model
aaa authentication ppp default if-needed group radius
aaa authorization network default group radius
virtual-profile virtual-template 1
interface Serial0:15
encapsulation ppp
dialer-group 1
ppp authentication chap
!
interface Virtual-Template1
ipv6 enable
!
dialer-list 1 protocol ipv6 permit
radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123
This configuration for the remote customer edge router shows PPP encapsulation and IPv6 routes defined.
hostname cust-36a
interface BRI1/0
encapsulation ppp
ipv6 enable
isdn switch-type basic-net3
ppp authentication chap optional
ppp multilink
!
dialer-list 1 protocol ipv6 permit
ipv6 route 2001:DB8::1/128 BRI1/0
ipv6 route ::/0 2001:DB8::1
Related Topic |
Document Title |
---|---|
Cisco IOS IPv6 features |
Standard/RFC |
Title |
---|---|
RFCs for IPv6 |
IPv6 RFCs |
MIB |
MIBs Link |
---|---|
To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL: |
Description |
Link |
---|---|
The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password. |
The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.
Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.
Feature Name |
Releases |
Feature Information |
---|---|---|
IPv6 ADSL and Dial Deployment Support |
12.2(13)T |
ADSL and dial deployment provide the extensions that make large-scale access possible for IPv6 environments, including IPv6 RADIUS attributes, stateless address configuration on PPP links, per-user static routes, and ACLs. The following commands were introduced or modified: aaa authentication ppp , aaa authorization multicast default , aaa new-model , dialer-group , dialer-list , encapsulation , hostname , ipv6 address autoconfig , ipv6 route , isdn switch-type , ppp authentication , ppp multilink , radius-server host , show ipv6 route , virtual-profile virtual-template . |
IPv6 Access Services: PPPoA |
12.2(13)T 12.3 12.3(2)T 12.4 12.4(2)T |
ADSL and dial deployment is available for interfaces with PPP encapsulation enabled, including PPPoA. |
IPv6 Access Services: PPPoE |
12.2(13)T 12.3 12.3(2)T 12.4 12.4(2)T |
ADSL and dial deployment is available for interfaces with PPP encapsulation enabled, including PPPoE. |