Configuring the Fabric Extender

This chapter describes how to configure a Cisco Nexus 2000 Series Fabric Extender using a parent device and includes the following sections:

Configuring the Cisco Nexus 2000 Series Fabric Extender

This section describes how to configure the Fabric Extender.

Managing the Fabric Extender Feature Set

You can install and manage the Fabric Extender feature set.

SUMMARY STEPS

    1.    Installing the Fabric Extender Feature Set

    2.    Enabling the Fabric Extender Feature Set


DETAILED STEPS
    Step 1   Installing the Fabric Extender Feature Set
    Step 2   Enabling the Fabric Extender Feature Set

    Installing the Fabric Extender Feature Set

    SUMMARY STEPS

      1.    configure terminal

      2.    install feature-set fex

      3.    exit


    DETAILED STEPS
       Command or ActionPurpose
      Step 1configure terminal


      Example:
      switch# configure terminal
      switch(config)# 
       

      Enters global configuration mode.

       
      Step 2 install feature-set fex


      Example:
      switch(config)# install feature-set fex
       

      To uninstall the Fabric Extender feature set, use the no install feature-set fex command. Before you can uninstall the feature set, you must ensure the following:

       
      Step 3exit


      Example:
      switch(config)# exit
      switch# 
       

      Exits global configuration mode.

       

      Enabling the Fabric Extender Feature Set

      You can enable the installed Fabric Extender feature set in any VDC on the device.

      SUMMARY STEPS

        1.    configure terminal

        2.    feature-set fex

        3.    exit


      DETAILED STEPS
         Command or ActionPurpose
        Step 1configure terminal


        Example:
        switch# configure terminal
        switch(config)# 
         

        Enters global configuration mode.

         
        Step 2 feature-set fex


        Example:
        switch(config)# feature-set fex
         

        Enables the Fabric Extender feature set. The feature set must be installed before it shows as an option to this command.

        To disable the Fabric Extender feature set, use the no feature-set fex command.

        Note   

        The no feature-set fex command might take some time to complete if the size of the configuration is very large. The command cleans up all of the configurations associated with the Fabric Extender feature set.

         
        Step 3exit


        Example:
        switch(config)# exit
        switch# 
         

        Exits global configuration mode.

         

        Associating a Fabric Extender to a Fabric Interface

        Associating a Fabric Extender to a Port Channel

        Before You Begin

        Ensure that you have enabled the Fabric Extender feature.

        SUMMARY STEPS

          1.    configure terminal

          2.    interface port-channel channel

          3.    switchport mode fex-fabric

          4.    fex associate FEX-number

          5.    (Optional) show interface port-channel channel fex-intf


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 configure terminal


          Example:
          switch# configure terminal
          switch(config)# 
           

          Enters global configuration mode.

           
          Step 2 interface port-channel channel


          Example:
          switch(config)# interface port-channel 4
          switch(config-if)# 
           

          Specifies a port channel to configure.

           
          Step 3 switchport mode fex-fabric


          Example:
          switch(config-if)# switchport mode fex-fabric
           

          Sets the port channel to support an external Fabric Extender.

           
          Step 4 fex associate FEX-number


          Example:
          switch(config-if)# fex associate 101
           

          Associates a FEX number to the Fabric Extender unit attached to the interface. The range is from 101 to 199.

           
          Step 5 show interface port-channel channel fex-intf


          Example:
          switch# show interface port-channel 4 fex-intf
           
          (Optional)

          Displays the association of a Fabric Extender to a port channel interface.

           

          This example shows how to associate the Fabric Extender to a port channel interface on the parent device:

          switch# configure terminal
          switch(config)# interface ethernet 1/28
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/29
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/30
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface ethernet 1/31
          switch(config-if)# channel-group 4
          switch(config-if)# no shutdown
          switch(config-if)# exit
          switch(config)# interface port-channel 4
          switch(config-if)# switchport
          switch(config-if)# switchport mode fex-fabric
          switch(config-if)# fex associate 101
          

          Tip


          As a best practice, only enter the fex associate command from the port channel interface, not from the physical interface.



          Note


          When adding physical interfaces to port channels, all configurations on the port channel and physical interface must match.


          This example shows how to display the association of the Fabric Extender and the parent device:

          switch# show interface port-channel 4 fex-intf
          Fabric           FEX
          Interface        Interfaces
          ---------------------------------------------------
          Po4              Eth101/1/48   Eth101/1/47   Eth101/1/46   Eth101/1/45
                           Eth101/1/44   Eth101/1/43   Eth101/1/42   Eth101/1/41
                           Eth101/1/40   Eth101/1/39   Eth101/1/38   Eth101/1/37
                           Eth101/1/36   Eth101/1/35   Eth101/1/34   Eth101/1/33
                           Eth101/1/32   Eth101/1/31   Eth101/1/30   Eth101/1/29
                           Eth101/1/28   Eth101/1/27   Eth101/1/26   Eth101/1/25
                           Eth101/1/24   Eth101/1/23   Eth101/1/22   Eth101/1/21
                           Eth101/1/20   Eth101/1/19   Eth101/1/18   Eth101/1/17
                           Eth101/1/16   Eth101/1/15   Eth101/1/14   Eth101/1/13
                           Eth101/1/12   Eth101/1/11   Eth101/1/10   Eth101/1/9
                           Eth101/1/8    Eth101/1/7    Eth101/1/6    Eth101/1/5
                           Eth101/1/4    Eth101/1/3    Eth101/1/2    Eth101/1/1
           

          Disassociating a Fabric Extender from an Interface

          Before You Begin

          Ensure that you have enabled the Fabric Extender feature.

          SUMMARY STEPS

            1.    configure terminal

            2.    interface {ethernet slot/port | port-channel channel}

            3.    no fex associate


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 configure terminal


            Example:
            switch# configure terminal
            switch(config)# 
             

            Enters global configuration mode.

             
            Step 2 interface {ethernet slot/port | port-channel channel}


            Example:
            switch(config)# interface port-channel 4
            switch(config-if)# 
             

            Specifies the interface to configure. The interface can be an Ethernet interface or a port channel.

             
            Step 3 no fex associate


            Example:
            switch(config-if)# no fex associate
             

            Disassociates the Fabric Extender unit attached to the interface.

             

            Configuring Fabric Extender Global Features

            You can configure global features on the Fabric Extender.

            Before You Begin

            Ensure that you have enabled the Fabric Extender feature set.

            SUMMARY STEPS

              1.    configure terminal

              2.    fex FEX-number

              3.    (Optional) description desc

              4.    (Optional) no description

              5.    (Optional) no type

              6.    (Optional) serial serial

              7.    (Optional) no serial


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 configure terminal


              Example:
              switch# configure terminal
              switch(config)# 
               

              Enters global configuration mode.

               
              Step 2 fex FEX-number


              Example:
              switch(config)# fex 101
              switch(config-fex)# 
               

              Enters FEX configuration mode for the specified Fabric Extender. The range of the FEX-number is from 101 to 199.

              Note   

              If you need to change the FEX number, you must remove the previous configuration (using the no fex FEX-number command) before applying a new FEX number.

               
              Step 3 description desc


              Example:
              switch(config-fex)# description Rack7A-N2K
               
              (Optional)

              Specifies the description. The default is the string FEXxxxx where xxxx is the FEX number. If the FEX number is 123, the description is FEX0123.

               
              Step 4 no description


              Example:
              switch(config-fex)# no description
               
              (Optional)

              Deletes the description.

               
              Step 5no type


              Example:
              switch(config-fex)# no type
               
              (Optional)

              Deletes the FEX type. When a Fabric Extender is connected to the fabric interfaces and does not match the configured type that is saved in the binary configuration on the parent switch, all configurations for all interfaces on the Fabric Extender are deleted.

               
              Step 6 serial serial


              Example:
              switch(config-fex)# serial JAF1339BDSK
               
              (Optional)

              Defines a serial number string. If this command is configured, a switch allows the corresponding chassis ID to associate (using the fex associate command) only if the Fabric Extender reports a matching serial number string.

              Caution   

              Configuring a serial number that does not match the specified Fabric Extender forces the Fabric Extender offline.

               
              Step 7 no serial


              Example:
              switch(config-fex)# no serial
               
              (Optional)

              Deletes the serial number string.

               

              Configuration Examples

              This section contains examples of FEX configurations.

              Configuring a Host Interface in a vPC Topology Connected to Two FEXs

              This example shows how to configure a host vPC with a FEX (host vPC attached to two different FEXs):

              Switch 1 Configuration Switch 2 Configuration
              config t
              feature lacp
              int e101/1/1-2
              channel-group 10 mode active
              no shutdown
              
              Int port-channel10
              switchport
                switchport mode trunk
                switchport trunk allowed vlan 1-20
              vpc 10
              
              config t
              feature lacp
              int e101/1/1-2
              channel-group 10 mode active
              no shutdown
              
              Int port-channel10
              switchport
                switchport mode trunk
                switchport trunk allowed vlan 1-20
              vpc 10
              

              Verifying the Configuration

              This section describes how to display the configuration of the Fabric Extender and verify the chassis hardware status.

              Verifying the Fabric Extender Configuration

              Use the following commands to display configuration information about the defined interfaces on a Fabric Extender:

              Command or Action

              Purpose

              show fex [FEX-number] [detail]

              Displays information about a specific Fabric Extender or all attached units.

              show interface type number fex-intf

              Displays the Fabric Extender ports that are pinned to a specific switch interface.

              show interface fex-fabric

              Displays the switch interfaces that have detected a Fabric Extender uplink.

              show interface ethernet number transceiver [fex-fabric]

              Displays the SFP+ transceiver and diagnostic optical monitoring (DOM) information for the Fabric Extender uplinks.

              show feature-set

              Displays the status of the feature sets on the device.

              Configuration Examples for the Fabric Extender

              This example shows how to display all the attached Fabric Extender units:

              This example shows how to display the detailed status of a specific Fabric Extender:

              This example shows how to display the Fabric Extender interfaces pinned to a specific switch interface:

              This example shows how to display the switch interfaces that are connected to a Fabric Extender uplink:

              This example shows how to display the SFP+ transceiver and diagnostic optical monitoring (DOM) information for Fabric Extender uplinks for an SFP+ transceiver that is plugged into the parent switch interface:

              switch# show interface ethernet 1/40 transceiver
              Ethernet1/40
                  sfp is present
                  name is CISCO-MOLEX INC
                  part number is 74752-9026
                  revision is A0
                  serial number is MOC13321057
                  nominal bitrate is 12000 MBits/sec
                  Link length supported for copper is 3 m(s)
                  cisco id is --
                  cisco extended id number is 4
               

              This example shows how to display the SFP+ transceiver and DOM information for Fabric Extender uplinks for an SFP+ transceiver that is plugged into the uplink port on the Fabric Extender:

              switch# show interface ethernet 1/40 transceiver fex-fabric
              Ethernet1/40
                  sfp is present
                  name is CISCO-MOLEX INC
                  part number is 74752-9026
                  revision is A0
                  serial number is MOC13321057
                  nominal bitrate is 12000 MBits/sec
                  Link length supported for 50/125mm fiber is 0 m(s)
                  Link length supported for 62.5/125mm fiber is 0 m(s)
                  cisco id is --
                  cisco extended id number is 4
               

              Verifying the Chassis Management Information

              Use the following to display configuration information used on the switch supervisor to manage the Fabric Extender.

              Command or Action

              Purpose

              show environment fex {all | FEX-number} [temperature | power | fan]

              Displays the environmental sensor status.

              show inventory fex FEX-number

              Displays inventory information for a Fabric Extender.

              show module fex FEX-number

              Displays module information about a Fabric Extender.

              show sprom fex FEX-number {all | backplane | powersupply ps-num} | all

              Displays the contents of the serial PROM (SPROM) on the Fabric Extender. The unit of the power for the show sprom command is displayed in centi-amperes.

              Configuration Examples for Chassis Management

              This example shows how to display the module information about all connected Fabric Extender units:

              This example shows how to display the inventory information about a specific Fabric Extender:

              switch# show inventory fex 101
              NAME: "FEX 101 CHASSIS", DESCR: "N2K-C2248TP-1GE  CHASSIS"
              PID: N2K-C2248TP-1GE   , VID: V00 , SN: SSI13380FSM
              
              NAME: "FEX 101 Module 1", DESCR: "Fabric Extender Module: 48x1GE, 4x10GE Supervisor"
              PID: N2K-C2248TP-1GE   , VID: V00 , SN: JAF1339BDSK
              
              NAME: "FEX 101 Fan 1", DESCR: "Fabric Extender Fan module"
              PID: N2K-C2248-FAN     , VID: N/A , SN: N/A
              
              NAME: "FEX 101 Power Supply 2", DESCR: "Fabric Extender AC power supply"
              PID: NXK-PAC-400W      , VID:  000, SN:      LIT13370QD6
               

              This example shows how to display the environment status for a specific Fabric Extender:

              switch# show environment fex 101
              
              
              Temperature Fex 101:
              -----------------------------------------------------------------
              Module   Sensor     MajorThresh   MinorThres   CurTemp     Status
                                  (Celsius)     (Celsius)    (Celsius)
              -----------------------------------------------------------------
              1        Outlet-1   60            50           33          ok
              1        Outlet-2   60            50           38          ok
              1        Inlet-1    50            40           35          ok
              1        Die-1      100           90           44          ok
              
              
              Fan Fex: 101:
              ------------------------------------------------------
              Fan             Model                Hw         Status
              ------------------------------------------------------
              Chassis         N2K-C2148-FAN        --         ok
              PS-1            --                   --         absent
              PS-2            NXK-PAC-400W         --         ok
              
              
              Power Supply Fex 101:
              ---------------------------------------------------------------------------
              Voltage: 12 Volts
              -----------------------------------------------------
              PS  Model                Power       Power     Status
                                       (Watts)     (Amp)
              -----------------------------------------------------
              1   --                        --        --     --
              2   NXK-PAC-400W            4.32      0.36     ok
              
              
              Mod Model                Power     Power       Power     Power       Status
                                       Requested Requested   Allocated Allocated
                                       (Watts)   (Amp)       (Watts)   (Amp)
              --- -------------------  -------   ----------  --------- ----------  ----------
              1    N2K-C2248TP-1GE     0.00      0.00        0.00      0.00        powered-up
              
              
              Power Usage Summary:
              --------------------
              Power Supply redundancy mode:                 redundant
              
              Total Power Capacity                                4.32 W
              
              Power reserved for Supervisor(s)                    0.00 W
              Power currently used by Modules                     0.00 W
              
                                                              -------------
              Total Power Available                               4.32 W
                                                              -------------
               

              This example shows how to display the SPROM for a specific Fabric Extender:

              switch# show sprom fex 101 all
              DISPLAY FEX 101 SUP sprom contents
              Common block:
               Block Signature : 0xabab
               Block Version   : 3
               Block Length    : 160
               Block Checksum  : 0x1a1e
               EEPROM Size     : 65535
               Block Count     : 3
               FRU Major Type  : 0x6002
               FRU Minor Type  : 0x0
               OEM String      : Cisco Systems, Inc.
               Product Number  : N2K-C2248TP-1GE
               Serial Number   : JAF1339BDSK
               Part Number     : 73-12748-01
               Part Revision   : 11
               Mfg Deviation   : 0
               H/W Version     : 0.103
               Mfg Bits        : 0
               Engineer Use    : 0
               snmpOID         : 9.12.3.1.9.78.3.0
               Power Consump   : 1666
               RMA Code        : 0-0-0-0
               CLEI Code       : XXXXXXXXXTBDV00
               VID             : V00
              Supervisor Module specific block:
               Block Signature : 0x6002
               Block Version   : 2
               Block Length    : 103
               Block Checksum  : 0x2686
               Feature Bits    : 0x0
               HW Changes Bits : 0x0
               Card Index      : 11016
               MAC Addresses   : 00-00-00-00-00-00
               Number of MACs  : 0
               Number of EPLD  : 0
               Port Type-Num   : 1-48;2-4
               Sensor #1       : 60,50
               Sensor #2       : 60,50
               Sensor #3       : -128,-128
               Sensor #4       : -128,-128
               Sensor #5       : 50,40
               Sensor #6       : -128,-128
               Sensor #7       : -128,-128
               Sensor #8       : -128,-128
               Max Connector Power: 4000
               Cooling Requirement: 65
               Ambient Temperature: 40
              
              DISPLAY FEX 101 backplane sprom contents:
              Common block:
               Block Signature : 0xabab
               Block Version   : 3
               Block Length    : 160
               Block Checksum  : 0x1947
               EEPROM Size     : 65535
               Block Count     : 5
               FRU Major Type  : 0x6001
               FRU Minor Type  : 0x0
               OEM String      : Cisco Systems, Inc.
               Product Number  : N2K-C2248TP-1GE
               Serial Number   : SSI13380FSM
               Part Number     : 68-3601-01
               Part Revision   : 03
               Mfg Deviation   : 0
               H/W Version     : 1.0
               Mfg Bits        : 0
               Engineer Use    : 0
               snmpOID         : 9.12.3.1.3.914.0.0
               Power Consump   : 0
               RMA Code        : 0-0-0-0
               CLEI Code       : XXXXXXXXXTDBV00
               VID             : V00
              Chassis specific block:
               Block Signature : 0x6001
               Block Version   : 3
               Block Length    : 39
               Block Checksum  : 0x2cf
               Feature Bits    : 0x0
               HW Changes Bits : 0x0
               Stackmib OID    : 0
               MAC Addresses   : 00-0d-ec-e3-28-00
               Number of MACs  : 64
               OEM Enterprise  : 0
               OEM MIB Offset  : 0
               MAX Connector Power: 0
              WWN software-module specific block:
               Block Signature : 0x6005
               Block Version   : 1
               Block Length    : 0
               Block Checksum  : 0x66
              wwn usage bits:
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00 00 00 00 00 00 00
               00 00
              License software-module specific block:
               Block Signature : 0x6006
               Block Version   : 1
               Block Length    : 16
               Block Checksum  : 0x86f
              lic usage bits:
               ff ff ff ff ff ff ff ff
              
              DISPLAY FEX 101 power-supply 2 sprom contents:
              Common block:
               Block Signature : 0xabab
               Block Version   : 3
               Block Length    : 160
               Block Checksum  : 0x1673
               EEPROM Size     : 65535
               Block Count     : 2
               FRU Major Type  : 0xab01
               FRU Minor Type  : 0x0
               OEM String      : Cisco Systems Inc   NXK-PAC-400W
               Product Number  : NXK-PAC-400W
               Serial Number   :      LIT13370QD6
               Part Number     :         341
               Part Revision   : -037
               CLEI Code       : 5-01     01  000
               VID             :  000
               snmpOID         : 12336.12336.12336.12336.12336.12336.12374.12336
               H/W Version     : 43777.2
               Current         : 36
               RMA Code        : 200-32-32-32
              Power supply specific block:
               Block Signature : 0x0
               Block Version   : 0
               Block Length    : 0
               Block Checksum  : 0x0
               Feature Bits    : 0x0
               Current 110v    : 36
               Current 220v    : 36
               Stackmib OID    : 0
               

              Additional References

              This section includes additional information that is related to configuring the Cisco Nexus 2000 Series Fabric Extender.

              Related Documents

              Related Topic

              Document Title

              Cisco NX-OS Licensing

              Cisco NX-OS Licensing Guide

              Interface configuration

              Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide

              Command reference

              Cisco Nexus 9000 Series Command References