Show Commands

This chapter describes the Cisco NX-OS virtual port channel (vPC) show commands.

show ip arp vpc-statistics

To display the global statistics for the Address Resolution Protocol (ARP) on a virtual port channel (vPC), use the show ip arp vpc-statistics command.

show ip arp vpc-statistics

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

This command does not require a license.

Examples

This example shows how to display the global ARP statistics on vPCs:

switch# show ip arp vpc-statistics
ARP sync Enabled
 
ARP vPC global statistics
MCECM api failed while processing CFS payload : 2980
switch#
 

 
Related Commands

Command
Description

ip arp synchronize

Enables ARP synchronization on a vPC domain.

show running-config vpc

Displays the running configuration information for vPCs.

 

show port-profile

To display the port profiles configured on a switch, use the show port-profile command.

show port-profile

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use this command to view the configuration information of the port profiles configured on the switch and the interfaces that inherited the port profiles.

Examples

This example shows how to display the port profiles configured on the switch:

switch# show port-profile
 
port-profile p1
type: Ethernet
description:
status: enabled
max-ports: 512
inherit:
config attributes:
ip port access-group denyv4 in
evaluated config attributes:
ip port access-group denyv4 in
assigned interfaces:
 
port-profile ppEth
type: Ethernet
description: Port profile to configure batch commands for Ethernet interfaces
status: enabled
max-ports: 512
inherit:
pp
config attributes:
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
assigned interfaces:
Ethernet198/1/11
 
switch#
 

Table 1 describes the fields shown in the display.

 

Table 1 show port-profile Field Descriptions

Field
Description

type

The type of interface that the port profile represents. The value can be Ethernet, Interface-vlan, or Port-channel.

description

The summary purpose of the port profile.

status

The state of the port profile, enabled or disabled.

max-ports

The maximum number of ports on which this profile can be inherited. The default is 512.

inherit

The name of the port profile that this port profile inherited. This field is blank if the port profile does not inherit another port profile.

config attributes

The configuration commands of the port profile.

evaluated config attributes

The verified configuration commands of this port profile and the inherited commands from the other port profile.

assigned interfaces

The interfaces that inherits this port profile.

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

inherit

Attaches a port profile to an interface.

show port-profile name

Displays information about the specific port profile.

show running-config port-profile

Displays the running configuration for the port profile.

show port-profile brief

To display brief information about the port profiles configured on a switch, use the show port-profile brief command.

show port-profile brief

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use this command to view the number of interfaces that inherited the port profile, the number of child port profiles, and the number of commands configured in, or inherited to, a port profile.

Examples

This example shows how to display brief information about the port profiles configured on the switch:

switch# show port-profile brief
----------------------------------------------------------
Port Profile Conf Eval Assigned Child
Profile State Items Items Intfs Profs
----------------------------------------------------------
ppEth 1 3 3 1 1
p1 1 1 1 0 0
switch#
 

Table 2 describes the fields shown in the display:

 

Table 2 show port-profile brief Field Descriptions

Field
Description

Port Profile

The name of the port profile.

Profile State

The state of the port profile. The value 1 represents the profile is enabled, and 0 represents a disabled state.

Conf Items

The number of commands configured in the port profile.

Eval Items

The number of commands configured in the port profile or inherited from another port profile.

Assigned Intfs

The interfaces assigned to the port profile.

Child Profs

The number of port profiles inherited by this port profile.

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

show port-profile

Displays information about all configured port profiles.

show port-profile name

Displays information about a specific port profile.

show running-config port-profile

Displays the running configuration for the port profile.

show port-profile expand-interface

To display the active port profile configurations that are applied to an interface, use the show port-profile expand-interface command.

show port-profile expand-interface [ pp-profile-name ]

 
Syntax Description

pp-profile-name

(Optional) Name of the port profile. The name can be a maximum of 80 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

Use this command to view the port profile configuration that is applied to an interface.

Examples

This example shows how to display the port profile configurations applied to the assigned interfaces:

switch# show port-profile expand-interface
 
port-profile ppEth
Ethernet198/1/11
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
 
port-profile p1
 
port-profile pp
 
switch#
 

This example shows how to display a specific port profile configuration assigned to an interface:

switch# show port-profile expand-interface name ppEth
 
port-profile ppEth
Ethernet198/1/11
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
 
switch#
 

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

show port-profile

Displays information about all configured port profiles.

show running-config port-profile

Displays the running configuration for the port profile.

show port-profile name

To display the configuration information of specific port profiles, use the show port-profile name command.

show port-profile name pp-profile-name

 
Syntax Description

pp-profile-name

Name of the port profile. The name can be a maximum of 80 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the configuration information of a port profile named ppEth:

switch# show port-profile name ppEth
 
port-profile ppEth
type: Ethernet
description: Port profile to configure batch commands for Ethernet interfaces
status: enabled
max-ports: 512
inherit:
pp
config attributes:
evaluated config attributes:
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
assigned interfaces:
Ethernet198/1/11
 
switch#
 

Table 3 describes the fields shown in the display:

 

Table 3 show port-profile Field Descriptions

Field
Description

type

The type of interface that the port profile represents. The value can be Ethernet, Interface-vlan, or Port-channel.

description

The summary purpose of the port profile.

status

The state of the port profile, enabled or disabled.

max-ports

The maximum number of ports on which this profile can be inherited. The default is 512.

inherit

The name of the port profile that this port profile inherited. This field is blank if the port profile does not inherit another port profile.

config attributes

The configuration commands of the port profile.

evaluated config attributes

The verified configuration commands of this port profile and the inherited commands from the other port profile.

assigned interfaces

The interfaces that inherits this port profile.

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

inherit

Attaches a port profile to an interface.

show port-profile

Displays information about all port profiles.

show running-config port-profile

Displays the running configuration for the port profile.

show port-profile usage

To display the list of interfaces that inherited a port profile, use the show port-profile usage command.

show port-profile usage [ pp-profile-name ]

 
Syntax Description

pp-profile-name

(Optional) Name of the port profile. The name can be a maximum of 80 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the assigned interfaces for port profiles configured on the switch:

switch# show port-profile usage
 
port-profile eth
Ethernet198/1/11
 
port-profile p1
 
port-profile pp
 
switch#
 

This example shows how to display the interfaces attached to a port profile named ppEth:

switch# show port-profile usage name ppEth
 
port-profile ppEth
Ethernet198/1/11
 
switch#
 

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

show port-profile

Displays information about all configured port profiles.

show running-config port-profile

Displays the running configuration for port profiles.

show startup-config port-profile

Displays the startup configuration for port profiles.

show running-config expand-port-profile

To display the detailed running configuration for a port profile, use the show running-config expand expand-port-profile command.

show running-config expand-port-profile

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the running configuration for an expanded port profile:

switch# show running-config expand-port-profile
 
!Command: show running-config expand-port-profile
!Time: Wed Jan 16 09:19:41 2013
 
version 5.0(2)N1(1)
feature fcoe
 
feature telnet
feature tacacs+
cfs ipv4 distribute
cfs eth distribute
feature udld
feature interface-vlan
feature lacp
feature dhcp
feature vpc
feature lldp
feature vtp
feature fex
 
username admin password 5 $1$wmFN7Wly$/pjqx1DfAkCCAg/KyxbUz/ role network-admin
username install password 5 ! role network-admin
username praveena password 5 ! role network-operator
no password strength-check
ip domain-lookup
ip domain-lookup
tacacs-server host 192.0.2.54 key 7 "wawy1234"
tacacs-server host 192.0.2.37
tacacs-server host 192.0.2.37 test username user1
:
<--Snip-->
:
vpc domain 1000
role priority 65534
system-mac 00:23:04:ee:c1:e8
peer-keepalive destination 192.0.2.2 source 192.0.2.3 vrf default
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
interface Vlan1
 
:
<--snip-->
:
mac address-table notification threshold limit 99 interval 60
interface fc2/1
interface fc2/2
interface fc2/3
interface fc2/4
logging server 192.0.2.101
logging server 192.0.2.102
logging timestamp milliseconds
no logging console
 
 
switch#
 

 
Related Commands

Command
Description

port-profile

Configures a port profile.

show port-profile

Displays the port profile information.

show running-config port-profile

Displays the running configuration with port profile configurations.

show running-config port-profile

To display the running configuration of a port profile, use the show running-config port-profile command.

show running-config port-profile [ pp-profile-name ]

 
Syntax Description

pp-profile-name

Name of the port profile. The name can be a maximum of 80 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the running configuration of all port profiles that are configured on the switch:

switch# show running-config port-profile
 
!Command: show running-config port-profile
!Time: Wed Jan 30 00:37:27 2013
 
version 6.0(2)N1(1)
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
switch#
 

This example shows how to display the running configuration of a port profile named ppEth that is configured on the switch:

switch# show running-config port-profile ppEth
 
!Command: show running-config port-profile ppEth
!Time: Wed Jan 30 00:37:27 2013
 
version 6.0(2)N1(1)
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

 
Related Commands

Command
Description

port-profile

Configures a port profile.

show port-profile

Displays the configuration information of port profiles.

show startup-config switch-profile

Displays the startup configuration information for the switch profile.

show running-config switch-profile

To display the running configuration of a switch profile, use the show running-config switch-profile command.

show running-config switch-profile

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the running configuration of a switch profile named s5600 configured on switch 1 of the peer:

switch# show running-config switch-profile
switch-profile s5600
sync-peers destination 192.0.2.3
interface Ethernet1/1
switchport mode trunk
speed 1000
 
switch#
 

 
Related Commands

Command
Description

switch-profile

Configures a switch profile.

show startup-config switch-profile

Displays the startup configuration information for the switch profile.

show running-config vpc

To display the running configuration information for virtual port channels (vPCs), use the show running-config vpc command.

show running-config vpc [ all ]

 
Syntax Description[

all

(Optional) Displays configured and default information.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the running configuration for a vPC:

switch (config)# show running-config vpc
version 6.0(2)
feature vpc
vpc domain 2
role priority 1
system-priority 32667
peer-keepalive destination 192.0.2.52 source 192.0.2.51 udp-port 3200 vrf ma
engagement interval 1000 timeout 5
 
 
interface port-channel10
vpc 20
 
interface port-channel101
vpc 101
 
interface port-channel200
vpc peer-link
 
interface port-channel201
vpc 201
 

This example shows how to display the running configuration for a vPC:

switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Wed Jan 30 00:37:27 2013
 
version 6.0(2)N1(1)
feature vpc
 
vpc domain 1000
role priority 2000
peer-keepalive destination 192.0.2.52 source 192.0.2.51 vrf management
peer-config-check-bypass
 
 
interface port-channel1
vpc peer-link
 
interface port-channel3
vpc 4096
 
interface port-channel5
vpc 4001
 
interface port-channel12
vpc 4000
 
interface port-channel24
vpc 2000
 
interface port-channel41
vpc 41
 
interface port-channel48
vpc 48
 
--More--

switch#

 

This example shows how to display the vPC reload configuration on a switch:

switch# show running-config vpc
 
 
!Command: show running-config vpc
!Time: Wed Jan 30 00:37:27 2013
 
version 6.0(2)N1(1)
feature vpc
 
vpc domain 10
peer-keepalive destination 192.0.2.48
reload restore
 
--More--
<--output truncated>
switch#
 

This example shows how to display the vPC automatic recovery configuration:

switch# show running-config vpc
 
!Command: show running-config vpc
!Time: Wed Jan 30 00:37:27 2013
 
version 6.0(2)N1(1)
feature vpc
 
vpc domain 100
peer-keepalive destination 192.0.2.138
auto-recovery reload-delay 300
 
interface port-channel1
vpc 1
 
interface port-channel100
vpc peer-link
 
switch#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, this command returns an error.

 

show startup-config interface

To display interface configuration information in the startup configuration, use the show startup-config interface command.

show startup-config interface [ ethernet slot [ QSFP-module/ ] / port | expand-port-profile | loopback number | mgmt 0 | port-channel { channel-number } [ membership ] | tunnel number | { vlan vlan-id }

 
Syntax Description

ethernet slot / port

(Optional) Displays the number of the module and port number. The slot number is from 1 to 255, and the port number is from 1 to 128.

slot

Slots from 1 to 8. The following list defines the slots available:

• Slots 1 to 4 are fixed Linecard Expansion Modules (LEMs).

• Slots 5 to 8 are hot-swappable LEMs.

QSFP-module

(Optional) Linecard Expansion Module (LEM) that has been set to 10G

mode.

port

Port number within a particular slot. The port number is from 1 to 128.

expand-port-profile

Displays the port profiles.

loopback number

Displays the number of the loopback interface. The range of values is from 1 to 4096.

mgmt 0

Displays the configuration information of the management interface.

port-channel channel-number

Displays the number of the port-channel group. The range of values is from 0 to 1023.

membership

(Optional) Displays the membership of the specified port channel.

tunnel number

Displays the number of the tunnel interface. The range of values is from 0 to 65535.

vlan vlan-id

Displays the number of the VLAN. The range of values is from 1 to 4096.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the information in the startup configuration for the interface Ethernet 7/1:

switch(config)# show startup-config interface ethernet 7/1
version 6.0(2)
 
interface Ethernet7/1
ip pim sparse-mode
switch(config)#
 

 
Related Commands

Command
Description

show interface

Displays information about the specified interface.

show startup-config port-profile

To display the startup configuration of port profiles, use the show startup-config port-profile command.

show startup-config switch-profile [ pp-profile-name ]

 
Syntax Description

pp-profile-name

(Optional) Name of the port profile. The name can be a maximum of 80 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the configuration information of all port profiles stored in the startup configuration file:

switch# show startup-config switch-profile
 
!Command: show startup-config port-profile
!Time: Wed Jan 30 00:37:27 2013
!Startup config saved at: Sun Jan 27 03:40:28 2013
 
version 6.0(2)N1(1)
port-profile type interface-vlan ppVlan
bandwidth 30000000
mtu 3000
description Sample port-profile for VLAN interfaces
port-profile type ethernet eth
switchport mode trunk
switchport trunk allowed vlan 300-800
flowcontrol receive on
state enabled
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

This example shows how to display the startup configuration of a port profile named ppPO that is configured for port channel interfaces on the switch:

switch# show startup-config port-profile ppPO
 
!Command: show startup-config port-profile ppPO
!Time: Wed Jan 30 07:34:31 2013
!Startup config saved at: Wed Jan 30 07:29:19 2013
 
version 6.0(2)N1(1)
port-profile type port-channel ppPO
delay 5000000
load-interval counter 1 30
switchport mode trunk
description Sample port profile for Port Channel interface
state enabled
 
 
switch#
 

This example shows how to display the startup configuration of a port profile named ppEth that is configured for Ethernet interfaces on the switch:

switch# show startup-config port-profile ppEth
 
!Command: show startup-config port-profile ppEth
!Time: Wed Jan 30 07:35:44 2013
!Startup config saved at: Wed Jan 30 07:29:19 2013
 
version 6.0(2)N1(1)
port-profile type ethernet ppEth
inherit port-profile eth
switchport mode trunk
switchport trunk allowed vlan 300-400
speed 10000
bandwidth 1000000
description Sample port profile for Ethernet interfaces
state enabled
 
 
switch#
 

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

show running-config switch-profile

Displays the running configuration information for a switch profile.

show startup-config switch-profile

To display the startup configuration of a switch profile, use the show startup-config switch-profile command.

show startup-config switch-profile

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the startup configuration of a switch profile named s5600 that is configured on switch 1 of the peer:

switch# show running-config switch-profile
switch-profile s5600
sync-peers destination 192.0.2.3
 
interface Ethernet101/1/35
switchport mode trunk
switchport trunk native vlan 300
switchport trunk allowed vlan 300-800
switch#
 

 
Related Commands

Command
Description

copy running-config startup-config

Copies the running configuration to the startup configuration.

switch-profile

Configures a switch profile.

show running-config switch-profile

Displays the running configuration information for a switch profile.

show startup-config vpc

To display virtual port channel (vPC) configuration information in the startup configuration, use the show startup-config vpc command.

show startup-config vpc [ all ]

 
Syntax Description

all

(Optional) Displays startup-configuration information for all vPCs.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the vPC information in the startup configuration:

switch(config)# show startup-config vpc
version 6.0(2)
feature vpc
vpc domain 1
 
 
interface port-channel10
vpc peer-link
 
interface port-channel20
vpc 100
switch(config)#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show switch-profile

To display the switch profile configured on the switch, use the show switch-profile command.

show switch-profile

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the switch profile that is configured on switch 1 of the peer:

switch# show switch-profile
----------------------------------------------------------
Profile-name Config-revision
----------------------------------------------------------
s5600 1
 
switch#
 

Table 4 describes the fields shown in the display:

 

Table 4 show switch-profile Field Descriptions

Field
Description

Profile-name

The name of the switch profile.

Config-revision

The revision of the switch profile configuration. The revision number is used to synchronize the configuration in the peer switch.

See the commit command for more information.

 
Related Commands

Command
Description

commit

Commits a switch profile configuration.

switch-profile

Configures a switch profile.

show switch-profile status

Displays the status of the switch profile.

show switch-profile buffer

To display the switch profile buffer, use the show switch-profile buffer command.

show switch-profile sw-profile-name buffer

 
Syntax Description

sw-profile-name

Name of the switch profile. The name is case sensitive, can be a maximum of 64 alphanumeric characters and can include an underscore, and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the buffer for the switch profile named s5600:

switch# show switch-profile s5600 buffer
----------------------------------------------------------
Seq-no Command
----------------------------------------------------------
1 interface ethernet 1/1
1.1 switchport mode trunk
1.2 speed 1000
2 interface port-channel 102
2.1 vpc 1
2.2 switchport mode trunk
 
switch#
 

Table 5 describes the fields shown in the display:

 

Table 5 show switch-profile buffer Field Descriptions

Field
Description

Seq-no

The sequence number or order of entry of the command in the switch profile buffer.

Command

The command used for configuring the switch profile.

 
Related Commands

Command
Description

command (switch profile)

Adds commands to a switch profile.

import

Imports commands to a switch profile.

switch-profile

Configures a switch profile.

show switch-profile status

Displays the status of the switch profile.

show switch-profile peer

To display information about the destination peer switch in a switch profile configuration, use the show switch-profile peer command.

show switch-profile sw-profile-name peer ip-address

 
Syntax Description

sw-profile-name

Name of the switch profile. The name is case sensitive, can be a maximum of 64 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

ip-address

IPv4 address of the destination peer switch in the format A. B. C. D.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the information about a destination peer switch with IPv4 address 192.0.2.3 added to the switch profile named s5600 on switch 1 of the peer:

switch# show switch-profile s5600 peer 192.0.2.3
Peer-sync-status : Not yet merged. pending-merge:1 received_merge:0
Peer-status : Peer not reachable
Peer-error(s) :
switch#
 

This example shows how to display the successful commit information about a destination peer switch with IPv4 address 192.0.2.3 for the switch profile named s5600 on switch 1 of the peer:

switch1# show switch-profile sp peer 192.0.2.3
Peer-sync-status : In Sync.
Peer-status : Commit Success
Peer-error(s) :
switch1#
 

Table 6 describes the fields shown in the display.

 

Table 6 show switch-profile peer Field Descriptions

Field
Description

Peer-sync-status

The status of the synchronized configuration in the peer switch as follows:

  • In Sync—The configuration on both switches are synchronized.
  • Not yet merged. pending-merge:1 received_merge:0—The configuration in the local switch is not yet merged with the peer switch.

Peer-status

The status of the peer switch during a configuration synchronization, whether reachable or not reachable, successfully verified or committed.

Peer-error(s)

The reason for the failure in connecting to the peer switch.

 
Related Commands

Command
Description

show switch-profile status

Displays the status of the switch profile.

switch-profile

Configures a switch profile.

sync-peers destination

Configures the peer switch for configuration synchronization.

show switch-profile session-history

To display the session history of the switch profile configuration, use the show switch-profile session-history command.

show switch-profile sw-profile-name session-history

 
Syntax Description

sw-profile-name

Name of the switch profile. The name is case sensitive, can be a maximum of 64 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the session history of the switch profile named s5600 on switch 1 of the peer:

switch# show switch-profile s5600 session-history
 
Start-time: 959269 usecs after Wed Jan 30 00:37:27 2013
End-time: 961304 usecs after Wed Jan 30 00:37:27 2013
 
Profile-Revision: 1
Session-type: Initial-Exchange
Peer-triggered: No
Profile-status: -
 
Local information:
----------------
Status: -
Error(s):
 
Peer information:
----------------
IP-address: 192.0.2.3
Pending-merge: 1
Received-merge: 0
Sync-status: Not yet merged. pending-merge:1 received-merge:0
Status: Peer not reachable
Error(s):
 
Start-time: 794606 usecs after Wed Jan 30 00:37:27 2013
End-time: 796861 usecs after Wed Jan 30 00:37:27 2013
 
Profile-Revision: 1
Session-type: Peer-delete
Peer-triggered: No
Profile-status: Sync Success
 
Local information:
----------------
Status: Verify Success
Error(s):
 
switch#
 

Table 7 describes the fields shown in the display:

 

Table 7 show switch-profile session-history Field Descriptions

Field
Description

Start-time

The start time of the configuration session in the format nn usecs after Day-of-week Month Date hh : mm : ss Year, where usecs represents microseconds.

For example, 265561 usecs after Fri Aug 13 06:21:30 2010

End-time

The end time of the configuration session in the format nn usecs after Day-of-week Month Date hh : mm : ss Year, where usecs represents microseconds.

Profile-Revision

The number of times the switch profile configuration has been revised.

Session-type

The action taken on the switch profile configuration; for example, Initial-Exchange, Commit, Peer-Delete.

Peer-triggered

The status of receiving the peer reachable notification.

Profile-status

The status of the configuration synchronization.

Local information

The information about the local switch profile.

Status

The status of the configuration synchronization action in the local switch.

Error(s)

The reason for the errors that appear while synchronizing the configuration in the local switch.

Peer information

The information about the peer switch profile.

IP-address

The IPv4 address of the destination peer switch.

Pending-merge

The latest configuration revision number in the local switch that is to be merged with the configuration in the peer switch.

Received-merge

The configuration revision received from the local switch to synchronize with the peer switch.

Sync-status

The status of the synchronized configuration in the peer switch as follows:

  • In Sync—The configuration on the peer switch is synchronized with the configurations of the local switch.
  • Not yet merged. pending-merge:1 received_merge:0—The configuration in the local switch is not yet merged with the peer switch.

Status

The status of the peer switch, such as the connectivity, or command execution status.

Error(s)

The reason for the errors that appear while synchronizing the configuration in the peer switch.

 
Related Commands

Command
Description

show switch-profile

Displays the switch profile and configuration revisions.

show switch-profile status

Displays the status of the switch profile.

switch-profile

Configures a switch profile.

show switch-profile status

To display the switch profile configuration status, use the show switch-profile command.

show switch-profile sw-profile-name status

 
Syntax Description

sw-profile-name

Name of the switch profile. The name is case sensitive, can be a maximum of 64 alphanumeric characters and can include an underscore and hyphen. The name cannot contain spaces or special characters.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the status of the switch profile named s5600 on switch 1 of the peer:

switch# show switch-profile s5600 status
 
Start-time: 794606 usecs after Wed Jan 30 00:37:27 2013
End-time: 796861 usecs after Wed Jan 30 00:37:27 2013
 
Profile-Revision: 3
Session-type: Commit
Peer-triggered: Yes
Profile-status: Sync Success
 
Local information:
----------------
Status: Commit Success
Error(s):
 
Peer information:
----------------
IP-address: 192.0.2.3
Sync-status: In Sync.
Status: Commit Success
Error(s):
 
switch#
 

Table 8 describes the fields shown in the display:

 

Table 8 show switch-profile status Field Descriptions

Field
Description

Start-time

The start time of the configuration session in the format nn usecs after Day-of-week Month Date hh : mm : ss Year, where usecs represents microseconds.

For example, 265561 usecs after Fri Aug 13 06:21:30 2010

End-time

The end time of the configuration session in the format nn usecs after Day-of-week Month Date hh : mm : ss Year, where usecs represents microseconds.

Profile-Revision

The number of times the switch profile configuration has been revised.

Session-type

The action taken on the switch profile configuration; for example, Commit, Peer-Delete.

Peer-triggered

The status of receiving the peer reachable notification.

Profile-status

The status of the configuration synchronization.

Local information

The information about the local switch profile.

Status

The status of the configuration synchronization action in the local switch.

Error(s)

The reason for the errors that appear while synchronizing the configuration in the local switch.

Peer information

The information about the peer switch profile.

IP-address

The IPv4 address of the destination peer switch.

Sync-status

The status of the synchronized configuration in the peer switch.

  • In Sync—The configuration on the peer switch is synchronized with the configurations of the local switch.
  • Not yet merged. pending-merge:1 received_merge:0—The configuration in the local switch is not yet merged with the peer switch.

Status

The status of the configuration synchronization action in the peer switch.

Error(s)

The reason for the errors that appear while synchronizing the configuration in the peer switch.

 
Related Commands

Command
Description

show switch-profile

Displays the switch profile and configuration revisions.

switch-profile

Configures a switch profile.

show tech-support vpc

To display troubleshooting information about the virtual port channel (vPC), use the show tech-support vpc command.

show tech-support vpc

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the vPC troubleshooting information:

Need new command output.

switch# show tech-support vpc
`show version`
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2010, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0
loader: version N/A
kickstart: version 4.2(1)N1(1) [build 4.2(1)N1(0.329)]
system: version 4.2(1)N1(1) [build 4.2(1)N1(0.329)]
power-seq: version v1.2
BIOS compile time: 09/08/09
kickstart image file is: bootflash:/n5000-uk9-kickstart.4.2.1.N1.latest.bin
kickstart compile time: 4/18/2010 8:00:00 [04/18/2010 15:03:44]
system image file is: bootflash:/n5000-uk9.4.2.1.N1.latest.bin
system compile time: 4/18/2010 8:00:00 [04/18/2010 16:08:18]
 
 
Hardware
cisco Nexus5020 Chassis ("40x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2074284 kB of memory.
Processor Board ID JAF1413ADCS
 
Device name: d14-switch-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 2 hour(s), 25 minute(s), 26 second(s)
 
Last reset at 414529 usecs after Mon Apr 19 05:59:19 2010
 
Reason: Disruptive upgrade
System version: 4.2(1u)N1(1u)
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
`show module`
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ---------------------- ------------
1 40 40x10GE/Supervisor N5K-C5020P-BF-SUP active *
2 8 8x1/2/4G FC Module N5K-M1008 ok
3 6 6x10GE Ethernet Module N5K-M1600 ok
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- -------------- ------ --------------------------------------------------
1 4.2(1)N1(1) 1.3 --
2 4.2(1)N1(1) 0.200 20:41:00:05:9b:78:6e:40 to 20:48:00:05:9b:78:6e:40
3 4.2(1)N1(1) 0.100 --
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 0005.9b78.6e48 to 0005.9b78.6e6f JAF1413ADCS
2 0005.9b78.6e70 to 0005.9b78.6e77 JAB1228016M
3 0005.9b78.6e78 to 0005.9b78.6e7f JAB12310214
`show vpc brief`
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 1000
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : secondary
Number of vPCs configured : 150
Peer Gateway : Disabled
Dual-active excluded VLANs : -
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po1 up 1-330,335,338-447,1000-1023,2000-2018
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
41 Po41 down* failed Consistency Check Not -
Performed
48 Po48 down* failed Consistency Check Not -
Performed
2000 Po24 down success success -
4000 Po12 down success success -
4001 Po5 down success success -
4096 Po3 down success success -
101376 Eth100/1/1 down* failed Consistency Check Not -
Performed
101377 Eth100/1/2 down* failed Consistency Check Not -
Performed
101378 Eth100/1/3 down* failed Consistency Check Not -
Performed
101379 Eth100/1/4 down* failed Consistency Check Not -
Performed
101380 Eth100/1/5 down* failed Consistency Check Not -
--More--
switch#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show version

To display information about the software and hardware version, use the show version command.

show version

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

All version information

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the version information of a switch:

Need new command output.

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2010, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0 [last: ]
loader: version N/A
kickstart: version 4.2(1u)N1(1u) [build 4.2(1)N1(0.328)]
system: version 4.2(1u)N1(1u) [build 4.2(1)N1(0.328)]
power-seq: version v1.2
BIOS compile time: 09/08/09 [last: ]
kickstart image file is: bootflash:///n5000-uk9-kickstart.4.2.1.N1.latest.bin.
upg
kickstart compile time: 12/25/2020 12:00:00 [04/17/2010 15:06:29]
system image file is: bootflash:/n5000-uk9.4.2.1.N1.latest.bin.upg
system compile time: 12/25/2020 12:00:00 [04/17/2010 16:11:29]
 
 
Hardware
cisco Nexus5020 Chassis ("40x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2074284 kB of memory.
Processor Board ID JAF1413ADCS
 
Device name: d14-switch-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 1 hour(s), 2 minute(s), 41 second(s)
 
Last reset at 167864 usecs after Mon Apr 19 04:22:45 2010
 
Reason: Reset due to upgrade
System version: 4.2(1)N1(1)
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
switch#
 

This example shows how to display the version information for the kickstart and system image running on a device:

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2013, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.3.0
loader: version N/A
kickstart: version 6.0(2)N1(1) [build 6.0(2)N1(1)]
system: version 6.0(2)N1(1) [build 6.0(2)N1(1)]
power-seq: version v1.2
BIOS compile time: 09/08/09
kickstart image file is: bootflash:/sanity-kickstart
kickstart compile time: 12/6/2010 7:00:00 [12/06/2010 07:35:14]
system image file is: bootflash:/sanity-system
system compile time: 12/6/2010 7:00:00 [12/06/2010 08:56:45]
 
 
Hardware
cisco Nexus5600 Chassis ("20x10GE/Supervisor")
Intel(R) Celeron(R) M CPU with 2073416 kB of memory.
Processor Board ID JAF1228BTAS
 
Device name: BEND-2
bootflash: 1003520 kB
 
Kernel uptime is 0 day(s), 3 hour(s), 30 minute(s), 45 second(s)
 
Last reset
Reason: Unknown
System version:
Service:
 
plugin
Core Plugin, Ethernet Plugin, Fc Plugin
switch#
 

This example shows how to display the version information for the kickstart and system image running on a device that runs Cisco NX-OS Release 5.0(3)N1(1):

switch# show version
Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2011, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
other third parties and are used and distributed under license.
Some parts of this software are covered under the GNU Public
License. A copy of the license is available at
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 3.3.0
loader: version N/A
kickstart: version 5.0(3)N2(1) [build 5.0(3)N2(0.116)] [gdb]
system: version 5.0(3)N2(1) [build 5.0(3)N2(0.116)] [gdb]
power-seq: Module 1: version v3.0
Module 3: version v2.0
uC: version v1.0.0.14
BIOS compile time: 12/20/2010
kickstart image file is: bootflash:///nc_hpfex.k
kickstart compile time: 2/15/2011 14:00:00 [02/18/2011 04:40:42]
system image file is: bootflash:///nc_hpfex.s
system compile time: 2/15/2011 14:00:00 [02/19/2011 00:23:52]
 
 
Hardware
cisco Nexus5548 Chassis ("O2 32X10GE/Modular Supervisor")
Intel(R) Xeon(R) CPU with 8299368 kB of memory.
Processor Board ID JAF1432DABR
 
Device name: switch
bootflash: 2007040 kB
 
Kernel uptime is 2 day(s), 5 hour(s), 0 minute(s), 36 second(s)
 
Last reset at 111527 usecs after Wed Apr 30 00:42:54 2008
 
Reason: Reset Requested by CLI command reload
System version: 5.0(3)N2(0.116)
Service:
 
plugin
Core Plugin, Ethernet Plugin
switch#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show vpc

To display detailed information about the virtual port channels (vPCs) configured on the switch, use the show vpc command.

show vpc [ vpc-number ]

 
Syntax Description

vpc-number

(Optional) vPC number. The range is from 1 to 4096.

 
Command Default

None

 
Command Modes

EXEC mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

Examples

This example shows how to display the vPC information:

switch# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
Type-2 consistency reason : Consistency Check Not Performed
vPC role : secondary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po4000 up 1,3001-3500
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
10 Po10 up success success 3001-3200
 
switch#
 

This example shows how to display information about a specific vPC:

switch# show vpc 10
 
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
10 Po10 up success success 3001-3200
 
switch#
 

 
Related Commands

Command
Description

show vpc brief

Displays vPC information in a brief summary.

vpc

Configures vPC features on the switch.

show vpc brief

To display brief information about the virtual port channels (vPCs), use the show vpc brief command.

show vpc brief [ vpc number ]

 
Syntax Description

vpc number

(Optional) Displays the brief information for the specified vPC. The range is from 1 to 4096.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The show vpc brief command displays the vPC domain ID, the peer-link status, the keepalive message status, whether the configuration consistency is successful, and whether a peer link formed or failed to form.

This command is not available if you have not enabled the vPC feature. See the feature vpc command for information about enabling vPCs.

You can display the track object if you have configured a tracked object for running vPCs on a single module in the vpc-domain configuration mode.

Examples

This example shows how to display brief information about the vPCs on a switch:

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : primary
Number of vPC configured : 1
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
 
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- -------------------------- ------------
20 Po20 up success success 1-100
switch(config)#
 

This example shows how to display brief information about the vPCs. In this example, the port channel failed the consistency check, and the device displays the reason for the failure:

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 10
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: failed
Configuration consistency reason: vPC type-1 configuration incompatible - STP interface port type inconsistent
vPC role : secondary
Number of vPC configured : 1
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
 
vPC status
----------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
-- ---- ------ ----------- -------------------------- ------------
20 Po20 up failed vPC type-1 configuration -
incompatible - STP
interface port type
inconsistent
switch(config)#
 

This example shows how to display information about the tracked objects in the vPCs:

switch(config)# show vpc brief
 
Legend:
(*) - local vpc is down, forwarding via vPC peer-link
 
vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status: success
vPC role : secondary
Number of vPC configured : 3
Track object : 12
 
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po10 up 1-100
switch(config)#
 

This example shows how to display the vPC configuration, including the Graceful Type-1 Consistency configuration:

switch# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link
 
vPC domain id : 100
Peer status : peer link is down
vPC keep-alive status : peer is alive, but domain IDs do not match
Configuration consistency status: success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
 
vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ --------------------------------------------------
1 Po100 down -
 
vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
1 Po1 down success success -
 
switch#
 

 
Related Commands

Command
Description

feature vpc

Enables vPCs on the device.

show port channel summary

Displays information about port channels.

vpc

Configures vPC domains and peers.

show vpc consistency-parameters

To display the consistency of parameters that must be compatible across the virtual port-channel (vPC) interfaces, use the show vpc consistency-parameters command.

show vpc consistency-parameters { global | interface port-channel channel-number | vlans | vpc number }

 
Syntax Description

global

Displays the configuration of all Type 1 global parameters on both sides of the vPC peer link.

interface port-channel channel-number

Displays the configuration of all Type 1 interface parameters on both sides of the vPC peer link.

vlans

Displays the configuration of all VLANs, including incompatible VLANs, on both sides of the vPC peer link for the specified vPC.

vpc number

Displays the configuration of all Type 1 interface parameters on both sides of the vPC peer link for the specified vPC.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The show vpc consistency-parameters command displays the configuration of all the vPC Type 1 parameters on both sides of the vPC peer link.


Note All the Type 1 configurations must be identical on both sides of the vPC peer link, or the link will not come up.


The vPC Type 1 configuration parameters are as follows:

  • Port-channel mode: on, off, or active
  • Link speed per channel
  • Duplex mode per channel
  • Trunk mode per channel

Native VLAN

VLANs allowed on trunk

Tagging of native VLAN traffic

  • Spanning Tree Protocol (STP) mode
  • STP region configuration for Multiple Spanning Tree
  • Enable/disable state the same per VLAN
  • STP global settings

Bridge Assurance setting

Port type setting—We recommend that you set all vPC peer link ports as network ports.

Loop Guard settings

  • STP interface settings:

Port type setting

Loop Guard

Root Guard

  • Maximum transmission unit (MTU)
  • Allowed VLAN bit set

This command is not available if you have not enabled the vPC feature. See feature vpc for information on enabling vPCs.

Examples

This example shows how to display the vPC global consistency parameters:

switch(config)# show vpc consistency-parameters global
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS 1 ([], [3], [0], [1-2], ([], [3], [0], [1-2],
[4-5], [6]) [4-5], [6])
Network QoS (MTU) 1 (1538, 2240, 5038, (1538, 2240, 5038,
4038, 9216, 9216) 4038, 9216, 9216)
Network Qos (Pause) 1 (F, T, F, F, F, F) (F, T, F, F, F, F)
Input Queuing (Bandwidth) 1 (5, 10, 20, 0, 20, 40) (5, 10, 20, 0, 20, 40)
Input Queuing (Absolute 1 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority)
Output Queuing (Bandwidth) 1 (5, 10, 20, 0, 20, 40) (5, 10, 20, 0, 20, 40)
Output Queuing (Absolute 1 (F, F, F, T, F, F) (F, F, F, T, F, F)
Priority)
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
Allowed VLANs - 1-330,335,338-450,1000 1-330,333-447,1000-102
-1023,2000-2023 8,2000-2018
Local suspended VLANs - 331-334,336-337,448-45 -
0,2019-2023
switch(config)#
 

This example shows how to display the vPC global consistency parameters:

switch# show vpc consistency-parameters global
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS 2 ([], [3], [], [], [], ([], [3], [], [], [],
[]) [])
Network QoS (MTU) 2 (1538, 2240, 0, 0, 0, (1538, 2240, 0, 0, 0,
0) 0)
Network Qos (Pause) 2 (F, T, F, F, F, F) (1538, 2240, 0, 0, 0,
0)
Input Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Input Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
Output Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Output Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
Allowed VLANs - - -
Local suspended VLANs - - -
 
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
QoS 2 ([], [3], [], [], [], ([], [3], [], [], [],
[]) [])
Network QoS (MTU) 2 (1538, 2240, 0, 0, 0, (1538, 2240, 0, 0, 0,
0) 0)
Network Qos (Pause) 2 (F, T, F, F, F, F) (1538, 2240, 0, 0, 0,
0)
Input Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Input Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
Output Queuing (Bandwidth) 2 (50, 50, 0, 0, 0, 0) (50, 50, 0, 0, 0, 0)
Output Queuing (Absolute 2 (F, F, F, F, F, F) (50, 50, 0, 0, 0, 0)
Priority)
STP Mode 1 Rapid-PVST Rapid-PVST
STP Disabled 1 None None
STP MST Region Name 1 "" ""
STP MST Region Revision 1 0 0
STP MST Region Instance to 1
VLAN Mapping
STP Loopguard 1 Disabled Disabled
STP Bridge Assurance 1 Enabled Enabled
STP Port Type, Edge 1 Normal, Disabled, Normal, Disabled,
BPDUFilter, Edge BPDUGuard Disabled Disabled
STP MST Simulate PVST 1 Enabled Enabled
VTP domain 2 cisco cisco
VTP version 2 2 2
VTP mode 2 Server Server
VTP password 2
VTP pruning status 2 Disabled Disabled
VTP trunk status 2 Enabled Enabled
Pruning eligible vlans 2 2-1001 2-1001
Allowed VLANs - 1-10 1-2
Local suspended VLANs - 3-10 -
 
switch#
 

This example shows how to display the vPC consistency parameters for the specified port channel:

switch(config)# show vpc consistency-parameters interface port-channel 20
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ------------------------ --------------------------
STP Port Type 1 Default Default
STP Port 1 None None
Guard
mode 1 on on
Speed 1 10 Gb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 trunk trunk
Native Vlan 1 1 1
MTU 1 1500 1500
Allowed VLAN - 1-100 1-100
bitset
switch(config)#
 

This example shows how to display the vPC consistency parameters for the specified port channel:

switch# show vpc consistency-parameters interface port-channel 1
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Shut Lan 1 No No
STP Port Type 1 Default Default
STP Port Guard 1 None None
STP MST Simulate PVST 1 Default Default
mode 1 on on
Speed 1 10 Gb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 trunk trunk
Native Vlan 1 1 1
MTU 1 1500 1500
VTP trunk status 2 Enabled Enabled
Pruning eligible vlans 2 2-1001 2-1001
Allowed VLANs - 1-3967,4048-4093 1-3967,4048-4093
Local suspended VLANs - 3-10 -
switch#
 

This example shows how to display the vPC consistency parameters for the specified vPC:

switch# show vpc consistency-parameters vpc 1
 
Legend:
Type 1 : vPC will be suspended in case of mismatch
 
Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
Shut Lan 1 No No
STP Port Type 1 Default Default
STP Port Guard 1 None None
STP MST Simulate PVST 1 Default Default
lag-id 1 [(7f9b, [(7f9b,
0-23-4-ee-be-64, 8001, 0-23-4-ee-be-64, 8001,
0, 0), (8000, 0, 0), (8000,
0-5-9b-23-40-3c, 0, 0, 0-5-9b-23-40-3c, 0, 0,
0)] 0)]
mode 1 active active
Speed 1 1000 Mb/s 10 Gb/s
Duplex 1 full full
Port Mode 1 access access
MTU 1 1500 1500
Allowed VLANs - 1 1
Local suspended VLANs - - -
switch#
 

This example shows how to display the vPC consistency parameters for VLANs:

switch# show vpc consistency-parameters vlans
 
Name Type Reason Code Pass Vlans
 
------------- ---- ---------------------- -----------------------
STP Mode 1 success 0-4095
STP Disabled 1 success 0-4095
STP MST Region Name 1 success 0-4095
STP MST Region Revision 1 success 0-4095
STP MST Region Instance to 1 success 0-4095
VLAN Mapping
STP Loopguard 1 success 0-4095
STP Bridge Assurance 1 success 0-4095
STP Port Type, Edge 1 success 0-4095
BPDUFilter, Edge BPDUGuard
STP MST Simulate PVST 1 success 0-4095
Pass Vlans - 0-4095
switch#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show port channel summary

Displays information about port channels.

vpc

Configures vPC domains and peers.

show vpc orphan-ports

To display ports that are not part of the virtual port channel (vPC) but have common VLANs, use the show vpc orphan-ports command.

show vpc orphan-ports

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The show vpc orphan-ports command displays those ports that are not part of the vPC but that share common VLANs with ports that are part of the vPC.

This command is not available if you have not enabled the vPC feature. See the feature vpc command for information about enabling vPCs.

Examples

This example shows how to display vPC orphan ports:

switch(config)# show vpc orphan-ports
 
Note:
--------::Going through port database. Please be patient.::--------
 
VLAN Orphan Ports
------- -------------------------
1 Po600
2 Po600
3 Po600
4 Po600
5 Po600
6 Po600
7 Po600
8 Po600
9 Po600
10 Po600
11 Po600
12 Po600
13 Po600
14 Po600
--More--
switch(config)#
 

 
Related Commands

Command
Description

feature vpc

Enables vPCs on the device.

vpc orphan-port suspend

Suspends a non-vPC port.

show vpc brief

Displays brief information about vPCs.

show vpc peer-keepalive

To display the destination IP for the virtual port-channel (vPC) peer keepalive message and the status of the messages, use the show vpc peer-keepalive command.

show vpc peer-keepalive

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The show vpc peer-keepalive command displays the destination IP of the peer keepalive message for the vPC. The command also displays the send and receive status as well as the last update from the peer in seconds and milliseconds.


Note We recommend that you create a separate VRF on the peer devices to send and receive the vPC peer keepalive messages. Do not use the peer link itself to send the vPC peer-keepalive messages.


This command is not available if you have not enabled the vPC feature. See the feature vpc command for information about enabling vPCs.

Examples

This example shows how to display information about the peer-keepalive message:

switch(config)# show vpc peer-keepalive
 
vPC keep-alive status : peer is alive
--Send status : Success
--Last send at : 2008.05.17 18:23:53 986 ms
--Sent on interface : Eth7/16
--Receive status : Success
--Last receive at : 2008.05.17 18:23:54 99 ms
--Received on interface : Eth7/16
--Last update from peer : (0) seconds, (486) msec
 
vPC Keep-alive parameters
--Destination : 192.168.145.213
--Keepalive interval : 1000 msec
--Keepalive timeout : 5 seconds
--Keepalive hold timeout : 3 seconds
--Keepalive vrf : pkal
--Keepalive udp port : 3200
--Keepalive tos : 192
switch(config)#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show vpc role

To display information about the virtual port-channel (vPC) role of the peer device, use the show vpc role command.

show vpc role

 
Syntax Description

This command has no arguments or keywords.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The show vpc role command displays the following information about the vPC status:

  • Status of peer adjacency
  • vPC role of the VDC that you are working on
  • vPC MAC address
  • vPC system priority
  • MAC address of the device that you are working on
  • System priority for the device that you are working on

This command is not available if you have not enabled the vPC feature. See the feature vpc command for information on enabling vPCs.

Examples

This example shows how to display the vPC role information of the device that you are working on:

switch(config)# show vpc role
 
Primary:
 
vPC Role status
----------------------------------------------------
vPC role : primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:ea:c1
vPC local role-priority : 32667
 
 
Secondary:
 
vPC Role status
----------------------------------------------------
vPC role : secondary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:01
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:de:41
vPC local role-priority : 32667
switch(config)#
 

When you reload the primary vPC peer device, the secondary vPC peer device assumes the role of the primary device. This example shows how the vPC role displays then on the new primary device:

switch(config)# show vpc role
 
vPC Role status
----------------------------------------------------
vPC role : secondary, operational primary
Dual Active Detection Status : 0
vPC system-mac : 00:23:04:ee:be:64
vPC system-priority : 32667
vPC local system-mac : 00:22:55:79:de:41
vPC local role-priority : 32667
 
switch(config)#
 

 
Related Commands

Command
Description

role

Assigns a primary or secondary role to a vPC device.

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show port channel summary

Displays information about port channels.

show vpc statistics

To display virtual port-channel (vPC) statistics, use the show vpc statistics command.

show vpc statistics { peer-keepalive | peer-link | vpc number }

 
Syntax Description

peer-keepalive

Displays statistics about the peer-keepalive message.

peer-link

Displays statistics about the peer link.

vpc number

Displays statistics about the specified vPC. The range is from 1 to 4096.

 
Command Default

None

 
Command Modes

Any command mode

 
Command History

Release
Modifications

6.0(2)N1(1)

This command was introduced.

 
Usage Guidelines

The peer-link parameter displays the same information as the show interface port-channel channel number command for the vPC peer-link port channel.

The vpc number parameter displays the same information as the show interface port-channel channel number command for the specified vPC port channel.

This command is not available if you have not enabled the vPC feature. See the feature vpc command for information on enabling vPCs.

Examples

This example shows how to display statistics about the peer-keepalive message:

switch# show vpc statistics peer-keepalive
 
vPC keep-alive status : peer is alive
 
VPC keep-alive statistics
----------------------------------------------------
peer-keepalive tx count: 1036
peer-keepalive rx count: 1028
average interval for peer rx: 995
Count of peer state changes: 1
switch(config)#
 

 
Related Commands

Command
Description

show vpc brief

Displays information about vPCs. If the feature is not enabled, the system displays an error when you enter this command.

show port channel summary

Displays information about port channels.