A Commands

This chapter describes the Cisco NX-OS Multiprotocol Label Switching commands that begin with A.

accept-lifetime

To configure the accept lifetime of a key, use the accept-lifetime command. To return to the default setting, use the no form of this command.

accept-lifetime {start-time | local start-time} {duration seconds | end-time | infinite}

no accept-lifetime {start-time | local start-time} {duration seconds | end-time | infinite}

 
Syntax Description

start-time

Time to start. hh:mm:ss is the time format. The range is from 0 to 23: 0 and from 59: 0 to 59. The maximum size is 8 alphanumeric characters.

local start-time

Specifies the time in the local time zone. hh:mm:ss is the time format.

duration

Sets the key lifetime duration as follows:

  • Enter the number of days from 1 to 31.
  • Enter the name of the month.
  • Enter the year from the present to 2035.

seconds

Seconds. The range is from 1 to 2147483646 seconds.

end-time

Time to stop.

infinite

Allows the lifetime period to never expire.

 
Defaults

None

 
Command Modes

Keychain key configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

If you enter the no accept-lifetime command, the associated password is valid for authenticating incoming TCP segments.

This command requires the MPLS Services license.

Examples

This example shows how to configure the accept lifetime of a key:

switch# configure terminal
switch(config)# key chain keychain1
switch(config-keychain)# key 10
switch(config-keychain-key)# accept-lifetime 10:00:00 Jan 13 2010 10:00:00 Jun 13 2010
switch(config-keychain-key)#

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

address-family

To configure an address family type that pertains to BGP, use the address-family command. To return to the default setting, use the no form of this command.

address-family {ipv4 {multicast | unicast}} {ipv6 {multicast | unicast | labeled unicast }} {vpnv4 | vpnv6 {unicast }}

no address-family {ipv4 {multicast | unicast}} {ipv6 {multicast | unicast | labeled unicast }} {vpnv4 | vpnv6 {unicast }}

 
Syntax Description

ipv4

Specifies an IPv4 address family.

ipv6

Specifies an IPv6 address family.

multicast

Specifies a multicast address family.

unicast

Specifies a unicast address family.

vpnv4

Specifies IPv4 VPN address family.

vpnv6

Specifies IPv6 VPN address family.

unicast

Specifies a unicast sub address family.

 
Defaults

None

 
Command Modes

Router BGP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

VPNv4 and VPNv6 options require MPLS Services license.

Examples

This example shows how to configure IPV4 multicast address family:

switch# configure t
switch(config)# router bgp 1
switch(config-router)# address-family ipv4 multicast
switch(config-router-af)#
 

This example shows how to configure IPV6 unicast address family:

switch# configure t
switch(config)# router bgp 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)#
 

This example shows how to configure unicast sub address family:

switch# configure t
switch(config)# router bgp 1
switch(config-router)# address-family VPNv4 unicast
switch(config-router-af)#
 

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

 

advertise-labels

To configure label advertisements, use the advertise-labels command. To return to the default setting, use the no form of this command.

advertise-labels [for prefix-list [to prefix-list] | interface interface number]

no advertise-labels [for prefix-list [to prefix-list] | interface interface number]

 
Syntax Description

for

(Optional) Specifies the prefix list controls on destination prefixes.

prefix-list

Name of the prefix list.

to

(Optional) Specifies the prefix list controls on Label Distribution Protocol (LDP) peers.

interface

(Optional) Specifies the interface address.

interface-number

Interface number.

 
Defaults

None

 
Command Modes

LDP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

To block label advertisements to the rest of the LDP peers, use the no advertise-labels command.

This command requires the MPLS Services license.

Examples

This example shows how to configure the device to advertise the label on destination prefixes:

switch# configure terminal
switch(config)# mpls ldp configuration
switch(config-ldp)# advertise-labels for p1
switch(config-ldp)#
 

This example shows how to configure the device to advertise the label for designated destination prefixes to designated LDP peers:

switch# configure terminal
switch(config)# mpls ldp configuration
switch(config-ldp)# advertise-labels for p1 to peer1
switch(config-ldp)#

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

affinity (LSP attribute configuration mode)

To configure attribute flags for links that comprise a label switched path (LSP), use the affinity command.

affinity [mask value]

 
Syntax Description

mask

(Optional) Link attribute to be checked. A 32-bit decimal number. Valid values are from 0x0 to 0xFFFFFFFF, representing 32 attributes (bits), where the value of an attribute is 0 or 1.

value

Attribute values required for links carrying this tunnel. A 32-bit decimal number. Valid values are from 0x0 to 0xFFFFFFFF, representing 32 attributes (bits), where the value of an attribute is 0 or 1.

 
Defaults

Value default is 0x00000000

Mask default is 0x0000ffff

 
Command Modes

LSP attributes configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

The following holds true for all tunnel-te commands that can be specified both in "TE interface configuration mode" or path-option command line or "LSP attribute configuration mode":

If a setting is specified for an LSP, either via the path-option command directly or by assigning an LSP attribute list to a path-option, takes precedence for that specific path-option.

If no setting is specified for an LSP, then the LSP path-option inherits any setting specified in the tunnel-te configuration mode: affinity, auto-bw, priority, record-route, protection/fast-reroute.

This command requires the MPLS Services license.

Examples

This example shows how to configure attribute flags for links that comprise an LSP:

switch# configure terminal
switch(config)# mpls traffic-eng configuration
switch(config-te)# lsp attributes 1
switch(config-lsp-attr)# affinity 0X0101 mask 0X0303

 
Related Commands

Command
Description

mpls traffic-eng configuration

Configures the Multiprotocol Label Switching (MPLS) Traffic Engineering protocol (MPLS-TE).

affinity (TE interface configuration mode)

To configure attribute flags for links that comprise a label switched path (LSP), use the affinity command.

affinity [mask value]

 
Syntax Description

mask

(Optional) Link attribute to be checked. A 32-bit decimal number. Valid values are from 0x0 to 0xFFFFFFFF, representing 32 attributes (bits), where the value of an attribute is 0 or 1.

value

Attribute values required for links carrying this tunnel. A 32-bit decimal number. Valid values are from 0x0 to 0xFFFFFFFF, representing 32 attributes (bits), where the value of an attribute is 0 or 1.

 
Defaults

Value default is 0x00000000

Mask default is 0x0000ffff

 
Command Modes

TE interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to configure attribute flags for links that comprise an LSP:

switch# configure terminal
switch(config)# interface tunnel-te 1
switch(config-if-te)# affinity 0X0101 mask 0X0303
switch(config-if-te)#

 
Related Commands

Command
Description

interface tunnel-te

Configures the traffic engineering (TE) interface.

allowas-in

To allow an autonomous system (AS) path with the provider edge (PE) AS number (ASN) a specified number of times, use the allowas-in command.

allowas-in number

 
Syntax Description

number

Specified number to allowa the AS path. The range is from 1 to 10.

 
Defaults

None

 
Command Modes

config-router-vrf-neighbor-af mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2.2

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to allow an AS path with the PE ASN a specified number of times:

switch# configure terminal
switch(config)# feature bgp
switch(config)# router bgp 1.1
switch(config-router)# vrf vpn1
switch(config-router-vrf)# neighbor 209.165.201.1 remote-as 1.2
config-router-vrf-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# neighbor 33.0.1.63 remote-as 100
switch(config-router-vrf-neighbor)# address-family ipv4 unicast
switch(config-router-vrf-neighbor-af)# allowas-in 3
switch(config-router-vrf-af)#

 
Related Commands

Command
Description

address-family ipv4 unicast

Enters address family configuration mode for configuring routing sessions that use standard IPv4 address prefixes.

neighbor

Adds an entry to the BGP or multiprotocol BGP neighbor table for this VRF.

area

To configure the sham link on the provider edge (PE) interface within a specified Open Shortest Path First (OSPF) area and with the loopback interfaces specified by the IP addresses as endpoints, use the area command. To return to the default setting, use the no form of this command.

area area-id sham-link source-address destination-address

no area area-id sham-link source-address destination-address

 
Syntax Description

area-id

Area ID as an integer or IP address.

sham-link

Specifies the sham link and its parameters.

virtual-link

Specifies a virtual link and its parameters.

source-address

Source address.

destination-address

Destination address.

 
Defaults

None

 
Command Modes

Router configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to configure the maximum number of routes that can be stored in the virtual routing and forwarding (VRF) route table:

switch# configure t
switch(config)# feature ospf
switch(config)# router ospf p1
switch(config-router)# timer throttle lsa 0 50 500
switch(config-router)# vrf vpn1
switch(config-router-vrf)# area 1 sham-link 10.2.1.1 10.2.1.2
switch(config-router-vrf)#
 
 

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

as-override

To specify to override the autonomous system number (ASN) when sending an update, use the as-override command.

as-override

 
Syntax Description

This command does have any arguments or keywords.

 
Defaults

None

 
Command Modes

config-router-vrf-neighbor-af mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2.2

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify to override the ASN when sending an update:

switch# configure terminal
switch(config)# feature bgp
switch(config)# feature-set mpls
switch(config)# feature mpls l3vpn
switch(config)# feature bgp
switch(config)# router bgp 1.1
switch(config-router)# neighbor 209.165.201.1 remote-as 1.2
config-router-vrf-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# send-community extended
switch(config-router-neighbor-af)# vrf 2hub
switch(config-router-vrf-neighbor)# address-family ipv4 unicast
switch(config-router-vrf-neighbor-af)# as-override
switch(config-router-vrf-af)#

authentication challenge

Command
Description

address-family ipv4 unicast

Enters address family configuration mode for configuring routing sessions that use standard IPv4 address prefixes.

allowas-in

Allows duplicate autonomous system number (ASN) in the AS path. Configure this parameter in the VPN address family configuration mode at the PE spokes and at the neighbor mode at the PE hub.

To perform a challenge or response handshake with the new Resource Reservation Protocol (RSVP) neighbors, use the authentication challenge command. To disable global authentication, use the no form of this command.

authentication [neighbor address ip-address] challenge

no authentication [neighbor address ip-address] challenge

 
Syntax Description

neighbor

(Optional) Specifies the RSVP neighbor.

address ip-address

(Optional) Specifies the RSVP neighbor address.

 
Defaults

None

 
Command Modes

RSVP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to perform a challenge handshake with the new RSVP neighbors:

switch# configure terminal
switch(config)# ip rsvp
switch(config-ip-rsvp)# authentication neighbor 1.1.1.1 challenge
switch(config-ip-rsvp)#

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

authentication key-chain

To activate the Resource Reservation Protocol (RSVP) cryptographic authentication for a neighbor, use the authentication key-chain command. To disable global authentication, use the no form of this command.

authentication [neighbor address ip-address] key-chain key-chain-name

no authentication [neighbor address ip-address] key-chain key-chain-name

 
Syntax Description

neighbor

(Optional) Specifies the RSVP neighbor.

address ip-address

(Optional) Specifies the RSVP neighbor address.

key-chain-name

Key chain name.

 
Defaults

None

 
Command Modes

RSVP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify the authentication password keychain:

switch# configure terminal
switch(config)# ip rsvp
switch(config-ip-rsvp)# authentication neighbor 1.1.1.1 key-chain key1
switch(config-ip-rsvp)#

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

authentication lifetime

To control how long the Resource Reservation Protocol (RSVP) maintains security associations with a neighbor, use the authentication lifetime command. To revert to the default lifetime, use the no form of this command.

authentication [neighbor address ip-address] lifetime hh:mm:ss

no authentication [neighbor address ip-address] lifetime hh:mm:ss

 
Syntax Description

neighbor

(Optional) Specifies the RSVP neighbor.

address ip-address

(Optional) Specifies the RSVP neighbor address.

hh:mm:ss

Lifetime value in seconds. The range is from 30 to 86400 seconds.

 
Defaults

30 minutes

 
Command Modes

RSVP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify the maximum lifetime of a neighbor authentication state:

switch# configure terminal
switch(config)# ip rsvp
switch(config-ip-rsvp)# authentication neighbor 1.1.1.1 lifetime 60
switch(config-ip-rsvp)#

 
Related Commands

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

authentication type

To configure the algorithm used to generate cryptographic signatures messages for a neighbor, use the authentication type command. To revert to the default type, use the no form of this command.

authentication [neighbor address ip-address] type {md5 | sha-1}

no authentication [neighbor address ip-address] type {md5 | sha-1}

 
Syntax Description

neighbor

(Optional) Specifies the Resource Reservation Protocol (RSVP) neighbor.

address

(Optional) Specifies the RSVP neighbor address.

ip-address

RSVP neighbor address.

md5

Specifies the Rivest, Shamir, and Adleman (RSA) Message Digest 5 hash algorithm.

sha-1

Specifies the National Institute of Standards and Technology (NIST) Secure Hash Algorithm 1.

 
Defaults

md5

 
Command Modes

RSVP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify the MD5 authentication algorithm:

switch# configure terminal
switch(config)# ip rsvp
switch(config-ip-rsvp)# authentication neighbor 1.1.1.1 type md5
switch(config-ip-rsvp)#

 
Related Commands#

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

 

authentication window-size

To configure the tolerance for the window size for an out-of-sequence message, use the authentication window-size command. To revert to the default type, use the no form of this command.

authentication [neighbor address ip-address] window-size value

no authentication [neighbor address ip-address] window-size value

 
Syntax Description

neighbor

(Optional) Specifies the Resource Reservation Protocol (RSVP) neighbor.

address ip-address

(Optional) Specifies the RSVP neighbor address.

value

Maximum number of messages allowed in a window. The range is from 1 to 64.

 
Defaults

1

 
Command Modes

RSVP configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

Use authentication window-size command to specify the tolerance for an out-of-sequence messages for a neighbor or globally.

This command requires the MPLS Services license.

Examples

This example shows how to configure the tolerance for an out-of-sequence message for a neighbor:

switch# configure terminal
switch(config)# ip rsvp
switch(config-ip-rsvp)# authentication neighbor 1.1.1.1 window-size 1
switch(config-ip-rsvp)#

 
Related Commands#

Command
Description

mpls ldp configuration

Configures the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP).

autoroute announce

To announce the traffic-engineering tunnel to an Interior Gateway Protocol (IGP), use the autoroute announce command. To restore the system to its default condition, use the no form of this command.

autoroute announce

no autoroute announce

 
Syntax Description

This command has no arguments or keywords.

 
Defaults

None

 
Command Modes

TE interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to announce the tunnel to IGP:

switch# configure terminal
switch(config)# interface tunnel-te 1
switch(config-if-te)# autoroute announce
switch(config-if-te)#

 
Related Commands

Command
Description

interface tunnel-te

Configures the traffic engineering (TE) interface.

auto-bw (LSP attribute configuration mode)

To configure the automatic bandwidth configuration, use the auto-bw command.

auto-bw [frequency secs] [max-bw kbps] [min-bw kbps] [collect-bw]

no auto-bw [frequency secs] [max-bw kbps] [min-bw kbps] [collect-bw]

 
Syntax Description

frequency

(Optional) Specifies the interval between bandwidth adjustments.

secs

(Optional) Seconds. The range is from 300 to 604800 seconds.

max-bw

(Optional) Specifies the maximum automatic bandwidth, in kbps, for this path option.

kbps

(Optional) Kilobits per second. The range is from 0 to 4294967295.

min-bw

(Optional) Specifies the minimum automatic bandwidth, in kbps, for this path option.

collect-bw

(Optional) Collects the output rate information for the path option but does not adjust the bandwidth of the path option.

 
Defaults

If the command is entered with no optional keywords, automatic bandwidth adjustment for the LSP is enabled, with adjustments made every 24 hours and with no constraints on the bandwidth adjustments made.If the collect-bw keyword is entered, the bandwidth is sampled but not adjusted, and the other options, if any, are ignored.If the collect-bw keyword is not entered and some, but not all of the other keywords are entered, the defaults for the keywords not entered are: frequency, every 24 hours; min-bw, unconstrained (0); max-bw, unconstrained.

 
Command Modes

LSP attribute configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

The following conditions apply for all traffic-engineering tunnel (TE) commands that can be specified both in TE interface configuration mode, path-option command line or LSP attribute configuration mode:

  • If a setting is specified for a label switched path (LSP) either via the path-option command directly or by assigning an LSP attribute list to a path option, this setting takes precedence for that specific path option.
  • If no setting is specified for an LSP, then the LSP/path option inherits any setting specified in the tunnel-te configuration mode such as affinity, auto-bw, priority, record-route, protection/fast-reroute.

The bandwidth command configures the initial tunnel bandwidth, which is adjusted by the auto bandwidth mechanism.

This command requires the MPLS Services license.

Examples

This example shows how to configure the automatic bandwidth configuration:

switch# configure terminal
switch(config)# mpls traffic-eng configuration
switch(config-te)# lsp attributes 1
switch(config-lsp-attr)# auto-bw

 
Related Commands

Command
Description

interface tunnel-te

Configures the traffic engineering (TE) interface.

auto-bw (TE interface configuration mode)

To configure the automatic bandwidth configuration, use the auto-bw command. To restore the system to its default condition, use the no form of this command.

auto-bw [frequency secs] [max-bw kbps] [min-bw kbps] [collect-bw]

no auto-bw [frequency secs] [max-bw kbps] [min-bw kbps] [collect-bw]

 
Syntax Description

frequency

(Optional) Specifies the interval between bandwidth adjustments.

secs

(Optional) Seconds. The range is from 300 to 604800 seconds.

max-bw

(Optional) Specifies the maximum automatic bandwidth, in kbps, for this path option.

kbps

(Optional) Kilobits per second. The range is from 0 to 4294967295.

min-bw

(Optional) Specifies the minimum automatic bandwidth, in kbps, for this path option.

collect-bw

(Optional) Collects the output rate information for the path option but does not adjust the bandwidth of the path option.

 
Defaults

If the command is entered with no optional keywords, automatic bandwidth adjustment for the LSP is enabled, with adjustments made every 24 hours and with no constraints on the bandwidth adjustments made.If the collect-bw keyword is entered, the bandwidth is sampled but not adjusted, and the other options, if any, are ignored.If the collect-bw keyword is not entered and some, but not all of the other keywords are entered, the defaults for the keywords not entered are: frequency, every 24 hours; min-bw, unconstrained (0); max-bw, unconstrained.

 
Command Modes

TE interface configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

The bandwidth command configures the initial tunnel bandwidth, which is adjusted by the auto bandwidth mechanism.

This command requires the MPLS Services license.

Examples

This example shows how to enable automatic bandwidth adjustment for the tunnel and controls how the bandwidth for a tunnel is adjusted:

switch# configure terminal
switch(config)# interface tunnel-te 1
switch(config-if-te)# auto-bw max-bw 2000 min-bw 1000
switch(config-if-te)#
 

 
Related Commands

Command
Description

interface tunnel-te

Configures the traffic engineering (TE) interface.

 

auto-bw timers

To enable automatic bandwidth adjustment on a platform and begin sampling the output rate for tunnels that have been configured for automatic bandwidth adjustment, use the auto-bw timers command. To restore the system to its default condition, use the no form of this command.

auto-bw timers [frequency seconds]

no auto-bw timers [frequency seconds]

 
Syntax Description

frequency

(Optional) Specifies how often tunnel-te output rates should be sampled.

seconds

(Optional) Interval in seconds, for sampling the output rate of each tunnel configured for automatic bandwidth. The range is 1 through 604800. The recommended value is 300.

 
Defaults

When the optional frequency keyword is not specified, the sampling interval is 300 seconds (5 minutes).

 
Command Modes

Traffic engineering global configuration mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

5.2(1)

This command was introduced.

 
Usage Guidelines

The bandwidth command configures the initial tunnel bandwidth, which is adjusted by the auto bandwidth mechanism.

This command requires the MPLS Services license.

Examples

This example shows how to enable automatic bandwidth adjustment on a platform that has been configured for automatic bandwidth adjustment:

switch# configure terminal
switch(config)# mpls traffic-eng configuration
switch(config-te)# auto–bw timers frequency 600
switch(config-te)#

 
Related Commands

Command
Description

mpls traffic-eng configuration

Configures the Multiprotocol Label Switching (MPLS) Traffic Engineering Protocol (MPLS-TE).

autonomous-system

To specify the autonomous system number (ASN) for this address family for the customer site, use the autonomous-system command.

autonomous-system as-number

 
Syntax Description

as-number

AS number. The AS number can be a 16-bit integer or a 32-bit integer in the form of a higher 16-bit decimal number and a lower 16-bit decimal number in the xx.xx format.

 
Defaults

None

 
Command Modes

config-router-vrf mode

 
Supported User Roles

network-admin
vdc-admin

 
Command History

Release
Modification

6.2.2

This command was introduced.

 
Usage Guidelines

This command requires the MPLS Services license.

Examples

This example shows how to specify the ASN for an address family for a customer site:

switch# configure terminal
switch(config)# router eigrp Test1
switch(config-router)# vrf vpn1
switch(config-router-vrf)# address-family ipv4 unicast
switch(config-router-vrf-af)# redistribute bgp 1.0 route-map BGPMap
switch(config-router-vrf-af)# autonomous-system 1.3

 
Related Commands

Command
Description

address-family ipv4 unicast

Enters address family configuration mode for configuring routing sessions that use standard IPv4 address prefixes.

send-community extended

Specifies that a community’s attribute should be sent to a BGP neighbor.