Auto-QoS Commands

This chapter contains the following auto-QoS commands:

auto qos classify

To automatically configure quality of service (QoS) classification for untrusted devices within a QoS domain, use the auto qos classify command in interface configuration mode. To return to the default setting, use the no form of this command.

auto qos classify [police]

no auto qos classify [police]

Syntax Description

police

(Optional) Configures QoS policing for untrusted devices.

Command Default

Auto-QoS classify is disabled on the port.

Command Modes

Interface configuration

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

Use this command to configure the QoS for trusted interfaces within the QoS domain. The QoS domain includes the switch, the network interior, and edge devices that can classify incoming traffic for QoS.

When auto-QoS is enabled, it uses the ingress packet label to categorize traffic, to assign packet labels, and to configure the ingress and egress queues.

Table 1 Auto-QoS Configuration for the Egress Queues

Egress Queue

Queue Number

CoS-to-Queue Map

Queue Weight (Bandwidth)

Queue (Buffer) Size for Gigabit-Capable Ports

Queue (Buffer) Size for 10/100 Ethernet Ports

Priority (shaped)

1

4, 5

up to 100 percent

15 percent

15 percent

SRR shared

2

2, 3, 6,7

10 percent

25 percent

25 percent

SRR shared

3

0

60 percent

40 percent

40 percent

SRR shared

4

1

20 percent

20 percent

20 percent

Auto-QoS configures the switch for connectivity with a trusted interface. The QoS labels of incoming packets are trusted. For nonrouted ports, the CoS value of the incoming packets is trusted. For routed ports, the DSCP value of the incoming packet is trusted.

To take advantage of the auto-QoS defaults, you should enable auto-QoS before you configure other QoS commands. You can fine-tune the auto-QoS configuration after you enable auto-QoS.

To display the QoS configuration that is automatically generated when auto-QoS is enabled, enable debugging before you enable auto-QoS. Use the debug auto qos privileged EXEC command to enable auto-QoS debugging.

This is the policy map when the auto qos classify command is configured:
policy-map AUTOQOS-SRND4-CLASSIFY-POLICY 
class AUTOQOS_MULTIENHANCED_CONF_CLASS 
set dscp af41 
class AUTOQOS_BULK_DATA_CLASS 
set dscp af11 
class AUTOQOS_TRANSACTION_CLASS 
set dscp af21 
class AUTOQOS_SCAVANGER_CLASS 
set dscp cs1 
class AUTOQOS_SIGNALING_CLASS 
set dscp cs3 
class AUTOQOS_DEFAULT_CLASS 
set dscp default

This is the policy map when the auto qos classify police command is configured:

policy-map AUTOQOS-SRND4-CLASSIFY-POLICE-POLICY 
class AUTOQOS_MULTIENHANCED_CONF_CLASS 
set dscp af41 
police 5000000 8000 exceed-action drop 
class AUTOQOS_BULK_DATA_CLASS 
set dscp af11 
police 10000000 8000 exceed-action policed-dscp-transmit 
class AUTOQOS_TRANSACTION_CLASS 
set dscp af21 
police 10000000 8000 exceed-action policed-dscp-transmit 
class AUTOQOS_SCAVANGER_CLASS 
set dscp cs1 
police 10000000 8000 exceed-action drop 
class AUTOQOS_SIGNALING_CLASS 
set dscp cs3 
police 32000 8000 exceed-action drop 
class AUTOQOS_DEFAULT_CLASS 
set dscp default 
police 10000000 8000 exceed-action policed-dscp-transmit 


Note


The switch applies the auto-QoS-generated commands as if the commands were entered from the command-line interface (CLI). An existing user configuration can cause the application of the generated commands to fail or to be overridden by the generated commands. These actions occur without warning. If all the generated commands are successfully applied, any user-entered configuration that was not overridden remains in the running configuration. Any user-entered configuration that was overridden can be retrieved by reloading the switch without saving the current configuration to memory. If the generated commands fail to be applied, the previous running configuration is restored.


After auto-QoS is enabled, do not modify a policy map or aggregate policer that includes AutoQoS in its name. If you need to modify the policy map or aggregate policer, make a copy of it, and change the copied policy map or policer. To use the new policy map instead of the generated one, remove the generated policy map from the interface and apply the new policy map.


Note


To disable auto-QoS, you need remove the auto-QoS commands manually.
Enter the no mls qos global configuration command to disable the auto-QoS-generated global configuration commands. With QoS disabled, there is no concept of trusted or untrusted ports because the packets are not modified. The CoS, DSCP, and IP precedence values in the packet are not changed. Traffic is switched in pass-through mode. Packets are switched without any rewrites and classified as best effort without any policing.

To disable auto-QoS on a port, use the no auto qos trust interface configuration command. Only the auto-QoS-generated interface configuration commands for this port are removed. If this is the last port on which auto-QoS is enabled and you enter the no auto qos trust command, auto-QoS is considered disabled even though the auto-QoS-generated global configuration commands remain (to avoid disrupting traffic on other ports affected by the global configuration).

Examples

This example shows how to enable auto-QoS classification of an untrusted device and police traffic:

Switch(config)# interface gigabitethernet2/0/1
Switch(config-if)# auto qos classify police

You can verify your settings by entering the show auto qos interface interface-id privileged EXEC command.

Related Commands

Command

Description

debug auto qos

Enables debugging of the auto-QoS feature.

mls qos trust

Configures the port trust state.

queue-set

Maps a port to a queue-set.

show auto qos

Displays auto-QoS information.

show mls qos interface

Displays QoS information at the port level.

srr-queue bandwidth share

Assigns the shared weights and enables bandwidth sharing on the four egress queues mapped to a port.

auto qos trust

To automatically configure quality of service (QoS) for trusted interfaces within a QoS domain, use the auto qos trust command in interface configuration mode. To return to the default setting, use the no form of this command.

auto qos trust { cos | dscp }

no auto qos trust { cos | dscp}

Syntax Description

cos

Trusts the CoS packet classification.

dscp

Trusts the DSCP packet classification.

Command Default

Auto-QoS trust is disabled on the port.

When auto-QoS is enabled, it uses the ingress packet label to categorize traffic, to assign packet labels, and to configure the ingress and egress queues. For more information, see Table 1

Command Modes

Interface configuration

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

Use this command to configure the QoS for trusted interfaces within the QoS domain. The QoS domain includes the switch, the network interior, and edge devices that can classify incoming traffic for QoS.

Table 2 Traffic Types, Packet Labels, and Queues

VOIP Data Traffic

VOIP Control Traffic

Routing Protocol Traffic

STP1 BPDU2 Traffic

Real-Time Video Traffic

All Other Traffic

DSCP3

46

24, 26

48

56

34

CoS4

5

3

6

7

3

CoS-to-egress queue map

4, 5 (queue 1)

2, 3, 6, 7 (queue 2)

0 (queue 3)

2 (queue 3)

0, 1 (queue 4)

1 STP = Spanning Tree Protocol
2 BPDU = bridge protocol data unit
3 DSCP = Differentiated Services Code Point
4 CoS = class of service
Table 3 Auto-QoS Configuration for the Egress Queues

Egress Queue

Queue Number

CoS-to-Queue Map

Queue Weight (Bandwidth)

Queue (Buffer) Size for Gigabit-Capable Ports

Queue (Buffer) Size for 10/100 Ethernet Ports

Priority (shaped)

1

4, 5

up to 100 percent

15 percent

15 percent

SRR shared

2

2, 3, 6,7

10 percent

25 percent

25 percent

SRR shared

3

0

60 percent

40 percent

40 percent

SRR shared

4

1

20 percent

20 percent

20 percent

To display the QoS configuration that is automatically generated when auto-QoS is enabled, enable debugging before you enable auto-QoS. Use the debug auto qos privileged EXEC command to enable auto-QoS debugging.

This is the auto-QoS generated configuration for the auto qos trust cos command:

Switch config-if)#
Mar 16 02:57:46.351 PST: mls qos map cos-dscp 0 8 16 24 32 46 48 56
Mar 16 02:57:46.351 PST: mls qos 
Mar 16 02:57:46.351 PST: no mls qos srr-queue output cos-map  
Mar 16 02:57:46.362 PST: no mls qos queue-set output 2 threshold 
Mar 16 02:57:46.379 PST: no mls qos queue-set output 2 buffers 
Mar 16 02:57:46.382 PST: mls qos srr-queue output cos-map queue 1 threshold 3  4 5
Mar 16 02:57:46.386 PST: mls qos srr-queue output cos-map queue 2 threshold 1  2
Mar 16 02:57:46.393 PST: mls qos srr-queue output cos-map queue 2 threshold 2  3
Mar 16 02:57:46.403 PST: mls qos srr-queue output cos-map queue 2 threshold 3  6 7
Mar 16 02:57:46.407 PST: mls qos srr-queue output cos-map queue 3 threshold 3  0
Mar 16 02:57:46.410 PST: mls qos srr-queue output cos-map queue 4 threshold 3  1
Mar 16 02:57:46.414 PST: no mls qos srr-queue output dscp-map 
Mar 16 02:57:46.417 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  32 33 40 41 42 43 44 45
Mar 16 02:57:46.417 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  46 47
Mar 16 02:57:46.421 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
Mar 16 02:57:46.421 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  26 27 28 29 30 31 34
Mar 16 02:57:46.424 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  35 36 37 38 39
Mar 16 02:57:46.428 PST: mls qos srr-queue output dscp-map queue 2 threshold 2  24
Mar 16 02:57:46.431 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
Mar 16 02:57:46.442 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
Mar 16 02:57:46.445 PST: mls qos srr-queue output dscp-map queue 3 threshold 3  0 1 2 3 4 5 6 7
Mar 16 02:57:46.449 PST: mls qos srr-queue output dscp-map queue 4 threshold 1  8 9 11 13 15
Mar 16 02:57:46.452 PST: mls qos srr-queue output dscp-map queue 4 threshold 2  10 12 14
Mar 16 02:57:46.456 PST: mls qos queue-set output 1 threshold 1 100 100 50 200
Mar 16 02:57:46.463 PST: mls qos queue-set output 1 threshold 2 125 125 100 400
Mar 16 02:57:46.466 PST: mls qos queue-set output 1 threshold 3 100 100 100 400
Mar 16 02:57:46.470 PST: mls qos queue-set output 1 threshold 4 60 150 50 200
Mar 16 02:57:46.473 PST: mls qos queue-set output 1 buffers 15 25 40 20
Mar 16 02:57:46.484 PST: auto qos srnd4 
Mar 16 02:57:46.501 PST:   mls qos trust cos
Mar 16 02:57:46.505 PST:  no queue-set 1 
Mar 16 02:57:46.505 PST:   queue-set 1
Mar 16 02:57:46.508 PST:  priority-queue out 
Mar 16 02:57:46.512 PST:  srr-queue bandwidth share 1 30 35 5

This is the auto-QoS generated configuration for the auto qos trust dscp command:

Switch (config-if)#
switch1(config-if)#
Mar 16 02:58:40.430 PST: mls qos map cos-dscp 0 8 16 24 32 46 48 56
Mar 16 02:58:40.433 PST: mls qos 
Mar 16 02:58:40.433 PST: no mls qos srr-queue output cos-map  
Mar 16 02:58:40.444 PST: no mls qos queue-set output 2 threshold 
Mar 16 02:58:40.458 PST: no mls qos queue-set output 2 buffers 
Mar 16 02:58:40.461 PST: mls qos srr-queue output cos-map queue 1 threshold 3  4 5
Mar 16 02:58:40.465 PST: mls qos srr-queue output cos-map queue 2 threshold 1  2
Mar 16 02:58:40.468 PST: mls qos srr-queue output cos-map queue 2 threshold 2  3
Mar 16 02:58:40.472 PST: mls qos srr-queue output cos-map queue 2 threshold 3  6 7
Mar 16 02:58:40.482 PST: mls qos srr-queue output cos-map queue 3 threshold 3  0
Mar 16 02:58:40.486 PST: mls qos srr-queue output cos-map queue 4 threshold 3  1
Mar 16 02:58:40.489 PST: no mls qos srr-queue output dscp-map 
Mar 16 02:58:40.496 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  32 33 40 41 42 43 44 45
Mar 16 02:58:40.496 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  46 47
Mar 16 02:58:40.500 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
Mar 16 02:58:40.503 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  26 27 28 29 30 31 34
Mar 16 02:58:40.503 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  35 36 37 38 39
Mar 16 02:58:40.506 PST: mls qos srr-queue output dscp-map queue 2 threshold 2  24
Mar 16 02:58:40.510 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
Mar 16 02:58:40.513 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
Mar 16 02:58:40.524 PST: mls qos srr-queue output dscp-map queue 3 threshold 3  0 1 2 3 4 5 6 7
Mar 16 02:58:40.527 PST: mls qos srr-queue output dscp-map queue 4 threshold 1  8 9 11 13 15
Mar 16 02:58:40.531 PST: mls qos srr-queue output dscp-map queue 4 threshold 2  10 12 14
Mar 16 02:58:40.538 PST: mls qos queue-set output 1 threshold 1 100 100 50 200
Mar 16 02:58:40.541 PST: mls qos queue-set output 1 threshold 2 125 125 100 400
Mar 16 02:58:40.545 PST: mls qos queue-set output 1 threshold 3 100 100 100 400
Mar 16 02:58:40.548 PST: mls qos queue-set output 1 threshold 4 60 150 50 200
Mar 16 02:58:40.562 PST: mls qos queue-set output 1 buffers 15 25 40 20
Mar 16 02:58:40.566 PST: auto qos srnd4 
Mar 16 02:58:40.583 PST:   mls qos trust dscp
Mar 16 02:58:40.590 PST:  no queue-set 1 
Mar 16 02:58:40.590 PST:   queue-set 1
Mar 16 02:58:40.590 PST:  priority-queue out 
Mar 16 02:58:40.601 PST:  srr-queue bandwidth share 1 30 35 5


Note


The switch applies the auto-QoS-generated commands as if the commands were entered from the command-line interface (CLI). An existing user configuration can cause the application of the generated commands to fail or to be overridden by the generated commands. These actions occur without warning. If all the generated commands are successfully applied, any user-entered configuration that was not overridden remains in the running configuration. Any user-entered configuration that was overridden can be retrieved by reloading the switch without saving the current configuration to memory. If the generated commands fail to be applied, the previous running configuration is restored.


After auto-QoS is enabled, do not modify a policy map or aggregate policer that includes AutoQoS in its name. If you need to modify the policy map or aggregate policer, make a copy of it, and change the copied policy map or policer. To use the new policy map instead of the generated one, remove the generated policy map from the interface and apply the new policy map.


Note


To disable auto-QoS, you need to remove the auto-QoS commands manually.
Enter the no mls qos global configuration command. With QoS disabled, there is no concept of trusted or untrusted ports because the packets are not modified (the CoS, DSCP, and IP precedence values in the packet are not changed). Traffic is switched in pass-through mode (packets are switched without any rewrites and classified as best effort without any policing).

To disable auto-QoS on a port, use the no auto qos trust interface configuration command. Only the auto-QoS-generated interface configuration commands for this port are removed. If this is the last port on which auto-QoS is enabled and you enter the no auto qos trust command, auto-QoS is considered disabled even though the auto-QoS-generated global configuration commands remain (to avoid disrupting traffic on other ports affected by the global configuration).

Examples

This example shows how to enable auto-QoS for a trusted interface with specific CoS classification:

Switch(config)# interface gigabitethernet2/0/1
Switch(config-if)# auto qos trust cos

You can verify your settings by entering the show auto qos interface interface-id privileged EXEC command.

Related Commands

Command

Description

debug auto qos

Enables debugging of the auto-QoS feature.

mls qos trust

Configures the port trust state.

queue-set

Maps a port to a queue-set.

show auto qos

Displays auto-QoS information.

srr-queue bandwidth share

Assigns the shared weights and enables bandwidth sharing on the four egress queues mapped to a port.

srr-queue bandwidth share

Assigns the shared weights and enables bandwidth sharing on the four egress queues mapped to a port.

auto qos video

To automatically configure quality of service (QoS) for video within a QoS domain, use the auto qos video command in interface configuration mode. Use the no form of this command to return to the default setting.

auto qos video { cts | ip-camera | media-player}

no auto qos video { cts | ip-camera | media-player}

Syntax Description

cts

Identifies this port as connected to a Cisco TelePresence System and automatically configures QoS for video.

ip-camera

Identifies this port as connected to a Cisco IP camera and automatically configures QoS for video.

media-player

Identifies this port as connected to a CDP-capable Cisco digital media player and automatically configures QoS for video.

Command Default

Auto-QoS video is disabled on the port.

When auto-QoS is enabled, it uses the ingress packet label to categorize traffic, to assign packet labels, and to configure the ingress and egress queues.

Command Modes

Interface configuration

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

Use this command to configure the QoS appropriate for video traffic within the QoS domain. The QoS domain includes the switch, the network interior, and edge devices that can classify incoming traffic for QoS.

Table 4 Traffic Types, Packet Labels, and Queues

VOIP Data Traffic

VOIP Control Traffic

Routing Protocol Traffic

STP5 BPDU6 Traffic

Real-Time Video Traffic

All Other Traffic

DSCP7

46

24, 26

48

56

34

CoS8

5

3

6

7

3

CoS-to-egress queue map

4, 5 (queue 1)

2, 3, 6, 7 (queue 2)

2, 3, 6, 7 (queue 2)

2, 3, 6, 7 (queue 2)

0 (queue 3)

2 (queue 3)

0, 1 (queue 4)

5 STP = Spanning Tree Protocol
6 BPDU = bridge protocol data unit
7 DSCP = Differentiated Services Code Point
8 CoS = class of service
Table 5 Auto-QoS Configuration for the Egress Queues

Egress Queue

Queue Number

CoS-to-Queue Map

Queue Weight (Bandwidth)

Queue (Buffer) Size for Gigabit-Capable Ports

Queue (Buffer) Size for 10/100 Ethernet Ports

Priority (shaped)

1

4, 5

up to 100 percent

15 percent

15 percent

SRR shared

2

2, 3, 6, 7

10 percent

25 percent

25 percent

SRR shared

3

0

60 percent

40 percent

40 percent

SRR shared

4

1

20 percent

20 percent

20 percent

Auto-QoS configures the switch for video connectivity to a Cisco TelePresence system, a Cisco IP camera, or a Cisco digital media player.

To take advantage of the auto-QoS defaults, enable auto-QoS before you configure other QoS commands. You can fine-tune the auto-QoS configuration after you enable auto-QoS.

To display the QoS configuration that is automatically generated when auto-QoS is enabled, enable debugging before you enable auto-QoS. Use the debug auto qos privileged EXEC command to enable auto-QoS debugging.

This is the QoS configuration that is automatically generated for the auto qos video cts command:

Switch(config-if)# auto qos video cts

Mar 16 02:54:17.286 PST: mls qos map cos-dscp 0 8 16 24 32 46 48 56
Mar 16 02:54:17.296 PST: mls qos 
Mar 16 02:54:17.296 PST: no mls qos srr-queue output cos-map  
Mar 16 02:54:17.300 PST: no mls qos queue-set output 2 threshold 
Mar 16 02:54:17.324 PST: no mls qos queue-set output 2 buffers 
Mar 16 02:54:17.328 PST: mls qos srr-queue output cos-map queue 1 threshold 3  4 5
Mar 16 02:54:17.331 PST: mls qos srr-queue output cos-map queue 2 threshold 1  2
Mar 16 02:54:17.331 PST: mls qos srr-queue output cos-map queue 2 threshold 2  3
Mar 16 02:54:17.338 PST: mls qos srr-queue output cos-map queue 2 threshold 3  6 7
Mar 16 02:54:17.338 PST: mls qos srr-queue output cos-map queue 3 threshold 3  0
Mar 16 02:54:17.342 PST: mls qos srr-queue output cos-map queue 4 threshold 3  1
Mar 16 02:54:17.345 PST: no mls qos srr-queue output dscp-map 
Mar 16 02:54:17.349 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  32 33 40 41 42 43 44 45
Mar 16 02:54:17.363 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  46 47
Mar 16 02:54:17.366 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
Mar 16 02:54:17.370 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  26 27 28 29 30 31 34
Mar 16 02:54:17.373 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  35 36 37 38 39
Mar 16 02:54:17.380 PST: mls qos srr-queue output dscp-map queue 2 threshold 2  24
Mar 16 02:54:17.384 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
Mar 16 02:54:17.387 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
Mar 16 02:54:17.391 PST: mls qos srr-queue output dscp-map queue 3 threshold 3  0 1 2 3 4 5 6 7
Mar 16 02:54:17.401 PST: mls qos srr-queue output dscp-map queue 4 threshold 1  8 9 11 13 15
Mar 16 02:54:17.405 PST: mls qos srr-queue output dscp-map queue 4 threshold 2  10 12 14
Mar 16 02:54:17.408 PST: mls qos queue-set output 1 threshold 1 100 100 50 200
Mar 16 02:54:17.415 PST: mls qos queue-set output 1 threshold 2 125 125 100 400
Mar 16 02:54:17.419 PST: mls qos queue-set output 1 threshold 3 100 100 100 400
Mar 16 02:54:17.422 PST: mls qos queue-set output 1 threshold 4 60 150 50 200
Mar 16 02:54:17.426 PST: mls qos queue-set output 1 buffers 15 25 40 20
Mar 16 02:54:17.433 PST: auto qos srnd4 
Mar 16 02:54:17.454 PST:   mls qos trust device cts
Mar 16 02:54:17.457 PST:   mls qos trust dscp
Mar 16 02:54:17.464 PST:  no queue-set 1 
Mar 16 02:54:17.464 PST:   queue-set 1
Mar 16 02:54:17.468 PST:  priority-queue out 
Mar 16 02:54:17.482 PST:  srr-queue bandwidth share 1 30 35 5

This is the QoS configuration that is automatically generated for the auto qos video ip-camera command:

Switch(config-if)# auto qos video ip-camera
Mar 16 02:55:43.675 PST: mls qos map cos-dscp 0 8 16 24 32 46 48 56
Mar 16 02:55:43.685 PST: mls qos 
Mar 16 02:55:43.685 PST: no mls qos srr-queue output cos-map  
Mar 16 02:55:43.689 PST: no mls qos queue-set output 2 threshold 
Mar 16 02:55:43.703 PST: no mls qos queue-set output 2 buffers 
Mar 16 02:55:43.706 PST: mls qos srr-queue output cos-map queue 1 threshold 3  4 5
Mar 16 02:55:43.710 PST: mls qos srr-queue output cos-map queue 2 threshold 1  2
Mar 16 02:55:43.710 PST: mls qos srr-queue output cos-map queue 2 threshold 2  3
Mar 16 02:55:43.724 PST: mls qos srr-queue output cos-map queue 2 threshold 3  6 7
Mar 16 02:55:43.727 PST: mls qos srr-queue output cos-map queue 3 threshold 3  0
Mar 16 02:55:43.731 PST: mls qos srr-queue output cos-map queue 4 threshold 3  1
Mar 16 02:55:43.734 PST: no mls qos srr-queue output dscp-map 
Mar 16 02:55:43.741 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  32 33 40 41 42 43 44 45
Mar 16 02:55:43.745 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  46 47
Mar 16 02:55:43.748 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
Mar 16 02:55:43.762 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  26 27 28 29 30 31 34
Mar 16 02:55:43.766 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  35 36 37 38 39
Mar 16 02:55:43.769 PST: mls qos srr-queue output dscp-map queue 2 threshold 2  24
Mar 16 02:55:43.773 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
Mar 16 02:55:43.780 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
Mar 16 02:55:43.783 PST: mls qos srr-queue output dscp-map queue 3 threshold 3  0 1 2 3 4 5 6 7
Mar 16 02:55:43.786 PST: mls qos srr-queue output dscp-map queue 4 threshold 1  8 9 11 13 15
Mar 16 02:55:43.790 PST: mls qos srr-queue output dscp-map queue 4 threshold 2  10 12 14
Mar 16 02:55:43.793 PST: mls qos queue-set output 1 threshold 1 100 100 50 200
Mar 16 02:55:43.804 PST: mls qos queue-set output 1 threshold 2 125 125 100 400
Mar 16 02:55:43.807 PST: mls qos queue-set output 1 threshold 3 100 100 100 400
Mar 16 02:55:43.811 PST: mls qos queue-set output 1 threshold 4 60 150 50 200
Mar 16 02:55:43.814 PST: mls qos queue-set output 1 buffers 15 25 40 20
Mar 16 02:55:43.818 PST: auto qos srnd4 
Mar 16 02:55:43.832 PST:   mls qos trust device ip-camera
Mar 16 02:55:43.842 PST:   mls qos trust dscp
Mar 16 02:55:43.849 PST:  no queue-set 1 
Mar 16 02:55:43.849 PST:   queue-set 1
Mar 16 02:55:43.849 PST:  priority-queue out 
Mar 16 02:55:43.853 PST:  srr-queue bandwidth share 1 30 35 5

This is the QoS configuration that is automatically generated for the auto qos video media-player command:

Switch(config-if)# auto qos video media-player
Mar 16 02:56:39.969 PST: mls qos map cos-dscp 0 8 16 24 32 46 48 56
Mar 16 02:56:39.980 PST: mls qos 
Mar 16 02:56:39.980 PST: no mls qos srr-queue output cos-map  
Mar 16 02:56:39.987 PST: no mls qos queue-set output 2 threshold 
Mar 16 02:56:40.011 PST: no mls qos queue-set output 2 buffers 
Mar 16 02:56:40.011 PST: mls qos srr-queue output cos-map queue 1 threshold 3  4 5
Mar 16 02:56:40.015 PST: mls qos srr-queue output cos-map queue 2 threshold 1  2
Mar 16 02:56:40.018 PST: mls qos srr-queue output cos-map queue 2 threshold 2  3
Mar 16 02:56:40.018 PST: mls qos srr-queue output cos-map queue 2 threshold 3  6 7
Mar 16 02:56:40.022 PST: mls qos srr-queue output cos-map queue 3 threshold 3  0
Mar 16 02:56:40.022 PST: mls qos srr-queue output cos-map queue 4 threshold 3  1
Mar 16 02:56:40.029 PST: no mls qos srr-queue output dscp-map 
Mar 16 02:56:40.029 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  32 33 40 41 42 43 44 45
Mar 16 02:56:40.043 PST: mls qos srr-queue output dscp-map queue 1 threshold 3  46 47
Mar 16 02:56:40.046 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
Mar 16 02:56:40.050 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  26 27 28 29 30 31 34
Mar 16 02:56:40.053 PST: mls qos srr-queue output dscp-map queue 2 threshold 1  35 36 37 38 39
Mar 16 02:56:40.057 PST: mls qos srr-queue output dscp-map queue 2 threshold 2  24
Mar 16 02:56:40.064 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
Mar 16 02:56:40.067 PST: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
Mar 16 02:56:40.071 PST: mls qos srr-queue output dscp-map queue 3 threshold 3  0 1 2 3 4 5 6 7
Mar 16 02:56:40.081 PST: mls qos srr-queue output dscp-map queue 4 threshold 1  8 9 11 13 15
Mar 16 02:56:40.085 PST: mls qos srr-queue output dscp-map queue 4 threshold 2  10 12 14
Mar 16 02:56:40.092 PST: mls qos queue-set output 1 threshold 1 100 100 50 200
Mar 16 02:56:40.095 PST: mls qos queue-set output 1 threshold 2 125 125 100 400
Mar 16 02:56:40.099 PST: mls qos queue-set output 1 threshold 3 100 100 100 400
Mar 16 02:56:40.102 PST: mls qos queue-set output 1 threshold 4 60 150 50 200
Mar 16 02:56:40.106 PST: mls qos queue-set output 1 buffers 15 25 40 20
Mar 16 02:56:40.109 PST: auto qos srnd4 
Mar 16 02:56:40.130 PST:   mls qos trust device media-player
Mar 16 02:56:40.133 PST:   mls qos trust dscp
Mar 16 02:56:40.137 PST:  no queue-set 1 
Mar 16 02:56:40.137 PST:   queue-set 1
Mar 16 02:56:40.140 PST:  priority-queue out 
Mar 16 02:56:40.172 PST:  srr-queue bandwidth share 1 30 35 5


Note


The switch applies the auto-QoS-generated commands as if the commands were entered from the command-line interface (CLI). An existing user configuration can cause the application of the generated commands to fail or to be overridden by the generated commands. These actions occur without warning. If all the generated commands are successfully applied, any user-entered configuration that was not overridden remains in the running configuration. Any user-entered configuration that was overridden can be retrieved by reloading the switch without saving the current configuration to memory. If the generated commands fail to be applied, the previous running configuration is restored.


If this is the first port on which you have enabled auto-QoS, the auto-QoS-generated global configuration commands are executed followed by the interface configuration commands. If you enable auto-QoS on another port, only the auto-QoS-generated interface configuration commands for that port are executed.

When you enable the auto-QoS feature on the first port, QoS is globally enabled (mls qos global configuration command), and other global configuration commands are added.

After auto-QoS is enabled, do not modify a policy map or aggregate policer that includes AutoQoS in its name. If you need to modify the policy map or aggregate policer, make a copy of it, and change the copied policy map or policer. To use the new policy map instead of the generated one, remove the generated policy map from the interface, and apply the new policy map.


Note


To disable auto-QoS, you need to remove the auto-QoS commands manually.
Enter the no mls qos global configuration command to disable the auto-QoS-generated global configuration commands. With QoS disabled, there is no concept of trusted or untrusted ports because the packets are not modified (the CoS, DSCP, and IP precedence values in the packet are not changed). Traffic is switched in pass-through mode (packets are switched without any rewrites and classified as best effort without any policing).

To disable auto-QoS on a port, use the no auto qos video interface configuration command. Only the auto-QoS-generated interface configuration commands for this port are removed. If this is the last port on which auto-QoS is enabled and you enter the no auto qos video command, auto-QoS is considered disabled even though the auto-QoS-generated global configuration commands remain (to avoid disrupting traffic on other ports affected by the global configuration).

Examples

This example shows how to enable auto-QoS for a Cisco Telepresence interface with conditional trust. The interface is trusted only if a Cisco Telepresence device is detected; otherwise, the port is untrusted.

Switch(config)# interface gigabitethernet2/0/1
Switch(config-if)# auto qos video cts

You can verify your settings by entering the show auto qos video interface interface-id privileged EXEC command.

Related Commands

Command

Description

debug auto qos

Enables debugging of the auto-QoS feature.

mls qos trust

Configures the port trust state.

queue-set

Maps a port to a queue-set.

show auto qos

Displays auto-QoS information.

show mls qos interface

Displays QoS information at the port level.

srr-queue bandwidth share

Assigns the shared weights and enables bandwidth sharing on the four egress queues mapped to a port.

auto qos voip

To automatically configure quality of service (QoS) for voice over IP (VoIP) within a QoS domain, use the auto qos voip command in interface configuration mode. Use the no form of this command to return to the default setting.

auto qos voip { cisco-phone | cisco-softphone | trust}

no auto qos voip { cisco-phone | cisco-softphone | trust}

Syntax Description

cisco-phone

Identifies this port as connected to a Cisco IP Phone, and automatically configures QoS for VoIP. The QoS labels of incoming packets are trusted only when the telephone is detected.

cisco-softphone

Identifies this port as connected to a device running the Cisco SoftPhone, and automatically configures QoS for VoIP.

trust

Identifies this port as connected to a trusted switch, and automatically configures QoS for VoIP. The QoS labels of incoming packets are trusted. For nonrouted ports, the CoS value of the incoming packet is trusted. For routed ports, the DSCP value of the incoming packet is trusted.

Command Default

Auto-QoS is disabled on the port.

When auto-QoS is enabled, it uses the ingress packet label to categorize traffic, assign packet labels, and configure the ingress and egress queues. For more information, seeTable 1

Command Modes

Interface configuration

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

Use this command to configure the QoS appropriate for VoIP traffic within the QoS domain. The QoS domain includes the switch, the network interior, and edge devices that can classify incoming traffic for QoS.

Auto-QoS configures the switch for VoIP with Cisco IP Phones on switch and routed ports and for VoIP with devices running the Cisco SoftPhone application. These releases support only Cisco IP SoftPhone Version 1.3(3) or later. Connected devices must use Cisco Call Manager Version 4 or later.

To take advantage of the auto-QoS defaults, enable auto-QoS before you configure other QoS commands. You can fine-tune the auto-QoS configuration after you enable auto-QoS.

Table 6 Traffic Types, Packet Labels, and Queues

VOIP Data Traffic

VOIP Control Traffic

Routing Protocol Traffic

STP9 BPDU10 Traffic

Real-Time Video Traffic

All Other Traffic

DSCP11

46

24, 26

48

56

34

CoS12

5

3

6

7

3

CoS-to-egress queue map

4, 5 (queue 1)

2, 3, 6, 7 (queue 2)

2, 3, 6, 7 (queue 2)

2, 3, 6, 7 (queue 2)

0 (queue 3)

2 (queue 3)

0, 1 (queue 4)

9 STP = Spanning Tree Protocol
10 BPDU = bridge protocol data unit
11 DSCP = Differentiated Services Code Point
12 CoS = class of service
The switch configures egress queues on the port according to the settings in this table.

Table 7 Auto-QoS Configuration for the Egress Queues

Egress Queue

Queue Number

CoS-to-Queue Map

Queue Weight (Bandwidth)

Queue (Buffer) Size for Gigabit-Capable Ports

Queue (Buffer) Size for 10/100 Ethernet Ports

Priority (shaped)

1

4, 5

up to 100 percent

15 percent

15 percent

SRR shared

2

2, 3, 6, 7

10 percent

25 percent

25 percent

SRR shared

3

0

60 percent

40 percent

40 percent

SRR shared

4

1

20 percent

20 percent

20 percent


Note


The switch applies the auto-QoS-generated commands as if the commands were entered from the command-line interface (CLI). An existing user configuration can cause the application of the generated commands to fail or to be overridden by the generated commands. These actions occur without warning. If all the generated commands are successfully applied, any user-entered configuration that was not overridden remains in the running configuration. Any user-entered configuration that was overridden can be retrieved by reloading the switch without saving the current configuration to memory. If the generated commands fail to be applied, the previous running configuration is restored.


If this is the first port on which you have enabled auto-QoS, the auto-QoS-generated global configuration commands are executed followed by the interface configuration commands. If you enable auto-QoS on another port, only the auto-QoS-generated interface configuration commands for that port are executed.

When you enable the auto-QoS feature on the first port, these automatic actions occur:

  • QoS is globally enabled (mls qos global configuration command), and other global configuration commands are added.
  • When you enter the auto qos voip cisco-phone interface configuration command on a port at the edge of the network that is connected to a Cisco IP Phone, the switch enables the trusted boundary feature. The switch uses the Cisco Discovery Protocol (CDP) to detect the presence of a Cisco IP Phone. When a Cisco IP Phone is detected, the ingress classification on the port is set to trust the QoS label received in the packet. The switch also uses policing to determine whether a packet is in or out of profile and to specify the action on the packet. If the packet does not have a DSCP value of 24, 26, or 46 or is out of profile, the switch changes the DSCP value to 0. When a Cisco IP Phone is absent, the ingress classification is set to not trust the QoS label in the packet. The policing is applied to the traffic that matches the policy-map classification before the switch enables the trust boundary feature.
  • When you enter the auto qos voip cisco-softphone interface configuration command on a port at the edge of the network that is connected to a device running the Cisco SoftPhone, the switch uses policing to decide whether a packet is in or out of profile and to specify the action on the packet. If the packet does not have a DSCP value of 24, 26, or 46 or is out of profile, the switch changes the DSCP value to 0.
  • When you enter the auto qos voip trust interface configuration command on a port connected to the network interior, the switch trusts the CoS value for nonrouted ports or the DSCP value for routed ports in ingress packets (the assumption is that traffic has already been classified by other edge devices).

You can enable auto-QoS on static, dynamic-access, and voice VLAN access, and trunk ports. When enabling auto-QoS with a Cisco IP Phone on a routed port, you must assign a static IP address to the IP phone.


Note


When a device running Cisco SoftPhone is connected to a switch or routed port, the switch supports only one Cisco SoftPhone application per port.


After auto-QoS is enabled, do not modify a policy map or aggregate policer that includes AutoQoS in its name. If you need to modify the policy map or aggregate policer, make a copy of it, and change the copied policy map or policer. To use the new policy map instead of the generated one, remove the generated policy map from the interface, and apply the new policy map.

To display the QoS configuration that is automatically generated when auto-QoS is enabled, enable debugging before you enable auto-QoS. Use the debug auto qos privileged EXEC command to enable auto-QoS debugging.


Note


To disable auto-QoS, you need to remove the auto-QoS commands manually.
Enter the no mls qos global configuration command to disable the auto-QoS-generated global configuration commands. With QoS disabled, there is no concept of trusted or untrusted ports because the packets are not modified (the CoS, DSCP, and IP precedence values in the packet are not changed). Traffic is switched in pass-through mode. Packets are switched without any rewrites and classified as best effort without any policing.

To disable auto-QoS on a port, use the no auto qos voip interface configuration command. Only the auto-QoS-generated interface configuration commands for this port are removed. If this is the last port on which auto-QoS is enabled and you enter the no auto qos voip command, auto-QoS is considered disabled even though the auto-QoS-generated global configuration commands remain (to avoid disrupting traffic on other ports affected by the global configuration).

This is the enhanced configuration for the auto qos voip cisco-phone command:

Switch(config)# mls qos map policed-dscp  0 10 18 to 8
Switch(config)# mls qos map cos-dscp 0 8 16 24 32 46 48 56
Switch(config)# class-map match-all AUTOQOS_VOIP_DATA_CLASS
Switch(config-cmap)# match ip dscp ef 
Switch(config)# class-map match-all AUTOQOS_DEFAULT_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-DEFAULT
Switch(config)# class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-cmap)# match ip dscp cs3 
Switch(config)# policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
Switch(config-pmap)# class AUTOQOS_VOIP_DATA_CLASS
Switch(config-pmap-c)# set dscp ef
Switch(config-pmap-c)# police 128000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)# police 32000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_DEFAULT_CLASS
Switch(config-pmap-c)# set dscp default
Switch(config-pmap-c)# police 10000000 8000 exceed-action policed-dscp-transmit
Switch(config-if)# service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

This is the enhanced configuration for the auto qos voip cisco-softphone command:

Switch(config)# mls qos map policed-dscp  0 10 18 to 8
Switch(config)# mls qos map cos-dscp 0 8 16 24 32 46 48 56
Switch(config)# class-map match-all AUTOQOS_MULTIENHANCED_CONF_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-MULTIENHANCED-CONF
Switch(config)# class-map match-all AUTOQOS_VOIP_DATA_CLASS
Switch(config-cmap)# match ip dscp ef 
Switch(config)# class-map match-all AUTOQOS_DEFAULT_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-DEFAULT
Switch(config)# class-map match-all AUTOQOS_TRANSACTION_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-TRANSACTIONAL-DATA
Switch(config)# class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-cmap)# match ip dscp cs3 
Switch(config)# class-map match-all AUTOQOS_SIGNALING_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-SIGNALING
Switch(config)# class-map match-all AUTOQOS_BULK_DATA_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-BULK-DATA
Switch(config)# class-map match-all AUTOQOS_SCAVANGER_CLASS
Switch(config-cmap)# match access-group name AUTOQOS-ACL-SCAVANGER
Switch(config)# policy-map AUTOQOS-SRND4-SOFTPHONE-POLICY
Switch(config-pmap)# class AUTOQOS_VOIP_DATA_CLASS
Switch(config-pmap-c)# set dscp ef
Switch(config-pmap-c)# police 128000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_VOIP_SIGNAL_CLASS
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)# police 32000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_MULTIENHANCED_CONF_CLASS
Switch(config-pmap-c)# set dscp af41
Switch(config-pmap-c)# police 5000000 8000 exceed-action drop
Switch(config-pmap)# class AUTOQOS_BULK_DATA_CLASS
Switch(config-pmap-c)# set dscp af11
Switch(config-pmap-c)# police 10000000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_TRANSACTION_CLASS
Switch(config-pmap-c)# set dscp af21
Switch(config-pmap-c)# police 10000000 8000 exceed-action policed-dscp-transmit
Switch(config-pmap)# class AUTOQOS_SCAVANGER_CLASS
Switch(config-pmap-c)# set dscp cs1
Switch(config-pmap-c)# police 10000000 8000 exceed-action drop
Switch(config-pmap)# class AUTOQOS_SIGNALING_CLASS
Switch(config-pmap-c)# set dscp cs3
Switch(config-pmap-c)# police 32000 8000 exceed-action drop
Switch(config-pmap)# class AUTOQOS_DEFAULT_CLASS
Switch(config-pmap-c)# set dscp default
Switch(config-if)# service-policy input AUTOQOS-SRND4-SOFTPHONE-POLICY

Examples

This example shows how to enable auto-QoS and to trust the QoS labels received in incoming packets when the switch or router connected to the port is a trusted device:

Switch(config)# interface gigabitethernet2/0/1
Switch(config-if)# auto qos voip trust

You can verify your settings by entering the show auto qos interface interface-id privileged EXEC command.

Related Commands

Command

Description

debug auto qos

Enables debugging of the auto-QoS feature.

mls qos cos

Defines the default CoS value of a port or assigns the default CoS to all incoming packets on the port.

mls qos map

Defines the CoS-to-DSCP map or the DSCP-to-CoS map.

mls qos queue-set output buffers

Allocates buffers to a queue-set.

mls qos srr-queue output cos-map

Maps CoS values to an egress queue or maps CoS values to a queue and to a threshold ID.

mls qos srr-queue output dscp-map

Maps DSCP values to an egress queue or maps DSCP values to a queue and to a threshold ID.

mls qos trust

Configures the port trust state.

queue-set

Maps a port to a queue-set.

show auto qos

Displays auto-QoS information.

show mls qos interface

Displays QoS information at the port level.

srr-queue bandwidth shape

Assigns the shaped weights and enables bandwidth shaping on the four egress queues mapped to a port.

srr-queue bandwidth share

Assigns the shared weights and enables bandwidth sharing on the four egress queues mapped to a port.

debug auto qos

To enable debugging of the automatic quality of service (auto-QoS) feature, use the debug auto qos command in privileged EXEC mode. Use the no form of this command to disable debugging.

debug auto qos

no debug auto qos

Syntax Description

This command has no arguments or keywords.

Command Default

Auto-QoS debugging is disabled.

Command Modes

Privileged EXEC

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

To display the QoS configuration that is automatically generated when auto-QoS is enabled, enable debugging before you enable auto-QoS. You enable debugging by entering the debug auto qos privileged EXEC command.

The undebug auto qos command is the same as the no debug auto qos command.

When you enable debugging on a switch stack, it is enabled only on the active switch. To enable debugging on a stack member, you can start a session from the active switch by using the session switch-number privileged EXEC command. Then enter the debug command at the command-line prompt of the stack member. You also can use the remote command stack-member-number LINE privileged EXEC command on the active switch to enable debugging on a member switch without first starting a session.

Examples

This example shows how to display the QoS configuration that is automatically generated when auto-QoS is enabled:

Switch# debug auto qos 
Auto QoS debugging is on

Switch# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)#auto qos voip cisco-softphone 
May 31 09:03:32.293: no policy-map AUTOQOS-SRND4-SOFTPHONE-POLICY 
May 31 09:03:32.296: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-SOFTPHONE-POLICY '
May 31 09:03:32.296: no policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY 
May 31 09:03:32.300: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY '
May 31 09:03:32.300: no policy-map AUTOQOS-SRND4-CLASSIFY-POLICY 
May 31 09:03:32.300: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CLASSIFY-POLICY '
May 31 09:03:32.303: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CLASSIFY-POLICE-POLICY '
May 31 09:03:32.303: no  class-map match-all AUTOQOS_DEFAULT_CLASS
May 31 09:03:32.307: no  class-map match-all AUTOQOS_MULTIENHANCED_CONF_CLASS
May 31 09:03:32.310: no  class-map match-all AUTOQOS_TRANSACTION_CLASS
May 31 09:03:32.310: no  class-map match-all AUTOQOS_BULK_DATA_CLASS
May 31 09:03:32.314: no  class-map match-all AUTOQOS_SCAVANGER_CLASS
May 31 09:03:32.317: no  class-map match-all AUTOQOS_SIGNALING_CLASS
May 31 09:03:32.321: no  class-map match-all AUTOQOS_VOIP_DATA_CLASS
May 31 09:03:32.324: no  class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
May 31 09:03:32.324: no  ip access-list extended AUTOQOS-ACL-DEFAULT
May 31 09:03:32.328: no  ip access-list extended AUTOQOS-ACL-BULK-DATA
May 31 09:03:32.331: no  ip access-list extended AUTOQOS-ACL-SCAVANGER
May 31 09:03:32.335: no  ip access-list extended AUTOQOS-ACL-TRANSACTIONAL-DATA
May 31 09:03:32.338: no  ip access-list extended AUTOQOS-ACL-SIGNALING
May 31 09:03:32.415: no  ip access-list extended AUTOQOS-ACL-MULTIENHANCED-CONF
May 31 09:03:32.419: mls qos map cos-dscp 0 8 16 24 32 46 48 56
May 31 09:03:32.426: mls qos 
May 31 09:03:32.426: no mls qos srr-queue output cos-map 
May 31 09:03:32.429: no mls qos map policed-dscp 
May 31 09:03:32.446: mls qos srr-queue output cos-map queue 1 threshold 3  5
May 31 09:03:32.450: mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
May 31 09:03:32.527: mls qos srr-queue output cos-map queue 3 threshold 3  2 4
May 31 09:03:32.530: mls qos srr-queue output cos-map queue 4 threshold 2  1
May 31 09:03:32.530: mls qos srr-queue output cos-map queue 4 threshold 3  0
May 31 09:03:32.537: no mls qos srr-queue output dscp-map 
May 31 09:03:32.541: mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
May 31 09:03:32.544: mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
May 31 09:03:32.544: mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
May 31 09:03:32.544: mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
May 31 09:03:32.548: mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
May 31 09:03:32.548: mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
May 31 09:03:32.621: mls qos srr-queue output dscp-map queue 4 threshold 1  8
May 31 09:03:32.628: mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
May 31 09:03:32.751: mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
May 31 09:03:32.761: mls qos queue-set output 1 threshold 1 138 138 92 138
May 31 09:03:32.779: mls qos queue-set output 1 threshold 2 138 138 92 400
May 31 09:03:32.779: mls qos queue-set output 1 threshold 3 36 77 100 318
May 31 09:03:32.782: mls qos queue-set output 1 threshold 4 20 50 67 400
May 31 09:03:32.859: mls qos queue-set output 1 buffers 10 10 26 54
May 31 09:03:33.488: no policy-map AUTOQOS-SRND4-SOFTPHONE-POLICY 
May 31 09:03:33.492: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-SOFTPHONE-POLICY '
May 31 09:03:33.492: no policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY 
May 31 09:03:33.495: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY '
May 31 09:03:33.495: no policy-map AUTOQOS-SRND4-CLASSIFY-POLICY 
May 31 09:03:33.495: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CLASSIFY-POLICY '
May 31 09:03:33.495: no policy-map AUTOQOS-SRND4-CLASSIFY-POLICE-POLICY 
May 31 09:03:33.499: %PARSE_RC-4-PRC_NON_COMPLIANCE: `no policy-map AUTOQOS-SRND4-CLASSIFY-POLICE-POLICY '
May 31 09:03:33.499: no  class-map match-all AUTOQOS_DEFAULT_CLASS
May 31 09:03:33.499: no  class-map match-all AUTOQOS_MULTIENHANCED_CONF_CLASS
May 31 09:03:33.499: no  class-map match-all AUTOQOS_TRANSACTION_CLASS
May 31 09:03:33.502: no  class-map match-all AUTOQOS_BULK_DATA_CLASS
May 31 09:03:33.502: no  class-map match-all AUTOQOS_SCAVANGER_CLASS
May 31 09:03:33.502: no  class-map match-all AUTOQOS_SIGNALING_CLASS
May 31 09:03:33.502: no  class-map match-all AUTOQOS_VOIP_DATA_CLASS
May 31 09:03:33.502: no  class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
May 31 09:03:33.502: no  ip access-list extended AUTOQOS-ACL-DEFAULT
May 31 09:03:33.506: no  ip access-list extended AUTOQOS-ACL-BULK-DATA
May 31 09:03:33.509: no  ip access-list extended AUTOQOS-ACL-SCAVANGER
May 31 09:03:33.513: no  ip access-list extended AUTOQOS-ACL-TRANSACTIONAL-DATA
May 31 09:03:33.516: no  ip access-list extended AUTOQOS-ACL-SIGNALING
May 31 09:03:33.520: no  ip access-list extended AUTOQOS-ACL-MULTIENHANCED-CONF
May 31 09:03:33.523: no mls qos map cos-dscp 
May 31 09:03:33.544: no mls qos 
May 31 09:03:33.638: no mls qos srr-queue output cos-map 
May 31 09:03:33.642: no mls qos map policed-dscp 
May 31 09:03:33.642: no mls qos srr-queue output dscp-map 
May 31 09:03:33.656: no mls qos queue-set output 1 threshold 1
May 31 09:03:33.659: no mls qos queue-set output 1 threshold 2
May 31 09:03:33.663: no mls qos queue-set output 1 threshold 3
May 31 09:03:33.663: no mls qos queue-set output 1 threshold 4
May 31 09:03:33.663: no mls qos queue-set output 1 buffers
May 31 09:03:33.782: no mls qos queue-set output 2 threshold 1
May 31 09:03:33.785: no mls qos queue-set output 2 threshold 2
May 31 09:03:33.785: no mls qos queue-set output 2 threshold 3
May 31 09:03:33.785: no mls qos queue-set output 2 threshold 4
May 31 09:03:33.789: no mls qos queue-set output 2 buffers
May 31 09:03:33.789: mls qos srr-queue output queues 8 
May 31 09:03:33.792: mls qos 

Related Commands

Command

Description

show auto qos

Displays the initial configuration that is generated by the auto-QoS feature.

show debugging

Displays information about the types of debugging that are enabled.

show auto qos

To display the quality of service (QoS) commands entered on the interfaces on which auto-QoS is enabled, use the show auto qos command in privileged EXEC mode.

show auto qos [ interface [interface-id] ]

Syntax Description

interface [interface-id]

(Optional) Displays auto-QoS information for the specified port or for all ports. Valid interfaces include physical ports.

Command Modes

User EXEC

Privileged EXEC

Command History

Release

Modification

Cisco IOS 15.0(2)EX

This command was introduced.

Usage Guidelines

The show auto qos command output shows only the auto qos command entered on each interface. The show auto qos interface interface-id command output shows the auto qos command entered on a specific interface.

Use the show running-config privileged EXEC command to display the auto-QoS configuration and the user modifications.

The show auto qos command output shows the service policy information for the Cisco IP phone.

To display information about the QoS configuration that might be affected by auto-QoS, use one of these commands:

  • show mls qos

  • show mls qos maps cos-dscp

  • show mls qos interface [interface-id] [buffers | queueing]

  • show mls qos maps [cos-dscp | cos-input-q | cos-output-q | dscp-cos | dscp-input-q | dscp-output-q]

  • show mls qos input-queue

  • show running-config

Examples

This is an example of output from the show auto qos command after the auto qos voip cisco-phone and the auto qos voip cisco-softphone interface configuration commands are entered:

Switch# show auto qos
GigabitEthernet2/0/4
auto qos voip cisco-softphone

GigabitEthernet2/0/5
auto qos voip cisco-phone


GigabitEthernet2/0/6
auto qos voip cisco-phone

This is an example of output from the show auto qos interface interface-id command when the auto qos voip cisco-phone interface configuration command is entered:

Switch# show auto qos interface gigabitethernet 2/0/5
GigabitEthernet2/0/5
auto qos voip cisco-phone

This is an example of output from the show running-config privileged EXEC command when the auto qos voip cisco-phone and the auto qos voip cisco-softphone interface configuration commands are entered:

Switch# show running-config
Building configuration...
...
mls qos map policed-dscp  0 10 18 24 46 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
mls qos
...
!
spanning-tree mode pvst
spanning-tree extend system-id
!
network-policy profile 1
!
vlan access-map vmap4 10
 action forward
!
vlan internal allocation policy ascending
!
class-map match-all paul
class-map match-all cm-1
  match ip dscp af11
class-map match-all AUTOQOS_VOIP_DATA_CLASS
  match ip dscp ef
class-map match-all AUTOQOS_DEFAULT_CLASS
  match access-group name AUTOQOS-ACL-DEFAULT
class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS
  match ip dscp cs3
class-map match-all ftp_class
!
policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY
 class AUTOQOS_VOIP_DATA_CLASS
   set dscp ef
  police 128000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_VOIP_SIGNAL_CLASS
   set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit
 class AUTOQOS_DEFAULT_CLASS
   set dscp default
  police 10000000 8000 exceed-action policed-dscp-transmit
policy-map policy_ftp
 class ftp_class
!!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
!
interface GigabitEthernet1/0/2
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
 service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
!

<output truncated>

These are examples of output from the show auto qos interface command:

Switch# show auto qos interface

!
interface GigabitEthernet2/0/4
 switchport mode access
 switchport port-security maximum 400
 service-policy input AutoQoS-Police-SoftPhone
 speed 100
 duplex half
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 auto qos voip cisco-softphone
!
interface GigabitEthernet2/0/5
 switchport mode access
 switchport port-security maximum 1999
 speed 100
 duplex full
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
!
interface GigabitEthernet2/0/6
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode access
 speed 10
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
!
interface GigabitEthernet4/0/1
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust device cisco-phone
 mls qos trust cos
 mls qos trust device cisco-phone 
service-policy input AutoQoS-Police-CiscoPhone

These are examples of output from the show auto qos interface interface-id command when auto-QoS is disabled on an interface:

Switch# show auto qos interface gigabitethernet3/0/1
AutoQoS is disabled

Related Commands

Command

Description

debug auto qos

Enables debugging of the auto-QoS feature.