- Index
- Preface
- Product Overview
- Command-Line Interfaces
- Configuring the Switch for the First Time
- Configuring a Supervisor Engine 32 PISA
- Configuring NSF with SSO Supervisor Engine Redundancy
- Configuring RPR Supervisor Engine Redundancy
- Configuring Interfaces
- Configuring Layer 2 Ethernet Interfaces
- Configuring Flex Links
- Configuring Layer 3 and Layer 2 EtherChannel
- Configuring VLAN Trunking Protocol (VTP)
- Configuring VLANs
- Configuring Private VLANs (PVLANs)
- Configuring Cisco IP Phone Support
- Configuring IEEE 802.1Q Tunneling
- Configuring Layer 2 Protocol Tunneling (L2PT)
- Configuring STP and MST
- Configuring STP Features
- Configuring Layer 3 Interfaces
- Configuring UDE and UDLR
- Configuring PFC3BXL and PFC3B Multiprotocol Label Switching (MPLS)
- Configuring IPv4 Multicast VPN Support
- Configuring IP Unicast Layer 3 Switching
- Configuring IPv6 Multicast Layer 3 Switching
- Configuring IPv4 Multicast Layer 3 Switching
- Configuring MLDv2 Snooping
- Configuring IGMP Snooping
- Configuring PIM Snooping
- Configuring Router-Port Group Management Protocol (RGMP)
- Configuring Network Security
- Understanding Cisco IOS ACL Support
- Configuring VLAN ACLs (VACLs)
- Configuring Denial of Service (DoS) Protection
- Configuring DHCP Snooping
- Configuring Dynamic ARP Inspection (DAI)
- Configuring Traffic-Storm Control
- Configuring Unknown Unicast and Multicast Flood Blocking
- Configuring PFC QoS
- Configuring PFC3BXL or PFC3B Mode MPLS QoS
- Configuring PFC QoS Statistics Data Export
- Configuring Network Admission Control (NAC)
- Configuring 802.1X Port-Based Authentication
- Configuring Port Security
- Configuring Cisco Discovery Protocol (CDP)
- Configuring UniDirectional Link Detection (UDLD)
- Configuring the NetFlow Table
- Configuring NetFlow Data Export (NDE)
- Configuring Local SPAN, Remote SPAN (RSPAN), and Encapsulated RSPAN
- Configuring SNMP IfIndex Persistence
- Power Management and Environmental Monitoring
- Configuring Online Diagnostics
- Configuring Top N Utility Reports
- Using the Layer 2 Traceroute Utility
- Online Diagnostic Tests
- Acronyms
Configuring EtherChannels
This chapter describes how to configure EtherChannels on the Catalyst 6500 series switch Layer 2 or Layer 3 LAN ports.
Note For complete syntax and usage information for the commands used in this chapter, refer to the Catalyst Supervisor Engine 32 PISA Cisco IOS Command Reference, Release 12.2ZY, at this URL:
http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2ZY/command/reference/cmdref.html
This chapter consists of these sections:
•Understanding How EtherChannels Work
•EtherChannel Feature Configuration Guidelines and Restrictions
Understanding How EtherChannels Work
These sections describe how EtherChannels work:
•EtherChannel Feature Overview
•Understanding How EtherChannels Are Configured
•Understanding Port Channel Interfaces
EtherChannel Feature Overview
An EtherChannel bundles individual Ethernet links into a single logical link that provides the aggregate bandwidth of up to eight physical links. The maximumnumber of EtherChannels is 128.
You can form an EtherChannel with up to eight compatibly configured LAN ports on any module in a Catalyst 6500 series switch. All LAN ports in each EtherChannel must be the same speed and must all be configured as either Layer 2 or Layer 3 LAN ports.
Note The network device to which a Catalyst 6500 series switch is connected may impose its own limits on the number of ports in an EtherChannel.
If a segment within an EtherChannel fails, traffic previously carried over the failed link switches to the remaining segments within the EtherChannel. When a failure occurs, the EtherChannel feature sends a trap that identifies the switch, the EtherChannel, and the failed link. Inbound broadcast and multicast packets on one segment in an EtherChannel are blocked from returning on any other segment of the EtherChannel.
Understanding How EtherChannels Are Configured
These sections describe how EtherChannels are configured:
•EtherChannel Configuration Overview
•Understanding Manual EtherChannel Configuration
•Understanding PAgP EtherChannel Configuration
•Understanding IEEE 802.3ad LACP EtherChannel Configuration
EtherChannel Configuration Overview
You can configure EtherChannels manually or you can use the Port Aggregation Control Protocol (PAgP) or the Link Aggregation Control Protocol (LACP) to form EtherChannels. The EtherChannel protocols allow ports with similar characteristics to form an EtherChannel through dynamic negotiation with connected network devices. PAgP is a Cisco-proprietary protocol and LACP is defined in IEEE 802.3ad.
PAgP and LACP do not interoperate with each other. Ports configured to use PAgP cannot form EtherChannels with ports configured to use LACP. Ports configured to use LACP cannot form EtherChannels with ports configured to use PAgP.
Table 10-1 lists the user-configurable EtherChannel modes.
Understanding Manual EtherChannel Configuration
Manually configured EtherChannel ports do not exchange EtherChannel protocol packets. A manually configured EtherChannel forms only when you enter configure all ports in the EtherChannel compatibly.
Understanding PAgP EtherChannel Configuration
PAgP supports the automatic creation of EtherChannels by exchanging PAgP packets between LAN ports. PAgP packets are exchanged only between ports in auto and desirable modes.
The protocol learns the capabilities of LAN port groups dynamically and informs the other LAN ports. Once PAgP identifies correctly matched Ethernet links, it facilitates grouping the links into an EtherChannel. The EtherChannel is then added to the spanning tree as a single bridge port.
Both the auto and desirable modes allow PAgP to negotiate between LAN ports to determine if they can form an EtherChannel, based on criteria such as port speed and trunking state. Layer 2 EtherChannels also use VLAN numbers.
LAN ports can form an EtherChannel when they are in different PAgP modes if the modes are compatible. For example:
•A LAN port in desirable mode can form an EtherChannel successfully with another LAN port that is in desirable mode.
•A LAN port in desirable mode can form an EtherChannel with another LAN port in auto mode.
•A LAN port in auto mode cannot form an EtherChannel with another LAN port that is also in auto mode, because neither port will initiate negotiation.
Understanding IEEE 802.3ad LACP EtherChannel Configuration
LACP supports the automatic creation of EtherChannels by exchanging LACP packets between LAN ports. LACP packets are exchanged only between ports in passive and active modes.
The protocol learns the capabilities of LAN port groups dynamically and informs the other LAN ports. Once LACP identifies correctly matched Ethernet links, it facilitates grouping the links into an EtherChannel. The EtherChannel is then added to the spanning tree as a single bridge port.
Both the passive and active modes allow LACP to negotiate between LAN ports to determine if they can form an EtherChannel, based on criteria such as port speed and trunking state. Layer 2 EtherChannels also use VLAN numbers.
LAN ports can form an EtherChannel when they are in different LACP modes as long as the modes are compatible. For example:
•A LAN port in active mode can form an EtherChannel successfully with another LAN port that is in active mode.
•A LAN port in active mode can form an EtherChannel with another LAN port in passive mode.
•A LAN port in passive mode cannot form an EtherChannel with another LAN port that is also in passive mode, because neither port will initiate negotiation.
LACP uses the following parameters:
•LACP system priority—You must configure an LACP system priority on each switch running LACP. The system priority can be configured automatically or through the CLI (see the "Configuring the LACP System Priority and System ID" section). LACP uses the system priority with the switch MAC address to form the system ID and also during negotiation with other systems.
Note The LACP system ID is the combination of the LACP system priority value and the MAC address of the switch.
•LACP port priority—You must configure an LACP port priority on each port configured to use LACP. The port priority can be configured automatically or through the CLI (see the "Configuring Channel Groups" section). LACP uses the port priority with the port number to form the port identifier. LACP uses the port priority to decide which ports should be put in standby mode when there is a hardware limitation that prevents all compatible ports from aggregating.
•LACP administrative key—LACP automatically configures an administrative key value equal to the channel group identification number on each port configured to use LACP. The administrative key defines the ability of a port to aggregate with other ports. A port's ability to aggregate with other ports is determined by these factors:
–Port physical characteristics, such as data rate, duplex capability, and point-to-point or shared medium
–Configuration restrictions that you establish
On ports configured to use LACP, LACP tries to configure the maximum number of compatible ports in an EtherChannel, up to the maximum allowed by the hardware (eight ports). If LACP cannot aggregate all the ports that are compatible (for example, the remote system might have more restrictive hardware limitations), then all the ports that cannot be actively included in the channel are put in hot standby state and are used only if one of the channeled ports fails. You can configure an additional 8 standby ports (total of 16 ports associated with the EtherChannel).
Understanding Port Channel Interfaces
Each EtherChannel has a numbered port channel interface. You can configure a maximum of 128 port-channel interfaces, numbered from 1 to 256. The configuration that you apply to the port channel interface affects all LAN ports assigned to the port channel interface.
After you configure an EtherChannel, the configuration that you apply to the port channel interface affects the EtherChannel; the configuration that you apply to the LAN ports affects only the LAN port where you apply the configuration. To change the parameters of all ports in an EtherChannel, apply the configuration commands to the port channel interface, for example, Spanning Tree Protocol (STP) commands or commands to configure a Layer 2 EtherChannel as a trunk.
Understanding Load Balancing
An EtherChannel balances the traffic load across the links in an EtherChannel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel.
EtherChannel load balancing can use MAC addresses or IP addresses. EtherChannel load balancing can also use Layer 4 port numbers. EtherChannel load balancing can use either source or destination or both source and destination addresses or ports. The selected mode applies to all EtherChannels configured on the switch. EtherChannel load balancing can use MPLS Layer 2 information.
Use the option that provides the balance criteria with the greatest variety in your configuration. For example, if the traffic on an EtherChannel is going only to a single MAC address and you use the destination MAC address as the basis of EtherChannel load balancing, the EtherChannel always chooses the same link in the EtherChannel; using source addresses or IP addresses might result in better load balancing.
EtherChannel Feature Configuration Guidelines and Restrictions
When EtherChannel interfaces are configured improperly, they are disabled automatically to avoid network loops and other problems. To avoid configuration problems, observe these guidelines and restrictions:
•The commands in this chapter can be used on all LAN ports in Catalyst 6500 series switches, including the ports on the supervisor engine and a redundant supervisor engine.
•The WS-X6148-GE-TX and WS-X6148V-GE-TX switching modules do not support more than 1 Gbps of traffic per EtherChannel.
•When you add a member port that does not support ISL trunking to an EtherChannel, Cisco IOS software automatically adds a switchport trunk encapsulation dot1q command to the port-channel interface to prevent configuration of the EtherChannel as an ISL trunk. The switchport trunk encapsulation dot1q command is inactive when the EtherChannel is not a trunk.
•All Ethernet LAN ports on all modules, including those on a redundant supervisor engine, support EtherChannels (maximum of eight LAN ports) with no requirement that the LAN ports be physically contiguous or on the same module.
•Configure all LAN ports in an EtherChannel to use the same EtherChannel protocol; you cannot run two EtherChannel protocols in one EtherChannel.
•Configure all LAN ports in an EtherChannel to operate at the same speed and in the same duplex mode.
•LACP does not support half-duplex. Half-duplex ports in an LACP EtherChannel are put in the suspended state.
•Enable all LAN ports in an EtherChannel. If you shut down a LAN port in an EtherChannel, it is treated as a link failure and its traffic is transferred to one of the remaining ports in the EtherChannel.
•An EtherChannel will not form if one of the LAN ports is a Switched Port Analyzer (SPAN) destination port.
•For Layer 3 EtherChannels, assign Layer 3 addresses to the port channel logical interface, not to the LAN ports in the channel.
•For Layer 2 EtherChannels:
–Assign all LAN ports in the EtherChannel to the same VLAN or configure them as trunks.
–If you configure an EtherChannel from trunking LAN ports, verify that the trunking mode is the same on all the trunks. LAN ports in an EtherChannel with different trunk modes can operate unpredictably.
–An EtherChannel supports the same allowed range of VLANs on all the LAN ports in a trunking Layer 2 EtherChannel. If the allowed range of VLANs is not the same, the LAN ports do not form an EtherChannel.
–LAN ports with different STP port path costs can form an EtherChannel as long they are compatibly configured with each other. If you set different STP port path costs, the LAN ports are not incompatible for the formation of an EtherChannel.
–An EtherChannel will not form if protocol filtering is set differently on the LAN ports.
–Configure static MAC addresses on the EtherChannel only and not on physical member ports of the EtherChannel.
•After you configure an EtherChannel, the configuration that you apply to the port channel interface affects the EtherChannel. The configuration that you apply to the LAN ports affects only the LAN port where you apply the configuration.
•When QoS is enabled, enter the no mls qos channel-consistency port-channel interface command to support EtherChannels that have ports with and without strict-priority queues.
Configuring EtherChannels
These sections describe how to configure EtherChannels:
•Configuring Port Channel Logical Interfaces for Layer 3 EtherChannels
•Configuring EtherChannel Load Balancing
•Configuring the EtherChannel Min-Links Feature
Note Make sure that the LAN ports are configured correctly (see the "EtherChannel Feature Configuration Guidelines and Restrictions" section).
Configuring Port Channel Logical Interfaces for Layer 3 EtherChannels
Note•When configuring Layer 2 EtherChannels, you cannot put Layer 2 LAN ports into manually created port channel logical interfaces. If you are configuring a Layer 2 EtherChannel, do not perform the procedures in this section (see the "Configuring Channel Groups" section).
•When configuring Layer 3 EtherChannels, you must manually create the port channel logical interface as described in this section, and then put the Layer 3 LAN ports into the channel group (see the "Configuring Channel Groups" section).
•To move an IP address from a Layer 3 LAN port to an EtherChannel, you must delete the IP address from the Layer 3 LAN port before configuring it on the port channel logical interface.
To create a port channel interface for a Layer 3 EtherChannel, perform this task:
The group_number can be 1 through 256, up to a maximum of 128 port-channel interfaces. This example shows how to create port channel interface 1:
Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 172.32.52.10 255.255.255.0
Router(config-if)# end
This example shows how to verify the configuration of port channel interface 1:
Router# show running-config interface port-channel 1
Building configuration...
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
Router#
Configuring Channel Groups
Note•When configuring Layer 3 EtherChannels, you must manually create the port channel logical interface first (see the "Configuring Port Channel Logical Interfaces for Layer 3 EtherChannels" section), and then put the Layer 3 LAN ports into the channel group as described in this section.
•When configuring Layer 2 EtherChannels, configure the LAN ports with the channel-group command as described in this section, which automatically creates the port channel logical interface. You cannot put Layer 2 LAN ports into a manually created port channel interface.
•For Cisco IOS to create port channel interfaces for Layer 2 EtherChannels, the Layer 2 LAN ports must be connected and functioning.
To configure channel groups, perform this task for each LAN port:
|
|
|
---|---|---|
Step 1 |
Router(config)# interface type1 slot/port |
Selects a LAN port to configure. |
Step 2 |
Router(config-if)# no ip address |
Ensures that there is no IP address assigned to the LAN port. |
Step 3 |
Router(config-if)# channel-protocol (lacp | pagp} |
(Optional) On the selected LAN port, restricts the channel-group command to the EtherChannel protocol configured with the channel-protocol command. |
Router(config-if)# no channel-protocol |
Removes the restriction. |
|
Step 4 |
Router(config-if)# channel-group number mode {active | auto | desirable | on | passive} |
Configures the LAN port in a port channel and specifies the mode (see Table 10-1). PAgP supports only the auto and desirable modes. LACP supports only the active and passive modes. |
Router(config-if)# no channel-group |
Removes the LAN port from the channel group. |
|
Step 5 |
Router(config-if)# lacp port-priority priority_value |
(Optional for LACP) Valid values are 1 through 65535. Higher numbers have lower priority. The default is 32768. |
Router(config-if)# no lacp port-priority |
Reverts to the default. |
|
Step 6 |
Router(config-if)# end |
Exits configuration mode. |
Step 7 |
Router# show running-config interface type1 slot/port Router# show interfaces type1 slot/port etherchannel |
Verifies the configuration. |
1 type = ethernet, fastethernet, gigabitethernet, or tengigabitethernet |
This example shows how to configure Fast Ethernet ports 5/6 and 5/7 into port channel 2 with PAgP mode desirable:
Router# configure terminal
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-group 2 mode desirable
Router(config-if)# end
Note See the "Configuring a Range of Interfaces" section for information about the range keyword.
This example shows how to verify the configuration of port channel interface 2:
Router# show running-config interface port-channel 2
Building configuration...
Current configuration:
!
interface Port-channel2
no ip address
switchport
switchport access vlan 10
switchport mode access
end
Router#
This example shows how to verify the configuration of Fast Ethernet port 5/6:
Router# show running-config interface fastethernet 5/6
Building configuration...
Current configuration:
!
interface FastEthernet5/6
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Router# show interfaces fastethernet 5/6 etherchannel
Port state = Down Not-in-Bndl
Channel group = 12 Mode = Desirable-Sl Gcchange = 0
Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1
2
Port index = 0 Load = 0x00 Protocol = PAgP
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/2 d U1/S1 1s 0 128 Any 0
Age of the port in the current state: 04d:18h:57m:19s
This example shows how to verify the configuration of port channel interface 2 after the LAN ports have been configured:
Router# show etherchannel 12 port-channel
Port-channels in the group:
----------------------
Port-channel: Po12
------------
Age of the Port-channel = 04d:18h:58m:50s
Logical slot/port = 14/1 Number of ports = 0
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = PAgP
Router#
Configuring the LACP System Priority and System ID
The LACP system ID is the combination of the LACP system priority value and the MAC address of the switch.
To configure the LACP system priority and system ID, perform this task:
This example shows how to configure the LACP system priority:
Router# configure terminal
Router(config)# lacp system-priority 23456
Router(config)# end
Router(config)#
This example shows how to verify the configuration:
Router# show lacp sys-id
23456,0050.3e8d.6400
Router#
The system priority is displayed first, followed by the MAC address of the switch.
Configuring EtherChannel Load Balancing
To configure EtherChannel load balancing, perform this task:
The load-balancing keywords indicate the following information:
•dst-ip—Destination IP addresses
•dst-mac—Destination MAC addresses
•dst-port—Destination Layer 4 port
•mpls—Load balancing for MPLS packets
•src-dst-ip—Source and destination IP addresses
•src-dst-mac—Source and destination MAC addresses
•src-dst-port—Source and destination Layer 4 port
•src-ip—Source IP addresses
•src-mac—Source MAC addresses
•src-port—Source Layer 4 port
This example shows how to configure EtherChannel to use source and destination IP addresses:
Router# configure terminal
Router(config)# port-channel load-balance src-dst-ip
Router(config)# end
Router(config)#
This example shows how to verify the configuration:
Router# show etherchannel load-balance
Source XOR Destination IP address
Router#
Configuring the EtherChannel Min-Links Feature
The EtherChannel Min-Links feature is supported on LACP EtherChannels. This feature allows you to configure the minimum number of member ports that must be in the link-up state and bundled in the EtherChannel for the port channel interface to transition to the link-up state. You can use the EtherChannel Min-Links feature to prevent low-bandwidth LACP EtherChannels from becoming active. This feature also causes LACP EtherChannels to become inactive if they have too few active member ports to supply your required minimum bandwidth.
To configure the EtherChannel Min-Links feature, perform this task:
|
|
|
---|---|---|
Step 1 |
Router(config)# interface port-channel number |
Selects an LACP port channel interface. |
Step 2 |
Router(config-if)# port-channel min-links number |
Configures the minimum number of member ports that must be in the link-up state and bundled in the EtherChannel for the port channel interface to transition to the link-up state. |
Router(config-if)# no port-channel min-links |
Reverts to the default number of active member ports (one). |
|
Step 3 |
Router(config-if)# end |
Exits configuration mode. |
Step 4 |
Router# show running-config interface type1 slot/port Router# show interfaces type1 slot/port etherchannel |
Verifies the configuration. |
Note Although the EtherChannel Min-Links feature works correctly when configured only on one end of an EtherChannel, for best results, configure the same number of minimum links on both ends of the EtherChannel.
This example shows how to configure port channel interface 1 to be inactive if fewer than 2 member ports are active in the EtherChannel:
Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# port-channel min-links 2
Router(config-if)# end