Configuring MPLS InterAS Option B

Information About MPLS VPN InterAS Options

The MPLS VPN InterAS Options provide various ways of interconnecting VPNs between different MPLS VPN service providers. This allows sites of a customer to exist on several carrier networks (autonomous systems) and have seamless VPN connectivity between these sites.

ASes and ASBRs

An autonomous system (AS) is a single network or group of networks that is controlled by a common system administration group and using a single, clearly defined protocol. In many cases, VPNs extend to different ASes in different geographical areas. Some VPNs must extend across multiple service providers; these VPNs are called overlapping VPNs. The connection between ASes must be seamless to the customer, regardless of the complexity or location of the VPNs.

An AS boundary router (ASBR) is a device in an AS that is connected by using more than one routing protocol, and exchanges routing information with other ASBRs by using an exterior routing protocol (for example, eBGP), or use static routes, or both.

Separate ASes from different service providers communicate by exchanging information in the form of VPN IP addresses and they use the following protocols to share routing information:

  • Within an AS, routing information is shared using iBGP.

    iBGP distributes network layer information for IP prefixes within each VPN and each AS.

  • Between ASes, routing information is shared using eBGP.

    eBGP allows service providers to set up an interdomain routing system that guarantees loop-free exchange of routing information between separate ASes. The primary function of eBGP is to exchange network reachability information between ASes, including information about the list of AS routes. The ASes use eBGP border edge routers to distribute the routes, which includes label-switching information. Each border edge router rewrites the next-hop and MPLS labels.

MPLS VPN InterAS Options configuration is supported and can include an inter provider VPN, which is MPLS VPNs that include two or more ASes, connected by separate border edge routers. The ASes exchange routes using eBGP, and no iBGP or routing information is exchanged between the ASes.

MPLS VPN InterAS Options

The following options defined in RFC4364 provide MPLS VPN connectivity between different ASes:

  • InterAS Option B – This option provides VPNv4 route distribution between ASBRs.

Next-Hop Self Method

The following figure shows the label forwarding path for next-hop-self method. The labels get pushed, swapped and popped on the stack as packet makes its way from PE-200 in AS 200 to PE-300 in AS 300. In step 5, ASBR-A300 receives labeled frame, replaces label 164 with label 161 pushes IGP label 162 onto the label stack.

Redistribute Connected Subnet Method

The following figure shows the label forwarding path for Redistribute connected subnets method. The labels get pushed, swapped and popped on the stack as packet travels from PE- 300 in AS 300 to PE-200 in AS 200. In step 5, ASBR-A200 receives frame with BGP label 20, swaps it with label 29 and pushes label 17.

Configuring MPLS VPN InterAS Option B

Configuring InterAS Option B using the Next-Hop-Self Method

To configure interAS Option B on ASBRs using the next-hop-self method, complete the following steps:

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. router ospf process-id
  4. router-id ip-address
  5. nsr
  6. nsf
  7. redistribute bgp autonomous-system-number
  8. passive-interface interface-type interface-number
  9. network ip-address wildcard-mask aread area-id
  10. exit
  11. router bgp autonomous-system-number
  12. bgp router-id ip-address
  13. bgp log-neighbor changes
  14. no bgp default ipv4-unicast
  15. no bgp default route-target filter
  16. neighbor ip-address remote-as as-number
  17. neighbor ip-address update-source interface-type interface-number
  18. neighbor ip-address remote-as as-number
  19. address-family ipv4
  20. neighbor ip-address activate
  21. neighbor ip-address send-label
  22. exit address-family
  23. address-family vpnv4
  24. neighbor ip-address activate
  25. neighbor ip-address send-community extended
  26. neighbor ip-address next-hop-self
  27. neighbor ip-address activate
  28. neighbor ip-address send-community extended
  29. exit address-family
  30. bgp router-id ip-address
  31. bgp log-neighbor changes
  32. neighbor ip-address remote-as as-number
  33. neighbor ip-address update-source interface-type interface-number
  34. address-family vpnv4
  35. neighbor ip-address activate
  36. neighbor ip-address send-community extended
  37. exit address-family

DETAILED STEPS

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

router ospf process-id

Example:


Device(config)# router ospf 1

Configures an OSPF routing process and assign a process number.

Step 4

router-id ip-address

Example:


Device(config)# router-id 4.1.1.1

Specifies a fixed router ID.

Step 5

nsr

Example:


Device(config-router)# nsr

Configures OSPF non-stop routing (NSR).

Step 6

nsf

Example:


Device(config-router)# nsf

Confgures OSPF non-stop forwarding (NSF).

Step 7

redistribute bgp autonomous-system-number

Example:


Device(config-router)# redistribute bgp 200

Redistributes routes from a BGP autonomous system into and OSPF routing process.

Step 8

passive-interface interface-type interface-number

Example:


Device(config-router)# passive-interface GigabitEthernet 1/0/10
Device(config-router)# passive-interface Tunnel0

Disables Open Shortest Path First (OSPF) routing updates on an interface.

Step 9

network ip-address wildcard-mask aread area-id

Example:

Device(config-router)# network 4.1.1.0 0.0.0.0.255 area 0

Defines an interface on which OSPF runs and defines the area ID for that interface.

Step 10

exit

Example:


Device(config-router)# exit

Exits router configuration mode.

Step 11

router bgp autonomous-system-number

Example:


Device(config)# router bgp 200

Configures a BGP routing process.

Step 12

bgp router-id ip-address

Example:


Device(config-router)# bgp router-id 4.1.1.1

Configures a fixed router ID for the BGP routing process.

Step 13

bgp log-neighbor changes

Example:


Device(config-router)# bgp log-neighbor changes

Enables logging of BGP neighbor resets.

Step 14

no bgp default ipv4-unicast

Example:


Device(config-router)# no bgp default ipv4-unicast

Disables advertisement of routing information for address family IPv4.

Step 15

no bgp default route-target filter

Example:


Device(config-router)# no bgp default route-target filter

Disables automatic BGP route-target community filtering.

Step 16

neighbor ip-address remote-as as-number

Example:


Device(config-router)# neighbor 4.1.1.3 remote-as 200

Configures an entry to the BGP neighbor table.

Step 17

neighbor ip-address update-source interface-type interface-number

Example:


Device(config-router)# neighbor 4.1.1.3 update-source Loopback0

Allows Cisco IOS software to use a specific operational interface for TCP connections by the BGP sessions.

Step 18

neighbor ip-address remote-as as-number

Example:


Device(config-router)# neighbor 4.1.1.3 remote-as 300

Configures an entry to the BGP neighbor table.

Step 19

address-family ipv4

Example:


Device(config-router)# address-family ipv4

Enters address family configuration mode for configuring BGP routing sessions that use standard IP Version 4 address prefixes.

Step 20

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 10.32.1.2 activate

Enables the exchange of information with a BGP neighbor.

Step 21

neighbor ip-address send-label

Example:


Device(config-router-af)# neighbor 10.32.1.2 send-label

Sends MPLS labels with BGP routes to a neighboring BGP router.

Step 22

exit address-family

Example:


Device(config-router-af)# exit address-family

Exits BGP address-family submode.

Step 23

address-family vpnv4

Example:


Device(config-router)# address-family vpnv4

Configures the device in address family configuration mode for configuring routing sessions, such as BGP, that use standard VPNv4 address prefixes.

Step 24

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 4.1.1.3 activate

Enables the exchange of information with a BGP neighbor.

Step 25

neighbor ip-address send-community extended

Example:


Device(config-router-af)# neighbor 4.1.1.3 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

Step 26

neighbor ip-address next-hop-self

Example:


Device(config-router-af)# neighbor 4.1.1.3 next-hop-self

Configure a router as the next hop for a BGP-speaking neighbor. This is the command that implements the next-hop-self method.

Step 27

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 10.30.1.2 activate

Enables the exchange of information with a BGP neighbor.

Step 28

neighbor ip-address send-community extended

Example:


Device(config-router-af)# neighbor 10.30.1.2 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

Step 29

exit address-family

Example:


Device(config-router-af)# exit address-family

Exits BGP address-family submode.

Step 30

bgp router-id ip-address

Example:


Device(config-router)# bgp router-id 4.1.1.3

Configures a fixed router ID for the BGP routing process.

Step 31

bgp log-neighbor changes

Example:


Device(config-router)# bgp log-neighbor changes

Enables logging of BGP neighbor resets.

Step 32

neighbor ip-address remote-as as-number

Example:


Device(config-router)# neighbor 4.1.1.1 remote-as 200

Configures an entry to the BGP neighbor table.

Step 33

neighbor ip-address update-source interface-type interface-number

Example:


Device(config-router)# neighbor 4.1.1.1 update-source Loopback0

Allows Cisco IOS software to use a specific operational interface for TCP connections by the BGP sessions.

Step 34

address-family vpnv4

Example:


Device(config-router)# address-family vpnv4

Configures the device in address family configuration mode for configuring routing sessions, such as BGP, that use standard VPNv4 address prefixes.

Step 35

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 4.1.1.1 activate

Enables the exchange of information with a BGP neighbor.

Step 36

neighbor ip-address send-community extended

Example:


Device(config-router-af)# neighbor 4.1.1.1 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

Step 37

exit address-family

Example:


Device(config-router-af)# exit address-family

Exits BGP address-family submode.

Configuring InterAS Option B using Redistribute Connected Method

To configure interAS Option B on ASBRs using the redistribute connected method, complete the following steps:

SUMMARY STEPS

  1. enable
  2. configure terminal
  3. router ospf process-id
  4. router-id ip-address
  5. nsr
  6. nsf
  7. redistribute connected
  8. passive-interface interface-type interface-number
  9. network ip-address wildcard-mask aread area-id
  10. exit
  11. router bgp autonomous-system-number
  12. bgp router-id ip-address
  13. bgp log-neighbor changes
  14. no bgp default ipv4-unicast
  15. no bgp default route-target filter
  16. neighbor ip-address remote-as as-number
  17. neighbor ip-address update-source interface-type interface-number
  18. neighbor ip-address remote-as as-number
  19. address-family vpnv4
  20. neighbor ip-address activate
  21. neighbor ip-address send-community extended
  22. neighbor ip-address activate
  23. neighbor ip-address send-community extended
  24. exit address-family
  25. mpls ldp router-id interface-id [force]

DETAILED STEPS

  Command or Action Purpose

Step 1

enable

Example:


Device> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

Example:


Device# configure terminal

Enters global configuration mode.

Step 3

router ospf process-id

Example:


Device(config)# router ospf 1

Configures an OSPF routing process and assign a process number.

Step 4

router-id ip-address

Example:


Device(config)# router-id 5.1.1.1

Specifies a fixed router ID.

Step 5

nsr

Example:


Device(config-router)# nsr

Configures OSPF non-stop routing (NSR).

Step 6

nsf

Example:


Device(config-router)# nsf

Confgures OSPF non-stop forwarding (NSF).

Step 7

redistribute connected

Example:


Device(config-router)# redistribute connected

Redistributes the next hop address of the remote ASBR into the local IGP. This is the command that implements redistribute connected method.

Step 8

passive-interface interface-type interface-number

Example:


Device(config-router)# passive-interface GigabitEthernet 1/0/10
Device(config-router)# passive-interface Tunnel0

Disables Open Shortest Path First (OSPF) routing updates on an interface.

Step 9

network ip-address wildcard-mask aread area-id

Example:

Device(config-router)# network 5.1.1.0 0.0.0.0.255 area 0

Defines an interface on which OSPF runs and defines the area ID for that interface.

Step 10

exit

Example:


Device(config-router)# exit

Exits router configuration mode.

Step 11

router bgp autonomous-system-number

Example:


Device(config)# router bgp 300

Configures a BGP routing process.

Step 12

bgp router-id ip-address

Example:


Device(config-router)# bgp router-id 5.1.1.1

Configures a fixed router ID for the BGP routing process.

Step 13

bgp log-neighbor changes

Example:


Device(config-router)# bgp log-neighbor changes

Enables logging of BGP neighbor resets.

Step 14

no bgp default ipv4-unicast

Example:


Device(config-router)# no bgp default ipv4-unicast

Disables advertisement of routing information for address family IPv4.

Step 15

no bgp default route-target filter

Example:


Device(config-router)# no bgp default route-target filter

Disables automatic BGP route-target community filtering.

Step 16

neighbor ip-address remote-as as-number

Example:


Device(config-router)# neighbor 5.1.1.3 remote-as 300

Configures an entry to the BGP neighbor table.

Step 17

neighbor ip-address update-source interface-type interface-number

Example:


Device(config-router)# neighbor 4.1.1.3 update-source Loopback0

Allows Cisco IOS software to use a specific operational interface for TCP connections by the BGP sessions.

Step 18

neighbor ip-address remote-as as-number

Example:


Device(config-router)# neighbor 10.30.1.2 remote-as 200

Configures an entry to the BGP neighbor table.

Step 19

address-family vpnv4

Example:


Device(config-router)# address-family vpnv4

Configures the device in address family configuration mode for configuring routing sessions, such as BGP, that use standard VPNv4 address prefixes.

Step 20

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 5.1.1.3 activate

Enables the exchange of information with a BGP neighbor.

Step 21

neighbor ip-address send-community extended

Example:


Device(config-router-af)# neighbor 5.1.1.3 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

Step 22

neighbor ip-address activate

Example:


Device(config-router-af)# neighbor 10.30.1.1 activate

Enables the exchange of information with a BGP neighbor.

Step 23

neighbor ip-address send-community extended

Example:


Device(config-router-af)# neighbor 10.30.1.2 send-community extended

Specifies that a communities attribute should be sent to a BGP neighbor.

Step 24

exit address-family

Example:


Device(config-router-af)# exit address-family

Exits BGP address-family submode.

Step 25

mpls ldp router-id interface-id [force]

Example:


Device(config-router)# mpls ldp router-id Loopback0 force

Specifies the preferred interface for determining the LDP router ID.

Verifying MPLS VPN InterAS Options Configuration

To verify InterAS option B configuration information, perform one of the following tasks:

Command

Purpose

ping ip-address source interface-type

Checks the accessibility of devices. Use this command to check the connection between CE1 and CE2 using the loopback interface.

show bgp vpnv4 unicast labels

Displays incoming and outgoing BGP labels.

show mpls forwarding-table

Display the contents of the MPLS Label Forwarding Information Base.

show ip bgp

Displays entries in the BGP routing table.

show { ip | ipv6 } bgp [ vrf vrf-name ]

Displays information about BGP on a VRF.

show ip route [ ip-address [ mask ]] [ protocol ] vrf vrf-name

Displays the current state of the routing table. Use the ip-address argument to verify that CE1 has a route to CE2. Verify the routes learned by CE1. Make sure that the route for CE2 is listed.

show { ip | ipv6 } route vrf vrf-name

Displays the IP routing table that is associated with a VRF. Check that the loopback addresses of the local and remote CE routers are in the routing table of the PE routers.

show running-config bgp

Displays the running configuration for BGP.

show running-config vrf vrf-name

Displays the running configuration for VRFs.

show vrf vrf-name interface interface-type interface-id

Verifies the route distinguisher (RD) and interface that are configured for the VRF.

trace destination [ vrf vrf-name ]

Discovers the routes that packets take when traveling to their destination. The trace command can help isolate a problem if two routers cannot communicate.

Configuration Examples for MPLS VPN InterAS Options

Next-Hop-Self Method

Figure 1. Topology for InterAS Option B using Next-Hop-Self Method

Configuration for PE1-P1-ASBR1

PE1

P1

ASBR1

vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition vrf1
rd 200:1
route-target export 200:1
route-target import 200:1
route-target import 300:1
!
address-family ipv4
exit-address-family
interface Loopback0
ip address 4.1.1.3 255.255.255.255
ip ospf 1 area 0
!
interface Loopback1
vrf forwarding vrf1
ip address 192.1.1.1 255.255.255.255
ip ospf 200 area 0
!
interface GigabitEthernet2/0/4
no switchport
ip address 10.10.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface GigabitEthernet2/0/9
description to-IXIA-1:p8
no switchport
vrf forwarding vrf1
ip address 192.2.1.1 255.255.255.0
ip ospf 200 area 0
router ospf 200 vrf vrf1
router-id 192.1.1.1
nsr
nsf
redistribute connected
redistribute bgp 200
network 192.1.1.1 0.0.0.0 area 0
network 192.2.1.0 0.0.0.255 area 0
router ospf 1
router-id 4.1.1.3
nsr
nsf
redistribute connected
router bgp 200
bgp router-id 4.1.1.3
bgp log-neighbor-changes
neighbor 4.1.1.1 remote-as 200
neighbor 4.1.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 4.1.1.1 activate
neighbor 4.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf1
redistribute connected
redistribute ospf 200
maximum-paths ibgp 2
exit-address-family
interface Loopback0
ip address 4.1.1.2 255.255.255.255
ip ospf 1 area 0
interface GigabitEthernet1/0/4
no switchport
ip address 10.10.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet1/0/23
no switchport
ip address 10.20.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface Loopback0
ip address 4.1.1.1 255.255.255.255
ip ospf 1 area 0
interface GigabitEthernet1/0/10
no switchport
ip address 10.30.1.1 255.255.255.0
mpls bgp forwarding
interface GigabitEthernet1/0/23
no switchport
ip address 10.20.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
router ospf 1
router-id 4.1.1.1
nsr
nsf
redistribute bgp 200
passive-interface GigabitEthernet1/0/10
passive-interface Tunnel0
network 4.1.1.0 0.0.0.255 area 0
router bgp 200
bgp router-id 4.1.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 4.1.1.3 remote-as 200
neighbor 4.1.1.3 update-source Loopback0
neighbor 10.30.1.2 remote-as 300
!
address-family ipv4
neighbor 10.30.1.2 activate
neighbor 10.30.1.2 send-label
exit-address-family
!
address-family vpnv4
neighbor 4.1.1.3 activate
neighbor 4.1.1.3 send-community extended
neighbor 4.1.1.3 next-hop-self
neighbor 10.30.1.2 activate
neighbor 10.30.1.2 send-community extended
exit-address-family

Configuration for ASBR2 – P2 – PE2

Table 1.

PE2

P2

ASBR2

vrf definition vrf1
rd 300:1
route-target export 300:1
route-target import 300:1
route-target import 200:1
!
address-family ipv4
exit-address-family
interface Loopback0
ip address 5.1.1.3 255.255.255.255
ip ospf 1 area 0
!
interface Loopback1
vrf forwarding vrf1
ip address 193.1.1.1 255.255.255.255
ip ospf 300 area 0
interface GigabitEthernet1/0/1
no switchport
ip address 10.50.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet1/0/2
no switchport
vrf forwarding vrf1
ip address 193.2.1.1 255.255.255.0
ip ospf 300 area 0
router ospf 300 vrf vrf1
router-id 193.1.1.1
nsr
nsf
redistribute connected
redistribute bgp 300
network 193.1.1.1 0.0.0.0 area 0
network 193.2.1.0 0.0.0.255 area 0
!
router ospf 1
router-id 5.1.1.3
nsr
nsf
redistribute connected
router bgp 300
bgp router-id 5.1.1.3
bgp log-neighbor-changes
neighbor 5.1.1.1 remote-as 300
neighbor 5.1.1.1 update-source Loopback0
!
address-family ipv4
neighbor 5.1.1.1 activate
neighbor 5.1.1.1 send-label
exit-address-family
!
address-family vpnv4
neighbor 5.1.1.1 activate
neighbor 5.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf1
redistribute connected
redistribute ospf 300
maximum-paths ibgp 2
exit-address-family
interface Loopback0
ip address 5.1.1.2 255.255.255.255
ip ospf 1 area 0
interface GigabitEthernet1/0/1
no switchport
ip address 10.50.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface GigabitEthernet2/0/3
no switchport
ip address 10.40.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface Loopback0
ip address 5.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1/0/37
no switchport
ip address 10.30.1.2 255.255.255.0
mpls bgp forwarding
interface GigabitEthernet1/0/47
no switchport
ip address 10.40.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
router ospf 1
router-id 5.1.1.1
nsr
nsf
passive-interface GigabitEthernet1/0/37
passive-interface Tunnel0
network 5.1.1.0 0.0.0.255 area 0
!
router bgp 300
bgp router-id 5.1.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 5.1.1.3 remote-as 300
neighbor 5.1.1.3 update-source Loopback0
neighbor 10.30.1.1 remote-as 200
!
address-family ipv4
neighbor 10.30.1.1 activate
neighbor 10.30.1.1 send-label
exit-address-family
!
address-family vpnv4
neighbor 5.1.1.3 activate
neighbor 5.1.1.3 send-community extended
neighbor 5.1.1.3 next-hop-self
neighbor 10.30.1.1 activate
neighbor 10.30.1.1 send-community extended
exit-address-family

IGP Redistribute Connected Subnets Method

Figure 2. Topology for InterAS Option B using Redistribute Connected Subnets Method

Configuration for PE1-P1-ASBR1

PE1

P1

ASBR1

vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition vrf1
rd 200:1
route-target export 200:1
route-target import 200:1
route-target import 300:1
!
address-family ipv4
exit-address-family
interface Loopback0
ip address 4.1.1.3 255.255.255.255
ip ospf 1 area 0
!
interface Loopback1
vrf forwarding vrf1
ip address 192.1.1.1 255.255.255.255
ip ospf 200 area 0
!
interface GigabitEthernet2/0/4
no switchport
ip address 10.10.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface GigabitEthernet2/0/9
description to-IXIA-1:p8
no switchport
vrf forwarding vrf1
ip address 192.2.1.1 255.255.255.0
ip ospf 200 area 0
router ospf 200 vrf vrf1
router-id 192.1.1.1
nsr
nsf
redistribute connected
redistribute bgp 200
network 192.1.1.1 0.0.0.0 area 0
network 192.2.1.0 0.0.0.255 area 0
router ospf 1
router-id 4.1.1.3
nsr
nsf
redistribute connected
router bgp 200
bgp router-id 4.1.1.3
bgp log-neighbor-changes
neighbor 4.1.1.1 remote-as 200
neighbor 4.1.1.1 update-source
Loopback0
!
address-family vpnv4
neighbor 4.1.1.1 activate
neighbor 4.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf1
redistribute connected
redistribute ospf 200
maximum-paths ibgp 2
exit-address-family
interface Loopback0
ip address 4.1.1.2 255.255.255.255
ip ospf 1 area 0
interface GigabitEthernet1/0/4
no switchport
ip address 10.10.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet1/0/23
no switchport
ip address 10.20.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
router ospf 1
router-id 4.1.1.1
nsr
nsf
redistribute connected
passive-interface GigabitEthernet1/0/10
passive-interface Tunnel0
network 4.1.1.0 0.0.0.255 area 0
router bgp 200
bgp router-id 4.1.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 4.1.1.3 remote-as 200
neighbor 4.1.1.3 update-source
Loopback0
neighbor 10.30.1.2 remote-as 300
!
address-family vpnv4
neighbor 4.1.1.3 activate
neighbor 4.1.1.3 send-community extended
neighbor 10.30.1.2 activate
neighbor 10.30.1.2 send-community extended
exit-address-family
mpls ldp router-id Loopback0 force

Configuration for ASBR2 – P2 – PE2

PE2

P2

ASBR2

vrf definition vrf1
rd 300:1
route-target export 300:1
route-target import 300:1
route-target import 200:1
!
address-family ipv4
exit-address-family
interface Loopback0
ip address 5.1.1.3 255.255.255.255
ip ospf 1 area 0
!
interface Loopback1
vrf forwarding vrf1
ip address 193.1.1.1 255.255.255.255
ip ospf 300 area 0
interface GigabitEthernet1/0/1
no switchport
ip address 10.50.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet1/0/2
no switchport
vrf forwarding vrf1
ip address 193.2.1.1 255.255.255.0
ip ospf 300 area 0
router ospf 300 vrf vrf1
router-id 193.1.1.1
nsr
nsf
redistribute connected
redistribute bgp 300
network 193.1.1.1 0.0.0.0 area 0
network 193.2.1.0 0.0.0.255 area 0
!
router ospf 1
router-id 5.1.1.3
nsr
nsf
redistribute connected
router bgp 300
bgp router-id 5.1.1.3
bgp log-neighbor-changes
neighbor 5.1.1.1 remote-as 300
neighbor 5.1.1.1 update-source
Loopback0
!
address-family ipv4
neighbor 5.1.1.1 activate
neighbor 5.1.1.1 send-label
exit-address-family
!
address-family vpnv4
neighbor 5.1.1.1 activate
neighbor 5.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf vrf1
redistribute connected
redistribute ospf 300
maximum-paths ibgp 2
exit-address-family
interface Loopback0
ip address 5.1.1.2 255.255.255.255
ip ospf 1 area 0
interface GigabitEthernet1/0/1
no switchport
ip address 10.50.1.1 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
interface GigabitEthernet2/0/3
no switchport
ip address 10.40.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
router ospf 1
router-id 5.1.1.1
nsr
nsf
redistribute connected
passive-interface GigabitEthernet1/0/10
passive-interface Tunnel0
network 5.1.1.0 0.0.0.255 area 0
router bgp 300
bgp router-id 5.1.1.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 5.1.1.3 remote-as 300
neighbor 5.1.1.3 update-source
Loopback0
neighbor 10.30.1.1 remote-as 200
!
address-family vpnv4
neighbor 5.1.1.3 activate
neighbor 5.1.1.3 send-community extended
neighbor 10.30.1.1 activate
neighbor 10.30.1.1 send-community extended
exit-address-family
mpls ldp router-id Loopback0 force

Additional References for MPLS VPN InterAS Options

Related Documents

Related Topic Document Title

For complete syntax and usage information for the commands used in this chapter.

See the MPLS Commands section of theCommand Reference (Catalyst 9300 Series Switches)

Feature History for MPLS VPN InterAS Options

This table provides release and related information for features explained in this module.

These features are available on all releases subsequent to the one they were introduced in, unless noted otherwise.

.

Release

Feature

Feature Information

Cisco IOS XE Gibraltar 16.11.1

MPLS VPN InterAS Option B

InterAS Options use iBGP and eBGP peering to allow VPNs in different AS to communicate with each other. In an interAS option B network, ASBR ports are connected by one or more interfaces that are enabled to receive MPLS traffic.

Use Cisco Feature Navigator to find information about platform and software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn.