UPF Ingress Interfaces

Feature Summary and Revision History

Summary Data

Table 1. Summary Data

Applicable Product(s) or Functional Area

5G-UPF

Applicable Platform(s)

VPC-SI

Feature Default Setting

Disabled – Configuration Required

Related Changes in this Release

Not Applicable

Related Documentation

UCC 5G UPF Configuration and Administration Guide

Revision History

Table 2. Revision History

Revision Details

Release

Added support for IP separation per interface to allow separate networks for N3 and N9 interfaces.

2023.02.0

First introduced.

2020.02.0

Feature Description

UPF supports the GTP-U ingress interface to initiate the user plane service. The user plane service associates with the GTP-U service using the associate gtpu-service CLI command in User Plane Service configuration mode.

The UPF supports different GTP-U ingress interfaces to allow a separate network for N3 interface and N9, S5u, and S8u interfaces. The N9, S5u, and S8u interfaces share the same public IP.


Note


UPF does not support multiple GTP-U service selection for single call.


The supported GTP-U ingress interfaces include:

  • N3—N3 is the interface between gNodeB and UPF.

  • N9—The N9 interface connects two UPFs. It is the interface between intermediate I-UPF and UPF session anchor connecting different PLMN.

  • S5u—S5u is similar to the N9 interface that connects two UPFs. It is the interface between intermediate I-UPF and UPF session anchor.

  • S8u—S8u is an inter-PLMN variant of the S5u interface.

UPF Ingress Interface Type Configuration

Configuring UPF Ingress Interface Type

To configure the UPF ingress interface type, use the following configuration:

To enable upf-ingress CLI, you need the require upf CLI on the UPF. However, to enable the require upf CLI, you need the UPF license.


configure 
   context context_name 
      user-plane-service service_name 
         [ no ] associate gtpu-service gtpu_service_name upf-ingress interface-type [ n9 | s5u | s8u | n3 ] 
         end 

NOTES:

  • associate gtpu-service gtpu_service_name : Associate the GTP-U service with the user plane service.

  • upf-ingress : Configure the interface type as UPF ingress.

  • interface-type [ n9 | s5u | s8u | n3 ] : Configure the desired GTP-U ingress interface type.

  • If the N3 GTP-U ingress service is not present, then UPF uses the default interface.

  • If the configuration for N9, S5u, or S8u interfaces is not present, then UPF performs the following actions:

    • UPF looks to use the N9 interface first followed by the S5u and S8u interfaces.

    • If there is no GTP-U service, then UPF uses the default interface.

Configuration Example

The following is an example configuration:

associate gtpu-service n3-ingress upf-ingress 
associate gtpu-service n3-ingress upf-ingress interface-type n3
associate gtpu-service n9-ingress upf-ingress interface-type n9
associate gtpu-service s5-ingress upf-ingress interface-type s5
associate gtpu-service s8-ingress upf-ingress interface-type s8

Configuring Echo Response for N9 Interface

The echo response in a GTP-U service provides the availability of peer UPF.

The following is a sample echo response configuration for the N9 interface in hUPF:

gtpu-service n9-ingress
   echo-interval 60
   echo-retransmission-timeout 1
   bind ipv4-address 60.60.41.5 bearer-type all
   exit

The following is a sample echo response configuration for the N9 interface in vUPF:

gtpu-service n9-egress
   echo-interval 60
   echo-retransmission-timeout 1
   bind ipv4-address 60.60.42.5 bearer-type all
   exit

Configuration for Separating N3 and N9 BGP Routes

The following is a sample configuration to separate the N3 and N9 BGP routes for hUPF.


 config
  context SAEGW
    ip vrf mpls-vrf-1
    #exit
    ip vrf mpls-vrf-2
    #exit
    mpls bgp forwarding
    bfd-protocol
    #exit
    ip prefix-list name up seq 15 permit 50.50.17.4/32
    ip prefix-list name up seq 20 permit 50.50.17.5/32
    ip prefix-list name up seq 25 permit 50.50.17.6/32
    ip prefix-list name up seq 40 permit 50.50.17.7/32
    ip prefix-list name n9-up1 seq 50 permit 60.60.17.5/32
    ip prefix-list name n9-up1 seq 55 permit 60.60.17.6/32
    route-map up_routes1 permit 10
      match ip address prefix-list n9-up1
    #exit
    route-map up_routes permit 10
      match ip address prefix-list up
    #exit
    router bgp 61435
      maximum-paths ebgp 4
      neighbor 20.14.35.100 remote-as 65000
      neighbor 20.14.35.100 ebgp-multihop
      neighbor 20.14.35.100 update-source 20.14.35.98
      neighbor 2001:4888:121:1435::1 remote-as 65000
      neighbor 2001:4888:121:1435::1 ebgp-multihop
      neighbor 2001:4888:121:1435::1 update-source 2001:4888:121:1435::2
      neighbor 20.14.40.100 remote-as 65000
      neighbor 20.14.40.100 ebgp-multihop
      neighbor 20.14.40.100 update-source 20.14.40.98
      address-family ipv4
        neighbor 20.14.35.100 max-prefix 8192 threshold 50
        neighbor 20.14.35.100 route-map up_routes out
        neighbor 20.14.35.100 send-community extended
        neighbor 20.14.40.100 max-prefix 8192
        neighbor 20.14.40.100 route-map up_routes1 out
        neighbor 20.14.40.100 send-community extended
        redistribute connected
        redistribute static
      #exit
      address-family ipv6
        neighbor 2001:4888:121:1435::1 activate
        redistribute connected
        redistribute static
      #exit
    #exit
    interface SxC loopback
      ip address 50.50.17.4 255.255.255.255
    #exit
    interface SxC-ipv6 loopback
      ipv6 address 2001:4888:50:50::17/128
    #exit
    interface gn-1
      ip address 20.14.35.98 255.255.255.0
      ipv6 address 2001:4888:121:1435::2/64 secondary
    #exit
    interface gn-2
      ip address 20.14.36.98 255.255.255.0
      ipv6 address 2001:4888:121:1436::2/64 secondary
    #exit
    interface gn-n9-ingress
      ip address 20.14.40.98 255.255.255.0
    #exit
    interface n9-ingress-hupf loopback
      ip address 60.60.17.5 255.255.255.255
    #exit
    interface pgw-gtpu loopback
      ip address 50.50.17.5 255.255.255.255
    #exit
    interface sgw-gtpu-egress loopback
      ip address 50.50.17.6 255.255.255.255
    #exit
    interface sgw-gtpu-ingress-phazr loopback
      ip address 60.60.17.6 255.255.255.255
    #exit
    subscriber default
    exit
    aaa group default
    #exit
    gtpp group default
      gtpp limit-secondary-rat-usage 32
    #exit
    gtpu-service SxC
      echo-interval 60
      echo-retransmission-timeout 1
      bind ipv4-address 50.50.17.4 ipv6-address 2001:4888:50:50::17 bearer-type all
    exit
    gtpu-service n9-ingress
      bind ipv4-address 60.60.17.5 bearer-type all
    exit
    gtpu-service pgw-gtpu
      bind ipv4-address 50.50.17.5 bearer-type all
    exit
    gtpu-service sgw-gtpu-egress
      bind ipv4-address 50.50.17.6 bearer-type all
    exit
    gtpu-service sgw-gtpu-ingress-phazr
      echo-interval 60
      echo-retransmission-timeout 1
      bind ipv4-address 60.60.17.6 bearer-type all
    exit
    sx-service sx-svc
      instance-type userplane
      bind ipv4-address 50.50.17.4 ipv6-address 2001:4888:50:50::17
      sxa max-retransmissions 5
      sxa retransmission-timeout-ms 1000
      sxb max-retransmissions 5
      sxb retransmission-timeout-ms 1000
      sxab max-retransmissions 5
      sxab retransmission-timeout-ms 1000
      sx-protocol heartbeat retransmission-timeout 15
      sx-protocol heartbeat max-retransmissions 3
      sx-protocol association debug-mode debug-reattempt-timeout 1
      no sx-protocol compression
    exit
    user-plane-service user_plane_svc
      associate gtpu-service pgw-gtpu upf-ingress
      associate gtpu-service n9-ingress upf-ingress interface-type n9
      associate gtpu-service sgw-gtpu-ingress-phazr sgw-ingress
      associate gtpu-service sgw-gtpu-egress sgw-egress
      associate gtpu-service SxC cp-tunnel
      associate sx-service sx-svc
      associate fast-path service
      associate control-plane-group SAEGW
      associate userplane-load-control-profile LCP
      associate userplane-overload-control-profile OLCP
    exit

The following is a sample configuration to separate the N3 and N9 BGP routes for vUPF.

context SAEGW
    router bgp 61441
      neighbor 20.14.41.100 remote-as 65000
      neighbor 20.14.41.100 ebgp-multihop
      neighbor 20.14.41.100 update-source 20.14.41.98
      neighbor 2001:4888:121:1441::1 remote-as 65000
      neighbor 2001:4888:121:1441::1 ebgp-multihop
      neighbor 2001:4888:121:1441::1 update-source 2001:4888:121:1441::2
      address-family ipv4
        redistribute connected
        redistribute static
      #exit
      address-family ipv6
        neighbor 2001:4888:121:1441::1 activate
        redistribute connected
        redistribute static
      #exit
    #exit
    interface SxC loopback
      ip address 50.50.18.4 255.255.255.255
    #exit
    interface SxC-ipv6 loopback
      ipv6 address 2001:4888:50:50::18/128
    #exit
    interface gn-1
      ip address 20.14.41.98 255.255.255.0
      ipv6 address 2001:4888:121:1441::2/64 secondary
    #exit
    interface gn-2
      ip address 20.14.42.98 255.255.255.0
      ipv6 address 2001:4888:121:1442::2/64 secondary
    #exit
    interface n9-egress loopback
      ip address 50.50.18.8 255.255.255.255
    #exit
    interface pgw-gtpu loopback
      ip address 50.50.18.5 255.255.255.255
    #exit
    interface pgw-gtpu-ipv6 loopback
      ipv6 address 2001:4888:50:50::18:5/128
    #exit
    interface sgw-gtpu-egress loopback
      ip address 50.50.18.6 255.255.255.255
    #exit
    interface sgw-gtpu-egress-ipv6 loopback
      ipv6 address 2001:4888:50:50::18:6/128
    #exit
    interface sgw-gtpu-ingress-phazr loopback
      ip address 50.50.18.7 255.255.255.255
    #exit
    interface sgw-gtpu-ingress-phazr-ipv6 loopback
      ipv6 address 2001:4888:50:50::18:7/128
    #exit
    subscriber default
    exit
    aaa group default
    #exit
    gtpp group default
      gtpp limit-secondary-rat-usage 32
    #exit
    gtpu-service SxC
      echo-interval 60
      echo-retransmission-timeout 1
      bind ipv4-address 50.50.18.4 ipv6-address 2001:4888:50:50::18 bearer-type all
    exit
    gtpu-service n9-egress
      bind ipv4-address 50.50.18.8 bearer-type all
    exit
    gtpu-service pgw-gtpu
      bind ipv4-address 50.50.18.5 ipv6-address 2001:4888:50:50::18:5 bearer-type all
    exit
    gtpu-service sgw-gtpu-egress
      bind ipv4-address 50.50.18.6 ipv6-address 2001:4888:50:50::18:6 bearer-type all
    exit
    gtpu-service sgw-gtpu-ingress-phazr
      echo-interval 60
      echo-retransmission-timeout 1
      bind ipv4-address 50.50.18.7 ipv6-address 2001:4888:50:50::18:7 bearer-type all
    exit
    sx-service sx-svc
      instance-type userplane
      bind ipv4-address 50.50.18.4 ipv6-address 2001:4888:50:50::18
      sxa max-retransmissions 5
      sxa retransmission-timeout-ms 1000
      sxb max-retransmissions 5
      sxb retransmission-timeout-ms 1000
      sxab max-retransmissions 5
      sxab retransmission-timeout-ms 1000
      sx-protocol heartbeat retransmission-timeout 15
      sx-protocol heartbeat max-retransmissions 3
      sx-protocol association debug-mode debug-reattempt-timeout 1
      no sx-protocol compression
    exit
    user-plane-service user_plane_svc
      associate gtpu-service pgw-gtpu upf-ingress
      associate gtpu-service n9-egress upf-egress
      associate gtpu-service sgw-gtpu-ingress-phazr sgw-ingress
      associate gtpu-service sgw-gtpu-egress sgw-egress
      associate gtpu-service SxC cp-tunnel
      associate sx-service sx-svc
      associate fast-path service
      associate control-plane-group SAEGW
      associate userplane-load-control-profile LCP
      associate userplane-overload-control-profile OLCP
    exit
    ip route 0.0.0.0 0.0.0.0 20.14.41.100 gn-1
    ip igmp profile default
    #exit
  #exit 

Note


For RCM UPF, add all the IP prefix-lists in day 0.5 configuration.


Verifying the UPF Ingress Interface Type Configuration

To verify the configuration, use the following command:

show user-plane-service all

The show user-plane-service all command displays user-plane service information.

The following is a sample output of this command:

show user-plane-service all
Service name                        : user-plane-service 
  Service-Id                        : 7 
  Context                           : EPC2-UP 
  Status                            : NOT STARTED 
  UPF Ingress GTPU Service          : sx-gtpu-service 
  UPF Ingress N3 Interface Type GTPU Service: n3-ingress  
  UPF Ingress N9 Interface Type GTPU Service: n9-ingress  
  UPF Ingress S5U Interface Type GTPU Service: s5u-ingress  
  UPF Ingress S8U Interface Type GTPU Service: s8u-ingress  
  UPF Egress GTPU Service           : Not defined 
  SGW Ingress GTPU Service          : SGW-Ingress 
  SGW Egress GTPU Service           : SGW-Egress 
  Control Plane Tunnel GTPU Service : control_gtpu 
  Sx Service                        : sxu 
  Control Plane Group               : g1 
  Fast-Path service                 : Disabled 

NOTES:

  • The UPF configures only one of the interface types, pgw-ingress or upf-ingress in a single user plane service.