ここでは、ルート マップを使用した場合と、使用しない場合の再配布の例を示します。 IP および Connectionless Network Service(CLNS)の両方のルーティング プロトコルの例が示されています。 次の例では、すべての Open Shortest Path First(OSPF)ルートを Enhanced Interior Gateway Routing Protocol(EIGRP)に再配布します。
Device(config)# router eigrp 1
Device(config-router)# redistribute ospf 101
Device(config-router)# exit
次の例では、ホップ カウントが 1 のルーティング情報プロトコル(RIP)ルートを OSPF に再配布しています。 これらのルートは、メトリック 5、メトリック タイプ 1、およびタグ 1 の外部リンク ステート アドバタイズメント(LSA)として OSPF に再配布されます。
Device(config)# router ospf 1
Device(config-router)# redistribute rip route-map rip-to-ospf
Device(config-router)# exit
Device(config)# route-map rip-to-ospf permit
Device(config-route-map)# match metric 1
Device(config-route-map)# set metric 5
Device(config-route-map)# set metric-type type 1
Device(config-route-map)# set tag 1
Device(config-route-map)# exit
次の例では、OSPF で学習されたタグ 7 のルートを、RIP メトリック 15 として再配布しています。
Device(config)# router rip
Device(config-router)# redistribute ospf 1 route-map 5
Device(config-router)# exit
Device(config)# route-map 5 permit
Device(config-route-map)# match tag 7
Device(config-route-map)# set metric 15
次の例では、シリアル インターフェイス 0/0/0 のネクスト ホップ デバイスで、OSPF エリア内およびエリア間ルートをボーダー ゲートウェイ プロトコル(BGP)に 5 の INTER_AS メトリックで再配布します。
Device(config)# router bgp 50000
Device(config-router)# redistribute ospf 1 route-map 10
Device(config-router)# exit
Device(config)# route-map 10 permit
Device(config-route-map)# match route-type internal
Device(config-route-map)# match interface serial 0/0/0
Device(config-route-map)# set metric 5
次の例では、2 つのタイプのルートを(IP と CLNS のいずれもサポートする)統合 IS-IS ルーティング テーブルに再配布しています。 1 つめのタイプは、タグ 5 の OSPF 外部 IP ルートです。これらのルートは、メトリック 5 のレベル 2 IS-IS リンクステート パケット(LSP)に挿入されます。 2 番目のタイプは CLNS アクセス リスト 2000 と一致する ISO-IGRP から発生した CLNS プレフィックスです。これらのルートはメトリック 30 のレベル 2 IS-IS LSP に再配布されます。
Device(config)# router isis
Device(config-router)# redistribute ospf 1 route-map 2
Device(config-router)# redistribute iso-igrp nsfnet route-map 3
Device(config-router)# exit
Device(config)# route-map 2 permit
Device(config-route-map)# match route-type external
Device(config-route-map)# match tag 5
Device(config-route-map)# set metric 5
Device(config-route-map)# set level level-2
Device(config-route-map)# exit
Device(config)# route-map 3 permit
Device(config-route-map)# match address 2000
Device(config-route-map)# set metric 30
Device(config-route-map)# exit
次の設定では、タグ 1、2、3、および 5 の OSPF 外部ルータがそれぞれメトリック 1、1、5、および 5 の RIP に再配布されています。 タグ 4 の OSPF ルートは再配布されません。
Device(config)# router rip
Device(config-router)# redistribute ospf 101 route-map 1
Device(config-router)# exit
Device(config)# route-map 1 permit
Device(config-route-map)# match tag 1 2
Device(config-route-map)# set metric 1
Device(config-route-map)# exit
Device(config)# route-map 1 permit
Device(config-route-map)# match tag 3
Device(config-route-map)# set metric 5
Device(config-route-map)# exit
Device(config)# route-map 1 deny
Device(config-route-map)# match tag 4
Device(config-route-map)# exit
Device(config)# route map 1 permit
Device(config-route-map)# match tag 5
Device(config-route-map)# set metric 5
Device(config-route-map)# exit
次の設定の場合、RIP が学習したネットワーク 172.18.0.0 のルートと ISO-IGRP が学習したプレフィックス 49.0001.0002 のルートを、メトリック 5 の IS-IS レベル 2 LSP に再配布します。
Device(config)# router isis
Device(config-router)# redistribute rip route-map 1
Device(config-router)# redistribute iso-igrp remote route-map 1
Device(config-router)# exit
Device(config)# route-map 1 permit
Device(config-route-map)# match ip address 1
Device(config-route-map)# match clns address 2
Device(config-route-map)# set metric 5
Device(config-route-map)# set level level-2
Device(config-route-map)# exit
Device(config)# access-list 1 permit 172.18.0.0 0.0.255.255
Device(config)# clns filter-set 2 permit 49.0001.0002...
次の設定例では、default-information ルータ コンフィギュレーション コマンドでルート マップを参照する手順を示しています。 この参照タイプは、「条件付きのデフォルト発信元」と呼ばれます。 172.20.0.0 がルーティング テーブルにある場合、OSPF はタイプ 2 メトリック 5 のデフォルト ルート(ネットワーク 0.0.0.0)を発信します。
Device(config)# route-map ospf-default permit
Device(config-route-map)# match ip address 1
Device(config-route-map)# set metric 5
Device(config-route-map)# set metric-type type-2
Device(config-route-map)# exit
Device(config)# access-list 1 172.20.0.0 0.0.255.255
Device(config)# router ospf 101
Device(config-router)# default-information originate route-map ospf-default