소개
이 문서에서는 Finesse Supervisor Desktop에 너무 많은 정보가 표시될 때 Cisco UCCX(Unified Contact Center Express)에서 발생하는 문제에 대해 설명하고 문제 해결 방법에 대해서도 설명합니다.
사전 요구 사항
요구 사항
Finesse Desktop을 사용하여 UCCX 버전 10.0 이상에 대해 알고 있는 것이 좋습니다.
사용되는 구성 요소
이 문서의 정보는 UCCX 버전 10.0 이상(Finesse Desktop 포함)을 기반으로 합니다.
이 문서의 정보는 특정 랩 환경의 디바이스를 토대로 작성되었습니다.이 문서에 사용된 모든 디바이스는 초기화된(기본) 컨피그레이션으로 시작되었습니다.현재 네트워크가 작동 중인 경우, 모든 명령어의 잠재적인 영향을 미리 숙지하시기 바랍니다.
문제
Finesse Supervisor Desktop은 Finesse의 Queue Data(대기열 데이터) 탭의 Voice CSQ Summary Report(음성 CSQ 요약 보고서)에서 UCCX에 구성된 모든 CSQ(연결 서비스 대기열)에 대한 통계를 표시합니다.이 보고서는 Cisco CUIC(Unified Intelligence Center)에서 라이브 정보를 가져오는 내장형 라이브 데이터 가젯입니다. 또한 수퍼바이저는 에이전트가 할당된 팀과 상관없이 Finesse의 팀 데이터 탭에서 로그인한 모든 에이전트를 볼 수 있습니다.
일부 수퍼바이저만 모든 대기열 및 로그인한 에이전트를 볼 수 있는 것으로 관찰되었습니다.너무 많은 정보가 표시되므로 컨택 센터 환경 전체에서 이 문제가 발생합니다.
원인
이 문제는 수퍼바이저가 보고 사용자로 구성될 수도 있기 때문에 발생합니다.수퍼바이저가 Historical Reporting 사용자로 설정되면 수퍼바이저도 AllUsers에 할당됩니다.ReportingUsers 그룹 - 액세스 가능한 컬렉션 목록을 변경합니다(범위 확대).
Finesse Supervisor Desktop의 Queue Data(대기열 데이터) 탭에서 CUIC 라이브 데이터에서 음성 CSQ 요약 보고서, 음성 CSQ 상담원 세부 정보 보고서 및 상담원 통계 보고서에서 데이터를 가져옵니다.수퍼바이저의 범위에 해당하는 CSQ 항목이 표시되며, 수퍼바이저가 보고 사용자이기 때문에 이제 모든 CSQ가 표시됩니다.
Finesse Supervisor Desktop의 Team Data 탭에서 CUIC 라이브 데이터에서 Agent Statistics Report의 데이터를 가져옵니다.수퍼바이저의 범위에 해당하는 에이전트가 표시되며, 수퍼바이저가 보고 사용자이기 때문에 이제 모든 상담원이 표시됩니다.
참고:기본적으로 수퍼바이저는 Cisco Unified Contact Center Express 보고서 사용 설명서 10.6(1)에 설명된 라이브 데이터 보고서에만 액세스할 수 있습니다.
해결 방법
참고:이 문제는 Cisco 버그 ID CSCus17605에서 개선 요청으로 추적됩니다.
이 문제를 해결하려면 Finesse Supervisor Desktop에 나타나는 통계의 범위가 축소됩니다. Finesse Administration 페이지를 통해 XML 레이아웃을 수정해야 합니다.각 가젯의 URL을 수정해야 합니다.예를 들면 다음과 같습니다.
참고:이 섹션에서 XML 코드를 복사하여 붙여넣지 마십시오.이 예제는 예제로 표시되며, Finesse에서 XML 코드를 변경하면 사례별로 변경됩니다.
팀 "blue"의 리소스인 수퍼바이저가 CSQ에 할당된 팀 "blue" 및 팀 "red"에 대한 CSQ 데이터를 보려는 경우, 이 두 팀에 할당되지 않은 CSQ에 대한 다른 CSQ 데이터는 보려면, 이 예에 표시된 것처럼 Finesse Administration(팀 리소스) 탭의 Finesse Administration(Finesse 관리) 페이지에서 팀 "blue"에 대한 Finesse 레이아웃 XML의 queueData URL을 편집합니다.
<id>queueData</id>
<label>finesse.container.tabs.supervisor.queueDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveData
Gadget.jsp?gadgetHeight=620&viewId_1=C8E2DB1610000140000000A60A4E5E6B&filterId_1
=VoiceIAQStats.esdName=CL%20blue,%20red&viewId_2=9A7A14CE10000140000000ED0A
4E5E6B&filterId_2=VoiceCSQDetailsStats.agentId=CL%20blue,%20red&compositeFilterId
=VoiceCSQDetailsStats.AgentVoiceCSQNames.agentVoiceCSQName=CL%20blue,%20red
&viewId_3=C8EF510810000140000000EB0A4E5E6B&filterId_3=VoiceIAQStats.esdName
=CL%20blue,%20red&viewId_4=C8EE241910000140000000C30A4E5E6B&filterId_4
=VoiceIAQStats.esdName=CL%20blue,%20red</gadget>
마찬가지로 팀 "blue"의 리소스인 수퍼바이저가 팀 "blue" 및 팀 "red"의 멤버에 대한 팀 데이터를 보고자 하지만 이 두 팀에 속하지 않은 상담원에 대한 다른 팀 데이터는 보고자 하는 경우 이 예와 같이 팀 "blue"에 대한 teamData URL을 편집합니다.
<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>
<column>
<gadgets>
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=620&viewId_1=7291DCB410000140000000890A4E5B33&filterId_1=
ResourceIAQStats.resourceId=CL%20blue,%20red&viewId_2=728283C210000140000000530A4E5B33
&filterId_2=ResourceIAQStats.resourceId=CL%20blue,%20red</gadget>
이 예제에 대한 몇 가지 중요한 참고 사항이 있습니다.
- URL 내에서 CL만 사용하는 경우 보고서에는 수퍼바이저가 권한을 가진 모든 컬렉션의 값이 포함됩니다.
- CL%20<Team_Name>이 URL 내에서 사용되는 경우 <Team_Name>은 수퍼바이저가 데이터를 보려는 팀의 실제 이름으로 바뀝니다.따라서 <Team_Name>에 대한 데이터만 표시됩니다.URL의 <Team_Name>은 자리 표시자이며 CUIC 서버로 전송되기 전에 Finesse가 CUIC 가젯 코드로 전달하는 실제 값으로 대체됩니다.수퍼바이저가 여러 팀의 데이터를 보려면 팀 수 'N'개, CL%20<Team_Name_1>,%20<Team_Name_2>,...,%20<Team_Name_N>을 사용해야 합니다.
- CL%20blue를 URL 내에서 사용하면(파란색이 실제 팀 이름이라는 가정) 파란색 컬렉션에 속하는 값만 표시됩니다.
- CL%20blue,%20red가 URL 내에서 사용될 때(파란색과 빨간색이 실제 팀 이름이라는 가정) 파란색 컬렉션과 빨간색 컬렉션에 속하는 값만 표시됩니다.
다른 가젯에도 이러한 수정 사항을 구현해야 합니다.가젯 URL 및 라이브 데이터에 대한 가젯 정의에 대한 자세한 내용은 Cisco Unified CCX 관리 가이드, 릴리스 10.6을 참조하십시오.
참고:팀 레벨의 데스크톱 레이아웃에서 수정을 완료해야 하므로 이 해결 방법을 사용할 때 신중하게 평가해야 합니다.팀 수준에서 편집 작업을 수행할 때 시스템 기본 레이아웃을 재정의할 수 있습니다.
참고:공백이 있는 팀 이름을 사용할 수 있지만 공백을 나타내려면 XML 레이아웃을 %20으로 설정해야 합니다.
기능 소개
이 문제를 완전히 해결하기 위해 UCCX 11.6에 새로운 기능이 도입되었습니다.이 기능은 Cisco 버그 ID CSCus17605 아래의 개선 요청을 통해 추가되었습니다.
UCCX 11.6부터 수퍼바이저는 팀의 기록 보고서에 액세스할 수 있으므로 추가 보고 사용자 역할을 설정할 필요가 없습니다.이렇게 하면 수퍼바이저는 Finesse Live Data 보고서에서만 팀을 볼 수 있으며, 보고 사용자 역할 없이도 팀의 기록 보고서에 액세스할 수 있습니다.보고 사용자 역할이 어떤 사용자에게 추가되면 모든 보고서의 모든 팀 에이전트 및 CSQ를 볼 수 있는 액세스 권한이 부여되며 Finesse 라이브 데이터 보고서의 모든 에이전트 및 CSQ가 표시됩니다.