簡介
本文檔介紹如何使用環回地址配置或不使用環回地址配置iBGP和eBGP。
必要條件
需求
思科建議您瞭解以下主題:
採用元件
本文件所述內容不限於特定軟體和硬體版本。
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路運作中,請確保您瞭解任何指令可能造成的影響。
慣例
如需文件慣例的詳細資訊,請參閱思科技術提示慣例。
背景資訊
BGP是一種外部閘道通訊協定(EGP),用於在TCP/IP網路中執行網域間路由。在交換BGP更新之前,BGP路由器需要與每個BGP對等體建立連線(在TCP埠179上)。如果BGP對等點位於不同的自治系統(AS)中,則兩個BGP對等點之間的BGP作業階段稱為外部BGP (eBGP)作業階段。如果BGP對等體位於相同的自治系統中,則兩個BGP對等體之間的BGP會話稱為內部BGP (iBGP)會話。
預設情況下,對等關係是使用最接近對等路由器的介面的IP地址建立的。但是,當使用neighbor update-source命令時,可指定任何工作介面(包括環回介面)以建立TCP連線。這種與環回介面對等的方法很有用,因為當BGP對等體之間存在多個路徑時,它無法中斷BGP會話。否則,如果用於建立會話的物理介面斷開,BGP會話將會斷開。此外,它還允許運行BGP且其間有多個鏈路的路由器在可用路徑上進行負載均衡。
本文檔中的配置示例用於iBGP和eBGP,有環回地址也有環回地址。
設定
本節包含以下配置示例:
本節提供用於設定本文件中所述功能的資訊。
注意:要查詢關於用於本文的命令的其他資訊,請使用命令查詢工具。只有已註冊的思科使用者才能訪問思科內部資訊和工具。
網路圖表
此文件使用以下網路設定:
iBGP配置
在此配置中,兩台路由器均為inAS 400。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 400
!--- Enables BGP for the autonomous !--- system 400.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an iBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 400
!-- Output suppressed.
end |
eBGP配置
在此配置中,路由器R1-AGS位於AS 300中,而路由器R6-2500位於AS 400中。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
!--- Enables BGP for the autonomous !--- system 300.
neighbor 10.10.10.2 remote-as 400
!--- Specifies a neighbor 10.10.10.2 !--- in the remote AS 400, making !--- this an eBGP connection.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.10.10.1 remote-as 300
!-- Output suppressed.
end |
使用eBGP時,對等體必須直接連線。如果它們不是直接連線,則必須使用neighbor ebgp-multihop 命令,並且必須存在透過IGP或靜態路由到達對等體的路徑,以便路由器建立鄰居關係。在先前的配置中,R1-AGS路由器屬於AS 300,而R6-2500路由器屬於AS 400。
使用環回地址的iBGP配置
您可以使用環回地址(或任何其他操作介面)配置iBGP,如本部分所示。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 300
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the specified external !--- peer should be established with the !--- address on the loopback interface.
!
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 300
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
使用環回地址的eBGP配置
您還可以使用環回地址(或任何其他操作介面)配置eBGP,如本部分所示。以這種方式使用環回介面可保證具有多個路徑的網路中的可達性,詳細資訊請參閱使用環回地址作為BGP鄰居的負載共用。
R1-AGS |
R6-2500 |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface Serial1
ip address 10.10.10.1 255.255.255.0
!
router bgp 300
neighbor 10.2.2.2 remote-as 400
neighbor 10.2.2.2 ebgp-multihop 2
!--- This command changes the ttl value in !--- order to allow the packet to reach the !--- external BGP peer which is not directly !--- connected or is with an interface other !--- than the directly connected interface.
neighbor 10.2.2.2 update-source Loopback0
!--- This command specifies that the TCP !--- connection with the external BGP !--- peer should be established with the !--- address on the loopback interface.
ip route 10.2.2.2 255.255.255.255 10.10.10.2
!--- This static route ensures that the !--- remote peer address used for peering !--- is reachable.
!-- Output suppressed.
end |
Current configuration:
!-- Output suppressed.
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
neighbor 10.1.1.1 remote-as 300
neighbor 10.1.1.1 ebgp-multihop 2
neighbor 10.1.1.1 update-source Loopback0
!
ip route 10.1.1.1 255.255.255.255 10.10.10.1
!-- Output suppressed.
end |
驗證
以下各節提供的資訊可用於確認您的配置是否正常工作。輸出直譯器工具支援某些show命令(只限於註冊使用者),透過它可以檢視show命令輸出的分析。
驗證iBGP配置
使用show ip bgp neighbors 命令顯示有關TCP和邊界網關協定(BGP)連線的資訊,並驗證是否建立了BGP對等體。show ip bgp neighbors 命令的輸出接著顯示BGP狀態為Established,表示已成功建立BGP對等體關係。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:04:20
BGP table version 1, neighbor version 1
R1-AGS#
show ip bgp neighbors 命令以前使用過修飾符| 包括BGP。如此可讓指令輸出更易於閱讀,且只顯示相關部分。
此外,show ip bgp summary 命令還可用於顯示所有BGP連線的狀態,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
驗證eBGP配置
使用show ip bgp neighbors 命令顯示有關TCP和邊界網關協定(BGP)連線的資訊,並驗證是否建立了BGP對等體。show ip bgp neighbors 命令的輸出接著顯示BGP狀態為Established,表示已成功建立BGP對等體關係。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:17
BGP table version 1, neighbor version 1
此外,show ip bgp summary 命令還可用於顯示所有BGP連線的狀態,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 400 3 3 1 0 0 00:00:26 0
使用環回地址驗證iBGP配置
使用show ip bgp neighbors 命令顯示有關TCP和邊界網關協定(BGP)連線的資訊,並驗證是否建立了BGP對等體。show ip bgp neighbors 命令的輸出接著顯示BGP狀態為Established,表示已成功建立BGP對等體關係。
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 300, internal link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:28
BGP table version 1, neighbor version 1
R1-AGS#
此外,show ip bgp summary 命令還可用於顯示所有BGP連線的狀態,如下所示。
R1-AGS(9)#show ip bgp summary
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
使用環回地址驗證eBGP配置
R1-AGS#show ip bgp neighbors | include BGP
BGP neighbor is 10.2.2.2, remote AS 400, external link
BGP version 4, remote router ID 10.2.2.2
BGP state = Established, up for 00:00:16
BGP table version 1, neighbor version 1
External BGP neighbor may be up to 2 hops away.
此外,show ip bgp summary 命令還可用於顯示所有BGP連線的狀態,如下所示。
R1-AGS(9)#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.2.2.2 4 400 3 3 1 0 0 00:00:26 0
疑難排解
有關詳細資訊,請參閱為什麼BGP鄰居在空閒、連線和活動狀態之間切換,並對常見BGP問題進行故障排除。
相關資訊