L2CP トンネリングの設定
プロトコル |
パケット タイプ |
アクション |
---|---|---|
CDP |
タグなし |
ピア |
LACP |
タグなし |
ピア |
LLDP |
タグなし |
ピア以外トンネル化 |
STP |
タグなし |
ピア |
VTP |
タグなし |
ピア |
OAM |
タグなし |
ピア |
BPDU |
タグなし |
トンネル化 |
CDP |
タグ付き |
トンネル化 |
LACP |
タグ付き |
トンネル化 |
LLDP |
タグ付き |
トンネル化 |
STP |
タグ付き |
トンネル化 |
VTP |
タグ付き |
トンネル化 |
BPDU |
タグ付き |
トンネル化 |
OAM |
タグ付き |
トンネル化 |
ELMI |
タグ付き |
トンネル化 |
L2CP トンネリングを設定するには、次のステップを実行します。
/* Configure Attachment Circuit interface. *
RP/0/RP0/CPU0:ios(config)#int tenGigE 0/1/0/8/0
RP/0/RP0/CPU0:ios(config-if)#no shut
RP/0/RP0/CPU0:ios(config-if)#ipv4 addr 13.1.1.1/24
RP/0/RP0/CPU0:ios(config-if)#commit
Fri Sep 1 17:02:57.130 UTC
rRP/0/RP0/CPU0:ios(config-if)#int loop 1
RP/0/RP0/CPU0:ios(config-if)#ipv4 addr 2.2.2.6/32
RP/0/RP0/CPU0:ios(config-if)#commit
Fri Sep 1 17:03:08.163 UTC
RP/0/RP0/CPU0:ios(config)#l2vpn
RP/0/RP0/CPU0:ios(config-l2vpn)#xconnect group g1
RP/0/RP0/CPU0:ios(config-l2vpn-xc)#p2p 1
RP/0/RP0/CPU0:ios(config-l2vpn-xc-p2p)#int tenGigE 0/1/0/8/3.1
RP/0/RP0/CPU0:ios(config-l2vpn-xc-p2p)#neighbor 12.12.12.1 pw-id 1
RP/0/RP0/CPU0:ios(config-l2vpn-xc-p2p-pw)#commit
Fri Sep 1 17:11:19.516 UTC
/* Configure OSPF. */
RP/0/RP0/CPU0:ios(config-if)#router ospf 100 area 0
RP/0/RP0/CPU0:ios(config-ospf-ar)#int tenGigE 0/1/0/8/0
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#int loop 1
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#commit
Fri Sep 1 17:03:20.753 UTC
RP/0/RP0/CPU0:ios(config-ospf-ar-if)#exit
RP/0/RP0/CPU0:ios(config-ospf-ar)#exit
RP/0/RP0/CPU0:ios(config-ospf)#exit
/* Configure MPLS LDP. */
RP/0/RP0/CPU0:ios(config)#mpls ldp
RP/0/RP0/CPU0:ios(config-ldp)#int tenGigE 0/1/0/8/0
RP/0/RP0/CPU0:ios(config-ldp-if)#exit
RP/0/RP0/CPU0:ios(config-ldp)#
実行コンフィギュレーション
RP/0/RP0/CPU0:ios# show run
Fri Sep 1 17:27:52.682 UTC
Building configuration...
!! IOS XR Configuration version = 6.4.1.11I
!! Last configuration change at Fri Sep 1 17:26:37 2017 by root
!
telnet vrf default ipv4 server max-servers 10
username root
group root-lr
group cisco-support
secret 5 $1$X9aA$9qdjKAnEbvNG8pfSNsgm/0
!
interface Loopback1
ipv4 address 2.2.2.6 255.255.255.255
!
interface MgmtEth0/RP0/CPU0/0
ipv4 address 5.10.10.122 255.255.0.0
!
interface TenGigE0/1/0/8/0
ipv4 address 13.1.1.1 255.255.255.0
!
interface TenGigE0/1/0/8/1
shutdown
!
interface TenGigE0/1/0/8/2
shutdown
!
interface TenGigE0/1/0/8/3
l2transport
!
!
controller Optics0/1/0/8
breakout 4x10
!
interface HundredGigE0/1/0/0
shutdown
!
interface HundredGigE0/1/0/1
shutdown
!
interface HundredGigE0/1/0/2
shutdown
!
interface HundredGigE0/1/0/3
shutdown
!
interface HundredGigE0/1/0/4
shutdown
!
interface HundredGigE0/1/0/5
shutdown
!
interface HundredGigE0/1/0/6
shutdown
!
interface HundredGigE0/1/0/7
shutdown
!
interface HundredGigE0/1/0/9
shutdown
!
interface HundredGigE0/1/0/10
shutdown
!
interface HundredGigE0/1/0/11
shutdown
!
interface HundredGigE0/1/0/12
shutdown
!
interface HundredGigE0/1/0/13
shutdown
!
interface HundredGigE0/1/0/14
shutdown
!
interface HundredGigE0/1/0/15
shutdown
!
interface HundredGigE0/1/0/16
shutdown
!
interface HundredGigE0/1/0/17
shutdown
!
interface HundredGigE0/1/0/18
shutdown
!
interface HundredGigE0/1/0/19
shutdown
!
interface HundredGigE0/1/0/20
shutdown
!
interface HundredGigE0/1/0/21
shutdown
!
interface HundredGigE0/1/0/22
shutdown
!
interface HundredGigE0/1/0/23
shutdown
!
router static
address-family ipv4 unicast
202.153.144.0/24 5.10.0.1
!
!
router ospf 100
area 0
interface Loopback1
!
interface TenGigE0/1/0/8/0
!
!
!
l2vpn
bridge group b1
bridge-domain b1
interface TenGigE0/1/0/8/3
!
vfi vf
neighbor 12.12.12.1 pw-id 1
!
!
!
!
!
mpls ldp
interface TenGigE0/1/0/8/0
!
!
end
確認
RP/0/RP0/CPU0:ios#show ospf neighbor
Fri Sep 1 17:24:43.641 UTC
* Indicates MADJ interface
# Indicates Neighbor awaiting BFD session up
Neighbors for OSPF 100
Neighbor ID Pri State Dead Time Address Interface
12.12.12.1 1 FULL/DR 00:00:31 13.1.1.2 TenGigE0/1/0/8/0
Neighbor is up for 00:21:15
Total neighbor count: 1
RP/0/RP0/CPU0:ios#show mpls ldp neighbor
Fri Sep 1 17:24:46.602 UTC
Peer LDP Identifier: 12.12.12.1:0
TCP connection: 12.12.12.1:64120 - 2.2.2.6:646
Graceful Restart: No
Session Holdtime: 180 sec
State: Oper; Msgs sent/rcvd: 19/26; Downstream-Unsolicited
Up time: 00:01:46
LDP Discovery Sources:
IPv4: (1)
TenGigE0/1/0/8/0
IPv6: (0)
Addresses bound to this peer:
IPv4: (8)
5.5.5.1 5.10.23.254 12.12.12.1 13.1.1.2
17.1.1.1 88.8.8.8 102.0.0.2 200.169.0.1
IPv6: (0)
RP/0/RP0/CPU0:ios#show bgp neighbor
Fri Sep 1 17:24:50.158 UTC
BGP neighbor is 12.12.12.1
Remote AS 15169, local AS 15169, internal link
Remote router ID 88.8.8.8
BGP state = Established, up for 00:00:05
NSR State: None
Last read 00:00:00, Last read before reset 00:00:00
Hold time is 180, keepalive interval is 60 seconds
Configured hold time: 180, keepalive: 60, min acceptable hold time: 3
Last write 00:00:00, attempted 29, written 29
Second last write 00:00:05, attempted 19, written 19
Last write before reset 00:00:00, attempted 0, written 0
Second last write before reset 00:00:00, attempted 0, written 0
Last write pulse rcvd Sep 1 17:24:50.144 last full not set pulse count 6
Last write pulse rcvd before reset 00:00:00
Socket not armed for io, armed for read, armed for write
Last write thread event before reset 00:00:00, second last 00:00:00
Last KA expiry before reset 00:00:00, second last 00:00:00
Last KA error before reset 00:00:00, KA not sent 00:00:00
Last KA start before reset 00:00:00, second last 00:00:00
Precedence: internet
Non-stop routing is enabled
Multi-protocol capability received
Neighbor capabilities:
Route refresh: advertised (old + new) and received (old + new)
4-byte AS: advertised and received
Address family L2VPN VPLS: advertised and received
Received 3 messages, 0 notifications, 0 in queue
Sent 3 messages, 0 notifications, 0 in queue
Minimum time between advertisement runs is 0 secs
Inbound message logging enabled, 3 messages buffered
Outbound message logging enabled, 3 messages buffered
For Address Family: L2VPN VPLS
BGP neighbor version 1
Update group: 0.2 Filter-group: 0.1 No Refresh request being processed
NEXT_HOP is always this router
Route refresh request: received 0, sent 0
0 accepted prefixes, 0 are bestpaths
Exact no. of prefixes denied : 0.
Cumulative no. of prefixes denied: 0.
Prefix advertised 0, suppressed 0, withdrawn 0
Maximum prefixes allowed 2097152
Threshold for warning message 75%, restart interval 0 min
AIGP is enabled
An EoR was received during read-only mode
Last ack version 1, Last synced ack version 0
Outstanding version objects: current 0, max 0
Additional-paths operation: None
Send Multicast Attributes
Connections established 1; dropped 0
Local host: 2.2.2.6, Local port: 34285, IF Handle: 0x00000000
Foreign host: 12.12.12.1, Foreign port: 179
Last reset 00:00:00
RP/0/RP0/CPU0:ios#
RP/0/RP0/CPU0:ios#show l2vpn bridge-domain
Fri Sep 1 17:27:25.002 UTC
Legend: pp = Partially Programmed.
Bridge group: b1, bridge-domain: b1, id: 0, state: up, ShgId: 0, MSTi: 0
Aging: 300 s, MAC limit: 32000, Action: none, Notification: syslog
Filter MAC addresses: 0
ACs: 1 (1 up), VFIs: 1, PWs: 1 (1 up), PBBs: 0 (0 up), VNIs: 0 (0 up)
List of ACs:
Te0/1/0/8/3, state: up, Static MAC addresses: 0
List of Access PWs:
List of VFIs:
VFI vf (up)
Neighbor 12.12.12.1 pw-id 1, state: up, Static MAC addresses: 0
List of Access VFIs:
RP/0/RP0/CPU0:ios#
RP/0/RP0/CPU0:ios#show l2vpn xconnect
Fri Sep 1 17:28:58.259 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed
XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ----------------------------- -----------------------------
1 1 UP Te0/1/0/8/3 UP 12.12.12.1 1 UP
----------------------------------------------------------------------------------------
RP/0/RP0/CPU0:ios#
RP/0/RP0/CPU0:ios#show l2vpn xconnect
Fri Sep 1 17:28:58.259 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
SB = Standby, SR = Standby Ready, (PP) = Partially Programmed
XConnect Segment 1 Segment 2
Group Name ST Description ST Description ST
------------------------ ----------------------------- -----------------------------
1 1 UP Te0/1/0/8/3 UP 12.12.12.1 1 UP
----------------------------------------------------------------------------------------
RP/0/RP0/CPU0:ios#