Configuring Static Routing

This chapter describes how to configure static routing on the Cisco NX-OS device.

This chapter contains the following sections:

About Static Routing

Routers forward packets using either route information from route table entries that you manually configure or the route information that is calculated using dynamic routing algorithms.

Static routes, which define explicit paths between two routers, cannot be automatically updated. You must manually reconfigure static routes when network changes occur. Static routes use less bandwidth than dynamic routes. No CPU cycles are used to calculate and analyze routing updates.

You can supplement dynamic routes with static routes where appropriate. You can redistribute static routes into dynamic routing algorithms, but you cannot redistribute routing information calculated by dynamic routing algorithms into the static routing table.

You should use static routes in environments where network traffic is predictable and where the network design is simple. You should not use static routes in large, constantly changing networks because static routes cannot react to network changes. Most networks use dynamic routes to communicate between routers but might have one or two static routes configured for special cases. Static routes are also useful for specifying a gateway of last resort (a default router to which all unroutable packets are sent).

Administrative Distance

An administrative distance is the metric used by routers to choose the best path when there are two or more routes to the same destination from two different routing protocols. An administrative distance guides the selection of one routing protocol (or static route) over another, when more than one protocol adds the same route to the unicast routing table. Each routing protocol is prioritized in order of most to least reliable using an administrative distance value.

Static routes have a default administrative distance of 1. A router prefers a static route to a dynamic route because the router considers a route with a low number to be the shortest. If you want a dynamic route to override a static route, you can specify an administrative distance for the static route. For example, if you have two dynamic routes with an administrative distance of 120, you would specify an administrative distance that is greater than 120 for the static route if you want the dynamic route to override the static route.

Directly Connected Static Routes

You must specify only the output interface (the interface on which all packets are sent to the destination network) in a directly connected static route. The router assumes that the destination is directly attached to the output interface and the packet destination is used as the next-hop address. The next hop can be an interface, but only for point-to-point interfaces. For broadcast interfaces, the next hop must be an IPv4/IPv6 address.

Fully Specified Static Routes

You must specify either the output interface (the interface on which all packets are sent to the destination network) or the next-hop address in a fully specified static route. You can use a fully specified static route when the output interface is a multi-access interface and you need to identify the next-hop address. The next-hop address must be directly attached to the specified output interface.

Floating Static Routes

A floating static route is a static route that the router uses to back up a dynamic route. You must configure a floating static route with a higher administrative distance than the dynamic route that it backs up. In this instance, the router prefers a dynamic route to a floating static route. You can use a floating static route as a replacement if the dynamic route is lost.


Note


By default, a router prefers a static route to a dynamic route because a static route has a smaller administrative distance than a dynamic route.


Remote Next Hops for Static Routes

You can specify the next-hop address of a neighboring router that is not directly connected to the router for static routes with remote (non-directly attached) next hops. If a static route has remote next hops during data forwarding, the next hops are recursively used in the unicast routing table to identify the corresponding directly attached next hops that have reachability to the remote next hops.

BFD

This feature supports bidirectional forwarding detection (BFD). BFD is a detection protocol that is designed to provide fast forwarding-path failure detection times. BFD provides subsecond failure detection between two adjacent devices and can be less CPU intensive than protocol hello messages because some of the BFD load can be distributed onto the data plane on supported modules. See the Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide, Release 9.3(x) for more information.

Virtualization Support

Static routes support virtual routing and forwarding (VRF) instances.

Prerequisites for Static Routing

Static routing has the following prerequisites:

  • A static route will not be added to the unicast routing table if there is no unicast route containing its next hop address.

Default Settings

The table lists the default settings for static routing parameters.

Table 1. Default Static Routing Parameters
Parameters Default

Administrative distance

1

RIP feature

Disabled

Configuring Static Routing


Note


If you are familiar with the Cisco IOS CLI, be aware that the Cisco NX-OS commands for this feature might differ from the Cisco IOS commands that you would use.


Configuring a Static Route

You can configure a static route on the device.

SUMMARY STEPS

  1. configure terminal
  2. Enter one of these commands:
    • ip route {ip-prefix | ip-addr/ip-mask} {[next-hop | nh-prefix] | [interface next-hop | nh-prefix]} [name nexthop-name] [tag tag-value] [preference]
    • ipv6 route ipv6-prefix {nh-prefix | link-local-nh-prefix} | {nexthop [interface] | link-local-nexthop [interface]} [name nexthop-name] [tag tag-value] [preference]
  3. (Optional) show {ip | ipv6} static-route
  4. (Optional) copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

Enter one of these commands:

  • ip route {ip-prefix | ip-addr/ip-mask} {[next-hop | nh-prefix] | [interface next-hop | nh-prefix]} [name nexthop-name] [tag tag-value] [preference]
  • ipv6 route ipv6-prefix {nh-prefix | link-local-nh-prefix} | {nexthop [interface] | link-local-nexthop [interface]} [name nexthop-name] [tag tag-value] [preference]

Example:

switch(config)# ip route 192.0.2.0/8
ethernet 1/2 192.0.2.4

switch(config)# ipv6 route
2001:0DB8::/48 6::6 ethernet 2/1

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 to 255. The default is 1.

Note

 

Use the no {ip | ipv6} route command to remove the static route.

Step 3

(Optional) show {ip | ipv6} static-route

Example:

switch(config)# show ip static-route
(Optional)

Displays information about static routes.

Step 4

(Optional) copy running-config startup-config

Example:

switch(config)# copy running-config
startup-config
(Optional)

Saves this configuration change.

Example

This example shows how to configure a static route for a null interface:

switch# configure terminal
switch(config)# ip route 1.1.1.1/32 null 0
switch(config)# copy running-config startup-config

Configuring a Static Route Over a VLAN

You can configure a static route without next-hop support over a VLAN.

Before you begin

Ensure that the access port is part of the VLAN.

SUMMARY STEPS

  1. configure terminal
  2. feature interface vlan
  3. interface-vlan vlan-id
  4. ip address ip-addr/length
  5. [no] ip route ip-addr/length vlan-id
  6. (Optional) show ip route
  7. (Optional) copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

feature interface vlan

Example:

switch(config)# feature interface-vlan

Enables VLAN interface mode.

Step 3

interface-vlan vlan-id

Example:

switch(config)# interface-vlan 10

Creates an SVI and enters interface configuration mode.

The range for the vlan-id argument is from 1 to 4094, except for the VLANs reserved for the internal switch.

Step 4

ip address ip-addr/length

Example:

switch(config)# ip address 192.0.2.1/8

Configures an IP address for the VLAN.

Step 5

[no] ip route ip-addr/length vlan-id

Example:

switch(config)# ip route
209.165.200.224/27 vlan 10

Adds an interface static route without a next hop on the switch virtual interface (SVI).

The IP address is the address that is configured on the interface that is connected to the switch.

Use the no keyword with this command to remove the static route.

Step 6

(Optional) show ip route

Example:

switch(config)# show ip route
(Optional)

Displays routes from the Unicast Route Information Base (URIB).

Step 7

(Optional) copy running-config startup-config

Example:

switch(config)# copy running-config
startup-config
(Optional)

Saves this configuration change.

Example

This example shows how to configure a static route without a next hop over an SVI:

switch# configure terminal
switch(config)# feature interface-vlan
swicth(config)# interface vlan 10
switch(config-if)# ip address 192.0.2.1/8
switch(config-if)# ip route 209.165.200.224/27 vlan 10  <===209,165.200.224 is the IP
address of the interface that is configured on the interface that is directly connected to
the switch.
switch(config-if)# copy running-config startup-config

Configuring Virtualization

You can configure a static route in a VRF.


Note


When a ip route command is applied on a VRF context, the show run vrf command displays some octets that have changed from the initial configuration.


SUMMARY STEPS

  1. configure terminal
  2. vrf context vrf-name
  3. Enter one of these commands:
    • ip route {ip-prefix | ip-addr ip-mask} {next-hop | nh-prefix | interface} [name nexthop-name] [tag tag-value] [preference]
    • ipv6 route ipv6-prefix {nh-prefix | link-local-nh-prefix} | {nexthop [interface] | link-local-nexthop [interface]} [name nexthop-name] [tag tag-value] [preference]
  4. (Optional) show {ip | ipv6} static-route vrf vrf-name
  5. (Optional) copy running-config startup-config

DETAILED STEPS

  Command or Action Purpose

Step 1

configure terminal

Example:

switch# configure terminal
switch(config)#

Enters global configuration mode.

Step 2

vrf context vrf-name

Example:

switch(config)# vrf context StaticVrf
switch(config-vrf)#

Creates a VRF and enters VRF configuration mode.

Step 3

Enter one of these commands:

  • ip route {ip-prefix | ip-addr ip-mask} {next-hop | nh-prefix | interface} [name nexthop-name] [tag tag-value] [preference]
  • ipv6 route ipv6-prefix {nh-prefix | link-local-nh-prefix} | {nexthop [interface] | link-local-nexthop [interface]} [name nexthop-name] [tag tag-value] [preference]

Example:

switch(config-vrf)# ip route 192.0.2.0/8
ethernet 1/2

switch(config-vrf)# ipv6 route
2001:0DB8::/48 6::6 ethernet 2/1

Configures a static route and the interface for this static route. Use ? to display a list of supported interfaces. You can specify a null interface by using null 0 .

You can optionally configure the next-hop address.

The preference value sets the administrative distance. The range is from 1 through 255. The default is 1.

Step 4

(Optional) show {ip | ipv6} static-route vrf vrf-name

Example:

switch(config-vrf)# show ip static-route
(Optional)

Displays information about static routes.

Step 5

(Optional) copy running-config startup-config

Example:

switch(config-vrf)# copy running-config
startup-config
(Optional)

Saves this configuration change.

Example

This example shows how to configure a static route:

switch# configure terminal
switch(config)# vrf context StaticVrf
switch(config-vrf)# ip route 192.0.2.0/8 192.0.2.10
switch(config-vrf)# copy running-config startup-config

Verifying the Static Routing Configuration

To display the static routing configuration, perform one of the following tasks:

Command

Purpose

show {ip | ipv6} static-route

Displays the configured static routes.

show ipv6 static-route vrf vrf-name

Displays static route information for each VRF.

show {ip | ipv6} static-route track-table

Displays information about the IPv4 or IPv6 static-route track table.

Configuration Example for Static Routing

This example shows how to configure static routing:

configure terminal
ip route 192.0.2.0/8 192.0.2.10
copy running-config startup-config