WCCP with Generic GRE Support

Extended Web Cache Communication Protocol (WCCP) supports multipoint generic routing encapsulation (mGRE) return method on Cisco IOS devices. GRE-negotiated return is not supported on the Cisco Wide Area Application Services (WAAS) AppNav I/O module (IOM), customers need to use generic GRE tunnels (multipoint GRE) on the devices.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for WCCP with Generic GRE Support

  • Generic GRE tunnel does not work with a loopback source address. Because the highest numbered loopback is reserved for WCCP, customers need to use the second highest loopback address.

  • WCCP traffic redirection does not work when a zone-based policy firewall is configured on a Cisco Aggregation Services Router that is configured with Cisco AppNav I/O modules. Cisco AppNav is a wide-area networking optimization solution. For WCCP traffic redirection to work, remove the zone-based policy firewall configuration from interfaces. If you are using a WAVE device, WCCP traffic redirection works correctly.

  • Static and dynamic NAT with generic GRE and dynamic NAT with Layer 2 do not work when used with hardware-based Cisco AppNav appliances (for example, Wide Area Application Services [WAAS]).

Information About WCCP with Generic GRE Support

WCCP with Generic GRE Support

The generic routing encapsulation (GRE) negotiated return is not supported on AppNav I/O Module (IOM), the customers need to use Generic GRE tunnels (multipoint GRE [mGRE]) on devices. That is, a mGRE tunnel needs to be configured manually on the router if the AppNav is configured with Generic GRE return method.


Note


If two multipoint generic routing encapsulation (mGRE) tunnels are configured (one programmatically generated and the other manually created) on a device, and have the same key or exist in the same VRF, do one of the following:
  • Configure both tunnels with different loopback addresses.

  • Configure a physical interface on manually created tunnel, and configure a loopback address on the programmatically generated tunnel.


This feature focuses on the interactions between AppNav IOM and the router. The Cisco Wide Area Application Services (WAAS) AppNav must be configured as a device mode application-accelerator and interception method WCCP.

Cisco WAAS AppNav Solution

Cisco Wide Area Application Services (WAAS) AppNav is a hardware and software solution that simplifies network integration of WAN optimization. It also overcomes the challenges related to provisioning, visibility, scalability, asymmetry, and high availability. Only a Wide Area Virtualization Engine (WAVE) appliance that contains a Cisco AppNav Controller (ANC) Interface Module can operate as an ANC. AppNav is configured as Web Cache Communication Protocol (WCCP) client of the router.

For more information on Cisco WAAS AppNav and how to configure Cisco WAAS AppNav, see "Configuring AppNav" chapter in Cisco Wide Area Application Services Configuration Guide.

How to Configure WCCP with Generic GRE Support

Configure WCCP Redirection with Generic GRE Configured on the Device Using a Loopback Interface

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface loopback loopback-nterface-number

    4.    ip address ip-address subnet-mask

    5.    no shutdown

    6.    exit

    7.    interface loopback loopback-interface-number

    8.    ip address ip-address subnet-mask

    9.    no shutdown

    10.    exit

    11.    ip wccp source-interface loopback loopback-interface-number

    12.    interface Tunnel tunnel-interface-number

    13.    ip address ip-address subnet-mask

    14.    no shutdown

    15.    no ip redirects

    16.    ip wccp redirect exclude in

    17.    tunnel source loopback loopback-interface-number

    18.    tunnel mode gre multipoint

    19.    end

    20.    show ip wccp summary


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
    
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
    
     

    Enters global configuration mode.

     
    Step 3 interface loopback loopback-nterface-number


    Example:
    Device(config)# interface loopback 100
    
     

    Enters interface configuration for the device.

     
    Step 4 ip address ip-address subnet-mask


    Example:
    Device(config-if)# ip address 10.10.10.1 255.255.255.255
    
     

    Sets a primary IP address for the loopback interface.

     
    Step 5 no shutdown


    Example:
    Device(config-if)# no shutdown
    
     

    Restarts the loopback interface if the interface is down.

     
    Step 6 exit


    Example:
    Device(config-if)# exit
    
     

    Returns to global configuration mode.

     
    Step 7 interface loopback loopback-interface-number


    Example:
    Device(config)# interface loopback 1000
    
     

    Enters interface configuration for the device.

     
    Step 8 ip address ip-address subnet-mask


    Example:
    Device(config-if)# ip address 10.11.10.1 255.255.255.255
    
     

    Sets a primary IP address for the loopback interface.

     
    Step 9 no shutdown


    Example:
    Device(config-if)# no shutdown
    
     

    Restarts the loopback interface if the interface is down.

     
    Step 10 exit


    Example:
    Device(config-if)# exit
    
     

    Returns to global configuration mode.

     
    Step 11 ip wccp source-interface loopback loopback-interface-number


    Example:
    Device(config)# ip wccp source-interface loopback 1000
    
     

    Configures a preferred Web Cache Communication Protocol (WCCP) router ID.

     
    Step 12 interface Tunnel tunnel-interface-number


    Example:
    Device(config)# interface Tunnel 10
    
     

    Enters tunnel interface configuration mode.

     
    Step 13 ip address ip-address subnet-mask


    Example:
    Device(config-if)# ip address 10.10.20.1 255.255.255.0
    
     

    Sets a primary IP address for the tunnel interface.

     
    Step 14 no shutdown


    Example:
    Device(config-if)# no shutdown
    
     

    Restarts the tunnel interface if the interface is down.

     
    Step 15 no ip redirects


    Example:
    Device(config-if)# no ip redirects
    
     

    Disables the sending of ICMP redirect messages to learn routes. This command is enabled by default.

     
    Step 16 ip wccp redirect exclude in


    Example:
    Device(config-if)# ip wccp redirect exclude in
    
     

    Specifies that packets received on this interface be excluded from any egress redirection.

     
    Step 17 tunnel source loopback loopback-interface-number


    Example:
    Device(config-if)# tunnel source loopback 100
    
     

    Configures the loopback interface as the tunnel source.

     
    Step 18 tunnel mode gre multipoint


    Example:
    Device(config-if)# tunnel mode gre multipoint
    
     

    Sets the global encapsulation mode on all interfaces of a device to generic routing encapsulation (GRE).

     
    Step 19 end


    Example:
    Device(config-if)# end
    
     

    Returns to privileged EXEC mode.

     
    Step 20 show ip wccp summary


    Example:
    Device# show ip wccp summary
    
     

    Displays a summary of WCCP services.

     

    Configure WCCP Redirection with Generic GRE Configured on a Device Using a Physical Interface

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface GigabitEthernet interface-id

      4.    ip address ip-address subnet-mask

      5.    no shutdown

      6.    exit

      7.    interface Tunnel tunnel-interface-number

      8.    ip address ip-address subnet-mask

      9.    no shutdown

      10.    no ip redirects

      11.    ip wccp redirect exclude in

      12.    tunnel source GigabitEthernet interface-id

      13.    tunnel mode gre multipoint

      14.    end

      15.    show ip wccp summary


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
      
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
      
       

      Enters global configuration mode.

       
      Step 3 interface GigabitEthernet interface-id


      Example:
      Device(config)# interface GigabitEthernet0/0/1
      
       

      Enters interface configuration for the device.

       
      Step 4 ip address ip-address subnet-mask


      Example:
      Device(config-if)# ip address 10.10.10.1 255.255.255.0
      
       

      Sets a primary IP address for the loopback interface.

       
      Step 5 no shutdown


      Example:
      Device(config-if)# no shutdown
      
       

      Restarts the loopback interface if the interface is down.

       
      Step 6 exit


      Example:
      Device(config-if)# exit
      
       

      Returns to global configuration mode.

       
      Step 7 interface Tunnel tunnel-interface-number


      Example:
      Device(config)# interface Tunnel 10
      
       

      Enters tunnel interface configuration mode.

       
      Step 8 ip address ip-address subnet-mask


      Example:
      Device(config-if)# ip address 10.10.20.1 255.255.255.0
      
       

      Sets a primary IP address for the tunnel interface.

       
      Step 9 no shutdown


      Example:
      Device(config-if)# no shutdown
      
       

      Restarts the tunnel interface if the interface is down.

       
      Step 10 no ip redirects


      Example:
      Device(config-if)# no ip redirects
      
       

      Disables the sending of ICMP redirect messages to learn routes. This command is enabled by default.

       
      Step 11 ip wccp redirect exclude in


      Example:
      Device(config-if)# ip wccp redirect exclude in
      
       

      Specifies that packets received on this interface be excluded from any egress redirection.

       
      Step 12 tunnel source GigabitEthernet interface-id


      Example:
      Device(config-if)# tunnel source GigabitEthernet0/0/1
      
       

      Configures the loopback interface as the tunnel source.

       
      Step 13 tunnel mode gre multipoint


      Example:
      Device(config-if)# tunnel mode gre multipoint
      
       

      Sets the global encapsulation mode on all interfaces of a device to generic routing encapsulation (GRE).

       
      Step 14 end


      Example:
      Device(config-if)# end
      
       

      Returns to privileged EXEC mode.

       
      Step 15 show ip wccp summary


      Example:
      Device# show ip wccp summary
      
       

      Displays a summary of WCCP services.

       

      Configuration Examples for WCCP with Generic GRE Support

      Example: Configure WCCP Redirection with Generic GRE Configured on Device Using a Loopback Interface

      The following example shows how to configure Web Cache Communication Protocol (WCCP) redirection on the device using loopback interface when generic routing encapsulation (GRE) is enabled on the Cisco Wide Area Application Services (WAAS) AppNav:

      Device> enable
      Device# configure terminal
      Device(config)#  interface loopback 100
      Device(config-if)#  ip address 10.10.10.1 255.255.255.255
      Device(config-if)#  no shutdown
      Device(config-if)#  exit
      Device(config)#  interface loopback 1000
      Device(config-if)#  ip address 10.11.10.1 255.255.255.255
      Device(config-if)#  no shutdown
      Device(config-if)#  exit
      Device(config)#  ip wccp source-interface loopback 1000
      Device(config)#  interface Tunnel 10
      Device(config-if)#  ip address 10.12.10.1 255.255.255.0
      Device(config-if)#  no shutdown
      Device(config-if)#  no ip redirects
      Device(config-if)#  ip wccp redirect exclude in
      Device(config-if)#  tunnel source loopback 100  
      Device(config-if)#  tunnel mode gre multipoint
      Device(config-if)#  end
      Device# show ip wccp summary
      
      WCCP version 2 enabled, 2 services
      
      Service  Clients  Routers  Assign  Redirect  Bypass 
      -------  -------  -------  ------  --------  ------ 
      Default  routing  table  (Router Id: 10.10.10.1):
      61          1      1       MASK   GRE     GRE 
      62          1      1       MASK   GRE     GRE 
      
      

      Example: Configure WCCP Redirection with Generic GRE Configured on a Device Using a Physical Interface

      The following example shows how to configure Web Cache Communication Protocol (WCCP) redirection on the device using a physical interface when generic routing encapsulation (GRE) is enabled on the Cisco Wide Area Application Services (WAAS) AppNav:

      Device> enable
      Device# configure terminal
      Device(config)#  interface GigabitEthernet0/0/1
      Device(config-if)# ip address 10.12.10.1 255.255.255.0
      Device(config-if)# no shutdown
      Device(config-if)# exit
      Device(config)# interface Tunnel 10
      Device(config-if)# ip address 10.13.10.1 255.255.255.0
      Device(config-if)# no ip redirects
      Device(config-if)# ip wccp redirect exclude in
      Device(config-if)# tunnel source GigabitEthernet0/0/1
      Device(config-if)# tunnel mode gre multipoint
      Device(config-if)# end
      Device# show ip wccp summary
      
      WCCP version 2 enabled, 2 services
      
      Service  Clients  Routers  Assign  Redirect  Bypass 
      -------  -------  -------  ------  --------  ------ 
      Default  routing  table   (Router Id: 10.10.10.1):
      61          1      1       MASK      GRE     GRE 
      62          1      1       MASK      GRE     GRE 
      
      

      Additional References for WCCP with Generic GRE Support

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Cisco IOS Master Commands List, All Releases

      IP addressing and services commands and configuration tasks

      WCCP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Application Services Command Reference

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for WCCP with Generic GRE Support

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to . An account on Cisco.com is not required.
      Table 1 Feature Information for WCCP with Generic GRE Support

      Feature Name

      Releases

      Feature Information

      WCCP with Generic GRE Support

      Cisco IOS XE Release 3.10.2

      This feature provides extended WCCP support to use Generic GRE tunnels (multipoint GRE) on the devices when generic routing encapsulation (GRE) negotiated return is not supported on AppNav I/O Module (IOM).

      Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/​go/​trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)