Step 1 |
show
call
fallback
cache
Use this command to display the current ICPIF estimates for all IP addresses in the cache.
|
Step 2 |
show
call
fallback
config
Use this command to display the call fallback configuration.
|
Step 3 |
show
call
fallback
stats
Use this command to display call fallback statistics.
|
Step 4 |
show
call
rsvp-sync
conf
Use this command to display the configuration settings for RSVP synchronization.
|
Step 5 |
show
call
rsvp-sync
stats
Use this command to display statistics for calls that attempted RSVP reservation.
Router# show call rsvp-sync
conf Show RSVP/Voice Synchronization Config. information
state Show RSVP/Voice Statistics
The following sample output also shows configuration settings for RSVP synchronization. Of particular note in the example
are the following:
Router# show call rsvp-sync conf
VoIP QoS:RSVP/Voice Signaling Synchronization config:
Overture Synchronization is ON
Reservation Timer is set to 10 seconds
The following sample output shows configuration settings for RSVP synchronization. Of particular note in the example are the
following:
-
Number of calls for which QoS was initiated--Number of calls for which RSVP setup was attempted.
-
Number of calls for which QoS was torn down--Number of calls for which an established RSVP reservation was released.
-
Number of calls for which Reservation Success was notified--Number of calls for which an RSVP reservation was successfully
established.
-
Total Number of PATH Errors encountered--Number of path errors that occurred.
-
Total Number of RESV Errors encountered--Number of reservation errors that occurred.
-
Total Number of Reservation Timeouts encountered--Number of calls in which the reservation setup was not complete before the
reservation timer expires.
Router# show call rsvp-sync stats
VoIP QoS:Statistics Information:
Number of calls for which QoS was initiated : 0
Number of calls for which QoS was torn down : 0
Number of calls for which Reservation Success was notified : 0
Total Number of PATH Errors encountered : 0
Total Number of RESV Errors encountered : 0
Total Number of Reservation Timeouts encountered : 0
|
Step 6 |
show
dial-peer
voice
Use this command to display detailed information for a specific voice dial peer.
Router# show dial-peer voice 5
VoiceOverIpPeer5
information type = voice,
tag = 5, destination-pattern = `5550100',
answer-address = `', preference=0,
numbering Type = `unknown'
group = 5, Admin state is up, Operation state is up,
incoming called-number = `', connections/maximum = 0/unlimited,
DTMF Relay = disabled,
modem passthrough = system,
huntstop = disabled,
in bound application associated:session
out bound application associated
dnis-map =
permission :both
incoming COR list:maximum capability
outgoing COR list:minimum requirement
type = voip, session-target = `ipv4:172.18.192.218',
technology prefix:
settle-call = disabled
ip media DSCP = default, ip signaling DSCP = default, UDP checksum = disabled,
session-protocol = sipv2, session-transport = system, req-qos = best-effort,
acc-qos = best-effort,
fax rate = voice, payload size = 20 bytes
fax protocol = system
fax NSF = 0xAD0051 (default)
codec = g711ulaw, payload size = 160 bytes,
Expect factor = 0, Icpif = 20,
Playout Mode is set to default,
Initial 60 ms, Max 300 ms
Playout-delay Minimum mode is set to default, value 40 ms
Expect factor = 0,
Max Redirects = 1, Icpif = 20,signaling-type = cas,
CLID Restrict = disabled
VAD = enabled, Poor QOV Trap = disabled,
voice class sip url = system,
voice class sip rel1xx = system,
voice class perm tag = `'
Connect Time = 0, Charged Units = 0,
Successful Calls = 0, Failed Calls = 0, Incomplete Calls = 0
Accepted Calls = 0, Refused Calls = 0,
Last Disconnect Cause is "",
Last Disconnect Text is "",
Last Setup Time = 0.
|
Step 7 |
show
ip
rsvp
reservation
Use this command to display RSVP-related receiver information currently in the database.
The following sample output shows, in the “To” field, the IP address of the receiver.
Router # show ip rsvp reservation
To From Pro DPort Sport Next Hop I/F Fi Serv BPS Bytes
172.18.193.101 172.18.193.102 UDP 20532 20600 FF LOAD 24K 120
172.18.193.102 172.18.193.101 UDP 20600 20532 172.18.193.102 Et0/0 FF LOAD 24K 120
|
Step 8 |
show
running-conf
Use this command to display the contents of the currently running configuration file, the configuration for a specific interface,
or map class information. Use it to display SIP user-agent statistics, including reliable provisional response information.
Use it also to display configuration for the Cisco IOS VoiceXML feature.
The following sample output shows SIP user-agent statistics, including reliable provisional response information. In the following
partial output, a dynamic payload value of 115 is configured, freeing up the reserved value of 101.
Router# show running-config
Building configuration...
Current configuration: 2024 bytes
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname r4
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
ipx routing 0000.0000.0004
no voice hpi capture buffer
no voice hpi capture destination
fax interface-type fax-mail
mta receive maximum-recipients 0
interface Loopback0
ip address 10.0.0.0 255.255.255.0
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
speed 100
full-duplex
interface Serial0/0
ip address 10.0.0.4 255.255.255.0
encapsulation frame-relay
.
.
.
call rsvp-sync
voice-port 3/0/0
voice-port 3/0/1
mgcp ip qos dscp cs5 media
mgcp ip qos dscp cs3 signaling
no mgcp timer receive-rtcp
mgcp profile default
dial-peer cor custom
dial-peer voice 1234 voip
rtp payload-type nte 115
alias exec co config t
alias exec br show ip int brief
alias exec i show ip route
alias exec sr show run
alias exec sri sh run interface
alias exec sio show ip ospf
alias exec sioi show ip ospf int
alias exec sion show ip ospf nei
alias exec cir clear ip route *
alias exec ix show ipx route
alias exec b show ip bgp
alias exec sis show isdn status
alias exec fm show frame map
alias exec dm show dialer map
line con 0
exec-timeout 0 0
privilege level 15
password password1
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password password1
logging synchronous
no login
end
The following sample output shows configuration for the Cisco IOS VoiceXML feature. If the SIP hold timer is enabled, which is the default setting, and the timer is set to the default value of 2880
minutes, command output does not display the timers hold 2880 command. In the following partial output, the hold timer is set to a nondefault value of 18 minutes.
Router# show running-config
Building configuration...
Current configuration :2791 bytes
.
.
.
sip-ua
max-forwards 10
retry invite 1
retry response 4
retry bye 1
retry cancel 1
timers expires 300000
timers hold 18
.
.
.
end!
|
Step 9 |
show
sip-ua
retry
Use this command to display SIP retry statistics.
Router# show sip-ua retry
SIP UA Retry Values
invite retry count = 10 response retry count = 1
bye retry count = 1 cancel retry count = 8
prack retry count = 10 comet retry count = 10
reliable 1xx count = 6
|
Step 10 |
show
sip-ua
statistics
Use this command to display response, traffic, and retry SIP statistics.
Note
|
When 0/0 is included in a field, the first number is an inbound count and the last number is an outbound count.
|
Router# show sip-ua statistics
SIP Response Statistics (Inbound/Outbound)
Informational:
Trying 15/9, Ringing 9/0,
Forwarded 0/0, Queued 0/0,
SessionProgress 36/9
Success:
OkInvite 6/4, OkBye 5/5,
OkCancel 5/5, OkOptions 0/0,
OkPrack 29/8, OkPreconditionMet 11/0
Redirection (Inbound only):
MultipleChoice 0, MovedPermanently 0,
MovedTemporarily 0, SeeOther 0,
UseProxy 0, AlternateService 0
Client Error:
BadRequest 0/0, Unauthorized 0/0,
PaymentRequired 0/0, Forbidden 0/0,
NotFound 0/0, MethodNotAllowed 0/0,
NotAcceptable 0/0, ProxyAuthReqd 0/0,
ReqTimeout 0/0, Conflict 0/0, Gone 0/0,
LengthRequired 0/0, ReqEntityTooLarge 0/0,
ReqURITooLarge 0/0, UnsupportedMediaType 0/0,
BadExtension 0/0, TempNotAvailable 0/0,
CallLegNonExistent 0/0, LoopDetected 0/0,
TooManyHops 0/0, AddrIncomplete 0/0,
Ambiguous 0/0, BusyHere 0/0,
RequestCancel 0/0, NotAcceptableMedia 0/0
Server Error:
InternalError 0/0, NotImplemented 0/0,
BadGateway 0/0, ServiceUnavail 0/0,
GatewayTimeout 0/0, BadSipVer 0/0,
PreCondFailure 0/0
Global Failure:
BusyEverywhere 0/0, Decline 0/0,
NotExistAnywhere 0/0, NotAcceptable 0/0
SIP Total Traffic Statistics (Inbound/Outbound)
Invite 9/16, Ack 4/6, Bye 5/5,
Cancel 5/9, Options 0/0,
Prack 8/43, Comet 0/11
Retry Statistics
Invite 5, Bye 0, Cancel 4, Response 0,
Prack 13, Comet 0, Reliable1xx 0
|
Step 11 |
show
sip-ua
status
Use this command to display SIP user-agent status.
Router# show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
SIP max-forwards : 6
SIP DNS SRV version: 1 (rfc 2052)
|
Step 12 |
show
sip-ua
timers
Use this command to display SIP user-agent timer settings.
Router# show sip-ua timers
SIP UA Timer Values (millisecs unless noted)
trying 500, expires 150000, connect 500, disconnect 500
comet 500, prack 500, rel1xx 500, notify 500, hold 2880 minutes
|
Step 13 |
test
call
fallback
probe
ip-address
codec
Use this command to test a probe to a specific IP address and display ICPIF RTR values. Keywords and arguments are as follows:
|