- Preface
- Cisco ONS Documentation Roadmap for Release 9.2.1
- Chapter 1, CE-Series Ethernet Cards
- Chapter 2, E-Series and G-Series Ethernet Cards
-
- Chapter 3, ML-Series Cards Overview
- Chapter 4, CTC Operations
- Chapter 5, Initial Configuration
- Chapter 6, Configuring Interfaces
- Chapter 7, Configuring CDP
- Chapter 8, Configuring POS
- Chapter 9, Configuring Bridges
- Chapter 10, Configuring IEEE 802.1Q Tunneling and Layer 2 Protocol Tunneling
- Chapter 11, Configuring STP and RSTP
- Chapter 12, Configuring Link Aggregation
- Chapter 13, Configuring Security for the ML-Series Card
- Chapter 14, Configuring RMON
- Chapter 15, Configuring SNMP
- Chapter 16, Configuring VLAN
- Chapter 17, Configuring Networking Protocols
- Chapter 18, Configuring IRB
- Chapter 19, Configuring IEEE 802.17b Resilient Packet Ring
- Chapter 20, Configuring VRF Lite
- Chapter 21, Configuring Quality of Service
- Chapter 22, Configuring Ethernet over MPLS
- Chapter 23, Configuring the Switching Database Manager
- Chapter 24, Configuring Access Control Lists
- Chapter 25, Configuring Cisco Proprietary Resilient Packet Ring
-
- Chapter 26, ML-MR-10 Card Overview
- Chapter 27, IP Host Functionality on the ML-MR-10 Card
- Chapter 29: Configuring Security for the ML-MR-10 Card
- Chapter 30: Configuring IEEE 802.17b Resilient Packet Ring on the ML-MR-10 Card
- Chapter 31, Configuring POS on the ML-MR-10 Card
- Chapter 32, Configuring Card Port Protection on the ML-MR-10 Card
- Chapter 32, Configuring Ethernet Virtual Circuits and QoS on the ML-MR-10 Card
- Chapter 34: Configuring Link Agrregation on ML-MR-10 card
- Chapter 35, Configuring Ethernet OAM (IEEE 802.3ah), CFM (IEEE 802.1ag), and E-LMI on the ML-MR-10 Card
- Appendix A: CPU and Memory Utilization on the ML-MR-10 Card
- Appendix A, POS on ONS Ethernet Cards
- Appendix B, Command Reference
- Appendix C, Unsupported CLI Commands
- Appendix D, Using Technical Support
Configuring VRF Lite
Note This chapter applies only to the ML-Series (ML100T-2, ML100X-8, and ML1000-2) cards.
This chapter describes how to configure VPN Routing and Forwarding Lite (VRF Lite) for the ML-Series cards. For additional information about the Cisco IOS commands used in this chapter, refer to the Cisco IOS Command Reference publication. This chapter contains the following major sections:
•VRF Lite Configuration Example
•Monitoring and Verifying VRF Lite
Note If you have already configured bridging, you may now proceed with configuring VRF Lite as an optional step.
Understanding VRF Lite
VRF is an extension of IP routing that provides multiple routing instances. It provides a separate IP routing and forwarding table to each VPN and is used in concert with MP-iBGP (Multi-Protocol internal BGP) between provider equipment (PE) routers to provide Layer 3 MPLS-VPN. However, ML-Series VRF implementation is without MP-iBGP. With VRF Lite, the ML Series card is considered a PE-extension or a customer equipment (CE)-extension. VRF Lite is considered a PE-extension since its has VRF (but without MP-iBGP), and it is considered a CE-extension since this CE can have multiple VRFs and serves many customer with one CE box.
Under VRF Lite, an ML-Series CE can have multiple interfaces/subinterfaces with PE for different customers (while a normal CE is only for one customer). It holds VRFs (routing information) locally and it does not distribute the VRFs to its connected PE. It uses VRF information to direct traffic to the correct interfaces/subinterfaces when it receives traffic from customers' routers or from Internet service provider (ISP) PE router(s).
Configuring VRF Lite
Perform the following procedure to configure VRF Lite:
Example 20-1 shows an example of configuring a VRF. In the example, the VRF name is customer_a, the route-distinguisher is 1:1, and the interface type is Fast Ethernet, number 0.1.
Example 20-1 Configuring a VRF
Router(config)# ip vrf customer_a
Router(config-vrf)# rd 1:1
Router(config-vrf)# route-target both 1:1
Router(config)# interface fastEthernet 0.1
Router(config-subif)# ip vrf forwarding customer_a
VRF Lite Configuration Example
Figure 20-1 shows an example of a VRF Lite configuration. The configurations for Router A and Router B are provided in Example 20-2 and Example 20-3, respectively. The associated routing tables are shown in Example 20-4 through Example 20-9.
Figure 20-1 VRF Lite—Sample Network Scenario
Example 20-2 Router A Configuration
hostname Router_A
!
ip vrf customer_a
rd 1:1
route-target export 1:1
route-target import 1:1
!
ip vrf customer_b
rd 2:2
route-target export 2:2
route-target import 2:2
!
bridge 1 protocol ieee
bridge 2 protocol ieee
bridge 3 protocol ieee
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet0.1
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.1.1 255.255.255.0
bridge-group 2
!
interface FastEthernet1
no ip address
!
interface FastEthernet1.1
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.2.1 255.255.255.0
bridge-group 3
!
interface POS0
no ip address
crc 32
no cdp enable
pos flag c2 1
!
interface POS0.1
encapsulation dot1Q 1 native
ip address 192.168.50.1 255.255.255.0
bridge-group 1
!
interface POS0.2
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.100.1 255.255.255.0
bridge-group 2
!
interface POS0.3
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.200.1 255.255.255.0
bridge-group 3
!
router ospf 1
log-adjacency-changes
network 192.168.50.0 0.0.0.255 area 0
!
router ospf 2 vrf customer_a
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
router ospf 3 vrf customer_b
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.255 area 0
!
Example 20-3 Router_B Configuration
hostname Router_B
!
ip vrf customer_a
rd 1:1
route-target export 1:1
route-target import 1:1
!
ip vrf customer_b
rd 2:2
route-target export 2:2
route-target import 2:2
!
bridge 1 protocol ieee
bridge 2 protocol ieee
bridge 3 protocol ieee
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet0.1
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.4.1 255.255.255.0
bridge-group 2
!
interface FastEthernet1
no ip address
!
interface FastEthernet1.1
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.5.1 255.255.255.0
bridge-group 3
!
interface POS0
no ip address
crc 32
no cdp enable
pos flag c2 1
!
interface POS0.1
encapsulation dot1Q 1 native
ip address 192.168.50.2 255.255.255.0
bridge-group 1
!
interface POS0.2
encapsulation dot1Q 2
ip vrf forwarding customer_a
ip address 192.168.100.2 255.255.255.0
bridge-group 2
!
interface POS0.3
encapsulation dot1Q 3
ip vrf forwarding customer_b
ip address 192.168.200.2 255.255.255.0
bridge-group 3
!
router ospf 1
log-adjacency-changes
network 192.168.50.0 0.0.0.255 area 0
!
router ospf 2 vrf customer_a
log-adjacency-changes
network 192.168.4.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
!
router ospf 3 vrf customer_b
log-adjacency-changes
network 192.168.5.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.255 area 0
!
Example 20-4 Router_A Global Routing Table
Router_A# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.50.0/24 is directly connected, POS0.1
Example 20-5 Router_A customer_a VRF Routing Table
Router_A# show ip route vrf customer_a
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
O 192.168.4.0/24 [110/2] via 192.168.100.2, 00:15:35, POS0.2
C 192.168.1.0/24 is directly connected, FastEthernet0.1
C 192.168.100.0/24 is directly connected, POS0.2
Example 20-6 Router_A customer_b VRF Routing Table
Router_A# show ip route vrf customer_b
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.200.0/24 is directly connected, POS0.3
O 192.168.5.0/24 [110/2] via 192.168.200.2, 00:10:32, POS0.3
C 192.168.2.0/24 is directly connected, FastEthernet1.1
Example 20-7 Router_B Global Routing Table
Router_B# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.50.0/24 is directly connected, POS0.1
Example 20-8 Router_B customer_a VRF Routing Table
Router_B# sh ip route vrf customer_a
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.4.0/24 is directly connected, FastEthernet0.1
O 192.168.1.0/24 [110/2] via 192.168.100.1, 00:56:24, POS0.2
C 192.168.100.0/24 is directly connected, POS0.2
Example 20-9 Router_B customer_b VRF Routing Table
Router_B# show ip route vrf customer_b
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.200.0/24 is directly connected, POS0.3
C 192.168.5.0/24 is directly connected, FastEthernet1.1
O 192.168.2.0/24 [110/2] via 192.168.200.1, 00:10:51, POS0.3
Monitoring and Verifying VRF Lite
Table 20-1 shows the privileged EXEC commands for monitoring and verifying VRF Lite.