Configuring Virtual-LPWA

This chapter describes the details of configuring virtual-LPWA (VLPWA) interface on the IR807 series for the configuration of the Cisco LoRaWAN Gateway.

Configuring Virtual-LPWA

This chapter describes the details of configuring virtual-LPWA (VLPWA) interface on the IR807 series for the configuration of the Cisco LoRaWAN Gateway.

This chapter contains the following sections:

Configuring Virtual-LPWA Interface on the IR807 Series

The Cisco LoRaWAN Gateway is connected to IR807 series via an Ethernet cable with PoE+ to work as a LoRaWAN gateway. By creating a VLPWA interface on the IR807 series, you can:

  • Manage hardware and software of the Cisco LoRaWAN Gateway.
  • Send and receive VLPWA protocol modem message to monitor the status of the Cisco LoRaWAN Gateway.
  • Send SNMP traps to the IoT Field Network Director (IoT FND).

Note : You need to install the Actility Thingpark LRR software as the LoRa forwarder firmware, which is loaded through the Cisco IOS software, for the Cisco LoRaWAN Gateway to work.

Note : Refer to the LoRa Alliance LoRaWAN 1.0 specifications for more information.

You can find other documentation for the Cisco LoRaWAN Gateway at: http://www.cisco.com/c/en/us/support/routers/interface-module-lorawan/tsd-products-support-series-home.html

Configuring Ethernet Interface and Creating VLPWA Interface

When you configure IP address for the Ethernet interface or Vlan interface, the IP address allocated must be aligned with the prefix configured for the DHCP pool allocated to the LoRaWAN interface.

The Cisco LoRaWAN Gateway communicates through IOS, therefore a private IPv4 address is assigned with NAT being configured.

Configuring IR807 for One Cisco LoRaWAN Gateway

Beginning in privileged EXEC mode, follow these steps to configure the Ethernet interface on IR807 and create the VLPWA interface for one Cisco LoRaWAN Gateway.

Step

Command

Purpose

1

configure terminal

Enters global configuration mode.

2

interface FastEthernet ID

Configures the Fast Ethernet (FE) port.

3

ip address address mask

Configures the GE interface IP address.

Note : The IP address should be the default router address in its associated DHCP pool.

4

ip nat inside

Identifies the interface as the NAT inside interface.

5

ip virtual-reassembly in

Enables virtual fragment reassembly (VFR) on the interface.

6

exit

Exits to global configuration mode.

7

interface Virtual-LPWA vlpwa-id

Creates VLPWA interface.

Note : The value of vlpwa-id should be the same as the option 43 hex number which is specified in DHCP pool.

8

end

Exits to privileged EXEC mode.

9

write memory

Saves the configurations.

Configuring IR807 for Multiple Cisco LoRaWAN Gateways

Beginning in privileged EXEC mode, follow these steps to configure the Ethernet interface on IR807 and create the VLPWA interface for multiple Cisco LoRaWAN Gateways.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface FastEthernet ID

Configures the Fast Ethernet (FE) port.

3

no shutdown

Enables the interface.

4

exit

Exits to privileged EXEC mode.

5

interface FastEthernet ID.subID

Configures sub-interface on the FE port.

6

encapsulation dot1Q vlpwa-id native

Configures IEEE802.1Q encapsulation of traffic on a interface.

7

ip address address mask

Configures the FE interface IP address.

Note : The IP address should be the default router address in its associated DHCP pool.

8

ip nat inside

Identifies the interface as the NAT inside interface.

9

ip virtual-reassembly in

Enables virtual fragment reassembly (VFR) on the interface.

10

exit

Exits to global configuration mode.

11

interface Virtual-LPWA vlpwa-id

Creates VLPWA interface.

Note : The value of vlpwa-id should be the same as the option 43 hex number which is specified in DHCP pool.

12

end

Exits to privileged EXEC mode.

13

write memory

Saves the configurations.

Configuring DHCP Pool for the Cisco LoRaWAN Gateway

The Cisco LoRaWAN Gateway connects to the IR807 series through the Ethernet interface. The communication between Cisco LoRaWAN Gateway firmware and IOS are conducted over IP. Therefore, an IP address must be assigned to the Cisco LoRaWAN Gateway through an IOS local DHCP server pool.

If you connect multiple Cisco LoRaWAN Gateways to a single IR807 router, each interface must have its own DHCP pool.

On the IR807 series, beginning in privileged EXEC mode, follow these steps to configure DHCP pool.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

ip dhcp pool pool-name

Creates a DHCP server address pool and enters DHCP pool configuration mode.

Note : If you have changed the parameters of the DHCP server, you must perform a refresh using the no service dhcp interface-type number command and service dhcp interface-type number command.

3

network network-number mask

Specifies the subnet network number and mask of the DHCP address pool. Make sure to allow only one dhcp address releasable to modem.

4

default-router address

Specifies the IP address of the default router for a DHCP client. The default router address will be assigned to the associated VLAN interface afterwards.

5

option 43 hex client-ID

Enables vendor specific option 43 and assign the associated Cisco LoRaWAN Gateway client ID number as the hex value.

6

dns-server address

Defines DNS services.

7

exit

Exits to global configuration mode.

8

ip dhcp excluded-address address

Masks all redundant addresses including the default router in DHCP pool.

9

end

Exits to privileged EXEC mode.

10

write memory

Saves the configurations.

Examples

The following is an example of configuring DHCP pool on IR807:


IR807#configure terminal
IR807(config)#ip dhcp pool modempool
IR807(dhcp-config)#network 192.168.1.0 255.255.255.248
IR807(dhcp-config)#default-router 192.168.1.1
IR807(dhcp-config)#option 43 hex 01
IR807(dhcp-config)#dns-server 192.168.1.1
IR807(dhcp-config)#exit
IR807(config)#
IR807(config)#ip dhcp excluded-address 192.168.1.1
IR807(config)#ip dhcp excluded-address 192.168.1.3 192.168.1.6
IR807(config)#exit
IR807#

The following is an example on IR807 using the sub-interface method:


ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.3 192.168.1.6
!
ip dhcp pool modempool1
 network 192.168.1.0 255.255.255.248
 default-router 192.168.1.1 
 option 43 hex 01
!
interface Virtual-LPWA1
!
interface FastEthernet1.101
 encapsulation dot1Q 101 native
 ip address 192.168.1.1 255.255.255.248
 ip nat inside
 ip virtual-reassembly in
!
end

The following is an example on IR807 using the VLAN method:


ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.3 192.168.1.6
!
ip dhcp pool modempool1
 network 192.168.1.0 255.255.255.248
 default-router 192.168.1.1 
 option 43 hex 01
!
interface Virtual-LPWA1
!
interface FastEthernet1
 switchport access vlan 101
!
interface Vlan101
 ip address 192.168.1.1 255.255.255.248
!
end

Configuring SNMP TRAP for Modem Notifications

On the IR807 series, beginning in privileged EXEC mode, follow these steps to enable SNMP TRAP notifications for virtual-lpwa interface and its associated Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

snmp-server enable traps vlpwa

Enables virtual LPWA traps to monitor modem status changing.

3

snmp-server enable traps snmp linkup linkdown

Enables linkUp and linkDown traps to monitor modem heartbeat event.

4

end

Exits to privileged EXEC mode.

5

write memory

Saves the configurations.

The Modem feature status notifications and OIDs are listed in the following table:

Notification

OID

modem door open/close

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 1 };

modem exceeds maximum temperature threshold

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 2 };

modem temperature returns to normal from overheat

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 3 };

modem falls below minimum temperature threshold

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 4 };

modem temperature returns to normal from undercooling

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 5 };

modem FPGA upgrade starts

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 6 };

modem exceeds maximum CPU threshold

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 7};

modem CPU usage returns to normal

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 8 };

modem exceeds maximum memory threshold

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 9};

modem memory usage returns to normal

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 10 };

modem exceeds maximum storage threshold

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 11};

modem storage usage returns to normal

{ 1, 3, 6, 1, 4, 1, 9, 9, 830, 0, 12 };

When the SNMP linkUp and linkDown traps are enabled, the modem device status could be monitored. The modem device status notifications are listed below:

modem power on/off

interface FastEthernet_ID linkUp/linkDown

modem agent heartbeat

interface virtual-lpwa_ID linkUp/linkDown

Configuring VLPWA Interface and Associated Cisco LoRaWAN Gateway

On the IR807 series, beginning in privileged EXEC mode, follow these steps to configure one or multiple VLPWA interfaces and associated Cisco LoRaWAN Gateways.

Note : The following set-up refers to the Thingpark LoRa Forwarder software. When configuring the virtual-lpwa interface with other 3rd party network server, refer to the 3rd party vendor documentation.

Configuring IR807 for One Cisco LoRaWAN Gateway

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem environment var1 [var2 ]

Specify the environment variables as the configuration for the LoRaWAN modem.

Note : There are one or two environment variables to be configured.

4

lpwa packet-forwarder firmware [flash: | nvram: ] firmware-name auto-install [if-not-installed | unconditional ]

Configures the packet-forwarder firmware (only Actility LRR is supported) which will be installed on the LoRaWAN modem from the IR807 series.

For the values of auto-install method:

  • if-not-installed —Automatically install if there is no firmware already installed on modem.
  • unconditional —Automatically install this firmware unconditionally.

5

lpwa packet-forwarder public-key [flash: | nvram: ] public-key file

Configures the packet-forwarder public-key which will be installed on the LoRaWAN modem from the IR807 series.

6

end

Exits to privileged EXEC mode.

7

write memory

Saves the configurations.

Examples

The following is an example of configuring VLPWA interface on IR807:


interface Virtual-LPWA1
no ip address
lpwa packet-forwarder public-key flash:lrr-opk.pubkey
lpwa modem environment PKTFWD_ROOT /tmp/mdm/pktfwd/firmware
lpwa modem environment LXC_STORE_PATH /tmp/mdm/pktfwd/firmware/usr/etc/lrr
lpwa modem password root $1$0822455D0A16
lpwa modem ntp server ip fr.pool.ntp.org
lpwa modem timezone Europe/Paris

Configuring Cisco LoRaWAN Gateway Password

On the IR807 series, beginning in privileged EXEC mode, follow these steps to configure password for the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem password var1 [var2 ]

Specifies the password variables as the configuration for the LoRaWAN modem. The default account is root .

Note : There are one or two environment variables to be configured. But currently only the root account is supported.

4

lpwa modem password root [var2 ]

Configures the password of the root account for LoRaWAN modem. The default password is NULL.

The unencrypted (clear text) secret has the minimum length of 4 characters, and the maximum length of 25 characters.

5

end

Exits to privileged EXEC mode.

6

write memory

Saves the configurations.

Configuring Clock for the Cisco LoRaWAN Gateway

The modem clock can use either NTP or the GPS as its source. The default source is NTP.

Configuring NTP Server for the Cisco LoRaWAN Gateway

On the IR807 series, beginning in privileged EXEC mode, follow these steps to configure the NTP server for the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem ntp server ip [var1 ]

Specifies the NTP server variables as the configuration for the LoRaWAN modem. For the hostname of peer, refer to www.pool.ntp.org .

Example:


lpwa modem ntp server ip 0.asia.pool.ntp.org

4

lpwa modem ntp server address [var2 ]

Configures the IP address of peer.

Example:


lpwa modem ntp server address 192.168.1.1

5

end

Exits to privileged EXEC mode.

6

write memory

Saves the configurations.

Configuring Cisco LoRaWAN Gateway Timezone

On the IR807 series, beginning in privileged EXEC mode, follow these steps to configure timezone for the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem timezone [timezone ]

Specifies the timezone variables as the configuration for the LoRaWAN modem. The value is based on the IANA Timezone database. Please check the /usr/share/zoneinfo/ folder in your PC host.

timezone —Name of time zone, for example, Asia/Shanghai.

Example:


lpwa modem timezone Asia/Shanghai

4

end

Exits to privileged EXEC mode.

5

write memory

Saves the configurations.

Configuring IPSec on the Cisco LoRaWAN Gateway

In virtual-lpwa mode, IPsec is set to protect the communications between the LoRaWAN gateway and the IR800 router.

On the IR800 series, beginning in privileged EXEC mode, follow these steps to configure IPSec for the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem ipsec enable

Enables IPSec. By default, IPSec is disabled.

4

lpwa modem isakmp <xauth-user> <xauth-pw> <peer-ip> group <name> <psk-key> <lifetime>

Specifies the XAUTH credential’s username, password, and the IP address of the right participant’s interface. Matches this information to the IKEID group with group name, pre-shared key for remote peer, and lifetime in seconds.

5

end

Exits to privileged EXEC mode.

6

write memory

Saves the configurations.

Note : Only PSK (IKEv1) and RSA (IKEv2) are supported.

Configuring SCEP on the Cisco LoRaWAN Gateway

On the IR807 series, beginning in privileged EXEC mode, use these commands to configure Simple Certificate Enrollment Protocol (SCEP) on the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

Configure SCEP by using a configuration file or profile method. Choose one of the following:

  • lpwa modem scep [{flash:|nvram: } <SCEP_Configuration_File> ]
  • lpwa modem scep [profile]

To configure by file, enter the SCEP configuration file. This file must be provided with the following formatted:


url <SCEP server URL used for enrollment>
country <2 letter country name>
province <Province/State>
locality <Location>
organization <Organization>
unit <Organization Unit>
common-name <Common Name>
type <SCEP server type: NDES>
persistent <Store certificates in modem; default is false>
key-length <Length of keys; 1024, 2048 (default) or 4096>

Example:

lpwa modem scep flash:scep_conf

SCEP Configuration File Example:


url http://172.19.234.54:80/certsrv/mscep/mscep.dll
country CN
province Nanning
locality Nanning
organization Cisco
unit iot
common-name cisco-iot
type ndes
persistent false
key-length 1024

To configure the parameters individually, use the profile methord.


IR807(config-if)#lpwa modem scep profile
IR807(config-if-vlpwa-scep)#?
Enter parameters for scep. country, locality, name, org, province, 
unit & url must all be present.
 country       Country server located in
 default       Set a command to its defaults
 exit          Exit from if-vlpwa-scep sub mode
 keylen        Specify key length 1024, 2048 or 4096
 locality      Locality of server
 name          Name of the certificate
 no            Negate a command or set its defaults
 organization  Organization of the server
 persistent    Specify persistency of the key
 province      State or Province
 type          Specify type
 unit          Business unit within server 
               organization
 url           Specify url

Note : In either file or profile method, “ndes” is the default and only supported SCEP type. However, you can enter SCEP type as xpki in either method. This option may or may not work. It has not been tested and will not be officially supported until a future re

4

end

Exits to privileged EXEC mode.

5

write memory

Saves the configurations.

Note : Only PSK (IKEv1) and RSA (IKEv2) are supported.

Note : Without SCEP, the IPSec is done with pre-shared key. With SCEP, IPSec is done with RSA or certificates.

Configuring Security Protection

On the IR807 series, beginning in privileged EXEC mode, use these commands to configure security protection for the Cisco LoRaWAN Gateway.

Step

Command or Action

Purpose

1

configure terminal

Enters global configuration mode.

2

interface Virtual-LPWA vlpwa-id

Enters the vlpwa interface which is to be configured.

3

lpwa modem authentication mandatory enable

Enables mandatory security level in modem, which is disabled by default. When enabled, IR807 will shut down corresponding vlan or subinterface for ACT2 authentication failure or version mismatch to prevent further attacking. When disabled, IR807 will only send notifications to IoT FND when the same situations happen, without shutting down vlan or subinterface.

4

lpwa modem authentication timeout <subinterface/vlan name > <subinterface/vlan number > time <time >

Specifies a timeout protection for a suspended vlpwa interface (one with no traffic up from corresponding vlan or subinterface). You need to set the subinterface or vlan manually with a time (in minute) threshold. If the mandatory security level is also enabled, the corresponding vlan or subinterface will be shut down after the time threshold. If the mandatory security level is disabled, only a notification will be sent to IoT FND.

5

end

Exits to privileged EXEC mode.

6

write memory

Saves the configurations.

Managing the Cisco LoRaWAN Gateway

Note: virtual-lpwa vlpwa-id packet-forwarder install and uninstall are not supported.

On the IR807 series, beginning in privileged EXEC mode, use these commands to manage the Cisco LoRaWAN Gateway.

Command

Purpose

virtual-lpwa vlpwa-id [modem | packet-forwarder ]

Management for the LoRaWAN modem virtual-LPWA interface:

  • modem —Manage the modem clock.
  • packet-forwarder —Manage the packet forwarder.

virtual-lpwa vlpwa-id modem [cacert | clock | delete | install | reboot | upload ]

Management for the LoRaWAN modem:

  • cacert —Clean the certificates stored in the modem.
  • clock —Manage the modem clock.
  • delete —Delete uploaded file(s) on the modem.
  • install —Install the modem firmware.
  • reboot —Reboot the modem hardware.
  • upload —Upload a file to the modem.

virtual-lpwa vlpwa-id packet-forwarder [restart | start | stop ]

Management for the LoRaWAN modem packet-forwarder:

  • restart —Restart packet-forwarder.
  • start —Start packet-forwarder.
  • stop —Stop packet-forwarder.

virtual-lpwa vlpwa-id modem clock set hh:mm:ss {dd Mon yyyy}

Management the clock for the LoRaWAN modem:

hh:mm:ss: —Current time.

dd Mon yyyy —Day, month, and year.

Example:


modem clock set 20:30:30 31 Mar 2016

Examples

The following is an example of setting the clock for the Cisco LoRaWAN Gateway:


IR807#virtual-lpwa 10 modem clock set 12:02:40 15 Apr 2016
Name: Virtual-LPWA 10

The following is an example of rebooting the Cisco LoRaWAN Gateway:


IR807#virtual-lpwa 10 modem reboot
Name: Virtual-LPWA 10 
Modem reboot initiated.

The following is an example of restarting packet-forwarder:


IR807#virtual-lpwa 10 packet-forwarder restart
Name: Virtual-LPWA 10 
Restarted

LoRaWAN Modem Firmware Upgrade

There are three methods to upgrade the LoRaWAN modem firmware image:

  • Normal—It takes over 5 minutes to install the image.
  • TFTP server—It takes over 3 minutes to install the image.
  • External TFTP server—It takes more time than the other two methods, considering the unexpected network accessibility of a user-customized TFTP server.

Use the virtual-lpwa 1 modem install firmware command to upgrade the Cisco LoRaWAN Gateway firmware. The following upgrade options are available:

  • external-tftp-factory—Install the firmware from external tftp and wipe user data on the LoRaWAN modem.
  • external-tftp-normal—Install the firmware from external tftp and keep user data on the LoRaWAN modem.
  • factory—Install the firmware and wipe the user data on the LoRaWAN modem.
  • normal—Install the firmware and keep the user data on the LoRaWAN modem.
  • tftp-factory—Upload the firmware image via tftp, install the firmware, and wipe user data on the LoRaWAN modem.
  • tftp-normal—Upload the firmware image via tftp, install the firmware, and keep user data on the LoRaWAN modem.

Example

  • Normal install:

IR807#virtual-lpwa 1 modem install firmware normal flash:ixm_mdm_i_k9-1.0.tar.gz
Name: Virtual-LPWA 1
Modem image installed successfully
The modem will reboot in 10 s. 
IR807#
  • TFTP install:

IR807(config)#tftp-server flash:ixm_mdm_i_k9-1.0.tar.gz
IR807#virtual-lpwa 1 modem install firmware tftp-normal flash:ixm_mdm_i_k9-1.0.tar.gz
Name: Virtual-LPWA 1
Modem image installed successfully
The modem will reboot in 10 s. 
IR807#
  • External TFTP install (for which you need to manually enter the file URL):

IR807(config)#tftp-server flash:ixm_mdm_i_k9-1.0.tar.gz
IR807#virtual-lpwa 1 modem install firmware external-tftp-normal 10.10.10.10:ixm_mdm_i_k9-1.0.tar.gz
Name : Virtual-LPWA 1
Modem image installed successfully
The modem will reboot in 10 s. 
IR807#

Installing U-boot

To install u-boot with the firmware image or by itself, use the following command:


IR807#install firmware factory flash:ixm_mdm_i_k9-1.0.06.tar.gz 
{only-uboot
|uboot
}
  only-uboot  install uboot only
  uboot       install uboot together
  <cr>

If you execute the comand without any u-boot parameters, only the firmware image will be installed.

LoRaWAN Gateway FPGA Upgrade

Every released Cisco LoRaWAN Gateway firmware image includes the FPGA image for RF board. When the image is installed successfully, the Cisco LoRaWAN Gateway will auto-reboot and start to upgrade the FPGA when bring up.

Note : The FPGA upgrade needs about 20 minutes to be finished. During this time, LRR can’t work until the upgrade is completed. The FPGA upgrade will only happen if version differs.

You can check the status of the FPGA upgrade using the show virtual-lpwa 1 modem info command or show virtual-lpwa 1 modem status command.

Example


IR807#show virtual-lpwa 1 modem info
Name : Virtual-LPWA 1 
ModemImageVer : 1.0
BootloaderVer : 20160708_cisco
ModemAgentVer : 1.02
SerialNumber : FOC20133FK0
PID : IXM-LORA-800-H-V2
UTCTime : 00:02:56.492 UTC Sat Aug 06 2016
IPv4Address : 10.20.20.4
IPv6Address : none
FPGAVersion :            ! Blank when FPGA is upgrading
TimeZone : CEST
LocalTime : Sat Aug  6 02:02:56 CEST 2016
ACT2 Authentication : PASS
IR807#show virtual-lpwa 1 modem status
Name : Virtual-LPWA 1 
Status : Running
Uptime : 0:04:11.050000
Door : DoorClose
Upgrade Status : Ready  fpga upgrading —14.2%
IR807#show virtual-lpwa 1 modem info | begin IPv6
IPv6Address : none
FPGAVersion : 48           ! Correct FPGA version is displayed when upgrade is complete
TimeZone : CEST
LocalTime : Sat Aug 6 02:32:23 CEST 2016
ACT2 Authentication : PASS
IR807#

Uploading a File to the LoRaWAN Gateway

Customized files from the LRR package, for example, lrr.ini or custom.ini (AES key for geo-location), can be loaded from IOS if necessary by using the virtual-lpwa 1 modem upload flash:filename command.

Example


IR807# virtual-lpwa 1 modem upload flash:lgwx8_us920.ini
Name : Virtual-LPWA 1 
Uploaded successfully

The environment variables should be defined correctly using the following commands:


IR807# configure terminal
IR807(config)#interface virtual-LPWA 1
IR807(config-if)#lpwa modem environment PKTFWD_ROOT /tmp/mdm/pktfwd/firmware/
IR807(config-if)#lpwa modem environment LXC_STORE_PATH /tmp/mdm/pktfwd/firmware/usr/etc/lrr
IR807(config-if)#exit

After proper installation of the LRR package, the output of the command shows the directory that contains customized files:


IR807# show virtual-lpwa 1 modem uploads
Name : Virtual-LPWA 1 
Current folder: '/mnt/container/rootfs/tmp/mdm/pktfwd/firmware/usr/etc/lrr'
_parameters.sh
_system.sh
autoreboot_last
channels.ini
custom.ini
lgw.ini
lrr.ini
sysconfig_done
IR807# show virtual-lpwa 1 modem uploads detail
Name : Virtual-LPWA 1 
Current folder: '/mnt/container/rootfs/tmp/mdm/pktfwd/firmware/usr/etc/lrr'
total 32
-rw-r--r-- 1 root root 143 Aug 11 20:26 _parameters.sh
-rw-r--r-- 1 root root 20 Aug 11 20:26 _system.sh
-rw-r--r-- 1 root root 0 Aug 16 09:33 autoreboot_last
-rw-rw-r-- 1 sshd sshd 2000 Aug 5 16:15 channels.ini
-rw-rw-r-- 1 sshd sshd 275 Aug 5 15:35 custom.ini
-rw-rw-r-- 1 sshd sshd 1576 Aug 5 16:18 lgw.ini
-rwxrwxr-x 1 sshd sshd 8017 Aug 24 13:53 lrr.ini
-rw-r--r-- 1 root root 29 Aug 11 20:26 sysconfig_done
IR807#

Monitoring the LoRaWAN Gateway

On the IR807 series, beginning in privileged EXEC mode, use these commands to monitor the Cisco LoRaWAN Gateway.

Command

Purpose

show virtual-lpwa vlpwa-id modem [gps | info | ipsec | led | log | statistics | status | uploads ]

Displays the information of the LoRaWAN modem:

  • gps —Displays modem GPS information.
  • info —Displays modem information.
  • ipsec —Displays modem IPSec status and detailed information.
  • led —Displays modem LED information.
  • log —Displays modem logs.
  • statistics —Displays modem statistics.
  • status —Displays modem status.
  • uploads —Lists uploaded files.

show virtual-lpwa vlpwa-id packet-forwarder [info | log | status ]

Displays the information of the LoRaWAN modem packet-forwarder software:

  • info —Displays packet-forwarder information.
  • log —Displays packet-forwarder logs.
  • status —Displays packet-forwarder status.

Examples

The following is a sample output of the show virtual-lpwa 4 modem info command, which displays the modem information:


IR807# show virtual-lpwa 4 modem info
Name : Virtual-LPWA 4
ModemImageVer : 1.0.20
BootloaderVer : 20160830_cisco
ModemAgentVer : 1.02
SerialNumber : FOC20522TRZ
PID : IXM-LPWA-900-16-K9
UTCTime : 22:51:15.493 UTC Mon Feb 27 2017
IPv4Address : 192.168.4.2
IPv6Address : none
FPGAVersion : 58
TimeZone : UTC
LocalTime : Mon Feb 27 22:51:15 UTC 2017
ACT2 Authentication : PASS
ModemVersionID : V01
ProtocolVersion : 2
ChipID : LSB = 0x2876fd04 MSB = 0x00f1400e
LoRaSerialNumber : FOC20522TUV
LoRaCalc : <NA,NA,NA,56,38,111,102,94,85,77,69,59,50,40,31,22-NA,NA,NA,55,37,110,101,93,84,76,68,58,49,39,30,21>
CalTempCelsius : 34
CalTempCodeAD9361 : 91
RSSIOffset : -204.00,-204.00
-202.00,-202.00
AESKey : 1E5E364646EC3C3927F234FA8E200B3C

The following is sample outputs of the show virtual-lpwa 3 modem log commands, which display the modem logs:


IR807# show virtual-lpwa 3 modem log ?
  list  Modem log list
  name  Modem log name
IR807# show virtual-lpwa 3 modem log list
Name : Virtual-LPWA 3 
==========================================
dmesg           Modem kernel activity log
mdmagent        Modem agent log
messages        Modem system activity log
ipsec           Modem IPSec status log
gps             Modem GPS status log
certs           Modem Certificates log
IR807# show virtual-lpwa 3 modem log name certs
Name : Virtual-LPWA 3 
==========================================
Certificate
  Serial Number: 303e7714000000000078
  Certificate Usage: Digital Signature, Key Encipherment
  Issuer: DC=com, DC=example, DC=LASSI, CN=LASSI-ROOT-CA
  Subject: C=CN, ST=Nanning, L=Nanning, O=Cisco, OU=iot, CN=cisco-iot
  CRL Distribution Points:
ldap:///CN=LASSI-ROOT-CA,CN=win-jg39jcs57o7,CN=CDP,CN=Public%20Key%20Services,CN=Services,CN=Configuration,DC=LASSI,DC=example,DC=com?certificateRevocationList?base?objectClass=cRLDistributionPoint
  Validity Date:
    Not Before: Mar 29 17:35:17 2017 GMT
    Not After : Mar 29 17:45:17 2019 GMT
CA Certificate
  Serial Number: 4371ebdb781925be4b638ed1c5ca523c
  Certificate Usage: Digital Signature, Certificate Sign, CRL Sign
  Issuer: DC=com, DC=example, DC=LASSI, CN=LASSI-ROOT-CA
  Subject: DC=com, DC=example, DC=LASSI, CN=LASSI-ROOT-CA
  Validity Date:
    Not Before: Dec  2 21:34:38 2016 GMT
    Not After : Dec  2 21:44:38 2021 GMT
IR807#show virtual-lpwa 10 modem log name dmesg
Name: Virtual-LPWA 10
==========================================
2016-06-03T07:21:23+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T07:32:26+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T07:43:29+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T07:54:32+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T08:05:35+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T08:16:38+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T08:27:41+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T08:38:44+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T08:49:47+08:00 lorawan kernel: ttyS1: 1 input overrun(s)
2016-06-03T09:00:50+08:00 lorawan kernel: ttyS1: 1 input overrun(s)

The following is a sample output of the show virtual-lpwa 10 modem statistics command, which displays the modem statistics information:


IR807#show virtual-lpwa 10 modem statistics
Name: Virtual-LPWA 10 
Load Average: 0.00 0.04 0.05
Memory Usage: 0.22
Flash Usage: sys:0.03 app:0.04
Temperature: 44.5 C

The following is a sample output of the show virtual-lpwa 10 modem status command, which displays the modem status information:


IR807#show virtual-lpwa 10 modem status
Name: Virtual-LPWA 10 
Status: Running
Uptime: 13:40:37.500000
Door: DoorClose
Upgrade Status: Ready

The following is a sample output of the show virtual-lpwa 1 packet-forwarder info command, which displays the packet-forwarder information, and the LRRID which is required when registering a LoRaWAN interface on Actility Thingpark LoRaWAN network server:


IR807#show virtual-lpwa 1 packet-forwarder info
Name : Virtual-LPWA 1 
PublicKeyStatus : Installed
FirmwareStatus : Installed
PacketFwdVersion : 1.8.15
LRRID : 68ba477e
PartnerID : 0001

The following is a sample output of the show virtual-lpwa 10 packet-forwarder status command, which displays the packet-forwarder status:


IR807#show virtual-lpwa 10 packet-forwarder status
Name: Virtual-LPWA 10 
Status: Running

The following is a sample output of the show virtual-lpwa 10 packet-forwarder log list command, which displays the packet-forwarder log list:


IR807#show virtual-lpwa 10 packet-forwarder log list
Name: Virtual-LPWA 10 
==========================================
lrr.ini      lrr.ini information
config       Get the detail config
radio        Radio status
trace        LRR Trace log

The following is a sample output of the show virtual-lpwa 10 packet-forwarder log name trace command, which displays the packet-forwarder log name trace:


IR807#show virtual-lpwa 10 packet-forwarder log name trace
Name: Virtual-LPWA 10 
==========================================
05:51:35.464  (6196) [../xlap.c:726] TCP Disconnected on RTU(0x7e7b0,lrc7.thingpark.com,2404) fd=7 conn=1 'connection closed (eot)'
05:51:35.464  (6196) [../main.c:2299] LAP LRC DISC (2648)
05:51:35.465  (6196) [../xlap.c:553] Lap reset partial on RTU(0x7e7b0,lrc7.thingpark.com,2404) outq=0 ackq=3
05:51:37.405  (6196) [../xlap.c:1492] keep DNS resolution 'lrc7.thingpark.com' => '51.255.52.229'
05:51:37.405  (6196) [../xlap.c:1614] connect in progress on RTU(0x7e7b0,lrc7.thingpark.com,2404) fd=7
05:51:37.405  (6196) [../xlap.c:784] CB_LapRequest(0x7e7b0,lrc7.thingpark.com,2404) fd=7 conn=0 events=0 connect progress
05:51:37.756  (6196) [../xlap.c:1139] connect accepted on RTU(0x7e7b0,lrc7.thingpark.com,2404) fd=7
05:51:37.756  (6196) [../xlap.c:1397] (0x7e7b0,lrc7.thingpark.com,2404) from st='SSP_INIT'to st='SSP_STOPPED'(1000->2000)
05:51:37.756  (6196) [../main.c:2294] LAP LRC CNX
05:51:37.756  (6196) [../main.c:2075] LAP LRC TCP KEEPALIVE HIGH lrc=-1 fd=7 alive=1 idle=5 intvl=5 cnt=20

Monitoring LED Status

Use the show virtual-lpwa 1 modem led command to display LED status of the Cisco LoRaWAN Gateway. For the LED definitions, see the Cisco LoRaWAN Gateway Hardware Installation Guide .

The following is a sample output of the show virtual-lpwa 1 modem led command:


IR807#sh virtual-lpwa 3 modem led
Name : Virtual-LPWA 3
LED1 : GREEN ON, Solid
LED2 : GREEN ON, Solid

Checking Connectivity

To check the connectivity between the Cisco LoRaWAN Gateway and Thingpark Network Server after the LRR software is installed, you must check the IP NAT translations, to make sure the TCP connection over port 2404 is established.


IR807#show ip nat translation
Pro Inside global Inside local Outside local Outside global
icmp 192.168.0.2:3348 10.16.16.3:3348 217.69.25.85:3348 217.69.25.85:3348
tcp 192.168.0.2:49901 10.16.16.3:49901 217.69.25.85:2404 217.69.25.85:2404
IR807#

Connection with port 2404 indicates a successful communication between the LoRaWAN interface and the LoRaWAN network server.

Note : Make sure that port 2404 is open on the firewall if the gateway is installed on a secured network. It also requires DNS resolution for the name of the LoRaWAN network server, in case DNS is filtered on the firewall.

Debugging the LoRaWAN Modem

On the IR807 series, beginning in privileged EXEC mode, use these commands to debug the Cisco LoRaWAN Gateway.

Command

Purpose

debug vlpwa all

Enables all vlpwa debug messages.

undebug vlpwa all

Disables all vlpwa debug messages.

debug vlpwa [decode | detail | errors | memory | raw | registry | session | timers | trace ]

Enables the following vlpwa debug messages:

  • decode —Decoded packet information.
  • detail —Detailed trace information.
  • errors —Errors.
  • memory —Memory information.
  • raw —Raw packet information.
  • registry —Registry information.
  • session —Session information.
  • timers —Timers information.
  • trace —Trace information.