EtherChannel Configuration Between the Switch Module and the Host Router

This chapter describes how to configure the backplane interface PortChannel48, which provides communication between the host router and the switch module. It contains the following topics:

About the Backplane PortChannel48 Interface

The CGR 2010 ESM is inserted into the Cisco CGR 2010 Router. The switch module’s backplane interface is called PortChannel48 . PortChannel48 is the backplane interface connected to the CGR 2010 Router and provides communication between the host router and the switch module.

The PortChannel48 interface consists of eight 10/100 Fast Ethernet physical links that are grouped together to create a FastEtherChannel. PortChannel48 is created automatically when the switch module boots up.


Note It is recommended that all eight interfaces should be EtherChannel members and users are discouraged from removing any of the eight interfaces from the EtherChannel.


You can configure these interfaces like any other interface with the important exception that you cannot delete the system-created PortChannel48 interface.

You can change the PortChannel48 interface configuration from trunk mode to access mode (that is, non-trunk mode), or configure the PortChannel48 interface as a Layer 3 interface by configuring an IP address on the interface. For details, see “Configuring the Backplane PortChannel48 Interface” section.

Once a port is designated as a trunk port, it will forward and receive tagged frames.Frames belonging to the native VLAN do not carry VLAN tags when sent over the trunk. Conversely, if an untagged frame is received on a trunk port, the frame is associated with the native VLAN for this port.

The backplane PortChannel48 interfaces to the CGR 2010 host router. The router does not recognize spanning tree BPDUs; the spanning Tree Protocol is disabled on the PortChannel48 interface.

PortChannel48 Defaults

By default, the PortChannel48 interface comes up in Layer 2 trunk mode, with 802.1Q trunk encapsulation. 802.1Q is the only encapsulation method supported on the switch module.

Here is how the typical PortChannel and individual physical configuration looks when the switch module comes up the first time:

 

!
interface Port-channel48
port-type nni
switchport mode trunk
!
 
interface FastEthernet0/5
port-type nni
switchport mode trunk
channel-group 48 mode on

 

By default, the PortChannel48 interface is created in Layer 2 trunk mode, which means that the switch module operates in Layer 2 trunk mode with 802.1Q encapsulation carrying VLAN1 by default. This PortChannel48 interface supports load-balancing across multiple physical links, in the same way as the regular user-configured EtherChannel does, using the following parameters:

  • Destination IP address
  • Destination MAC address
  • Source IP address XOR with destination IP address
  • Source MAC address XOR with destination MAC address
  • Source IP address
  • Source MAC address (default mode)

Configuring the Backplane PortChannel48 Interface

By default, the switch module comes up in Layer 2 trunk mode. This section describes how to configure the PortChannel48 interface for the switch module for each of the following modes:

  • Layer 3 routing mode
  • Layer 2 trunk mode
  • Layer 2 access mode

Configuring the PortChannel48 Interface for Layer 3 Routing Mode

This section describes how to change from the default Layer 2 trunk mode to Layer 3 routing mode:

 

switch# show run interface f0/5
interface FastEthernet0/5
description: Member of internal backplane interface Port-channel48. Use caution while
changing the configuration.
port-type nni
switchport mode trunk
channel-group 48 mode on
end
 
switch# configure terminal
switch(config)# interface range f0/5-12
description: interfaces FE0/5 to FE0/12 apply to the Fiber model; interfaces FE0/9 to
FE0/16 apply to the Copper model
switch(config-if)# no channel-group 48 mode on
switch(config-if)# no switchport
switch(config-if)# end
switch(config)# interface port-channel 48
switch(config-if)# no switchport
switch(config-if)# ip address 209.165.200.225 255.0.0.0
switch(config-if)# ^Z
switch(config)# interface f0/5
switch(config-if)# channel-group 48 mode on
description: repeat for all 8 ports from 0/5 to 0/12
switch(config-if)# ^Z
switch#
switch# show interface port-channel 48
interface Port-channel48
description: "Internal backplane interface. Use caution while changing the
configuration"
port-type nni
no switchport
ip address 209.165.200.225 255.0.0.0
end

 

Configuring the PortChannel48 Interface for Layer 2 Trunk Mode

These commands configure the PortChannel in Layer 2 Trunk mode.

Method 1

This command configures both the PortChannel48 interface and its member ports in trunk mode.

 

configure terminal
default interface po48

 

Method 2

Note that every port from FE0/5 to FE0/12 (on the Fiber Model) and ports FE0/9 to FE0/16 (on the Copper Model) should be configured as shown here:

 

interface Port-channel48
port-type nni
switchport mode trunk
!
interface FastEthernet0/5
port-type nni
switchport mode trunk
channel-group 48 mode on

 

Configuring the PortChannel48 Interface for Layer 2 Access Mode

These commands configure the PortChannel in Layer 2 Access mode. Note that every port from FE0/5 to FE0/12 (on the Fiber Model) and ports FE0/9 to FE0/16 (on the Copper Model) should be configured as shown here:

 

interface InternalPort-channel48
switchport mode access
!
!#Incoming switch module interface connected
interface FastEthernet0/5
switchport mode access
channel-group 48 mode on

 

Sample Gigabit Ethernet Interface Configuration on the CGR 2010 Router

This section describes the Gigabit Ethernet configuration required on the host CGR 2010 router to implement the PortChannel48 interface on the router.

Interface GigabitEthernet0/ < slot 0 or 2> /0 is the backplane interface connected to the switch module. This interface can also have subinterfaces for each of the networks.

Interface to Receive Routed Traffic for Network 20.70.0.0

 

interface GigabitEthernet0/0/0
ip address 20.70.1.1 255.255.0.0

 

Interface to Receive Bridge Traffic on bridge-group 60

 

interface GigabitEthernet0/0/0
ip address 20.70.1.1 255.255.0.0
duplex auto
speed auto
media-type rj45
bridge-group 60

 

Backplane Subinterface to Receive Bridged Traffic on VLAN 60

 

interface GigabitEthernet0/0/0
ip address 20.70.1.1 255.255.0.0
!
interface GigabitEthernet0/0/0.60
encapsulation dot1Q 60
bridge-group 60
!

 

Backplane Subinterface to Receive Routed Traffic on VLAN 70

 

interface GigabitEthernet0/0/0.70
ip address 40.70.1.1 255.255.0.0

 

Specifying the Static Route for the Network

 

ip route 40.70.0.0 255.255.0.0 GigabitEthernet0/0/0