Configuring BGP

BGP Overview

Border Gateway Protocol (BGP) is an interdomain routing protocol designed to provide loop-free routing between separate routing domains that contain independent routing policies (autonomous systems). The Cisco software implementation of BGP version 4 includes support for 4-byte autonomous system numbers and multiprotocol extensions to allow BGP to carry routing information for IP multicast routes and multiple Layer 3 protocol address families including IP Version 4 (IPv4), IP Version 6 (IPv6), Virtual Private Networks Version 4 (VPNv4), Connectionless Network Services (CLNS), and Layer 2 VPN (L2VPN). This module contains conceptual material to help you understand how BGP is implemented in Cisco software.

For more information, see Information About Cisco BGP.

Limitations for BGP

  • BGP-PIC is not supported.

    But by default, BGP-PIC is enabled on all the Cisco IOS XE platforms, hence the BGP-PIC must be disabled using the cef table output-chain build favor memory-utilization command under configuration mode. If the BGP-PIC is not disabled, then the route update failure might occur.

  • When you configure BGP with graceful restart and remove the BGP configuration using no router bgp command, the graceful restart timer starts. As a result, the stale entry is present in the BGP routing table and it is only removed after the BGP graceful restart timer is over.

How to Configure BGP

Configuring BGP on BDI

Configuring a basic BGP network consists of a few required tasks and many optional tasks. A BGP routing process must be configured and BGP peers must be configured, preferably using the address family configuration model. If the BGP peers are part of a VPN network, the BGP peers must be configured using the IPv4 VRF address family task.

For more information, see Configuring BGP.

Verifying BGP Configuration

Use the following show command to verify the BGP configuration:


router#show run int lo0
Building configuration...

Current configuration : 86 bytes
!
interface Loopback0
ip address 192.0.2.0 255.255.255.255
ip ospf 30 area 0
end

RTR10-Dom3(config)#do sh run | sec router bgp
router bgp 1
bgp router-id 10.10.10.10
bgp log-neighbor-changes
redistribute connected
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.6.6.6 remote-as 1
neighbor 10.6.6.6 update-source Loopback0
neighbor 10.8.8.8 remote-as 1
neighbor 10.8.8.8 update-source Loopback0