OSPFv3 Address Families

This chapter describes how to use OSPFv3 address families to route IPv6 packets over OSPFv3—using IPv4 or IPv6 addresses. This chapter also describes how to configure and use OSPFv3 address families in conjunction with Mobile Ad-hoc Network (MANETs) and Radio Aware Routing (RAR).

This chapter includes the following major sections:

OSPFv3 is defined to support IPv6 unicast prefixes. The Internet draft, Support of Address Families in OSPFv3 ( IETF RFC 5838), extends OSPFv3 to support multiple address families. Cisco IOS implemented this extension, which allows IPv4 unicast addresses to be supported.

Configuring OSPFv3 Address Families

This section describes how to configure OSPFv3 Address Families for IPv6 and IPv4.

The Cisco OSPFv3 Address Families feature implements RFC 5838 and enables the ability to concurrently route IPv4 and IPv6 prefixes. The Cisco OSPFv3 Address Families feature is turned on in conjunction with the OSPFv3 MANET feature, which supports routing of IPv4 and IPv6 addresses and prefixes in mobile environments.

Configuring OSPFv3 Address Families is similar to configuring traditional IPv6 OSPFv3—the main difference being parameter usage in the CLI configuration commands. When configuring OSPFv3 Address Families, the new parameter ospfv3 replaces the deprecated ipv6 ospf parameter.


Note See Appendix A, “Command Reference” for complete command reference information.


Working with IPv6 and OSPFv3 involves the following tasks:

1. Enabling IPv6

2. Enabling IPv6 on the Interface

3. Configuring OSPFv3 for a Unicast Address Family

Enabling IPv6

This task explains how to enable IPv6 routing, which is disabled by default.

SUMMARY STEPS

1. enable

2. configure terminal

3. ipv6 unicast-routing

4. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing
 

Router(config)# ipv6 unicast-routing

Enables the forwarding of IPv6 unicast datagrams.

Step 4

exit

 

Router(config)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Enabling IPv6 on the Interface

This task explains how to enable IPv6 on an interface. This is a prerequisite to configuring OSPFv3 on the interface. IPv6 is disabled on the interface by default.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface [ type number ]

4. ipv6 enable

5. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface [ type number]

 

Router(config)# interface ethernet 0/0

Specifies an interface type and number and places the router in interface-configuration mode.

Step 4

ipv6 enable
 

Router(config-if)# ipv6 enable

Enables IPv6 processing on an interface that has not been configured with an explicit IPv6 address.

Step 5

exit

 

Router(config-if)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Configuring OSPFv3 for a Unicast Address Family

Perform one of the following tasks:

Configuring OSPFv3 for an IPv6 Unicast Address Family

Configuring OSPFv3 for an IPv6 unicast address family involves the following tasks:

Configuring the OSPFv3 IPv6 Address Family Instance on the Interface

This task explains how to enable IPv6 packet forwarding and IPv6 routing. By default, both are disabled.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface [ type number ]

4. ospfv3 [process-id] area [area-id] ipv6 [instance instance-id ]

5. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface [type number]

 

Router(config)# interface Ethernet 0/0

Configures an interface type.

Step 4

ospfv3 [process-id] area [area-id] ipv6 [instance instance-id ]

 

Router(config-if)# ospfv3 6 area 0 ipv6

Attaches the OSPFv3 process to an interface.

Process ID: Valid range is 1 to 65535.

Instance ID: 0 (Default value)

The valid range is 0 to 31.

Step 5

exit

 

Router(config-if)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Example

The following is a configuration example:

version 15.1
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
ipv6 unicast-routing
!
interface Ethernet0/0
ipv6 enable
ospfv3 6 area 0 ipv6
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
!
router ospfv3 6
router-id 6.6.6.6
log-adjacency-changes
address-family ipv6 unicast
exit-address-family
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Configuring the OSPFv3 IPv6 Address Family Process

This task explains how to enable an OSPFv3 routing process and configure the address family.

SUMMARY STEPS

1. enable

2. configure terminal

3. router ospfv3 [ process-id ]

4. router-id [ OSPFv3 router-id in IP address format ]

5. address-family ipv6 unicast

6. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

router ospfv3 [ process-id ]
 

Router (config)# router ospfv3 6

Enables an OSPFv3 routing process to route IPv6 address-family traffic in IPv6 networks and enters router configuration mode.

Step 4

router-id [ OSPFV3 router-id in IP address format ]

 

Router (config-rtr)# Router-id 10.1.1.1

Identifies a specific router rather than allowing the dynamic assignment of the router ID to occur.

Step 5

address-family ipv6 unicast

 

Router(config-rtr)# address-family ipv6 unicast

Places the router in address family configuration mode for IPv6 address family.

Step 6

exit

 

Router (config-router-af)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Configuring OSPFv3 for an IPv4 Unicast Address Family

Configuring an IPv4 unicast address family involves the following tasks:

1. Configuring the OSPFv3 IPv4 Address Family Instance on the Interface

2. Configuring an IPv4 Address on the Interface

3. Configuring the OSPFv3 IPv4 Address Family Process

Configuring the OSPFv3 IPv4 Address Family Instance on the Interface

This task explains how to enable IPv4 packet forwarding and IPv4 routing. By default, both are disabled.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface [ type number ]

4. ospfv3 [process-id] area [area-id] ipv4 [instance instance-id ]

5. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface [type number]

 

Router(config)# interface Ethernet 0/0

Specifies the interface type and number and places the router in interface-configuration mode.

Step 4

ospfv3 [process-id] area [area-id] ipv4 [instance instance-id ]

 

Router(config-if)# ospfv3 4 area 0 ipv4

Configures the OSPFv3 process ID. The valid range is 1 to 65535.

Optional—Instance ID: 64 (Default value)

The valid range is 64 to 95.

Step 5

exit

 

Router(config-if)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Example

The following is a configuration example:

version 15.1
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
ipv6 unicast-routing
!
interface Ethernet0/0
ip address 64.1.1.1 255.255.255.0
ipv6 enable
ospfv3 4 area 0 ipv4
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
ip forward-protocol nd
!
no ip http server
!
router ospfv3 4
router-id 4.4.4.4
log-adjacency-changes
address-family ipv4 unicast
exit-address-family
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Configuring an IPv4 Address on the Interface

This task configures an IPv4 address on the interface. You can assign a primary IP address for a network interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface [ type number ]

4. ip address [ ip address ] [ net mask ]

5. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

router# configure terminal

Enters global configuration mode.

Step 3

interface [ type number]

 

Router(config)# interface ethernet 0/0

Specifies an interface type and number and places the router in interface configuration mode.

Step 4

ip address [ ip address ] [ net mask ]
 

Router(config-if)# ip address 64.1.1.1 255.255.255.0

Assigns an IPv4 address to the interface.

Step 5

exit

 

Router(config-if)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Configuring the OSPFv3 IPv4 Address Family Process

This task explains how to enable an OSPFv3 routing process and configure the address family.

SUMMARY STEPS

1. enable

2. configure terminal

3. router ospfv3 [ process-id ]

4. router-id [ OSPFv3 router-id in IP address format ]

5. address-family ipv4 unicast

6. exit

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

router ospfv3 [ process-id ]
 

Router (config)# router ospfv3 4

Enables an OSPFv3 routing process to route IPv4 address-family traffic in IPv6 networks and enters router configuration mode.

Step 4

router-id [ OSPFv3 router-id in IP address format ]

 

Router (config-rtr)# Router-id 10.1.1.1

Identifies a specific router rather than allowing the dynamic assignment of the router ID to occur.

Step 5

address-family ipv4 unicast

 

Router(config-rtr)# address-family ipv4 unicast

Places the router in address family configuration mode for IPv4 address family.

Step 6

exit

 

Router (config-router-af)# exit

Exits global configuration mode and returns the router to privileged EXEC mode.

Working with Multiple Address Families

You can run Address Families OSPFv3 for IPv4 and IPv6 simultaneously on one interface.


Note To configure OSPFv3 for IPv4 and IPv6 simultaneously—with MANET and RAR features included, use tasks from this chapter and Chapter 10, “Configuring OSPFv3 for a MANET” The following example shows how to do this.


Example

version 15.1
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
ipv6 unicast-routing
!
subscriber authorization enable
!
subscriber profile Dargo7
pppoe service manet_radio
!
!
multilink bundle-name authenticated
!
no virtual-template subinterface
!
bba-group pppoe Group1
virtual-template 1
service profile Dargo7
!
interface Ethernet0/0
no ip address
pppoe enable group Group1
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Virtual-Template1
no ip address
ipv6 enable
no peer default ip address
no keepalive
!
interface vmi1
ip address 64.1.1.1 255.255.255.0
ipv6 enable
ospfv3 6 network manet
ospfv3 6 area 0 ipv6
ospfv3 4 network manet
ospfv3 4 area 0 ipv4
physical-interface Ethernet0/0
!
ip forward-protocol nd
!
router ospfv3 4
router-id 4.4.4.4
log-adjacency-changes
address-family ipv4 unicast
exit-address-family
!
router ospfv3 6
router-id 6.6.6.6
log-adjacency-changes
address-family ipv6 unicast
exit-address-family
!
control-plane
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end

Redistributing IPv4 Routes

Should you need to redistribute IPv4 routes between OSPFv3 Address Families and OSPFv2, be aware of common issues when redistributing IPv4 routes between OSPF processes as documented here: http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080531fd2.shtml

 

The following example shows how to redistribute IPv4 routes from OSPFv2 process 22 into OSPFv3 Address Families process 4:

Router (config)#router ospfv3 4
Router (config-router)#router-id 4.4.4.4
Router (config-router)#address-family ipv4 unicast
Router (config-router-af)#redistribute ?
bgp Border Gateway Protocol (BGP)
connected Connected
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
lisp Locator ID Separation Protocol (LISP)
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
ospfv3 OSPFv3
rip Routing Information Protocol (RIP)
static Static routes
 
Router (config-router-af)#redistribute ospf ?
<1-65535> Process ID
 
Router (config-router-af)#redistribute ospf 22 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
tag Set tag for routes redistributed into OSPF
vrf VPN Routing/Forwarding Instance
<cr>
 
Router (config-router-af)#redistribute ospf 22
 

The following example shows how to redistribute IPv4 routes from OSPFv3 Address Families process 4 into OSPFv2 process 22:

Router (config)#router ospf 22
Router (config-router)#redistribute ?
bgp Border Gateway Protocol (BGP)
connected Connected
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
lisp Locator ID Separation Protocol (LISP)
maximum-prefix Maximum number of prefixes redistributed to protocol
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
ospfv3 OSPFv3
rip Routing Information Protocol (RIP)
static Static routes
 
Router (config-router)#redistribute ospfv3 ?
<1-65535> Process ID
 
Router (config-router)#redistribute ospfv3 4 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
nssa-only Limit redistributed routes to NSSA areas
route-map Route map reference
subnets Consider subnets for redistribution into OSPF
tag Set tag for routes redistributed into OSPF
<cr>
 
Router (config-router)#redistribute ospfv3 4 subnets ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
nssa-only Limit redistributed routes to NSSA areas
route-map Route map reference
tag Set tag for routes redistributed into OSPF
<cr>
 
Router (config-router)#redistribute ospfv3 4 subnets

Verifying OSPFv3 Address Families Configuration and Operation

You can use any combination of the commands listed in this section to check the operation status of OSPFv3 for Address Families.


Note You must be in privileged EXEC mode to enter the command listed in this section.


 

Command or Action
Purpose

show run

 

Router# show run

Verify a configuration.

show ospfv3
 

Router# show ospfv3

Displays general information about all OSPFv3 routing processes.

show ospfv3 neighbor
 

Router# show ospfv3 neighbor

Displays OSPFv3 neighbor information per routing process.

show ospfv3 neighbor detail
 

Router# show ospfv3 neighbor detail

Displays a detailed list of all neighbors.

show ospfv3 interface [ interface-type interface-number ]
 
show ospfv3 interface e0/0

Displays all OSPFv3 routing information for an interface.

The show ospfv3 command can be used to show general information about the OSPFv3 Address Family router process.

Router# show ospfv3
Routing Process "ospfv3 4" with ID 4.4.4.4
Supports IPv4 Address Family
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
Initial SPF schedule delay 1000 msecs
Minimum hold time between two consecutive SPFs 2000 msecs
Maximum wait time between two consecutive SPFs 2000 msecs
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Graceful restart helper support enabled
Reference bandwidth unit is 100 mbps
Relay willingness value is 128
Pushback timer value is 2000 msecs
Relay acknowledgement timer value is 1000 msecs
LSA cache Disabled : current count 0, maximum 1000
ACK cache Disabled : current count 0, maximum 1000
Selective Peering is not enabled
Hello requests and responses will be sent multicast
Area BACKBONE(0) (Inactive)
Number of interfaces in this area is 1
SPF algorithm executed 0 times
Number of LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 
Router# show ospfv3 neighbor
 
OSPFv3 Router with ID (4.4.4.4) (Process ID 4)
 
Neighbor ID Pri State Dead Time Interface ID Interface
2.2.2.2 0 FULL/ - 00:00:19 3 Ethernet0/0
 
Router# show ospfv3 interface e0/0
Ethernet0/0 is up, line protocol is up
Link Local Address FE80::A8BB:CCFF:FE01:5500, Interface ID 3
Area 0, Process ID 100, Instance ID 0, Router ID 4.4.4.4
Network Type MANET, Cost: 10 (dynamic), Cost Hysteresis: Disabled
Cost Weights: Throughput 100, Resources 100, Latency 100, L2-factor 100
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:01
Graceful restart helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
Incremental Hello is enabled
Local SCS number 1
Relaying enabled