Configuring EIGRP in a MANET

This chapter explains how to configure the Enhanced Interior Gateway Routing Protocol (EIGRP) in a MANET.

This chapter includes the following major sections:

Understanding The Enhanced Interior Gateway Protocol

The Enhanced Interior Gateway Routing Protocol (EIGRP) integrates the capabilities of link-state protocols into distance vector protocols. EIGRP is distinguished from other routing protocols by the following key capabilities:

  • Fast convergence
  • Supports variable-length subnet mask
  • Supports partial updates
  • Supports multiple network layer protocols

A router running EIGRP stores all of its neighbors' routing tables so that the router running EIGRP can quickly adapt to alternate routes. If no appropriate route exists, EIGRP queries its neighbors to discover an alternate route. These queries propagate until an alternate route is found.

EIGRP supports variable-length subnet masks permitting routes to be automatically summarized on a network number boundary. EIGRP can be configured to summarize on any bit boundary at any interface.

EIGRP does not make periodic updates. EIGRP sends partial updates when the route metric changes. Propagation of partial updates is automatically bounded, so only routers needing the information update. EIGRP consumes significantly less bandwidth than the Interior Gateway Routing Protocol (IGRP).

Using EIGRP Cost Metrics for VMI Interfaces

When using EIGRP as the routing protocol, metrics allow EIGRP to respond to routing changes. The link-state metric is advertised as the link cost in the router link advertisement. The reply sent to any routing query always contains the latest metric information. The following exceptions result in an immediate update being sent:

  • A down interface
  • A down route
  • Any change in metrics that result in the router selecting a new next hop

EIGRP receives dynamic raw radio link characteristics and computes a composite EIGRP metric based on a proprietary formula. To avoid churn in the network as a result of the change in the link characteristics, EIGRP uses a tunable dampening mechanism.

EIGRP uses the metric weights along with a set of vector metrics to compute the composite metric for local Routing Information Base (RIB) installation and route selections. The EIGRP composite metric is calculated using the formula:

metric = [K1 * BW + (K2 * BW) / (256 - Load) + K3 * Delay] * [K5 / (Reliability + K4)]


Note Use K values only after careful planning. Mismatched K values prevent a neighbor relationship from being built, which can cause your network to fail to converge.



Note If K5 = 0, the formula reduces to metric = [K1 * BW + (K2 * BW)/(256 - Load) + K3 * Delay].


Table 11-1 lists the EIGRP vector metrics and their descriptions.

 

Table 11-1 EIGRP Vector Metrics

Vector Metric
Description

BW

Minimum bandwidth of the route in kilobits per second. It can be 0 or any positive integer.

Delay

Route delay in tens of microseconds. It can be 0 or any positive number that is a multiple of 39.1 nanoseconds.

Reliability

Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100 percent reliability; 0 means no reliability.

Load

Effective load of the route expressed as a number from 0 to 255 (255 is 100 percent loading).

MTU

Minimum Maximum Transmission Unit (MTU) size of the route in bytes. It can be 0 or any positive integer.

EIGRP monitors metric weights on an interface to allow for the tuning of EIGRP metric calculations and indicate Type of Service (ToS). Table 11-2 lists the K-values and their default.

 

Table 11-2 EIGRP K-Value Defaults

Setting
Default Value

K1

1

K2

0

K3

1

K4

0

K5

0

As shown in Table 11-2 , cost configurations use the first two metrics—delay and bandwidth. The default formula of (BW +Delay) is the EIGRP metric. The bandwidth for the formula is scaled and inverted by the following formula:

(10^7/minimum BW in kilobits per second)


Note You can change the weights, but these weights must be the same on all the routers.


For example, look at an EIGRP link where the bandwidth to a particular destination is 128k and the Relative Link Quality (RLQ) is 50 percent.

BW = (256 * 10000000) / 128 = 20000000

Delay = (((10000000000 / 128) * 100) / (50 * 1000)) * 256 = (40000000 / 10) = 4000000

Using the cut-down formula, the EIGRP metric calculation would simplify to 256*(BW + Delay), resulting in the following value:

Metric = (BW + Delay) = 20000000 + 4000000 = 240000000

Understanding VMI Metric to EIGRP Metric Conversion

With the VMI interface, the quality of connection to a neighbor varies based on a number of characteristics computed dynamically as a result of layer 2 feedback to layer 3. Table 11-3 lists the metrics and their significance.

 

Table 11-3 MANET Metrics for VMI Interfaces

Metric
Format
Significance

current data rate

uint64_t

The current data rate reported from the radio. EIGRP converts the value into kilobits per second.

max data rate

uint64_t

The maximum data rate reported from the radio. EIGRP converts the value into kilobits per second.

latency

unsigned int

The latency computed and reported by the radio in milliseconds.

resources

unsigned int

The resources computed by the radio. A representation of resources, such as battery power, ranges from 0 to 100. If a radio does not report dynamic resources, the value is always 100.

relative link quality

unsigned int

An opaque number that ranges from 0 to 100 is computed by the radio, representing radio's view of link quality. 0 represents the worst possible link, 100 represents the best possible link.

link-load

unsigned int

An opaque number that ranges from 0 to 100 is computed by VMI, representing the load on the Ethernet link. 0 represents an idle Ethernet link, 100 represents a fully loaded Ethernet link. Note that this is not associated with the radio link.

Table 11-4 lists these EIGRP vector metric values map to the basic EIGRP interface parameters.


Note Although not explicit in Table 11-4, all variables are converted to the proper units.


 

Table 11-4 Mapping of MANET Metric Values to EIGRP Vector Metrics Values

Metric
EIGRP Metric
Mapping

current data rate

Bandwidth

Calculated:

bandwidth = (256 * 10000000) / (current data rate / 1000)

relative link quality resources

Reliability

Calculated:

reliability = (255 * (relative link quality) / 100)) *

(resources / 100)

current data rate

relative link quality

Delay

Calculated:

delay = 256 * (1E10 / (current data rate / 1000)) * ((100 / relative link quality) / 1000) / 10

load

Load

Calculated:

load = ((255 * link-load) / 100)

Understanding EIGRP Metric Dampening for VMI

Because metric components can change rapidly, the frequency of the changes have an impact on the network. Frequent changes require that prefixes learned though the VMI be updated and sent to all adjacencies. This update can result in further updates and, in a worst-case scenario, cause network-wide churn. To prevent such effects, metrics can be dampened, or thresholds set, so that any change that does not exceed the dampening threshold is ignored.

The following network changes cause an immediate update:

  • A down interface
  • A down route
  • Any change in a metric that results in the router selecting a new next hop

Dampening the metric changes can be configured based on change or time intervals.

If the dampening method is change-based, changes in routes learned though a specific interface, or in the metrics for a specific interface, are not advertised to adjacencies until the computed metric changes from the last advertised value significantly enough to cause an update to be sent.

If the dampening method is interval-based, changes in routes learned though a specific interface, or in the metrics for a specific interface, are not advertised to adjacencies until the specified interval is met, unless the change results in a new route path selection.

When the timer expires, any routes with outstanding changes to report are sent out. If a route changes, such that the final metric of the route matches the last updated metric, no update is sent.

Understanding Neighbor Up/Down Signaling for EIGRP

MANETs are highly dynamic environments. Nodes may move in to, or out of, radio range at a fast pace. Each time a node joins or leaves, the network topology must be logically reconstructed by the routers. Routing protocols normally use timer-driven “hello” messages or neighbor time-outs to track topology changes. MANETs reliance on these mechanisms can result in unacceptably slow convergence.

This signaling capability provides faster network convergence by using link-status signals generated by the radio. The radio notifies the router each time a link to another neighbor is established or terminated by the creation and termination of PPPoE sessions. In the router, the EIGRP responds immediately to these signals by expediting the formation of a new adjacency (for a new neighbor) or tearing down an existing adjacency (if a neighbor is lost). For example, if a vehicle drives behind a building and loses its connection, the router immediately senses the loss and establishes a new route to the vehicle through neighbors that are not blocked. This high speed network convergence is essential for minimizing dropped voice calls and disruptions to video sessions.

When VMI with PPPoE is used and a partner node has left or a new one has joined, the radio informs the router immediately of the topology change. Upon receiving the signal, the router immediately declares the change and updates the routing tables.

The signaling capability offers the following benefits:

  • Reduces routing delays and prevents applications from timing out
  • Enables network-based applications and information to be delivered reliably and quickly over directional radio links
  • Provides faster convergence and optimal route selection so that delay-sensitive traffic such as voice and video are not disrupted
  • Reduces impact on radio equipment by minimizing the need for internal queuing/buffering
  • Provides consistent Quality of Service (QoS) for networks with multiple radios

The messaging allows for flexible rerouting when necessary because of the following factors:

  • Noise on the Radio links
  • Fading of the Radio links
  • Congestion of the Radio links
  • Radio link power fade
  • Utilization of the Radio

Figure 11-1 illustrates the signaling sequence that occurs when radio links go up and down.

Figure 11-1 Up and Down Signaling Sequence

 

Enabling EIGRP for IPv4

To create an EIGRP routing process, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1. enable

2. configure terminal

3. router eigrp as-number

4. network network-number

5. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

router(config) # router eigrp as-number

 
Router(config)# router eigrp 1

Enables an EIGRP routing process in global configuration mode.

Step 4

router(config) # network network-number

 
Router(config)# network 10.2.2.0 0.0.0.255

Associates networks with an EIGRP routing process in router configuration mode.

Step 5

End

 

Router(config-if)# end

Exits interface configuration.

Activating EIGRP IPv4 on a Configured VMI

Perform this task to activate EIGRP IPv4 on a configured VMI.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface vmi interface-number

4. no ip redirects

5. no ip split-horizon eigrp as-number

6. exit

7. router eigrp as-number

8. network network-number ip-mask

9. end

DETAILED STEPS

 

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface type interface-number

 

Router(config-if)# interface vmi 1

Specifies the number of the VMI.

Step 4

no ip redirect

 

Router(config)# no ip redirect

Disables the sending of ICMP redirect messages if the Cisco IOS software is forced to resend a packet through the same interface on which it was received.

Step 5

no ip split-horizon eigrp as-number

 

Router(config)# no ip split-horizon eigrp 1

Disables the split horizon mechanism for the specified session.

Step 6

exit

 

 

Router(config-if)# exit

Exits a command mode to the next higher mode.

Step 7

router eigrp as-number

 

Router(config)# router eigrp 1

Enables EIGRP routing on the router and identifies the autonomous system number.

Step 8

network network-number ip-mask

 

Router(config)# network 10.1.1.0 0.0.0.255

Identifies the EIGRP network.

Step 9

end

 

Router(config)# end

(Optional) Exits the configuration mode and returns to privileged EXEC mode.

Enabling EIGRP for IPv6

Perform the following task to enable EIGRP for IPv6 on a specified interface. EIGRP for IPv6 is directly configured on the interfaces over which it runs, which allows EIGRP for IPv6 to be configured without the use of a global IPv6 address.

SUMMARY STEPS

1. enable

2. configure terminal

3. ipv6 unicast-routing

4. interface type number

5. ipv6 enable

6. ipv6 eigrp as-number

7. no shutdown

8. ipv6 router eigrp as-number

9. router-id { ip-address | ipv6-address }

10. no shutdown

11. end

DETAILED STEPS

.

Command or Action
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

Enables IPv6 unicast routing.

Step 4

interfac e type number

 

Router(config)# interface vmi1

Creates a VMI.

Step 5

ipv6 enable

 

Router(config-if)# ipv6 enable

Enables IPv6 routing on the virtual template.

Step 6

ipv6 eigrp as-number

 

Router(config-if)# ipv6 eigrp 100

Enables EIGRP for IPv6 on a specified interface and specifies the Autonomous System (AS) number.

Step 7

no shutdown

 

Router(config-if)# no shutdown

Restarts a disabled interface or prevents the interface from being shut down.

Step 8

ipv6 router eigrp as-number

 

Router(config-if)# ipv6 router eigrp 101

Places the router in router configuration mode, creates an EIGRP routing process in IPv6, and allows you to enter additional commands to configure this process.

Step 9

router-id { ip-address | ipv6-address }

 

Router(config-router)# router-id 10.1.1.1

Enables the use of a fixed router ID.

Step 10

no shutdown

 

Router(config-router)# no shutdown

Restarts a disabled EIGRP process or prevents the EIGRP process from being shut down.

Step 11

end

 

Router(config-rtr)# end

(Optional) Exits the configuration mode and returns to privileged EXEC mode.

Setting the EIGRP Metric Change-based Dampening for VMI

Perform the following tasks to set the change-based dampening interval for VMI:

This configuration assumes that a virtual template and appropriate PPPoE configurations have already been completed. Refer to the Cisco IOS IP Mobility Configuration Guide for VMI configuration details.

This configuration sets the threshold to 50 percent tolerance routing updates involving VMIs and peers.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. eigrp as-number interface [ dampening-change value ] [ dampening-interval value ]

5. physical-interface interface-type / slot

6. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface type number

 
Router(config)# interface vmi 1

Enters interface configuration and creates a VMI.

Step 4

eigrp as-number interface [ dampening-change value ] [ dampening-interval value ]
 

Router(config-if)# eigrp 1 interface dampening-change 50

Sets the EIGRP change-based dampening.

Step 5

physical-interface interface-type/slo t

 

Router(config-if)# physical-interface Ethernet0/0

Creates a physical subinterface to be associated with the VMI.

Step 6

end

 

Router(config-rtr)# end

(Optional) Exits the configuration mode and returns to privileged EXEC mode.

Setting the EIGRP Interval-based Metric Dampening for VMI

Perform this task to set an interval-based dampening interval for VMI interfaces.

This configuration assumes that a virtual template and appropriate PPPoE configurations have already been completed. Refer to the Cisco IOS IP Mobility Configuration Guide for VMI configuration details.

This configuration sets the interval to 30 seconds at which updates occur for topology changes that affect VMI interfaces and peers:

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. eigrp as-number interface [ dampening-change value ] [ dampening-interval value ]

5. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 

Router> enable

Enables privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Router# configure terminal

Enters global configuration mode.

Step 3

interface type number

 
Router(config)# interface vmi 1

Enters interface configuration and creates a VMI.

Step 4

eigrp as-number interface [ dampening-change value ] [ dampening-interval value ]
 

Router(config-if)# eigrp 1 interface dampening-interval 15

Sets the EIGRP interval-based dampening interval.

Step 5

End

 

Router(config-if)# end

Exits interface configuration.

Examples

Basic VMI PPPoE Configuration with EIGRP IPv4

The following example illustrates the simplest configuration using EIGRP as the routing protocol. This configuration includes one VMI.

...
<output truncated>
...
!
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
!
!
multilink bundle-name authenticated
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe MANET1
virtual-template 1
service profile host1
!
!
interface FastEthernet0/0
no ip address
pppoe enable group MANET1
!
interface Virtual-Template1
ip unnumbered vmi1
service-policy output FQ
!
interface vmi1
ip address 10.3.3.1 255.255.255.0
no ip redirects
physical-interface FastEthernet0/0
!
router eigrp 1
network 10.3.0.0 0.0.255.255
auto-summary
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Basic VMI PPPoE Configuration Using EIGRP for IPv6

This example shows the basic requirements for configuring a VMI that uses EIGRP for IPv6 as the routing protocol. It includes one VMI.

...
<output truncated>
...
!
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
!
!
multilink bundle-name authenticated
!
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe MANET1
virtual-template 1
service profile host1
!
!
interface FastEthernet0/0
no ip address
pppoe enable group MANET1
!
!
interface Virtual-Template1
no ip address
ipv6 unnumbered vmi1
ipv6 enable
service-policy output FQ
!
interface vmi1
no ip address
ipv6 address 2001:DB1:2::1/96
ipv6 enable
no ipv6 redirects
ipv6 eigrp 101
no ipv6 split-horizon eigrp 101
physical-interface FastEthernet0/0
!
ipv6 router eigrp 101
router-id 10.9.1.1
no shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

VMI PPPoE Configuration Using EIGRP for IPv4 and IPv6

The following examples shows the configuration VMI PPPoE using EIGRP as the IP routing protocol when you have both IPv4 and IPv6 addresses configured on the interface. This configuration includes one VMI. While EIGRP allows you to use the same AS number on an IPv4 EIGRP process and on an IPv6 process, we recommend using a unique AS number for each process for clarity.

...
<output truncated>
...
!
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe MANET1
virtual-template 1
service profile host1
!
!
interface FastEthernet0/0
no ip address
pppoe enable group MANET1
!
!
interface Virtual-Template1
ip unnumbered vmi1
ipv6 unnumbered vmi1
ipv6 enable
service-policy output FQ
!
interface vmi1
ip address 10.3.3.1 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ipv6 address 2001:0DB1:2::1/64
ipv6 enable
no ipv6 redirects
ipv6 eigrp 101
no ipv6 split-horizon eigrp 1
eigrp 1 interface dampening-interval 30
eigrp 101 interface dampening-interval 30
physical-interface FastEthernet0/0
!
router eigrp 1
network 10.3.0.0 0.0.255.255
auto-summary
!
!
ipv6 router eigrp 101
router-id 10.9.1.1
no shutdown
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

EIGRP Metric Dampening for VMI Interfaces

The eigrp interface command advertises routing changes for EIGRP traffic only.

The REPLY sent to any QUERY will always contain the latest metric information. The following exceptions result in an immediate UPDATE:

  • A down interface
  • A down route
  • Any change in metric which results in the router selecting a new next hop

To prevent network-wide churn from frequent metric changes from impacting the network, even causing network-wide churn, metrics can be dampened, or thresholds set, so that any change that does not exceed the dampening threshold is ignored. The examples in this section show how to set the EIGRP dampening intervals to avoid such impacts.

EIGRP Change-based Metric Dampening for VMI Interfaces

The following example sets the threshold to 50 percent tolerance routing updates involving VMIs and peers:

interface vmi1
ip address 10.2.2.1 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ipv6 address 2001:0DB1:2::1/64
ipv6 enable
no ipv6 redirects
ipv6 eigrp 101
no ipv6 split-horizon eigrp 101
eigrp 1 interface dampening-change 50
eigrp 101 interface dampening-change 50
physical-interface FastEthernet0/0

EIGRP Interval-based Metric Dampening for VMI Interfaces

The following example sets the interval to 30 seconds at which updates occur for topology changes that affect VMIs and peers:

interface vmi1
ip address 10.2.2.1 255.255.255.0
no ip redirects
no ip split-horizon eigrp 1
ipv6 address 2001:0DB1:2::1/64
ipv6 enable
no ipv6 redirects
ipv6 eigrp 101
no ipv6 split-horizon eigrp 101
eigrp 1 interface dampening-interval 30
eigrp 101 interface dampening-interval 30
physical-interface FastEthernet0/0

EIGRP VMI Bypass Mode

The following examples show the configuration of VMI bypass mode with EIGRP IPv4, EIGRP IPv6, and EIGRP for IPv4 and IPv6.

VMI Bypass mode PPPoE Configuration Using EIGRP for IPv6:

...
hostname host1
!
no ip domain lookup
!
ipv6 unicast-routing
!
ipv6 cef
!
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
no virtual-template subinterface
!
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
load-interval 30
ipv6 address 3514:1::1/64
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Virtual-Template1
no ip address
load-interval 30
ipv6 address 3514:2::1/64
ipv6 enable
ipv6 eigrp 1
no keepalive
service-policy output FQ
!
interface vmi1
no ip address
load-interval 30
ipv6 enable
physical-interface FastEthernet0/0
mode bypass
!
ipv6 router eigrp 1
no shutdown
redistribute connected
...
end

VMI Bypass mode PPPoE Configuration with EIGRP IPv4:

hostname host1
!
ip cef
!
no ip domain lookup
!
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
!
no virtual-template subinterface
!
archive
log config
!
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 35.9.1.1 255.255.255.0
load-interval 30
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Virtual-Template1
ip address 4.3.3.1 255.255.255.0
load-interval 30
no keepalive
service-policy output FQ
!
interface vmi1
! the IP Address of the vmi1 interface needs to be defined,
! but it will not be routable since the vmi interface will be
! down/down.
ip address 4.3.9.1 255.255.255.0
load-interval 30
physical-interface FastEthernet0/0
mode bypass
!
router eigrp 1
redistribute connected
network 4.2.0.0 0.0.255.255
network 4.3.0.0 0.0.255.255
auto-summary
!
...
end

VMI Bypass mode PPPoE Configuration Using EIGRP for IPv4 and IPv6:

...
hostname host1
!
ip cef
!
no ip domain lookup
!
ipv6 unicast-routing
!
ipv6 cef
!
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
!
no virtual-template subinterface
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 35.9.1.1 255.255.255.0
load-interval 30
ipv6 address 3514:1::1/64
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Virtual-Template1
ip address 4.3.3.1 255.255.255.0
load-interval 30
ipv6 address 3514:2::1/64
ipv6 enable
ipv6 eigrp 1
no keepalive
service-policy output FQ
!
interface vmi1
ip address 4.3.9.1 255.255.255.0
load-interval 30
ipv6 enable
physical-interface FastEthernet0/0
mode bypass
!
router eigrp 1
redistribute connected
network 4.2.0.0 0.0.255.255
network 4.3.0.0 0.0.255.255
auto-summary
!
ipv6 router eigrp 1
eigrp router-id 35.9.1.1
no shutdown
redistribute connected
...
end