V Commands

This chapter describes the Cisco NX-OS Open Shortest Path First (OSPF) commands that begin with V.

vrf

To enter a virtual routing and forwarding (VRF) configuration mode and configure submode commands, use the vrf command. To remove a VRF instance or disable the VRF configuration mode, use the no form of this command.

vrf name | management

no vrf name | management

 
Syntax Description

name

Name of the VRF. The name can be any case-sensitive, alphanumeric string up to 32 characters.

management

Specifies the management VRF.

 
Command Default

None

 
Command Modes

Address-family configuration mode
Router configuration mode
VRF configuration mode

 
Command History

Release
Modification

5.2(1)N1(1)

This command was introduced.

 
Usage Guidelines

The VRF does not become active until you create an identically named VRF in global configuration mode.

When you enter the VRF configuration mode, the following commands are available:

  • area —(OSPF) Configures area properties.
  • address-family —(BGP) Configures an address-family. See the address-family (BGP) command for additional information.
  • auto-cost —(OSPF) Calculates OSPF cost according to bandwidth.
  • cluster-id { cluster-id | cluster-ip-addr } —(BGP) Configures the Route Reflector Cluster-ID (router, vrf). Range: 1 to 4294967295. You can enter the cluster identification as a 32-bit quantity or as an IP address. To remove the cluster ID, use the no form of this command. Together, a route reflector and its clients form a cluster. When a single route reflector is deployed in a cluster, the cluster is identified by the router ID of the route reflector.

The cluster-id command is used to assign a cluster ID to a route reflector when the cluster has one or more route reflectors. Multiple route reflectors are deployed in a cluster to increase redundancy and avoid a single point of failure. When multiple route reflectors are configured in a cluster, the same cluster ID is assigned to all route reflectors, which allows all route reflectors in the cluster to recognize updates from peers in the same cluster and reduces the number of updates that need to be stored in BGP routing tables.


Note All route reflectors must maintain stable sessions between all peers in the cluster. If stable sessions cannot be maintained, you should use overlay route reflector clusters instead (route reflectors with different cluster IDs).


  • default-information —(OSPF) Controls the distribution of the default route. See the default-information originate (OSPF) command for additional information.
  • default-metric —(OSPF) Specifies the default metric for redistributed routes. See the default-metric (OSPF) command for additional information.
  • distance —(OSPF) Defines the OSPF administrative distance. See the distance (OSPF) command for additional information.
  • exit —(BGP) Exits from the current command mode.
  • log-adjacency-changes —(OSPF) Logs changes in adjacency state.
  • log-neighbor-changes —Enables logging of the BGP neighbor resets. To disable the logging of changes in BGP neighbor adjacencies, use the no form of this command. The log-neighbor-changes command enables logging of BGP neighbor status changes (up or down) and resets for troubleshooting network connectivity problems and measuring network stability. Unexpected neighbor resets might indicate high error rates or high packet loss in the network and should be investigated.

Using the log-neighbor-changes command to enable status change message logging does not cause a substantial performance impact, unlike, for example, enabling per BGP update debugging. If the UNIX syslog facility is enabled, messages are sent to the UNIX host running the syslog daemon so that the messages can be stored and archived. If the UNIX syslog facility is not enabled, the status change messages are retained in the internal buffer of the router, and are not stored to the disk. You can set the size of this buffer, which is dependent upon the available RAM, using the logging buffered command.

The neighbor status change messages are not tracked if the bgp log-neighbor-changes command is disabled, except for the reset reason, which is always available as output of the show ip bgp neighbors command.

The eigrp log-neighbor-changes command enables logging of Enhanced Interior Gateway Routing Protocol (EIGRP) neighbor adjacencies, but messages for BGP neighbors are logged only if they are specifically enabled with the bgp log-neighbor-changes command.

Use the show logging command to display the log for the BGP neighbor changes.

  • max-metric —(OSPF) Maximizes the cost metric. See the max-metric (OSPF) command for additional information.
  • maximum-paths —(OSPF) Sets the maximum number of parallel routes that OSPF can support. See the maximum-paths (OSPF) command for additional information.
  • neighbor —Configures a BGP neighbor. See the neighbor command for additional information.
  • no —Negates a command or set its defaults.
  • redistribute —(OSPF) Redistributes information from another routing protocol. See the redistribute (OSPF) command for additional information.
  • rfc1583compatibility —(OSPF) Configures RFSC 1583 compatibility for external path preferences. See the rfc1583compatibility command for additional information.
  • router-id ip-addr —Specifies the IP address to use as the router-id.
  • shutdown —(OSPF) Shuts down the OSPF protocol instance. See the shutdown (OSPF) command for additional information.
  • summary-address —(OSPF) Configures route summarization for redistribution. See the summary-address (OSPF) command for additional information.
  • timers bestpath-timeout —Configures the best-path timeout in seconds. Range: 1 to 3600. Default: 300.

Examples

This example shows how to enter VRF configuration mode in a BGP environment:

switch(config)# router bgp 100
switch(config-router)# vrf management
switch(config-router-vrf)#
 

This example shows how to enter VRF configuration mode in an OSPF environment:

switch(config)# vrf context RemoteOfficeVRF
switch(config-vrf)# router ospf 201
switch(config-router)# vrf RemoteOfficeVRF
switch(config-router-vrf)#
 

 
Related Commands

Command
Description

vrf context

Creates a VRF.

show vrf

Displays the VRF configuration information.

 

vrf context

To create a virtual routing and forwarding instance (VRF) and enter VRF configuration mode, use the vrf context command. To remove a VRF entry, use the no form of this command.

vrf context { name | management }

no vrf context { name | management }

 
Syntax Description

name

Name of the VRF. The name can be any case-sensitive, alphanumeric string up to 32 characters.

management

Specifies the management VRF.

 
Command Default

None

 
Command Modes

Global configuration mode

 
Command History

Release
Modification

5.2(1)N1(1)

This command was introduced.

Examples

This example shows how to create a VRF context:

switch(config)# vrf context RemoteOfficeVRF
switch(config-vrf)#
 

 
Related Commands

Command
Description

vrf

Creates or configures a VRF instance.

show vrf

Displays the VRF configuration information.

 

vrf member

To add an interface to a virtual routing and forwarding (VRF) instance or to configure object tracking on a VRF instance, use the vrf member command. To remove the object tracking for this route, use the no form of this command.

vrf member vrf-name

no vrf member vrf-name

 
Syntax Description

vrf-name

VRF name. The name can be any case-sensitive, alphanumeric string up to 32 characters.

 
Command Default

None

 
Command Modes

Interface configuration mode
Object tracking confiuration mode

 
Command History

Release
Modification

5.2(1)N1(1)

This command was introduced.

 
Usage Guidelines

Use the vrf member command in object tracking configuration mode to track objects in a nondefault VRF.

Examples

This example shows how to track an IP route in VRF Red:

switch(config)# track 1 ip route 10.10.10.0/8 reachability
switch(config-track)# vrf member Red
switch(config-track)#
 

This example shows how to add the Ethernet interface 1/5 to VRF RemoteOfficeVRF:

switch(config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# vrf member RemoteOfficeVRF
switch(config-if)#
 

 
Related Commands

Command
Description

show vrf

Displays the VRF configuration information.